02:00:15 <kei> #startmeeting product_working_group
02:00:16 <openstack> Meeting started Tue Apr 19 02:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is kei. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
02:00:20 <openstack> The meeting name has been set to 'product_working_group'
02:00:30 <kei> Hi everyone.
02:00:33 <shamail> Hi kei
02:00:35 <fredli> hi
02:00:59 <kei> This is the second PWG regional meeting.  I'm the chair as hughhalf (Hugh Blemings) cannot make it today.
02:01:25 <leong> o/
02:01:27 <leong> hi
02:01:28 <kei> Who's here for the Product WG Regional Meeting?
02:01:32 <shamail> hi leong
02:01:41 <shamail> Here, good morning.
02:01:43 <leong> hi shamail, kei
02:01:59 <hidekazu> hi
02:02:00 <kei> Hi shamail, fredli, leong
02:02:11 <kei> Hi hidekazu
02:02:16 <hidekazu> hi kei
02:02:16 <fredli> hi kei
02:02:22 <leong> hi all :-)
02:02:24 <kei> You can find the agenda for today here:
02:02:54 <kei> #link https://wiki.openstack.org/wiki/Meetings/product-team#April_19th.2C_2016_.28UTC.29_Product_Team_Regional_Meeting_Agenda
02:03:46 <kei> I'd like to do Action Item Review first.
02:03:55 <leong> ok
02:04:04 <kei> #topic Action Item Review
02:04:25 <leong> i believe i have sent out the irc cheatsheet before :-)
02:04:28 <leong> here's the link again
02:04:34 <leong> #link IRC Cheat-sheet https://docs.google.com/document/d/1m--DFSwTPqKmxGNxP7ThDYuNr017wI_bUQOtqyaeyG0/edit
02:05:03 <kei> leong: Ah, thanks.  Have I already missed something?
02:05:27 <leong> kei.. you are good :)
02:05:36 <kei> leong: :)
02:05:58 <kei> From the last meeting, there were two action items.  I'll go through them really quickly.
02:06:18 <kei> The first one is "All to read the Product WG User Story Workflow https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow".
02:06:41 <kei> Hope everyone has done it.  If you haven't, please do so.
02:07:05 <fredli> yes, I have read it.
02:07:21 <shamail> Any questions on the workflow?
02:07:23 <kei> fredli: good.
02:07:27 <kei> any questions?
02:08:06 <hidekazu> I checked.
02:08:18 <fredli> I have one question: how will this flow ensure the projects PTL/Core to accept the requirements from the user stories?
02:09:24 <leong> that's the tricky part..
02:09:57 <kei> shamail: Are you looking at me?  Because I'm looking at you :)
02:10:09 <leong> note that the User Story doesn't "mandate" the PTL/core to "accept" the requirements... we still need to get resource to work on the spec and collaborate with the PTL/Core
02:10:16 <shamail> fredli: There is no mechanism to ensure it gets accepted but we are hopeful that by following the worflow, we will get people from the technical community to review and comment on the requirement.  The workflow is there to help us make the transition as smooth as possible but nothing is guaranteed.  We are hopeful that people helping us implement the user story at the project level are already a part of the project team
02:10:17 <shamail> (and that should help too)
02:10:25 <shamail> lol kei :)
02:11:05 <fredli> OK
02:11:12 <shamail> The goal of the workflow is to broadly advertise the requirement and get as much collaborative action as possible.  Both of these should hopefully help us when it comes time for the project to review the spec/blueprint
02:12:29 <leong> also if i remember correctly, in order for a User Story to progress into spec/impl, we need to get resource commitment from various company
02:12:30 <fredli> will TC(just a example) review our input and give priority advice to the projects?
02:13:10 <shamail> That is true leong, that is where the implementation team I was referring to would be formed
02:13:29 <shamail> fredli: I am not certain about the TC but the cross project team will review it based on the workflow
02:13:37 <shamail> all cross project specs today require TC review too
02:13:55 <kei> So it's not really about ensurance, but it's more like uniting force of people who has the same interests or requirements.
02:14:26 <fredli> ok, thanks. You replied my questions.
02:14:31 <shamail> This portion of the workflow (e..g who will review it, how much can the user story be concept vs implementation detail) is all going to be discussed at the summit since we definitely have open questions here.  We will be raising this question to the TC and Board at the next Board meeting.
02:15:06 <shamail> More information on cross project: http://docs.openstack.org/project-team-guide/cross-project.html
02:15:19 <shamail> kei: +1
02:15:46 <kei> And there would be some changes needed to the workflow because of Design Summit separation if I understand it correctly.
02:16:31 <shamail> Workflow *might* change but we will have more information by the PWG working session on Friday
02:16:55 <shamail> Anything to add leong?
02:17:01 <kei> shamail: OK.  Thank you.
02:17:03 <leong> i'm good :)
02:17:46 <fredli> thanks again, shaman ,key ,leong
02:17:51 <kei> If there's no other questions, I'll move to the next action item.
02:17:52 <fredli> kei, sorry
02:18:09 <kei> fredli: no problem :)
02:18:24 <kei> The next one is "kei and hughhalf to plan for next meeting".  I've done this.
02:18:36 <kei> OK.  Let's move to the next topic.
02:18:48 <kei> #topic Summary of Last Two PWG Meetings
02:18:49 <shintaro> hi
02:19:12 <kei> shintaro: hi
02:19:29 <kei> I'll try to summarise the last two PWG meetings.  We had them on 11th and 18th UTC.
02:20:10 <kei> First off, you can find meetings PWG members may want to join here:
02:20:23 <kei> #link https://etherpad.openstack.org/p/PWG_Austin_Working_Session_Planning
02:21:26 <kei> I'm not sure if everyone has already taken a look at it.  Does anyone have any questions about the planning?
02:22:18 <kei> My only question is the pages says Cross-Projec Session starts from 4:20pm, but the following link says 4:40pm.
02:22:28 <kei> https://www.openstack.org/summit/austin-2016/summit-schedule/events/9478
02:22:37 <kei> I just noticed that.
02:23:17 <leong> we should follow the event schedule
02:24:04 <kei> leong: OK.  I'll talk to Carol and fix it in the planning page.
02:24:07 <shamail> yes, the event schedule is the best source
02:24:21 <shamail> This is the second session though Kei
02:24:28 <shamail> I think it is accurate…
02:24:49 <shamail> https://wiki.openstack.org/wiki/Design_Summit/Newton/Etherpads#Cross-Project_workshops
02:25:35 <shamail> Seems like they changed the order between summit split and purpose of cross project specs
02:26:27 <shamail> I would assign an action item here kei (#action) and an owner to follow up on final times
02:26:41 <kei> shamail: Yes.  It looks like it.
02:27:07 <kei> #action kei to follow up on final times
02:27:28 <kei> thanks, shamail.
02:27:55 <kei> The latest status for TOP 5 user stories is like this:
02:28:09 <kei> Rolling Upgrade: Cross Project Spec Created, under review
02:28:24 <kei> #link https://github.com/openstack/openstack-user-stories/blob/master/user-stories/proposed/rolling-upgrades.rst
02:28:34 <kei> HA VM: Proposed with one +2
02:28:41 <kei> #link https://review.openstack.org/#/c/289469/
02:28:50 <kei> Bare metal: Proposed with no +2 yet
02:28:57 <kei> #link https://review.openstack.org/#/c/289627/
02:29:05 <kei> Capacity Management: Merged, no Cross Project Spec created yet
02:29:18 <kei> #link https://github.com/openstack/openstack-user-stories/blob/master/user-stories/proposed/capacity_management.rst
02:29:25 <kei> Fleet Management: Proposed with no +2 yet
02:29:41 <kei> #link https://review.openstack.org/#/c/299531/
02:29:58 <kei> I believe the ones in Proposed status need more reviews.
02:30:30 <shamail> For capacity management, we are looking for volunteers to share how they leverage quotas/capacity management today.  More information in this message: http://lists.openstack.org/pipermail/product-wg/2016-April/001081.html
02:30:40 <leong> we need core reviews for the above user stories
02:30:42 <shamail> Please let us know if anyone would be interested in helping.
02:31:14 <hidekazu> I will respond to review.
02:31:44 <shamail> I will go ahead and review 299531 and 289627 later this week.  I have alread reviewed 289469
02:31:55 <kei> leong: I haven't responded to your comments on bare metal spec.  Sorry, I'll do that.
02:32:07 <leong> no prob kei
02:33:39 <leong> we need more review on the baremetal..
02:33:57 <leong> i have contact a few ironic core to review the story
02:34:45 <kei> leong: thanks for doing that.
02:35:31 <kei> Speaking of review, some more reviews are asked for slide decks or agenda for Summit.
02:35:43 <kei> Joint TC/Board Slide:
02:35:52 <kei> #link https://docs.google.com/presentation/d/1zD3sc90WtcdCIwOsCPIrY1fsEvmk1wHmUTFmRE8mChc/edit#slide=id.p3
02:35:58 <kei> Content for Cross-Project Design Session:
02:36:05 <kei> #link https://wiki.openstack.org/wiki/Design_Summit/Newton/Etherpads#Cross-Project_workshops
02:36:12 <kei> Agenda review for Product WG working session:
02:36:18 <kei> #link https://etherpad.openstack.org/p/PWG_Austin_Working_Session_Planning
02:36:24 <kei> BOF session:
02:36:51 <kei> #link https://docs.google.com/presentation/d/1sv6ipcZ97mVBMRM70pLWK6c8mowXCQ8ntCSzTEkB4oc/edit#slide=id.p3
02:36:56 <kei> Community Roadmap:
02:36:59 <kei> #link https://drive.google.com/file/d/0B_yCSDGnhIbzTDZTN1lwT3A1M1E/view?pref=2&pli=1
02:37:03 <kei> Community Roadmap Session Content:
02:37:06 <kei> #link https://drive.google.com/open?id=1OVDC9-u4fVM_XcfskMiVVutfsUHQO_gyML12u7_Ljis
02:37:14 <kei> Themes update session review:
02:37:21 <kei> #link https://docs.google.com/presentation/d/1jAtkJVMYua7v9t0gaHJbwFMIvg-AuRLiDPzyX5f3YRg/edit#slide=id.g129bd00c3d_3_9
02:37:43 <kei> Hope I've covered everything and the combination of the title and link is correct.
02:37:59 <leong> I would encourage all to try your best to join the Product WG working session if you are in Austin
02:38:17 <fredli> sure, I will attend.
02:38:19 <kei> leong: That's the Friday one, right?
02:38:21 <fredli> wish to meet you there
02:38:26 <leong> yup
02:38:30 <leong> Friday
02:39:12 <kei> #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/8358
02:39:35 <kei> I'll be there.
02:40:51 <kei> shamail: leong: Are there anything else we should cover in terms of summarizing the last two PWG meetings?
02:41:37 <shamail> I think the recap is good.  We will be covering the community generated roadmap content at the roadmap sub-team meeting tomorrow
02:42:01 <leong> anyone interested to find out more can checkout the meeting summary here:
02:42:04 <shamail> It is at 4/19 1800 UTC so it might be too late for most people here but everyone is welcome to join if you want to help review/give feedback on the content
02:42:09 <kei> shamail: That's right.  Thanks for bringing it up.
02:42:14 <leong> #link 4/18 Main Meeting Summary: http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-04-18-21.03.html
02:42:40 <fredli> thanks kei
02:44:55 <kei> If there's no more questions / comments, I'll do meeting plans and then go to open topics.
02:45:05 <kei> #topic Upcoming Meeting Plan
02:45:31 <kei> Why don't we cancel 5/2 UTC as the main meeting just canceled 4/25 and 5/2?
02:45:50 <kei> And let's resume on 5/9 UTC.
02:46:30 <leong> sound good kei
02:46:38 <leong> 5/9 +1
02:46:41 <shamail> kei: +1
02:46:45 <hidekazu> +1
02:47:02 <kei> thanks
02:47:03 <kei> #agreed Regional meeting to cancel 5/2 and resume on 5/9 UTC
02:47:04 <leong> should be 5/10 Tuesday 0200 UTC
02:47:15 <kei> I did it again...
02:47:20 <leong> haha
02:47:28 <kei> #agreed Regional meeting to cancel 5/2 and resume on 5/10 UTC
02:48:23 <kei> #topic Opens
02:49:00 <kei> Any questions / comments / thoughts ?
02:49:01 <shintaro> There were an announcement in openstack-ops ML that telco-wg will be suspending its activity and moving to ProductWG for further discussion. Were there any discussion on that topic in PWG?
02:49:14 <shintaro> #link http://lists.openstack.org/pipermail/openstack-operators/2016-April/010169.html
02:49:48 <shamail> No shintaro, but we were aware that was going to happen.  We are starting to collaborate with OPNFV more to ensure there is still a place to discuss topics of interest to the telco/NFV market.
02:50:22 <shamail> Steve and Callum were already participating in PWG, so nothing changed excep the suspension of the telco WG meeting
02:50:25 <shamail> meetings*
02:50:48 <shintaro> shamil: ok thaks I will follow the PWG ML on this
02:50:54 <shamail> sounds great
02:54:05 <kei> There's an event "PWG" on 25th in my calendar, but there's no PWG related session, right?  Maybe, I just put it in the wrong spot.
02:55:11 <leong> don't think we have any PWG event on 25th Mon
02:55:39 <kei> leong: Thanks!
02:56:24 <kei> Seems that there's no more topics to discuss.  OK.  Nice chat with you all!
02:56:59 <shamail> Sounds good, see you next week
02:56:59 <hidekazu> thanks.
02:57:14 <shintaro> thank you
02:57:19 <kei> Looking forward to meeting you in F2F.
02:57:35 <leong> see u in Austin
02:57:47 <kei> leong: right!
02:58:00 <kei> #endmeeting