21:03:00 <shamail> #startmeeting product working group
21:03:00 <openstack> Meeting started Mon May  9 21:03:00 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:03 <openstack> The meeting name has been set to 'product_working_group'
21:03:12 <shamail> hi everyone!
21:03:15 <pchadwick> o/
21:03:17 <kencjohnston> o/ hi shamail
21:03:17 <shamail> Who is here for the PWG meeting?
21:03:19 <cloudrancher> o/
21:03:21 <MeganR> Hi!
21:03:23 <KrishR> o/
21:03:24 <carolbarrett> o/
21:03:31 <shamail> #chair carolbarrett
21:03:33 <openstack> Current chairs: carolbarrett shamail
21:03:43 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:03:47 <shamail> This is the agenda for today
21:03:52 <mkashyap> Hi
21:04:11 <shamail> #topic Review Summit activities
21:04:19 <shamail> #link https://etherpad.openstack.org/p/PWG_Working_Session_AUS
21:04:34 <shamail> We had a productive summit a couple of weeks ago
21:04:41 <shamail> You can find all the details in the linked etherpad
21:05:25 <shamail> We discussed potential themes for the roadmap, workflow changes based on design summit session, and shared the user story tracker for feedback as well
21:06:01 <shamail> For themes, we decided to add a few themes and I took the action item of revisiting our roadmap template to accomodate them
21:06:11 <shamail> I hope to have a preview for discussion by our next meeting
21:06:56 <shamail> We also discussed doing a new “Design Series” webinar with PTLs to discuss how their design summit sessions went
21:07:00 <KrishR> shamail: any initial thoughts on what those new themes could be?
21:07:32 <shamail> KrishR: We had discussed adding Security and User Experience… plus modifying manageability
21:07:46 <shamail> Essentially user experience would include UX and any new user facing APIs
21:07:59 <shamail> and manageability would be used for operator-related feature enhancements
21:08:01 <KrishR> shamail: thx
21:08:14 <shamail> you’re welcome
21:08:34 <shamail> I am trying to find the etherpad for the Newton Design Series
21:08:37 <KrishR> in OSIC, we're using the term Simplicity to capture all operator related issues with deployment and manageabilioty
21:09:16 <shamail> KrishR: Nice, similar concept here… We decided to have an operator-centric theme and a consumer (user)-centric theme
21:09:23 <shamail> In the past, both were bundled together
21:10:03 <shamail> #link https://etherpad.openstack.org/p/Newton_design_series_PTL_interview
21:10:11 <shamail> This is the etherpad we are using to schedule the PTL interviews
21:10:18 <pchadwick> Simplicity works for me.
21:10:27 <shamail> We have all the same projects listed that were included in the latest release of the roadmap
21:11:00 <Arkady_Kanevsky> hello
21:11:12 <kencjohnston> shamail - how do we signup to help perform these interviews?
21:11:16 <shamail> Heidi Joy and I were asking for additional volunteers to help with the interviews.  It would require minimal time commitment… essentially you would need to show up for the interview, conduct it, and then make a few slides summarizing the answers to the various questions
21:11:22 <pchadwick> I can help
21:11:34 <shamail> kencjohnston: Please add your name to the top in the “webinars hosted by” section
21:11:46 <kencjohnston> shamail ok done.
21:11:47 <shamail> You’re already on the volunteer list pchadwick
21:11:51 <shamail> Thx kencjohnston
21:11:55 <pchadwick> Also, do we need to update the themes to reflect what we just talked about.
21:12:10 <shamail> I think Heidi Joy will send another email to the PTLs since we only have 5 signed up so far
21:12:17 <pchadwick> shamail: thanks - I hadn't read that far
21:12:52 <shamail> pchadwick: Great point.  I think we should… The themes in the design series are verbal… we will have to include a brief description at the bottom (line 70 in etherpad)
21:13:33 <shamail> Once we get more PTLs signed up, Heidi Joy will most likely send out calendar invites
21:13:49 <shamail> If you have a preference based on your schedule.. please add your name next to the PTL’s
21:13:53 <Arkady_Kanevsky> what is the goal for these interviews?
21:14:05 <Arkady_Kanevsky> roadmap update for each project?
21:14:16 <carolbarrett> If we use the updated themes, does that mean we should also create an updated roadmap with those themes?
21:14:37 <shamail> Arkady_Kanevsky: The goal is to create a video (5-10 min long) that gives a good overview of the project and what they are working on
21:14:43 <shamail> Here is a past interview for reference: https://www.youtube.com/watch?v=iJr7fDr8rnc
21:14:50 <Arkady_Kanevsky> thanks
21:14:52 <shamail> These videos also get linked to the project in the project navigator
21:15:05 <Arkady_Kanevsky> excellent on navigator link
21:15:24 <shamail> carolbarrett: I believe so… We do two refreshes of the roadmap and this data would be used for the post-summit refresh
21:15:33 <shamail> I did update it last time with the interview data
21:15:41 <carolbarrett> shamail: sounds good
21:16:08 <shamail> i’ll share a new view for the roadmap next week and if we think it is reasonable then we can use it for the next refresh which will include the new themes
21:16:10 <Arkady_Kanevsky> do we reach out to PTL to sign them for a timeslot? or Heidi is doing it?
21:16:35 <shamail> #action shamail to share a roadmap view concept that can incorporate more themes by 5/16
21:16:45 <Arkady_Kanevsky> shall we agree on themes ofr Newton?
21:16:53 <shamail> Arkady_Kanevsky: The PTLs are self-registering for slots… we sent them an email asking them to sign up
21:17:25 <Arkady_Kanevsky> Ok. In that case I will wait for a couple I am CPL for to sign in then I will add my name to the time slot
21:17:26 <shamail> In the product WG working session we agreed that the themes would stay the same with the addition of two new ones (Security and User Experience)
21:17:41 <Arkady_Kanevsky> +1 on new themese
21:17:41 <shamail> I will summarize the new themes in the roadmap view, we can discuss them next week during the review
21:18:10 <shamail> The other major topic was our workflow
21:18:29 <shamail> #link https://wiki.openstack.org/wiki/ProductTeam/User_Stories
21:18:44 <shamail> I have updated the wiki page to reflect our conversation during the working session on updates
21:19:29 <Arkady_Kanevsky> 'should new project come from Cross Project Spec?
21:19:34 <shamail> the main update is that gaps analysis has been moved to its original location (before a cross project spec) and we will leverage CPSLs to determine the best course of action before submitting a cross project spec
21:19:54 <Arkady_Kanevsky> That is how we know that no projects wants to touch some of its part that require new project.
21:19:57 <shamail> Arkady_Kanevsky: No, it doesn’t have to.  We are not modifying any established workflows and to create a new project today doesn’t require a cross project spec
21:20:28 <shamail> The gaps/overlap analysis meeting will help us determine whether a cross project spec is needed or whether we can proceed with project level artifacts
21:20:46 <shamail> If we find the new concept is out of scope for the project then we might need to create a new project
21:21:36 <shamail> This step of interlocking with CPSLs will help us ensure that we proceed with the best path based on the project teams preferences
21:21:42 <shamail> Any questions on the workflow changes?
21:22:20 <shamail> The next topic we discussed was the cross-project/user story dashboard
21:22:27 <Arkady_Kanevsky> do we document tools to help user story owner to track progress?
21:22:43 <shamail> Arkady_Kanevsky: can you please give an example?
21:23:27 <Arkady_Kanevsky> upgrade requires work on each project so spec is create for each.
21:23:47 <shamail> Ah, that information would be contained in the user story tracker
21:24:02 <Arkady_Kanevsky> But uuser story tracker box left to story owner to track them all.
21:24:26 <rockyg> o/
21:24:40 <shamail> We do have documentation on it but it needs to be updated.
21:24:46 <shamail> Hi rockyg
21:24:57 <shamail> Arkady_Kanevsky: Yes, but most user story owners will only be tracking 1-2 stories
21:24:59 <rockyg> hey.  Sorry I'm late
21:25:13 <shamail> We have a different owner per story so the burden shouldn’t be overwhelming (hopefully)
21:25:18 <Arkady_Kanevsky> just want to have a pointer fomr this doc to the doc where we define how to track it
21:25:28 <shamail> plus the PWG CPLs will help them get updates from a project perspective
21:25:42 <shamail> makes sense
21:26:00 <shamail> #action Update user story workflow wiki page to link to user story tracker overview
21:26:05 <shamail> Thanks
21:26:16 <Arkady_Kanevsky> only if CPL is specifically tracking every spec & blueprint created for user stories we created.
21:26:20 <shamail> The next topic we discussed was the cross-project/user story dashboard
21:26:29 <shamail> #link http://104.239.130.200:9000/projectList
21:26:33 <Arkady_Kanevsky> So far PTL onbly mention major blueprints.
21:27:21 <shamail> We demonstrated this tool at the summit and the the community saw value in the concept but had concerns over whether we were creating a new tool for something that could be addressed by storyboard or phabricator
21:27:51 <rockyg> neither of which are yet in general use....
21:28:09 <shamail> This tool was created as a prototype to demonstrate the concept and we don’t have to necessarily keep this application if one of the other tools will suffice
21:28:26 <Arkady_Kanevsky> do we have pointers to all these tools? and are oyu going to do comparison?
21:28:34 <shamail> correct rockyg, but there are already plans by infra to use them so we were asked to see if they could be used for our requirements as well
21:28:46 <rockyg> If we could get storyboard to adopt this interface, I'd say let's go with storyboard.
21:29:16 <shamail> We do need to do a comparison… The main goal would be to see if the other tools could be populated with the necessary information and relationships to provide a similar tracking dashboard
21:29:38 <Arkady_Kanevsky> +1
21:29:49 <shamail> Any volunteers?  I volunteered at the summit but would be definitely appreciate help
21:30:00 <shamail> would definitely*
21:30:23 <Arkady_Kanevsky> can we schedule for these tools owners to do demo for us?
21:30:24 <rockyg> I think we should invite Zara, the current dev on storyboard, to join us in a discussion/show and tell, etc. session
21:30:38 <shamail> There was a design summit session that I couldn’t attend that covered task tracking as well (https://etherpad.openstack.org/p/newton-infra-community-task-tracking)
21:30:50 <rockyg> phabricator is an opensource package that Monty is most familiar with
21:31:04 <shamail> rockyg: +1, Carol and I met with Zara and Adam at the summit.
21:31:41 <shamail> Infra currently plans to use the UX and ticketing modules from Phabricator
21:32:00 <shamail> no one has reviewed its issue tracking capabilities… I got a sandbox URL so we could play around with it
21:32:02 <carolbarrett> I wonder if we can pull together Monty, Zara and Adam to collaborate on the analysis?
21:32:28 <rockyg> great idea, carolbarrett
21:32:50 <shamail> carolbarrett: I think that is a good group to validate our findings with… I think Zara and Adam would be great to collaborate with on the story board side…. I am not certain if Monty has used the issue tracking modules in Phabricator but I can find out.
21:33:37 <shamail> Any volunteers to help with this analysis?
21:33:43 <carolbarrett> Thanks Shamail - we're going to need help from experts to complete this.
21:33:48 <shamail> carolbarrett: +1
21:33:56 <carolbarrett> I'll partner with you on this
21:34:00 <shamail> thanks!
21:34:01 <rockyg> I have a great understanding of but tracking/issue tracking systems.  Which is why I think LP sucks for it, but can look and see pluses, minuses and could use help in dtermining how it interfaces with tasks, etc
21:34:25 <shamail> #action carolbarrett and shamail to develop analysis plan for user story tracking requirements and enlist help
21:35:18 <shamail> The big thing for us rockyg, I think, is the need to be able to build a hierarchical view of non-related artifacts
21:35:56 <shamail> Alright, i’ll move on to the next topic
21:36:32 <shamail> pchadwick had suggested setting up a meeting between the roadmap sub-team and the OpenStack foundation to discuss themes
21:36:43 <shamail> HeidiJoy: Hi!  Any thoughts on this item?
21:36:56 <shamail> OpenStack Foundation *marketing team
21:37:04 * rockyg thinks shamail's summary is concise, accurate and spot on for the major requierement.
21:37:26 <shamail> thanks rockyg
21:37:36 <pchadwick> At a minimum I would like to review the themes with the marketing team for input.
21:37:46 <shamail> We can revisit the sync between marketing and the roadmap team
21:37:50 <rockyg> #topic for agenda?
21:37:56 <shamail> pchadwick: +1, I think it was a great suggestion
21:37:56 <Arkady_Kanevsky> +1 on pete. We need to be in sync on themes Product WG and foundation are using/driving
21:38:41 <shamail> rockyg: All of these items were covered under the “summit review” topic… in hindsight, could’ve been broken up further.  My fault. :)
21:38:56 <Arkady_Kanevsky> np.
21:38:57 <shamail> #topic Updates from user story owners
21:39:06 <Arkady_Kanevsky> do we have buy in from foundation on it?
21:39:19 <shamail> Any user story owners have updates from activiities at the summit?
21:39:29 <shamail> we do Arkady_Kanevsky
21:39:40 <HeidiJoy> Shamail - apologies, I keep getting pulled away.
21:39:50 <shamail> np HeidiJoy
21:39:53 <pchadwick> Workflow HA - we had a meeting to discuss the user story and also potential solutions.
21:40:11 <pchadwick> /Workflow/Workload/
21:40:22 <shamail> pchadwick: Did the existing cross-project HA team see the user story as proposed?
21:40:27 <pchadwick> Yes
21:40:29 <shamail> nice
21:40:46 <pchadwick> Adam Spiers on our team is pushing this along with Intel and NTT
21:40:58 <shamail> Any resulting next steps or projected updates to the story?
21:41:03 <Arkady_Kanevsky> on refstack - we discussed it on devcore and refstack. They will refiew it formally. WIll update based on their feedback. they ask to chnage ttitle to better reflect the goal
21:41:32 <pchadwick> I'll check with Adam next week - (we have our sales kickoff this week)
21:41:35 <shamail> Arkady_Kanevsky: +1, thanks.
21:41:40 <shamail> np pchadwick, thanks for the update
21:41:54 <KrishR> we had a good Fleet Mgmt meeting - see https://etherpad.openstack.org/p/Fleet_Management
21:42:11 <shamail> #link https://etherpad.openstack.org/p/Fleet_Management
21:42:18 <Arkady_Kanevsky> Team, can we choose a story per week and go thru reviews so we can merge it at the end of the week? We have stories lingering for a while now...
21:42:40 <shamail> Awesome KrishR
21:42:48 <Arkady_Kanevsky> concentrated effort.
21:42:52 <shamail> I see the next steps in the etherpad.  Any changes required to the user story based on the meeting?
21:43:26 <shamail> Good suggestion Arkady_Kanevsky, let’s discuss further in the next topic (opens)
21:44:12 <Arkady_Kanevsky> given the effort on Fleet Management - let's concentrate on it for a week.
21:44:26 <shamail> For capacity management, I met with the cross-project quotas team working on DELIMITER.
21:44:42 <Arkady_Kanevsky> Ken will have to do frequent updates based on feedback.
21:44:46 <KrishR> Kenny and I willr evise the user story after the next meeting with collaborators - thinking is first rev of Fleet Mgmt will implement a subset
21:44:53 <Arkady_Kanevsky> what is DELIMITER?
21:44:56 <shamail> thanks KrishR
21:45:15 <shamail> Arkady_Kanevsky: It is the new library being built to support quotas in OpenStack, specifically started with nested quotas as the first objective
21:45:19 <shamail> #link http://openstack-in-production.blogspot.fr/2016/04/resource-management-at-cern.html
21:45:25 <Arkady_Kanevsky> +1 Krish
21:45:46 <shamail> Tim Bell sent us an email with his use-cases based on the call for white papers we sent out to the PWG mailing list
21:46:03 <shamail> He turned it into a wiki post since Scientific WG has “accounting” as one of their top 4 priorities
21:46:18 <shamail> I will be updating the capacity management user story based on Tim’s feedback by next week
21:46:44 <shamail> kencjohnston: any updates on feature classification or standard config options?
21:47:15 <Arkady_Kanevsky> I will update refstack story this week based on feedback
21:47:24 <shamail> Thanks Arkady_Kanevsky
21:47:39 <shamail> alright, we can move on to the last topic :)
21:47:41 <shamail> #topic Open
21:48:11 <pchadwick> HeidiJoy: Did you get a chameleon?
21:48:28 <HeidiJoy> Sad trombone - no. :-)
21:48:40 <pchadwick> hmm - will have to rectify that.
21:48:42 <shamail> lol
21:49:00 <HeidiJoy> <3
21:49:31 <shamail> Arkady_Kanevsky suggested putting a focus on one user story per week to foster discussions, reviews, etc. so we can close out concept validation phase on a few of the open ones.  Thoughts?
21:49:45 <rockyg> Sounds great.
21:49:50 <shamail> I like the concept too
21:49:52 <KrishR> +1
21:49:54 <mkashyap> +1
21:49:56 <MeganR> +1
21:50:03 <pchadwick> +1
21:50:08 <Arkady_Kanevsky> shmail - pick a story
21:50:22 <carolbarrett> +1
21:50:22 <shamail> #agree Add one user story to the agenda each week to make progress on concept validation
21:50:38 <shamail> Arkady_Kanevsky: I won’t pick one but I will quickly say NOT IT
21:50:42 <shamail> (for capacity management)
21:50:47 <rockyg> And post the agenda with story link at least one day before the meeting...
21:50:50 <shamail> :-) We aren’t there yet with that one
21:51:00 <shamail> Good idea rockyg
21:51:07 <Arkady_Kanevsky> +1
21:51:23 <carolbarrett> +1
21:51:29 <shamail> carolbarrett: how do you recommend we do this?  schedule or should any user story owner should just update the agenda when they are ready?
21:52:09 <rockyg> Last to post "NOT IT" has to present?
21:52:21 <pchadwick> not it
21:52:26 <MeganR> lol - excellent idea!
21:52:33 <Arkady_Kanevsky> any user owner who can dedicate time thru out the week should push his story into the bucket.
21:52:52 <carolbarrett> How about we use the priorities we established to guide?
21:52:54 <Arkady_Kanevsky> Leave it to Carol and/or Shamail to pull rabbit out of the bucket
21:53:03 <shamail> Arkady_Kanevsky: would you mind sending an email to the ML with this agreement and we can see if anyone volunteers?
21:53:08 <shamail> Not all story owners are here today
21:53:11 <Arkady_Kanevsky> +1 on priorities among ready stories
21:53:19 <KrishR> kencjohnston: can we say we'll be ready week after next?
21:53:29 <Arkady_Kanevsky> correct. we will start next week.
21:54:43 <shamail> Awesome
21:54:44 <Arkady_Kanevsky> we have 14 stories in pipeline...
21:54:45 <shamail> Alright
21:54:58 <shamail> We’ll go ahead and call this a meeting.
21:55:04 <shamail> Thanks everyone!
21:55:06 <carolbarrett> Thanks Shamail!
21:55:08 <Arkady_Kanevsky> bye you all
21:55:10 <shamail> #endmeeting