02:02:11 <hughhalf> #startmeeting Product Working Group
02:02:12 <openstack> Meeting started Tue May 17 02:02:11 2016 UTC and is due to finish in 60 minutes.  The chair is hughhalf. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
02:02:15 <openstack> The meeting name has been set to 'product_working_group'
02:02:18 * hughhalf is new to this
02:02:24 <hughhalf> #topic Roll Call
02:02:25 <shintaro> hi /
02:02:31 <samP> hi/
02:02:32 <leong> hi again :)
02:02:36 <hughhalf> o/
02:02:36 <fredli> hi all
02:02:40 <shintaro> hi/
02:03:00 <hughhalf> any other takers for the roll call ?
02:03:01 <kei> o/
02:03:22 * hughhalf notes with thanks kei and leong for assiting in pulling the meeting together :)
02:03:37 <leong> no problem!
02:03:47 <kei> no problem at all.
02:03:48 <hughhalf> I don't see any other roll call-ees so lets go to the next topic in the agenda - Summit Recap
02:04:00 <hughhalf> #topic Summit Recap
02:04:21 <hughhalf> leong and kei please interject if I miss things :)
02:04:25 <hughhalf> (or anyone else)
02:04:32 <leong> sure!
02:04:46 <kei> sure thing.
02:05:05 <hughhalf> For the Summit Recap - I'll put in a little note for a post I did that summaries all the different Project summaries that went to the list; http://hugh.blemings.id.au/2016/05/17/openstack-summit-austin-2016-summary-of-summaries/
02:05:45 <hughhalf> I'd welcome other Summit Recap style things though please if folk have them
02:06:22 <leong> anyone has any feedback/comments from the summit?
02:06:41 <hughhalf> Were many people that are here today at the Summit ?
02:07:00 <leong> i am
02:07:26 <fredli> I was at summit.
02:07:34 <kei> hughhalf: that's a nice page.
02:07:42 <shintaro> i was but could not attend PWG sessions
02:07:51 <kei> i was there.
02:07:59 * hughhalf thanks kei
02:08:38 <hughhalf> fredli, shintaro, did you find the summit useful ?
02:09:13 <kei> #link https://etherpad.openstack.org/p/PWG_Working_Session_AUS
02:09:16 <shintaro> hughhalf: yes as always!
02:09:27 <leong> please note there is a updated workflow after reviewing with the TC/Board
02:09:31 <hughhalf> shintaro, excellent!
02:09:37 <leong> #link Revised workflow https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
02:09:43 <fredli> hughhalf: yes. face to face is always good.
02:09:58 <hughhalf> yes, hard to beat IRL discussions to be sure :)
02:10:29 <hughhalf> My sense is that there's not a lot of Summit Recap to discuss, shall we move on to the Workflow Revision as that was next on the agenda ?  Leong would you like to lead this ?
02:10:36 <leong> ok
02:11:02 <leong> #topic Workflow Revision
02:11:18 <hughhalf> thanks
02:11:20 <leong> hughhalf can use set the next topic
02:11:29 <hughhalf> #topic Workflow Revision
02:11:39 <leong> thanks
02:11:46 <hughhalf> np
02:11:48 <leong> there is a revised workflow
02:11:54 <leong> #link Revised workflow https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
02:12:05 <leong> please have a look and let us know if you have any questions
02:12:46 <hughhalf> Looks reasonable to me
02:12:51 <leong> the revised workflow takes into consideration the feedback from TC/board
02:13:18 <fredli> the action "gap and overlap analysis" is new, cool
02:14:20 <leong> yup.. so a user story potentially can lead into a new project depending on the analysis outcome
02:14:29 <hughhalf> it's a good model I think
02:14:30 <shintaro> What is Implementation Plan?
02:14:30 <fredli> so it will be important to attend cross project meeting
02:14:35 <leong> instead of just cross-project spec in the past
02:15:12 <leong> the implementation plan will lead into 3 potential path
02:15:50 <leong> we shall update the wiki page to elaborate what an implementation plan is
02:16:02 <leong> hughhalf, please put that action item to me
02:16:25 <kei> leong: So does this mean that PWG will also treat non cross project user stories?
02:16:26 <shintaro> so the implementation plan is some kind of documentation to decide which path the use case should take?
02:16:28 <leong> #action leong to work with shamail to update the wiki to elaborate what an implementation plan is
02:16:29 <hughhalf> #action leong to update the Wiki Page to explain the implementation plan
02:16:47 <leong> kei, potentially yes!
02:17:08 <kei> leong: that's nice.  thanks.
02:17:30 <leong> so in this morning "us-region" product wg meeting, Product WG will collaborate with the OPNFV community for user stories
02:17:51 <hughhalf> #topic User Story review/merge/discuss
02:18:24 <hughhalf> Yes that scrollback is probably worth reviewing if people have it - http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-05-16-21.01.log.html
02:18:59 <leong> some action item from "us-region" meeting:
02:19:10 <leong> #link action item from us-region meeting: http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-05-16-21.01.html
02:19:26 <hughhalf> Thanks leong good call
02:19:42 <leong> next week the team will review the status of the top 5 user story
02:20:02 <hughhalf> I think they are reviewing in a phone call then minuting in an etherpad
02:20:27 <leong> two of the user-stories 'ha vm' and 'baremetal' are mainly driven from this team here from apac region
02:20:54 <leong> yes... the review will be done over phone
02:20:54 <hughhalf> are the right people in the loop to participate in that discussion do you think leong ?
02:21:11 <leong> i will definitely be in the call
02:21:23 <hughhalf> excellent
02:21:29 <leong> would anyone from NTT be able to attend?
02:21:40 <leong> especially for the ha_vm user story
02:21:43 <samP> me shintaro and kazu
02:21:59 <leong> the ha_vm user story is coordinated by Pete (suse)
02:22:06 <shintaro> what time?
02:22:18 <leong> US pacific at 2pm
02:22:45 * hughhalf nods
02:22:53 <leong> is that 6am in Tokyo with current timezone/dst
02:23:08 <leong> kei was in the call this morning, is that 6am?
02:23:19 <kei> leong: yes.  it is.
02:23:20 <hughhalf> Yes, I believe it's 0600h
02:23:33 <samP> leong: where can I find the details of this meeting?
02:23:42 * hughhalf buys the .jp folk a virtual espresso for that session
02:23:49 <leong> http://eavesdrop.openstack.org/meetings/product_working_group/2016/product_working_group.2016-05-16-21.01.html
02:23:55 <shintaro> leong: thanks that may work
02:24:23 <shintaro> with some espresso!
02:24:25 <leong> talking about the ha_vm , is there any discussion with mistral?
02:25:01 <samP> leong: we had some discussion with mistral team.
02:25:41 <samP> https://etherpad.openstack.org/p/newton-instance-ha
02:26:05 <kei> hughhalf: my virtual espresso (my one year old son) woke up at 6am today and kept me awake by keeping talking to me...
02:26:14 <hughhalf> #link https://etherpad.openstack.org/p/newton-instance-ha
02:26:24 <hughhalf> heh, that's the best kind of espresso kei :)
02:26:29 <leong> that's good, the objective of next week call for each user story is to update the status and see what help is required to move forward.
02:26:30 <samP> Here is the summit discussion of HA-Team. There are work items for mistral
02:26:31 <shintaro> hughhalf: :)
02:26:45 <kei> hughhalf: :)
02:26:46 * hughhalf nods at leong
02:27:01 <samP> But how to proceed is still under discussion.
02:27:19 <kazuIchikawa> The discussion in the summit clarified us some requirements, so I believe I have to revisit the user story of HA VMs to make sure all factors are covered.
02:27:27 <hughhalf> it's good the converesation is being had samP - hopefully lessens duplication
02:28:36 <kazuIchikawa> I and SamP are working on that.
02:28:37 <leong> kazuIchikawa, it will be great if you could update the ha vm user story prior to next week call...
02:28:54 <kazuIchikawa> leong: got it!
02:30:08 <leong> cool!
02:30:22 <leong> for the baremetal.. are we good with the user story?
02:30:54 <hughhalf> leong yes it looks reasonable to me
02:31:05 <kei> leong: I believe there's no outstanding comments now.
02:31:18 <leong> ok..
02:31:32 <leong> the scientific-wg also has interested in ironic/baremetal
02:31:43 <leong> but they are more coming from academic/hpc perspective
02:31:58 <leong> so they might brought up a different related user story in baremetal
02:32:12 <leong> the user story that we are driving here is more from the enterprise workload perspective
02:32:42 <leong> the scientific-wg just inaugural in austin and the first meeting is tomorrow on irc channel
02:33:34 <hughhalf> sounds good leong - HPC is always good to have in the mix I think for these conversations, particularly as there are more people interested in OpenStack for these applications
02:34:12 <kei> leong: thanks for the information.  at the summit, i mentioned i may add one more feature to the baremetal user story, which is nmi injection and graceful shutdown for enterprise.
02:34:51 <leong> ok kei, it will be great if you could include that prior to next week call
02:34:57 <kei> leong: since it can be considered as a single project thing, i haven't added it to the user story yet.  but with the new work flow, i think i'll add it.
02:35:29 <leong> i think it is fine to include in this user story as this is generally from a "user" perspective
02:35:44 <kei> leong: ok.  i will do that.
02:35:53 <leong> later on in the workflow, the "analysis" stage might lead into a different implementation path
02:35:54 * hughhalf nods
02:36:16 <kei> leong: that's right.
02:37:11 <leong> that's all i need to discuss for these two user stories
02:37:39 <hughhalf> thanks leong
02:37:40 <kei> thanks, leong.
02:37:51 <hughhalf> anythign else on user stories that people would like to contribute ?
02:38:14 * hughhalf waits another moment
02:38:32 <hughhalf> I propose we move on to Open Discussion next then, if there is any
02:38:58 <hughhalf> #topic open discussion
02:39:21 <hughhalf> I'd welcome any open topics from ya'll (pretending to be Texan there :)
02:39:57 <kei> hughhalf: :)  in the main meeting today, they've decided three focus areas for newton cycle.
02:40:25 <kei> 1) validating the updated work flow
02:40:27 <hughhalf> Gah, I must have missed that kei, do you recall what they were ?
02:40:47 <kei> 2) Evolving roadmap themes and corresponding views
02:40:59 <kei> 3) integration with OPNFV, with a plan to follow that with a Container Community
02:41:14 <leong> bingo kei +1
02:41:29 <kei> if anyone in this meeting wants to add/change/remove, now is the time i guess :)
02:42:00 <shintaro> looks good but OPNFV use case would be broad
02:42:29 <shintaro> may need a lot of work to prioritize them
02:42:46 * leong agree with shintaro
02:43:45 <hughhalf> I think there was some discussion to that effect - that OPNFV would be complex to consider
02:43:55 <hughhalf> I guess we can flag that in the meeting
02:44:22 <samP> BTW, we gonna have a VoIP meeting in HA-Team tomorrorw (5/18) 9 UTC. Pls find more details at ML [openstack-dev][HA]
02:44:35 <hughhalf> thanks samP
02:44:51 <hughhalf> any other matters we should discuss in open discussion ?
02:45:03 * hughhalf hopes he's not pushing the meeting too fast
02:45:07 <leong> basically trying to integrate the flow of user stories from OPNFV community into OpenStack
02:45:55 <leong> samP will be great if you could update that into the user-stories if there is any changes
02:47:12 <leong> i think we are good today...
02:47:27 <hughhalf> Anything further folks before we close the meeting ?
02:47:47 <leong> please try to join the voice call meeting next week.. though is 6am in Japan :-)
02:47:58 <samP> Thank you all
02:48:00 <hughhalf> I again thank leong and kei for organising things, and to all that participated in the conversations today!
02:48:07 <leong> our next regional meeting shall be two weeks later
02:48:12 <hughhalf> Have a great week everyone, until next time! :)
02:48:15 * hughhalf nods at leong
02:48:18 <leong> thanks all!
02:48:29 <kei> thanks!
02:48:30 * leong give all a thumbs up!
02:48:46 <hughhalf> All done, thanks folks, I will close the meeting now
02:49:06 <hughhalf> #endmeeting