21:00:21 <carolbarrett> #startmeeting product_working_group
21:00:22 <openstack> Meeting started Mon Jun  6 21:00:21 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:25 <openstack> The meeting name has been set to 'product_working_group'
21:00:38 <carolbarrett> Hi Folks - It's time for the Product Working Group meeting
21:00:47 <carolbarrett> The agenda can be found here
21:00:50 <rockyg> o/
21:00:53 <carolbarrett> #Link https://wiki.openstack.org/wiki/Meetings/product-team
21:01:01 <carolbarrett> Hi Rockyg
21:01:09 <carolbarrett> Let's start with roll call
21:01:10 <qwebirc80186> Hi Carrol, Soyeh McCarthy here.... What bridge number?
21:01:13 <cloudrancher> o/
21:01:23 <shamail> hi everyone
21:01:48 <shamail> qwebirc80186: this meeting is IRC only so there is not a bridge.
21:01:54 <MeganR> o/
21:02:06 <carolbarrett> Hi Soyeh - No bridge today, we had one last week for the user story review, but usually we use IRC
21:02:10 <carolbarrett> hi Shamail
21:02:10 <qwebirc80186> ok, thanks
21:02:17 <kencjohnston> o/
21:02:20 <KrishR> o/
21:02:26 <carolbarrett> great - let's get going
21:02:33 <carolbarrett> #topic Midcycle Planning
21:02:33 <kencjohnston> hi team, fyi I've got to drop in about 15 minutes
21:02:41 <rockyg> boy, 80186 takes me back....Worked on a system that used that processor
21:02:55 <Arkady_Kanevsky> hello team
21:03:18 <carolbarrett> kencjohnston: thanks for the heads-up. Do you have any opens that you want to share or comments on the other agenda items?
21:03:40 <carolbarrett> #link:  https://etherpad.openstack.org/p/PWG_Newton_Midcycle_Planning
21:03:45 <Arkady_Kanevsky> are we also on the phone bridge today?
21:03:54 <carolbarrett> That's the link for the mid cycle planning etherpad
21:04:11 <kei_> o/
21:04:11 <carolbarrett> Arkdady_kanevsky: no bridge today
21:04:17 <carolbarrett> hi Kei
21:04:24 <Arkady_Kanevsky> thanks Carol
21:04:26 <kei_> hi carolbarrett!
21:04:32 <kencjohnston> carolbarrett nope
21:04:54 <carolbarrett> Thanks kencjohnston
21:04:55 <shamail> carolbarrett: I thought NYC and Seattle were in the running for ops-midcycle… Is PDX as well?
21:05:00 <carolbarrett> On the midcycle - does anyone have an update on the Ops Midcycle?
21:05:33 <carolbarrett> shamail: No one has reached out to me about PDX/Intel hosting. Though they may have other plans
21:05:43 <rockyg> They're thinking mid august, either Seattle or NYC
21:05:47 <shamail> I saw PDX in the etherpad thats why I asked
21:05:58 <carolbarrett> rockyg: Thanks. Any idea when they will finalize?
21:05:59 <shamail> I was aware of the same as rockyg, NYC or SEA
21:06:30 <carolbarrett> While the date and location are still be worked, we can spend our time on planning the agenda for our midcycle
21:06:40 <leong> hi folks
21:06:41 <rockyg> They're talking to the companies about the sites this week.  So possible this week, but more likely next week.
21:06:46 <carolbarrett> Hi Leong
21:06:48 <shamail> carolbarrett: +1
21:06:57 <carolbarrett> Thanks Rocky.
21:07:14 <Arkady_Kanevsky> +1 on planning
21:07:24 <carolbarrett> Can folks go to the planning etherpad and spend 10 mins now adding your proposals for the agenda?
21:07:26 <Arkady_Kanevsky> The currebt 5 user stories are for Newton
21:07:49 <Arkady_Kanevsky> What about starting to plan usre stories for Ocata at mid-cyclke
21:09:55 <rockyg> crickets
21:09:57 <leong> might be worthwhile to review the process of user story workflow/gap-analysis/implementation
21:10:15 <leong> review if we missed out anything or any rooms for improvement
21:10:38 <carolbarrett> As topics get added to the etherpad pls indicate your top 3-4 priorities with +1. If you think a topic is not a good use of time, pls put a -1 by it
21:11:11 <carolbarrett> leong +1: Can you pls add this to the etherpad?
21:11:19 <leong> just added
21:11:28 <carolbarrett> Arkady_Kanesvky: Can you add that to the planning etherpad?
21:12:02 <rockyg> Love to discuss success/failure so far in current active user stories.
21:12:03 <Arkady_Kanevsky> I already did
21:12:21 <carolbarrett> arkady_kanevsky: Thanks
21:12:29 <carolbarrett> rockyg: good
21:12:50 <carolbarrett> rockyg: can you add that to the etherpad?
21:13:02 <rockyg> working on that...
21:13:27 <carolbarrett> rockyg: thanks
21:14:30 <carolbarrett> We haven't discussed length of the midcycle - what do you all think? 1 day? 2 days?
21:14:54 <Arkady_Kanevsky> can we move all user story related topics together on etherpad?
21:15:16 <MeganR> 2 days has been really beneficial in the past
21:15:17 <carolbarrett> Arkady_Kanevsky: Sure, go ahead and group them. Thanks
21:15:24 <shamail> I vote 2 as well
21:15:26 <kencjohnston> carolbarrett MeganR +1 on 2 days
21:15:51 <Arkady_Kanevsky> done
21:15:52 * kencjohnston quietly slips out the side door
21:15:56 <shamail> cya kencjohnston
21:16:02 <carolbarrett> bye kencjohnston
21:16:09 <carolbarrett> thanks Arkday_kanevsky
21:16:20 <rockyg> +1 on 2
21:16:24 <carolbarrett> OK - Let's plan on 2 days
21:16:42 <carolbarrett> #agree Newton Midcycle will be 2 days
21:17:11 <leong> 2 days
21:17:18 <carolbarrett> Thanks for the additions to the agenda - over the next week, pls look over the etherpad and add your +1s, -1s and other topics
21:17:48 <carolbarrett> Seems like there's a couple of Topics on Roadmap that we can group together too
21:17:50 <shamail> wil ldo
21:18:02 <Arkady_Kanevsky> we will need to put some time duration per topic to see what we can fit in 2 days. Then we can vote both on topic and duration.
21:18:24 <Arkady_Kanevsky> If we can fit them all then +1 for all and we only need to prioritize agenda
21:18:52 <carolbarrett> arkady_kanevsky: good point. Let's tackle that next week, once folks have had a chance to look it over.
21:19:05 <carolbarrett> Let's move to the next topic
21:19:15 <carolbarrett> #topic Identify Pilot for Workflow
21:19:53 <carolbarrett> In our review of the user stories last week, we didn't get time to talk about which, if any, would be good for a pilot for the workflow we developed out of the Austin discussion.
21:20:19 <Arkady_Kanevsky> looking at current 5 top stories
21:20:37 <Arkady_Kanevsky> upgrade has been going ofr a long while - not a good candidate
21:20:40 <carolbarrett> Shamail - Do you have thoughts on this to share?
21:20:55 <carolbarrett> Arkady_Kanevsky: agree
21:20:57 <shamail> I like fleet management but it might be too big for plit
21:20:59 <shamail> pilot*
21:21:19 <Arkady_Kanevsky> shamail agree with you.
21:21:27 <shamail> I think bare metal might be a good one
21:21:31 <rockyg> Agree with shamail  about fleet mgmt
21:21:38 <shamail> bare metal or HA VM imo
21:21:38 <carolbarrett> Link to workflow
21:21:40 <carolbarrett> #link: https://wiki.openstack.org/wiki/ProductTeam/User_Stories
21:21:46 <Arkady_Kanevsky> HA VM also have been going ofr a while and require parts outside of openstack
21:21:49 <rockyg> HA VM is getting lots of comments
21:22:08 <carolbarrett> could we divide fleet management?
21:22:09 <rockyg> I suspect most of our user stories will....
21:22:29 <KrishR> i think HA VM is a good candiadte even though it needs outside parts like Pacemaker etc.
21:22:29 <Arkady_Kanevsky> I think it will be easier to devide HA VM.
21:22:44 <Arkady_Kanevsky> +1 for KrishR
21:22:45 <shamail> agreed, mainly because a team is already started to work on the cross prokject spec
21:23:17 <carolbarrett> Pete Chadwick - Are you around?
21:23:30 <shamail> I think we could divide it carolbarrett, ken added prioritization info which could be used for that
21:23:44 <rockyg> ++
21:24:05 <Arkady_Kanevsky> does that mean that we shoudl prioritize use cases within a story?
21:24:06 <KrishR> shamail: you meant for Fleet Mgmt, right?
21:24:11 <shamail> yea
21:24:18 <carolbarrett> so it sounds like the 2 options are Fleet Management and HA VM
21:24:30 <carolbarrett> KrishR: What do you think?
21:24:48 <KrishR> Kenny and I are working on prioritizing the use cases so we can focus on a subset
21:24:50 <Arkady_Kanevsky> HA VM is simpler
21:24:50 <shamail> carolbarrett: +1 on those two
21:25:11 <KrishR> I meantof ro Fleet Mgmt
21:25:17 <KrishR> +1 on FLeet and HA VM
21:25:22 <Arkady_Kanevsky> can we do 2 pilots?
21:25:34 <rockyg> I tend to go with Arkady_Kanevsky
21:25:36 <Arkady_Kanevsky> or we should really pick 1
21:25:48 <shamail> probably just want to pilot one… (we can proceed with both but use one as pilot)
21:25:52 <carolbarrett> arkady_Kanevsky: I don't see why not...as long as we have enough resources
21:26:02 <rockyg> HA VM might be more direct in the early stages, and a phase one would be based on gaps
21:26:04 <shamail> there is nothing preventing us from progressing with multiple stories.. but we should only read out on one
21:26:09 <Arkady_Kanevsky> let's ask story owners.
21:26:27 <Arkady_Kanevsky> if they willing and able to handle it
21:26:29 <shamail> good idea Arkady_Kanevsky
21:26:50 <carolbarrett> That would be KrishR and Pete Chadwick
21:27:12 <KrishR> I'm OK with Fleet - but rememebr that a lot of it is outside OpenStack
21:27:22 <shamail> Agreed KrishR
21:27:43 <Arkady_Kanevsky> +1 with KrishR.
21:27:51 <carolbarrett> KrishR: That's a good point
21:27:55 <shamail> I think the discussion is a good one to have… let’s see how much HA VM and Fleet Mgmt think they can achieve in this cycle...
21:27:59 <Arkady_Kanevsky> But it is a pilot - our goal is to get expererince...
21:27:59 <rockyg> That's why I was leaning to HA VM
21:28:03 <shamail> We can decide which one to showcase as the pilot later
21:28:14 <shamail> as long as they are moving forward
21:28:25 <carolbarrett> I wonder if HA VM is a better pilot
21:28:29 <Arkady_Kanevsky> and DOCIMENT experience
21:28:29 <shamail> if we only have enough resources for one then we have to choose now (but I dont think that is the case)
21:28:30 <carolbarrett> shamail +1
21:28:53 <leong> i think we can work on multiple
21:29:00 <carolbarrett> leong +1
21:29:01 <shamail> I think HA VM might be the better/simpler pilot as well carolbarrett but let’s move both forward
21:29:02 <leong> even baremetal can fits in aas well
21:29:11 <shamail> leong: +1 it sure can
21:29:41 <carolbarrett> How do we want to decide?
21:29:51 <shamail> So carolbarrett, would an action to contact user story owners for bare metal, HA VM, and fleet mgmt be the right next step?
21:29:57 <shamail> action item*
21:30:12 <shamail> to gauge their thoughts on what can be accomplished for each one
21:30:31 <Arkady_Kanevsky> +1
21:30:33 <leong> ha_vm, fleet_mgmt, baremetal are all progressing into the next phase of the flow: Gap analysis
21:30:54 <KrishR> for Fleet, i can say we will hav gap analysis done
21:31:23 <KrishR> and possibly implementation plan too
21:31:39 <carolbarrett> KrishR: That's great!
21:31:55 <shamail> I think either of those three are good candidates, that is why I am thinking that we let them all make progress and then maybe decide which one is our “pilot” at mid-cycle?
21:32:03 <Arkady_Kanevsky> next topic?
21:32:06 <leong> +1 shamail
21:32:19 <shamail> The only difference between pilot and others is which one we will showcase when giving workflow examples
21:32:24 <shamail> achievements of all will be shared
21:32:26 <carolbarrett> #agree decide on User Story Pilot at Midcycle
21:32:50 <carolbarrett> Moving on
21:32:52 <shamail> and I am sure we will learn lessons from all as well
21:32:53 <shamail> thanks.
21:33:06 <carolbarrett> #topics Newton Design Series Update
21:33:10 <carolbarrett> Shamail - Pls take this one
21:33:19 <shamail> Sure thing carolbarrett
21:33:41 <shamail> So we had good success with lining up PTL interviews
21:33:41 <carolbarrett> #topic Newton Design Series Update
21:33:54 <shamail> So we had good success with lining up PTL interviews (most recordings are done)
21:34:15 <Arkady_Kanevsky> so what is the next xtep?
21:34:22 <shamail> I will be contacting a few people to possibly re-record based on the videos…. Some were missing video for PTL
21:34:45 <KrishR> hope not one of mine :-(
21:34:55 <shamail> The next thing we need to do is create slides that summarize the answers for each question from the PTL in 2-3 bullet points
21:34:59 <shamail> KrishR: One of them is :(
21:35:05 <Arkady_Kanevsky> I was thinkinbg of updating each project roadmap based on interveiw
21:35:22 <Arkady_Kanevsky> shamail +2
21:35:25 <shamail> I am waiting until I review all videos before I send out an email about re-recording
21:35:41 <shamail> Arkady_Kanevsky: +1, I have been doing that for the interviews I conducted but that would be appreciated
21:35:46 <Arkady_Kanevsky> I have my last one rescheduled for this wednesday
21:36:04 <shamail> For the slides, I am glad to help those who want me to create them on their behalf… Is anyone willing to create their own summary slides?
21:36:09 <shamail> I will gladly send the template
21:36:10 <Arkady_Kanevsky> I will od that for 3 I am CPL
21:36:28 <Arkady_Kanevsky> I expected that CPL will do that for their projects.
21:36:52 <Arkady_Kanevsky> Do we have a base Newton slides where to put them?
21:37:00 <shamail> I will be creating slides for the videos that have been sent to Heidi Joy this week
21:37:01 <KrishR> shamail: can you send out a link to all the videos? I didnt take notes while interviewing
21:37:09 <shamail> We will begin publishing the videos next week :)
21:37:11 <Arkady_Kanevsky> looking for consistency for slide across projects
21:37:37 <Arkady_Kanevsky> carol can you repost pointer to interveiw schedule?
21:37:49 <Arkady_Kanevsky> Suggest each person add a pointer to interview on it
21:37:50 <shamail> KrishR: Please email Heidi Joy and ask her to add you to the newton design series dropbox account
21:38:21 <Arkady_Kanevsky> I uploaded to google and send heidi a pointer to it
21:38:25 <shamail> Arkady_Kanevsky: This information already exists.. it is in the google spreadsheet we used and all videos are in a single dropbox account.  We don’t need to add it to etherpad
21:38:29 <shamail> Thanks
21:38:37 <carolbarrett> #link https://etherpad.openstack.org/p/Newton_design_series_PTL_interview
21:38:39 <shamail> Any questions?
21:38:46 <shamail> Seems like I volunteered to create all slides. :x
21:38:51 <shamail> lol
21:38:54 <Arkady_Kanevsky> tahnsk carol
21:39:16 <carolbarrett> shamail: Sounds like you're looking for the CPLs to create the slides, not the person who did the interview?
21:39:32 <shamail> carolbarrett: I am looking for the interviewer to create them (or I will)
21:39:36 <Arkady_Kanevsky> shamail, if you send a pointer to sample slides, I will handle once I am CPL for
21:39:47 <carolbarrett> shamail: OK. Is there a deadline you want us working to?
21:39:50 <shamail> either is fine but I was trying to spread the workload a bit
21:39:54 <KrishR> shamail: I'll create slides for my interviews
21:40:26 <shamail> Yes carolbarrett, please let me know if you are going to be creating slides for your interview by tomorrow.  If you are creating the slides then please have them completed by 6/13
21:40:35 <shamail> Thanks KrishR, I will send you the template we are using.
21:40:38 <carolbarrett> #agree Newton design series interviewers to complete and post slides by 6/13
21:40:50 <MeganR> I can help create slides, if needed.
21:40:52 <shamail> Thanks Arkady_Kanevsky, i’ll send it to you as well
21:40:58 <shamail> Awesome MeganR!
21:41:02 <carolbarrett> shamail: I can create the slides for the interviews I did - pls cc me on the email with the template (again)...
21:41:11 <shamail> I meant to reply to your email but then got sidetracked
21:41:24 <shamail> Will do.. thank you carolbarrett, Arkady_Kanevsky, KrishR, and MeganR!
21:41:30 <shamail> That’s all I had for this topic
21:41:31 <Arkady_Kanevsky> +1
21:41:36 <carolbarrett> Thanks Shamail
21:41:39 <carolbarrett> let's move on
21:41:49 <carolbarrett> #topic 6/20 Meeting Plan
21:42:08 <carolbarrett> In Austin and even before then, we had discussed getting regular updates from CPLs in this meeting.
21:42:47 <carolbarrett> The intention is to help educate the rest of this team on the hot topics and highlight anything that relates to our use cases
21:43:11 <carolbarrett> Shamail and I talked about order and decided to use the project adoption info to guide this.
21:43:36 <carolbarrett> We'd like to dedicate 30 mins in the 6/20 meeting to CPL updates.
21:43:49 <Arkady_Kanevsky> carol, great idea.
21:44:07 <Arkady_Kanevsky> But I expect we will need shareable mdeai to present and hear
21:44:11 <carolbarrett> The ones we'd like to cover are: Nova (Hugh), Keystone (Who owns this?), Horizon (Carol), Glance (Nate)
21:45:02 <carolbarrett> arkady_kanevsky: Good point. We can use an etherpad for the CPLs to put notes into. I can add a bridge for that meeting if folks want
21:45:04 <rockyg> What about Neutron "core"?  That would hit all the defcore projects then
21:45:44 <carolbarrett> rockyg: neutron would be in the next wave
21:45:52 <shamail> carolbarrett: +1
21:45:52 <Arkady_Kanevsky> waht about webex so we can see a slide or 2 per project?
21:46:28 <shamail> I would prefer an etherpad per project, that way the update can be seen later by those who miss the meeting
21:46:30 <Arkady_Kanevsky> who was keystoen CPL before?
21:46:36 <shamail> It could also be used by the AsiaPac Regional meeting
21:46:47 <carolbarrett> shamail: +1
21:46:54 <shamail> Arkady_Kanevsky: Sheena from Mirantis
21:47:04 <Arkady_Kanevsky> yes on etherpad for notes on the projects. Aslo slides should be on google so all can see them
21:47:26 <carolbarrett> We could do a combo of Etherpad + Phone or Etherpad + Webex - preferences?
21:47:34 <Arkady_Kanevsky> he dropped out I assume?
21:47:35 <KrishR> +1 on etherpads
21:47:41 <shamail> MeganR: You did the keystone roadmap slides right?  Were you just helping with the roadmap content or did you take CPL?
21:48:03 <shamail> carolbarrett: etherpad or phone+etherpad
21:48:18 <carolbarrett> #agree Setup 1 etherpad per project for the CPL to place updates in; Link etherpad from Wiki
21:48:36 <carolbarrett> shamail: I think we need something beyond the etherpad for the Q&A...yes?
21:48:43 <shamail> Yep
21:48:47 <shamail> IRC or Phone
21:49:01 <carolbarrett> shamail: Etherpad and IRC is a tough combo
21:49:12 <shamail> fair
21:49:19 <shamail> im fine with etherpad+phone as well!
21:49:21 <Arkady_Kanevsky> ca n we do etherpad and google?
21:49:29 <KrishR> +1 to etherpad and phone
21:49:32 <carolbarrett> Is etherpad + phone OK with everyone?
21:49:42 <Arkady_Kanevsky> etherpad & webex (or equivalent) for meeting
21:49:43 <rockyg> +1
21:49:49 <MeganR> +1
21:50:03 <carolbarrett> #agree Use a combo of Etherpad and Phone for the CPL updates
21:50:17 <Arkady_Kanevsky> +1 for etherapd and phone.
21:50:19 <carolbarrett> Do we have a Keystone CPL volunteer
21:50:22 <carolbarrett> ?
21:50:27 <KrishR> Arkady_Kanevsky: looks like you prefer a video link - let me talk to Kenny about the one we've been using
21:50:34 <rockyg> If the phone conference owner is using ATT, they have an online app for sharing desktop...
21:51:04 <Arkady_Kanevsky> My comment that it is hard to present etherpad. SLide is easier
21:51:41 <carolbarrett> I'll send an email to the CPLs who aren't here today and confirm they can do the 6/20 meeting
21:52:14 <carolbarrett> arkady_kanesvky: I think the ease of sharing and tracking info in etherpad is important
21:52:32 <carolbarrett> #action Carol send email to CPLs to confirm 6/20 attendance and readiness for updates
21:52:43 <carolbarrett> Let's move on
21:52:54 <carolbarrett> #topic Barcelona Session Planning
21:53:09 <carolbarrett> I'm sure you all saw emails from the Foundation folks about the start of submissions
21:53:29 <KrishR> carolbarrett: yes
21:53:59 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Barcelona_Sessions
21:54:19 <carolbarrett> I started an etherpad where we can propose, discuss and track session proposals
21:54:57 <shamail> awesome thanks
21:55:22 <Arkady_Kanevsky> +1
21:55:35 <shamail> I will think about sessions this week and add them to the etherpad
21:55:39 <carolbarrett> Pls use the etherpad to capture your proposals and we can review it next week.
21:55:43 <carolbarrett> shamail: Thanks!
21:55:44 <leong> me too
21:56:11 <carolbarrett> OK - last topic
21:56:14 <carolbarrett> #topic Opens
21:56:23 <carolbarrett> Anyone have any opens to share?
21:56:57 <carolbarrett> Pete, Mark Baker and I will be presenting the Roadmap at the OpenStack Ireland Day on Friday.
21:57:05 <shamail> none from me
21:57:26 <Arkady_Kanevsky> good luck. Say hi to Gael rehault (Dell) from me
21:57:26 <carolbarrett> Anyone else?
21:57:34 <MeganR> Have fun at OS Ireland!!
21:57:37 <shamail> Yea
21:57:42 <shamail> have fun and a safe trip!
21:57:43 <carolbarrett> arkday_kanevsky: Will do
21:57:48 <KrishR> carolbarrett: all the best
21:57:57 <carolbarrett> Thanks all - looking forward to it!
21:58:04 <Arkady_Kanevsky> thanks all
21:58:06 <shamail> o/
21:58:07 <carolbarrett> You all have a good rest of your week.
21:58:09 <leong> have fun
21:58:12 <Arkady_Kanevsky> bye
21:58:20 <carolbarrett> Bye
21:58:23 <MeganR> bye
21:58:25 <kei_> bye
21:58:28 <cloudrancher> bye
21:58:29 <carolbarrett> #endmeeting