02:00:26 <hughhalf> #startmeeting product_working_group
02:00:26 <openstack> Meeting started Tue Jun  7 02:00:26 2016 UTC and is due to finish in 60 minutes.  The chair is hughhalf. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
02:00:29 <openstack> The meeting name has been set to 'product_working_group'
02:00:40 <hughhalf> Welcome to the Regional Product WG Meeting folks :)
02:00:52 <hughhalf> We have a short agenda here
02:00:53 <hughhalf> #link https://wiki.openstack.org/wiki/Meetings/product-team
02:00:57 <shintaro> hi
02:01:01 <hughhalf> lets start with a roll call though please
02:01:03 <kazuIchikawa> hi
02:01:10 <leong> o/
02:01:12 <kei_> o/
02:01:18 <hughhalf> o/
02:01:26 <rockyg> o/  might not be able to stay for long...
02:01:41 <hughhalf> thats ok rockyg I suspect it will be a fairly short meeting today
02:02:06 <hughhalf> Any other roll calls if not we'll move on to the first agenda item
02:02:14 <leong> sound good
02:02:24 <hughhalf> Ok
02:02:35 <hughhalf> #topic User Story Review
02:02:53 <hughhalf> And I place on record my thanks to kei_ for suggesting this
02:03:06 <hughhalf> kei_ would you like to discuss thie Bare Metal User story for starters ?
02:03:09 <leong> the baremetal user story is merged
02:03:21 <hughhalf> excellent!
02:03:27 <kei_> leong just said that :)
02:03:40 <leong> kei_, the next step is to perform gap analysis
02:03:49 <hughhalf> please continue leong, thank you :)
02:03:53 <kei_> so that status for the top5 user stories is:
02:04:04 <kei_> 1) Rolling Upgrade: Kenny Johnston
02:04:12 <kei_> #link https://review.openstack.org/#/c/304181/
02:04:21 <kei_> It's been merged for a while.
02:04:34 <kei_> 2) HA VM: Pete Chadwick
02:04:35 * hughhalf nods
02:04:47 <kei_> #link https://review.openstack.org/#/c/318431/
02:05:00 <kei_> Under reviewing, aiming to complete by mid-June.
02:05:20 <kei_> However, specs are beginning to be written.
02:05:29 <kei_> #link https://etherpad.openstack.org/p/newton-instance-ha
02:05:38 <kei_> 3) Bare Metal Service: Yih Leong Sun
02:05:46 <kei_> #link https://review.openstack.org/#/c/289627/
02:06:09 <kei_> It's been merged.  It will be brought up to "Gap and Overlap Analysis by Cross Project Spec Liaisons, User Story Owner, and User Story Technical SME".
02:06:24 <kei_> 4) Fleet Management: Krish Raghuram
02:06:32 <kei_> #link https://review.openstack.org/#/c/299531/
02:06:40 <kei_> It's been merged.  Next step is to complete Gaps/Overlaps Analysis as same as bare metal service.
02:06:51 <kei_> 5) Capacity Management: Shamail Tahir
02:07:01 <kei_> CERN has requirements for quotas/capacity management.
02:07:09 <kei_> #link http://openstack-in-production.blogspot.fr/2016/04/resource-management-at-cern.html
02:07:18 <kei_> Trying to figure out how to integrate them into the user story (or maybe just create a new user story).
02:07:21 <kei_> 
02:07:45 <kei_> that's it.  does anyone have a link to Capacity Management user story?
02:08:13 <leong> #link Capacity http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/capacity_management.html
02:08:30 <leong> this is some pre-work done before..
02:08:41 <hughhalf> Thank you kei_  and leong
02:09:12 <kei_> leong: thanks.  do you also have a link to its gerrit?
02:10:04 <leong> this one? https://review.openstack.org/#/c/253228/
02:10:40 <leong> that looks pretty old one
02:10:47 <kei_> leong: i thought i would be the one, but i was not sure.
02:11:13 <leong> i think Shamail will work with CERN and trying to define one
02:11:27 <leong> maybe a new user story if the existing one doesn't fit
02:11:30 <hughhalf> Is it worth asking on the ML ?
02:11:39 <leong> maybe can ask shamail first
02:11:44 * hughhalf nods
02:11:56 <hughhalf> leong are you happy to follow that up with Shamail ?
02:12:07 <leong> would you also have specific requirements or interest in the capacity management?
02:12:40 <kei_> leong: none for now.
02:13:08 <leong> maybe we can first concenrate on the baremetal user story first.. ?
02:13:19 <kei_> leong: hughhalf: if it's ok, i'll ask shamail about its user story.
02:13:29 <hughhalf> cool
02:13:52 <kei_> leong: yes.  i just wanted to know the right user story for capacity management that is one of the top5 user stories.
02:15:05 <hughhalf> Anything else we should discuss on user stories ?
02:15:16 <leong> just email shamail and ask him about the cap mgmt
02:15:32 <shintaro> how about instance ha? looks like it is in pretty good shape.
02:16:08 <kei_> i sure will do that.  thanks, leong.
02:16:30 <leong> HA VM is in good shape.. we just need to resolve all the conflict and merge it.. then proceed with Gap Analysis then Implementation Plan
02:16:50 <leong> there are already some existing work done by the HA team
02:17:05 <shintaro> great
02:18:10 <hughhalf> Shall we move on to Midcycle discussions or is there other User Story matters folk would like to raise first ?
02:18:31 <leong> nothing else from me for user story
02:18:51 <hughhalf> ok
02:18:58 <kei_> do we choose another top5 for ocata?
02:19:17 <hughhalf> kei_ Yes from memory it gets reviewed each cycle
02:19:31 <leong> depending on the progress that we have now..we will need to re-evaluate
02:19:33 <hughhalf> it hasn't (also from memory) changed much these last couple as they've still been worked on
02:20:04 * hughhalf waits a moment to see if anything further
02:20:16 <hughhalf> #topic Midcycle Planning
02:20:31 <hughhalf> I note that in the main meeting earlier today they had a planning etherpad for this
02:20:44 <hughhalf> #link https://etherpad.openstack.org/p/PWG_Newton_Midcycle_Planning
02:21:09 <leong> yup.. and it is decided to have a 2-day Product WG midcycle meet-up, colocated with the Ops midcycle
02:21:18 <leong> date and location is not decided yet
02:21:29 <hughhalf> I think New York or Seattle ?
02:21:31 <leong> but most likely in August and in USA (probably Seattle or New York)
02:21:43 <shintaro> would it be co-located with ops-meetup?
02:21:46 * hughhalf nods
02:21:58 <leong> shintaro, yes!
02:22:00 <hughhalf> I believe that is the plan shintaro
02:22:11 <kei_> Over the next week, eveyone is asked to look over the etherpad and add your +1s, -1s and other topics.
02:22:16 <leong> anyone here planning to come?
02:22:32 * hughhalf may be able to depending on other travel commitments around that time
02:23:14 <kei_> i'm not sure at this moment...
02:23:20 <shintaro> Planning to join Ops so I will
02:23:32 <leong> ok
02:24:08 <hughhalf> do you think you will attend leong  ?
02:24:18 <leong> more likely i will
02:24:26 <hughhalf> excellent
02:24:39 <rockyg> i'll probably be there, too.
02:24:55 <hughhalf> Nice one :)
02:25:29 <shintaro> according to the OpsML, there will be a cap for the number of attendees, so need to be quick to register!
02:25:49 <hughhalf> Ah good to know shintaro
02:26:15 <hughhalf> I wonder if we fall under that same cap though ?
02:26:51 * hughhalf might just ask on the product list about it
02:27:11 <hughhalf> Do we need to cover anything else with Midcycle Planning here - I think the Etherpad is fairly self explanatory otherwise ?
02:28:15 <kei_> hughhalf: none from me.
02:28:18 * hughhalf waits for a moment in case anyone is typing :)
02:28:27 <hughhalf> Ok I think we can move on to open discussion
02:28:35 <hughhalf> #topic Open Discussion
02:28:44 * rockyg sneaks out the side door
02:28:54 <hughhalf> I have one item for Open Discussion, but before I go ahead, anyone else ?
02:29:01 <hughhalf> Thanks for joining rockyg
02:29:25 <leong> can start think of Barcelona Summit
02:30:08 <hughhalf> Please go ahead leong :)
02:30:33 <leong> i'm saying we can start brainstorming any proposal for Barcelona Summit
02:31:19 * hughhalf is going to put a talk proposal in to discuss Lwood and mailing list statistics, ettiquette etc.
02:31:37 <kei_> as the Foundation sent out email about the start of submission, carol started an etherpad to capture our proposals here.
02:31:51 <kei_> #link https://etherpad.openstack.org/p/PWG_Barcelona_Sessions
02:31:58 <hughhalf> Oh nice one kei_ thanks for that
02:32:14 <kei_> the main meeting plans to review it next week.
02:33:52 <hughhalf> good to know - since a number of us make the main meeting we can perhaps summarise that for Regional too
02:34:59 <hughhalf> Anything else for Barcelona ?
02:35:09 <leong> not from me
02:35:14 <kei_> hughhalf: that's a good idea. > summarising.
02:35:54 <kei_> maybe one proposal would be VMs, bare metals, containers integration?
02:36:26 <kei_> "integration" may not be the right word here, but
02:36:28 <hughhalf> They're certainly widely common/popular topics
02:36:43 <hughhalf> No I think integration is ok
02:36:53 <hughhalf> or perhaps coexistence
02:36:54 <kei_> hughhalf: ok.  thanks.
02:37:22 <hughhalf> more of a "how do we make these technologies work sensibly in the same environment" than "mix them all together" perhaps
02:37:28 <hughhalf> But yes, worth considering I think
02:38:05 <kei_> hughhalf: i agreed.
02:38:09 <leong> yes! definitely worth to do it!
02:39:16 <hughhalf> kei_ would you like to suggest the proposal in the etherpad or ML ?
02:39:37 <kei_> hughhalf: yes.  i will do that.
02:40:01 <hughhalf> Thanks kei_ - I'm sure we can assist if you have drafts etc.
02:40:37 <kei_> hughhalf: that'd be really appreciated.  i'll share my draft first.
02:40:38 <hughhalf> I have a small item if people are happy to move on to another Open Discussion topic
02:40:41 <hughhalf> Cool :)
02:40:58 <leong> sure!
02:41:00 <kei_> hughhalf: please go ahead.
02:42:03 <hughhalf> Wanted to check folk were happy with the regional meetings - both the timing (roughly every two weeks) and the way we chair them.  I'd also like to note my appreciation for kei_ , leong and others who help with the process of running the meeting. I have two thoughts;
02:42:19 <hughhalf> I think we should continue to maintain the two week cadence so people get used to the meeting being on
02:42:35 <hughhalf> and I think that sharing the Chair role, informal though it is, works quite well too
02:42:41 <hughhalf> But I would welcome your thoughts :)
02:43:06 <leong> +1
02:43:46 <leong> is the meeting time (9am Japan Standard time) works for everyone ? do we need to re-evaluate the meeting time?
02:44:04 <hughhalf> Good question leong, thank you
02:44:41 <hughhalf> The time is pretty ideal for me (as long as I remeber to have a snack first :)
02:45:32 <leong> hopefully we can attract more participation from others in APAC region
02:45:39 <kazuIchikawa> it's 11am in JST now. it works for me.
02:45:45 <kei_> leong: you mean 11am JST, right?  it works for me.
02:45:49 <hughhalf> thank you kazuIchikawa :)
02:45:51 <shintaro> +1
02:46:03 <leong> opsss. wrong timezone calculation :p
02:46:08 * hughhalf chuckles
02:46:19 <hughhalf> it's a tricky business :)
02:46:27 <kei_> it is.
02:46:43 <hughhalf> My sense is the time of day and every two weeks agrees with people so I think that's ok
02:47:15 <shintaro> yes, this is great!
02:47:16 <leong> let's keep it the way we have now ... we can always revisit if needed
02:47:31 <hughhalf> Agreed
02:47:45 <kei_> leong: +1
02:48:08 <hughhalf> #agreed keep current time of day (Tuesday 0200 UTC) and cadence (every two weeks) for Regional meeting
02:48:43 <hughhalf> Is there anything else we should cover today ?
02:48:54 <leong> i'm good
02:49:07 <kei_> none from me.
02:49:29 <hughhalf> I think we're just about done, will wait another moment in case someone is furiously typing
02:50:06 <kei_> :)
02:50:16 <hughhalf> Looks like we're done
02:50:21 * leong .. going to say bye and chat with you all soon..:-)
02:50:28 <hughhalf> Thank you all again for your participation, I'll close the meeting now
02:50:34 <shintaro> thanks
02:50:37 <kei_> thanks all!
02:50:38 <leong> thanks
02:50:45 <hughhalf> Arigato/ Xie Xie :)
02:50:51 <hughhalf> #endmeeting