21:00:14 <shamail> #startmeeting product working group
21:00:15 <openstack> Meeting started Mon Jun 20 21:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:18 <openstack> The meeting name has been set to 'product_working_group'
21:00:25 <shamail> Hi, who’s here today?
21:00:32 <cloudrancher> Howdy
21:00:32 <kencjohnston_> Me o/
21:00:43 <shamail> Hi cloudrancher and kencjohnston_
21:00:47 <Soyeh_McCarthy> Hi, Soyeh McCarthy with Ericsson is here
21:00:54 <kencjohnston_> Hi shamail!
21:00:56 <shamail> Hello Soyeh_McCarthy
21:01:20 <Soyeh_McCarthy> hello
21:01:37 <shamail> The agenda for today can be found at
21:01:39 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team#June_20.2C_2016_Product_Team_Meeting_Agenda
21:02:00 <leong> o/
21:02:06 <shamail> hi leong
21:02:13 <leong> hi shamail
21:02:19 <shamail> #topic CPL Review Update
21:02:39 <shamail> The first topic for today is just a quick update on the CPL reviews that we were trying to schedule
21:02:53 <shamail> We didn’t get confirmation in time from enough CPLs to do the first round of updates this week
21:03:02 <shamail> We’re going to try and aim for 6/27 at this point
21:03:20 <rockyg> o/
21:03:20 <shamail> Hi MeganR, rockyg, and HeidiJoy
21:03:31 <MeganR> Hi!
21:03:34 <shamail> #topic User story Review
21:03:38 <HeidiJoy> Hi! 0/
21:03:40 <rockyg> \o/
21:03:51 <shamail> We have had a lot of good activity on user stories over the last couple of weeks in our repo
21:04:13 <shamail> it seems as though some might be ready for the next step, which would be to conduct a gaps analysis meeting with the right people
21:04:18 <leong> the HA VM and baremetal is ready for gap analysis
21:04:37 <shamail> kencjohnston_ and leong, have you already made plans on how to proceed with the next step?
21:05:00 <leong> i will discuss with Kei (fujitsu) on the plan for baremetal
21:05:01 <kencjohnston_> kencjohnston_ for which one? I don't believe I'm the owner of either HA VM or baremetal...
21:05:05 <shamail> Thanks leong
21:05:07 <leong> is Pete here?
21:05:23 <shamail> kencjohnston_ I thought either fleet management or standard options was also getting there
21:05:34 <shamail> I don’t see Pete on today
21:05:43 <kencjohnston_> shamail Ah, yes fleet management is Krish and we are moving forward with a gaps analysis
21:05:47 <leong> in today regional meeting, we will also discuss the plan for HA VM with NTT
21:06:00 <kencjohnston_> shamail: "Standard Options"?
21:06:06 <shamail> standard config options
21:06:25 <kencjohnston_> shamail: Centralize Config has a Cross Project Spec already underway
21:06:32 <kencjohnston_> Gaps Analysis happening there
21:06:45 <shamail> sounds good leong, please let us know when you schedule a meeting with the appropriate CSPLs!
21:07:11 <shamail> Got it kencjohnston_, do we need to track it then or anything else?
21:07:15 <leong> btw, where can i get the list of CSPLs
21:07:28 <kencjohnston_> shamail: I don't think we need to continue to track it
21:07:41 <kencjohnston_> #link Centralize Config Cross Project Spec https://review.openstack.org/#/c/295543/
21:07:43 <shamail> leong:
21:07:45 <shamail> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Cross-Project_Spec_Liaisons
21:08:06 <shamail> Thanks for the link kencjohnston_… sounds good.
21:08:56 <shamail> #action Schedule gaps analysis meeting between user story owners, technical SMEs, CSPLs for HA VM, Fleet Management, Bare Metal (Leong, Krish, Pete)
21:09:07 <leong> seems like irc is the only contact method? is tt possible to get their email contact?
21:09:24 <shamail> I would suggest contacting them via IRC and asking for it
21:09:42 <shamail> The other way would be to search through whichever mailbox you recieve openstack-dev messages on
21:09:49 <shamail> That’s how I usually find them
21:10:04 <leong> ok
21:10:33 <rockyg> Sometimes can also find them through their launchpad acct
21:10:39 <shamail> Thanks for the updates leong and kencjohnston_!
21:10:50 <Arkady_Kanevsky> Is that one meeting per user story or one for general process?
21:11:02 <shamail> one per use story Arkady_Kanevsky
21:11:05 <shamail> user*
21:11:14 <Arkady_Kanevsky> thanks
21:11:30 <shamail> #topic Midcycle Planning
21:11:44 <shamail> #link https://etherpad.openstack.org/p/PWG_Newton_Midcycle_Planning
21:12:08 <shamail> The ops-meetup admin WG will decide on a venue at their upcoming meeting (tomorrow)
21:12:11 <Arkady_Kanevsky> so where will it be?
21:12:18 <Arkady_Kanevsky> +1
21:12:37 <shamail> It is between Seattle (Best Buy) and New York (Bloomberg)…. the last time I checked, NYC had more votes
21:12:59 <Arkady_Kanevsky> NY is more expensive...
21:13:24 <shamail> Knowing the locations (SEA or NYC), do we have any volunteers that could potentially host the PWG midcycle if it’s in one of these cities?
21:13:46 <shamail> I’d like to add Blue Box (IBM) as a potential host for Seattle
21:15:09 <shamail> I added a new section to the midcycle planning etherpad for hosts
21:15:17 <shamail> line 28
21:15:21 <Arkady_Kanevsky> see it (+1)
21:15:54 <shamail> #action If your company has a location in either city that could host the PWG midcycle, please add it to the list in the midcycle planning etherpad (all)
21:16:27 <shamail> Next step is to go through list of proposed topics and give them a ranking
21:16:45 * kencjohnston_ quietly leaves through the side door.
21:17:03 <shamail> Can everyone take the next 2 minutes to look through the list of topics in the etherpad and add a +1 for those that you believe should be discussed at the midcycle?
21:17:04 <Arkady_Kanevsky> How do you propose to rank it?
21:17:15 <shamail> Cya kencjohnston_, please add your thoughts to tthe etherpad
21:17:27 <shamail> Arkady_Kanevsky: Add +1 next to topics that you would like to see
21:17:35 <Arkady_Kanevsky> On etherpad with x # of votes per person? setup poll like we did for user stories?
21:19:29 <shamail> Arkady_Kanevsky: no restrictions for now just based on where you see value
21:19:44 <shamail> We can go more formal if clear interests do not emerge
21:20:14 <leong> +1 shamail
21:20:31 * shamail adds new section at bottom of etherpad with results (give me 1 min)
21:21:14 <Arkady_Kanevsky> I think we need rought time estimate for each topic so we can see how many we can land
21:22:43 <shamail> Okay!
21:22:50 <Arkady_Kanevsky> removing double counting
21:22:51 <shamail> That’s the next step Arkady_Kanevsky
21:23:09 <shamail> So we have a ranked list starting at Line 73 of the etherpad
21:23:43 <shamail> Let’s discuss each topic to establish length with the assumption that we are capped at 14-16 hours
21:23:56 <shamail> Item 1: OpenStack Strategy (this is following up from the Austin summit presentation where we suggested the PWG could be an advisor on "strategy")
21:23:59 <Arkady_Kanevsky> we will need to present roadmap at next summit so I would move to the top of (2)s
21:24:20 <shamail> Does 2 hour seem appropriate for this topic?
21:24:47 <Arkady_Kanevsky> yes, maybe even 1+1/2
21:24:54 <shamail> I am thinking two hours mainly because of the SWOT and CI items
21:25:08 <shamail> Anyone else here? :P
21:25:25 <shamail> It’s just us Arkady_Kanevsky :)
21:25:35 <Arkady_Kanevsky> leong?
21:25:40 <leong> yes
21:25:55 <leong> 2 hrs looks good to me
21:26:06 <shamail> We can defer the duration topic until next week if that makes more sense
21:26:22 <leong> maybe email the "result" to maillist
21:26:25 <shamail> Do ya’ll want to build a draft agenda in this meeting or should Carol and I take a stab and share a draft we can edit?
21:26:29 <Arkady_Kanevsky> lets put draft of duration on the etherpad and let folks comment
21:26:38 <Arkady_Kanevsky> yes
21:26:53 <shamail> That way we focus on fixing rather than building the initial draft
21:27:01 <Arkady_Kanevsky> +1
21:27:06 <Soyeh_McCarthy> Apologies Shamail, I'm new to this and trying to get a hang of things, including conducting the meeting through IRC and etherpad :-)
21:27:26 <Arkady_Kanevsky> welcome Soyeh
21:27:35 <Soyeh_McCarthy> Thank you
21:27:38 <rockyg> welcom Soyeh_McCarthy !
21:27:52 <Arkady_Kanevsky> will you be able to join midcycle?
21:27:57 <shamail> No worries Soyeh_McCarthy, it does take an adjustment and welcome!
21:28:35 <Soyeh_McCarthy> I don't know yet
21:29:38 <Soyeh_McCarthy> what are the dates?
21:29:50 <shamail> Soyeh_McCarthy: We will know by next week (along with location)
21:29:54 <Arkady_Kanevsky> are we going to review roadmaps per project based on interviews?
21:30:10 <MeganR> shamail: if we are talking strategy - will two hours be enough?
21:30:17 <shamail> No Arkady_Kanevsky, we generally use the roadmap topic at the midcycle to discuss process and planning next release
21:30:20 <Arkady_Kanevsky> and building spreadsheet for themes/projects work?
21:30:43 <shamail> MeganR: It could be longer or less depending on how deep we go.  Please add your thoughts on the timeframe as well.
21:30:51 <Arkady_Kanevsky> OK. We will need to discuss also coordinatoin iwht the board on themes
21:31:06 <Arkady_Kanevsky> and for adding new themes as we had done for Newton summit
21:31:13 <shamail> I added a new section to the etherpad (Line 84) so that each person can add however long they think each topic should have
21:31:28 <shamail> We can build an initial estimate using this data by our next meeting
21:31:30 <MeganR> yes - sorry, needed to scroll down  :)
21:32:01 <Arkady_Kanevsky> +1 on all other estimates
21:32:05 <shamail> #action Please add how long you think we will need to spend on each topic to the etherpad for planning purposes (all)
21:32:13 <Arkady_Kanevsky> my comments on estimates are on etherpad
21:32:32 <shamail> Thanks Arkady_Kanevsky
21:32:41 <shamail> Moving on to the next topic
21:32:49 <shamail> #topic Level Playing Field email thread
21:32:59 <shamail> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097307.html
21:33:05 <shamail> #link https://review.openstack.org/#/c/329448/
21:33:38 <shamail> Thierry sent an email last week to revisit the discussion on open core… It made sense to bring this topic up as a FYI in our WG meeting...
21:34:00 <shamail> There has been a lot of discussion in the mailing list and I think we have a better understanding of the goal now.
21:34:32 <shamail> Essentially, this resolution is intending to make it so that projects based on a non-open source reference implementation can not become official
21:35:24 <shamail> There was a lot of discussion around whether this impacts Nova (different hypervisors), cinder volume providers, etc. since they support non open-source HW/SW
21:35:43 <Arkady_Kanevsky> that is strange. How can you have OpenStack project (that is open source by default) be non-open source?
21:36:05 <shamail> In general, this seems to be to prevent a project or feature from being based on open-source and at the end of the day, the reference will be left to humans to intrepret
21:36:29 <shamail> Arkady_Kanevsky: the example that came up in the ML was Poppy which was supposed to be an OpenStack CDN service
21:36:39 <Arkady_Kanevsky> I can understand that implementation behind some drive is not-open sourced since it talks to proprietary "black box".
21:36:53 <shamail> but there were no active open source CDN projects to use for reference implementation
21:37:46 <shamail> I encourage everyone to read the mailing list discussion as it has a lot of Q&A/clarification details
21:38:05 <Arkady_Kanevsky> Most of OS projects provides common API and front for multiple drivers with default one open sourced one
21:38:16 <shamail> yep
21:38:29 <Arkady_Kanevsky> will read and maybe evne comment on Thiery PR.
21:38:43 <shamail> and this is just affirming that the RI needs to be open source
21:38:48 <shamail> sounds good Arkady_Kanevsky
21:38:53 <Arkady_Kanevsky> +1
21:39:04 <shamail> Okay, final topic!
21:39:06 <shamail> #topic FSI (FinServ) requirements gathering session
21:39:20 <Arkady_Kanevsky> I wish swift would follow that model also and provide driver plugin support
21:40:40 <shamail> Carol and I were asked to meet with a group of people that are interested in providing requirements from the Financial Services segment.  We accepted the conversation but wanted to also open it up to others in the product working group who might have a background working with Financials.  Would anyone care to join?
21:40:51 <shamail> The meeting is not scheduled yet, simply building the attendee list
21:41:37 <leong> shamail you can put me in
21:41:38 <Arkady_Kanevsky> <shamail> does that means reqs from Financial workload segment?
21:41:39 <shamail> #action Please let Carol or Shamail know if you want to participate in the requirements gathering meeting for Financial Services market segment (all)
21:41:48 <shamail> Will do leong
21:41:58 <Arkady_Kanevsky> add me too, please
21:42:12 <shamail> Arkady_Kanevsky: I assume that would be one aspect, in general its how they foresee needing to leverage OpenStacl
21:42:16 <shamail> OpenStack*
21:42:18 <shamail> will do Arkady_Kanevsky
21:42:23 <shamail> #topics Open
21:42:24 <Arkady_Kanevsky> +1
21:42:29 <shamail> #topic Open
21:42:45 <shamail> That is all we had on the agenda today.  Any other topics?
21:42:51 <Arkady_Kanevsky> Where do we collect roadmap slides
21:43:04 <shamail> Please send them to HeidiJoy
21:43:18 <Arkady_Kanevsky> can we have a pointer to etherpad where we track interviews, and sldies presentation for roadmap
21:43:26 <shamail> And these are called the “Newton Design Series” slides (not the same as roadmap slides) :)
21:44:05 <Arkady_Kanevsky> Shall we have google repository for all projects for newton and just point Heidi to it?
21:44:07 <shamail> #link https://etherpad.openstack.org/p/Newton_design_series_PTL_interview
21:44:25 <shamail> That’s a good way of doing it Arkady_Kanevsky, I did it the same way
21:44:33 <Arkady_Kanevsky> I dislike to email raw and pdf files of presentations
21:44:47 <shamail> +1
21:44:55 <shamail> Anything else?
21:45:10 <leong> nope from me
21:45:13 <shamail> Thank you for joining everyone!
21:45:18 <Arkady_Kanevsky> no.
21:45:21 <shamail> Have a wonderful evening/night
21:45:24 <shamail> #endmeeting