21:00:58 <carolbarrett> #startmeeting Product Working Group
21:00:59 <openstack> Meeting started Mon Jul 11 21:00:58 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:02 <openstack> The meeting name has been set to 'product_working_group'
21:01:04 <Rockyg> O/`
21:01:12 <carolbarrett> Hi Folks - who is here for the Product WG meeting?
21:01:13 <cloudrancher> o/
21:01:22 <MeganR> o/
21:01:45 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:01:55 <carolbarrett> You can find the agenda for today at the link above
21:02:01 <carolbarrett> Hi All
21:02:11 <pchadwick> Hi Carol
21:02:16 <carolbarrett> HI Pete
21:02:39 <carolbarrett> Sorry for missing the last several meetings, travel was conspiring against me. Good to join again!
21:02:46 <carolbarrett> Let's get going.
21:02:51 <carolbarrett> #topic Midcycle planning
21:02:58 <kei_> hi.
21:03:04 <carolbarrett> Hi Kei
21:03:10 <kei_> hi carolbarrett!
21:03:23 <carolbarrett> I read the notes from the last couple of meetings and here's my take away
21:03:59 <carolbarrett> Plan a 1 Day F2F on 8/22 in NYC ahead of OpenStack East and Ops
21:04:13 <carolbarrett> Focus on the top 3 agenda items from our planning etherpad
21:04:25 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Newton_Midcycle_Planning
21:04:35 <carolbarrett> Review Status of Top 5 User Story Review User Story wokflow OpenStack Strategy
21:04:39 * shamail sneaks in…
21:05:06 <carolbarrett> Review Status of Top 5 User Story, Review User Story workflow and OpenStack Strategy (with punctuation this time)
21:05:15 <carolbarrett> perfect timing Shamail
21:05:40 * Rockyg hands shamail some popcorn
21:05:42 <carolbarrett> Then plan an extended working session, with voice, on 8/29 to review and discuss the outcome.
21:05:52 <carolbarrett> How does that sound?
21:05:57 <pchadwick> +1
21:06:01 <kencjohnston> carolbarrett: +1
21:06:02 <shamail> +1
21:06:06 <MeganR> +1
21:06:08 <cloudrancher> +1
21:06:21 <carolbarrett> Yay!
21:06:21 <Rockyg> +1
21:06:47 <shamail> I should -1 just to be the rebel
21:06:49 <mkashyap> +1
21:07:06 <carolbarrett> LOL
21:07:07 <shamail> jk :)
21:07:18 <carolbarrett> It turns out that Intel has an office in NYC it's on the Avenue of the Americas. I've reserved a conference room that holds ~20 from 8:00 - 5:00 that day
21:07:33 <Rockyg> kewl!
21:07:33 <pchadwick> carolbarret: sounds good
21:07:33 <carolbarrett> Would that work?
21:07:36 <shamail> carolbarrett: that is awesome news!!  Great location.
21:07:51 <shamail> The other events that week are close by too.
21:07:55 <carolbarrett> Excellent - I have never been there, but it should be a good location.
21:08:13 <MeganR> awesome!!
21:08:21 <Rockyg> any hotel suggestions?
21:08:24 <carolbarrett> I will need the names of everyone planning on attending to give to the security folks so you can get into the building
21:08:44 <carolbarrett> Would appreciate if you would put that info in the midcycle planning etherpad
21:09:03 <shamail> carolbarrett: will do
21:09:11 <carolbarrett> RockyG: I am using the hotel info provided by the OpenStack East folks, which is around TimeSquare
21:09:24 <carolbarrett> Does anyone else have Hotel recommendations?
21:09:24 <carolbarrett> Does anyone else have Hotel recommendations?
21:10:41 <shamail> I am at the Marriott Marquis in Time Sqaure
21:10:41 <carolbarrett> We'll need to spend more time planning the agenda and getting owners for topics, etc. So pls think about this, add your thoughts to the etherpad and we'll discuss again in upcoming meetings
21:10:55 <carolbarrett> of course you're at a Marriott :)
21:11:02 <shamail> That should be close by but I don’t have the address to see how close exactly
21:11:14 <shamail> Of course I am carolbarrett :]
21:11:25 <kencjohnston> carolbarrett: Anything you need for security other than our names in the Etherpad?
21:11:41 <pchadwick> Bring a picture ID
21:11:59 <carolbarrett> Kencjohnston: Pls include company and contact number in case I do need more info
21:12:06 <kencjohnston> pchadwick: Oh... does a TX drivers license count?
21:12:09 <carolbarrett> pchadwick: Good point -Thanks
21:12:13 <carolbarrett> LOL
21:12:31 <pchadwick> kencjohnston: does it have a picture on it - preferably yours? ;-)
21:12:38 <Rockyg> kencjohnston, probably not
21:12:46 <carolbarrett> Anything else on this topic for today?
21:13:01 <carolbarrett> If not, let's move on....
21:13:03 <shamail> Nothing for me, I am psyched we have a location.  Thank you carolbarrett and Intel!
21:13:15 <kencjohnston> shamail: +1, thanks carolbarrett!
21:13:19 <carolbarrett> #topic Barcelona Summit Sessions
21:13:39 <carolbarrett> As you all know the deadline for submissions is coming up! EoD Wednesday 7/13
21:13:52 <carolbarrett> We started an etherpad to track submissions from this group
21:14:03 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Barcelona_Sessions
21:14:18 <pchadwick> yep
21:14:41 <carolbarrett> I have drafted a submission for a Roadmap session and will submit it before the deadline and will include Pete and Rocky as co-presenters
21:15:00 <Rockyg> kewl.  Thanks!
21:15:06 <carolbarrett> Pchadwick: Where are you on Themes and HA VM?
21:15:31 <shamail> pchadwick: I posted a question in the etherpad regarding HA VM too
21:15:35 <carolbarrett> Rockyg: you'll see a draft in your email...
21:15:39 <pchadwick> I plan to use the same abstract for the themes discussion as in Austing
21:16:00 <pchadwick> I need to follow up with Adam, but he has committed to submit a session or two.
21:16:18 <Arkady_Kanevsky> Pete, I am always happy to help with themes
21:16:34 <pchadwick> arkady_kanevsky: sounds good.
21:16:41 <pchadwick> I'll add you.
21:16:52 <shamail> Arkady_Kanevsky: Please add your name next to the session in the etherpad as well.
21:17:31 <kencjohnston> team, I have to jump in a second but I'll submit talks for Roadmap and Birds of a Feather, I have another OSIC talk I'm submitting with Krish so that will max me out.
21:17:34 <Arkady_Kanevsky> We have open user story on troubleshooting. and a lot of email discussion in community for it
21:17:50 <Arkady_Kanevsky> Shamail - done
21:17:54 <shamail> Thanks
21:18:03 <shamail> Sounds good kencjohnston
21:18:07 <carolbarrett> kencjohnston: i thought BoF were submitted later
21:18:22 <Arkady_Kanevsky> Ken do you want to help with troubleshooting
21:18:42 <kencjohnston> carolbarrett: Ah, I couldn't remember
21:18:42 <pchadwick> What is our limit this time? I was told two? Is it still three?
21:18:50 <shamail> Three sessions max per person
21:18:59 <pchadwick> Ok - thanks.
21:19:01 <Arkady_Kanevsky> troubelshooting is your story - https://review.openstack.org/#/c/317695/
21:19:04 <shamail> Maximum of three speakers per presentation, Maximum of Four panelist + moderator for panels
21:19:12 <carolbarrett> kencjohnston - OK, better safe than sorry - go ahead and make the submission.
21:19:18 <Rockyg> BoF talks are now.  meetups later
21:19:25 <kencjohnston> carolbarrett: OK will do.
21:19:29 <carolbarrett> rockyg: Thanks!
21:19:37 * kencjohnston sneaks out.
21:19:41 <shamail> TTFN
21:20:32 <carolbarrett> There is a proposal around State of OpenStack for Enterprise - Anyone working on that?
21:20:44 <Arkady_Kanevsky> shall we combine roadmap and themes update?
21:20:54 <shamail> That is a great topic, unfortunately I can’t participate. :(
21:21:22 <shamail> Should we ask Mark Baker (he did something similar at the last summit) or send an email to the Enterprise WG to see if someone there is interested?
21:21:25 <Arkady_Kanevsky> Carol, what do you have in mind for Enterprise state?
21:21:27 <pchadwick> Arkady_kanevsky: Last time we thought it made sense to keep them separate, but I am open
21:21:31 <carolbarrett> shamail: would you want to partner with someone on that?
21:21:44 <carolbarrett> shamail: Mark Baker would be a good person to ping. Thanks!
21:21:44 <shamail> carolbarrett: I am already at three sessions. :(
21:21:47 <Arkady_Kanevsky> upgrade, HA VM, migration,???
21:22:04 <carolbarrett> Also one on User Story updates - anyone working that?
21:22:25 <carolbarrett> I see Krish has a session in the Ops Summit to discuss Day 2 Operations...
21:22:31 <shamail> I prefer keeping roadmap and theme separate since there is always so much content in the roadmap session that 40 minutes doesn’t seem like enough.  If we add themes as well then I don’t think we could do either topic justice.
21:22:35 <Arkady_Kanevsky> Carol, I htough Krish is driving user story update
21:22:45 <carolbarrett> shamail: I agree
21:22:47 <pchadwick> shamail: +1
21:22:53 <Arkady_Kanevsky> OK
21:23:16 <Arkady_Kanevsky> Do we want to present user story workflow???
21:24:03 <shamail> Arkady_Kanevsky: I think that’s probably a sub-topic in the BoF
21:24:09 <shamail> or a design summit session
21:24:21 <carolbarrett> I'd keep the work flow for the BoF session, where we have a more targeted group
21:24:35 <Arkady_Kanevsky> OK with that. but at some time we need to expose it to wider community.
21:24:50 <Arkady_Kanevsky> I explained it several time to developers at last summit...
21:25:02 <carolbarrett> arkady_kanevsky: agree, do we want to propose a session in the cross-project design summit track?
21:25:24 <Arkady_Kanevsky> I can do that. But this is shamail baby.
21:25:24 <Rockyg> we can maybe try for a crossporjct slot for the workflow?
21:25:39 <Arkady_Kanevsky> Must have him as at least co-presentor
21:25:50 <shamail> Arkady_Kanevsky: Go for it… I’ll be glad to help but it’s the PWG’s baby not mine :)
21:25:57 <carolbarrett> RockyG; Sure - will someone take the AR to do this when the etherpads open for the event?
21:26:06 <Rockyg> no limits in design summit for presenters
21:26:17 <shamail> Rockyg: Good point
21:26:32 <Rockyg> I'll ping shamail then and work with him
21:26:36 <pchadwick> Agreed it makes sense in design summit
21:26:46 <carolbarrett> #action Arkady to propose a work flow walk thru in Cross-project design summit in Barcelona with Shamail and others as co-presenters
21:27:08 <Arkady_Kanevsky> I will take 9)
21:27:18 <Arkady_Kanevsky> But I will vacate 7)
21:27:21 <carolbarrett> Krish - Thanks for joining. Are you making any submission around User Stories or Fleet management for Barcelona Sessions?
21:27:50 <carolbarrett> #action Arkady, Rockyg to propose a work flow walk thru in Cross-project design summit in Barcelona with Shamail and others as co-presenters
21:28:15 <KrishR> the Craton team is making a submission in collaboration with Sean Roberts of WalMart
21:28:36 <KrishR> showing fleet mgmt integrating with OneOps
21:28:50 <KrishR> will address a subset of use cases in the user story
21:29:26 <carolbarrett> Sounds good - will you or someone from the PWG be part of the team?
21:29:58 <KrishR> Kenny and I have reviewed the abstract, but dont expect to actually present it
21:30:16 <KrishR> The presenters will be Jim Baker and Sean Roberts
21:30:31 <carolbarrett> OK - would be good to give folks a pointer to where they can provide more input on User Stories over all
21:30:58 <Arkady_Kanevsky> google docs for all submissions?
21:31:12 <Arkady_Kanevsky> or just email to group with the draft?
21:31:17 <KrishR> we're asking the Craton team to tell us what needs to change in the user story for Fleet Mgmt
21:31:30 <Arkady_Kanevsky> Krish - good
21:31:38 <carolbarrett> arkady_Kanevsky: Google docs is probably best
21:31:53 <Arkady_Kanevsky> Carol: for all submission should fols email draft to team for feedback before submission?
21:31:55 <KrishR> carolbarrett: may ahve misunderstood your question - are you asking for the submission abstract tor eview?
21:32:04 <Arkady_Kanevsky> Carol; OK
21:32:32 <carolbarrett> KrishR: Not asking to review the abstract, trust that you will have select a good group of reviewers
21:33:18 <carolbarrett> Arkady_kanevsky: If you want to send to everyone for review that's OK, if you want to target a subset who are closer to the topic, that's good too. Think it's just good practice to get another set of eyes on these things
21:33:31 <carolbarrett> Anything else on Barcelona submissions?
21:33:32 <Arkady_Kanevsky> +2
21:33:59 <carolbarrett> OK, moving on...
21:34:05 <carolbarrett> #topic Newton Design Series
21:34:07 <kei_> carolbarrett: Leong and I are thinking of submitting a Bare Metal User Story presentation (or something else).
21:34:14 <carolbarrett> Shamail - can you pls take this topic?
21:34:26 <shamail> Sure carolbarrett
21:34:38 <KrishR> carolbarrett: yes, we're asking people to review it...you all can see item 3 at https://etherpad.openstack.org/p/OSIC-Barcelona-Summit-submissions and let me know what you think
21:34:49 <shamail> We have made good progress on the Newton Design Series so far
21:34:57 <shamail> #link https://docs.google.com/spreadsheets/d/1hVSoNXRlp7X1VLEyulI_0PCJbfWbL6_Ue4y7jpsHp7k/edit
21:35:10 <pchadwick> I need to follow up on feedback on slides
21:35:27 <shamail> Green indicates a video has been finalized and red indicates the step we are executing for each interview
21:35:38 <carolbarrett> #link  https://docs.google.com/spreadsheets/d/1hVSoNXRlp7X1VLEyulI_0PCJbfWbL6_Ue4y7jpsHp7k/edit
21:36:00 <shamail> I would suggest that if you have reached out to the PTL already to review the slides, send another reminder, and then let’s move forward with green lighting the content if we don’t hear back by the end of the week.
21:36:12 <Arkady_Kanevsky> +1
21:36:26 <shamail> Also, if you see a status that is incorrect, please update the spreadsheet accordingly
21:36:28 <carolbarrett> carol making real time updates...
21:36:36 <shamail> Thanks!
21:36:56 <pchadwick> shamail: +1
21:37:07 <carolbarrett> Does anyone need help getting review attention on slides?
21:37:49 <shamail> That is all I have on this topic… carolbarrett, Arkady_Kanevsky, MeganR_: all of you have projects that need action (it could be as simple as updating the spreadsheet :))
21:37:59 <carolbarrett> I'll take that as a no... Thanks Shamail!
21:38:00 <shamail> carolbarrett: good question
21:38:07 <shamail> Thank you everyone!
21:38:32 <carolbarrett> OK, moving on....
21:38:40 <carolbarrett> #topic CPL Updates
21:39:03 <Arkady_Kanevsky> will do. Still waiting for Rally PTL to respond. send him email last week with reminder. will do one more atte,mpt htis week
21:39:32 <carolbarrett> This is the 1st round of updates in this meeting. Our goal is to have this as a regular agenda item, with different CPLs providing updates each week.
21:39:56 <carolbarrett> These are meant to be short updates to keep us all informed about status and priorities
21:40:06 <carolbarrett> I'll start with Kolla
21:40:13 <pchadwick> carolbarrett: I can do Manila next week
21:40:19 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Kolla_CPL_Update
21:40:22 <pchadwick> (I have the slides already ;) )
21:40:31 <carolbarrett> pchadwick - thanks, will add you to the agenda!
21:40:49 <carolbarrett> I created an etherpad to capture the info so, others can refer to it also
21:40:52 <Rockyg> He'll most likely be at OpenStck SV.  I can corner him there if you need me to (rally ptl)
21:41:39 <carolbarrett> The focus for the team is around bare metal support, Ansible 2.0 and increasing ease of use for Operators
21:42:08 <carolbarrett> Longer term they are investigating, getting plans in place for Kubernetes support.
21:42:36 <Arkady_Kanevsky> I can do refstack next week
21:42:51 <carolbarrett> And just as a reminder, Kolla is targeting the ability to run OpenStack Services in Containers - which can simplify service management and upgrades
21:42:52 <Arkady_Kanevsky> Rally should be delay till I have PTL review
21:43:08 <carolbarrett> arkady_kanevsky: Thanks, will add that to the agenda
21:43:12 <Arkady_Kanevsky> +1 on kolla
21:44:19 <Arkady_Kanevsky> need to leave early today.
21:44:19 <carolbarrett> Any questions or add'l info from others on Kolla?
21:44:31 <carolbarrett> arkady_kanevsky: have a good week!
21:44:56 <pchadwick> No - makes sense
21:45:04 <carolbarrett> OK - I'll update the etherpad with new info as I get it. Am working on a Horizon update in a couple of weeks.
21:45:20 <carolbarrett> Shamail: Do you want to talk to Cinder?
21:45:45 <shamail> Sure!
21:46:15 <shamail> #link https://etherpad.openstack.org/p/PWG_Cinder_CPL_Update
21:46:39 <shamail> I have missed  a lot of Cinder meetings but I built this update using IRC logs and the interview I conducted for the Newton Design Series
21:46:55 <shamail> #link https://drive.google.com/open?id=0B_yCSDGnhIbzVi1HS0ZrVjJBb00
21:47:08 <shamail> The second link is to the final version of the Newton Design Series slides
21:47:09 <pchadwick> How is Cinder doing Active/Active?
21:47:13 <shamail> Oslo Tooz
21:47:51 <shamail> They are one of (if not THE) first projects to leverage the new DLM (distributed lock management) capabilities exposed via Oslo Tooz
21:48:18 <shamail> Effectively they are able to share lock information and prevent split brain
21:48:44 <shamail> The team is focused on providing summary messages
21:49:21 <shamail> Summary messages will improve the verbosity/context of messages from the Cinder services for operator consumption
21:49:34 <shamail> They have also been working on Replication V2 since Mitaka
21:49:53 <shamail> they devised a plan for the Replication V2 API during Mitaka and they are continuing forward with implementation in Newton
21:50:46 <shamail> They are also working on changing Third-party CI to adhere to the new recheck rules from the openstack-infra team
21:50:48 <KrishR> shamail: you're right about TOoz use - see https://review.openstack.org/#/c/185646/ - OSIC guys worked on this
21:50:48 <shamail> #link http://docs.openstack.org/infra/system-config/third_party.html#requirements
21:51:03 <shamail> Thanks for the link KrishR!
21:51:32 <shamail> And, as always, the first milestone had a lot of driver work since Cinder has a lot
21:51:33 <carolbarrett> Good stuff!
21:51:46 <shamail> a lot of them have made progress and others are working on 3rd party CI reporting
21:51:49 <shamail> Any questions?
21:52:09 <shamail> Thanks for your time!  That’s all I had carolbarrett
21:52:16 <carolbarrett> Sounds like a full agenda for Newton!
21:52:17 <pchadwick> I asked mine already
21:52:20 <pchadwick> ;)
21:52:31 <shamail> pchadwick: Great question
21:53:02 <pchadwick> I need to see how this interacts with the HA capability that one already gets with Pacemaker/Corosync
21:53:27 <carolbarrett> Next week we'll have updates on Manila and RefStack - if you want to get on the agenda for updates for other meeting dates, pls let me know!
21:53:36 <carolbarrett> pchadwick: +1
21:53:41 <carolbarrett> OK - let's move on
21:53:55 <carolbarrett> #topic OPNFV Update
21:54:03 <carolbarrett> There was an update in the Enterprise WG on OPNFV Summit. Lots of OpenStack Interest/Discussion.
21:54:04 <shamail> pchadwick: +1, I think it will be orthogonal but the relationship should be investigated
21:54:14 <carolbarrett> You can find notes here
21:54:20 <carolbarrett> #link https://etherpad.openstack.org/p/EWG_7_11_16
21:54:27 <carolbarrett> And here
21:54:29 <pchadwick> shamail: that is what I hope. Otherwise, I hate reinventing the wheel.
21:54:44 <carolbarrett> #link https://etherpad.openstack.org/p/EWG_6_27_16
21:55:31 <carolbarrett> Later this week, Shamail and I are talking with the ED at OPNFV to follow-up on our Austin discussion about how to flow requirements and resources to implement them between the 2 Communities
21:56:13 <carolbarrett> We'll bring an update from that discussion to this team next week. But wanted to let people know this is something still in the works
21:56:19 <carolbarrett> at least at the discussion phase
21:56:31 <carolbarrett> shamail: anything to add?
21:57:02 <shamail> nothing from me
21:57:07 <carolbarrett> OK - Last topic for today is Opens....anyone have anything to share?
21:57:11 <carolbarrett> #topic Opens
21:57:29 <pchadwick> nothing from me
21:57:49 <KrishR> nothing from me
21:57:59 <Rockyg> nada
21:58:13 <carolbarrett> OK - Thanks everyone, good meeting, type with you next week.
21:58:24 <pchadwick> ciao
21:58:30 <carolbarrett> #endmeeting