21:00:10 <carolbarrett> #startmeeting product working group
21:00:11 <openstack> Meeting started Mon Jul 18 21:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:15 <openstack> The meeting name has been set to 'product_working_group'
21:00:29 <carolbarrett> Hi - Who's here for the Product WG meeting?
21:00:38 <KrishR> o/
21:00:38 <cloudrancher> Hi
21:01:17 <Soyeh_McCarthy> Hello
21:01:43 <carolbarrett> You can find the agenda here
21:01:50 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:12 <carolbarrett> Let's start with Midcycle
21:02:19 <carolbarrett> #topic Midcycle Planning
21:03:01 <carolbarrett> Does everyone who needs it, have the info on the Ops Midcycle?
21:03:23 <pchadwick> hi there
21:03:30 <Arkady_Kanevsky> yes
21:03:33 <carolbarrett> Hi pete
21:03:44 <KrishR> carolbarrett: can you post the link
21:03:44 <shamail> hi everyone
21:03:46 <Soyeh_McCarthy> Carol, Is that the email that you sent?
21:04:01 <carolbarrett> Soyeh_McCarthy: yes
21:04:16 <Soyeh_McCarthy> on Friday?
21:04:33 <carolbarrett> Krishr: here it is
21:04:36 <carolbarrett> #link https://opsmidcyclenyc2016.eventbrite.com
21:04:43 <KrishR> carolbarrett: i don't see any agenda at https://etherpad.openstack.org/p/NYC-ops-meetup
21:05:09 <carolbarrett> I haven't see a call for topics. Has anyone else?
21:06:35 <carolbarrett> I'll reach out to TomF to see what the plan is
21:06:57 <carolbarrett> #action Carol Reachout to TomF to understand how call for sessions will work at the Ops Midcycle
21:07:21 <carolbarrett> As for our midcycle, the planning etherpad is here
21:07:29 <carolbarrett> #link https://etherpad.openstack.org/p/PWG_Newton_Midcycle_Planning
21:07:57 <carolbarrett> we'll have 1 day, would like feedback on agenda listed starting at line 23
21:09:40 <carolbarrett> Is everyone listed under attendees starting on line 7 planning on attending?
21:09:55 <KrishR> I'm still tentative
21:10:02 <Arkady_Kanevsky> I thought that already ranked topics that are at the bottom lines 92-101
21:10:19 <Arkady_Kanevsky> me too.
21:10:37 <Soyeh_McCarthy> I'm still tentative. I will know next week
21:10:44 <pchadwick> I plan to be there, but probably can't stay for the ops meetup.
21:10:47 <carolbarrett> Arkady_kanevsky: Yes, that was the brainstorm and now we're finalizing the agenda based upon a 1 day midcycle instead of 2 day
21:11:24 <carolbarrett> comments on the agenda on lines 23 - 30?
21:11:35 <pchadwick> I think we need to focus on items that *really* benefit from face-to-face discussion.
21:11:44 <shamail> pchadwick: +1
21:11:51 <Arkady_Kanevsky> +1
21:12:13 <Arkady_Kanevsky> OpenStack Strategy (this is following up from the Austin summit presentation where we suggested the PWG could be an advisor on "strategy")  - still #1 one in my view
21:12:18 <carolbarrett> Interesting - so folks will stay for our midcycle and through OpenStack East, then go?
21:12:20 <shamail> I think workflow, top user stories, openstack strategy were the top 3
21:12:21 <pchadwick> +1
21:12:39 <shamail> carolbarrett: I plan to stay through the ops-meetup
21:12:48 <pchadwick> I don't think anything on the list is higher than those.
21:12:51 <carolbarrett> Arkady_kanevsky: It's in the 3 agenda items listed
21:13:06 <Arkady_Kanevsky> user story pilot we should be able to do on email and then just finalize at mid-cycle
21:13:08 <carolbarrett> pchadwick: What are those? What is missing or un-needed on the agenda?
21:13:33 <Arkady_Kanevsky> <carolbarrett> correct
21:13:39 <carolbarrett> The 3 proposed topics are: Review Status of Top 5 User Story, Review User Story wokflow, OpenStack Strategy
21:13:54 <shamail> Sounds like a full day to me!
21:14:01 <Arkady_Kanevsky> that is 6 hours based on our estimates
21:14:04 <pchadwick> carolbarrett: Sorry - the three listed at lines 28-30 are all more important than anything starting at line 110
21:14:40 <Arkady_Kanevsky> Suggest we do others via email.
21:14:55 <Arkady_Kanevsky> <pchadwick> +1
21:15:05 <shamail> Arkady_Kanevsky: 6 hours + time for wrap up + breaks
21:15:12 <Arkady_Kanevsky> correct
21:15:26 <Arkady_Kanevsky> We can start early and finihs at 6:00
21:15:36 <Arkady_Kanevsky> that will give us extra hour.
21:15:36 <carolbarrett> I think it will be a full day too - if we cover those sooner than expected, do we want to have a topic we would use the cycles for?
21:16:00 <Arkady_Kanevsky> I am partial to Criteria for Prioritization
21:16:11 <carolbarrett> ok - other thoughts?
21:16:32 <pchadwick> arkady_kanevsky: +1
21:16:38 <shamail> Prioritization is a good one
21:16:40 <Arkady_Kanevsky> By I sugggest we have owner for each others and let him/her start email threat on it.
21:16:49 <Arkady_Kanevsky> So we can finalize results at the mid-cycle
21:17:03 <carolbarrett> Arkady_Kanvesky: I like the way you think!
21:17:11 <shamail> I don’t think we need roadmap/themes to be covered since we’ve gotten pretty good at coordinating that stuff over phone
21:17:28 <carolbarrett> Do we have volunteers to own the agenda item and bring other folks in, as needed, ahead of the midcycle?
21:17:38 <carolbarrett> shamail +1
21:17:46 <Arkady_Kanevsky> I will volunteer for Criteria for Prioritization
21:17:49 <shamail> I can do workflow
21:18:22 <carolbarrett> Shamail: Thanks
21:18:44 <carolbarrett> Arkady_Kanevsky: Thanks
21:19:00 <carolbarrett> who wants to lead OpenStack Strategy?
21:19:04 <carolbarrett> Kencjohnston: Are you on?
21:19:11 <shamail> hah, I was thinking of him too
21:19:17 <carolbarrett> LOL
21:19:34 <carolbarrett> I'll add him as tentative
21:19:39 <shamail> +1
21:19:48 <KrishR> +1
21:20:19 <Arkady_Kanevsky> that will teach him to miss a meeting
21:20:26 <carolbarrett> We can ask the User story Owners to prepare their updates. I think what we want them to cover is status, stakeholders involved, next steps and issues/help needed...?
21:20:38 <shamail> Sounds good
21:20:38 <pchadwick> Sounds good
21:20:41 <Arkady_Kanevsky> +1
21:20:43 <shamail> jinx.
21:21:11 <pchadwick> ;-)
21:21:12 <carolbarrett> #action Carol confirm with kencjonston he will lead OpenStack Strategy discussion at midcycle
21:21:19 <carolbarrett> Great  - think we've got a plan.
21:21:41 <carolbarrett> Arkady_kanevsky, Shamail,kencjohnston: If you want time in a team meeting ahead of the midcycle pls let me know.
21:21:50 <shamail> Thanks
21:21:59 <Arkady_Kanevsky> will do
21:22:04 <carolbarrett> Any other comments before we move on?
21:22:22 <carolbarrett> #topic CPL Updates
21:22:49 <carolbarrett> pchadwick & arkady_kanevsky volunteered to give updates today. Who wants to go first?
21:22:51 <pchadwick> Me first?
21:22:57 <pchadwick> Can you all go to:https://drive.google.com/open?id=0B7b_BEGDRsIcMjVZZnZSMG4ydHc
21:23:10 <carolbarrett> Thanks pchadwick
21:23:23 <carolbarrett> #link https://drive.google.com/file/d/0B7b_BEGDRsIcMjVZZnZSMG4ydHc/view
21:23:39 <pchadwick> This should be pretty self explanatory -
21:24:19 <pchadwick> Manila enables access to data from VMs using standard file sharing protocols.
21:24:31 <pchadwick> Think of it as Cinder for files instead of blocks.
21:25:00 <pchadwick> Hmm - slide look screwed up.
21:25:22 <pchadwick> the key areas of focus for Newton were share replication for disaster recovery
21:25:26 <cloudrancher> look ok to me
21:25:43 <carolbarrett> Can you say a few more words about Hierarchical port binding? What type of segmentation?
21:25:49 <carolbarrett> slides look ok to me too
21:25:58 <pchadwick> cloudrancher: Slide 3 is a duplicate of Slide 2 - not supposed to be
21:26:33 <pchadwick> I can say a bit - currently the protocols that Manila uses don't work well with VLAN.
21:27:00 <pchadwick> In other words, you can't put a file share on a VLAN - hierarchical port binding should enable that.
21:27:13 <carolbarrett> got it
21:27:41 <carolbarrett> On the Ocata HA focus, should we collaboration on that with our User story and other resources?
21:28:16 <pchadwick> Yes - I think the Manila team is looking a Tooz which is what Cinder is planning to use
21:28:35 <pchadwick> I need to figure out how that compares (+/-) with pacemaker/corosync approach.
21:29:06 <pchadwick> The other key part is getting the project integrated better for testing, etc.
21:29:29 <Arkady_Kanevsky> what about using the same storage for both manila and cinder?
21:29:32 <pchadwick> I have seen a reasonable amount of interest in Manila from customers and this will pick up even more with CephFS integration.
21:30:05 <pchadwick> arkady_kanevsky: I think that is doable, but it depends on the backend.
21:30:25 <Arkady_Kanevsky> of course. Say Ceph, Glance, NFS, ...
21:30:29 <pchadwick> There are even permutations like running Manila on top of Cinder,
21:30:45 <pchadwick> which could be running on top of Ceph via RBD. ;)
21:30:59 <Arkady_Kanevsky> sure
21:31:17 <pchadwick> I think that most array vendors either will have or already have different drivers for the three access modes.
21:31:26 <pchadwick> Certainly, that is true of Ceph.
21:31:34 <Arkady_Kanevsky> yes
21:31:45 <pchadwick> RBD vs Rados vs Ceph FS
21:32:09 <carolbarrett> Are there any actions we want to capture around this discussion?
21:32:09 <Arkady_Kanevsky> It would be ineteresting what would happen as they all report available capacity, etc.
21:32:33 <pchadwick> Yes - our Ceph team is planning to start testing that over the next few months.
21:32:46 <carolbarrett> arkday_kanevsky: it seems like we would want to make sure they respond with similar numbers
21:33:05 <carolbarrett> pchadwick: that will provide good info
21:33:08 <Arkady_Kanevsky> yes. I think we need to keep track of it and bring to cross functional team if we see issues
21:33:17 <pchadwick> +1
21:33:26 <pchadwick> Any other questions?
21:33:38 <Arkady_Kanevsky> non frm me
21:33:53 <Arkady_Kanevsky> refstack is https://docs.google.com/presentation/d/1JVmJ4KMhv7z5BfA-5z6Rt9YIx-z20HS3Ws6bJMH9HBU
21:34:00 * pchadwick goes to fix slide
21:34:04 <carolbarrett> pchadwick - when would be a good time for the next update
21:34:18 <carolbarrett> #action pchadwick fix manila slides
21:34:53 <pchadwick> carolbarrett: not sure that there will be much change ahead of Barcelona
21:34:57 <Arkady_Kanevsky> ready when you are
21:35:08 <carolbarrett> #action carol schedule pchadwick in this team for another update in the beginning of Sept
21:35:09 <carolbarrett> OK
21:35:21 <carolbarrett> arkady_kanevsky - pls take it away
21:35:22 <carolbarrett> arkady_kanevsky - pls take it away
21:35:23 <pchadwick> Arkady_kanevsky: Google telling me I don't have permission
21:35:44 <carolbarrett> #link https://docs.google.com/presentation/d/1JVmJ4KMhv7z5BfA-5z6Rt9YIx-z20HS3Ws6bJMH9HBU
21:35:52 <Arkady_Kanevsky> The slides are based on interview of Catherine and she reviewed and approved slides afterwords
21:36:11 <carolbarrett> I can open them OK
21:36:25 <Arkady_Kanevsky> give me your google name
21:36:28 <Arkady_Kanevsky> email
21:36:44 <pchadwick> chadwick.pete@gmail.com
21:37:11 <Arkady_Kanevsky> added
21:37:21 <Arkady_Kanevsky> will figure out how to open for all
21:37:39 <pchadwick> got it thanks
21:37:54 <Arkady_Kanevsky> Ferstack is toolset for interop.
21:38:14 <Arkady_Kanevsky> Collects test results and created manage DB for it.
21:38:24 <Arkady_Kanevsky> Used by devcore for LOGO program
21:38:57 <Arkady_Kanevsky> any comments?
21:39:32 <pchadwick> I assume that the other PTLs know this, but in case they don't how do they submit tests for this?
21:39:33 <KrishR> Arkady_kanevsky: can you add krishnan.raghuram@intel.com?
21:39:35 <carolbarrett> How are resources for the project
21:39:58 <Arkady_Kanevsky> Team has big ask to collect more results from users and vendors so they can hvae more dtata to be used for definoing LOGO tests
21:40:19 <Arkady_Kanevsky> KrishR - done
21:41:13 <KrishR> thx!
21:41:23 <pchadwick> Hmm - not sure I'm a big fan of extending DefCore
21:41:35 <Arkady_Kanevsky> last bullet on slide6 is my user story https://review.openstack.org/300057
21:42:07 <Arkady_Kanevsky> I can use a couple of core reviewers comments on it
21:42:23 <carolbarrett> Will look at it
21:42:32 <Arkady_Kanevsky> thank you.
21:42:36 <KrishR> carolbarrett: i can review Telemetry if time permits
21:42:59 <Arkady_Kanevsky> Where do we story pointers to these presentation?
21:43:28 <carolbarrett> Krishr: Can I put you on the agenda for next week?
21:43:35 <KrishR> ok
21:43:51 <Arkady_Kanevsky> I will miss next week - family in town
21:43:57 <carolbarrett> arkday_kanevsky: we capture them vi the meetbot #link command
21:44:01 <KrishR> # link https://etherpad.openstack.org/p/PWG_Telemetry_CPL_Update
21:44:07 <KrishR> if people want to see it offline
21:44:12 <carolbarrett> arkady_kanevsky: thanks for the heads-up
21:44:23 <carolbarrett> #link  https://etherpad.openstack.org/p/PWG_Telemetry_CPL_Update
21:44:30 <carolbarrett> Thanks KRishR
21:44:45 <pchadwick> i will likely miss next week due to team meetings.
21:44:54 <carolbarrett> Ok - thanks Arkady_Kanevsky and Pchadwick - any final questions for them?
21:45:40 <carolbarrett> #topic OPNFV Update
21:45:45 <carolbarrett> Shamail: Do you want to cover this one?
21:46:00 <shamail> Can you please do it? Ill add
21:46:05 <shamail> sory multitasking
21:46:08 <Arkady_Kanevsky> KrishR are oyu going to convert it into presentation that we can use for thge summit?
21:46:10 <carolbarrett> OK
21:46:27 <shamail> Thanks
21:47:11 <carolbarrett> Shamail and I had a call with Heather Kirksey - the Executive Director for OPNFV
21:47:28 <carolbarrett> This was a follow-up for our initial discussion in Austin and their Summit in Berlin
21:47:58 <carolbarrett> The focus of these discussions is how to integrate/align requirements gathering/execution across the 2 organizations
21:48:18 <carolbarrett> Heather told us that OPNFV is starting a work group similar to ours, called PolStar.
21:49:55 <carolbarrett> When the vision/charter around teh WG is formed, Heather will forward the info to us.
21:50:17 <carolbarrett> We were thinking it would make sense for 1 or 2 of us to join that team to see what we can learn about what we're doing as well as how we can work together.
21:50:27 <carolbarrett> Expect to see that info in the next week or 2.
21:50:37 <carolbarrett> Shamail: Anything to add?
21:50:46 <pchadwick> OK - it would likely be Ron Nunan from SUSE as he is working on OPNFV for us.
21:50:51 <Arkady_Kanevsky> any user stories from them?
21:51:00 <shamail> No, that’s about it.  The PWG workflow was presented at the summit in Berlin but no immediate questions were raised.
21:51:15 <carolbarrett> pchadwick: that would be good to have him be eyes and ears for us
21:51:26 <shamail> Not yet Arkady_Kanevsky, we are hoping to work with the PolStar team on those.
21:51:32 <Arkady_Kanevsky> +1
21:51:33 <carolbarrett> pchadwick: can you pass this info along to Ron?
21:51:45 <pchadwick> carolbarrett: absolutely
21:52:02 <carolbarrett> arkday_kanevsky: I haven't see anything from them yet. I know they are working blueprints and implementation within projects
21:52:31 <carolbarrett> #action pchadwick to talk with Ron Nunan about the startup of PolStar in OPNFV
21:52:48 <Arkady_Kanevsky> concern that they are circumventing user story process and driving projects directly...
21:52:53 <carolbarrett> Any questions?
21:53:25 <Arkady_Kanevsky> nope
21:53:32 <carolbarrett> arkady_kanevsky: I think many of their requirements are local to neutron and/or nova....
21:53:54 <carolbarrett> Ok - last topic for today - opens
21:53:57 <carolbarrett> #topic Opens
21:54:08 <carolbarrett> anyone have info to share or questions to ask?
21:54:09 <Arkady_Kanevsky> that is fine. But once they become cross projects there are issues
21:54:29 <Arkady_Kanevsky> We have 5 open user stories.
21:54:44 <Arkady_Kanevsky> Lets' try to close all of them for barcelona.
21:55:11 <carolbarrett> arkady_kanevsky +1
21:55:18 <Arkady_Kanevsky> Have we document where to generate gap analysis and what is the format for that?
21:55:53 <shamail> Arkady_Kanevsky: I did add a new section to the wiki to explain implementation plan and gap analysis more
21:56:08 <Arkady_Kanevsky> Thanks.
21:56:11 <carolbarrett> shamail: good stuff - thanks
21:56:13 <shamail> In general, there isn’t a pre-defined format as it will be up to the teams to use whatever format makes it easiest for them
21:56:16 <shamail> Adding link..
21:56:31 <carolbarrett> arkady_kanevsky: If you need more info, pls send Qs on mail list
21:56:43 <Arkady_Kanevsky> OK
21:56:43 <shamail> #link https://wiki.openstack.org/wiki/ProductTeam/User_Stories#Gap_and_Overlap_Analysis
21:57:03 <carolbarrett> Anything else?
21:57:45 <Arkady_Kanevsky> Shamail for gap analysis do we have a template, simsilar to user story to fill for it?
21:57:58 <carolbarrett> ok folks, that's all for today. Have a great week!
21:58:02 <shamail> We don’t
21:58:08 <shamail> Its up to the user story team
21:58:21 <pchadwick> ciao
21:58:22 <Arkady_Kanevsky> Do we submit gap analysis as user story, blueprint or some other define entity?
21:58:36 <KrishR> bye
21:58:43 <Arkady_Kanevsky> I will take it offline
21:58:49 <Arkady_Kanevsky> Have a good day
21:58:54 <carolbarrett> #endmeeting