21:00:25 <carolbarrett> #startmeeting product working group
21:00:26 <openstack> Meeting started Mon Aug  1 21:00:25 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <openstack> The meeting name has been set to 'product_working_group'
21:00:42 <KrishR> o/
21:00:46 <carolbarrett> Hi Folks who is here for the product working group meeting?
21:00:51 <KrishR> o/
21:00:52 <carolbarrett> You can find the agenda here:
21:00:54 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:01:01 <carolbarrett> Hi KrishR
21:01:12 <KrishR> Hi carolbarrett:
21:01:23 * MarkBaker here
21:01:35 <carolbarrett> Hi Markbaker
21:02:03 <Soyeh> Hi Soyeh is here!'
21:02:25 <carolbarrett> Hi Soyeh
21:02:26 <shamail> Hi everyone
21:02:31 <carolbarrett> Hi Shamail
21:02:32 <leong> o/
21:02:36 <carolbarrett> Hi Leong
21:02:42 <Soyeh> hi
21:02:44 <carolbarrett> Let's get started
21:02:56 <carolbarrett> #topic Upcoming meetings
21:03:38 <carolbarrett> There's a typo on the agenda - it should say 8/8 OpenStack Silicon Valley not 8/1...
21:04:14 <carolbarrett> Is anyone on this call going to be heading to OpenStack Silicon valley and unable to make this call on 8/8?
21:04:45 <leong> i'm not going to OpenStack silicon vallye
21:05:05 <KrishR> me neither
21:05:13 <shamail> Not going to OSSV either
21:05:17 <pchadwick> I'm passing as well
21:05:19 <carolbarrett> I will take silence to mean not going and can attend..
21:05:26 <carolbarrett> Great - we'll keep next week's meeting
21:05:33 <MarkBaker> I'm not.
21:05:44 <carolbarrett> Then we will cancel 8/22 for our Midcycle
21:05:55 <carolbarrett> and Cancel  9/5 due to Labor Day holiday in US
21:06:03 <carolbarrett> Any questions on any of that?
21:06:11 <shamail> carolbarrett: +1
21:06:29 <carolbarrett> Next topic...
21:06:35 <carolbarrett> #topic Midcycle Planning
21:06:36 <MarkBaker> carolbarrett, so we will not meet in NYC 8/22?
21:06:46 <carolbarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team#August_1.2C_2016_Product_Team_Meeting_Agenda
21:06:54 * MarkBaker missed last weeks call
21:07:04 <pchadwick> I think carol means that we won't have the call, instead we meet
21:07:08 <carolbarrett> Markbaker: We will meet in NY for our midcycle, but will not have this call on that day
21:07:14 <carolbarrett> pchadwick +1
21:07:19 <MarkBaker> carolbarrett, got you - thanks
21:07:49 <carolbarrett> If you'd click on the etherpad link above, i'd like to talk through the agenda and prework
21:07:52 <carolbarrett> and timing
21:08:06 <carolbarrett> pls look at lines 24-39 in the etherpad
21:08:51 <carolbarrett> If you're planning to attend pls add your info to the attendee section starting at linke 3
21:09:19 <carolbarrett> meant: line 3
21:09:54 <carolbarrett> User Story owners: is 2 hrs enough time for review and discussion?
21:09:59 <Soyeh> I removed my name, as I won't be able to join you
21:10:10 <pchadwick> carolbarrett: should be
21:10:22 <carolbarrett> soyeh: bummer
21:10:46 <carolbarrett> OK - we'll plan for 2 hrs on that topic
21:11:04 <carolbarrett> for User Story Workflow - does 2 hrs seem like enough time?
21:11:20 <carolbarrett> shamail: What do you think?
21:13:05 <shamail> I think 2 hours is plenty
21:13:16 <carolbarrett> too much?
21:13:20 <shamail> It will mainly be a review
21:13:24 <shamail> Yeah,
21:13:39 <carolbarrett> OK - we'll keep that at 2 hrs
21:13:48 <shamail> I would recommend starting with 1.5 hours and we can discuss any open questions later
21:13:52 <carolbarrett> I don't think kenny is here, will check with him offline to validate time.
21:14:03 <carolbarrett> Shamail: Will there be pre-work for the topic?
21:14:04 <shamail> Sounds good
21:14:18 <carolbarrett> pchadwick, KrishR: will there be prework for your user stories?
21:14:31 <shamail> I would like to encourage people to read the wiki as a primer
21:14:36 <pchadwick> Other than reading the story, no.
21:14:38 <shamail> So that we can focus on Q&A
21:15:11 <carolbarrett> shamail, pchadwick: Can you send an email on the ML for this and include link to most recent info?
21:15:24 <pchadwick> +1
21:15:32 <carolbarrett> Thank you
21:15:40 <shamail> #link https://wiki.openstack.org/wiki/ProductTeam/User_Stories
21:15:47 <shamail> Please read before the midcycle
21:15:58 <carolbarrett> #action shamail, pchadwick send email to ML for midcycle prework directions and links
21:16:00 <shamail> carolbarrett: +1, will do
21:16:18 <carolbarrett> I see lots of activitiy in the etherpad on the Additional Topic
21:16:51 <carolbarrett> Pls add thoughts/questions on this, but we'll hold off on discussion til the 22nd - OK?
21:17:22 <carolbarrett> Are folks interested in going to dinner that night?
21:17:33 <shamail> I would be carolbarrett
21:17:35 <leong> fine with me :-)
21:18:30 <carolbarrett> OK - I've added a section in the etherpad for dinner plans. Pls add your name there and we'll figure out where to go
21:18:54 <carolbarrett> Anything else on midcycle planning?
21:19:44 <pchadwick> carolbarrett: assume we are talking about Monday night?
21:19:53 <carolbarrett> pchadwick: yes
21:20:19 <pchadwick> lol - was paying attention to the ether pad and missed the original comment.
21:21:12 <carolbarrett> markbaker: are you flying in on Sunday? or Monday?
21:21:44 <carolbarrett> Let's move along...
21:21:58 <carolbarrett> #topic Ops Midcycle
21:22:06 <carolbarrett> Has anyone seen an agenda for this yet?
21:22:35 <MarkBaker> carolbarrett, Sun, but I will make it as late as I can to minimise disruption to Sun
21:22:49 <KrishR> #link https://etherpad.openstack.org/p/NYC-ops-meetup
21:22:50 <shamail> Not yet, I emailed Tom and Matt J. today
21:22:56 <carolbarrett> markbaker: understand, dinner will be Monday night
21:23:02 <KrishR> link has the brainstorming
21:23:03 <carolbarrett> shamail: Thanks.
21:23:27 <carolbarrett> I will try to make the 7AM Pacific Ops Meeting on Tuesday
21:23:42 <carolbarrett> We'll revisit this one next week
21:23:45 <carolbarrett> moving on
21:23:53 <carolbarrett> #topic CPL Updates
21:24:17 <carolbarrett> KrishR had volunteered to provide a Telemetry update
21:24:25 <carolbarrett> KrishR take it away!
21:24:39 <KrishR> #link https://etherpad.openstack.org/p/PWG_Telemetry_CPL_Update
21:24:57 <KrishR> summary is not much work on Ceilometer itself
21:25:07 <MarkBaker> carolbarrett, in that case count me in
21:25:10 <KrishR> focus has been on Aodh and the new Panko project
21:25:20 <KrishR> Panko = events split-out
21:25:25 <carolbarrett> markbaker: OK
21:26:07 <KrishR> Leong ahs been doing some additional work on scaling exercises using Gnocchi
21:27:00 <pchadwick> What is the rationale for splitting out events from Ceilometer?
21:27:08 <KrishR> we'll need more work in Ceilometer itself next cycle to redirect events to Panko
21:27:13 <leong> to be precise... (not me) the ceilometer core developers are working on some gnocchi integration in my lab :-)
21:27:56 <KrishR> don't know the full explanation, but the telemetry team has been on the path of breaking up into multiple modules
21:28:00 <KrishR> to help scaling
21:28:58 <pchadwick> So, referring to line 14 in the etherpad, if alarms, events, and samples are pulled out of Ceilometer,
21:29:02 <pchadwick> what's left?
21:29:22 <KrishR> they've even stopped regular meetings....it's just collaboration on the irc channel
21:30:04 <KrishR> pchadwick: i guess Ceilometer becomes a "re-director" of sorts?
21:30:36 <pchadwick> krishr: sounds less than interesting from a customer value.
21:30:45 <shamail> I think it's just to facilitate collection of metrics?  What you do with them and how you store them is being broken out (from collection and each other)?
21:31:05 <KrishR> shamail: yes, that's correct
21:31:36 <KrishR> ceilometer will continue to do the polling
21:31:45 <pchadwick> OK - so Ceilometer collects and then hands off to others.
21:32:05 <KrishR> yes
21:32:14 <shamail> +1
21:32:25 <pchadwick> OK - thanks.
21:32:52 <KrishR> ahy other questions? dont have much more to add
21:33:26 <pchadwick> krishr: not from me - thanks.
21:33:48 <carolbarrett> good discussion
21:34:01 <carolbarrett> Anyone want to volunteer for next week?
21:35:11 <carolbarrett> don't all shout at once! :)
21:35:24 <shamail> Lol
21:35:36 <carolbarrett> We'll come back to that next week....
21:36:03 <carolbarrett> #topic Project Navigator/Show which Distros contain which projects
21:36:15 <carolbarrett> shamail: Do you want to take this one?
21:36:15 <pchadwick> carolbarrett: I already had my 15 minutes of fame.
21:36:42 <shamail> Sure
21:37:00 <MarkBaker> carolbarrett, I cuod have a stab at Designate if you like
21:37:00 <shamail> Can you please add the link from the agenda as well?
21:37:19 <carolbarrett> #link https://etherpad.openstack.org/p/r.0749ed9d8a670d65c267145350accefa
21:37:22 <shamail> Thanks
21:37:40 <carolbarrett> MarkBaker: Thanks - will put you on the agenda for next week.
21:38:13 <shamail> We had an ops-tag meeting at the Austin Summit and one of the tags that we discussed adding was to show which services are available in which distributions
21:38:55 <pchadwick> Is the etherpad locked?
21:39:13 <shamail> (E.g. list whether or not a package is available for a particular distribution and its status (packaged but not officially supported, experimental, fully supported by the Distro provider, etc.))
21:39:20 <carolbarrett> pchadwick: It works for me
21:39:23 <shamail> This is a read only version of the etherpad
21:39:48 <shamail> The read/write version is available from the ops-midcycle page (under Austin)
21:40:15 <shamail> We (the ops-tag team) thinks this data would be valuable and make a great addition to the project navigator
21:40:59 <shamail> However, this content isn't published in a centralized location so I wanted to ask whether your teams could help us gather and maintain this information?
21:41:31 <shamail> I would be glad to start an email thread with those that are interested in learning more
21:41:32 <MarkBaker> shamail, of course
21:41:46 <shamail> Thanks MarkBaker
21:41:54 <pchadwick> shamail: yes
21:42:05 <MarkBaker> shamail, I would add that in our case included does not necessarily mean supported
21:42:09 <shamail> Thanks!
21:42:25 <MarkBaker> so you may need to be a little more precise in syntax used
21:42:33 <shamail> Exactly MarkBaker, we had the DEB packaging team with us and we discussed that at length
21:42:54 <shamail> We definitely need to work on possibly statuses
21:43:15 <MarkBaker> i.e Murano is packaged and avaiilable in Ubuntu but we won't support it under SLA
21:43:25 <shamail> I'll start a separate thread and try to identify participants from additional distributions too
21:43:50 <shamail> We also have to deal with "tech preview" as well
21:43:58 <pchadwick> For SUSE, there are likely 4: Deployed supported, deployed tech preview, Supported, packaged
21:44:03 * MarkBaker chuckles
21:44:55 <shamail> Supported and Deploy Support were the two we had a hard time distinguishing eloquently
21:45:06 <shamail> Thanks MarkBaker and pchadwick
21:45:18 <MarkBaker> and "supported if you pay enough or super strategic but pls don't tell anyone else"
21:45:26 <shamail> I think that concludes this Topic for now carolbarrett!
21:45:35 <shamail> Lol MarkBaker
21:45:52 <carolbarrett> Thanks Shamail
21:46:02 <pchadwick> Markbaker; +1
21:46:24 <carolbarrett> #topic Opns
21:46:26 <carolbarrett> next up is Opens - I'll come back to the Membership topic if we have no opens
21:46:29 <carolbarrett> #topic Opens
21:46:38 * MarkBaker has a topic
21:46:41 <carolbarrett> anyone have something to share
21:46:46 * shamail does too
21:46:47 <carolbarrett> MarkBaker - go ahead
21:47:31 <carolbarrett> shamail - you'll be next
21:47:36 <MarkBaker> so as many of you know, IBM has launched an Interop challenge with the goal of building a set of workload templates that work cross distribution
21:48:06 <pchadwick> yep
21:48:28 <MarkBaker> The basis of this challenge is to try and address a user need to have workload portability across distributions
21:49:02 <MarkBaker> this is a noble goal and I'd like to ask the group if we can write a user journey to articulate this need
21:49:30 <MarkBaker> and set a roadmap for the likely milestones beyond the initial challenge
21:49:38 <MarkBaker> thoughts?
21:50:01 <shamail> MarkBaker: +1, capturing the multiple layers of considerations for true interop/portability would be good to document/discuss
21:50:01 <pchadwick> I haven't heard anything since the initial contact from IBM ~a month ago.
21:50:02 <MarkBaker> if anyone needs background on the initiative then happy to provide link to slides etc..
21:50:14 <pchadwick> Has there been follow up?
21:50:27 <shamail> pchadwick: there was a poll, first meeting is supposed to be this Wednesday at 10A EST
21:50:32 <MarkBaker> pchadwick, not yet
21:50:43 <pchadwick> shamail: did not see the poll.
21:50:46 <shamail> 1400 UTC
21:50:52 <shamail> I can forward the invite if you didn't get it
21:51:11 <shamail> Anyone else need it?
21:51:16 <pchadwick> Thanks - but I have a conflict then.
21:51:24 <leong> pls forward that to me as well shamail, thanks!
21:51:26 <pchadwick> I'll if we can cover.
21:51:27 <shamail> Np
21:51:45 <pchadwick> Please forward - I'll see if we can cover.
21:51:48 <MarkBaker> whilst it is possible that driving the interop is beyond the scope of product working group, it would be helpful for us to define the problem at least
21:51:49 <shamail> Will do leong
21:51:53 <shamail> Sure thing pchadwick
21:51:53 <MarkBaker> problem/need
21:52:10 <carolbarrett> MarkBaker +1
21:52:16 <leong> +1 markbaker
21:52:20 <shamail> +1
21:52:27 <carolbarrett> Anything else on this one?
21:52:42 <leong> AR: to create a user story on distro interop?
21:52:48 <MarkBaker> I am happy to work on it, I guess I am looking for help from anyone else interested
21:53:07 <pchadwick> markbaker: I can help
21:53:33 <shamail> I'll help MarkBaker, +1 to Leong's suggested AR 🤓
21:53:33 <MarkBaker> pchadwick, thanks!
21:53:43 <MarkBaker> :)
21:53:46 <carolbarrett> #action Mark Baker, Shamail, others Create a user story on distro interop
21:54:07 <carolbarrett> We can touch base on this at the midcycle, maybe over lunch or...
21:54:16 <carolbarrett> Shamail: Go with your open
21:54:28 <shamail> Can someone get me tickets to Hamilton?
21:54:31 <shamail> Sorry, I digress.
21:54:48 <shamail> I wanted to share a discussion from the dev ML
21:54:51 <carolbarrett> +1
21:54:56 <shamail> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/100558.html
21:55:23 <shamail> There is a topic about setting community/project wide goals by the TC moving forward
21:55:35 <leong> i saw that email thread as well
21:55:42 <MarkBaker> +1
21:55:47 <shamail> The initial ones are things that are already in flight but future ones may encompass multiple release efforts
21:55:55 * MarkBaker didn't really understand it tho
21:56:05 <shamail> I suggested possibly creating user stories or using the tracker to track progress on the goals
21:56:39 <shamail> There seems to be a good opportunity for alignment and for the PWG and SWG to share documentation and tracking techniques :)
21:56:49 <pchadwick> it seems that the comment at the end is that our user stories don't have a very good "definition of done"
21:57:15 <pchadwick> Can we get (or does it make sense) to get the developers to feed that into the stories.
21:57:16 <shamail> I would agree with that pchadwick
21:57:38 <shamail> We have usage scenarios but they are looking for implementation-level "done" qualifiers
21:58:00 <leong> +!
21:58:02 <leong> +1
21:58:18 <shamail> In our current workflow, that fits into the implementation plan but that's a good question pchadwick
21:58:22 <leong> also no "timebound"
21:58:40 <pchadwick> shamail, I'm not saying it makes sense
21:58:43 <shamail> What is stopping us from including a final "read out" of the proposed plan and acceptance criteria
21:58:46 <leong> a goal will not be a goal if there is no timebound associated :)
21:58:54 <shamail> leong: +1
21:59:09 <pchadwick> There is a balance between having something that is readable/usable by the broader community
21:59:18 <pchadwick> And something that can be put on a Trello card.
21:59:23 <shamail> The user stories could simply be another artifact describing a goal, the tracker might still be useful though
22:00:02 <shamail> True pchadwick
22:00:33 <shamail> I just wanted to share the discussion/topic here in case anyone has a good intersection (or not) between stories and goals
22:01:10 <shamail> An open-ended open-topic :)
22:01:14 <shamail> That's all I had
22:01:37 <carolbarrett> We can talk about this as part of the workflow topic at our midcycle
22:01:47 <shamail> +1
22:01:52 <carolbarrett> We're at the top of the hour - thanks everyone for joining
22:02:04 <carolbarrett> #endmeeting