21:00:17 <CarolBarrett> #startmeeting product_working_group
21:00:18 <openstack> Meeting started Mon Sep 19 21:00:17 2016 UTC and is due to finish in 60 minutes.  The chair is CarolBarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:22 <openstack> The meeting name has been set to 'product_working_group'
21:00:44 <CarolBarrett> Hi - Who's here for the Product WG meeting?
21:01:12 <CarolBarrett> you can find the agenda here
21:01:21 <CarolBarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team#September_19th.2C_2016_Product_Team_Meeting_Agenda
21:01:49 <Arkady_Kanevsky> hello
21:02:07 <KrishR> hi
21:02:25 <sgordon> o/
21:02:54 <CarolBarrett> Hi sgordon - thanks for joining!
21:02:56 * shamail sneaks in
21:03:20 <CarolBarrett> Let's get going
21:03:33 <CarolBarrett> #topic 9/26 meeting leadership
21:03:59 <CarolBarrett> I'm on vacation next week and won't be able to lead this meeting. Any volunteers to take that on?
21:04:44 <MeganR> *was lurking
21:05:29 <CarolBarrett> If there aren't any volunteers then I'll cancel the meeting
21:05:35 <Arkady_Kanevsky> cannot  commit to run call next week
21:05:42 <rocky_g> o/
21:05:57 <Arkady_Kanevsky> do we need to cover sdometing next week for summit?
21:06:00 <shamail> Im out as well.
21:06:22 <CarolBarrett> arkady: I don't think there is anything pressing
21:06:36 <Arkady_Kanevsky> then lets cancel it.
21:06:42 <MeganR> it might be best to cancel - I won't be able to attend, and sounds as if there are several "key" people out next week (certainly not including myself)
21:06:46 <CarolBarrett> sounds good
21:06:55 <CarolBarrett> #action Carol to cancel next week's team meeting
21:07:11 <CarolBarrett> #topic Barcelona Session Planning
21:07:26 <CarolBarrett> #link https://etherpad.openstack.org/p/PWG_Session_Oct16_BCN
21:07:49 <CarolBarrett> Shamail submitted our requests for Bof and working session.
21:07:58 <CarolBarrett> We should hear back around 10/3
21:08:13 <CarolBarrett> We're using the etherpad to start the planning now
21:08:35 <CarolBarrett> Pls add your thoughts on agenda items
21:08:48 <CarolBarrett> And +1/-1 topics too
21:09:04 <Arkady_Kanevsky> what about items we droped from midcycle due to only one day duration?
21:09:04 <shamail> Also, please keep in mind that we requested 3 hours
21:09:17 <shamail> so realistically, we can probably focus on 2-3 topics
21:09:27 <Arkady_Kanevsky> OK
21:09:42 <CarolBarrett> arkady: Pls go ahead and add topics you think we should consider. Time will be tight as always
21:09:45 <Arkady_Kanevsky> also ocata is short cycle
21:09:54 <Arkady_Kanevsky> let's be realistic what we can do during it
21:09:55 <CarolBarrett> how convienent
21:10:12 <shamail> lol
21:10:14 <CarolBarrett> good point
21:10:37 <shamail> Arkady_Kanevsky: +1
21:10:42 <CarolBarrett> From the roadmap updates, seems like many projects are planning to focus on stabilization for ocata
21:11:30 <CarolBarrett> any questions or discussion on this?
21:11:51 <Arkady_Kanevsky> nope - agree
21:11:56 <CarolBarrett> I think we should lockdown our plan in our meeting on the 10th
21:12:20 <CarolBarrett> OK - moving on...
21:12:30 <CarolBarrett> #topic User Stories
21:13:05 <CarolBarrett> The focus of this agenda item is to understand Barcelona plans and support needed for each user story
21:13:27 <CarolBarrett> kencjohnston - are you here?
21:14:01 <CarolBarrett> I think Pete is on vacation and Leong is traveling
21:14:14 <CarolBarrett> Shamail - Can you talk to Capacity Management?
21:14:23 <shamail> The capacity management user story will not have much to do at this summit except for sharing the updated user story (based on findings from the UX study on quotas) and checking on the status of related items (e.g. shelfed instance accounting, nested quotas, delimiter)
21:14:40 <shamail> Will essentially firm up user story before summit and monitor whether it is in-line with community needs at summit
21:14:59 <CarolBarrett> Sounds good - do you need any help?
21:15:13 <shamail> I will also try speaking with people to see if others are interested in helping to move it forward (Scientific community has an interest)
21:15:24 <shamail> Good for now, thanks though CarolBarrett
21:15:38 <CarolBarrett> OK
21:15:40 <MadhuKashyap> Shamail, I am working on some edits to capacity management based on some NFV requirements. NFV community has an interest.
21:16:00 <Arkady_Kanevsky> When will workflow go from draft to solid?
21:16:07 <shamail> Thanks MadhuKashyap, I’ll keep an eye out for them and reach out to you if I need to understand anything.
21:16:08 <MadhuKashyap> It would be good to discuss with NFV community at the summit.
21:16:22 <shamail> Arkady_Kanevsky: This story has no resources committed so it can’t move until then
21:16:29 <shamail> MadhuKashyap: +1
21:16:42 <MadhuKashyap> Thanks
21:16:46 <shamail> I’ll email you to see what will be the best way to do that
21:17:04 <MadhuKashyap> ok. I will also add it to the etherpad.
21:17:05 <Arkady_Kanevsky> OK. on capacity management can I get a few reviews for https://review.openstack.org/#/c/358888/?
21:17:31 <MadhuKashyap> working on the reviews.
21:18:23 <CarolBarrett> All sounds good
21:18:34 <CarolBarrett> KrishR - can you cover fleet management
21:19:09 <KrishR> CarolBarrett: I can, though it's gone down in priority in OSIC
21:19:30 <Arkady_Kanevsky> OSIC?
21:19:36 <CarolBarrett> Why don't you give folks an update on that and the plans for Barcelona
21:20:36 <sgordon> Arkady_Kanevsky, https://osic.org/
21:20:36 <KrishR> now, or later?
21:20:42 <CarolBarrett> now pls
21:21:10 <KrishR> Plan for barcelona is to do a MVP of Inventory with 2-3 audit/remediation workflows
21:21:18 <KrishR> one of the workflows is the OSA Security Role
21:21:42 <KrishR> remaining workflows still TBD
21:21:57 <KrishR> there is a session under Ops Tools on Tue. 10/25
21:22:28 <CarolBarrett> what's an MVP?
21:22:30 <Arkady_Kanevsky> Can use a few reviews for fleet management PR - https://review.openstack.org/#/c/358781/ ?
21:22:32 <KrishR> beyond that, I'm a bit out of the loop as Rackspace is doing their own internal planning to decide next steps
21:22:50 <KrishR> MVP=Minimal Viable Product
21:23:52 <CarolBarrett> Thanks
21:24:17 <KrishR> i can check with Kenny later this week to get an update from Rackspace
21:24:18 <CarolBarrett> moving forward, will you continue to lead this team?
21:24:44 <KrishR> am looking for someone else to step up, until then I'm the lead
21:25:14 <CarolBarrett> OK, thanks for making sure we get a good hand-off
21:25:25 <shamail> +1
21:25:34 <Arkady_Kanevsky> +1
21:25:51 <rocky_g> +1
21:26:07 <CarolBarrett> Do you need any help with your Summit plans?
21:26:50 <KrishR> CarolBarrett: was that question for me?
21:26:53 <CarolBarrett> Yes
21:27:02 <KrishR> I wont be at the Summit
21:27:12 <CarolBarrett> Wondering if you need any help with the MVP, etc.
21:27:28 <KrishR> I'm going to ask Kenny if he can help
21:27:41 <Arkady_Kanevsky> who is going to present the status of fleet at the summit?
21:28:08 <KrishR> during the Product WG meeting?
21:28:13 <Arkady_Kanevsky> yes
21:28:36 <KrishR> I'm hoping it will be Kenny, otherwise I'll have to dial in
21:28:37 <Arkady_Kanevsky> Kenny?
21:28:44 <Arkady_Kanevsky> +1
21:29:32 <CarolBarrett> OK
21:29:53 <CarolBarrett> Anything else on User Story plans for Barcelona from anyone?
21:31:14 <CarolBarrett> #topic CPL updates
21:31:29 <CarolBarrett> Arkady_kanevsky: Are you ready for Rally update?
21:31:35 <Arkady_Kanevsky> yes
21:32:10 <Arkady_Kanevsky> biggest chunk of work for newton was refactoring plugins
21:32:51 <Arkady_Kanevsky> The goal is for Ocata to split rally into frameowrk and plugins repos
21:32:59 <Arkady_Kanevsky> https://docs.google.com/presentation/d/1plwLpHm4PckQLvQra8yvyWzAyQz2SWsWWzZ36NiyT-A/edit#slide=id.p4
21:33:10 <Arkady_Kanevsky> addintion to case scenarios.
21:33:33 <Arkady_Kanevsky> Plugins for Magnum, Monasco, Senlin, Watcher
21:33:46 <rocky_g> that's pretty cool.  Much better architecture
21:33:51 <Arkady_Kanevsky> More cleanup, more scalability
21:34:13 <Arkady_Kanevsky> adding steraming algorithms and finally support for multiple API versions
21:34:28 <Arkady_Kanevsky> The last one is critical for upgrades and microversions support
21:34:47 <CarolBarrett> Good!
21:35:00 <Arkady_Kanevsky> For Ocata move to have Rally as a service as part of deployment for multuple distros and vendors
21:35:05 <shamail> Very nice
21:35:10 <CarolBarrett> What does that mean?
21:35:12 <Arkady_Kanevsky> HA testsing and reliability
21:35:15 <CarolBarrett> RaaS?
21:35:44 <rocky_g> Raas and RAS
21:35:52 <rocky_g> all inone ;-)
21:35:53 <CarolBarrett> LOL
21:36:05 <Arkady_Kanevsky> Rally is part of deployment so you can validate (tempest) before and after upgrade, or new deployments,
21:36:40 <Arkady_Kanevsky> You can have rally service run independent from OpenStack deployments and compare rally results between different deplpoyments
21:36:59 <CarolBarrett> That sounds like a good benefit
21:37:04 <Arkady_Kanevsky> both for validation and for prefromance and for specific scenario testing
21:37:40 <Arkady_Kanevsky> Can be extended to use not just keystone but other identity management.
21:38:13 <Arkady_Kanevsky> Longer term to be able to test pure kubernetes with or without opentstack deployment.
21:38:33 <Arkady_Kanevsky> Rally is very ambitions project...
21:38:54 <Arkady_Kanevsky> any other questoins?
21:40:02 <Arkady_Kanevsky> I am also talking to them about configuration capture. That is one of the reasons I am proposing separate project to capture SW and HW config. Rally needs it as well as refstack
21:40:13 <Arkady_Kanevsky> Done
21:40:13 <CarolBarrett> Will we be able to get data on Rally usage moving forward?
21:40:47 <Arkady_Kanevsky> I will try. I thought that is part of questionare that fgoundation send out.
21:41:05 <Arkady_Kanevsky> Heidi is in a better position to answer it. I will ping her
21:41:22 <CarolBarrett> I think they are doing a light survey this time.
21:41:36 <CarolBarrett> Would be good to know if people actually use Rally to validate their installation...
21:41:42 <Arkady_Kanevsky> will check with Heidi
21:41:45 <rocky_g> ++
21:41:57 <CarolBarrett> Thanks
21:42:07 <CarolBarrett> Anyone else have anything for Arkady?
21:43:15 <CarolBarrett> OK - Let's move on..
21:43:28 <CarolBarrett> #topic Community Roadmap
21:43:33 <CarolBarrett> Shamail - Can you take this?
21:43:40 <shamail> Sure
21:43:59 <shamail> The community roadmap team is making great progress and we have collected the majority of the data needed for this next release
21:44:17 <shamail> we are waiting confirmation on content from about 3-4 projects and still working to collect data on another 4-5
21:44:36 <shamail> We believe we will be in a good condition to review the draft of the roadmap by this Thursday
21:45:07 <rocky_g> Yay!
21:45:22 <shamail> We have setup a call at 1700UTC on 9/22, use this link to join if interested: https://zoom.us/j/272384703
21:45:59 <shamail> Also, there will be a marketing preview of the Newton release on 9/27
21:46:16 <shamail> Do you all have details (sent out to marketing ML) or should I send it to our ML?
21:47:02 <MadhuKashyap> Please send it out to the PWG ML.
21:47:04 <shamail> That’s all I had
21:47:09 <shamail> Okay MadhuKashyap
21:47:23 <rocky_g> For the summit presentation of roadmmap,  please use my speaker slot for someone who has been working this topic.
21:48:03 <shamail> Alright rocky_g, thanks for the update
21:48:08 <CarolBarrett> +1
21:48:16 <Arkady_Kanevsky> +2
21:48:44 <Arkady_Kanevsky> Shamail, any help needed on any unfihished projects?
21:49:05 <shamail> Thanks Arkady_Kanevsky, I think we are good… most projects have assigned owners (just waiting on responses)
21:49:11 <shamail> On another note, I have two more projects to add
21:49:26 <shamail> We had to project teams (DragonFlow and Karbor) reach out to us to be included
21:49:36 <shamail> The more the merrier as long as they were willing to provide the info :)
21:49:56 <Arkady_Kanevsky> agree. can they generate a singel slide for hteir roadmap?
21:49:59 <CarolBarrett> that's good to hear!
21:50:13 <shamail> Yep, they sent me the data and i’ll build it for them Arkady_Kanevsky
21:50:15 <Arkady_Kanevsky> We will still need to figure our who will be CPL for them
21:50:16 <shamail> Agreed CarolBarrett
21:50:21 <shamail> They don’t need a CPL
21:50:23 <Arkady_Kanevsky> +1
21:50:35 <shamail> CPL is only for projects with high adoption and potentially user story dependencies
21:50:51 <shamail> I should have said don’t need a CPL (yet)
21:51:13 <Arkady_Kanevsky> will they maintain their roadmap slides? will they be able to participate on our call once in a while to provide updtae?
21:51:20 * shamail passes the mic back to Carol
21:51:44 <shamail> They won’t have to Arkady_Kanevsky, we generally do that.  If nooone volunteers to pick it up then they will have to reach out to us with the data.
21:52:02 <Arkady_Kanevsky> OK
21:52:02 <shamail> Roadmap is built on availability of volunteers and adoption data sets the priority
21:52:22 <CarolBarrett> I wonder if we should consider setting up a self-service process for projects - all of them...?
21:52:29 <shamail> CarolBarrett: +1
21:52:37 <shamail> It would be easy to do
21:52:55 <shamail> That would allow us to actively work with highly adopted projects (if they dont use self-service) but everyone else can opt-in
21:53:04 <Arkady_Kanevsky> as long as we have template, sample and list of questoins.
21:53:15 <CarolBarrett> +1
21:53:33 <Arkady_Kanevsky> need to create outreach subteam for new projects
21:53:34 <shamail> We could then just send out a reminder email on dev ML and things would happen
21:53:59 <rocky_g> Sounds good to me
21:54:06 <shamail> CarolBarrett: We can discuss that as a potential summit topic or I can setup a roadmap debrief meeting after the busy season ends
21:54:14 <shamail> We can try for that during the next cycle
21:54:18 <shamail> Great idea
21:54:19 <rocky_g> We could get the release team to add it to the dev schedule
21:54:26 <Arkady_Kanevsky> love it
21:54:41 <CarolBarrett> Pls add it to to the Barcelona planning etherpad so we don't lose the topic
21:54:47 <shamail> will do
21:55:08 <CarolBarrett> thanks
21:55:31 <CarolBarrett> Any other opens?
21:55:45 <shamail> I’ll be in Seattle next week if anyone happens to be in the area :)
21:56:00 <Arkady_Kanevsky> good luck
21:56:14 <shamail> I think there is an OpenDayLight event (https://www.opendaylight.org/events/2016-09-27-000000-2016-09-29-000000/opendaylight-summit-2016)
21:56:15 <CarolBarrett> Have a good trip!
21:56:27 <shamail> Im not going for the event but it increases chances of others being there
21:56:30 <shamail> Thanks CarolBarrett
21:57:13 <CarolBarrett> If there's nothing else, we can all have 3 mins back... :)
21:57:22 <rocky_g> WFM
21:57:25 <Arkady_Kanevsky> bye everybody
21:57:25 <KrishR> :)
21:57:29 <MeganR> Bye
21:57:32 <CarolBarrett> #endmeeting