21:01:15 <CarolBarrett> #startmeeting Product Working Group
21:01:15 <openstack> Meeting started Mon Nov  7 21:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is CarolBarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:18 <openstack> The meeting name has been set to 'product_working_group'
21:01:23 <Rockyg> o/
21:01:29 <CarolBarrett> Hi All - Who's here for the PWG meeting?
21:01:38 <CarolBarrett> Hi rockyg
21:02:05 <kencjohnston> o/
21:02:11 <shamail> Hi everyone
21:02:23 <kencjohnston> howdy shamail
21:02:30 <CarolBarrett> hi shamail & kencjohnston
21:02:43 <leong> o/
21:02:44 <CarolBarrett> you can find the agenda here
21:02:44 <shamail> hi kencjohnston, Rockyg, CarolBarrett, & leong :)
21:02:47 <CarolBarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team#November_7.2C_2016_Product_Team_Meeting_Agenda
21:02:52 <CarolBarrett> hi leong
21:02:59 <leong> hi all
21:03:26 <Rockyg> hey all!
21:03:40 <CarolBarrett> Glad to see you all were able to navigate the time change to be here!
21:03:47 <CarolBarrett> let's get started
21:03:59 <CarolBarrett> #topic Summit Observations
21:04:36 <CarolBarrett> Want to spend a little time sharing observations you all have from the Summit - any part of it.
21:04:54 <kencjohnston> Seemed to be good attendence at the summit in general
21:04:56 <CarolBarrett> What were the 2-3 take aways you had?
21:05:25 <kencjohnston> Keynotes had an awesome display of OpenStack users
21:05:26 <kencjohnston> Glad to see movement on changes to the User Committee and excited about the impact for the Product Work Group
21:05:28 <shamail> It seemed that a lot of the working sessions at this summit were preparing for transition (whether it be forum, PTG, UC charter, WG merges, etc.)
21:06:25 <shamail> Containers is still trending up, role of OpenStack services seemed to be not as well-known with some of the attendees I spoke with
21:06:26 <CarolBarrett> shamail: agree...I think there was also a lot of that in the design summit - Stewardship, cross-project goals, etc
21:06:29 <leong> with respect to PWG, it seems to me people has better understanding on what PWG trying to achieve... however, how we achieve our goal / creating positive impact to the community remains a challenge...:-)
21:06:46 <CarolBarrett> leong: +1
21:07:14 <shamail> like understanding that OpenStack has services that use containers, facilitate container orchestration engines, images for services exist, or it can be used w/o any “container specific” services for containers (as IaaS)
21:07:31 <leong> hoping that the PWG can really be effecting while the community moving towards the split of PTG and Forum/Summit
21:07:36 <shamail> +1
21:08:14 <kencjohnston> shamail: say more about "can be used w/o any "container specific"....
21:09:18 <shamail> kencjohnston: E.g. you can use COEs on top of infrastructure provided by OpenStack (e.g. instances, bare-metal, networks, etc.) without having to use a service such as Magnum, Kolla, etc.
21:09:35 <kencjohnston> shamail: ok got it, thanks
21:10:35 <CarolBarrett> I thought the Board/TC joint session was good - esp the discussion about developer resources and challenges for Infra and other teams.
21:10:38 <shamail> Generally, still seeing people exploring whether the technologies/platforms are complimentary, substitutes, orthogonal, etc.
21:10:45 <shamail> CarolBarrett: +1
21:11:08 <Rockyg> I think the momentum of OpenStack was very much on display.  While it's still not easy to use, the adoption is strong
21:11:24 <kencjohnston> CarolBarrett: I missed that, can you provide more details?
21:11:35 <kencjohnston> Rockyg: +1
21:11:39 <CarolBarrett> shamail: I think helping people sort out the relationship between the container technologies is going to be mission critical over the next 6-12 months
21:12:06 <Rockyg> Even if nothing changed and development continued at the current or even reduced rate, OpenStack will be used, even if a replacement turns up, for at least the next five years.
21:12:09 <shamail> CarolBarrett: totally agree, the easier we can make understanding the decision points and relationship the better it will be for continued momentum
21:12:19 <leong> Container being the "overlay" and "underlay"....
21:12:25 <Rockyg> ++ CarolBarrett
21:12:40 <CarolBarrett> kencjohnston: The work force reductions at some of the OpenStack Community companies has led to a decrease in the number of developers on projects.
21:13:33 <CarolBarrett> An example given was Infra; They used to have 12 cores and we just able to keep up with the work flow. Now they have 6, really understaffed,
21:13:41 <kencjohnston> specifically for Infra?
21:13:49 <kencjohnston> CarolBarrett: Ahhh, ok. Thanks.
21:14:26 <CarolBarrett> I think Nova was another example given about lower number of development resources...think this could become a challenge to navigate as the big tent continues to grow
21:14:38 <CarolBarrett> On containers, It would seem like a series of Reference Architectures would be helpful....thoughts?
21:14:49 <kencjohnston> I know the shortage is also felt in the Horizon team.
21:15:02 <kencjohnston> CarolBarrett: On containers, I don't think it is a matter of reference archtiectures
21:15:06 <kencjohnston> maybe just more like stack diagrams
21:15:28 <shamail> I agree with kencjohnston, I think even decision trees or cheat sheets on tech overview would be useful
21:15:31 <kencjohnston> Most people who are interested in "OpenStack and Containers" just want to know the ways to run containers on OpenStack
21:15:57 <kencjohnston> Part of our confusion is we talk about deploying on containers in the same breath as developing container based apps
21:15:57 <leong> running Container on OpenStack or using Container to manage OpenStack ? :)
21:15:58 <CarolBarrett> kencjohnston: Gotcha. Wonder if anyone's working on this....?
21:16:18 <kencjohnston> leong: I don't think anyone cares about running openstack on containers frankly
21:16:24 <shamail> leong: could be both… helping segment these use-cases is one of the things that could be covered
21:16:33 <kencjohnston> accept if it makes running openstack easier.
21:16:38 <CarolBarrett> this is where the confusion begins....
21:16:49 <kencjohnston> CarolBarrett: Ha, +1
21:17:13 <shamail> I think there is definitely greater value in explaining how to make containers available on OpenStack clouds versus deploying OpenStack services in containers themselves
21:17:20 <leong> that's the underlay and overlay question.. a "container sandwiches"...
21:17:21 <CarolBarrett> I don't think this is ours to solve, but I would I would like someone to own it
21:17:24 <shamail> broader segment
21:17:34 <kencjohnston> CarolBarrett: I'm happy to work on it
21:17:35 <leong> i agree shamail and kencjohnston...
21:18:02 <CarolBarrett> kencjohnston: Do you want to put together a team to take that on?
21:18:05 <kencjohnston> I agree that it is a critical time period for openstack, and we need to communicate crisply if we don't want to loose an audience
21:18:10 <kencjohnston> CarolBarrett: Sure.
21:18:14 <Rockyg> Also, I think maybe the kuryr project will be important for networking.
21:18:32 <kencjohnston> Rockyg: +1
21:18:36 <CarolBarrett> Thanks Kencjohnston! Appreciate you taking that on.
21:18:37 <kencjohnston> I'll send a note to the list.
21:18:45 <kencjohnston> Can I record my own action?
21:18:45 <CarolBarrett> any other observations from Barcelona to share?
21:18:50 <Rockyg> maybe storage, too.  so not deployment of openstack on/in containers, but managing the networks/storage via containers
21:19:14 <Rockyg> Asia growing fast
21:19:31 <Rockyg> And some western folks not happy about it.
21:19:32 <CarolBarrett> #action kencjohnston Start a team to develop crisp reference material to understand containers and OpenStack - how they can be used and what the value is
21:19:32 <shamail> Possibly Rockyg, but kuryr is focusing on libnetwork and k8s for now right?  Calico, Fannel, Weave, etc. are all interesting to discuss for container networking too.
21:19:35 <kencjohnston> Rockyg: +1, the numbers presented by the Gold Member applicants were pretty astounding
21:20:07 <shamail> Flannel*
21:20:13 <Rockyg> shamail, yes.  I think kuryr is talking to at least calico
21:20:17 <shamail> nice
21:20:34 <CarolBarrett> I'd like to defer that discussion to kencjohnston and that team
21:20:40 <shamail> Yep
21:20:42 <leong> +1
21:20:45 <CarolBarrett> Let's move along....
21:20:53 <Rockyg> The thing is, China really doesnt get how opensource communities are expected to work.
21:21:00 <CarolBarrett> #topic Summit Working Session recap
21:21:16 <Rockyg> missed it.  recap is good for me.
21:21:26 <shamail> ditto
21:21:45 <CarolBarrett> #link https://etherpad.openstack.org/p/PWG_Session_Oct16_BCN
21:21:54 <CarolBarrett> Here's the etherpad link for the session
21:22:27 <CarolBarrett> Good attendance, several new folks. Including Stig from the Scientific WG
21:23:02 <Rockyg> thanks
21:23:04 <CarolBarrett> 1st topi was Ocata Goals
21:23:12 <CarolBarrett> Kenny and Pete led this one
21:23:25 <CarolBarrett> Kenny - do you want to recap this one?
21:24:04 * kencjohnston reads teh etherpad notes
21:24:38 <kencjohnston> So we come up with a series of potential goals that ranged from completion (merger) of user stories to helping identifying a list of SMEs
21:25:25 <kencjohnston> Generally speaking we were supposed to +1 the items we were interested in being goals (and contributing to) and in a subsequent team meeting determien which to prioritize.
21:25:37 <kencjohnston> There was good discussion around new user stories wanted/needed, esepcially from operator feedback provided by Piet and the UX team.
21:26:05 <kencjohnston> There was also general agreement that we need to work towards completing the user story tracker as a critical deliverable.
21:26:22 <CarolBarrett> It seems like line #57, #61 and #71 are leading the voting
21:26:41 <kencjohnston> Agreed
21:26:51 <kencjohnston> I think it was also good to get ideas for user stories out on the table
21:27:05 <kencjohnston> I know I'll be collaborating with some members on other non-priority stories.
21:27:17 <CarolBarrett> I wonder if we can finalize that in this meeting...Thoughts?
21:27:25 <shamail> Is “establish simplified process for PWG to get wider range of feedback” one of the goals? Am I reading the etherpad correctly
21:27:33 <CarolBarrett> kencjohnston: sure, that makes sense.
21:27:35 <kencjohnston> CarolBarrett: I'd be in favor.
21:28:20 <shamail> CarolBarrett: +1
21:28:22 <CarolBarrett> shamail: yes, the work flow strikes people as complicated and long to execute.
21:28:29 <Rockyg> Yeah, I working with Kei on the logging.
21:28:35 <shamail> Thanks CarolBarrett
21:28:39 <kencjohnston> I don't mean to open a can of worms here, but the way to get our process to work faster is to get more reviewers reviewing user stories
21:28:52 <leong> yes.. rokcyg i'm working with Kei on that as well.. :-)
21:28:54 <CarolBarrett> The desire is to simplify it so that other work groups can flow user stories more easily
21:28:56 <kencjohnston> And that speaks to the complicated workflow, not just the actual flow but the tools required to be involved
21:28:58 <shamail> kencjohnston: +1, that is how I interpreted wider feedback
21:29:18 <Rockyg> ++
21:29:24 <kencjohnston> CarolBarrett: shamail +1 we need to figure out a smoother process, or provide better training for user story creation and review
21:29:53 <CarolBarrett> kencjohnston: Good point, the solution will be a combination of things...
21:29:59 <kencjohnston> Maybe that will come with time but we've struggled over the past year with it.
21:30:12 <kencjohnston> I'm saying all this to say that I think that should be our #1 priority
21:30:24 <kencjohnston> and that I don't have any great suggestions for next steps to tackle it :)
21:30:34 <CarolBarrett> kencjohnston: I agree
21:30:54 <shamail> Yeah, maybe its a combination of reducing the barrier for user stories in the creation/validation phase (e.g. maybe using a non-gerrit method) and then using gerrit when we need technical feedback from broader community
21:30:57 * shamail shrugs
21:31:21 <Rockyg> Well, I know some folks (mostly not here right now) won't like hearing this, but outside the dev community, it's much easier to get folks to collaborate via wiki than via garret
21:31:36 <shamail> basically make the first phase of the workflow as simple as possible with lower barrier (not havign to know tools) to get broader feedback/involvement
21:31:55 <kencjohnston> It actually feels like the broader UC is moving in the other direction.
21:32:00 <shamail> leave the second part closer to OpenStack process to make transition from story to dev artifacts easier
21:32:03 <kencjohnston> Moving to more gerrit/git workflows rather than less.
21:32:10 <shamail> kencjohnston: it is
21:32:16 <CarolBarrett> kencjohnston: I agree, I think they are moving that direction
21:32:31 <Rockyg> shamail, +1.  Maybe start with w iki page and move to gerrit when the story is close?
21:33:04 <kencjohnston> I'm not sure we want to solve this hear. But sounds like we all agree it should be a priority.
21:33:05 <shamail> Rockyg: something like that… the “formal” flow is still in gerrit but brainstorming/creation is outside to attract more content/perspectives
21:33:08 <shamail> Yeah
21:33:10 <CarolBarrett> Sounds like there is a lot of agreement around that priority, so let's capture that
21:33:15 <shamail> Let’s defer but it is a priority
21:33:26 <Rockyg> shamail,  ++
21:33:32 <CarolBarrett> #agree Priority #1 is Establish simplified process for PWG to get wider range of feedback
21:33:49 <CarolBarrett> Is anyone willing to be the lead for that?
21:34:03 <shamail> I can help with this one
21:34:17 <CarolBarrett> shamail: Thanks!
21:34:50 <CarolBarrett> #action Shamail to lead the Simplification effort with help from the team
21:34:58 <CarolBarrett> What about the 2nd priority?
21:35:03 <CarolBarrett> User Story Tracker?
21:35:04 <kencjohnston> Tracker
21:35:07 <shamail> ++
21:35:07 <Rockyg> ++
21:35:24 <kencjohnston> CarolBarrett: +1
21:35:46 <CarolBarrett> #agree 2nd Priority for Ocata cycle is completing the User Story Tracker
21:35:59 <CarolBarrett> someone want to lead that effort?
21:36:19 <shamail> I’ll be glad to help but can’t lead (cycles)
21:36:29 <CarolBarrett> understand shamail
21:36:52 <CarolBarrett> I'd like to have someone outside of Intel lead this, and ideally bring some resources too
21:37:17 <CarolBarrett> Our team could use some help from other people who have worked with Infra and scripts
21:37:30 <kencjohnston> CarolBarrett: I was thinking I could try and get some OSIC resources on it, but I can't lead it.
21:37:32 <shamail> Yeah, openstack-infra + puppet experience would be great
21:37:57 <CarolBarrett> kencjohnston: If you could check with OSIC that would be great.
21:38:07 <kencjohnston> CarolBarrett: already on it :)
21:38:16 <shamail> Thanks kencjohnston
21:38:17 <CarolBarrett> kencjohnston: Thanks
21:38:36 <CarolBarrett> #action kencjohnson check on resources to join User Story Tracker from OSIC
21:39:10 <CarolBarrett> #action CarolBarrett add getting an owner for this priority to next meeting when we have more info on resources from OSIC
21:40:16 <CarolBarrett> And for Priority #3: Capacity Management (completed and gaps analysis complete)
21:40:26 <CarolBarrett> ?
21:41:18 <CarolBarrett> The other proposal which didn't get as many votes as Cap Managment is UC/Other WGs working together..I do think this is going to be important for us to fulfill our "bridge" role
21:41:46 <CarolBarrett> What do you all think?
21:41:52 <MeganR> I think that might happen naturally, not certain it needs to be a focused priority for us
21:42:05 <MeganR> I think the Cap Management should be the focus
21:42:09 <shamail> I think the UC/Forum items are more important for this cycle
21:42:19 <Rockyg> cap mgmnt
21:42:32 <kencjohnston> CarolBarrett: I agree with MeganR between natural evolution and our work to improve the process we should have "workign with UC and other WG" covered.
21:42:39 <shamail> Is the goal with capacity management to just get the requirements captured?
21:43:05 <kencjohnston> Although I do agree that  don't think Cap Management, or the publication of any user story should be a team goal
21:43:29 <kencjohnston> We can have subgroups who are interested contribute to that effort
21:44:52 <CarolBarrett> kencjohnston: I think I understand your viewpoint, but want to check - as the bridge, we're working to get the process defined and operate it - not own the content that goes through it...?
21:45:24 <kencjohnston> CarolBarrett: Well, I mean we do own the content that goes through it
21:45:38 <kencjohnston> I'm just thinking we need to as a team focus on prioritizing getting our setup straight
21:45:54 <kencjohnston> and then individual team members who have a desire to move certain user stories can/should collaborate on creating that content
21:46:01 <CarolBarrett> kenjohnston: Understand and agree
21:46:19 <CarolBarrett> Other thoughts?
21:46:59 <kencjohnston> There was another thread aroudn acceptance criteria
21:47:07 <kencjohnston> that didn't seem to make it into the recap
21:47:14 <shamail> I agree that organizing our workflow/setup is more critical for the team (esp. with our potential role in the revised UC model)
21:47:24 <CarolBarrett> If we are in agreement on that, then I think working with the UC on its transition and the TC on the forum transition would be a a priority
21:47:26 <shamail> We should still be available to help during that transition as needed
21:47:42 <CarolBarrett> shamail: agree
21:47:55 <kencjohnston> CarolBarrett: I agree on the forum transition, i'm not sure what our goal is there.
21:48:45 <shamail> kencjohnston: Our goal would be to ensure that the forum results are captured in an actionable manner for the community (one of which could be to have user stories as an output) and/or ensuring that user stories can be considered topics as well.
21:48:59 <CarolBarrett> Kencjohnston: Our goal is to make sure the info gets captured with sufficent details to be actionable by the Project teams when they have their PTGs and are desiging the future release plans
21:49:09 <CarolBarrett> shamail: +1
21:49:34 <CarolBarrett> And ideally, track the action on the feedback so we can show Operators that they are being heard....
21:49:59 <shamail> We would not be involved with crafting the final plans but rather to ensure that the plans reflect a way to get to “next steps"
21:50:05 <CarolBarrett> So going for the close - I propose Priority #3 is supporting the UC and Forum transitions
21:50:33 <shamail> CarolBarrett: +1
21:50:47 <shamail> I also do think that capacity management can be pursued in parallel by a sub-team for that user story
21:50:54 <kencjohnston> CarolBarrett: shamail OK got it, +1 to those goals
21:51:02 <CarolBarrett> #agree Priority 3 is supporting the UC and Forum transitions
21:51:14 <CarolBarrett> Who wants to take point on this one?
21:51:47 <shamail> Happy to help again, I’ll volunteer next time if we still don’t find someone in the next meeting.
21:51:56 <Rockyg> +1
21:52:04 <kencjohnston> +1, I'd like to see some new members take it on, but you can put me down in the interim
21:52:24 <CarolBarrett> I can take this one, but that means someone else will need to take User Story Tracker lead
21:52:29 <MeganR> I'm happy to help, but with us heading into holiday - I can't lead it
21:52:43 <shamail> Seems like a team is already forming but just noone to lead :P
21:53:03 <CarolBarrett> #action Carol to lead Priority 3 - supporting the UC and Forum transitions
21:53:08 <shamail> So Kenny, you’re good with it for now and then we can ask for a volunteer next week?
21:53:13 <Rockyg> Hey, at least *we* are aware of lack of leadership.  Most devs aren't ;-)
21:53:19 <shamail> Oh, nm. :)
21:53:48 <CarolBarrett> Let's keep moving
21:53:55 <CarolBarrett> #topic User Story Updates from the Summit
21:54:02 <Rockyg> On tracker subject, has anyone talked to the storyboard folks recently?
21:54:21 <CarolBarrett> What's the progress report on the top User Stories?
21:54:33 <kencjohnston> CarolBarrett: Great cross project discussiona bout rolling upgrades
21:54:44 <kencjohnston> Keystone applied for the tag
21:54:47 <kencjohnston> glance is in POC
21:54:52 <CarolBarrett> kencjohnston: Yea!!
21:54:53 <kencjohnston> continued work in Neutron and Cinder
21:54:54 <shamail> Wow, awesome!
21:55:23 <CarolBarrett> I see on the TC agenda for tomorrow is a discussion on Create a project tag for zero-downtime upgrades
21:55:24 <kencjohnston> The cross project discussion was about moving beyond rolling to "Zero Downtime" upgrades tag
21:55:28 <kencjohnston> There is a PR up for review on that topic
21:55:35 <kencjohnston> CarolBarrett: ++
21:55:59 <CarolBarrett> kencjohnston: Will you able to attend the TC meeting tomorrow? I have a conflict
21:56:15 <kencjohnston> CarolBarrett: I'll try, let me check my calendar
21:56:57 <kencjohnston> There is a member of the OSIC team leading that discussion I imagine, Dolph Matthews. If I don't I'll get an update from him.
21:57:17 <CarolBarrett> Kencjohnston: Do you think we'll have the core project supporting rolling upgrades  in Ocata release?
21:57:26 <Rockyg> Oh, if Dolph is there, we're golden
21:57:33 <kencjohnston> CarolBarrett: Probably not for Neutron.
21:57:49 <Rockyg> Neutron is pushing hard.  But lots to get in place
21:57:58 <kencjohnston> Rockyg: +1, not for want of trying
21:58:02 <CarolBarrett> Bummer, though if the others get there, that's real progress!
21:58:16 <CarolBarrett> We've got 2 mins left - any other User Story updates?
21:58:58 <shamail> Great meeting :)
21:59:25 <kencjohnston> shamail: +1
21:59:29 <CarolBarrett> Good progress - will update our wiki with the goals and float an email on the ML too.
21:59:41 <shamail> Thanks CarolBarrett!
21:59:42 <kencjohnston> I'm glad the timezones are back so this fits into my calendar :)
21:59:48 <shamail> Yeah, welcome back kencjohnston :D
21:59:54 <kencjohnston> shamail: +1 Thanks CarolBarrett!
21:59:58 <CarolBarrett> #action CarolBarrett Update our wiki with the goals and float an email on the ML
22:00:08 <CarolBarrett> kencjohnston: +1
22:00:16 <CarolBarrett> Thanks everyone - type with you next week
22:00:24 <CarolBarrett> #endmeeting