21:01:30 <CarolBarrett> #startmeeting product_working_group
21:01:31 <openstack> Meeting started Mon Nov 14 21:01:30 2016 UTC and is due to finish in 60 minutes.  The chair is CarolBarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:35 <openstack> The meeting name has been set to 'product_working_group'
21:01:52 <CarolBarrett> Hi - Who's here for the Product WG meeting?
21:02:07 <Arkady_Kanevsky> me
21:02:13 <MeganR> Hi
21:02:14 <GeraldK> Gerald
21:02:29 <jamemcc> Hi
21:02:41 <kencjohnston> o/
21:02:58 <CarolBarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:03:08 <CarolBarrett> You can find the agenda for today's meeting at the link
21:03:11 <tnarg> hi, Grant here
21:03:25 <CarolBarrett> Hi Grant
21:03:35 <CarolBarrett> Let's get started.
21:03:49 <CarolBarrett> #topic Review Ocata Goals & Finalize leads
21:03:54 <CarolBarrett> #link: https://wiki.openstack.org/wiki/ProductTeam
21:04:05 <CarolBarrett> I updated our wiki page with our discussion from last week
21:04:22 <pchadwick> o/
21:04:33 <CarolBarrett> Hi pchadwick
21:04:48 <pchadwick> thanks carolbarrett
21:04:48 <CarolBarrett> Any comments/suggestions on the goals themselves?
21:04:52 <MadhuKashyap> Hi
21:05:04 <Arkady_Kanevsky> where is the pointer to goals page?
21:05:27 <jamemcc> Same as the Ocata Cycle Priorities?
21:05:38 <Rockyg> O/
21:05:50 <CarolBarrett> here's a link to the goals: https://wiki.openstack.org/wiki/ProductTeam
21:06:12 <CarolBarrett> They are on our wiki page under meeting and communication info
21:06:19 <shamail> Hi everyone
21:06:27 <CarolBarrett> yes goals/priorities are the same
21:06:31 <CarolBarrett> hi Shamail
21:06:49 <Arkady_Kanevsky> so we need leads for each project we want to move forward
21:07:07 <Arkady_Kanevsky> and usual questionare to drive?
21:07:23 <Arkady_Kanevsky> Do we want to do video intreview in this cycle?
21:07:37 <CarolBarrett> arkady_kanevsky: I'm not following your comments
21:07:44 <shamail> Hi Arkady_Kanevsky: We are not doing a design series interview for this cycle since it is a short one
21:08:00 <shamail> We will instead use this cycle to make the roadmap process more efficient
21:08:20 <Arkady_Kanevsky> for last cycle we interviewed PTL on video and then updated roadmap slides based on it
21:08:48 <pchadwick> Right - but the assumption this time is that not much will happen on the roadmaps.
21:08:51 <shamail> The goals/priorities are the overall objectives of our WG, the roadmap is a task we conduct but it is not one of the goals per se.
21:08:52 <Arkady_Kanevsky> do we want to do that deep level again. Or something lighter like email or call with PTL?
21:08:59 <shamail> pchadwick: +1 except process re-definition
21:09:18 <pchadwick> shamail: understood
21:09:33 <Arkady_Kanevsky> I expect that some project will reduce their deliveries based on resource reductions...
21:09:58 <Arkady_Kanevsky> I went to Rally planning in Barcelona for it.
21:10:18 <CarolBarrett> Good discussion
21:10:21 <Arkady_Kanevsky> Agree Ocata is short cycle - so fewer deliveries
21:11:08 <CarolBarrett> Any changes that we want to consider?
21:11:21 <shamail> For the goals/objectives?
21:11:27 <CarolBarrett> yes
21:11:30 <Rockyg> I think we do need to poll the PTLs at about milestone 2 to see whether they will do all the maintenance they had hoped.
21:11:40 <Arkady_Kanevsky> Do we need to review https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group - to see if the people are still in place for it?
21:11:47 <CarolBarrett> rockyg: why?
21:11:51 <shamail> I think they look good, I think kencjohnston volunteered to also start a sub-team for creating a primer on containers in OpenStack
21:12:25 <CarolBarrett> Shamail, kencjohnston: should we add that to our priorities for this cycle?
21:12:25 <kencjohnston> shamail: +1, not much progress in the last week but on my list.
21:12:37 <Rockyg> Like Arkady_Kanevsky said, to be able to broadcast where on the Ocata plans the various projects will land
21:12:48 <kencjohnston> shamail: CarolBarrett I also wanted to be clear that this is likely a refresh of the existing Containers Guide
21:12:58 <shamail> CarolBarrett: I think we should (mainly for tracking purposes)
21:13:09 <kencjohnston> #link OpenStack Containers Guide http://www.openstack.org/assets/pdf-downloads/Containers-and-OpenStack.pdf
21:13:15 <shamail> Understood kencjohnston, any material is useful in this space… even refreshing existing stuff
21:13:24 <CarolBarrett> Shamail: I agree, will add it
21:13:47 <jamemcc> THe 2nd goal is "Complete the User Story Tracker" - was it already started? Possibly it could overlap our work on something similar for the LCOO working group..
21:13:52 <CarolBarrett> #agreed at another priority to the Ocata set for updating the Containers Guide with kencjohnston as lead
21:14:09 <Arkady_Kanevsky> +1
21:14:10 <CarolBarrett> #action Carolbarrett update PWG wiki to include add'l priority
21:14:51 <GeraldK> if you are about adding new prios for Ocata, what about adding the capacity mgmt user story. unfortunately, I think I had missed last week's meeting where this was discussed and not put among the prios.
21:15:02 <CarolBarrett> jamemcc: Yes, the user story tracker is generally done and now needs to get hosted on OpenStack infrastructure and have some add'l testing to check for robustness
21:15:04 <Arkady_Kanevsky> Shamail, what do you need for projects roadmap update?
21:15:12 <shamail> jamemcc: Yes, it has already been started… the prototype is built using this ref. doc: https://drive.google.com/file/d/0B_yCSDGnhIbzRUxQUE5LYWswN2M/view?usp=sharing
21:15:33 <shamail> Arkady_Kanevsky: Nothing on project roadmaps for now… we are skipping the video interview for Ocata
21:16:34 <Arkady_Kanevsky> OK. just 1K view update slide?
21:16:55 <CarolBarrett> GeraldK: We had a lot of discussion about adding specific user stories to our goals and decided against it. The teams working on them should have goals,but not the overall WG
21:17:11 <shamail> Arkady_Kanevsky: We might do roadmap slides again near the end of the release but we haven’t kicked off the sub-team yet… Nothing on roadmap has been decided yet for the next 3-4 months.
21:17:24 <GeraldK> CarolBarrett: okay. thanks for clarification
21:17:39 <CarolBarrett> jamemcc: Would you be interested in joining/leading this effort? There is a team to partner with....more resources are always welcome!
21:17:43 <shamail> We will revisit near the end of the release cycle to discuss whether we will publish a roadmap this cycle or not.
21:17:54 <Arkady_Kanevsky> OK. keep me posted. Where do you want to update project liason ownership?
21:18:44 <jamemcc> Yes - please put me in contact
21:18:44 <Arkady_Kanevsky> Carol ready to move to next topic
21:19:32 <CarolBarrett> Thanks jamemcc - don't know if I have your email address - can you send me an email: carol.l.barrett@intel.com?
21:20:08 <CarolBarrett> #agreed jamemcc will take lead on user story tracker priority
21:20:33 <Arkady_Kanevsky> Looking at https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group. we are missing a few projects we are tracking.
21:20:49 <shamail> Thanks jamemcc!
21:21:00 <Arkady_Kanevsky> Can everybody check if they are still covering projects they are sign in there.
21:21:31 <CarolBarrett> arkady_kanevsky: Can you send a note on the ML asking people to review/update this? My guess is not everyone is here today.
21:21:42 <Arkady_Kanevsky> I will add Rally and me covring them
21:22:18 <CarolBarrett> #action arkady_kanevsky send a note on the ML asking people to review/update Cross project liason list
21:22:24 <CarolBarrett> Let's move on
21:22:38 <CarolBarrett> #topic Definition of Done
21:22:55 <CarolBarrett> In our BCN working session we had a good discussion on this.
21:23:04 <CarolBarrett> the etherpad link is here
21:23:12 <CarolBarrett> #link https://etherpad.openstack.org/p/PWG_Session_Oct16_BCN
21:24:38 <Arkady_Kanevsky> Carol - Done. email sent
21:24:48 <GeraldK> basically we have 2 stages "done": first, after having agreed in the user story and second, after having it address to our satisfaction
21:24:52 <CarolBarrett> Thoughts on this?
21:25:26 <pchadwick> Do the PTLs use and DoD for blueprints/specs?
21:25:51 <pchadwick> s/and/a/
21:26:10 <Arkady_Kanevsky> not sure. they do link patches to blueprints and specs and keep thme open.
21:26:22 <Arkady_Kanevsky> Not sure what is their process for done.
21:26:48 <Arkady_Kanevsky> I can ask a couple of PTLs
21:26:50 <CarolBarrett> pchadwick: sorry, don't understand your comment
21:27:32 <pchadwick> I was wondering if the development teams already have a definition of done (DoD) in their process?
21:27:39 <Arkady_Kanevsky> <GeraldK> - my understaning we have two options.
21:27:49 <CarolBarrett> gotcha
21:28:02 <pchadwick> If we can say that ours is "It's in the repos and specs are defined" then we only need to have that.
21:28:07 <Arkady_Kanevsky> One is when all the blueprints and specs we create for a user story are full completed.
21:28:18 <pchadwick> The second level is tracked by the dev teams.
21:28:48 <Arkady_Kanevsky> Second is when we created them and projects accept them. We will still to track thme but we do not need the same level of resourecs to drive them.
21:29:06 <shamail> We have concept validation (meaning we think we have captured all perspectives) and then implementation (which is when it has moved into project-level artifacts and is being worked on)
21:29:25 <Rockyg> The specs are done when they are approved.  When the BPs associated with the spec are done, then the implementation of the spec is done
21:29:34 <shamail> I think our view of done should be once the technical teams have picked it up… We still have to track it but we shouldn’t be editting the story any more.  Thoughts?
21:29:49 <CarolBarrett> I think lines 97 thru 101 was the definition that the group in BCN landed on - we wanted to make sure Done was in our control
21:29:58 <GeraldK> IMHO, DoD is usually applied when things are implemented. so, what term could we use for the "specs ready" stage?
21:30:03 <pchadwick> shamail: +1
21:30:06 <jamemcc> Carol, Seems correct to have 2 phases to done. Want to be able to proceed past User Story with some confidence.  I can see missing criteria in the PWG defination - basically that it needs multiple reviewers and some consideration of alternatives.  That may be deeper in the process.
21:30:09 <Arkady_Kanevsky> I think we still need to definitions. One internal to the team when we can move resources.
21:30:30 <shamail> The definition in the the etherpad also aligns with this view of “done"
21:30:37 <Arkady_Kanevsky> Another is externa;l to community - when we can report back that user story is completed and functionality is availavbe
21:31:35 <jamemcc> I think the 2nd Done is still our to make - Development teams can be done with 1 item in a release but we need to decide when it all comes together.
21:31:38 <Arkady_Kanevsky> There is also still expectation whne we put blueprint/spec on their board and they approve it - we provide resources to implement it.
21:32:00 <Arkady_Kanevsky> We is collective product WG member companies folks
21:32:25 <CarolBarrett> arkady_kanevsky: I agree  that when the user story is implemented is the ultimate done. We can't control that, only support with resources and ability to track status
21:32:31 <Arkady_Kanevsky> agree with jamescc - that is our external done definition
21:32:36 <GeraldK> I agree to the definition of Done as in the Etherpad. After we have filed the specs it is somehow out of our control. still, how would we call the stage when we can close the user story as implementation is complete?
21:33:34 <GeraldK> "internal done" and "external done" doesn't sound well
21:33:49 <CarolBarrett> GeraldK: I think we call that implemented. Our "done" would refer to the completion of the requirements gathering, documentation and providing actionable input and resources to the project development teams
21:34:28 <GeraldK> okay.
21:34:30 <Arkady_Kanevsky> suggestions for 2 stage completions?
21:34:37 <Arkady_Kanevsky> nameing ofr 2 stages?
21:34:39 <Rockyg> To paraphrase lots of devs -- if it isn't tested, it doesn't work so our definition of "delivered" should be that th implementation passes  acceptance (scenario) tests
21:35:03 <shamail> What about “validated story” and “user story complete”
21:35:22 <shamail> after its delivered (from a code perspective), we could say “implemented"
21:35:34 <jamemcc> @shamail +1
21:35:36 <shamail> We own the first two milestones; delivery owns third
21:36:10 <CarolBarrett> shamail: What would need to be completed for validated? ditto for complete?
21:36:25 <Arkady_Kanevsky> how aboud defined and delivered?
21:36:36 <shamail> For validated = PWG members have added their feedback… we have reached out to other WGs for feedback… and it is all merged into the story
21:36:45 <Arkady_Kanevsky> both start on D which is not great
21:36:50 <GeraldK> what about "accepted/agreed story" instead of "validated story". what kind of "validation" do we do on a user story that we agree on?
21:36:52 <shamail> User Story Complete = Implementation plan has been established, specs/bps created
21:37:05 <Arkady_Kanevsky> I like accepted and completed.
21:37:18 <shamail> Validation was implying needs have been validated by market-centric WGs
21:37:21 <CarolBarrett> I think that works too
21:37:24 <shamail> but agreed works too
21:37:40 <CarolBarrett> Any one have comments on that?
21:37:58 <GeraldK> okay. so validated is already one step ahead of PWG agreement on a story
21:38:54 <GeraldK> agreed -> validated -> done -> implemented
21:38:55 <GeraldK> ?
21:38:57 <CarolBarrett> GeraldK: I view is as the steps on line 98 and 99 in the etherpad
21:39:20 <Arkady_Kanevsky> what does done represent?
21:39:55 <Arkady_Kanevsky> agreed - user story approved
21:39:58 <CarolBarrett> GeraldK: I thought it would be validated (User Story Definition is Complete & Merged into Repo, json file created)
21:40:08 <shamail> Done IMHO represents when the capability is actually available in OpenStack-Powered clouds.
21:40:22 <Arkady_Kanevsky> validated - json file created & gap analysis done
21:40:41 <shamail> CarolBarrett: Your definition + we have sent notice of the user story to other WGs
21:40:46 <Arkady_Kanevsky> done - all specs/blueprints/projects created and approved
21:40:49 <shamail> and merged their comments (if applicable) as well
21:41:01 <CarolBarrett> Shamail: +1 on real definition of done.
21:41:14 <Arkady_Kanevsky> implemented - user story support delivred to Customers
21:41:44 <Arkady_Kanevsky> GeraldK - are these definitions you are using?
21:41:55 <CarolBarrett> Validated = User Story Definition is Complete & Merged into Repo, json file created, sent notice of the user story to other WGs and merged their comments
21:42:27 <GeraldK> Arkady_Kanevsky: no. just trying to summarize the milestones we had been discussing about
21:43:04 <CarolBarrett> User Story Complete = Implementation plan has been established, specs/bps created and json file updated
21:43:07 <Arkady_Kanevsky> CarolBarrett - so gap analysis and spec/blueprints/etc are part of done definition?
21:43:28 <CarolBarrett> arkady_kanevsky: Yes, this is done from PWG point of view
21:43:50 <Arkady_Kanevsky> Carol I do not like the ter, User Story Complete.
21:43:56 <CarolBarrett> User Story Done = User Story Tracker shows all required elements are complete
21:44:18 <Arkady_Kanevsky> It has implication that story has been done and ready for Customers to use.
21:44:24 <CarolBarrett> arkady_kanevsky: propose another name, I'm fine with changing it
21:44:32 <Arkady_Kanevsky> Can we use different term for it?
21:44:51 <Arkady_Kanevsky> user story defined?
21:45:08 <pchadwick> +1
21:45:36 <CarolBarrett> There are 3 milestones we're trying to define
21:45:44 <jamemcc> For me the name isn't yet as critical as that there is a 3rd Done - after the multiple Dev done - when the Product Manager says it's all ready for the customer.  All this dicussion is making me realize I can see 3 dones.
21:46:00 <CarolBarrett> If the 1st one is User Story Defined, what is the 2nd one (with specs/blueprints/etc)?
21:46:21 <jamemcc> User Story Ready
21:46:21 <Rockyg> third done is passes prod mgr's acceptance tests
21:46:35 <CarolBarrett> jamemcc: that's right. There's the actual implementation and release of code that enables someone to achieve the user story
21:46:35 <Arkady_Kanevsky> that actually raised a question for me if we want to define 4th - for gap analysis
21:46:57 <Arkady_Kanevsky> especially if need to propose new project.
21:47:11 <CarolBarrett> User Story Defined, User Story Ready, User Story Implemented?
21:47:40 <jamemcc> +1
21:47:43 <CarolBarrett> arkady_kanevsky: the gaps analysis is part of the 2nd phase (ie. ready for project team implementation)
21:48:03 <Arkady_Kanevsky> I suggest we add one more ahead of them - User Story Accepted or use story approved
21:48:12 * shamail has to drop (sorry)
21:48:30 <Arkady_Kanevsky> carol i think it is too much for one phase.
21:48:33 <CarolBarrett> Alrighty - this was a more lively discussion that I thought it would be. Can we take this to the ML? Will someone volunteer to summarize this discussion and start the thread?
21:48:40 <Arkady_Kanevsky> suggest we split it into 2 phases
21:48:54 <pchadwick> carolbarrett: I will send the email
21:49:01 <CarolBarrett> pchadwick: Thanks!
21:49:05 <Arkady_Kanevsky> thanks pete
21:49:24 <CarolBarrett> #action pchadwick summarize the Done discussion and send to ML for further refinement
21:49:35 <CarolBarrett> We've got 10 mins left
21:49:48 <CarolBarrett> #topic Roadmap refresh plans
21:50:07 <CarolBarrett> I know we touched on this earlier, but think it's good to make sure we all have the same understanding
21:50:17 <CarolBarrett> Shamail: Can you summarize the plans for this cycle?
21:50:17 <Arkady_Kanevsky> suggest we postpone it to next week when Shamail is back
21:50:33 <Rockyg> shamail dropped off...
21:50:34 <CarolBarrett> sorry - didn't see he dropped.
21:50:47 <Arkady_Kanevsky> finish early?
21:50:47 <CarolBarrett> #action Carol move Roadmap topic to next week's agenda
21:50:52 <CarolBarrett> #topic Opens
21:51:07 <CarolBarrett> Will people be working next monday 11/21?
21:51:15 <CarolBarrett> Want to make sure we'll have critical mass for a meeting
21:51:29 <Arkady_Kanevsky> yes for 21th
21:51:36 <Arkady_Kanevsky> but I iwll miss 28th
21:51:47 <Rockyg> can be...
21:52:16 <pchadwick> I should be available.
21:52:27 <jamemcc> I should be
21:52:36 <CarolBarrett> Sounds like most people will be here - I'll be gone, but Shamail has said he could run the meeting on the 21st
21:52:40 <GeraldK> I will be there
21:52:49 <CarolBarrett> #agree keep the team meeting on the 21st
21:53:01 <Arkady_Kanevsky> +1
21:53:06 <MeganR> I will be here for both
21:53:07 <CarolBarrett> I'm going to pass on the swift discussion and push to next week
21:53:15 <Arkady_Kanevsky> need to drop.
21:53:18 <Arkady_Kanevsky> have a good week
21:53:32 <CarolBarrett> The last think I wanted to pass along was a summary of the Work Flow changes happneing within the Community
21:53:32 <MadhuKashyap> +1
21:54:11 <CarolBarrett> When the PTG registration opened there were a lot of questions in my company, so I worked with Thierry to create a summary to help people plan what events they should attend
21:54:16 <CarolBarrett> you can find it here
21:54:25 <CarolBarrett> #link https://docs.google.com/document/d/1zC9I5rR8-Cv8S9Qlt8e8eLxi3CC0JuzsCNH1fZWdRYg/edit?usp=sharing
21:54:49 <CarolBarrett> If you have questions pls send them via the ML - others are likely to have the same questions/
21:54:50 <MeganR> Carol: thank you for putting this together!
21:54:55 <CarolBarrett> Anyone else have Opens?
21:55:38 <MeganR> I'm good
21:56:01 <GeraldK> thanks Carol for this summary
21:56:17 <Rockyg> yeah.  Thanks!
21:56:31 <CarolBarrett> Glad to do it, hope it's helpful
21:56:43 <CarolBarrett> Let's call it a wrap for today. Have a good week!
21:56:59 <CarolBarrett> #endmeeting