21:01:57 <shamail> #startmeeting product_working_group
21:01:59 <Arkady_Kanevsky> hello
21:01:59 <openstack> Meeting started Mon Nov 21 21:01:57 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:02 <openstack> The meeting name has been set to 'product_working_group'
21:02:08 <shamail> Hi everyone!
21:02:11 <shamail> Who’s here today?
21:02:19 <heidijoy> o?
21:02:25 <heidijoy> o/
21:02:29 <MeganR> o/
21:02:37 <shamail> Awesome!
21:02:39 <GeraldK_> Hi
21:02:47 <shamail> Our agenda for today:
21:02:49 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:54 <shamail> Carol is out this week
21:02:55 <Arkady_Kanevsky> we have quorum
21:03:13 <shamail> Yep
21:03:14 <shamail> Let’s begin
21:03:21 <shamail> #topic Discuss Roadmap refresh plan
21:03:42 <Arkady_Kanevsky> how can we help?
21:04:23 <shamail> As mentioned in the last meeting, we are not conducting an “Ocata Design Series” video interviews since this is a short release cycle and we decided to focus on improving our roadmap process and heidijoy is busy with a new user survey
21:04:46 <shamail> We had discussed trying to automate the roadmap data collection and make it into a self-service model
21:05:15 <heidijoy> I'd like to figure out how we can best automate the roadmap creation process. Mike Perez from the OSF is also working on automating release notes, so these might go hand in hand.
21:05:18 <mrhillsman> o/
21:05:30 <shamail> hi mrhillsman
21:05:38 <shamail> Agree heidijoy
21:06:06 <heidijoy> One option I'm considering is a Google Form (or similar) collection tool. That would collect everything in one spreadsheet automatically.
21:06:09 <Arkady_Kanevsky> +1 on automation. we will still need to poke PTLs on it
21:06:23 <shamail> Initial thought was to turn our “script” into a RST template that could be generated into a web page (similar to specs)
21:06:40 <heidijoy> The poking will probably still need to be manual, as would be the follow up for things left unclear
21:07:03 <shamail> I was hoping we could talk to the release management team and ask them to help us put “generate roadmap RST” on the release process checklist
21:07:18 <Arkady_Kanevsky> do we want PTL to do self interview or only fill forms?
21:07:21 <shamail> that could raise awareness even without us contacting the teams directly
21:07:38 <heidijoy> +1 on something that would auto generate to be visible to all. Would the release management team have bandwidth to help on this?
21:07:48 <Arkady_Kanevsky> And we will figure out antuomated mechanism for generating slides
21:08:00 <shamail> Release management wouldn’t need to help but rather just raise awareness it exists and should be completed
21:08:15 <heidijoy> Do we even need slides if we are generating answers to a web page?
21:08:33 <shamail> Arkady_Kanevsky: I think the initial data will be self-service but we might need to follow-up still to get clarification as needed when generating the content in other formats (slides, breakout sessions, etc)
21:08:51 <Arkady_Kanevsky> +1
21:08:52 <shamail> heidijoy: I don’t think we should need slides but might need to create some for a summit session
21:09:00 <kencjohnston> +1 to a self service, community generated content vehicle
21:09:02 <shamail> The summit slides could even be a summary of the web pages
21:09:21 <kencjohnston> shamail: Is this somethign we could do in the PWG or UC repo?
21:09:33 <heidijoy> What if we think of the collection of data in two parts (form + follow up questions 1:1), and the expression/sharing of data in two parts (auto-generated web page/results; and roadmap team analysis)
21:09:54 <shamail> kencjohnston: I think it would be the PWG repo since we would want to ensure timely merges (and not have to put that burden on UC members)
21:10:06 <shamail> heidijoy: +1
21:10:10 <kencjohnston> shamail: +1
21:10:36 <shamail> The goal for today was to shed some more light on what we meant by “optimize roadmap” and “self service"
21:10:38 <GeraldK_> good thoughts heidijoy and shamail
21:10:46 <heidijoy> +1 summit slides= summary of web pages. That would hit the two-part concept I'm thinking of.
21:10:51 <shamail> I will be glad to take the action item to send an email to the UC ML and solicit sub-team members
21:10:57 <kencjohnston> shamail: heidijoy If we did the colleciton of data in the form of an RST there would be an opportunity for back and forth in the review
21:11:08 <shamail> We can meet independently and provide updates to the PWG as a whole periodically, thoughts?
21:11:37 <heidijoy> +1 @kencjonston with the back & forth
21:11:38 <shamail> kencjohnston: Good point, we could even do it via exchanges in the change itself and it would be archived
21:12:15 <shamail> Does everyone agree with this plan?  (shamail to send out ML notice for roadmap sub-team, team will make progress on this outside of normal PWG meetings?)
21:12:24 <heidijoy> +1
21:12:26 <Arkady_Kanevsky> yes
21:12:28 <mrhillsman> +1
21:12:30 <GeraldK_> +1
21:12:36 <kencjohnston> shamail: sounds good to me, can you add me back tothe roadmap sub-team?
21:12:42 <shamail> #agree Shamail to send out ML notice for roadmap sub-team (team will focus on automation/self-service/outputs)
21:12:52 <shamail> absolutely kencjohnston, thanks!
21:13:11 <shamail> Okay to move to next topic?
21:13:13 <mrhillsman> should #agree be #action shamail? :)
21:13:24 <shamail> I don’t like actions, too rigid!
21:13:25 <heidijoy> I'd definitely like to be on the subteam, and would add that we could revise the Q&A for the RST and bring it back to the PWG for any feedback
21:13:29 <shamail> JK, good catch :P
21:13:40 <shamail> #action Shamail to send out ML notice for roadmap sub-team (team will focus on automation/self-service/outputs)
21:13:52 <shamail> heidijoy: +1
21:13:57 <shamail> #topic Overview of Swift questions about requirements and plans to setup a call to discuss
21:14:05 <shamail> #link https://docs.google.com/document/d/1dmpNy5vSeTRn7CBCnELMFXBvshauPbnqQdNASXFnjRY/edit?usp=sharing
21:14:20 <Arkady_Kanevsky> we still need to add new themes to questionarre for self service
21:14:42 <shamail> John (notmyname) had a brief discussion with some of us at the last ops meetup to bring up a request for PWG
21:15:10 <notmyname> just questions about when/how/where/what people are using related to swift
21:15:12 <shamail> The Swift team has been working on multiple features for end users and they wanted some market research to get data points for decision making in the team
21:15:18 <shamail> Hi notmyname
21:15:51 <shamail> We had asked the OpenStack UX team to help with this request but they are already at capacity for the cycle so we wanted to bring the request back into PWG
21:16:04 <shamail> Please see the linked google doc for the questions that notmyname submitted
21:16:11 <notmyname> TBH, I'm not entirely sure of even the right questions to ask :-)
21:16:36 <Arkady_Kanevsky> are you asking for us to add more questions to the list?
21:16:50 <notmyname> but my goal, in general (and like everyone here, I think), is to understand more about how people use what's available and what are the gaps in areas they might use swift
21:16:52 <shamail> notmyname: It’s as good as a starting point as any… If we get user feedback that indicates they cant answer them then we can refactor
21:17:09 <Arkady_Kanevsky> Heidi will oyu review and polish questions before doing questionarre distribution?
21:17:27 <shamail> Arkady_Kanevsky: no, I am sharing the list that Swift generated… the goal for us would be to get feedback on those questions from our customers and internal users of Swift
21:17:36 <shamail> notmyname: +1
21:17:58 <shamail> On that note, would people be willing to help collect answers/feedback on these questions?
21:18:09 <shamail> We can schedule a call with the volunteers
21:18:12 <Arkady_Kanevsky> I would like to add a couple more, releated to multisite and upgrade
21:18:19 <notmyname> great!
21:18:38 <shamail> Sounds good Arkady_Kanevsky, please add as a comment and we can append
21:18:45 <Arkady_Kanevsky> +1 on help with questionare distribution and answser collecting
21:18:47 <shamail> Anyone willing to help on this?
21:18:58 <Arkady_Kanevsky> will add to google doc
21:19:07 <shamail> Thanks Arkady_Kanevsky
21:19:24 <shamail> kencjohnston or mrhillsman, would Rackspace be able to provide answers from a user perspective at least?
21:19:51 <kencjohnston> shamail: Sure, we can take a look and ask our swift operators team.
21:19:56 <shamail> I will follow up with my teams as well (Blue Box Cloud and SoftLayer)
21:20:13 <shamail> Thanks kencjohnston
21:20:26 <Arkady_Kanevsky> done - adding questions.
21:20:33 <shamail> #action Shamail/Carol to schedule a call with Carol, Arkady, John, Shamail to build plan
21:20:37 <kencjohnston> notmyname: Is the best way to provide a response inline on that GoogleDOc?
21:20:58 <shamail> Thanks Arkady_Kanevsky
21:21:20 <Arkady_Kanevsky> How do we want to distribute questions and collect answers?
21:21:26 <notmyname> sure. actually, whatever works for this group. I emailed some questions to someone, and today there's a google doc and people talking about it in IRC. so whatever works with your process--I don't really care
21:21:40 <kencjohnston> shamail: notmyname I might have missed it but this would be a good candidate for an operators and PWG mailling list post.
21:21:42 <shamail> Changed link to edit permissions
21:21:43 <Arkady_Kanevsky> each one of us independently to our sales folks to Customers?
21:21:43 <kencjohnston> notmyname: cool +1
21:21:44 <shamail> (sorry about that)
21:21:46 <shamail> #link https://docs.google.com/document/d/1dmpNy5vSeTRn7CBCnELMFXBvshauPbnqQdNASXFnjRY/edit?usp=sharing
21:21:54 <shamail> kencjohnston: +1
21:22:27 <shamail> Alright, moving on…
21:22:30 <Arkady_Kanevsky> Or will be sent as part of foundation questionarre by Heidi?
21:22:58 <shamail> Arkady_Kanevsky: no, this is separate most likely because we can only accomodate a few questions per project in the user survey
21:23:03 <mrhillsman> shamail how about sending something to ops ML as well
21:23:08 <shamail> mrhillsman: +1
21:23:22 <shamail> I think we’ll have the initial call and then finalize format and start sharing the questions broadly
21:23:27 <mrhillsman> not sure if i missed that suggestion since i had to walk away
21:23:30 <mrhillsman> ok
21:23:42 <shamail> #topic Ops Midcycle Discussion
21:23:45 <Arkady_Kanevsky> <shamail> +1
21:23:58 <shamail> mrhillsman could you update the team on the ops meetup logistics?
21:24:02 <shamail> (date, place, etc)
21:24:06 <mrhillsman> sure, sec
21:24:14 <shamail> thanks
21:24:58 <mrhillsman> March 15-16 2017
21:25:03 <mrhillsman> Milano, Italy
21:25:04 <Arkady_Kanevsky> so we have summit in Boston in May, PTG in Atlanta in Feb and ops midcycle in Milan between them???
21:25:12 <shamail> Thanks mrhillsman!
21:25:17 <shamail> Arkady_Kanevsky: Yes sir
21:25:22 <mrhillsman> https://etherpad.openstack.org/p/ops-meetup-venue-discuss-spring-2017
21:25:36 <shamail> mrhillsman: Is the etherpad to suggest topics already available too?
21:25:39 <mrhillsman> This is the two proposals we got with details required to submit proposal per se
21:25:46 <Arkady_Kanevsky> 3 meetings per release around the world - too much!
21:26:03 <mrhillsman> It is the one at the bottom
21:26:26 <shamail> Arkady_Kanevsky: Hopefully not everyone will need to attend all three
21:26:30 <mrhillsman> I want to say we are sending that out tomorrow shamail as we have to get some last minute details from sponsor
21:26:32 <kencjohnston> Are PWG folks planning on attending the PTG?
21:26:38 <shamail> kencjohnston: thats the next topic
21:26:44 <shamail> but I am not
21:26:53 <Arkady_Kanevsky> True but a few of us will have too
21:27:01 <shamail> Awesome mrhillsman, we’ll keep our eye on the mailing list!
21:27:15 <leong> i'm not sure.. depending on travel budget
21:27:28 <mrhillsman> I did create shamail and so anyone in this meeting is welcome to contribute now
21:27:30 <mrhillsman> https://etherpad.openstack.org/p/MIL-ops-meetup
21:27:33 <shamail> The first question for our team… Do people think they can make the ops meetup in Italy? We usually co-locate our midcycles with ops.
21:27:38 <Arkady_Kanevsky> mrhillsman - thanks for info.
21:27:43 <mrhillsman> It is still in draft status as noted at the top :)
21:27:45 <shamail> Thanks!
21:27:48 <shamail> #link https://etherpad.openstack.org/p/MIL-ops-meetup
21:28:07 <shamail> I am tentative for now, I won’t know for sure until Q1’17.
21:28:08 <Arkady_Kanevsky> <shamail> - TBD from DellEMC
21:28:21 <Arkady_Kanevsky> me too
21:28:23 <leong> same here.. not sure till Q117
21:28:39 <MeganR> I am tentative, but highly doubtful  :)
21:28:41 <kencjohnston> shamail: I likely could as long as both are together.
21:28:41 <shamail> Thanks, anyone else know yes/no/maybe?
21:28:52 <GeraldK_> same here: still missing final authorization
21:28:57 <shamail> kencjohnston: I am banking on that too
21:29:08 <Arkady_Kanevsky> do we have an etherpad where we track our midcycle with proposed place and dates?
21:29:10 <kencjohnston> the "two-fer" has strong sway, likely wouldn't make the ops if there was no PWG
21:29:15 <shamail> #info Most of the team can not confirm whether they will be able to attend ops midcycle until Q1’17
21:29:48 <shamail> #info Co-locating does create a better “justification”
21:29:57 <shamail> Alright, we’ll defer for now but that was good data
21:30:00 <Arkady_Kanevsky> +1 on better justification
21:30:02 <mrhillsman> we are still discussing that at well
21:30:16 <GeraldK_> Milano is close to Munich, so good chances on my side to be able to join
21:30:21 <shamail> Nice GeraldK_
21:30:26 <shamail> #topic PTG Discussion
21:30:37 <mrhillsman> i think general consensus is co-locating as much as possible is great
21:30:37 <shamail> PTG is in Atlanta (Feb.)
21:30:42 <shamail> mrhillsman: ++
21:30:58 <shamail> Who is planning on attending the PTG?
21:31:11 <Arkady_Kanevsky> TBD from me till Q1'17
21:31:14 <GeraldK_> -1 for me
21:31:21 <shamail> I will not be attending as I don’t think I would contribute much
21:31:33 <mrhillsman> ^ same here
21:31:37 <kencjohnston> shamail: I will not be attending
21:31:43 <MeganR> not planning to attend, will formalize plans after "holiday"
21:31:53 <Arkady_Kanevsky> are we better colocated with ops or PTG?
21:32:29 <shamail> #info PTG count: Arkady_Kanevsky (maybe); GeraldK_, shamail, mrhillsman, kencjohnston (no); MeganR (maybe but leaning no)
21:32:31 <shamail> :D
21:32:39 <shamail> Arkady_Kanevsky: IMHO, ops
21:32:57 <shamail> PTG is for building execution plans whereas ops and Forum are for requirements gathering/sharing
21:33:05 <kencjohnston> Arkady_Kanevsky: shamail +1 on colocating with ops
21:33:08 <mrhillsman> ptg is going to be totally or should be totally about working on code
21:33:18 <Arkady_Kanevsky> I have major concern with separate ops and PTG?
21:33:34 <shamail> Agree, a new requirement being shared at PTG is misaligned
21:33:40 <Arkady_Kanevsky> engineering work becomes more disconnected from operators and requirements
21:34:03 <GeraldK_> I agree
21:34:05 <mrhillsman> my understanding is this first go round is more about debt
21:34:17 <shamail> Arkady_Kanevsky: I will send you a link, ttx and emagana have done a great job describing how it doesnt create a gap
21:34:31 <Arkady_Kanevsky> thanks shamail
21:34:48 <shamail> Should I send the link to overall ML if others are interested?
21:34:57 <mrhillsman> +1
21:34:59 <GeraldK_> +1
21:35:04 <kencjohnston> shamail: is the link not o.o/ptg?
21:35:10 <shamail> Will do
21:35:23 <shamail> It is a superuser article and ttx’s blog and the one you mentioned
21:35:34 <shamail> I was going to consolidate a few sources
21:35:43 <Arkady_Kanevsky> +1
21:35:44 <kencjohnston> shamail: OK, the FAQ on the ptg page is pretty all encompassing
21:35:50 <shamail> To not only share what PTG is but how PTG and Forum interlock
21:35:56 <shamail> kencjohnston: +1
21:36:24 <shamail> #action Send out link to PTG/Forum resources to team for context of the events
21:36:39 <shamail> #topic Follow-up on “Definition of Done” email thread
21:36:46 <shamail> #link http://lists.openstack.org/pipermail/user-committee/2016-November/001413.html
21:37:05 <shamail> In the last meeting, we had a great discussion on one of the items from the BCN F2F… the definition of done
21:37:26 <shamail> pchadwick had sent out an email summary and we generated more conversation on this topic on the ML
21:38:19 <shamail> leong summarized the flow workflow in his message: http://lists.openstack.org/pipermail/user-committee/2016-November/001432.html
21:38:38 <Arkady_Kanevsky> Like Leong summary and 4 stages
21:38:46 <shamail> Arkady_Kanevsky raised a point about differentiating implemented
21:39:34 <shamail> I like it too except I would like to see the last status be us tracking completion of the specs/bps
21:39:39 <Arkady_Kanevsky> leong also includes 4 stages with specific items to cover in each
21:39:55 <shamail> 3.3 in the email is “User story is “done” when all blueprint/spec are merged.”
21:39:59 <Arkady_Kanevsky> That is 3.2
21:40:12 <Arkady_Kanevsky> 3.2 for blueprints and spec tracking
21:40:28 <shamail> leong: Were 3.2 and 3.3 tracking status of the bp/spec or the code associated with them?
21:41:06 <shamail> e.g. is 3.3 marked “done” when bp has a milestone or spec has been merged or when code with topic aligned to bp/spec is merged?
21:41:32 <Arkady_Kanevsky> I expect that if we need to create new projects we track specific specs and blueprints in to for a user story
21:41:50 <Arkady_Kanevsky> in it
21:42:11 <shamail> We can work on the details when revisiting the workflow but do we agree with those four stages?  (User Story defined, User Story prepared, User Story ready, User Story implemented)?
21:42:25 <Arkady_Kanevsky> +1
21:42:32 <kencjohnston> shamail: +1
21:42:33 <shamail> +1
21:42:50 <shamail> Going once....
21:42:56 <shamail> twice…
21:42:58 <GeraldK_> I would tend to say "when code with topic aligned to bp/spec is merged". only then, we can ensure that code and the feature is available.
21:43:04 <MeganR> +1
21:43:09 <shamail> GeraldK_: +1
21:43:27 <GeraldK_> with just a spec merged, it could still be abandoned and no code being created
21:43:27 <shamail> #agree Workflow will have four stages (User Story defined, User Story prepared, User Story ready, User Story implemented)
21:43:30 <Arkady_Kanevsky> GeraldK_: +1
21:43:36 <shamail> agreed
21:43:51 <shamail> We will follow-up this conversation with a more detailed workflow conversation in the future
21:43:59 <Arkady_Kanevsky> spec blueprint impk,emented - not abandon
21:44:28 <shamail> We will have to address the topic of bp/spec merge vs code related to bp/spec,  how to solicit feedback from broader community, etc. (I am sure there are other topics that need clarification)
21:44:43 <shamail> 4 stages feels right
21:44:50 <shamail> #topic Open
21:44:56 <Arkady_Kanevsky> agree - details to be worked out. But 4 stages approved
21:44:59 <shamail> Anyone have any other topics they would like to discuss?
21:45:07 <Arkady_Kanevsky> Yes - https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group
21:45:10 <shamail> MarkBaker: Are you here?
21:45:23 <leong> sorry shamail.. was distracted... i am assuming that 3.2/3.3 can be tracked by User-Story-Tracker tool
21:45:25 <shamail> Go ahead Arkady_Kanevsky
21:45:25 <GeraldK_> arkady_Kanevsky has submitted a new patch: https://review.openstack.org/#/c/358888/
21:45:31 <shamail> thx leong
21:45:35 <GeraldK_> would be good if people could review it
21:45:36 <Arkady_Kanevsky> I send email for folks to updated/add PWG wiki page for liason
21:45:45 <shamail> #link https://review.openstack.org/#/c/358888/
21:45:58 <shamail> Arkady_Kanevsky: Did you get any updates?
21:46:08 <Arkady_Kanevsky> no. except mine
21:46:28 <shamail> :(
21:46:51 <shamail> Can you please send out another reminder after the holiday?  We can also add an agenda item in the next meeting.
21:47:03 <GeraldK_> shamail, what kind of updates are you referring to?
21:47:03 <Arkady_Kanevsky> asking for peoplle to take a quick look now. Andd if some projects are missing which they want to cover
21:47:20 <shamail> I am wondering if it partially got lost due to people recovering after being gone for BCN and now Thanksgiving
21:47:27 <Arkady_Kanevsky> GeraldK - need a couple of +2 for https://review.openstack.org/#/c/358888/
21:47:42 <Arkady_Kanevsky> As far as I am concern it is done
21:47:44 <GeraldK_> yes
21:47:58 <shamail> #action Please review https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group and volunteer to be a CPL… If you are a CPL already then please let Arkady_Kanevsky know its still valid for your project
21:48:12 <Arkady_Kanevsky> <shamail> - possible. I sent email during last Monday meeting
21:48:14 <shamail> Alright Arkady_Kanevsky, I will try to look at it over the next couple of days
21:48:34 <shamail> Thanks Arkady_Kanevsky and GeraldK_
21:48:37 <shamail> Anything else?
21:48:50 <Arkady_Kanevsky> none from me
21:48:54 <mrhillsman> nothing from me
21:48:55 <shamail> Alright , have a great week everyone!
21:49:01 <mrhillsman> you too!
21:49:04 <shamail> #endmeeting