21:02:06 <CarolBarrett> #startmeeting product_working_group
21:02:07 <openstack> Meeting started Mon Nov 28 21:02:06 2016 UTC and is due to finish in 60 minutes.  The chair is CarolBarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:11 <openstack> The meeting name has been set to 'product_working_group'
21:02:25 <CarolBarrett> Hi - Who's here for the Product WG meeting?
21:02:35 <leong> o/
21:02:41 <MeganR> o/
21:03:05 <CarolBarrett> The agenda is located here
21:03:07 <CarolBarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:03:17 <CarolBarrett> Hi Leong and Megan
21:03:41 <MeganR> Hi!
21:03:43 <CarolBarrett> Glad to see you survived Black Friday Megan!!
21:03:56 <MeganR> Lol - and getting through Cyber Monday!
21:04:34 <CarolBarrett> Yea - hearing all types types of things about slow internet, must be an active cyber Monday
21:04:35 <MeganR> I hope you had a great week off.
21:04:51 <MeganR> yes, but that doesn't happen in the office - never!
21:05:11 <piet> o/
21:05:13 <CarolBarrett> Thanks - the week off was nice! Missed a lot of rain here in the NW!
21:05:29 <CarolBarrett> Hi Piet
21:05:45 <piet> Howdy!
21:05:57 <CarolBarrett> Shamail sent a note, he won't make it today...
21:06:00 <kencjohnston> o/
21:06:11 <CarolBarrett> Hi kencjohnston
21:06:20 <CarolBarrett> let's get going
21:06:21 <kencjohnston> howdy leong piet MeganR CarolBarrett!
21:06:34 <CarolBarrett> #topic UX User Stories
21:06:35 <piet> Hi kencjohnston
21:06:35 <Rockyg> o/
21:06:46 <leong> hi all
21:06:47 <MeganR> Hi kencjohnston
21:06:55 <MeganR> and all!  :)
21:07:01 <CarolBarrett> Piet - can you give an overview of your plans for creating User Stories based upon the recent research your team has completed?
21:07:52 <piet> I wouldn't refer to them as UX user stories because there should be no difference with the stories the rest of the group is creating
21:08:13 <CarolBarrett> OK
21:08:23 <piet> I'm just very new to the PWG process and generated a few questions when creating my first one.
21:08:55 <kencjohnston> piet: It is admittedly not the easiest for non-developers, how can we help?
21:09:04 <CarolBarrett> You're not alone...
21:09:19 <piet> First, my impression is that Usage Scenarios reflect the proposed solution?
21:09:37 <piet> Rather than their current state of misery?
21:09:51 <kencjohnston> piet: Correct, the proposed user experience/usage
21:10:56 <kencjohnston> the Problem Definition and Opportunity justification should cover the misery
21:10:59 <piet> What kind of granularity do we need for each user story?  I get the impression that they're a bit intergalactic.  How do we decide whether a user story is too big or small?
21:11:27 <kencjohnston> I'd start with big and if the team decides it is better broken up then we can assist
21:12:21 <kencjohnston> piet: We have some quiet large ones out there already so practically speaking nothing is too large
21:12:43 <kencjohnston> I guess "Make OpenStack More User Friendly" would be too large...
21:12:56 <piet> I'm almost thinking rom the perspective a developer.  Big may be hard for them to complete
21:13:19 <piet> kencjohnston "Talk to operators" ;^)
21:13:30 <Rockyg> They will get broken into multiple specs for developers
21:13:32 <kencjohnston> agree that smaller is prefered
21:13:40 <piet> Kk
21:13:44 <kencjohnston> but don't feel compelled to break them down to the smallest degree
21:14:56 <piet> kencjohnston I'm also thinking that we generated multiple proposed solutions for each study.  How does the group land on a specific solution?
21:15:24 <CarolBarrett> Piet: Can you give an example of a user story that would be created from a study?
21:15:41 <piet> Quota Flavors
21:16:21 <kencjohnston> piet: Say more about that...
21:17:39 <piet> That's kind of a long conversation, but think in terms of instance flavors.  Each flavor has a specific value for RAM, Storage, Security Groups, etc.
21:18:21 <kencjohnston> Ahh gotcha, "Predefined Quota Allocations to be applied to projects"
21:18:24 <piet> Rather than adjust incrementally for each project, the operator would simply select one of x number of flavors.
21:18:41 <kencjohnston> Well I htink that is a "Usage Scenario" on the "Improved Quota Management" user story. What do others think?
21:19:23 <kencjohnston> Sorry specifically this story - http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/capacity_management.html
21:19:24 <piet> kencjohnston Hold on. ;^)
21:19:43 <CarolBarrett> Agree on Capacity management
21:19:46 <leong> agree... that would goes into usage scenario
21:20:01 <piet> There is also a solution around delegating quota management through domain admins.
21:21:00 <piet> The challenge is around multiple usage scenarios.  What if the group likes one, but doesn't like another?
21:21:24 <kencjohnston> piet: These usage scenarios are in conflict?
21:22:13 <piet> No, but some might be better than others or one might be prioritized over the other.  How is that handled through user stories?
21:22:21 <kencjohnston> piet: As in, you can't provide both experiences? If so we should spell that out in the user story.
21:22:36 <kencjohnston> piet: There is some precedence for prioritizing user stories and usage scenarios
21:22:50 <kencjohnston> so if you have that preference from the research we should include it.
21:22:53 <kencjohnston> Let me try and find an example.
21:23:14 <kencjohnston> Something like we did here - http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/fleet-management.html
21:23:30 <piet> kencjohnston Kk that is what I was looking for.
21:24:21 <piet> Remember that my previous experience with agile was that there were also epics
21:24:50 <CarolBarrett> kencjohnston: good example
21:24:55 <kencjohnston> piet: Ahh, is OpenStack considered Agile these days... :)
21:25:35 <piet> kencjohnston No comment.  ;^)
21:26:27 <piet> Alright. I got my questions answered. Thanks for the help! Anticipate around six user stories from me.
21:26:43 <CarolBarrett> Thanks kencjohnston
21:26:56 <piet> Thanks kencjohnston
21:26:57 <CarolBarrett> The next topic is around Scope for User Stories
21:27:02 <kencjohnston> piet: Awesome, thanks!
21:27:03 <CarolBarrett> #topic User Story SCope
21:27:20 <CarolBarrett> This is related to the previous discussion.
21:27:31 <piet> Yep
21:27:42 <CarolBarrett> The scope of some of the User Stories is large - is that a help or a hinderance?
21:28:29 <piet> I think they're a bit large personally, but really looking for some kind of documentation around what is too big or small
21:29:02 <kencjohnston> piet: You bring up a good point, it would be good to break them down further and use the "related user stories section"
21:29:32 <kencjohnston> but we do want these to be consumable by developers who are looking for the results of research (market and user experience).
21:30:00 <kencjohnston> That is the balance, provide complete context, and also link to actionable items like specs as rocky mentioned.
21:30:32 <leong> it is better for a user story to be more focus on a specific scope.. this helps for implementation and tracking
21:30:54 <CarolBarrett> Seems like we will need the ability to track specs/blueprints/bugs at the usage scenario level, not the user story level
21:31:16 <leong> track spec/blueprint should be covered by the User Story Tracker, i suppose?
21:31:16 <CarolBarrett> leong: can you characterize a specific scope?
21:31:25 <piet> leong CarolBarrett Yep
21:31:25 <kencjohnston> leong: +1, an that scope should be user focused, not nessaecarily developer focused.
21:31:35 <kencjohnston> s/an/and
21:31:37 <leong> yup.. user story should be user focused
21:31:48 <kencjohnston> leong: Imagine that... :)
21:31:52 <leong> spec/blueprint will be the one that need to be used by developer for implementation
21:31:56 <CarolBarrett> leong: Yes, but I think the current plan is to track at the user story level, not usage scenario (within the user story) level
21:32:19 <CarolBarrett> leong: agree
21:32:37 <leong> every requirement as specified in the user story should have a related/associated spec/blueprint
21:34:59 <piet> Just a thought. It feels like our User Stories are really blue prints and our use cases are really user stories.
21:35:12 <piet> leong Does that make sense?
21:35:32 <CarolBarrett> #action Carol to discuss with Shamail whether the User Story Tracker needs to be enhanced to track Specs/Blueprints/Bugs associated with each usage scenario in a User Story
21:35:36 <kencjohnston> piet: Ahh, yeah now I  get your agile comment. The combined documents aren't "user stories" in the agile sense.
21:35:55 <kencjohnston> As in the "As an X, in order to Y, I'd like Z"
21:36:21 <kencjohnston> those are what we call "Use Cases"
21:36:22 <kencjohnston> So you can think of the User Story as more like an Epic
21:37:14 <piet> Would a user story be more of a blueprint in OpenStack?
21:37:20 <CarolBarrett> kencjohnston +1
21:37:57 <CarolBarrett> piet: a user story is likely to cause multiple blueprints to be created
21:38:04 <leong> User story is not a blueprint
21:38:22 <leong> a user story potentially can create multiple blueprint and spec
21:38:22 <piet> CarolBarrett Kk
21:38:37 <piet> leong K
21:39:19 <CarolBarrett> Anyone else have thoughts about scope?
21:40:02 <CarolBarrett> Ok - let's move on
21:40:12 <CarolBarrett> #topic CPL Updates
21:40:29 <CarolBarrett> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group
21:40:55 <CarolBarrett> If you are listed as an existing CPL, we would like you to confirm that you're able to continue in that role.
21:41:19 <CarolBarrett> If you're interested in becoming a CPL, then pls look over the list and add your name where you'd like to dive in
21:41:49 <leong> CarolBarrett: need to send that message to maillist.. most CPL is not here
21:43:02 <CarolBarrett> Leong: Good point. I thought that had happened. Will ask Arkady to do this since he's been the point of contact for updates
21:43:56 <CarolBarrett> #action Arkady Send a message to the PWG mail list & User-Committee ML asking people to update their CPL info. Include Link to PWG Wiki page for CPL
21:44:15 <CarolBarrett> Does anyone have questions on CPL?
21:45:00 <CarolBarrett> OK - Then let's move to Opens
21:45:06 <CarolBarrett> #topic Opens
21:45:21 <CarolBarrett> I added 2 topics under this to the agenda
21:45:41 <CarolBarrett> 1st - I wanted to get input from you all for upcoming agenda topics.
21:46:20 <leong> midcycle planning?
21:46:31 <kencjohnston> piet: startd a mailing list thread we should discuss at some point. Adding OpenStack Personas to all user stories.
21:47:07 <kencjohnston> I'd add that we need to have another "can people do reviews" discussion. Especially as we have a number of incoming user stories from other User Committee groups.
21:47:07 <piet> kencjohnston Cool
21:47:11 <CarolBarrett> 2 good suggestions - thanks
21:47:18 <CarolBarrett> Others?
21:47:24 <piet> I will be sending a link to a user story in Google docs.  Please review to make sure I'm aligned with the group.
21:47:46 <piet> It will be updated based in feedback from this meeting
21:48:01 <kencjohnston> piet: As a kind of pre-check before submitting it for review in gerrit?
21:48:08 <piet> Yeah
21:48:21 <kencjohnston> piet: ok
21:48:39 <CarolBarrett> #action Carol add midcycle planning and use of Personas to upcoming PWG meeting agenda
21:48:52 <CarolBarrett> anything else on future agenda items?
21:48:56 <piet> One other thing.  I need four more operators for a deployment study
21:49:20 <leong> piet: send that request to ops maillist
21:49:33 <piet> I did
21:49:44 <leong> resend and remind :-)
21:49:57 <piet> I will tomorrow AM
21:50:21 <kencjohnston> piet: I have it on my list, do you already have the OSIC and Rackspace teams signed up?
21:50:56 <piet> kencjohnston As observers or participants?
21:51:06 <kencjohnston> piet: Either?
21:51:37 <kencjohnston> piet: I'll send you a note offline.
21:51:39 <piet> kencjohnston Trying to avoid using folks at OSIC as participants because of bias
21:52:33 <piet> We have folks from Puppet Labs, OSIC, Redhat and Intel observing.
21:52:47 <CarolBarrett> piet: have you gone into other WG meetings to recruit? Like Large Operators or Telco or Scientific WG?
21:53:05 <piet> Not yet, but could send a note
21:53:15 <leong> and EMEA/APAC operators....
21:53:34 <CarolBarrett> Piet: I was actually proposing that you attend their team meetings and add this topic to their agendas... :)
21:53:58 <CarolBarrett> I know it's time consuming, but...
21:53:58 <piet> CarolBarrett LOL. I know you were.
21:54:33 <CarolBarrett> good luck!
21:55:00 <CarolBarrett> Next, I want to confirm that we will cancel our team meetings for 12/26 and 1/2/17
21:55:04 <CarolBarrett> Any issues?
21:55:40 <leong> +1
21:55:40 <CarolBarrett> Wasn't expecting any.... :)
21:55:45 <kencjohnston> CarolBarrett: sounds appropriate, both observed US Holidays.
21:56:16 <CarolBarrett> Next, I want to start collecting info on PWG members who are also part of other User Committee WGs or Teams
21:56:23 <CarolBarrett> #link https://etherpad.openstack.org/p/UC_WG_Outreach
21:57:17 <CarolBarrett> I believe that we will need to reachout to the leaders and probably the members of these groups to introduce the PWG, our mission, work flow and how we can work together
21:57:31 <leong> +1 carol
21:57:40 <MeganR> good idea!
21:57:50 <CarolBarrett> It would be great if people who were active in the groups could help both prep the content and deliver it
21:58:19 <CarolBarrett> If you are working in other WGs or Teams, i'd appreciate if you'd add your name and the WGs/teams to the etherpad at the link
21:59:28 <CarolBarrett> I think we'll want to start this as soon as the simplified work flow task is complete
22:00:44 <CarolBarrett> #action All Add your name along with other UC WGs/Teams that you participate in to https://etherpad.openstack.org/p/UC_WG_Outreach
22:01:03 <CarolBarrett> I think that covers the agenda for today...just as we're out of time.
22:01:07 <CarolBarrett> Thanks everyone
22:01:16 <CarolBarrett> #endmeeting