21:02:49 <CarolBarrett> #startmeeting product working group
21:02:52 <openstack> Meeting started Mon Dec  5 21:02:49 2016 UTC and is due to finish in 60 minutes.  The chair is CarolBarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:56 <openstack> The meeting name has been set to 'product_working_group'
21:02:58 <Rockyg> o/
21:03:03 <kgerald> o/
21:03:05 <shamail> Hi everyone!
21:03:06 <kencjohnston> o/
21:03:09 <pchadwick> o/
21:03:15 <pchadwick> Hello all
21:03:16 <piet> o/
21:03:26 <CarolBarrett> Hi Everyone!
21:03:30 <Rockyg> hey!
21:03:40 <mrhillsman> o/
21:03:41 <Arkady_Kanevsky> hi. I am on gold members calls. so my participation will be sporadic
21:03:52 <piet> Can someone post the link to the agenda?
21:03:57 <CarolBarrett> arkady_kanevsky: thanks for the headsup
21:04:04 <CarolBarrett> Here's a link to the agenda
21:04:47 <CarolBarrett> #link https://wiki.openstack.org/wiki/Meetings/product-team#December_5.2C_2016_Product_Team_Meeting_Agenda
21:04:56 <CarolBarrett> Let's get going
21:05:03 <CarolBarrett> #topic Midcycle Planning
21:05:43 <CarolBarrett> As many may have seen, the Ops have set their next midcycle for Milan in March (13-14).
21:05:44 <shamail> CarolBarrett: Did we decide on location/timeframe?
21:05:55 <shamail> nm :)
21:06:11 <CarolBarrett> shamail: That's the discussion  :)
21:06:17 <CarolBarrett> Do we want to have a midcycle?
21:06:22 <kencjohnston> yes
21:06:23 <CarolBarrett> Do we want to co-locate with Ops?
21:06:28 <kencjohnston> yes :)
21:06:42 <pchadwick> It could be tough to get travel approval ;)
21:06:53 <kencjohnston> I think having a midcycle this cycle, of all cycles, is critical
21:07:07 <CarolBarrett> kencjohnston: why is that?
21:07:23 <shamail> I wouldn’t mind co-locating although it will be tough for me (my company conference is March 20-24)
21:07:27 <kencjohnston> Retooling/reconfiguring for the Forum
21:07:43 <CarolBarrett> kencjohnston: agree
21:07:52 <kencjohnston> plus our new role in the UC as the central point for other UC teams
21:08:01 <CarolBarrett> +1
21:08:04 <shamail> kencjohnston: +1
21:08:15 <shamail> plus its Milan
21:08:20 <CarolBarrett> +1
21:08:20 <kencjohnston> For me personally, the way I get to go to the PWG Midcycle at all is if it is a "two-fer"
21:08:29 <kgerald> I might be able to go to Milan.
21:08:48 <shamail> kencjohnston: I agree, stand-alone is harder unless it is somewhere really affordable
21:08:53 <kencjohnston> Even if it is just domestic travel, it's hard to justify for a one or two day mid-cycle
21:08:59 <kencjohnston> shamail: +1
21:09:23 <CarolBarrett> We might also be able to intercept other midcycles (like enterprise, scientific computing) that will be in Europe or even co-located with Ops
21:09:51 <pchadwick> If there were more co-located agree with kencjohnston that it would make it easier.
21:09:52 <kencjohnston> CarolBarrett: +1
21:09:54 <shamail> I prefer to co-locate especially for this midcycle since, as kencjohnston mentioned, the Forum is coming in Boston and this next ops midcycle would be the source of some of the first sessions
21:10:06 <kencjohnston> We struggled with this question the last time when Ops was in Manchester, how did we feel that worked out?
21:10:12 <shamail> we need to ensure that transition of feedback from ops to Forum happens smoothly and we help where we can
21:10:43 <shamail> Sorry kencjohnston, which question?
21:10:54 <CarolBarrett> kencjohnston: good question. I think it worked well - we connected with a new segment - Scientific folks - and their requirements.
21:11:01 <kencjohnston> shamail: Should we co-locate with ops even when they are outside of the US?
21:11:07 <shamail> Ah, got it
21:11:25 <CarolBarrett> Does anyone want to propose an alternative to co-locating with Ops?
21:11:52 <kencjohnston> CarolBarrett: I agree, I thought it went well, and we still had good PWG attendance.
21:12:06 <shamail> I think we should, we did connect with Scientific WG… and this next Ops meetup.. we should be there to help ensure each “interesting” topic is documented in a way to help it make its best case for a productive Forum session (topic, decisions, key attendees, any user stories before Forum, etc)
21:12:18 <kgerald> kencjohnston: are you saying we should only have PWG meetings in US?
21:12:31 <kencjohnston> kgerald: Absolutely not.
21:12:52 <Leong> o/
21:12:55 <kgerald> kencjohnston: okay. sorry, then I got the question wrong
21:12:59 <kencjohnston> kgerald: Just that everytime we talk about having a mid-cycle out of the US we have had this same discussion. And we've decided to hold teh mid-cycle out of the US once before.
21:13:20 <kencjohnston> kgerald: So we can use that as a proof point in one direction or the other.
21:13:52 <kencjohnston> kgerald: I see it as a proof point that we should hold mid-cycles aligned with ops, even when they are outside of the US.
21:13:53 <kencjohnston> Soudns like others agree.
21:14:13 <CarolBarrett> kencjohnston: +1
21:14:54 <pchadwick> +1
21:15:02 <Rockyg> ++
21:15:13 <Leong> +1 on align with ops mid cycle
21:15:17 <CarolBarrett> If no one has an alternative to propose, then I'd like to close on this with the agreement that we co-locate with Ops; targeting March 15-16 in or around Milan
21:15:27 <kencjohnston> CarolBarrett: ++
21:15:35 <Leong> +1
21:15:57 <CarolBarrett> #agree We will col-locate our Ocata midcycle with Ops on March 15-16 in (or around) Milan
21:16:19 <CarolBarrett> Next question - Do any of the PWG member companies have offices in Milan that can host us?
21:16:36 <kencjohnston> CarolBarrett: I knew that was coming...
21:16:40 <CarolBarrett> :)
21:16:53 <kencjohnston> Rackspace's nearest is in Geneva, and not a very large office.
21:16:54 <CarolBarrett> It doesn't look like Intel has anything
21:17:34 <shamail> There is an IBM Client Center there, I can try asking about space
21:17:39 <Rockyg> I'll have to check Huawei, but that could be tough for me.
21:17:49 <Leong> The Milan ops seems to be a 'renting'  space, alternative is to get members to sponsor?
21:17:52 <CarolBarrett> Shamail: That would be good! Thanks
21:18:18 <CarolBarrett> Rocky: Would appreciate if you could check
21:18:45 <CarolBarrett> Leong: Renting is an option, we can check with Ops to get more info...
21:19:03 <Leong> Though I still prefer member local office :)
21:19:04 <Rockyg> I'll look.  Have to bridge some silos, but if they're the right ones, it might be possible
21:19:05 <CarolBarrett> Leong: Would you be willing to follow-up on that?
21:19:10 <pchadwick> Our website claims we (SUSE) has an office there but I am doubtful.
21:19:19 <Leong> Ok . I will.
21:19:27 <CarolBarrett> pchadwick: Interesting - pls let us know what you find.
21:19:44 <CarolBarrett> #action Leong Check with Ops on their rental plans for midcycle
21:20:09 <CarolBarrett> OK - let's leave this discussion here and pick it up again in our meeting next week to see what folks have found out
21:20:21 <CarolBarrett> #action Carol add Midcycle planning to 12/12 team meeting
21:20:35 <CarolBarrett> Moving on....
21:20:46 <CarolBarrett> #topic Using Persona's in User Stories
21:21:26 <piet> Questions for me?
21:21:52 <kencjohnston> CarolBarrett: piet Here is my proposal.
21:21:56 <CarolBarrett> I know we have the persona's defined and have discussed adding them. I think there are some persona gaps that we need to get defined to support our user stories
21:22:06 <kencjohnston> We've already added the links to the personas to the template, so going forward we should expect all new stories use them
21:22:19 <kgerald> #info good idea. I am drafting a usage example for the capacity management where I will introduce a new persona that I plan to also propose to UX team
21:22:21 <CarolBarrett> think it was bare metal that referenced a type of user that doesn't have a persona defined for it
21:22:35 <kencjohnston> We should ask user story owners to submit patches adding references to the Personas, and filling in gaps if need be
21:22:47 <kencjohnston> s/user story owners/existing user story owners
21:22:48 <CarolBarrett> kgerald: I like that approach.
21:23:11 <kencjohnston> TL;DR all user stories should start using the UX Personas.
21:23:12 <CarolBarrett> kencjohnston: I think that's good. With the path to filling gaps being they propose a new persona to the UX team...
21:23:20 <kencjohnston> CarolBarrett: correct
21:23:30 <Rockyg> I'd love to see a matrix of personae to user stories and/or tasks
21:23:45 <CarolBarrett> Piet: Is there a link you can share?
21:23:53 <kencjohnston> I imagine we are close to 90% covered on the user stories we have today
21:23:57 <piet> Keep mind that the personas are bring updated as we speak
21:24:06 <Rockyg> Or a glossary of jobs that map to personae
21:24:14 <piet> lemme get the link
21:24:50 <piet> Also, keep in mind that there is actually a matrix of personas and model companies
21:25:16 <Rockyg> kewl
21:25:40 <CarolBarrett> We need to add this to our work flow documentation
21:25:49 <piet> The rationale is that personas change slightly or disappear based on the model company, ie service provider v service consumer
21:25:50 <Rockyg> +1
21:26:02 <CarolBarrett> Shamail: Would this fall under the work you're doing to simplify work flow?
21:26:06 <piet> Yeah, you may also want to add model companies
21:26:18 <kencjohnston> CarolBarrett: What is the work-flow impact?
21:26:28 <piet> http://docs.openstack.org/contributor-guide/ux-ui-guidelines/ux-personas.html
21:26:40 <Rockyg> piet, +1 on model compnies
21:26:41 <kencjohnston> CarolBarrett: Now that it is part of the template we reviewers can ensure UX Personas are properly used in new stories.
21:27:13 <CarolBarrett> #link http://docs.openstack.org/contributor-guide/ux-ui-guidelines/ux-personas.html
21:27:25 <piet> Rockyg Thank Jeff Calcaterra for the model companies.  He needs a raise.
21:27:37 <CarolBarrett> :)
21:27:48 * shamail will let Jeff know you said that and that he shouold include this in his annual review
21:27:59 <Rockyg> ++
21:28:21 <piet> Updated build http://docs-draft.openstack.org/39/404439/6/check/gate-openstack-manuals-tox-doc-publish-checkbuild/301308f/publish-docs/contributor-guide/ux-ui-guidelines/ux-personas.html
21:28:48 <CarolBarrett> So we agree we will use personas and if one doesn't exist the user story team has the responsibility to propose new one(s) - anything else on this topic?
21:29:01 <piet> Eventually we will have a separate page for each model company
21:29:08 <CarolBarrett> #agree  We will use personas in User Stories and if one doesn't exist the user story team has the responsibility to propose new one(s)
21:29:30 <piet> CarolBarrett We should also be using model companies
21:29:34 <shamail> Awesome
21:29:37 <pchadwick> @piet - How exhaustive is the model company list supposed to be?
21:30:03 <piet> Four companies, but two have a relationship
21:30:03 <CarolBarrett> where is the list of model companies
21:30:05 <shamail> CarolBarrett: We’ll document it in the workflow as a potential output during the user story acceptance phase
21:30:21 <pchadwick> http://docs-draft.openstack.org/39/404439/6/check/gate-openstack-manuals-tox-doc-publish-checkbuild/301308f/publish-docs/contributor-guide/ux-ui-guidelines/ux-personas/model-companies.html
21:30:23 <piet> Enterprise, service provider, service consumer and academic
21:30:46 <shamail> #link http://docs.openstack.org/contributor-guide/ux-ui-guidelines/ux-personas/model-companies.html#model-companies
21:30:49 <piet> Vary by distros, security needs, personas, etc
21:31:13 <piet> We are in the process of adding more content and pretty pictures for the model companies
21:31:54 <piet> I'd like to work on devops, but need your help adding content - https://etherpad.openstack.org/p/osux-persona-devops
21:31:57 <pchadwick> We might want to discuss elsewhere, but I have universities and service providers that are definitely not using roll your own.
21:32:03 <CarolBarrett> Got it - so we want user story writers to use both Model Company and Personas.
21:32:26 <shamail> And Companies in this case represent market segments
21:32:58 <piet> pchadwick Yep - it's tough trying to keep the model company list small; otherwise we could have a gazzilion
21:33:06 <mrhillsman> whew, step away for a few moments and have to read a lot to catch up hehe
21:33:06 <Rockyg> shamail, I think it's fuzzier than than market segments
21:33:17 <shamail> so when we build a user story and we think of which markets it impacts which will in turn influence which companies we put in the story… the company then has associated roles and that should influence persona selection
21:33:21 <piet> pchadwick However, would like feedback on whether we need to add more companies
21:33:28 <pchadwick> @piet - understood.
21:34:13 <Rockyg> piet, I think we need synonym companies listed under the models
21:34:17 <pchadwick> @piet - My concern is that when two of the companies end up doing roll your own, and the one uses a distro + professional services that doesn't line up with our experience.
21:34:29 <piet> For exmaple, domain admin may mean different things to a service provider or a service consumer. Or even an enterprise
21:34:49 <shamail> Rockyg: when I am looking at the model companies, they all seem to focus on a particular segment (large enterprise, service provider, research) except for the customer company (Moi)
21:34:49 <piet> pchadwick How so?
21:34:57 <kgerald> the persona I am working on is NOC engineer working for a Telco (i.e. I will also propose a new model company)
21:35:26 <Rockyg> Yeah.  That customer one is the grab bag of "other"
21:35:27 <pchadwick> @piet - all of my customers are using a distro (otherwise they aren't customers).
21:35:30 <piet> kgerald Can you create either an etherpad or Google doc so I can participate
21:35:32 <kencjohnston> kgerald: +1, I think it is easy to get lost in the abstract, let's frame these requests for additions based on what we need for user stories
21:35:46 <pchadwick> Some of them are universities or service providers.
21:36:05 <piet> pchadwick That;s exactly the feedback I need from all of you
21:36:06 <kgerald> and I believe a Telco model company would be good to looking into all the NFV use cases
21:36:13 <pchadwick> some of them used professional services to do the installation but now run with internal staff only.
21:36:48 <piet> You are also welcome to submit bugs to the persona doc
21:36:54 <CarolBarrett> pchadwick: can't that level of detail be in the user story?
21:37:07 <kgerald> piet: yes, first want to get some internal feedback and then I'll setup the etherpad
21:37:11 <kencjohnston> piet: +1
21:37:15 <pchadwick> Right now, I couldn't map any of my customers to the one of the models.
21:37:36 <pchadwick> /models/model companies/
21:37:52 <piet> pchadwick Which persona did you want to work on?
21:38:09 <CarolBarrett> pchadwick: that's a problem
21:38:26 <pchadwick> @piet - the personas are pretty accurate from my experience.
21:38:42 <shamail> The companies were created to give some depth to the personas since a persona could have different tasks associated with it in companies of different sizes and OpenStack experience.
21:38:50 <piet> pchadwick Sweet!
21:38:52 <Leong> Pchadwick: that means new type of persona need to be created?
21:39:18 <piet> pchadwick Baremetal Operations?
21:39:34 <kgerald> do we need to have model companies for all personas, or just in those cases where similar personas have different tasks in different companies?
21:39:36 <pchadwick> @piet - that is a whole different can of worms.
21:39:59 <piet> piet stunned that CarolBarrett has pulled-in the conversation
21:40:00 <pchadwick> Bare metal = server, storage and network.
21:40:05 <CarolBarrett> does the adoption model need to be part of the Model Company profile?
21:40:20 <piet> "hasn't" pulled-in
21:40:41 <kencjohnston> piet: +1, can we agree that we should adopt personas and model companies?
21:40:42 <pchadwick> @Carolbarret - we could just map to the deployment models we talk about in the ebook
21:40:43 <shamail> Adoption model influences tasks/responsibilities so I think it does
21:40:44 <CarolBarrett> piet: :)
21:40:47 <piet> CarolBarrett Are you thinking about breaking them up?
21:40:56 <kencjohnston> and like all things openstack if they aren't to our liking then we go contribut eto changing them?
21:41:07 <shamail> kencjohnston: +1, we can document where they “break” if/when we run into the situations
21:41:11 <Rockyg> So, service provider -- does it cover service providers like Workday?  SAAS as opposed to cloud provider...
21:41:28 <piet> kencjohnston +1 - I worry that people allow me to drive something that is a community effort
21:41:36 <CarolBarrett> piet: it just seems like there are lots of different models in the market - so we may need  a couple of Large Enterprise model company definitions to cover the gambit
21:41:47 <pchadwick> @shamail, @kencjohnston +1
21:41:50 <shamail> lol piet
21:41:52 <piet> CarolBarrett Makes sense
21:42:00 <Rockyg> CarolBarrett, ++
21:42:46 <kencjohnston> piet: ++, and contributing to changing them does not happen by IRC'ing with piet :)
21:42:50 <CarolBarrett> Ok - similar to how we resolved the use of persona's, if a user story needs add'l model company definitions, it's up to them to propose them.
21:42:54 <kgerald> is there any stats from OpenStack, e.g, from Summits which types of companies join OpenStack events -> those are the companies we need to model
21:43:34 <kgerald> i guess someone has already discussed about such company categories. can we use such info?
21:43:38 <CarolBarrett> #agree User Story writers are responsible for using Model Companies and as needed, propose additions to the model company set to express the full breadth of the user story
21:43:52 <kencjohnston> CarolBarrett: +!
21:44:51 <piet> kgerald When you feel comfortable adding content - https://etherpad.openstack.org/p/osux-persona-nocengineer
21:45:09 <piet> kgerald Includes formatting and headings
21:45:13 <shamail> Can of worms: Did we ever decide if each user story submission will contain only a single user story or could we actually have the same concept described multiple times with differing personas/companies?  Is each one a user story or are they all one?
21:45:25 <kgerald> piet: thanks for the preparation work
21:45:36 <CarolBarrett> Ok - I think the last thing on this topic is setting a due date for User Stories to be updated....by the end of this year OK?
21:45:47 <piet> All - please help with devops https://etherpad.openstack.org/p/osux-persona-devops
21:46:04 <kgerald> shamail: i'd say it is the same user story. the different comapnies may be part of the usage examples
21:46:23 <shamail> kgerald: Thanks, sounds reasonable.
21:47:04 <piet> I'm digging the support from PWG on this.  Epic!
21:47:14 <CarolBarrett> piet: +1
21:47:30 <Rockyg> ++
21:47:34 <CarolBarrett> Is end of the year OK for updating user stories to personas and model companies?
21:47:48 <kgerald> yes
21:47:52 <shamail> CarolBarrett: +1
21:48:13 <kencjohnston> CarolBarrett: updated... yes
21:48:26 <kencjohnston> CarolBarrett: Merged... seems to be more difficult these days.
21:48:32 <pchadwick> sound reasonable.
21:48:47 <kencjohnston> CarolBarrett: I'll get my patches up this week.
21:48:54 <CarolBarrett> kencjohnston: do you think merged is the right milestone to measure?
21:49:08 <kencjohnston> CarolBarrett: Yeah, it is the one that matters.
21:49:16 <shamail> kencjohnston: +1
21:49:24 <kencjohnston> CarolBarrett: I'm pointing out that we'll have to merge a bunch of changes over a short amount of time, during the holidays
21:49:31 <kencjohnston> something we haven't been great at in the past.
21:49:51 <kencjohnston> Let's ask everyone to get patches up by end of year. And then we as a team need to track the merging of those outstanding patches.
21:49:57 <Rockyg> So, be prepared to do lots of reviwing, folks
21:50:05 <kencjohnston> Rockyg: +1
21:50:15 <Leong> Ok.
21:50:16 <CarolBarrett> kencjohnston: I get that...which will be a challenge. But I think it's the right milestone. So maybe the due date for merging them is to have that complete before our 1st meeting in 2017 (1/9)
21:50:26 <Rockyg> and during my holiday, no less
21:50:27 <kencjohnston> CarolBarrett: +1
21:51:07 <CarolBarrett> #agree User story owners to submit patches for personas and model companies by end of year and be merged ahead of our 1/9/17 team meeting
21:51:09 <Leong> We should just patch Persona. No changes to the story itself?
21:51:22 <kencjohnston> Leong: +1 for patch scope separation
21:51:28 <CarolBarrett> #action Carol add User Story persona and model company update status to 1/9/17 team meeting
21:52:39 <CarolBarrett> We're running short on time and I'd like to skip to an topic for Opens
21:52:42 <CarolBarrett> #topic Opens
21:52:52 <piet> Just a quick note
21:52:59 <CarolBarrett> shamail: Do you want to lead the heads-up on tomorrow's BoD meeting?
21:53:04 <piet> Wanted to let you know early.
21:53:07 <shamail> Sure
21:53:36 <shamail> There is an OpenStack BoD meeting tomorrow from 7A-9A PT tomorrow
21:53:40 <shamail> Agenda can be found at: https://wiki.openstack.org/wiki/Governance/Foundation/6Dec2016BoardMeeting
21:53:42 <piet> So, I will no longer be with Intel at the end of the month
21:53:54 <Rockyg> ouch.
21:53:54 <shamail> In particular, there is a topic called “(08:00) OpenStack Futures - Mark, Toby, Imad, Allison”
21:54:16 <shamail> Associated etherpad: https://etherpad.openstack.org/p/ocata-strategic-review-board
21:54:38 <Arkady_Kanevsky> there is another one - Review and approval of the User Committee Proposal presented at the October and November Board Meetings
21:54:45 <shamail> This topic will cover items such as how PWG fits in and how the concept has worked so far to get important requirements into the community backlog
21:55:10 <shamail> CarolBarrett and I will both be there, we wanted to raise awareness in case others wanted to dial in to listen to the conversation
21:55:21 <kencjohnston> shamail: Interesting. I'll be on the call.
21:55:38 <shamail> I’m glad the topic has been raised and, everyone agrees, that we will not have all answers tomorrow but the BoD will form what questions need to be answered
21:55:47 <kgerald> piet: sorry to hear that
21:55:59 <shamail> That’s all I had CarolBarrett, anything to add?
21:56:19 <shamail> piet: Sorry to hear that, let’s talk this week. :[
21:56:24 <CarolBarrett> Shamail: Think that covers it - Thanks. If people can make the call that would be good.
21:56:25 <piet> To be fair, it was unfair to have just Intel bear the cost associated with UX
21:56:36 <CarolBarrett> Piet: You will be missed....
21:57:13 <CarolBarrett> piet: Can you share plans future plans for UX project in next week's meeting?
21:57:14 <piet> Here's my proposal.  We could talk about having the foundation create a UX position.   Need your help with that...if you agree
21:58:16 <Rockyg> worth a shot
21:58:20 <CarolBarrett> we've got 2 mins left....
21:58:33 <CarolBarrett> How do we want to move this topic forward?
21:58:47 <kgerald> piet: definitely an important position
21:58:48 <piet> Rockyg I thinks its more fair to the community
21:59:00 <Rockyg> Oh, seems like Huawei might have an office in Milan.  I'll talk to Anni
21:59:05 <shamail> I think you should propose that piet
21:59:28 <Arkady_Kanevsky> SHould it on on foundation or should of 5 proposed User WG rep members own it?
21:59:34 <Arkady_Kanevsky> I am back
21:59:40 <CarolBarrett> Piet: Do you want to propose that to the Foundation this week and we can follow-up in this meeting on the 12th?
21:59:52 <piet> shamail CarolBarrett Rockyg kencjohnston Leong Need your help proposing to the foundation
22:00:06 <piet> CarolBarrett Yep
22:00:27 <shamail> Sounds good piet
22:00:30 <shamail> CarolBarrett: We are at time
22:00:32 <Arkady_Kanevsky> thanks for your great work piet. will miss you
22:00:56 <kgerald> bye
22:01:03 <piet> I'll plan to support you until I land somewhere else
22:01:03 <shamail> cya
22:01:07 <Arkady_Kanevsky> bye
22:01:08 <piet> Cheers
22:01:13 <pchadwick> bye
22:01:17 <CarolBarrett> #action Carol to add topic on UX team next steps to 12/12 meeting
22:01:19 <CarolBarrett> Bye all
22:01:22 <CarolBarrett> #endmeeting