21:00:06 <leong> #startmeeting product_working_group
21:00:07 <openstack> Meeting started Mon Jan 30 21:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:10 <openstack> The meeting name has been set to 'product_working_group'
21:00:20 <leong> #topic rollcall
21:00:27 <leong> who is here for Product WG meeting?
21:00:27 <KrishR> o/
21:00:31 <MeganR> o/
21:00:36 <CarolBarrett> o/
21:00:47 <leong> today agenda can be found here:
21:00:55 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:00:57 <Rockyg> CarolBarrett, yup.  And saw your news,  too.  A bit sad, but happy for you.
21:01:09 <Rockyg> o/
21:01:23 <CarolBarrett> Thanks RockyG
21:01:46 <leong> do we have enough quorum to proceed with the meeting?
21:02:03 <mrhillsman> o/
21:02:09 <leong> let's wait for a few more minutes for other people to join
21:02:18 <leong> hi mrhillsman
21:02:26 <mrhillsman> hey there leong
21:02:29 <jamemcc> Hi
21:02:32 <GeraldK> o/
21:03:58 <leong> are we all fine with the Agenda today? if there is anything else not in the Agenda, feel free to raise up in Opens
21:04:30 <kencjohnston> o/
21:04:33 <leong> #topic Action items from last meeting
21:04:40 <leong> hi kencjohnston
21:05:00 <leong> let's quickly review last week action..
21:05:09 <leong> #link Last week action items: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-01-23-21.00.html
21:05:35 <leong> few items to follow up
21:06:06 <leong> Geraldk, leong, kencjohnston, shamail and carolbarrett met last week and drafted a proposal for PWG particiation in Forum
21:06:13 * leong looking for the link..
21:06:48 <leong> #link PWG proposal for Boston Forum: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit
21:07:05 <leong> i created the above slide to summarize the discussion
21:07:47 <GeraldK> nice
21:08:05 <leong> we asked to discuss this proposal in UC meeting this morning.. but the agenda doesn't get through.. we will bring up that in next UC meeting
21:08:09 <MeganR> the slides look good
21:08:40 <AndyU> agree
21:08:43 <leong> in general, we are thinking PWG can help with pre-planning and post-summit aggregation
21:08:45 <MeganR> are we going to meet again about this before the next UC meeting?
21:09:16 <leong> that depends on the team
21:09:28 <leong> anything that you would like to add?
21:10:05 <leong> kencjohnston, meganr, carolbarrett, geraldk? i hope i covered the things we have discussed in the slide
21:10:11 <leong> anything i missed?
21:10:22 <kencjohnston> leong: Nope.
21:10:51 <leong> ok. let's stick with the slides and feel free to comments offline
21:10:58 <GeraldK> LGTM
21:11:08 <leong> kencjohnston, can you update your action items as per last week meeting?
21:11:11 <MeganR> no, the slides look good - I know Carol asked for this topic to be added to the UC meeting, but only Jon was there today, can we have it added to the agenda before the next meeting?
21:11:30 <MeganR> *to the UC meeting agenda
21:11:34 <kencjohnston> leong: I submitted teh BOF session.
21:12:05 <leong> MeganR: i have proposed to add that into next UC meeting agenda
21:12:26 <MeganR> Great - and you'll send the slides to the ML
21:12:30 <leong> MeganR: it is now recorded in irc... but i will make sure to drop another email to UC prior to the meeting
21:12:41 <leong> that's right MeganR
21:12:45 <MeganR> leong: thank you!!
21:12:46 <leong> thanks Kencjohnston
21:13:02 <leong> i have also submitted the PWG Working Session
21:13:21 <leong> anything else from last meeting meeting that we need to review?
21:14:12 <leong> #topic Open User Story Review
21:14:29 <leong> ok... we talked about having to review the user story as a weekly agenda.
21:14:43 <leong> is there any open "user story" that we want to discuss today?
21:14:54 <leong> #link User Story to review: https://review.openstack.org/#/q/project:openstack/openstack-user-stories+status:open
21:15:30 <kencjohnston> leong: Not a user story but I'd request a core reviewer review on - https://review.openstack.org/#/c/424228/
21:15:58 <leong> ok kencjohnston.. i have +2 on it.. we need another core to review
21:16:13 <Rockyg> I'll review after this meeting
21:16:13 <kencjohnston> I also think it woudl be good if someone woudl pick up the Quota management user story - https://review.openstack.org/#/c/407735/
21:16:23 <leong> thanks Rockg
21:16:41 <kencjohnston> Rockyg: Thanks!
21:16:58 <Rockyg> Yeah on the quota story.  We've just gotten a lot of good info from the ops group on quota issues.
21:17:03 <leong> for 424228, looks like need more works on it?
21:17:29 <leong> kencjohnston, are you taking over 424228 from Piet
21:17:33 <kencjohnston> On 424228 we do not.
21:17:47 <kencjohnston> leong: I think you are referencing another story...
21:17:52 <GeraldK> on the quota story: what about taking over the parts from the capacity mgmt user story that deal with quotas. that might also help to narrow the scope of the capacity mgt user story.
21:18:01 <leong> ok.. i must mess up
21:18:55 <kencjohnston> CarolBarrett just +2'd  https://review.openstack.org/#/c/424228/ so it is on it's way to merge.
21:18:58 <leong> sorry.. i would probably means: 407735/
21:19:12 <leong> thanks CarolBarrett
21:19:33 <CarolBarrett> Welcome!
21:19:54 <leong> looks like we need more works/review on 407735
21:19:57 <kencjohnston> leong: Agreed, 407735 needs work. I wasn't planning on picking it up from Piet. I've got two others I picked up from him ATM.
21:20:28 <leong> ok... anyone volunteer to look at 407335 more closely?
21:20:47 <leong> it was originally submitted by Piet for Quota Mgmt
21:21:22 <leong> shall i mark that as "WIP"
21:22:23 <leong> anything else on gerrit that need review?
21:22:41 <leong> shall we move on to next topic then?
21:23:22 <kencjohnston> leong: +1 to marking as WIP and moving on.
21:23:38 <leong> #topic Midcycle planning
21:23:50 <leong> let's talk about midcycle
21:24:05 <leong> #link Midcycle Planning Etherpad: https://etherpad.openstack.org/p/MIL-pwg-meetup
21:24:19 <leong> first, are we confirm on the date?
21:24:25 <leong> March 13th and 14th 2017 (Monday & Tuesday)?
21:26:05 <leong> anyone got travel approval to attend midcycle at Milan?
21:26:15 <Rockyg> I do.
21:26:22 <leong> nice!
21:26:23 <Rockyg> Well, I will.
21:26:35 <leong> i think i will got mine as well
21:26:51 <kencjohnston> I'm still on the fence
21:27:04 <leong> shamail can't attend today meeting... i believe he told me IBM can host us?
21:27:07 <AndyU> Leong: I'm a solid "maybe"
21:27:15 <leong> is that right? CarolBarrett?
21:27:45 <leong> rockyg, any thing from Huawei to host PWG midcycle?
21:28:15 <leong> AndyU, i hope the maybe will turn into "yes" :)
21:28:21 <Rockyg> I need to recheck, but I don't think the office is in Milan.  I'll double check with Anni.
21:28:31 <MeganR> I won't be attending. :(
21:28:39 <leong> thanks Rockyg
21:28:53 <leong> that's sad MeganR
21:29:25 <MeganR> I'll miss being with the team!
21:29:39 <leong> looks like many are still "pending" on travel approval, let's keep that as a following-item to discuss next week?
21:30:29 <leong> #action RockyG to check with Anni on Huawei office for PWG midcycle
21:30:49 <leong> #action leong to check with Shamail to confirm if IBM can host PWG midcycle
21:31:34 <leong> #topic Boston Summit
21:31:53 <leong> Forum discussion
21:32:04 <leong> we just talked about the drafted proposal earlier on..
21:32:14 <leong> anything else has questions?
21:33:12 <leong> #link PWG proposal for Boston Forum: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit
21:33:52 <leong> is there anything else we want to discuss about the Forum?
21:35:47 * leong looking at kencjohnston, geraldk, rockyg, meganr, carolbarrett, andyu ....
21:36:35 <MeganR> not at the moment, you and Carol helped me "finally" understand it  :)
21:36:42 <Rockyg> Question... should I try to get a session for Error Codes for the forum?
21:36:58 <GeraldK> no questions from my side.
21:37:03 <leong> MeganR: haha :-)
21:37:10 <AndyU> I confess... I'm still working on "understanding" it
21:37:37 <leong> Rockyg: i think the Error codes could be fall into "improving logging" as a whole
21:37:53 <leong> might worth to have a joint-session with LCOO on logging?
21:38:29 <leong> as discussed in this morning UC meeting.. all WG are advised to submit session by Feb 6th
21:38:37 <Rockyg> Yup.  I'll look further into it, then.
21:38:50 <AndyU> If we have a little lead time to get the word out and draw in the right people it could be a very good topic
21:40:07 <leong> AndyU, Rokcyg, i am wondering if we can work on a User Story prior to Forum
21:40:19 <leong> that will give us a strong position and discussion point "during" the Forum
21:40:28 <Rockyg> I was heading up the effort, but ran out of time.  There's a Japanese team that wants to move it forward, though.
21:40:40 <leong> i think Fujitsu is also interested in..
21:40:45 <AndyU> Would that be NTT?
21:40:55 <Rockyg> I've got *lots* of docs on this.
21:41:09 <leong> let's bring that into a common user story...
21:41:20 <AndyU> I'm game to try. This will be new territory.
21:41:31 <leong> AndyU, do you want to take the lead to create that user story?
21:41:36 <leong> i can help you with that...
21:41:47 <Rockyg> It's already started by Pieter.
21:41:56 <Rockyg> A bit disjoint, but there.
21:42:14 <AndyU> Leong: I'd live to discuss it with you. Just not sure what I'd be agreeing to yet  ;-)
21:42:30 <leong> no problem AndyU
21:42:37 <leong> Rockyg, that reminded me..
21:42:54 <leong> i belive this is the story that Piet created before..
21:43:09 <leong> #link Error Code User Story: https://review.openstack.org/#/c/409878/
21:43:39 <leong> maybe let's review that user story and see how this can be collaborated among LCOO, PWG and rest
21:43:46 <Rockyg> Yup.  That's the one.
21:44:51 <AndyU> Thanks for the link; was looking for it. I'll reach out on my side about this.
21:45:02 <leong> #agreed RockyG, AndyU, Leong to review Error Code User Story as a first start for Logging https://review.openstack.org/#/c/409878/
21:45:46 <leong> anything we want to talk about Forum before we move on to the next topic on Conference Session?
21:46:40 <leong> let's talk about the Conference Session at Boston Summit
21:47:17 <leong> anyone has session proposal for the User Conference?
21:47:50 <leong> I was talking to Kei (Fujitsu, co-chair PWG regional meeting), we are thinking to submit a kind of "evangelise session" to introduce Product WG and its workflow
21:48:09 <leong> this was also brought up by andyu this morning in UC meeting
21:49:06 <AndyU> IMO, important to use Boston as a platform to raise awareness about the PWG Process and AUC role in general
21:49:31 <leong> AndyU, would you be interested to joint-present?
21:49:36 <AndyU> have there been any success stories yet? Or still too new?
21:49:53 <AndyU> Leong, Most definitely!
21:49:54 <leong> we can use "baremetal" as an example...
21:50:51 <leong> cool
21:51:30 <leong> #agreed Leong, AndyU and Kei will work on a joint-presentation to evangelise PWG process and AUC
21:51:43 <Rockyg> I strongly agree.  We need to let endusers (providers and private cloud ops/users/etc) know that the PWG is the place to get new features and large fixes promoted to dev community
21:52:07 <leong> +2 rockyg
21:52:31 <AndyU> perfect. thanks for including me.
21:53:17 <leong> anyone else has any other session ideas for the User Conference?
21:55:09 <leong> 5 mins to the hr..let's move on to "Open"
21:55:10 <AndyU> Is it possible to repeat a session introducing/training about the pwg process? Offer it multiple times to accommodate different schedules?
21:55:41 <leong> AndyU, do you mean multiple same sessions at the Boston Summit?
21:55:41 <AndyU> move on - we can discuss later
21:55:56 <AndyU> yes, repeats of same session
21:56:06 <leong> i don't think so.. usually in the past, it will be one session for whole submit
21:56:08 <leong> summit
21:56:21 <AndyU> ok, thx
21:56:30 <leong> but we can repeat that in the upcoming summit
21:56:58 <leong> i mean boston, sydney, etc..
21:57:38 <leong> #topic Open
21:57:48 <Rockyg> We might want to consider adding a course as part of the tutorials beforehand.
21:57:49 <leong> we have to proposed Agenda in next meeting...
21:57:52 <leong> anything else to add?
21:58:29 <leong> 2 mins...
21:58:37 <AndyU> RockyG, +1
21:59:13 <leong> right now we have two proposed agenda: User Story Tracker and Simplifying User Story Submission
21:59:56 <leong> if there is anything else to discuss, feel free to reach out to me...
22:00:06 <leong> thank you everyone !
22:00:11 <MeganR> Bye!
22:00:16 <leong> #endmeeting