21:00:28 <leong> #startmeeting product_working_group
21:00:28 <openstack> Meeting started Mon Feb  6 21:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:31 <openstack> The meeting name has been set to 'product_working_group'
21:00:40 <Rockyg> o/
21:00:45 <leong> anyone here for Product WG meeting?
21:00:51 <MeganR> o/
21:00:55 <leong> #topic rollcall
21:00:56 <leong> o/
21:01:00 <kencjohnston> o/
21:01:21 <leong> hi rockyg, meganr, kencjohnston and krishr...
21:01:33 <KrishR> hi Leong
21:01:40 <leong> today agenda can be found here:
21:01:45 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:02:14 <leong> hopefully shamail can join us as well....
21:02:35 <leong> anything else that you would like to add to today Agenda?
21:02:49 <Arkady_Kanevsky> hello
21:02:57 <leong> hi arkady
21:03:10 <Arkady_Kanevsky> hi leong
21:03:20 <leong> #topic Action items from previous meeting
21:03:25 <mrhillsman> o/
21:03:33 * Rockyg waves to everbody
21:03:36 <leong> #link Last week action items: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-01-30-21.00.html
21:03:56 * leong wave...
21:04:15 <leong> let's have a quick update from last week meeting...
21:04:36 <leong> the PWG midcycle location
21:04:49 <leong> Rockyg, do you have anything from Huawei?
21:05:57 <leong> also a question to everyone, have anyone receive/confirm travel to Milan Ops midcycle?
21:06:13 <Arkady_Kanevsky> no on Milan
21:06:14 <leong> i think we need to estimate the attendees and size of room
21:06:25 <Arkady_Kanevsky> but I planning to
21:06:45 <leong> my travel to Milan is approved
21:07:27 <MeganR> I will not be going
21:07:34 <heidijoy> I will be there.
21:07:43 <Arkady_Kanevsky> I plan to attend
21:08:42 <leong> Rockyg, do you have anything from Huawei?
21:08:48 <Rockyg> I've got yet another name to track down.  Office is about 1/2 hour from ops meetup site by car.  very round about.  I have to find out how big the office is and who's in charge.
21:09:14 <Rockyg> But, a little progress.
21:09:26 <Arkady_Kanevsky> any chance we can have it all in one place with ops summit?
21:10:02 <leong> i also prefer the same location as with Ops midcycle.... i remember the cost is about euro$300 per day
21:10:08 <leong> for a room
21:10:34 <Rockyg> Hmm.  Lemme run that by Anni....
21:10:41 <leong> if anyone here can get a "sponsor", then we can be at the same place
21:10:59 <Arkady_Kanevsky> meeting room or individual hotel room?
21:11:11 <leong> meeting room
21:11:45 <Rockyg> so, is it two or three days?
21:11:51 <Arkady_Kanevsky> I rcealled Intel was also volunteering...
21:11:53 <leong> mrhilsman: maybe if you can help us to validate if we can book a meeting room at the same location as Ops midcycle
21:12:23 <leong> the plan was two days PWG at Milan
21:12:56 <heidijoy> ^^Correct- plan is Mon/Tue preceding the Wed/Thur Ops Midcycle
21:12:57 <Rockyg> thanks.
21:13:02 <leong> Arkady_Kanevsky: i think u mix up with Aug one.. but Intel is not able to sponsor the Aug one either
21:13:25 <Arkady_Kanevsky> got it
21:13:50 <leong> Let's discuss the PWG Ops meetup again next week, we also need to make sure we have enough quorom to host the F2F meeting for PWG
21:14:05 <Rockyg> I texted Anni.  We'll see...
21:14:17 <leong> hi shamail
21:14:27 <Rockyg> hey, shamail
21:14:28 <leong> we were just talking about the mid-cycle location
21:14:47 <shamail> Hi Leong and everyone!  Sorry for being late, just landed.
21:15:02 <leong> not a problem..
21:15:08 <leong> can you confirm if IBM can host us? someone also suggest the same location as Ops
21:15:18 <shamail> IBM can host us during midcycle but I am confirming the final details
21:15:32 <shamail> It's more than likely that we can find space but I can confirm next week.
21:15:42 <leong> great.. thanks! let's follow up this again in next week meeting..
21:15:58 <shamail> Did we find out if it would be possible to get space in the same venue as the ops meetup?
21:16:17 <leong> #agreed: to follow-up the PWG mid-cycle planning next week
21:16:18 <shamail> mrhillsman: ping
21:17:18 <leong> let's follow that up offline with mrhillsman.. :-)
21:17:40 <leong> let's move on to next topic :)
21:17:45 <leong> #topic "open" gerrit review
21:17:58 <leong> #link gerrit: https://review.openstack.org/#/q/project:openstack/openstack-user-stories+status:open
21:18:07 <leong> any one gerrit item that need our attention?
21:19:17 <Arkady_Kanevsky> we have some fairly old ones sitting without progress
21:19:29 <AndyU> We'll be discussing Improve Error Codes Story in LCOO meeting this week
21:19:39 <leong> +1 andyU
21:19:44 <mrhillsman> sorry, had to step away
21:19:45 <Arkady_Kanevsky> like - https://review.openstack.org/253228
21:19:57 <Rockyg> Also tonight in Regional PWG
21:20:06 <leong> +1 rockg :)
21:20:15 <Arkady_Kanevsky> what shoudl we do with the ones that are not being responded on?
21:20:38 <shamail> Np mrhillsman, I was trying to find out if it would be possible to use the same venue as the ops meetup in Milan.  I'll follow up via email.
21:21:14 <shamail> Arkady_Kanevsky: I think we leave them alone for now unless the authors have made the necessary changes.  We can discuss further at midcycle to see if we need to abandon any.
21:21:16 <leong> Arkady_kanevsky, i will go through the list today and tomorrow and will reply on gerrit
21:21:18 <Rockyg> if we want movement on specific ones, someone should comment to get discussion happening again.
21:21:25 <leong> +1 shamail
21:21:30 <mrhillsman> ok shamail will keep an eye out
21:21:34 <kencjohnston> on gerrit, I had an item with a merge conflcit that I just resolved - https://review.openstack.org/#/c/352182/
21:22:00 <shamail> Nice kencjohnston
21:22:04 <Arkady_Kanevsky> Propose that if a patch was review and have feedback and author is not updating it acroiss releases we abandon it.
21:22:17 <leong> thanks kencjohnston.. i will have a look after this meeting
21:22:18 <kencjohnston> Also, we have a couple of "Abandon potentials" from Piet
21:22:23 <Arkady_Kanevsky> Thanks Shamail and Leong.
21:22:36 <leong> also, as Carol retired, we need to get more core reviewer
21:22:40 <Arkady_Kanevsky> Agree <kencjohnston>
21:22:44 <shamail> kencjohnston: +1
21:22:59 <Rockyg> I think we need to ping authors before we abandon.....
21:23:00 <kencjohnston> Without new owners steppign forward I'm willing to get what is there merged, but not going to be able to own it for updates/scope additions.
21:23:10 <Arkady_Kanevsky> I am trying to dillegently review any pacthes that are updated.
21:23:16 <Rockyg> And should come up with a policy on when to mark abandoned
21:23:18 <shamail> kencjohnston: +1
21:23:28 <Arkady_Kanevsky> nut will not comment on the ones that are already havce comments that are not being addressed
21:23:45 <shamail> I think we can revisit what needs to be abandoned when we are all together at midcycle
21:23:51 <Rockyg> ++
21:23:54 <Arkady_Kanevsky> +1
21:23:58 <leong> +1 shamail
21:24:03 <shamail> Rockyg: +1 on policy
21:24:04 <kencjohnston> shamail +1
21:24:25 <Arkady_Kanevsky> I think that only chair can abandon pull request or the author
21:24:27 <Rockyg> Policy should go on midcycle agenda...
21:24:51 <shamail> Leong can you make an action to review Ken's updated patch and agreement on reviewing old changes at midcycle
21:24:53 <leong> i think "core" can abandon
21:25:05 <shamail> Core is fair.
21:25:07 <Rockyg> leong, ++
21:25:30 <Arkady_Kanevsky> I am fine as long as we have formally defined process.
21:25:32 * kencjohnston pulls out his "abandon" baseball bat.
21:25:37 <leong> #agreed All review Kenny updated patch https://review.openstack.org/#/c/352182/
21:25:48 <shamail> lol kencjohnston
21:25:52 <kencjohnston> That patch was ready for merge, just hit a conflict that I took to long ot resolve.
21:26:00 <shamail> Yeah, saw that
21:26:09 <shamail> Should be a quick workflow
21:26:14 <leong> #agreed All will review the list of changes at gerrit and define abandon policy at Midcycle
21:27:08 <leong> any thing else on this agenda? if not, shall we move on to next topic?
21:27:48 <leong> #topic Updates on the proposal for PWG participation in Forum
21:28:27 <leong> #link Proposal: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit
21:28:50 <leong> We will present the above proposal at next UC meeting...
21:29:12 <leong> any feedback and comments?
21:29:15 <leong> shamail, do you have anything to add
21:29:17 <leong> ?
21:29:44 <shamail> We didn't present at the last UC meeting or did it get cancelled?
21:29:53 <shamail> (I missed it)
21:30:01 <leong> the agenda wasn't added to last UC meeting
21:30:16 <leong> and 2 out of 3 UC wasn't there
21:30:48 <shamail> Oh, okay.  Nothing add.. look forward to the team's feedback.  I should be able to attend the next UC meeting as well.
21:31:09 <shamail> 5 of us agreed to volunteer and continue this work until the Summit.
21:31:13 <leong> yup
21:31:25 <shamail> I will send a doodle poll once we hear feedback from UC to continue that work.
21:31:33 <Arkady_Kanevsky> nice proposal
21:31:35 <leong> 5= shamail, leong, meganr, kencjohnston and geraldk
21:31:46 <shamail> Others are welcome to join, just respond to the doodle poll when you see it.
21:31:56 <shamail> We will also be reaching out more broadly than just PWG
21:32:02 <kencjohnston> leong shamail - If I can help with the UC presentation let me know
21:32:03 <leong> it will be great to get everyone else in PWG to join!
21:32:16 <Arkady_Kanevsky> suggest that we are responsible that there is a rep from each required WG to attend.
21:32:24 <shamail> kencjohnston: absolutely
21:32:43 <Arkady_Kanevsky> I can help.
21:32:47 <shamail> I think Leong and yourself volunteered to present, I'll just be there to help provide support and say "YES!"
21:32:56 <leong> haha :-)
21:33:11 <shamail> I don't want to schedule the doodle poll though until we get feedback from UC
21:33:26 <leong> shamail: agree
21:33:27 <kencjohnston> I have to juggle around my calendar to make the UC meetings so let me know once we get on the agenda and I'll make it a priority to attend.
21:33:29 <shamail> So that's probably the next step after the UC meeting
21:33:42 <shamail> kencjohnston: +1, will do
21:33:58 <leong> i will take the lead to present the proposal at UC meeting, with support from Shamail and Kencjohnston :-)
21:34:08 <shamail> leong: do you want to pursue getting it added to agenda or do you want me to?
21:34:34 <leong> it is already added to the UC next meeting agenda... i will double check again
21:34:44 <shamail> Okay, thanks
21:34:58 <leong> #action Leong to check the proposal is added to UC meeting agenda
21:35:23 <leong> next topic on the agenda is Session Submissions
21:35:32 <leong> #topic Session Submissions
21:35:47 <Arkady_Kanevsky> for boston summit?
21:35:55 <leong> yup boston summit
21:35:57 <leong> I have submitted the PWG Working Session and Kenny has submitted the BoF
21:36:12 <leong> the deadline is today 11:59pm Pacific
21:36:24 <leong> i believe Shamail also submitted a Roadmap session
21:36:41 <shamail> I submitted the roadmap session and added Ken and Pete for now to ensure we made the deadline.  We can revisit the session/speakers if it's accepted
21:37:01 <leong> +1 shamail
21:37:20 <Rockyg> I'm trying to get a log WG session for Boston.  Work on error code stories, spec, etc.
21:37:24 <shamail> kencjohnston I meant :)
21:37:44 <shamail> Rockyg: Forum sessions haven't opened yet
21:38:04 <Rockyg> Wg group session, not forum
21:38:25 <shamail> Ah
21:38:54 <leong> rockyg: you mean a Logging Working Group? do we have that?
21:39:06 <Rockyg> log wg is moribund, but looks like ther's enough interest to get it going again.
21:39:07 <Arkady_Kanevsky> is it worth submitting something on Themes?
21:39:26 <shamail> I have to leave, boarding next flight soon :). I'll catch up via log.  Ya
21:39:29 <shamail> Ya
21:39:36 <Rockyg> leong, yup.  I am co-chair, but it's not been meeting for a while
21:39:37 <shamail> Take care!*
21:39:49 <leong> take care shamail
21:40:00 <Arkady_Kanevsky> SHould we submit one on status on non-disruptive upgrade user story?
21:40:08 <leong> rockyg: got it ..
21:40:24 <Arkady_Kanevsky> or is an example of roadmap submission?
21:41:10 <leong> Arkady_Kanevsky: i don't get you?
21:41:33 <Arkady_Kanevsky> upgrade is the olde user story we were driving.
21:42:15 <Arkady_Kanevsky> should we submit review of results of that work. And use Tracker for it
21:42:54 <leong> do you mean an agenda item in PWG WG session? or a separate discussion session at Forum
21:43:10 <leong> the Forum is not opening to accept submission yet.
21:43:12 <Arkady_Kanevsky> submission for bosotn summit
21:43:44 <Arkady_Kanevsky> deadline it today
21:44:19 <leong> Are referring to present a "user story update" presentation for Rolling Upgrade?
21:44:28 <Arkady_Kanevsky> yes
21:45:13 <leong> i'm not sure how much thing we can update on "rolling upgrade"? Kencjohnston?
21:46:04 <leong> kei, andyu and I have submitted a session to "promote / explain" Product WG, we plan to use Baremetal as an example.
21:46:10 <Arkady_Kanevsky> my concern that we as PWG are submitting very few things for a summit. so I am thinking what can we submit that are intersteding for community
21:46:16 <kencjohnston> Hmm, I'd be included to leave the updates on progress to the developers, but I agree on Arkady_Kanevsky point.
21:46:32 <kencjohnston> Arkady_Kanevsky +1, it would be interesting for the community, and provide visibility
21:46:37 <Arkady_Kanevsky> <leong> - cool
21:46:52 <kencjohnston> I'm not sure I could get the submission together in time, I'll try and throw something together tonight.
21:47:09 <leong> ok.. thanks kencjohnston
21:47:13 <heidijoy> Also the PWG will be helping to guide the PTL project sessions with a presentation template.
21:47:19 <leong> #info kei, andyu and leong have submitted a session to "promote / explain" Product WG, and plan to use Baremetal as an example.
21:47:21 <Arkady_Kanevsky> for tonight we only need a short blurb. real work will come later if accepetd
21:47:28 <kencjohnston> I have until 2am right?
21:47:38 <leong> 11:59pm Pacific :)
21:47:49 <Arkady_Kanevsky> Ken, I will be happy wotk work with you on it.
21:47:50 <kencjohnston> leong Right, like I said, 2am for me
21:48:01 <kencjohnston> Arkady_Kanevsky +1 thanks, I'll shoot you a note
21:48:13 <Arkady_Kanevsky> +1
21:48:33 <leong> #info Kencjonston and Arkady_Kanevsky will work on an update for Rolling Upgrade user-story
21:48:57 <leong> anything else on this agenda?
21:49:24 <leong> #topic Simplifying User Story Submission
21:49:36 <leong> #link https://etherpad.openstack.org/p/PWG-story-submission-ideas
21:49:36 <Rockyg> ++
21:50:26 <leong> i think we can discuss this at Midcycle as well on how to simplify user story submission?
21:50:41 <Arkady_Kanevsky> +1 leong
21:50:51 <leong> Please continue to brainstorm and put your suggestion on the above etherpad
21:51:21 <leong> #agreed Leong to include "Simplifying User Story Submission" in PWG Midcycle Agenda
21:51:34 <leong> #topic Open
21:51:37 <AndyU> Is the name going to possibly change? From "Story" to something higher level sounding?
21:52:12 <leong> AndyU: someone brought up that point as well, can you add that into the etherpad?
21:52:21 <AndyU> will do
21:52:34 <Arkady_Kanevsky> will comment on etherpad
21:52:44 <leong> any open item for the remaining 8 mins
21:53:17 <leong> i have one item for Open discussion...
21:53:26 <leong> is about LCOO
21:53:50 <leong> LCOO is a new WG that initiated by few large operators (AT&T, Orange, NTT, etc...)
21:54:22 <leong> they are still in a planning phase.. and AndyU is a co-chair of LCOO roadmap team
21:54:31 <Arkady_Kanevsky> I saw that. do we really need a new group for it?
21:54:36 <Rockyg> leong, thanks for bringing this up.
21:55:01 <leong> I was involved/engaged in recent conversation.. i think we, as in Product WG, can help to group to integrate with the community?
21:55:16 <leong> LCOO is keen to adopt our PWG workflow
21:55:21 <Arkady_Kanevsky> Why is Telco group not sufficient for it?
21:55:26 <Rockyg> It would be great if they could just integrate into existing WGs
21:55:39 <heidijoy> Additional topic: FYI, I'm distributing roadmap survey request today to PTLs - 25 projects covered - for the Ocata cycle & beyond.
21:55:44 <Rockyg> Might give the WGs some extra energy
21:55:44 <leong> the Telco group is a different function from LCOO
21:55:55 <leong> thanks heidijoy
21:56:02 <Arkady_Kanevsky> Love it if they use our workflow
21:56:15 <leong> #info Heidijoy is distributing roadmap survey request today to PTLs - 25 projects covered - for the Ocata cycle & beyond
21:56:38 <heidijoy> The foundation is looking to the PWG for help in prioritizing/highlighting Ocata features that support our "one platform" message.
21:57:06 <kencjohnston> heidijoy Where can we get more details on what we mean by "one platform"?
21:57:31 <heidijoy> our “one platform” message—that OpenStack enables users to coordinate virtual machines, bare metal, containers and other emerging technologies from a single platform. If your team’s features support this effort, please explain how they do so on the survey so we can highlight your project.
21:57:34 <leong> i am hoping that PWG members here can help to collaborate with LCOO... one example is the Logging feature
21:58:08 <Arkady_Kanevsky> heidi what help do you envision from PWG?
21:58:10 <heidijoy> kencjohnston: I'll follow up for a better description
21:58:20 <kencjohnston> heidijoy No worries, that gets me started :)
21:58:30 <AndyU> LCOO is definitely seeking to collaborate with PWG
21:59:01 <heidijoy> arkady_kanevsky: Looking for a few PWG folks to review the spreadsheet of answers and make notes (Google Sheets) on what has strong end-user benefit and/or significance for "one platform"
21:59:18 <Arkady_Kanevsky> heidi - I will be happy to help
21:59:32 <leong> any questions for LCOO?
21:59:56 <Arkady_Kanevsky> are LCOO meeting at Milan?
21:59:58 <Rockyg> Will anyone be attending tonight's PWG from LCOO?
22:00:06 <leong> Arkady, heidijoy, ken: will take note on that discussion with "one platform"
22:00:11 <Arkady_Kanevsky> If yes, can we invite them to "joint: meetong?
22:00:18 <leong> yes... AndyU from LCO is planning to
22:00:26 <Rockyg> Thanks1
22:00:31 <AndyU> RockyG: not that I know of, but perhaps
22:00:39 <leong> sorry... i refer to Milan meeting
22:00:45 <Rockyg> 10pm PST
22:00:57 <leong> Rockyg, i will discuss that in tonight regional meeting
22:00:59 <Rockyg> Late for folks with farms
22:01:10 <AndyU> Yes, I'm hoping to join you in Milan. Not approved to travel yet though.
22:01:16 <mordred> Rockyg: people can stay up late on the farm too :)
22:01:25 <Arkady_Kanevsky> neec to drop
22:01:30 <AndyU> Rocky G; ha ha
22:01:39 <leong> we hit the hour..
22:01:50 <leong> please direct questions to mailing list if necessary
22:01:57 <leong> #endmeeting