21:00:53 <leong> #startmeeting product_working_group
21:00:54 <openstack> Meeting started Mon Feb 13 21:00:53 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:57 <openstack> The meeting name has been set to 'product_working_group'
21:01:26 <leong> #topic rollcall
21:01:26 <shamail> Hi all
21:01:32 <leong> who is here for PWG meeting?
21:01:56 <Arkady_Kanevsky> hello all
21:02:01 <GeraldK> hi
21:02:02 <leong> hi arkady shamail
21:02:06 <leong> hi geraldk
21:02:20 <leong> today agenda can be found here
21:02:31 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:02:47 <leong> hi heidijoy_
21:03:14 <heidijoy_> Hello!
21:04:03 <leong> if you have any item to discuss, feel free to raise up...
21:04:14 <Arkady_Kanevsky> Ken and I submitted "update on upgrade story" to Boston summit. AI closed.
21:04:23 <leong> #topic Action items from last meeting
21:04:44 <leong> #info Ken and Arkady_Kanevsky submitted "update on upgrade story" to Boston summit.
21:05:07 <leong> #link last week meeting logs: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-02-06-21.00.html
21:05:54 <leong> we brought up the PWG Forum proposal in this morning UC meeting..
21:06:14 <leong> it is suggested to discuss after the UC election is closed after this Friday...
21:06:59 <leong> #info Shamail and Leong will follow up the PWG forum proposal after the UC election as there will be 2 new UC members
21:07:12 <Arkady_Kanevsky> +1
21:07:23 <leong> any thing else from last week meeting?
21:08:03 <leong> #topic "open" gerrit review
21:08:16 <Arkady_Kanevsky> nope. only mid-cycle planning which is a separate topic on agneda
21:08:38 <leong> ok..i set this as a regular topic.. anything that need attention to review user-stories?
21:08:54 <leong> #link user-story review: https://review.openstack.org/#/q/project:openstack/openstack-user-stories+status:open
21:09:00 <Arkady_Kanevsky> I would like review for 2 of my tracking pull requests
21:09:28 <Arkady_Kanevsky> https://review.openstack.org/#/c/426613/ and https://review.openstack.org/#/c/428571/
21:09:55 <leong> arkady_kanevsky: are they still Work In Progress?
21:09:56 <Arkady_Kanevsky> see good progress on others including pieters
21:10:01 * shamail is slightly distracted while multi-tasking, sorry
21:10:03 <leong> or are they ready to review?
21:10:05 <Arkady_Kanevsky> yes WIP
21:10:28 <Arkady_Kanevsky> working on gap analysis. Tus, active on template for it
21:10:34 <leong> nice
21:10:57 <GeraldK> we need one more review for the template: https://review.openstack.org/#/c/426994/
21:11:06 <leong> that bring to the next item... need core to approve the first revision of gap-analysis template
21:11:14 <Arkady_Kanevsky> but not all pieter's pull requests are moving forward...
21:11:25 <leong> thanks GeraldK
21:12:15 <leong> #link Gap-analysis template: https://review.openstack.org/#/c/426994/
21:12:21 <Arkady_Kanevsky> we need second +2 on Gerald's one
21:12:31 <kencjohnston> leong GeraldK I'm still not onboard with why we need gaps analysis as a separate document
21:12:49 <leong> hi kencjohnston
21:12:54 <kencjohnston> I'm sorry if I missed the meeting when this was previously discussed
21:13:06 <shamail> Where would you include it otherwise kencjohnston? Curious
21:13:11 <Arkady_Kanevsky> you had not missed anything.
21:13:17 <kencjohnston> It seems to me like gaps analysis should either happen in the user story, as we iterate on it, or in a cross project spec
21:13:18 <Arkady_Kanevsky> all discussions are on pull request
21:13:32 <leong> kencjohnston, if you look at existing workflow, there is this gap-analysis phase
21:13:50 <GeraldK> user story should IMHO not include gap analysis. different persons may work on it.
21:13:50 <leong> this document is for that phase
21:14:03 <kencjohnston> leong Agreed, but why a separate document?
21:14:05 <leong> user story only specify "requriements"
21:14:06 <kencjohnston> GeraldK Say more about that?
21:14:30 <Arkady_Kanevsky> Ken, what happens when you have a gap that does not have any projects that can cover it?
21:14:38 <leong> i believe that was the discussion many months back that we want to take the "gap-analysis" out from the "user-requirements"
21:14:52 <kencjohnston> Cross project spec, leave it in the user story?
21:15:12 <kencjohnston> Does the development community/tc agree that we need to create another artifact that is out of bands of the ones they officially use?
21:15:15 <GeraldK> the user story might be written by someone with no / little technical background. the gap analysis needs very good knowledge of the different projects
21:15:20 <shamail> kencjohnston: the gaps analysis is happening before the implantation so cross project spec would not exist yet.  It is to identify what are the areas we need to figure out an implementation plan for.  If we add it to the user story then we will be adding a lot of technical/implementation details into a document that is generally more concept oriented.
21:15:39 <AndyU> It would be really great for people like myself who are new to this, to have some side meetings or (?) to learn all of what you're doing to refine the process itself and where things are at. Also how to actively participate most effectively.
21:15:44 <leong> kencjohnston: what do u mean "another artifact that is out of bands of the ones they officially use"
21:15:55 <kencjohnston> GeraldK +1
21:16:01 <leong> this gap-analysis does not replace BP/SPEC/etc
21:16:12 <shamail> I would advocate for the implementation plan and gaps analysis being a single doc since they both contain implementation/technical details.
21:16:20 <kencjohnston> leong Well the development community uses specs, blueprints and cross project specs
21:16:38 <Arkady_Kanevsky> gap analysis is idnetify what we need to create in cross-spec, individual projetcs or board.
21:16:44 <kencjohnston> Well this gap analysis woudl very easily duplicate specs and bueprints in the case where the gap is in an existing project
21:16:50 <AndyU> It would seem that the gap analysis and the implementation planning have mutual interdependencies and that neither can be done completely independently of the other
21:17:17 <kencjohnston> Did we create this gaps analysis solely for the cases where new projects are required?
21:17:49 <kencjohnston> I thought our part was "define the need/use case" and then reference that in implementation/gaps documents like blueprints specs, etc
21:17:59 <Arkady_Kanevsky> Ken, no. We create it so we can document analysis and discuss it in the group before going to cross functioal and projects
21:18:16 <shamail> kencjohnston: the development effort would still use the existing artifacts.  This artifact is for our workflow and not needed for Dev workflow.  It is simply there to address the gap between "user story" --> specs/bps. (E.g. How do we define what needs to be done in Dev workflow artifacts to meet this user story)
21:18:18 <leong> this gap-analysis make sure that all "requirements" defined in user-story.rst are analysed and with actionable plan
21:18:33 <Arkady_Kanevsky> To me is technicaly details for user story.
21:18:44 <Arkady_Kanevsky> Leong +1
21:18:57 <kencjohnston> so the Rolling Upgrades user stry has a "gaps analysis"
21:19:10 <leong> +1 shamail: address the gap between "user story" --> specs/bps.
21:19:18 <kencjohnston> that doesn't include technical details
21:19:19 <kencjohnston> and should reference blueprints and specs
21:19:28 <kencjohnston> teh gap between userstory and blueprints and specs shouldn't have technical details right?
21:19:33 <kencjohnston> those should be saved for the specs?
21:20:07 <shamail> kencjohnston: +1 but it will call out "resolve bug X", "add X feature in service", etc
21:20:22 <Arkady_Kanevsky> gap anal;ysis should have enouhg details so we as a group can agree what cross functional spec and projects blueprints we need to do
21:20:28 <kencjohnston> Let me take a step back, what we hear from teh development community is "I want to know what is important and what the use cases are." What we hear from operators is "I want to be able to communicate what is important and what the use cases are."
21:20:38 <shamail> The actual contents of what is "add X feature in service" should be a spec/np
21:20:46 <shamail> bp*
21:20:59 <Arkady_Kanevsky> The person who does gap analysis is not necessary the person how did user sotry or create BP, bugs and specs
21:21:02 <GeraldK> kencjohnston: the gap analysis does not necessarily contain implementation details, however, someone needs to be familiar with bp and specs and probably even have some more insights into existing projects to be able to perform the gap analysis and identify related bp / specs
21:21:05 <AndyU> What if the gap analysis reveals some existing's back that would potentially be in conflict with the bigger picture?
21:21:40 <leong> an example of gap-analysis doc is here
21:21:46 <leong> #link gap-analysis for baremetal: https://etherpad.openstack.org/p/bare_metal_service_gap_and_overlap_analysis
21:21:52 <kencjohnston> So should it contain implementation details or not?
21:22:25 <Arkady_Kanevsky> impl details is not a requirement for it
21:22:29 <shamail> I get what you are saying Kencjohnston too... I think it should remain an optional artifact (a template for those that want to create a gaps analysis is a plus) and it should contain details about the implementation plan based on requirements rather than technical details on the implementation details (that should be reserved for the actual cross project spec/bp/project spec)
21:22:56 <kencjohnston> For the record, https://etherpad.openstack.org/p/bare_metal_service_gap_and_overlap_analysis, reads like a tracker document does it not?
21:22:57 <Arkady_Kanevsky> But if it conflicts how some ohter feature in a project is implemented then we need that info
21:23:18 <GeraldK> if we leave out the gap analysis phase we would need to re-consider the work flow defined earlier. there, the gap analysis phase is mandatory
21:23:20 <leong> it is more to keep track of discussion and the output will goes into the tracker
21:23:38 <kencjohnston> leong So almost like an etherpad? :)
21:23:41 <leong> if you don't have a discussion, where are you going to have the "output"
21:24:03 <leong> it is an ether pad now, that's why we are moving into a gap-analysis template so that it can be formally tracked in repo
21:24:44 <kencjohnston> I think I now understand the need
21:24:52 <Arkady_Kanevsky> if we want gap analysis to be more felxible doc we can have it etherpad.\
21:25:04 <GeraldK> #link https://etherpad.opnfv.org/p/promise_gap_analysis Capacity mgmt gap analysis draft
21:25:10 <Arkady_Kanevsky> easier to discuss and record discussions
21:25:17 <kencjohnston> a bridge between the user story and the tracker, I completely sypathize with that need
21:25:18 <kencjohnston> I'd strongly recommend keeping these docs in an etherpad
21:25:24 <GeraldK> for the capacity mgmt gap analysis we followed the baremetal example
21:25:26 <kencjohnston> especially given our teams general "time to merge" metrics
21:25:46 <kencjohnston> Maybe move the template to the wiki and point etherpad creators at it
21:25:47 <kencjohnston> ?
21:25:50 <Arkady_Kanevsky> But we need to havea clear end of gap_analysis step on our workflow when we move to netx step
21:26:25 <kencjohnston> How frequently would we expect to edit this document?
21:26:26 <GeraldK> we had used the etherpad to do the gap analysis. we could convert to RST once we finalized it.
21:26:30 <leong> information on etherpad will easily get lost, i prefer a system to "version-control" it :)
21:26:35 <Arkady_Kanevsky> The only concern with etherpad that they are not backed up and anybody can change it.
21:26:46 <Arkady_Kanevsky> +1 ofr version control
21:26:59 <kencjohnston> Arkady_Kanevsky "Anybody can change it" is a positive
21:27:08 <leong> not very often for editing once "agreed" on the completion of gap analysis
21:27:19 <Arkady_Kanevsky> not aftre we are done.
21:27:29 <kencjohnston> Everything from the gaps analysis eventually gets translated into the tracker right?
21:27:39 <GeraldK> my experience: the template was under review in Etherpad for 2 weeks -> almost no feedback. once we had moved it to RST, we had received many additional comments and trigger this discussion here....
21:27:44 <Arkady_Kanevsky> hard to refer to a doc tha tcan be chnage at anytime
21:28:13 <leong> depends.. a gap-analysis can say: this requirement need a new project or "completely out of scope"
21:28:18 <Arkady_Kanevsky> agree with gerald. review forced dicipline
21:28:36 <kencjohnston> Sorry for the prolonged discussion, I'll +2 the gaps analysis template
21:28:51 <kencjohnston> But it would be great to set some guidliens for reviewers of future gaps analysis submissions
21:28:54 <leong> that also help us to keep track of future AUC contribution, by the way :-)
21:28:59 <kencjohnston> because generally I'm going to be +2 everything I see right?
21:29:09 <Arkady_Kanevsky> ken it is a good discussion. If we have a better process let's consider it
21:29:10 <leong> lol kencjohnston
21:29:17 <AndyU> +1 to guidelines
21:29:45 <kencjohnston> leong I'm actually serious, I have no idea how to decide if this document is appropriate/sufficient/etc
21:30:10 <leong> i would suggest we go for this revision 1 and we can improve along the line
21:30:25 <Arkady_Kanevsky> my approach is lets start somewhere and then improve as we go
21:30:45 <Arkady_Kanevsky> do we want do have this topic for mid-cycle?
21:30:56 <AndyU> need a way to assess getting consensus of stakeholders who DO know if doc is appropriate/sufficient
21:30:58 <kencjohnston> to be clear, I'm not talkign about the template, I guess I can ensure the content is correct in the template's format.
21:31:08 <leong> definitely can discuss that at mid-cycle
21:31:48 <kencjohnston> sounds good, sorry again for the prolonged convo. I feel smarter, hopefully you all don't feel dumber. :)
21:32:07 <leong> that's a good discussion to make everyone align :-)
21:32:14 <Arkady_Kanevsky> +2
21:32:25 <leong> so let's get "core" to review the template
21:32:28 <leong> #link Gap-analysis template: https://review.openstack.org/#/c/426994/
21:32:46 <Arkady_Kanevsky> we have 2 +2 on it now
21:32:47 <GeraldK> kencjohnston: i understand your issue. very difficult for someone to review the gap analysis when you had not been part of the discussion on it or you are no core of the related projects
21:33:24 <leong> the user-story-owner /anyone else who drive the user-story will be "technically" to review the gap document
21:33:31 <GeraldK> thanks. be prepared that we will submit the first example on the capacity mgmt very soon :)
21:34:09 <Arkady_Kanevsky> i will follow suite
21:34:20 <leong> let's move on..
21:34:22 <leong> anything else on existing user-story-to-review?
21:34:35 <leong> #topic Midcycle planning
21:35:02 <leong> #link PWG midcycle planning: https://etherpad.openstack.org/p/MIL-pwg-meetup
21:35:41 <leong> again, please suggest agenda item on the etherpad and please indicate if you will be there for F2F midcycle
21:35:59 <leong> i want to talk about the location...
21:36:19 <leong> Arkady_kanevsky.. did you say Dell can host us?
21:36:26 <Arkady_Kanevsky> Arkady sent email for possible location at DellEMC
21:36:39 <shamail> leong: when do we want to finalize the agenda by?  My recommendation would be by 2/27 so we have time to prepare materials if needed
21:36:47 <shamail> Arkady_Kanevsky: thanks!
21:36:49 <leong> +1 shamail
21:36:54 <Arkady_Kanevsky> Yes. I send email with location nad rought distance from Wed-Th venue
21:37:07 <leong> i am hoping to get some sense on the location then follow by finalizing the agenda
21:37:47 <leong> shall we agreed that to fiinalize the agenda by 2/27?
21:37:58 <Arkady_Kanevsky> sure.
21:38:07 <Arkady_Kanevsky> But let's agree on location first.
21:38:10 <shamail> Sounds good.
21:38:15 <Arkady_Kanevsky> need to make reservations
21:38:16 <shamail> Arkady_Kanevsky: can we confirm that location? We seem to be having a hard time finding venues.
21:38:55 <leong> if we can't get confirmation from members company, the other alternative is to "pay" for the room at coworking-login, which is the same place as ops-midcycle
21:39:07 <Arkady_Kanevsky> I have rooms reserved at Dell facility.
21:39:14 <shamail> Arkady_Kanevsky: Is DellEMC confirmed?
21:39:26 <shamail> For 3/13 & 3/14?
21:39:31 <Arkady_Kanevsky> had not aske for hotels near by or transporation to from airport
21:39:40 <leong> do you have the address?
21:39:40 <Arkady_Kanevsky> yes Mon-Tu
21:39:52 <shamail> Thanks Arkady_Kanevsky
21:40:15 <Arkady_Kanevsky> Dell - Viale Piero e Alberto Pirelli 6, Milano (conf room Vivaldi) - Monday
21:40:19 <leong> for a group of 10-15 people?
21:40:31 <Arkady_Kanevsky> Dell - Viale Piero e Alberto Pirelli 6, Milano (conf room Verdi) - Tu
21:40:36 <Arkady_Kanevsky> same location deiff room
21:40:44 <shamail> Everyone okay with DellEMC as the host for our midcycle?
21:41:03 <leong> is about 7 mins drive away from Ops location
21:41:09 <leong> i think we can car-pool
21:41:10 <Arkady_Kanevsky> yes for 15 people. Oval table for 10 first day . bigger one for Tu
21:41:10 <shamail> Great location
21:41:24 <shamail> leong: can you lock it in?
21:41:24 <leong> i am fine with Dell location
21:41:30 <leong> +1
21:41:44 <Arkady_Kanevsky> I will let local team know
21:42:01 <leong> #agreed PWG midcycle location will be at DellEMC office at Viale Piero e Alberto Pirelli 6, Milano
21:42:32 <leong> arkady_kanevsky: please let us know if there anything we need for logistic, e.g. pre-register for entering the building
21:42:46 <leong> thank arkady
21:43:13 <leong> next..the agenda items
21:43:20 <Arkady_Kanevsky> will find out and send email on it and will update etherpad
21:43:41 <leong> shall we brainstorm here or do it offline and to review next week?
21:43:57 <leong> i mean the agenda item for PWG midcycle
21:44:10 <shamail> Leong: next week review is good, I would send a reminder on ML
21:44:15 <leong> cool
21:44:49 <leong> #agreed All to suggest PWG midcycle agenda and team will review in next meeting
21:45:09 <Arkady_Kanevsky> +1
21:45:23 <leong> #action shamail to email ML about the midcycle agenda item discussion
21:45:31 <shamail> Thanks leong
21:45:40 <leong> #action leong and arkady_kanevsky to email ML on the midcycle location
21:45:52 * leong time check 15 mins..
21:46:03 <Arkady_Kanevsky> I had updated etherpad already with location address
21:46:12 <leong> one  more thing
21:46:26 <leong> the ops-midcycle, is there any session that PWG want to present/talk at Ops midcycle?
21:46:41 <leong> #link Topics/sessions on Ops midcycle: https://etherpad.openstack.org/p/MIL-ops-meetup
21:47:16 <leong> do we need "lighting talk" to introduce PWG objective and the user-story-workflow to operator?
21:47:41 <shamail> leong: +1
21:48:23 <AndyU> +1 to educating on user-story-workflow
21:48:24 <leong> #action leong to propose a "PWG lighting talk" at Ops midcycle
21:48:25 <Arkady_Kanevsky> What about bringing user communities/workload together?
21:48:46 <Arkady_Kanevsky> like HPC, big data, NFV, enterprise, ...
21:49:21 <Arkady_Kanevsky> Some education needed on driving reqs thru PWG
21:49:36 <GeraldK> arkady: +1
21:49:48 <shamail> A session (not PWG specific) on how are operators sharing their requirements and success/failures would be a good one.
21:49:55 <leong> +1 shamail
21:50:12 <leong> do you want to propose that on the ops etherpad?
21:51:35 <shamail> Sure
21:51:49 <leong> #action shamail to propose a session at ops midcycle on "how are operators sharing their requirements and success/failures"
21:52:10 <leong> we have 9 mins to the hour.... anything we want to discuss next?
21:52:45 <leong> shamail/heidijoy_ do you want to provide a quick update on the "roadmap"?
21:53:00 <leong> #topic Roadmap Update
21:53:25 <shamail> thanks leong, are you here heidijoy?
21:53:40 <GeraldK> heidijoy has quit 20 mins ago
21:53:41 <shamail> She isn't here anymore
21:53:54 <leong> looks like she dropped
21:54:02 <shamail> Heidi Joy sent out a survey to the PTLs asking about their plans for Ocata and Pike
21:54:13 <shamail> So far we have a response from 13 PTLs
21:54:22 <shamail> And we are reaching out to others as a follow-up
21:54:46 <leong> #info a survey to the PTLs asking about their plans for Ocata and Pike was sent and so far received response from 13 PTLs
21:55:26 <shamail> Foundation has to do a marketing launch tomorrow and they have been working towards that.  We have not started on the multi-release roadmap yet.
21:55:30 <shamail> That's all I have so far
21:55:39 <leong> i assume that the PWG members will need to help to collate the output after that?
21:56:19 <leong> like what PWG has done previously for the community roadmap?
21:56:54 <leong> shamail: do you need any help from the PWG members here?
21:57:41 <AndyU> When future roadmap targets are given, is there any later status tracking/reporting?
21:58:35 <leong> that's a good question andyu
21:58:36 <leong> i don
21:58:53 <leong> i don't remember there is a "status" tracking on previous roadmap deliverables
21:59:08 <leong> except those proposed bp/spec are on tracked
21:59:10 <AndyU> just wondering... status tracking could be a daunting challenge
21:59:29 * leong one mins to hit the bell
21:59:43 <shamail> leong: I think we're good for now... next time we would need help is when processing
21:59:48 <leong> sure!
21:59:49 <leong> sorry the time fly....  i can't get into the next topic on "Collaboration with LCOO", feel free to reach out/discuss over ML and we can chat about in next meeting
22:00:30 <leong> any question feel free to follow up on mailing list.
22:00:41 <leong> #endmeeting