21:01:03 <leong> #startmeeting product_working_group
21:01:04 <openstack> Meeting started Mon Feb 27 21:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:08 <openstack> The meeting name has been set to 'product_working_group'
21:01:17 <leong> #topic rollcall
21:01:26 <leong> who is here for product wg meeting?
21:01:31 <MeganR> o/
21:01:34 <GeraldK> hi
21:02:03 <leong> hi meganr, geraldk
21:02:15 <Arkady_Kanevsky> hello everybody
21:02:21 <leong> just want to make sure we have quorum to start the meeting... :)
21:03:15 <leong> hi arkady
21:03:25 <Arkady_Kanevsky> I need time on agenda for Milan meeting details
21:03:40 * leong waiting 2 more minutes for more people to join
21:03:46 <shamail> hi evertibe
21:03:48 <shamail> everyone*
21:04:19 <leong> hi  shamail
21:04:28 <Arkady_Kanevsky> Hy shamail
21:04:43 <Arkady_Kanevsky> hi
21:04:51 <AndyU_> hi all
21:04:58 <leong> hi andy...
21:05:05 <leong> i think we got enough quorum to start :)
21:05:09 <shamail> Hi AndyU_ and Arkady_Kanevsky
21:05:13 <Arkady_Kanevsky> +1
21:05:27 <leong> #topic Action items from last meeting
21:05:30 <AndyU_> Hi Shamail
21:05:37 <leong> #chair add shamail
21:05:38 <openstack> Warning: Nick not in channel: add
21:05:39 <openstack> Current chairs: add leong shamail
21:06:04 <Rockyg> o/
21:06:12 <leong> let;s do a quick review on previous meeting AR
21:06:29 <leong> #link previous meeting: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-02-13-21.00.html
21:07:16 <Arkady_Kanevsky> mid-cycle location and related info emailed. etherpad updated
21:07:21 <shamail> Leong: I did not send an email about the midcycle agenda but have been socializing it at every chance.  The agenda seems fairly packed now.
21:07:30 <leong> ok note
21:07:32 <Arkady_Kanevsky> still have 3 open items I want to bring today
21:07:45 <shamail> I also did not propose the ops session since that seems to be a full agenda (had read only access)
21:07:56 <leong> got it...
21:08:03 <shamail> I have been given access now and will try to discuss with the ops midcycle planning team to see if there is room
21:08:13 <leong> arkady, do you have any update on the location?
21:08:25 <Arkady_Kanevsky> yes. Location is set.
21:08:41 <shamail> Thanks Arkady_Kanevsky and DellEMC
21:08:44 <Arkady_Kanevsky> I sent email on that.
21:08:55 <Arkady_Kanevsky> Also info on hotels near by and rates.
21:09:07 <Arkady_Kanevsky> etherpad updated also.
21:09:14 <leong> thanks arkady
21:09:39 <leong> any security needed from entering the DellEMC office?
21:09:40 <Arkady_Kanevsky> Let me know when we are ready to jump i nto midcycle planning
21:10:03 <Arkady_Kanevsky> I do not have an etherpad pointer. if you do please place it here
21:10:11 <leong> ok.. looks like we are good at previous meeting follow-up
21:10:30 <Arkady_Kanevsky> No security issues. I will provide a list of attendees a week before it.
21:10:34 <leong> #link Midcycle planning: https://etherpad.openstack.org/p/MIL-pwg-meetup
21:10:45 <leong> let's move on to next topic real quick
21:10:51 <leong> #topic "open" gerrit review
21:11:07 <leong> anything that need to review on existing gerrit list?
21:11:16 <leong> #link gerrit review: https://review.openstack.org/#/q/project:openstack/openstack-user-stories+status:open
21:11:55 <GeraldK> how do we proceed with the capacity mgmt gap analysis?
21:12:03 <mrhillsman> o/
21:12:08 <leong> i sent out an email about gap analysis for capacity management...
21:12:12 <Arkady_Kanevsky> Yes. I am waiting for reviews on 2 of my pull requests
21:12:30 <GeraldK> can we accept this first part of the gap analysis and then work on a second patch to add the missing parts?
21:13:06 <Rockyg> GeraldK, ++
21:13:08 <Arkady_Kanevsky> https://review.openstack.org/#/c/434577/ - this one?
21:13:19 <GeraldK> also, I had proposed to take out the quota related parts and merge it into the new quota mgmt user story?
21:13:22 <leong> thanks arkady..
21:13:26 <shamail> hi mrhillsman and Rockyg
21:13:31 <Arkady_Kanevsky> I do not think we agreed on the format and content on gap analysis.
21:13:36 <Rockyg> Arkady_Kanevsky, you got it before I could ask
21:13:43 <leong> #link Capacity Management Gap Analysis: https://review.openstack.org/#/c/434577
21:13:50 <GeraldK> Arkady_Kanevsky: yes. this one
21:14:04 <Arkady_Kanevsky> will review it tonight.
21:14:43 <leong> pleease also refer my email here:
21:14:46 <leong> #link Gap Analysis question http://lists.openstack.org/pipermail/user-committee/2017-February/001749.html
21:14:54 <GeraldK> Arkady_Kanevsky: yes, we had agreed on the template
21:15:04 <GeraldK> #link https://review.openstack.org/426994 template for gap analysis
21:15:12 <Arkady_Kanevsky> was it merged? I missed it I guess.
21:15:24 <leong> the template is agreed
21:15:39 <shamail> Yeah
21:15:42 <Arkady_Kanevsky> nice on format
21:15:44 <leong> #link Gap Template Agreed: https://review.openstack.org/#/c/426994/
21:15:48 <GeraldK> yes, we had agreed on it and had decided to revisit it after we had some more epxerience on gap analysis
21:16:02 <Arkady_Kanevsky> +1 Gerald
21:16:36 <leong> the questions now for Cap Mgmt is that we need other folks to perform gap analysis for other requirements
21:17:19 <leong> Geraldk and Hiroaki are working on part of the Cap Mgmt, not all requirements
21:17:39 <leong> some other requirements in Cap Mgmt was proposed by others
21:18:12 <Rockyg> I think it might be worthwhile to list all requirements in analysis, then leave either TBD to ones not yet addressed or N/A or INC for those that are in the code base.  One location for all reqs so we don't have to go searching.
21:18:30 <shamail> Rockyg: +1
21:18:35 <Arkady_Kanevsky> do we expect/require that every CRM use cases is covered by gap analysis?
21:18:47 <Rockyg> It also allows us to identify processed requirements versus still to be processed
21:18:54 <shamail> I agree that we should at least list all requirements in the gap analysis (CRM 1-8) with abstract and then leave the results as TBD
21:18:57 <leong> rockgy: that's a good suggestion
21:18:58 <Arkady_Kanevsky> And if soem reqs are already covered then just stated that is already covered not a gap?
21:18:59 <GeraldK> Rockyg: okay, we can add some TBD. it was our understand that everthying should become one document in the end
21:19:07 <shamail> that way we can merge it and then update as other requirements get analyzed
21:19:17 <Rockyg> Yup.
21:19:23 <shamail> GeraldK: It still will be one document, but updated multiple times
21:19:36 <leong> geraldk, can you take that action and update those "other" Requirement to TBD
21:19:38 <Arkady_Kanevsky> good recommendation
21:19:40 <GeraldK> shamail: yes. i fully agree
21:19:58 <GeraldK> leong: yes, we will take this task
21:20:04 <Rockyg> I'll have more at midcycle ;-)
21:20:22 <leong> #action geraldk to update the gap analysis of capacity management with TDB for those requirements that not currently working on.
21:20:36 <leong> anything else on the gerrit list before we move on to next topic?
21:20:51 * leong calling 3... 2... 1
21:21:00 <Arkady_Kanevsky> need review for https://review.openstack.org/#/c/428571/
21:21:16 <Arkady_Kanevsky> and for https://review.openstack.org/#/c/426613/
21:22:08 <leong> please remove WIP from the commit title if those are ready for review
21:22:17 <Arkady_Kanevsky> no need for responses now. jusr review in the tool
21:22:20 <Rockyg> ++
21:22:29 <Arkady_Kanevsky> Will do. Thanks Leong
21:22:40 <leong> #action all to review https://review.openstack.org/#/c/428571/ and https://review.openstack.org/#/c/426613/
21:22:59 <leong> anything else?
21:23:38 <leong> #topic Midcycle planning
21:23:39 <Rockyg> Up in a window.  Will do after meeting
21:23:54 <leong> #link Midcycle planning: https://etherpad.openstack.org/p/MIL-pwg-meetup
21:23:54 <Arkady_Kanevsky> https://etherpad.openstack.org/p/MIL-pwg-meetup
21:24:15 <Arkady_Kanevsky> address of the venue - Dell - Viale Piero e Alberto Pirelli 6, Milano
21:24:30 <Arkady_Kanevsky> hotel list at the bottom
21:24:46 <Arkady_Kanevsky> I am staying there for 2 days then moving to ops meeting hotel
21:24:58 <Arkady_Kanevsky> 1.	Do we need breakfast? Or everybody has it in hotel and we can skip it.
21:25:20 <leong> i will have breakfast at hotel :-)
21:25:25 <Rockyg> coffee is what I need...
21:25:40 <Arkady_Kanevsky> coffee/expresso will be there
21:25:45 <Rockyg> in some form...
21:25:53 * shamail is adding placeholder time limits to each suggested topic to help with planning, we can adjust them if we think each topic needs to be longer/shorter
21:25:56 <Rockyg> excellent!
21:26:06 <shamail> Arkady_Kanevsky: Coffee is key
21:26:06 <leong> nice shamail
21:26:14 <Arkady_Kanevsky> agreed
21:26:26 <Arkady_Kanevsky> that I already locked on
21:26:39 <leong> if you have any topic to discuss at the F2F meeting, please add that to tthe planning etherpad
21:26:46 <Arkady_Kanevsky> OK. will drop breakcfast. Coffee all day thru.
21:26:51 <AndyU_> yes, breakfast is at hotel for me
21:26:55 <leong> we will need to finalize the agenda soon
21:26:55 <Arkady_Kanevsky> Next - 2. who is organizing group dinner? Assume it is Monday night.
21:26:57 <shamail> My initial estimates have us at 12.5 hours
21:27:04 <Arkady_Kanevsky> Which day? Mo nday or Tuesday?
21:27:18 <shamail> Arkady_Kanevsky: Heidi Joy asked whether it could be Tuesday since some might be jetlagged on Monday
21:27:20 <Arkady_Kanevsky> yes on agenda.
21:27:28 <Arkady_Kanevsky> I am still worried about loogistcis
21:27:31 <leong> i'm fine on either day
21:27:39 <Arkady_Kanevsky> I am ok either day.
21:27:42 <shamail> leong: can you please add me as chair?
21:27:49 <leong> i thought i did? :)
21:27:53 <leong> #chair shamail
21:27:54 <openstack> Current chairs: add leong shamail
21:28:02 <shamail> Thanks
21:28:05 <Arkady_Kanevsky> Who want to own oragnizing dinner?
21:28:18 <shamail> #startvote Should we have dinner on Monday or Tuesday? Monday, Tuesday
21:28:19 <openstack> Begin voting on: Should we have dinner on Monday or Tuesday? Valid vote options are Monday, Tuesday.
21:28:20 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
21:28:23 <shamail> #vote Tuesday
21:28:30 <leong> #vote Tuesday
21:28:36 <AndyU_> #vote Tuesday
21:28:39 <Arkady_Kanevsky> #vote either day
21:28:40 <openstack> Arkady_Kanevsky: either day is not a valid option. Valid options are Monday, Tuesday.
21:28:43 <shamail> lol Arkady_Kanevsky
21:28:47 <mrhillsman> :)
21:28:49 <Arkady_Kanevsky> #ovet Tuesday
21:29:01 <shamail> 10 secs and closing
21:29:06 <Rockyg> #vote Tuesday
21:29:12 <shamail> #endvote
21:29:13 <Arkady_Kanevsky> so much ofr free choice...
21:29:13 <openstack> Voted on "Should we have dinner on Monday or Tuesday?" Results are
21:29:15 <openstack> Tuesday (4): shamail, Rockyg, leong, AndyU_
21:29:47 <shamail> Please add your name to line 15 of the etherpad if you plan to join for dinner
21:29:51 <Arkady_Kanevsky> OK. done with that. who owns organzing it?
21:29:53 <leong> #agreed Product WG midcycle dinner will be on Tuesday
21:29:56 <AndyU_> and Arkady's "ovet"
21:30:20 <Arkady_Kanevsky> not sure if it veto or vote...
21:30:27 <shamail> I can help organize but I know my organization would not be able to cover the bill.  Are we fine with paying seperately?
21:30:28 <AndyU_> :)
21:30:37 <Arkady_Kanevsky> fine with me
21:30:41 <leong> paying separately :)
21:30:47 <mrhillsman> +1
21:30:51 <AndyU_> yes to paying separately
21:31:04 <Arkady_Kanevsky> families are welcome
21:31:14 <shamail> Okay, I will send out an email to the mailing list asking for dietary restrictions
21:31:23 <Arkady_Kanevsky> thanks Shamail
21:31:24 <shamail> and send a few choices in our next meeting
21:31:24 <AndyU_> I may have one more coming from ATT
21:31:31 <shamail> That's fine AndyU_
21:31:36 <Arkady_Kanevsky> final question on logictics - 3.	Do we want catered lunch or we will take a break to go for it?
21:31:41 <AndyU_> k, good
21:31:50 <leong> please note that we have room size limitation not to exceed 15 in total
21:31:59 <Arkady_Kanevsky> andyU add to etherapd
21:32:05 <leong> i mean for the meeting room
21:32:07 <AndyU_> will do
21:32:09 <shamail> #action shamail to organize group dinner, will find out dietary restrictions to ensure everyone can be accomodated
21:32:26 <shamail> leong: Looks good, we are at 10 so far
21:32:48 <leong> worse case we do stand up meeting :-)
21:32:57 <shamail> I am adding another item to the agenda
21:33:05 <Arkady_Kanevsky> best way to get to agreemnet faster
21:33:22 <shamail> Reviewing ops midcycle etherpads for action items and planning next steps and volunteering mrhillsman to co-lead that topic
21:33:44 <mrhillsman> sure thing
21:33:54 <Rockyg> We're at 13
21:33:55 <Arkady_Kanevsky> Shamail - final logistics item
21:34:56 <shamail> what's up Arkady_Kanevsky ?
21:35:03 <leong> #link Ops midcycle etherpad: https://etherpad.openstack.org/p/MIL-ops-meetup
21:35:05 <Arkady_Kanevsky> working lunch or break for lunch?
21:35:17 <Arkady_Kanevsky> 3. Do we want catered lunch or we will take a break to go for it?
21:35:35 <Arkady_Kanevsky> go out or catering?
21:35:41 <AndyU_> I'm usually for working through... but whatever  ;)
21:35:41 <shamail> I'm up for taking a break, we'll need some because of the agenda
21:35:47 <shamail> We are now at 14.5 hours
21:36:25 <leong> 14.5 hrs is nearly two full days
21:36:33 <Arkady_Kanevsky> there are a coupel place in the same building and near by buildings.
21:36:47 <shamail> 15 min break in AM, 60 min lunch, 15 min break in PM, = 1.5 hours... assuming 9-5 means 6.5 hours per day
21:36:50 <AndyU_> will definitely need the break then
21:37:01 <shamail> Some of these topics might go faster
21:37:08 <Arkady_Kanevsky> OK. I will ask for info on lunch places and add it to etherpad
21:37:12 <leong> we need to prioritise the
21:37:18 <leong> them
21:37:32 <Arkady_Kanevsky> logistics done
21:37:43 <Arkady_Kanevsky> agenda next
21:37:47 <shamail> Trimmed 1.5 hours off agenda topics... new total is 13 hours
21:38:02 <mrhillsman> just throwing it out there
21:38:06 <AndyU_> I feel more rested already
21:38:14 <shamail> Please review lines 21-37 to see if you agree with the allotted time for each topic
21:38:16 <mrhillsman> but there is potential to use some time/space at ops midcycle as well
21:38:35 <mrhillsman> though i assume most of you will be busy with ops stuff :)
21:38:55 <mrhillsman> but you may be able to catch a nap hehe
21:38:55 <shamail> thanks mrhillsman, anything available near the end on Thursday?  This way we could move the Ops Midcycle Action Items to be a session at the ops meetup itself and others could join if interested
21:39:09 <shamail> We could have a 1 hour session at the end of the ops meetup and invite all moderators + open to all
21:39:25 <mrhillsman> https://docs.google.com/spreadsheets/d/1EUSYMs3GfglnD8yfFaAXWhLe0F5y9hCUKqCYe0Vp1oA/edit#gid=2006054635
21:39:34 <Arkady_Kanevsky> I think we need to chat about going to various user teams and enlist them to user story submissions.
21:39:35 <mrhillsman> there is a breakout reports
21:39:50 <mrhillsman> 40 minutes
21:39:52 <Arkady_Kanevsky> I mean HPC, NFV and a few others.
21:40:08 <mrhillsman> not sure what in particular you want to achieve shamail but maybe can be implemented during that time?
21:40:25 <mrhillsman> and then after there is ops meetups team session
21:40:34 <mrhillsman> 40 minutes
21:40:40 <shamail> mrhillsman: I was thinking about a session to consolidate breakout reports into one readout at the end of the meetup
21:40:43 <mrhillsman> and i do not see why that time could not be used
21:40:51 <shamail> This way it is a consolidated list and easier to consume for attendees
21:40:53 <mrhillsman> because the folks attending that is limited
21:41:32 <mrhillsman> we can discuss offline if everyone is ok with that or in the ops meetup meeting tomorrow
21:41:42 <shamail> In the past ops meetups, we have had each moderator come up for 10 min to review their session and that is good info but if we could consolidate ahead of time then we could show next steps rather than a summary of just the conversation
21:41:43 <mrhillsman> and in the ops meetup meeting i meant
21:41:51 <shamail> mrhillsman: +1, offline is good
21:42:12 <mrhillsman> maybe send me a quick rundown via email shamail and i can bring up tomorrow?
21:42:19 <shamail> will do mrhillsman
21:42:23 <mrhillsman> cool
21:42:34 <shamail> If this works out then we could shave an hour off the PWG agenda
21:43:02 <shamail> Arkady_Kanevsky: +1, that could be one of the next steps from sessions
21:43:29 <Arkady_Kanevsky> OK
21:43:51 <shamail> Are we good on this topic? It seems like all topics can be accommodated so we don't need to take any off the list.
21:43:54 <leong> nice... are we good at the midcycle planning? anything missing?
21:44:01 <shamail> LGTM
21:44:08 <Arkady_Kanevsky> godd with me
21:44:13 <leong> #topic Boston Summit
21:44:43 <leong> we presented the PWG forum proposal to UC and the next step is to make a formal proposal for Board approval
21:45:04 <leong> #link PWG Forum Proposal: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit
21:45:46 <leong> shamail, mrhillsman? anything you want to add?
21:46:29 <shamail> How do we want to handle the sub-team for planning our process for Forum?  Do you want to send a doodle poll to establish a weekly meeting?
21:47:10 <leong> i think a weekly meeting will be great
21:47:18 <leong> i will take setup the doodle link
21:47:26 <shamail> thanks
21:47:30 <Arkady_Kanevsky> sounds good. do we also want a separate email thread for it?
21:47:36 <MeganR> +1 for weekly meeting
21:47:41 <leong> #action leong to set up a doodle pool to establish weekly meeting for planning Forum progress
21:48:09 <shamail> leong: we should also take the same proposal to the TC
21:48:15 <leong> there was also suggestion to apply the "forum proposal" to the ops midcycle
21:48:24 <mrhillsman> am i correct in assuming that the specifics of the proposal have not been worked out due to waiting on the high level view presented to be approved?
21:48:25 <shamail> because not all sessions will be moderated by UC
21:48:27 <leong> +1 shamail, is there a dedicated ML for TC?
21:48:34 <shamail> yes
21:48:36 <shamail> openstack-tc
21:48:45 <leong> ok thanks!
21:49:15 <leong> i believe so mrhillsman
21:49:16 <shamail> mrhillsman: yes, the proposal currently covers what are things we believe the proposal needs to address but not the specifics on "how"
21:49:30 <mrhillsman> thx
21:49:53 * leong time check 11 mins
21:50:24 <leong> anything else to discuss under this topic?
21:51:02 <leong> #topic Roadmap Update
21:51:09 <leong> shamail: do you want to take this?
21:51:48 <shamail> Sure
21:51:53 <shamail> looking for a link, hold on
21:52:18 <shamail> #link https://etherpad.openstack.org/p/PTLupdatesBoston
21:52:38 <shamail> In the Boston Summit, there will be a specific initiative to capture updates from up to 32 projects
21:53:09 <shamail> We (PWG) helped with compiling the original list since it was based on projects that have been included in our roadmap updates in the past
21:53:40 <shamail> The goal is to use these new "project updates" videos as a replacement for what used to be the "design series" webinars.
21:54:10 <shamail> At this point, the slots have been opened up for self-nomination but we will need volunteers to help create roadmap slides based on the output of these recordings
21:54:32 <shamail> and, in the more short-term, create slides based on a survey that Heidi Joy recently conducted (which includes questions commonly found on our roadmap questionnaire)
21:54:54 <shamail> We can discuss changes to the roadmap process in greater detail at the midcycle but is anyone willing to sign up for this sub-team?
21:55:08 <Arkady_Kanevsky> done
21:55:25 <MeganR> I won't be at the mid-cycle, but will sign-up for the sub-team now.
21:55:26 <leong> i belive we need more :)
21:55:41 <shamail> Thanks Arkady_Kanevsky and MeganR
21:55:46 <MeganR> I don't know, Arkady is pretty good!  :)
21:55:47 <GeraldK> i can support the subteam
21:56:05 <leong> should i send out the email to ML and asking support...
21:56:08 <Arkady_Kanevsky> Do we have a quation in questionare of usage Tempest by usre for valdiation?
21:56:08 <shamail> Thanks, please add your names starting at line 17 on the etherpad
21:56:12 <shamail> that's all I had
21:56:12 <Arkady_Kanevsky> ditto for Rally?
21:56:22 <leong> thanks shamail
21:56:22 <shamail> leong: Sure
21:56:37 <leong> #action leong to email ML about supporting Roadmap Update
21:56:41 <shamail> Arkady_Kanevsky: no, this isn't the user survey but its based on our questionnaire so it contains features and themes data
21:56:53 <leong> #topic Board/TC/UC joint meeting
21:57:17 <Arkady_Kanevsky> there is # for git adoption. how do we measure it?
21:57:24 <leong> there is a F2F board meeting with TC/UC and Interop/Product chair at Boston Mar 8th and 9th
21:57:37 <shamail> Arkady_Kanevsky: we can discuss at midcycle further
21:57:51 <Arkady_Kanevsky> +1 Shamail
21:58:01 <leong> discussion topics are around OpenStack Future and Strategic Focus Area
21:58:55 <leong> i was invited to attend as a Product WG chair. and shamail and mrhillsman will be there as well
21:59:04 <Arkady_Kanevsky> Have it on my calendar remotely
21:59:44 <leong> if you have anything in mind please feel free to contact me, shamail and mrhillsman
21:59:56 <Arkady_Kanevsky> Thanks al. Have a great week.
21:59:57 <shamail> I will be there only near the end of 3/9 but will send my thoughts ahead of time to Alan, Jonathan, and Mark.
22:00:12 <leong> nice!
22:00:21 <shamail> I'll copy you leong and the UC
22:00:28 <leong> thanks shamail
22:00:46 <leong> ok.. i think we are pretty wrap up today...
22:00:47 <shamail> ^ thats called a hard stop
22:01:00 <leong> great to "chat" with you all!
22:01:04 <leong> have a good week.
22:01:06 <shamail> same here, take care!
22:01:08 <leong> #endmeeting