21:00:22 <leong> #startmeeting product_working_group
21:00:23 <openstack> Meeting started Mon Mar  6 21:00:22 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:26 <openstack> The meeting name has been set to 'product_working_group'
21:00:35 <leong> #topic Rollcall
21:00:44 <leong> hello
21:00:45 <GeraldK> o/
21:00:50 <leong> anybody here for product wg meeting?
21:00:51 <Arkady_Kanevsky> hello
21:00:59 <MeganR> o/
21:01:20 <AndyU_> yep
21:01:39 <leong> good to see you all here!
21:01:56 <AndyU_> good to see you too!
21:02:16 <Arkady_Kanevsky> agenda?
21:02:16 <leong> i think we have enough quorum to move forward this meting..:)
21:02:27 <leong> today agenda can be found here
21:02:32 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:03:03 <leong> as per usual, let's review last week action items, if any....
21:03:17 <leong> #topic Review action items
21:03:37 <Rockyg> o/
21:03:54 <leong> last week minutes should be this one:
21:03:59 <leong> #link Last week minute: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-02-27-21.01.html
21:04:08 <Arkady_Kanevsky> I think I sent out info on mid cycle meeting logistics
21:04:38 <Arkady_Kanevsky> All is also recored at https://etherpad.openstack.org/p/MIL-pwg-meetup
21:04:45 <leong> thanks Arkady...
21:05:04 <leong> GeraldK, do you want to update your action item from last week?
21:05:16 <leong> * geraldk to update the gap analysis of capacity management with TDB for those requirements that not currently working on.
21:05:46 <GeraldK> the user story has been updated.
21:06:04 <GeraldK> we got some comments by Arkady on the content of the gap analysis
21:06:39 <Arkady_Kanevsky> from tracker PRs I have one AI to bring here - on nomenclature of use cases in tracker format
21:06:55 <Arkady_Kanevsky> thanks GeraldK
21:06:57 <GeraldK> we are working to resolve/discuss on the comments.
21:07:20 <leong> is this the one?
21:07:21 <leong> https://review.openstack.org/#/c/434577/
21:07:37 <GeraldK> leong: yes
21:07:55 <leong> #link Gap Analysis for Capacity Mgmt: https://review.openstack.org/#/c/434577/
21:07:56 <Arkady_Kanevsky> concur
21:08:23 <leong> is there anything that need to be addressed in this meeting with respect to the Capacity Mgmt Gap analysis
21:08:50 <GeraldK> no, I think we can handle this offline. arkady, you agree?
21:08:56 <Arkady_Kanevsky> All gap analysis and trackers to be consitent.
21:09:13 <Arkady_Kanevsky> Agree that we can do it offline and if need to bring up next week in f2f
21:09:21 <leong> sound good.. thanks GeraldK and Arkady_Kanevsky
21:09:35 <leong> I have already set up the doodle link for the Forum planning meeting
21:09:40 * leong digging the link
21:10:23 <leong> #link Doodle Link for Forum Planning Meeting: http://doodle.com/poll/dff2nvubd4ncqgvw
21:10:52 <Arkady_Kanevsky> will respond there
21:10:58 <leong> if anyone volunteer to participate in the Forum planning meeting, please indicates your availability on the above link
21:10:58 <leong> thanks!
21:11:08 <mrhillsman> o/
21:11:15 <mrhillsman> have to run to doctor though
21:11:22 <mrhillsman> so will catch up via log
21:11:23 <leong> I have also send out the email to invite volunteer to help on the Roadmap update...
21:11:30 <leong> hi heidijoy and mrhillsman
21:11:37 <heidijoy> ^^ thank you for that! We have a good set of volunteers.
21:11:42 <jamemcc> o/
21:11:50 <heidijoy> Hello @leong and apologies for joining late.
21:12:17 <leong> http://lists.openstack.org/pipermail/user-committee/2017-March/001799.html
21:12:18 <jamemcc> I'm here also if I can help
21:12:23 <Arkady_Kanevsky> Leong is PWG Process Planning for Forum in Eastern time?
21:12:58 <leong> Arkady_kanevsky: that depends on your Doodle set up, my default timezone is Pacific on my Doodle
21:12:58 <GeraldK> Arkady_Kanevsky: usually, Doodle is converting the times to your time zone.
21:13:13 <Arkady_Kanevsky> cool. thanks.
21:13:21 <leong> the doodle link should indicate that on your screen
21:13:52 <leong> jamemcc, that is great if you can help on the roadmap update..
21:13:57 <leong> jamemcc: can you sign up here:
21:14:01 <heidijoy> For the roadmap, we have Leong, Shamail, Kenny, Arkady, Megan and Gerald volunteering so far.
21:14:06 <leong> #link Roadmap Update: https://etherpad.openstack.org/p/PTLupdatesBoston
21:14:08 <heidijoy> https://etherpad.openstack.org/p/PTLupdatesBoston
21:14:34 <AndyU_> I will probably volunteer to help with the roadmap update; just waiting until after the meetup assuming I'll know more about it
21:15:17 <leong> AndyU_: ok.. no problem.. do contact us if you have questions on the roadmap updates
21:15:18 <heidijoy> I'll provide an update there. We need to take action to provide PTLs with an outline for their "project update" talks in Boston. Also, we had 32 projects sign up to present, which is great!
21:15:43 <heidijoy> Presenting: Barbican Blazar (formerly Climate) Cinder Designate Docs Glance Heat Horizon Ironic Keystone Kolla Kuryr Magnum Manila Mistral Neutron Nova Octavia OpenStack-Ansible OpenStack Client QA Rally Sahara Security Solum Swift Telemetry TripleO Trove Vitrage Zaqar Zun
21:16:01 <leong> that's a lot to cover...
21:16:10 <heidijoy> Not presenting a project update are Congress (they might supply info later), Cue, Murano, Watcher.
21:16:37 <heidijoy> I have a plan that will make MUCH lighter work than past cycles.
21:16:56 <heidijoy> Also our survey pre-Ocata release helped aggregate a lot of the feedback we used to do manually.
21:17:19 <heidijoy> When would the PWG ideally like to release the next community-generated roadmap?
21:17:53 <leong> heidijoy: i believe we need to release the roadmap for the Boston summit?
21:18:30 <heidijoy> Excellent. Then we have the raw materials to do so now. OK if we discuss further in Milan or do we need to dig deeper during this meeting?
21:19:13 <leong> i think we can discuss that in Milan ? thought?
21:19:19 <Arkady_Kanevsky> Heidi, do we follow CPL owner for drive PTL presentation?
21:19:19 <heidijoy> +1
21:19:23 <AndyU_> works for me
21:19:28 <Arkady_Kanevsky> +1 for Milan
21:19:41 <leong> heidijoy: maybe you can provide/email us the "todo" list for roadmap update
21:20:11 <heidijoy> @arkady_kanevsky I'm not sure about CPL status. Yes, I can email the "to do" list - do you want it before or during the Milan meetup?
21:20:33 <Arkady_Kanevsky> email before Milan. discuss at Milan
21:20:38 <leong> it will be great if you can send the "to do" list prior to Milan?
21:20:39 <heidijoy> OK!
21:20:46 <leong> heidijoy: thanks!
21:20:51 <heidijoy> np
21:20:58 <leong> ok.. moving on..
21:21:13 <leong> i think shamail already send out the email about group dinner at Milan
21:21:24 <leong> please reply to shamail emai
21:21:42 <Arkady_Kanevsky> yes. it is also on launchpad for mid-cycle
21:22:03 <leong> cool...
21:22:14 <Arkady_Kanevsky> here is current list of dinner folks - Heidi Joy, Debbie,  Arkady, Leong, Shamail, Melvin, Ala, Isaac, Rocky, Anni, Andy, Hank
21:22:32 <leong> looks like an interesting party :)
21:22:52 <Arkady_Kanevsky> families welcome. One alergy warning so far
21:23:07 <heidijoy> Prizes for the best costumes, right?!?!
21:23:14 <Arkady_Kanevsky> https://etherpad.openstack.org/p/MIL-pwg-meetup
21:23:19 <AndyU_> haha
21:23:35 <leong> lol
21:23:41 <leong> ok.. let's move on..
21:23:50 <leong> #topic "open" gerrit review
21:24:05 <GeraldK> there had been some discussion in the tracker reviews on the tracker IDs: can we also quickly discuss this here (or do you prefer to handle it f2f next week)?
21:24:26 <leong> geraldk: do you mean the "unique id" for each tracker?
21:24:33 <GeraldK> leong: yes. https://review.openstack.org/#/c/426613/
21:24:45 <Arkady_Kanevsky> that. and do we create tracker before we complete gap analysis
21:25:03 <leong> i think the tracker tool will take care (auto-generate) the id, but i just need to confirm with the tool developer
21:26:06 <leong> #action Leong to check if the tracker tools will auto-generate id, to confirm with tool developer
21:26:07 <GeraldK> leong: okay. in that case we should update the template
21:26:19 <leong> yes.. once i confirm that, i will reply on gerrit
21:26:29 <GeraldK> thanks leong.
21:26:38 <leong> i would like to talk about this changes:
21:26:38 <leong> https://review.openstack.org/#/c/426613/
21:26:57 <leong> I can't see anything to track in this file. I don't think we need a tracker file to say "gap analysis"?
21:27:35 <GeraldK> i would be okay to create the tracker before the gap analysis is complete, but would also avoid having empty trackers
21:27:50 <Arkady_Kanevsky> OK with that
21:28:31 <Arkady_Kanevsky> I will than abandon refstack congig tracker and need more review for db_hygeane one
21:28:48 <leong> so are we agreed to abandon refstack tracker for now?
21:30:26 <Arkady_Kanevsky> The hard part of refstack congig htat it really requires new projects that will be used by refstack and rally.
21:30:42 <Arkady_Kanevsky> Not sure how ot record that and how to propose it.
21:30:49 <Arkady_Kanevsky> Maybe we can discuss it at Milan
21:31:04 <leong> arkady_kanevsky: can you bring that up during the Milan meeting?
21:31:10 <Arkady_Kanevsky> yes
21:31:32 <leong> and let's abandon that changes for now?
21:32:06 <Arkady_Kanevsky> Yes.
21:32:12 <leong> ok.. thanks!
21:32:15 <Arkady_Kanevsky> Added Process of brining new project based on initial gap analysis for mid-cycle topics
21:32:22 <leong> #agreed Arkady_kanevsky to abandon refstack tracker as there is nothing to track for now
21:32:24 <Rockyg> also might be worthwhile dropping in on the refstack meetin tomorrow at 11am pst
21:32:30 <leong> thanks arkady
21:32:53 <leong> anyone joining the refstack meeting?
21:32:58 <Arkady_Kanevsky> Thanks RockyG
21:33:14 <leong> on the DB hygience user story
21:33:34 <leong> #link DB-hygience user story: https://review.openstack.org/#/c/428571/
21:33:48 <leong> is there a gap-analysis document on that?
21:34:03 <Arkady_Kanevsky> partial gap analysis wiht a few tracking bugs/blueprints. On my plate to create more
21:34:18 <Arkady_Kanevsky> no gap analysis doc yet.
21:34:20 <leong> can we ensure we have gap-analysis documented prior to tracker..(though both may happen at the same time)
21:34:36 <Arkady_Kanevsky> can do that.
21:34:50 <leong> even a partial gap analysis is also fine..
21:35:12 <leong> mark other requirements as "tbd" if still work in progres
21:35:21 <Arkady_Kanevsky> will do. Thanks
21:36:00 <leong> #action Arkady_Kanevsky to add gap-analayis document for DB-hygience user story
21:36:36 <leong> Hieu LE submitted a new user story about "traceability"
21:36:48 <leong> #link Traceability User Story: https://review.openstack.org/#/c/440309/
21:37:35 <leong> please review and provide feedback to the traceability user story.. it is also somehow related to "logging" (but is not a logging)
21:37:38 <Arkady_Kanevsky> will review later this week
21:37:57 <leong> is more about correlation and faciliate root-cause analysis
21:38:10 <GeraldK> will review in next few days
21:38:25 <leong> ok.. anyone else has any item to review on gerrit? (before we move on to next topic)
21:38:51 <Arkady_Kanevsky> brings a question. If we propose that this or other story is really an extension to existing one, what is the process for it?
21:39:13 <leong> if two story are related, specify them under "related user story" section
21:39:18 <Arkady_Kanevsky> Updating extsing story, and gap analysis and tracker?
21:40:18 <Rockyg> From my perspective, the original logging story is some fundamentals for logs.  This one would enhance logs for microservices
21:40:46 <leong> rockgy: this is not about microservices, is about logs for each openstack services
21:40:55 <Rockyg> This user story could ref the original log one.  Sort of cascading user stories....
21:41:09 <Arkady_Kanevsky> refstack tracker abandon
21:41:33 <Rockyg> Well, it's about logs, but also about tracing requests through all services that act to complete request
21:41:46 <leong> let's review that offline over gerrit...
21:41:51 <Arkady_Kanevsky> that is the core question Rocky.
21:41:58 <leong> i want to spend some time today to talk about Boston Forum
21:42:02 <Arkady_Kanevsky> it changes the definition of complete.
21:42:20 <Arkady_Kanevsky> +1 leong
21:42:25 <leong> #topic Boston Forum
21:42:42 <leong> the Forum is open up to brainstorm session proposal now...
21:42:58 <leong> any topics that we want to propose at Forum from Product WG?
21:43:55 <Arkady_Kanevsky> I would like to bring discussion on intergrated release - not individual project releases close in time
21:44:06 <leong> see email from Shamail here
21:44:06 <leong> http://lists.openstack.org/pipermail/user-committee/2017-February/001767.html
21:44:29 <leong> and refer to this etherpad
21:44:39 <leong> #link UC Forum Brainstorm sessions: https://etherpad.openstack.org/p/BOS-UC-brainstorming
21:45:23 <leong> i notice this "Logging across all projects" on the above etherpad line28
21:46:23 <leong> btw, generally the sessions can be 1. Strategic  2. Cross-project OR 3. Project-specific
21:46:28 <Arkady_Kanevsky> thanks Leong. Something to think about
21:47:23 <jamemcc> The item I'm aware of from LCOO brainstorming I just added "Cloud Native Principles/Microservice approach for OpenStack"
21:48:09 <leong> please also include a brief abstract (2 -3 sentences) and contact info (irc handle or email)
21:48:37 <leong> i assume the formal submission process for the Forum will start March 14, mrhillsman, do you have any insights?
21:49:01 <leong> and deadline for Forum session proposal is March 26
21:50:40 <Rockyg> mrhillsman, dropped off for another appt.
21:50:50 <AndyU_> Leong: That's what I heard... but I heard it from you
21:50:50 <leong> btw, i propose a "track-chair" session (Summit Track Selection Process) thought not directly link to PWG but more related for Track-Chair
21:50:58 <leong> LOL AndyU_!
21:51:11 <AndyU_> ;)
21:51:53 <leong> those dates was previously announced, but i just want to make sure if i didn't miss any updates/changes to the dates
21:52:45 <leong> ok.. so folks, please think about the session for Forum, feel free to use the mailling list for discussion...
21:53:00 * leong last 8 minutes
21:53:06 <leong> #topic Midcycle planning
21:53:20 <leong> just want to make sure we are good toward PWG midcycle meeting
21:53:31 <leong> #link PWG Midcycle Planning Etherpad: https://etherpad.openstack.org/p/MIL-pwg-meetup
21:54:13 <leong> i will go through the PWG midcycle Agenda with Shamail again
21:54:21 <leong> we have quite a lot to cover within two days
21:54:25 <Arkady_Kanevsky> I will see you all in Milan next Monday
21:54:53 <leong> Arkady.. is there a way to contact you at Milan? eg. cell phone?
21:54:57 <AndyU_> I just hope I can find it!  :)
21:55:31 <Arkady_Kanevsky> yes my cell should work. texting is best. WIll add it to launchpad
21:55:44 <Arkady_Kanevsky> But this will be my first time at that facility also...
21:56:12 <Arkady_Kanevsky> also will add local phone.
21:56:15 <leong> so i assume we will go in and tell the security that we have an appointment with Arkady?
21:56:50 <leong> i am kind of avoiding putting my cell phone on public etherpad and irc :-)
21:57:07 <leong> i will email individually if you need my cell :)
21:57:43 <leong> there will be no irc meeting next week then... :)
21:58:20 <Arkady_Kanevsky> yes. They will be expecting you. I will gave them the list of attendess tomorrow.
21:58:21 <leong> do we need a voice bridge for the Milan meeting? anyone plan to dial in remotely?
21:59:11 <MeganR> I'm not, time difference will be tough, but it can also be really hard to hear and follow along.  I'll catch-up when you are all back!
21:59:28 <leong> thanks MeganR
21:59:34 <leong> #agreed no IRC meeting on March 13th due to PWG Milan Midcycle Meetup
21:59:40 <GeraldK> i will be in Japan next week, so also it would be difficult for me to dial in
21:59:56 <Arkady_Kanevsky> We will have phone. Let me know if we need phone bridge. We can decide it on the spot
22:00:02 <leong> i will make a summary report at the end of the meeting then... :)
22:00:13 <MeganR> Thank you Leong!
22:00:17 <Arkady_Kanevsky> need to leave.
22:00:20 <leong> we can use the Intel voice bridge facility if needed
22:00:21 <GeraldK> leong, that would be great. thx
22:00:25 <Arkady_Kanevsky> Thanks everybody and see you in Milan
22:00:26 <leong> alright
22:00:29 <leong> i think we are good..
22:00:32 <heidijoy> We'll do an excellent etherpad during the meeting.
22:00:37 <MeganR> Safe travel everyone!
22:00:39 <heidijoy> Safe travels!
22:00:46 <leong> see you all at Milan for those attending.. take care all!
22:00:51 <AndyU_> indeed. safe travels.
22:01:03 <Rockyg> see lots of you there!  wiil miss the rest
22:01:12 <leong> #endmeeting