21:00:14 <shamail> #startmeeting product_working_group
21:00:15 <openstack> Meeting started Mon Mar 27 21:00:14 2017 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:18 <openstack> The meeting name has been set to 'product_working_group'
21:00:26 <shamail> Hi, anyone here for the PWG meeting?
21:00:55 <shamail> Hi GeraldK
21:01:08 <GeraldK> hi
21:01:54 <shamail> Seems like we have 4-5 people here so far.. let’s give it another minute or two.
21:02:04 <MeganR> Hi
21:02:12 <AndyU> okeydokey
21:02:21 <AndyU> Hi Megan  :)
21:02:36 <MeganR> Hi AndyU!
21:03:10 <shamail> Alrighty
21:03:15 <shamail> Who’s here for the PWG meeting?
21:03:19 <shamail> #topic roll call
21:03:41 <GeraldK> o/
21:03:52 <AndyU> hi all
21:03:55 <MeganR> o/
21:04:07 <shamail> Agenda for today:
21:04:13 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:04:27 <shamail> #topic Recap from Ops midcycle
21:04:47 <shamail> A bunch of us were in Milan the week before last for the Product WG midcycle and Ops meetup
21:04:59 <shamail> The meetup was well-attended and an overall great event
21:05:17 <shamail> #link https://etherpad.openstack.org/p/MIL-ops-meetup
21:05:33 <shamail> In this etherpad, there are links to etherpads from all the sessions in case you want to catch up
21:06:00 <shamail> We also discussed using ‘hash tags’ to identify items that require follow-up and Leong created a small program to parse through etherpads and extract them
21:06:12 <shamail> #link https://drive.google.com/drive/folders/0B733UR8kbomaSVhqQ3Y4NkFxTmc
21:06:14 <jamemcc> o/ Jamey here as well
21:06:20 <shamail> Hi jamemcc
21:06:36 <Arkady_Kanevsky> hello
21:07:02 <shamail> In the linked folder, we have each hash-tag in a separate file along with line number information from the etherpad in which it was referenced
21:07:25 <shamail> This is still a work in progress but it is a good starting point towards being able to aggregate feedback from etherpads at events like the Ops meetup and Forum
21:08:01 <shamail> Does anyone who was at the ops meetup want to give their perspective on the event or areas/sessions they found enlightening?
21:09:12 <shamail> I personally thought the container sessions (both running containers on OpenStack or running OpenStack on containers) were interesting.. it seemed like there was a lot of discussion happening on the topics but few adopters so far
21:09:22 <GeraldK> from the files it looks like few projects made nice use of the hashtags
21:09:28 <shamail> The trend for adoption seemed to be there though
21:09:34 <shamail> Agreed GeraldK
21:09:54 <shamail> Moving on to the PWG midcycle topic...
21:10:01 <shamail> #topic Action item from PWG meetup
21:10:10 <shamail> #link https://etherpad.openstack.org/p/MIL-pwg-meetup
21:10:16 <shamail> #link https://drive.google.com/drive/folders/0B733UR8kbomabGpidlBBUDdNQ1E
21:10:46 <shamail> So we used the same hashtag method for our midcycle as well and the linked google drive folder contains hashtags used in our etherpad
21:11:14 <shamail> The PWG mid-cycle was VERY productive and we had several discussions on topics that will shape our future
21:12:23 <shamail> The key discussions were on evolving the roadmap process (to make it a bit more bi-directional in the future), renaming user stories, revisiting the workflow and how to foster idea submission, and how to increase participation/awareness of this WG
21:13:18 <shamail> As you can see from the Google drive folder, most action items have owners listed so I am going to be skipping those… but I did want to bring attention to other action items that currently do not have owners.
21:13:25 <Arkady_Kanevsky> I was impressed by HPC participation on multiple sessions.
21:13:41 <rockyg> o/  Sorry I'm late.  Involved in a deep convo
21:13:49 <shamail> hi rockyg
21:13:56 <shamail> +1 Arkady_Kanevsky
21:14:03 <shamail> Action item: Use adoption data as weight to apply on themes 100K view
21:14:23 <shamail> So this one doesn’t have an owner but will most likely be incorporated into the bundle of ‘things to do’ for the next roadmap.
21:14:33 <Arkady_Kanevsky> +1
21:14:51 <shamail> The general premise behind this action item is to add weights to the responses we get from projects on which themes they are pursuing
21:15:18 <shamail> The current process counts each entry equally so if Nova, Kuryr, Zaqar say they are working on theme #1, it would show the count as 3
21:16:01 <Arkady_Kanevsky> should we give "core" components hight weitght?
21:16:06 <shamail> in the future, we want to weigh the feedback so that (in the same example) it would Nova = 1 * <adoption rate> + Kuryr = 1 * adoption rate + Zaqar = 1 * adoption rate
21:16:30 <Arkady_Kanevsky> just adoption rate as multiplier?
21:16:31 <shamail> so that we say which theme was the most relevant based on the projects being adopted
21:16:39 <shamail> Yes Arkady_Kanevsky
21:17:18 <shamail> Adoption rate is a large part of the “core” component and therefore those lists would probably overlap
21:17:43 <Arkady_Kanevsky> so we are looking in late #s for adoption from previous released to prioritize future work?
21:18:15 <Arkady_Kanevsky> I guess - as good as we can do now
21:18:17 <shamail> Arkady_Kanevsky: Just for weighing the themes, not for development proposal priortization
21:18:37 <Arkady_Kanevsky> +2
21:18:39 <shamail> We can refine if we get better inputs in the future but its a good starting point without creating too much additional work
21:18:48 <Arkady_Kanevsky> agree
21:18:55 <shamail> Action item: Summary and next steps/ project out line & working plan:
21:18:57 <shamail> #link https://etherpad.openstack.org/p/PTLupdatesBoston
21:19:26 <shamail> Heidi Joy shared plans about the PTL updates track scheduled for Boston (which will replace our Design Series Webinars with PTLs)
21:19:42 <shamail> Please add your name to the list if you would like to participate in those interviews/roadmap creation
21:20:17 <shamail> Action item: update wiki with glossary/template-with-examples
21:21:40 <shamail> This one currently has no owner but the general discussion was to create examples in our wiki and repository that show what a completed development proposal (formerly called user story), tracker, gaps analysis, etc. might look like
21:21:49 <shamail> this is to help newcomers understand those artifacts
21:22:40 <shamail> Action item: Categorizing openstack projects
21:23:07 <Arkady_Kanevsky> If nobody will take it I will see if can do on weekend.
21:23:16 <shamail> Thanks Arkady_Kanevsky!
21:23:50 <GeraldK> I could take the previous one on updating the Wiki with glossary/templates
21:23:56 <shamail> #action Build sample development proposal, tracker, and gaps analysis for illustration purposes (Arkady_Kanevsky)
21:24:15 <shamail> #action Update wiki with Glossary and overview of templates (GeraldK)
21:24:18 <shamail> Thanks GeraldK
21:24:45 <shamail> The next action item is to help the OpenStack Foundation with building categories for the various OpenStack projects to make navigation simpler for new users
21:25:08 <shamail> We will need volunteers to help with this sub-team/task
21:25:24 <shamail> I will be glad to help with this one along with others who are interested
21:25:51 <Arkady_Kanevsky> SHamail - what kind of categories you arethinking?
21:25:56 <shamail> They already have a list of categories created, we just need to review and help simplify project descriptions where applicable
21:26:09 <shamail> https://etherpad.openstack.org/p/MIL-pwg-meetup
21:26:18 <shamail> Arkady_Kanevsky: Look at line 436
21:26:53 <Arkady_Kanevsky> got it - Configuration Management, Containers, Virtual Machines, Databases, Networking, Monitoring, Big Data, Storage, Service Catalog, etc.
21:27:10 <shamail> That’s about it on the unassigned action items
21:27:25 <shamail> #topic Storyboard
21:27:58 <shamail> In our discussion about simplifying the (initial) idea submission process, we discussed and settled on storyboard as a possible solution
21:28:10 <shamail> #link https://storyboard.openstack.org/#!/page/about
21:28:45 <shamail> Please look through the site to familarize yourself with it for now, but we will follow-up in a future meeting to review what works, what doesn’t, etc.
21:28:58 <jamemcc> I joined to talk about User Story Tracker (not exaclty Storyboard, but related I believe)
21:29:22 <shamail> Sounds good jamemcc, i’ll make sure we get to the opens so we can discuss.
21:29:31 <jamemcc> If nothing else- to announce there is a project meeting tomorrow
21:29:54 <shamail> jamemcc: Go ahead and share the details
21:30:03 <Arkady_Kanevsky> Need to clean up defintions - It all begins with a story. A story is a bug report or proposed feature. Stories are then further split into tasks, which affect a given project and branch.
21:30:05 <shamail> I’ll add it as ‘info’ to our log
21:30:56 <Arkady_Kanevsky> Need extend "proposed feature" to proposal definition. with single project feature reqyuest a subset of it
21:31:15 <Arkady_Kanevsky> I guess I can create a bug for it?
21:31:39 <shamail> Arkady_Kanevsky: Yes, I think the current thought is to use storyboard as an area where users (not active PWG members) can post an idea and associate it with a project labelled ‘development proposal’… our team would then review that queue and the ones that seem to be a significant need will be picked up for development proposal creation by us.
21:31:51 <jamemcc> Four User Story Tracker meeting: The open question for the project team is any enhancements needed and when / how can we get pointed at production repository.
21:31:55 <jamemcc> Purpose: Ongoing status tracking and collaboration for the Product Working Group driven development and rollout of the User Story Tracker.  Meeting will occur every 2 weeks at 2PM Pacific Time.
21:31:55 <jamemcc> Etherpad link: https://etherpad.openstack.org/p/User_Story_Tracker
21:31:55 <jamemcc> Tool link: http://featuretracker.openstack.org/
21:32:10 <shamail> #link https://etherpad.openstack.org/p/User_Story_Tracker
21:32:17 <shamail> #link http://featuretracker.openstack.org/
21:32:20 <jamemcc> Tuesday, March 28, 2017 4:00 PM-5:00 PM (UTC-06:00)
21:32:34 <jamemcc> https://join.att.com/meet/jm6819/672FQ2YC
21:32:40 <jamemcc> Web conference
21:32:54 <jamemcc> url: https://join.att.com/meet/jm6819/672FQ2YC
21:33:01 <shamail> #info Feature Tracker tool team meeting: Tuesday, March 28, 2017 4:00 PM-5:00 PM (UTC-06:00) [https://join.att.com/meet/jm6819/672FQ2YC]… Please join if able.
21:33:04 <AndyU> We also talked about letting posting an initial abstract and get feedback on whether or not it was worth putting in the further effort. Or will it be eclipsed by other priorities.
21:33:20 <shamail> AndyU: +1
21:33:23 <jamemcc> #link https://join.att.com/meet/jm6819/672FQ2YC
21:33:55 <shamail> The submission into storyboard is an entry point into gauging broader need for an idea… if it doesn’t get much traction then we will note that in the submission comments
21:34:23 <AndyU> I'm very motivated to help with the Dev Proposal (aka Story) process enhancements. Having to multi-task in two meetings right now so not following the PTG meeting very well.
21:34:33 <shamail> Thanks jamemcc, I think it would be good to get a demo scheduled for those that are interested in the Feature Tracker to see if there are any remaining gaps/enhancements that could be made for V1
21:35:11 <shamail> No problem AndyU, I was just sharing Storyboard with everyone for familiarity… we can dive deeper into the impact on process in a future meeting.
21:35:37 <shamail> Okay to move to the next topic?
21:35:48 <AndyU> Thx. Just would like to pitch in. Don't want to miss it ;-)
21:35:54 <rockyg> jamemcc, also, is there a link to a wiki page or a calendar that hast the meeting info on it?  Be nice to be able to bookmark the meeting info.
21:36:41 <shamail> rockyg: +1! jamemcc: It might be good to add a page to our wiki on Feature Tracker
21:36:49 <Arkady_Kanevsky> Adding the pointer from agenda wiki page will be goode for storyboard item
21:37:06 <jamemcc> Sure - I will
21:37:11 <Arkady_Kanevsky> thanks
21:37:25 <shamail> jamemcc: Making it a sub-page here might be ideal [https://wiki.openstack.org/wiki/ProductTeam/User_Stories]
21:37:29 <jamemcc> #action Jamey to update PWG wiki for Feature Tracker project meetings
21:37:34 <AndyU> +1 to adding more detail to wiki on all facets of Dev Proposal workflow
21:37:56 <shamail> #action Update PWG wiki to add a page on Feature Tracker and meeting info (jamemcc)
21:38:16 <shamail> #topic https://wiki.openstack.org/wiki/Meetings/product-team
21:38:23 <shamail> Copy Fial.
21:38:25 <shamail> Fail*
21:38:27 <shamail> #topic Forum session submission
21:38:57 <shamail> #info Deadline for Forum Topic submissions is 11:59PM UTC on SUNDAY April 2nd
21:39:01 <shamail> #link http://forumtopics.openstack.org/
21:39:34 <shamail> #action User Story owners should submit a forum session for their respective stories (all user story owners)
21:39:49 <shamail> If anyone has additional ideas, please submit them as well.
21:40:01 <shamail> I think we had discussed submitting a session on PWG overview and workflow.
21:40:27 <shamail> Arkady_Kanevsky: Did you volunteer to submit that one?
21:40:49 <Arkady_Kanevsky> Yes. I have it in https://etherpad.openstack.org/p/BOS-UC-brainstorming
21:40:55 <shamail> Also, please note that if you submitted a topic to the brainstorming etherpad for the Forum that it won’t be automatically transferred into the tool
21:40:59 <Arkady_Kanevsky> Need to formally submit it.
21:41:09 <shamail> Please take any ideas from the etherpad to formal submission via the tool
21:41:12 <shamail> Thanks Arkady_Kanevsky
21:41:25 <AndyU> I have a few to submit yet
21:41:40 <shamail> Awesome AndyU, you have a few days left :)
21:41:47 <shamail> Anything else on this topic?
21:41:53 <Arkady_Kanevsky> Actual proposal is at https://etherpad.openstack.org/p/BOS-PTG-proactive linek from BOS-UC-brainstorming one as agreed
21:42:10 <shamail> Arkady_Kanevsky: thanks!
21:42:20 <AndyU> When we do, what's expected?  An abstract, create an etherpad(?) for the session, etc?
21:42:22 <shamail> #link https://etherpad.openstack.org/p/BOS-UC-brainstorming
21:42:28 <shamail> #link https://etherpad.openstack.org/p/BOS-PTG-proactive
21:43:16 <shamail> An abstract is ideal, etherpads can be created after the session is accepted BUT if you already have an etherpad on the topic (like Arkady_Kanevsky just linked) then I would recommend including it in the abstract to show the discussions already happening
21:43:23 <shamail> AndyU: ^
21:43:44 <AndyU> thx!
21:43:57 <shamail> #topic Vote on biweekly dial-in and IRC meeting
21:44:10 <GeraldK> do we have a list of owners for the different user stories?
21:44:46 <shamail> GeraldK: Good question, we did at one point: https://wiki.openstack.org/wiki/ProductTeam/User_Stories/Rolling_Upgrades
21:44:52 <shamail> but those pages are out-dated
21:45:13 <shamail> We know who are the owners but, to your point, there is no wiki page as a “source of truth”
21:45:17 <shamail> might be worth adding as well
21:45:22 <GeraldK> I see team members, but no "owner".
21:45:51 <shamail> Kenny is the owner, but to your point, not noted as such on the page
21:45:57 <GeraldK> we should capture the owners to avoid submission overlaps or no submission as no one felt like the owner
21:46:14 <AndyU> yes
21:46:22 <shamail> I think we should probably remove the user story sub-pages and add a general one with a list of stories (link to the actual entry in the repo) along with the owner
21:46:35 <GeraldK> shamail: +1
21:46:59 <shamail> #action Remove user story sub-pages and add a new page that lists user story link and owner information (shamail)
21:47:05 <shamail> I can handle that one
21:47:06 <GeraldK> I can do this as part of the Wiki updates assigned to me earlier on in this meeting
21:47:10 <shamail> Oh cool
21:47:12 <AndyU> also need to be able to reflect some sense of if it's moving forward or lagging. Also Priority
21:47:12 <GeraldK> okay
21:47:13 <Arkady_Kanevsky> +1
21:47:20 <shamail> Let me know if you need to know who the owners are via email
21:47:38 <shamail> #action Remove user story sub-pages and add a new page that lists user story link and owner information (GeraldK as a part of the other wiki AI)
21:47:44 <GeraldK> shamail: yes. can you pls share via email?
21:47:49 <shamail> Will do
21:48:04 <GeraldK> AndyU: +1
21:48:06 <shamail> #action email list of user story owners to GeraldK (shamail/leong)
21:48:47 <shamail> AndyU: That is where the Feature Tracker comes into play… up to the completion of gaps analysis, we have to relay on data from Gerrit, etc.
21:48:48 <Arkady_Kanevsky> and what do we do with stories with no owners (owner left PTG)?
21:48:57 <GeraldK> AndyU: however, I am not sure we should capture this on the Wiki page as this information is too dynamic
21:48:58 <shamail> After that, we can use the Feature Tracker to see if its active
21:49:01 <AndyU> We should think about how we can assess/provide priority.  Via action of UC, TC, Board? Community voting? User Survey?
21:49:05 <shamail> GeraldK: +1
21:49:25 <AndyU> Yes, to big for just a wiki page at this point  :-)
21:49:47 <Arkady_Kanevsky> That why we had a subpages in the first place
21:49:52 <AndyU> Just suggesting we do some more brainstoriming around that
21:50:02 <shamail> AndyU: That is a difficult topic since user stories generally move forward when someone volunteers to “own” it.. The only way to get external prioritization is if we basically agree that we will staff user stories based on the prioritized list that is determined by whatever means
21:50:35 <shamail> I think this is where the “Feature Triage” team will play a role but details for that don’t exist yet
21:50:45 <Arkady_Kanevsky> I htink we had categorization of 3 stories in driven state others ad hoc
21:51:21 <shamail> We do Arkady_Kanevsky but my point was that those states are a result of who is willing work on a user story and not necessarily based on the priority of the feature being delivered
21:51:22 <AndyU> Understood. But I think they need some kind of legitimation. Something to help motivate projects to support them. Else only Owners who can do it all on their own (like OSIC maybe) will be successful.
21:51:29 <rocky_g> sorry. got disconnected and missed the previous 5 minutes.
21:51:33 <shamail> AndyU: +1000
21:51:55 <shamail> It would be much better to have an external review of the list of stories being worked on
21:51:57 <rocky_g> I think feature triage will be important to move forward faster.
21:51:57 <Arkady_Kanevsky> Shamail it was a combinatoin of both: owner willingness tpo drive and prioritization.
21:52:33 <shamail> This is something we can definitely discuss again in a future meeting (large topic) and continue in our next face to face as well.
21:53:02 <shamail> #action Add discussion on story staffing, prioritization/drivers to a future PWG meeting
21:53:11 <AndyU> We could also use priorities that get identified as a basis for requesting Dev proposals if not exist to address the need yet.
21:53:28 <shamail> +1
21:53:51 <shamail> #topic opens
21:54:06 <shamail> Do we have anything else to discuss?
21:54:09 <Arkady_Kanevsky> need to drop - have a great day everbody
21:54:24 <shamail> The prioritization topic needs to be a future topic because it will take awhile :)
21:54:32 <AndyU> We discussed starting to have some voice meetings. Those big brainstorming topics would be good for that format.
21:54:40 <shamail> AndyU: +1
21:55:07 <rocky_g> +100
21:55:09 <shamail> Will have to send an email to gauge whether people prefer a bi-weekly IRC/voice cadence or just IRC (we don’t have enough members in the meeting today)
21:55:25 <GeraldK> can someone have a look at https://review.openstack.org/#/c/434577/
21:55:43 <shamail> It is always an option to setup one-off phone meetings too… we normally do this for roadmap or other sub-team activities
21:56:21 <shamail> #action Please review https://review.openstack.org/#/c/434577/
21:56:29 <shamail> I put it down GeraldK so that I remember
21:56:43 <GeraldK> thanks shamail
21:56:50 <shamail> Thank you everyone!
21:56:55 <shamail> Have a great evening/day
21:57:08 <shamail> #endmeeting