21:00:24 <leong> #startmeeting product_working_group
21:00:25 <openstack> Meeting started Mon Apr 24 21:00:24 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:28 <openstack> The meeting name has been set to 'product_working_group'
21:00:33 <Arkady_Kanevsky> I will be on for the first 1/2 hour
21:00:41 <leong> #topic Rollcall
21:00:54 <shamail> Hi everyone
21:00:54 <GeraldK> o/
21:00:56 <leong> let's get the ball rolling
21:01:08 <pchadwick> o/
21:01:24 <leong> who is here for Product WG meeting? :)
21:01:46 <Arkady_Kanevsky> Arkady
21:01:46 <leong> #chair add shamail
21:01:47 <openstack> Warning: Nick not in channel: add
21:01:48 <openstack> Current chairs: add leong shamail
21:02:07 <shamail> :-)
21:02:13 <leong> today agenda can be found here:
21:02:19 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:02:34 <leong> if you have any topics not listed in the agenda, feel free to bring it up!
21:02:57 <leong> in general, today we want to cover more around Boston Summit and Forum
21:03:05 <AndyU> o/
21:03:28 <leong> any other agenda to add before i kick start the first one?
21:03:41 <Arkady_Kanevsky> For https://etherpad.openstack.org/p/PWG-forum-planning - do we need a volunteer for each session?
21:03:58 <Arkady_Kanevsky> Of it iwll be handled by user WG and only subset will fall on us.
21:04:24 <leong> #topic Boston Forum Planning
21:04:25 <Arkady_Kanevsky> We still need to convery to moderator about adding ## info.
21:04:43 <rockyg> o/
21:04:58 <leong> FYI, for those who are not aware, the approved list of forum sessions can be found here: http://forumtopics.openstack.org
21:05:02 <shamail> #link https://www.openstack.org/summit/boston-2017/summit-schedule/#track=146
21:05:15 <shamail> This link is the online version of the accepted sessions for the Forum
21:05:20 <leong> as well as the link provided by shamail :)
21:05:28 <leong> +1 shamail
21:06:03 <leong> from the list of approved session, does anyone need help here?
21:06:14 <leong> especially those "moderator"?
21:06:34 <shamail> I am moderating https://www.openstack.org/summit/boston-2017/summit-schedule/events/18744/evolving-the-community-generated-roadmap with HeidiJoy
21:06:39 <leong> Arkady_Kanevsky: i will get back to your question real quick...
21:06:54 <shamail> We are good for this topic, I sent an email earlier today to invite TC and UC members
21:07:11 <leong> shamail: yes i saw that email ...
21:07:28 <AndyU> I plan to join that one
21:07:35 <rockyg> shamail, I could use help on the logging topics
21:07:46 <leong> i assume the rest of the moderator should also start "inviting" people to join the relevant sessions
21:08:12 <shamail> rockyg: I saw that you didn’t confirm “moderator” for that one yet… I am going to be sending a reminder tomorrow to those who haven’t responded yet. Do you need to find a new moderator?
21:08:51 <rockyg> No, I can moderate, but I'd love to have some backup there.
21:08:52 <leong> for moderator, we also encourage you to use the etherpad template
21:08:56 <AndyU> Rocky, Hank Greene (he was with us in Milan) would like to connect with you about the logging session
21:09:04 <leong> #link Forum Etherpad Template: https://etherpad.openstack.org/p/BOS-forum-moderator-template
21:09:07 <shamail> Gotcha rockyg
21:09:34 <shamail> Thanks AndyU, rockyg seems like you there is someone willing to co-moderate :)
21:10:02 <rockyg> Excellent.  Either give him my email, or give me his.  Looks like we have lost some of our implementers.
21:10:23 <shamail> AndyU: Please copy me as well so I can have him added to the session
21:10:32 <AndyU> How about if i send an email to Hank & Rocky to make the introduction? He wants to connect with Rocky and work on the logging stuff
21:10:39 <rockyg> Thanks for the template link leong
21:10:56 <AndyU> ok, I'll include Shamail
21:11:13 <rockyg> Great!  can use all the help I can get from somebody who understands the issues.
21:11:17 <leong> awesome
21:11:38 <AndyU> To be clear... I can't promise Hank will want to co-moderate (but probably)
21:11:50 <shamail> leong: The template looks great, I used it for the community roadmap session. I know the UC meeting was cancelled today but when you have time can you please reply to the email and let the UC members know about our template and plans? Once we notify the UC, we can forward it to the forum planning committee.
21:12:00 <rockyg> FYI, Doug Hellmann is working on a spec from a developer POV.  I'll send out the link and some history to all interested.
21:12:12 <shamail> thanks rockyg
21:12:13 <leong> shamail: yes. i will do that after this meeting...
21:12:19 <shamail> leong: thanks
21:12:49 <leong> going back to Arkady's question: do we need a volunteer for each session?
21:13:12 <leong> Arkady_Kanevsky: i don't think we have enough manpower to cover every sessions
21:13:37 <Arkady_Kanevsky> agree.
21:13:40 <leong> there are nearly 70 forum sessions
21:14:04 <leong> i think that's part of the reason we propose to use the template and ##hashtag
21:14:12 <shamail> leong: Agreed, I think we just need to share the template and hashtag info
21:14:17 <Arkady_Kanevsky> Suggest we updated #hashtag guidance and send to each moderator for people to use in the session.
21:14:33 <leong> shamai: +1
21:14:38 <MeganR> will any of the forum sessions be recorded?
21:14:52 <Arkady_Kanevsky> Do we have enouhg from 04/13 page for it?
21:14:57 <leong> Arkady_Kanevsky: for #hashtag guidance, there is a short description in the Template
21:15:03 <shamail> good question, I don’t think so but I can double check and let everyone know
21:15:14 <shamail> they are similar to ops and design sessions which normally were not recorded
21:15:24 <leong> Arkady_Kanevsky:I don
21:15:29 <MeganR> that's what I figured, but thought I would ask  :)
21:15:33 <leong> i don't get your question: Do we have enouhg from 04/13 page for it
21:15:37 <Arkady_Kanevsky> excellent. Thanks.
21:15:46 * leong hit the cr key too fast...
21:15:55 <Arkady_Kanevsky> Templates cover it.
21:16:21 <Arkady_Kanevsky> Who is going to send it to all moderators? Do we have email list for it?
21:16:38 <leong> #action Leong to email UC about Forum template and ##hashtag today
21:17:02 <Arkady_Kanevsky> Thanks Leong
21:17:23 <leong> Arkady_Kanevsky: once i email UC, i will forward to "forum planning committee"
21:17:44 <Arkady_Kanevsky> thanks
21:17:45 <leong> "forum planning committee" will then notify all moderators...
21:17:52 <leong> shamail: am i right? :)
21:19:12 <rockyg> having major IRC delays here.  14:15:46 was last message received.  I will get the messages eventuallym, but expect me to ve very asynch.
21:20:33 <AndyU> Rocky, I just sent the email to you, Hank and Shamail about logging.
21:20:56 <leong> anything else for Forum sessions and preparation?
21:21:06 <leong> are we all clear on the template and ##hashtag
21:21:26 <leong> in case you are not aware, we listed down a few "suggested/recommended" ##hashtag
21:21:33 <shamail> leong: +1
21:21:39 <rockyg> thanks, AndyU
21:21:44 <leong> #link Hashtag definition: https://etherpad.openstack.org/p/BOS-forum-hashtag-definition
21:22:11 <leong> those definition are also included in the "etherpad template"
21:22:57 <AndyU> In our planning meeting we discussed an email to provide a quick reminder/overview of what the Forum is for all participants. i think Melvin was looking into that
21:23:52 <AndyU> I'm finding that many people (despite heroic efforts) still do not know what the Forum is, why, what to expect, how to pre-plan, etc
21:24:47 <leong> AndyU: i didn't recall that one? Is that something expecting from PWG?
21:24:48 <Arkady_Kanevsky> +1 AndyU
21:25:26 <Arkady_Kanevsky> need to drop. Will stay in the meteing to read later
21:25:29 <leong> I presume Tom/Forum-Planning-Committee will do that? and Shamail and Melvin also in that committee?
21:25:46 <rockyg> Yah.  Transparency ain't great.  I think because *nobod6y* is real clear on what is is/could be
21:26:04 <AndyU> Tips for moderators and participants might also be good. things like how to find the etherpad, review it, add items to it, reach out to people you want to attend and ask them to come, look for related presentations and reach out to speakers, ask speakers to mention the forum session, etc.
21:27:10 <AndyU> @Leong - we talked about it 4/20 and Melvin seemed to be taking notes, but no specific action items I think
21:28:13 <leong> ok.. you mean adding list of forum's session etherpads and instructions for moderators?
21:28:51 <leong> i will check with Tom/forum-committee
21:29:35 <shamail> What’s the question?
21:29:50 <leong> shamail: Tips for moderators and participants might also be good. things like how to find the etherpad, review it, add items to it, reach out to people you want to attend and ask them to come, look for related presentations and reach out to speakers, ask speakers to mention the forum session, etc
21:30:06 <leong> shamail: I presume Tom/Forum-Planning-Committee will do that?
21:30:12 <AndyU> instructions, tips, etc., but maybe one targeted at moderators and another as part of a general message about the Forum for everyone
21:30:14 <shamail> Yeah, spending this week making sure we have moderators for sessions
21:30:29 <AndyU> just a suggestion :-)
21:30:32 <shamail> next step is to enable moderators, which would be when we do all those things
21:30:40 <shamail> similar to ops meetup prep
21:31:04 <rockyg> Tom has a moderator's wiki page to point folks at.  There was a youtube made about a year ago, too.
21:31:44 <leong> #link Forum wiki page: https://wiki.openstack.org/wiki/Forum
21:32:17 <leong> #link List of Forum sessions: https://wiki.openstack.org/wiki/Forum/Boston2017
21:33:23 <AndyU> Yep, good resources.
21:33:27 <shamail> good links
21:33:43 <leong> ok.. anything else to discuss for Boston Forum ?
21:34:27 <leong> #topic Boston BoF
21:34:47 <leong> The BoF date/time is: Wednesday, May 10, 5:20pm-6:00pm
21:34:57 <AndyU> I'm just guessing that less than 1% of attendees know what an ops meetup is like. They probably have no experience to draw from to really get a sense for what the Forum sessions are supposed to be like. Moderators are probably fine. Thinking of general attendees
21:35:26 <leong> Shamail wil be moderating the BoF now
21:35:47 <shamail> that will be a general growing pain AndyU, first forum…
21:36:01 <AndyU> true
21:36:08 <leong> AndyU: yes.. the community is learning..:)
21:36:09 <shamail> developers and ops will know the format but users will experience it for the first time.
21:36:14 <shamail> There is an intro session on the first day
21:36:39 <leong> shamail: anything to discuss for the BoF?
21:36:40 <AndyU> oh that's right. That's good!
21:36:51 <shamail> #link https://www.openstack.org/summit/boston-2017/summit-schedule/events/18793/forum-101-previously-design-summit-101
21:37:08 <shamail> leong: working on the deck this week, I hope to have it ready for team review by next meeting
21:37:25 <leong> shamail: awesome, thanks, let me know if need help.
21:37:31 <shamail> thanks
21:37:44 <leong> #topic PWG Boston Working Session
21:37:56 <leong> The PWG working session date/time is: Wed 10 , 2:40pm-3:20pm
21:38:13 <shamail> #info New PWG working session date/time is: Wed 10 , 2:40pm-3:20pm
21:38:19 <leong> Please note the "time changed" in case you previously saved that in your calendar
21:38:37 <AndyU> The working session originally conflicted with LCOO's. Now they're been adjusted to follow each other.
21:39:03 <leong> i think both are now in the same room...
21:39:46 <leong> #link PWG Boston Working Session: https://etherpad.openstack.org/p/PWG_Session_May2017_BOS
21:40:19 <leong> this is the etherpad that we created previously.. i am wondering if we should also adopt the "forum template" :)
21:40:28 <AndyU> Might present an opportunity for PWG to help LCOO find focus
21:41:16 <leong> we only have 40 mins for the working session, if you have any agenda, please add to it..
21:41:22 <GeraldK> leong: +1
21:41:27 <shamail> leong: +1
21:41:32 <GeraldK> for adopting the template
21:41:46 <leong> i will change that then :-)
21:41:57 <leong> meanwhile if you have any agenda, please add to it..
21:42:20 <leong> we need to make the best use of 40-mins for things that need F2F discussion
21:42:48 <leong> #action leong to update the PWG Working Session etherpad to "forum template"
21:43:39 <leong> one key topic of discussion in the Working Session is the "post-forum analysis"
21:44:59 <leong> #action all please suggest agenda for Working Session, especially topics that need F2F discussion
21:45:25 <leong> let's move on to next topic.... :)
21:45:32 <leong> #topic Roadmap
21:45:52 <leong> #info Roadmap session: Monday, May 8, 2:50pm-3:30pm
21:46:50 <leong> #link Community roadmap session: https://www.openstack.org/summit/boston-2017/summit-schedule/events/17775/whats-going-on-in-openstack-learn-about-the-community-generated-roadmap
21:47:27 <shamail> HeidiJoy has sent out a questionnaire to PTLs and we have recieved a few responses already… she has been converting the responses into slide format.  We will leverage the slides she is creating to build the roadmap.
21:47:40 <shamail> pchadwick said that he has availability to help with the creation as well…
21:47:59 <leong> AndyU also mentioned to me that he would like to help... :)
21:48:03 * pchadwick still says that
21:48:06 <shamail> Kenny won’t be at the summit so I am going to update the presenters to HeidiJoy, pchadwick, and I is everyone is okay with that
21:48:20 <leong> shamail: +1
21:48:25 <pchadwick> +1
21:48:36 <shamail> I think at this point, we will need help after the summit when we use the project updates to build the roadmap refresh following the summit.
21:48:53 <rockyg> +1
21:49:08 <shamail> The short runway at this point probably works best to just churn through the updates… I will make sure to include everyone on the draft for feedback/analysis and suggestions
21:49:33 <AndyU> At the mid-cycle there was talk of also asking for a production readiness assessment, like should something be considered 'beta'. Will that be included?
21:49:54 <leong> shamail: maybe that can be a quick discussion for Working Session agenda?
21:50:03 <shamail> not in this release AndyU, we will bring that up in the “evolving the community generated roadmap"
21:50:12 <AndyU> And YES, I would like to help ;-)
21:50:21 <AndyU> ok just wondering
21:50:41 <shamail> You should def. be there as we will be sharing the recommendations we put together at the midcycle with the broader community to see which changes everyone agrees with
21:51:03 <AndyU> I definitely plan to join
21:51:07 <shamail> thanks AndyU
21:51:29 <leong> #link Evolving Community Generaged Roadmap forum session: https://www.openstack.org/summit/boston-2017/summit-schedule/events/18744/evolving-the-community-generated-roadmap
21:51:30 <shamail> That’s all I have on the roadmap at this point.
21:51:37 <leong> shamail: thanks
21:51:49 <leong> #topic Progress of renaming user-story to development proposal
21:52:07 <leong> i think we had made some good progress to rephase the term
21:52:13 <rockyg> I think it's done
21:52:15 <shamail> leong: +1
21:52:25 <rockyg> Although, now we should verify
21:52:27 <leong> and thanks all for the help!
21:52:37 <AndyU> well done
21:52:49 <leong> there are still few minor changes need to be updated/tweaked
21:52:52 <rockyg> Thanks, leonnng
21:53:17 <leong> #link latest repo: https://github.com/openstack/development-proposals
21:53:18 <GeraldK> I guess after the update of the repo, we may need to do some final changes in the Wiki. I could check tomorrow
21:53:44 <leong> existing changes need to rebase and align with the changes (e.g. directory structure changes)
21:54:11 <leong> geraldk: awesome! thanks for checking that :-)
21:54:34 <shamail> Thanks GeraldK
21:54:38 <GeraldK> #action Gerald to check Wiki for updates links to new repo
21:54:51 <leong> #action GeraldK will review the wiki for the user-story/development-proposal rephrased
21:55:08 <leong> lol... thanks geraldk
21:55:24 <AndyU> readme.rst: "The rendered user stories are available in OpenStack User Stories."  ;-)
21:55:35 <leong> good catch AndyU
21:55:40 <shamail> low-hanging-fruit :)
21:55:53 <AndyU> the tastiest
21:56:05 <leong> #info to be changed: readme.rst: "The rendered user stories are available in OpenStack User Stories."
21:56:19 <leong> great work team!
21:56:33 <leong> #topic Open
21:56:37 * shamail sneaks out… has another meeting in 4 min
21:56:41 <leong> 4 mins left for opens :)
21:56:44 <AndyU> just need to update the file in general; minor stuff
21:57:15 <leong> btw, i will be submitting a presentation to OpenStack Days China to talk about Product WG, in mandarin
21:57:32 <leong> #info OpenStack Days China (July 24-25, Beijing) : http://openstackdaychina.org/
21:57:38 <MeganR> long: that's fantastic!
21:57:43 <AndyU> I want the youtube link when you're done
21:57:50 <leong> i hope that can draw more membership/participants from other regional countries
21:57:55 <AndyU> Awesome  :-)
21:58:33 <leong> anyone any open?
21:59:19 <leong> looks like we are good?
21:59:26 <AndyU> +1
21:59:48 <leong> thank you all!
21:59:57 <MeganR> thank you!
22:00:07 <leong> #endmeeting