21:00:40 <leong> #startmeeting product_working_group
21:00:40 <openstack> Meeting started Mon May  1 21:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:43 <openstack> The meeting name has been set to 'product_working_group'
21:00:48 <leong> #chair shamail
21:00:49 <openstack> Current chairs: leong shamail
21:01:01 <leong> #topic rollcall
21:01:15 <shamail> Hi! I'm going to be mostly quiet since in transit but Siri can speak for me from time to time
21:01:18 <leong> hello ..anyone here for PWG meeting?
21:01:30 <leong> hi Siri :-)
21:01:30 <heidijoy> o/
21:01:40 <MeganR> o/
21:01:42 <leong> hello heidijoy
21:01:42 <rockyg> o/ brb
21:01:43 <shamail> lol
21:01:55 <leong> hello meganr, rockgy
21:02:14 <leong> let's wait for 2 minutes for other folks to join in...
21:02:25 <shamail> Ok
21:02:58 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:03:11 * leong waiting 2 mins for other folks to join in...
21:03:41 <leong> today agenda can be found in the above link...
21:03:55 <AndyU> Hi All o/
21:04:02 <leong> hi andyu
21:04:38 <leong> looks like we have the quorum to kick start...
21:04:41 <AndyU> Hi Leong
21:04:41 <GeraldK> o/
21:04:57 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:05:11 <leong> let's get going..
21:05:24 <leong> #topic Boston Summit/Forum planning review
21:05:48 <leong> i want to make sure that the team is ready for summit/forum
21:06:23 <leong> anyone still need help?
21:06:56 <leong> I have email the UC/operators/dev maillist about the pre-forum preparation, which includes the etherpad template and ##hashtag
21:06:59 <AndyU> I have something... who's responsible for building this page? us?
21:07:02 <shamail> I'm good, thanks for asking.
21:07:21 <AndyU> #link  https://wiki.openstack.org/wiki/Forum/Boston2017
21:07:22 <leong> andyu: which page?
21:07:45 <leong> i assume each session's moderator is asked to add the link
21:07:46 <rockyg> AndyU, yup.  Remove the directions on the etherpad and put in your session's information/questions/whetever, then let the community also add stuff
21:07:47 <AndyU> There's A LOT missing
21:08:06 <rockyg> We're all procrastinators
21:08:21 <shamail> Yes, each moderator is supposed to add the link
21:08:30 <leong> we probably can remind Forum Planning committee to send the email again as a reminder?
21:08:43 <AndyU> There are a lot of people who don't know what to do
21:08:53 <leong> just for information here in case you need the link..
21:08:56 <leong> #link Moderator Template: https://etherpad.openstack.org/p/BOS-forum-moderator-template
21:08:59 <rockyg> good idea.  Also, might want to include quick instructions for logging into the wiki and editing it
21:09:02 <leong> #link Hashtag Definition: https://etherpad.openstack.org/p/BOS-forum-hashtag-definition
21:09:19 <leong> #link Bostom Forum Session Etherpad: https://wiki.openstack.org/wiki/Forum/Boston2017
21:09:39 <leong> shamail: since you are in the forum planning committee, do you want to do that?
21:09:53 <leong> shamail: --> remind Forum Planning committee to send the email again as a reminde
21:09:53 <AndyU> +1 RockyG
21:10:33 <shamail> Sure, I can do that. I was going to remind people when I send a note to the moderators
21:11:16 <leong> #action shamail, as a Forum Planning committee will send reminder email to moderators to include etherpad links at the wiki page.
21:11:21 <AndyU> As a moderator I don't recall getting anything telling me to add my session and etherpad link to that wiki page. But doesn't mean I didn't get one...
21:11:41 <leong> andyu: there was an email sent out
21:11:58 <shamail> Tom sent an email to the mailing list, not individual moderators.
21:12:13 <AndyU> Direct or via mail lists?
21:12:21 <rockyg> mail lists
21:12:22 <shamail> MLs
21:13:14 <AndyU> Ah... yep. There are many "Users" jumping in now who are not plugged into those mail lists and other "community insider" type things
21:14:02 <leong> i believe, majority of the moderators are aware....
21:14:24 <shamail> leong: +1
21:15:37 <leong> with regards to the Forum and ##hashtag, i would like to ask all PWG members (especially those attending any session), to actively using (and advising people) the ##hashtag
21:16:12 <shamail> We wouldn't even after have their email addresses he didn't post to mailList since we didn't collect email addresses in the form
21:16:13 <leong> this is the first time PWG driving this effort at Boston Forum, so the ##hashtag method is pretty new
21:16:30 <shamail> Blah :)
21:16:48 <AndyU> I'm sure the majority are, but still some are not. maybe more that we realize. I think a direct email would be good. Covering at least: basic logistics, creating etherpads and posting to the wiki page, the hashtags, maybe some moderator tips
21:17:14 <shamail> Didn't collect email addresses
21:17:53 <AndyU> Shamail - Ahhh... lesson for next time  ;-)
21:17:56 <leong> in the normal practice in the past, usually the "moderator" will take the initiative..:-)
21:18:08 <shamail> 🙂
21:18:33 <leong> i think the action item to remind moderator should be fine.. let's move on next topic :-)
21:19:27 <leong> just want to emphasis this again :) --> with regards to the Forum and ##hashtag, i would like to ask all PWG members (especially those attending any session), to actively using (and advising people) the ##hashtag
21:19:52 <AndyU> I added some sessions to the wiki/Forum/Boston2017 page fixed some formatting, and filled in some missing bits
21:20:00 <GeraldK> leong: got it
21:20:04 <AndyU> Leong - understood
21:20:35 <leong> also want to make sure all aware the BoF and Working Session date/time
21:20:40 <heidijoy> Just adding a note about the ##hashtag use on each etherpad will help people remember. We can all do that (add reminders in the etherpad during sessions)
21:20:50 <leong> #link PWG BoF: https://www.openstack.org/summit/boston-2017/summit-schedule/events/17633/product-work-group-what-is-that
21:21:06 <leong> #info PWG BoF: Wednesday, May 10, 5:20pm-6:00pm, Hynes Convention Center - Level 2 - MR 202
21:21:17 <leong> #link PWG Working Session: https://www.openstack.org/summit/boston-2017/summit-schedule/events/17637/product-working-group-working-session
21:21:31 <leong> #info PWG Working Session: Wednesday, May 10, 2:40pm-3:20pm, Hynes Convention Center - Level 2 - MR 201
21:21:52 <leong> heidijoy: yes.. i did included a note on the etherpad template
21:21:53 <AndyU> #link PWG Development Proposal Process  https://www.openstack.org/summit/boston-2017/summit-schedule/events/18773/usersoperators-contributing-multi-project-requirements
21:22:17 <heidijoy> I saw that, just thinking adding it "in the moment" will help
21:22:30 <leong> heidijoy: +1
21:22:51 <AndyU> #link PWG Development Proposal Process etherpad  https://etherpad.openstack.org/p/BOS-forum-contributing-multi-project-requirements
21:23:08 <leong> #info PWG Development Proposal Process: Thursday, May 11, 9:00am-9:40am, Hynes Convention Center - Plaza Level - MR 104
21:23:14 <leong> andyu: thanks for the link :-)
21:23:16 <AndyU> I just want to remind everyone of the dev proposal forum session
21:23:48 <leong> and also the "Roadmap" session
21:24:02 <AndyU> and encourage all to join and/or get into the etherpad.  I confess I haven't yet.  Thanks to Leong for getting it started.
21:24:23 <leong> #link Community Generated Roadmap: https://www.openstack.org/summit/boston-2017/summit-schedule/events/17775/whats-going-on-in-openstack-learn-about-the-community-generated-roadmap
21:24:39 <leong> #info Community Generated Roadmap: Tuesday, May 9, 2:50pm-3:30pm, Hynes Convention Center - Level 3 - MR 311
21:25:18 <leong> #link Evolving Roadmap (Forum): https://www.openstack.org/summit/boston-2017/summit-schedule/events/18744/evolving-the-community-generated-roadmap
21:25:32 <leong> #info Evolving Roadmap (Forum): Monday, May 8, 2:00pm-2:40pm, Hynes Convention Center - Plaza Level - MR 104
21:25:32 <AndyU> heidijoy - looking forward to the roadmap and survey sessions
21:25:44 <heidijoy> :-)
21:25:50 <leong> any PWG-driving session that i missed out?
21:26:16 <AndyU> I'd like to help with those efforts next chance
21:27:05 <leong> heidijoy: since you are here. do you want to update anything on the roadmap?
21:27:06 <heidijoy> The purpose of the "Evolving the Roadmap" session at the Forum is to talk about what's going well and what could we do differently wrt the roadmap collection, content and expression of it. The Roadmap presentation to the community goes through the data we collected this cycle and various visualizations of it.
21:27:17 <leong> #topic Roadmap Update
21:27:34 <heidijoy> We have 24 projects reporting (~6 more than ever before) including all projects with 50% or greater adoption (9 projects) and 8 projects with >25% adoption, and 7 whose adoption isn’t tracked on the User Survey yet.   This is by far the best (and most digestible) roadmap we’ve produced. It gives us deep info for the Pike marketing release well in advance. It also looks at:
21:27:48 <heidijoy> Individual projects - top 3 features/enhancements coming in Pike Top 10 features/enhancements for Pike (from all projects’ input) Individual projects- 80% of them shared 1 or more likely Queens features Development themes - we move from yes/no answers to “is resiliency a focus?” to answers with “major focus,” “minor focus,” “not a focus,” and “n/a or no info” to give a sharper sense of where deve
21:27:59 <heidijoy> prevalent in each cycle, and a collapsed view of the next 3 cycles Which projects are focused on each development theme
21:28:32 <heidijoy> This is a key chart to pay attention to, and you can use it to cite when media/analysts are asking about NPS user dissatisfaction, in pointing out that the top 3 issues users identified are also getting the most attention from our developers over the coming three cycles: https://www.dropbox.com/s/ovjjy5v4zxn6wvq/Major%20Dev%20Forecast.png?dl=0
21:28:36 <AndyU> We moved the LCOO wg meeting to be right before or after(?) the PWG meeting. It would be great if lots of pwg folks could join the lcoo meeting. It would be great to make introductions and have discussion about opportunities to collaborate
21:29:14 <AndyU> oops... missed the topic change
21:29:42 <heidijoy> Can I answer any questions on the roadmap?
21:29:45 <leong> #andyu: LCOO working session is after PWG
21:29:53 <leong> all: any question on roadmap?
21:30:31 <heidijoy> I'm very happy with the strong response rate we got back. And the new visualizations should be interesting for the community.
21:30:50 <leong> heidijoy: that's awesome... :)
21:30:58 <shamail> +1
21:31:12 <leong> shamail: do you have anything to add for the Roadmap Updat?
21:31:21 <GeraldK> heidijoy: on the chart shared: shouldn't it show % instead of absolute numbers as the sum of major areas is not the same per release?
21:31:22 <heidijoy> A question I've received is whether the chart I posted the link to above suggests that our projects are NOT interested in security.
21:31:45 <AndyU> Can we get a sneak peak?
21:31:58 <heidijoy> I showed the absolute numbers to indicate how many projects responded to each.
21:31:59 <shamail> Nope,   Good from me
21:32:32 <heidijoy> andyu I think we'll have a sneak peek in a couple of days. Working on assembling the individual project features content now.
21:32:49 <AndyU> ok, thx
21:33:05 <leong> i think the chart shows that: how many projects is taking X as a major focus in release Y
21:33:27 <GeraldK> heidijoy: we could show the total number of responses in the bottom, e.g. Pike (56 votes), Queens (... votes), ...
21:33:34 <heidijoy> Something the roadmap doesn't do this round, which we discussed in our Milan meeting, was incorporating user requests to guide dev. We're just not asking for that/ showing that yet.
21:34:25 <leong> +1 to 'incorporating user requests to guide dev' to improve future roadmap
21:34:26 <heidijoy> The total number of responses is 24 (total projects reporting). These aren't so much "votes" as they are the number of projects reporting that X theme is a "major focus" area for them in X cycle.
21:34:28 <shamail> I think we have to have the forum session 1st to get there
21:34:47 <leong> shamail: +1
21:34:51 <heidijoy> We do have context building in the beginning of our presentation to help further explain the visualization GeraldK
21:35:05 <heidijoy> shamail +1
21:35:46 <leong> are we all good on the Roadmap topic?
21:35:56 <pchadwick> @heidijoy - In the last roadmap session, we talked about what was in the current release as well as futures is that the plan this time?
21:35:57 <heidijoy> I'm done with my update
21:36:11 * pchadwick comes late to the party.
21:36:17 <heidijoy> Yes, we're going to show Pike, Queens and Rocky in this presentation
21:36:17 <leong> i would encourage all to attend the "evolving roadmap" forum session if you are interested to help with Roadmap :)
21:36:37 <pchadwick> I meant Ocata ;)
21:36:57 <AndyU> Our "Rocky"?  :)
21:37:21 <rocky_g> Hi, guys!.  Nope.  The R release got named Rocky
21:37:23 * leong Rockyg will be famous in two more releases...
21:37:24 <pchadwick> In Barcelona, we listed what the key features were in Newton as well as futures in Ocata and Pike
21:37:47 <rocky_g> There might have been a few votes because people knew me, but....
21:37:56 <AndyU> @RockyG - congrats... quite an honor  ;)
21:38:27 <rocky_g> Thanks!  Let's make this a Quality in operations focused release!
21:38:29 <heidijoy> In this roadmap cycle we asked projects about PQR not OPQ since Ocata has already been released.
21:38:36 <AndyU> Can't wait for the Shamail release
21:38:49 <heidijoy> AndyU +1,000,000
21:38:53 <pchadwick> Darn, I missed my chance.
21:39:16 <leong> i will try to challenge S release to "sun".. my last name.. lol
21:39:26 <AndyU> haha
21:39:33 <leong> ok.. let's get back to business...
21:39:54 <pchadwick> @heidijoy - OK
21:40:05 <shamail> I think with the New release cadence it doesn't make sense to include a release that came out two months prior. The new road map shows what is in flight and what's coming
21:40:05 <leong> cool
21:40:18 <shamail> Lol AndyU
21:40:48 <leong> shamail: +1 roadmap shows in progress and future
21:40:50 <pchadwick> @shamail - yes, I just figured that out.
21:41:19 <leong> next topic ...
21:41:27 <leong> #topic Post-forum Report
21:41:59 <leong> shall we discuss what sort of data we would like to collect from Forum etherpad (by using the ##hashtag)
21:42:35 <leong> btw, thanks AndyU for a quick tip that allow me to "export" etherpad into text format in a very "super easy" way...
21:43:02 <AndyU> How about we discuss what our role/objectives are for all that forum data
21:43:51 <leong> andyu: +1
21:43:56 <leong> anyone any suggestion?
21:44:42 <GeraldK> find out about new user stories or user story priorities
21:45:11 <AndyU> For ex, look for important items that do not appear to have an "owner" and seek to get them one?  Look for themes that would have broad impact and produce Development Proposals / solicit for owners of a Dev Proposal?
21:45:38 <shamail> Provide a consolidated summary of the events using the data for those who weren't able to attend or join all session
21:45:38 <rocky_g> get dev commitments for specs for high priority gaps -- if we can.  Even one would be a start on learning how to make it happen
21:46:01 <AndyU> We could make sure info tagged for a wg or a project is shared with them
21:46:14 <leong> summarize tangible action items and priority that help dev to build features/solve problems for operators
21:46:24 <shamail> rocky_g: +1
21:46:28 <AndyU> Consolidated Summary +1
21:46:34 <rocky_g> shamail, if you can attend/join all sessions, I will worship you as a modern day god
21:46:59 <shamail> Lol
21:47:12 <leong> andyu: +1  info tagged for a wg or a project is shared with them
21:47:45 <AndyU> +1 identifying priority gaps for follow-up
21:49:18 <AndyU> Hmmm... could we align the forum results to Roadmap and/or user Survey contents, themes, etc?
21:50:18 <AndyU> It feels like Forum, Survey, Roadmap should all flow together
21:50:41 <leong> the forum results would probably help project teams to align with user needs, which eventually will drive the roadmap items..
21:51:11 <heidijoy> leong + 1
21:51:26 <AndyU> right. they all play a role in the same overall objective of injecting user needs/priorities
21:51:58 <leong> ok.. let me summarize a few key points based on the above inputs
21:52:10 <leong> #info Post-Forum Report: Consolidated Summary
21:52:28 <leong> #info Post-Forum Report: info tagged for a wg or a project is shared with respective team
21:52:38 <shamail> Let's make sure we don't bite off more than we can chew because this is the first time we will be doing this. Showing value going to be important
21:53:01 <leong> #info Post-Forum Report: Prioritize features that align with user needs
21:53:35 <leong> i think these 3 points is more than enough for us ...
21:54:13 <leong> second item should be easy to generate using the small python program that i have
21:54:20 <shamail> +1
21:54:21 <AndyU> priority gaps in need of ownership (at risk of not getting any follow-up)
21:54:33 <leong> third item might need some analysis
21:55:11 <leong> let's keep that as our Report objectives first, if anyone has suggestion, we can discuss over email
21:55:17 <leong> last 5 minutess.. open
21:55:19 <leong> #topic Open
21:55:37 <leong> I have one quick open item which brought up by Anni lai
21:55:46 <leong> do we want to present a report to Board Meeting at Boston?
21:55:47 <AndyU> I think doing a retrospective on the Forum would be beneficial as well
21:56:29 <rocky_g> Yeah, AndyU cand do that before the summit/forum, though.
21:57:04 <leong> to update the Board and get engagement from TC/UC/Board for Development Proposal
21:57:06 <AndyU> right. I meant the retrospective comment for part of the post-forum analysis
21:57:18 <rocky_g> I'd like to figure out a proposal based on what we've been discussing of how we work with TC to get developers involved once the priority gaps have been identified.  Like asking them to drive some cross project meetings or something
21:58:00 <rocky_g> We could use their help as facilitators to get the gap(s) turned into specs.
21:58:19 <leong> rock_g: i assume that would be in the "gap analysis" phase?
21:58:31 <leong> getting TC to faciliate "gap analysis"?
21:58:43 <rocky_g> Again, one would take us a long way in the learning process.  If we can get a commitment for them to stick with trying to get one turned into a spec, we all win
21:59:13 <AndyU> Do we have any alignment with this? https://www.openstack.org/summit/boston-2017/summit-schedule/events/17585/the-openstack-technical-committee-vision-for-2019-updates-stories-and-q-and-a
21:59:19 <rocky_g> leong, no, not the gap analysis, but once we know the gap, getting them to create a spec for the work needing to be done to fill the gap
21:59:20 <leong> let's push that the email discussion, then we will decide if we need an agenda item in the Board meeting
21:59:43 <shamail> FYI: I asked for a session (and it's been accepted) for the Kubernetes SIG-PM group to meet and I proposed that the OpenStack PWG come to the session as well so we can discuss open-source Product Management (find out what works for them, us, etc.). The session isn't on the schedule yet but will be on Monday at 5:30P, I'll send an email to the ML once it's posted.
21:59:59 <leong> shamail: +1
22:00:17 <pchadwick> shamail: +1
22:00:37 <leong> cool.. let's wrap up the meeting here
22:00:50 <leong> see u all at Boston (for those attending)
22:00:53 <leong> and safe travel...
22:00:57 <pchadwick> bye
22:00:57 <shamail> Cya
22:00:58 <leong> #endmeeting