21:00:29 <leong> #startmeeting product_working_group
21:00:30 <openstack> Meeting started Mon May 22 21:00:29 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:34 <openstack> The meeting name has been set to 'product_working_group'
21:00:47 <leong> #chair shamail
21:00:48 <openstack> Current chairs: leong shamail
21:01:04 <leong> #topic Rollcall
21:01:14 <leong> hi welcome to PWG meeting :)
21:01:33 <leong> roll calling....
21:01:35 <rockyg> o/
21:01:41 <MeganR> o/
21:01:44 <shamail> Hi everyone
21:02:13 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:02:13 <jamemcc> Hi
21:02:21 <leong> today agenda can be found at the above link
21:02:43 <leong> before we start.. anybody has any agenda item to add?
21:03:49 <leong> let's get going...
21:03:55 <leong> #topic Boston Forum/Summit Recap
21:04:25 <leong> i set this topic so that the team can do a quick recap from Boston Forum/Summit
21:04:33 <jamemcc> On March 14 we were going to talk about Feature Tracker status - not sure if we have the right people - but if so - lets cover that
21:05:10 <leong> jamemcc? March 14?
21:05:45 <jamemcc> At our agenda link - just scroll down to "CANCELLED March 14th..."
21:06:08 <leong> jamemcc: that was the regional meeting
21:06:46 <leong> i recalled that was about writing the feature tracker json for baremetal user story
21:07:23 <jamemcc> OK, if not appropriate but I think there seems to be a lot of confusion on why the various Feature Tracker stories are not implemented and wanted to get status or issue out on that.
21:09:01 <leong> on the Summit/Forum, anyone has any feedback?
21:09:02 <rockyg> Actually, good point.  I think we need to list the barriers for each of the features.  I think that would help in figuring out what is blocking them.
21:09:04 <shamail> I think the forum went well and we had a good mix of participants in each session. Lots of dialogue on how to more closely collaborate between users and developers. On the flipside, there were a lot of team including this one that saw a decline in active contributors.
21:09:07 <jamemcc> I think we dont' ahve the right people - I'll try to start in mail
21:09:32 <rockyg> Thanks, jamemcc
21:09:54 <rockyg> Yes,  this group seems to be losing participants quickly.
21:10:29 <shamail> Jamemcc: Adam wants to create a tracker for HA VMs. I'll forward his email to us again.
21:11:13 <leong> how should we deal with the decline in PWG active contributors?
21:11:19 <shamail> rockyg: yes, even BoF only had like 8 people
21:11:32 <rockyg> I think it might be because the roadmap is running smoothly, mostly and the user stories are not moving well.  So, the view is the PWG is not getting stuff done because people don't attribute the roadmp to us any more.
21:11:53 <leong> we have tried presented the challenges to Board, and also seek support from Board companies
21:12:09 <shamail> rockyg: +1
21:12:33 <leong> rockyg: +1
21:13:06 <rockyg> I have an idea, but first I have to present it to myh management and see if they will give me the time to do it.  I am going to ask them to put me 80% on PWG only for a cycle.
21:13:06 <leong> it seems to be lots of challenges in "gettting stuff done"
21:13:07 <shamail> I don't know how to solve this but we either need new members or a change in scope
21:13:55 <rockyg> I think we had the manpower/time to get the roadmap rolling and now it takes less.  We need to do the same to jumpstart the development proposals
21:14:21 <leong> Anni and I are going to have a talk at OpenStack China Day about Product WG, that "might" help to get some new members...
21:14:51 <leong> from the Dev Proposals, we need to collaborate with other WG such as LCOO, Scientific, Public Cloud
21:14:52 <rockyg> That's why I'm asking for 80% time.  So I can do some of that research/chasing bits/etc to get some of the features to something acceptable to devs.
21:14:53 <shamail> There were a lot of great action items for us coming out of the summit like making the roadmap bidirectional, helping teams prioritize
21:15:03 <leong> we should get resoures/help from those WG
21:15:29 <rockyg> leong, ++ but I think they are mostly in the same boat as us.
21:16:06 <leong> i think we need to shift from a focus to "driving user story" to "providing a platform for WG so that WG themselves can drive the user story"
21:17:00 <leong> also alignment with the UC "unanswered requirements"
21:17:07 <shamail> We also discussed helping newer companies to OpenStack find the big rocks to work on
21:17:27 <shamail> leong:+1
21:18:05 <rockyg> ++
21:18:42 <leong> so maybe the next action item for PWG can focus more around "collaborating with various WG based on the same PWG dev proposal platform"?
21:19:40 <jamemcc> Agreed with "platform for the WG to drive their own user stories"  but I also think that most - LCOO certainly may struggle to find the right ways to get together with the project tems and that Rocky's suggestion seems helpful.
21:20:22 <shamail> Platform would include our team helping make the right connections at the project level
21:20:32 <jamemcc> Great
21:20:32 <leong> shamail: +1
21:21:30 <shamail> We would help with properly documenting ideas, getting a structured workflow, and integration into development workflow
21:21:33 <leong> will be great if we can get the right people both from the project team and working groups to discuss on the Dev Proposal
21:21:44 <leong> shamail: +1
21:22:42 <leong> would that change our overall mission statement or goal?
21:23:17 <jamemcc> I have to admit I hadnt' thought to invite PWG to the Development proposal discussions - Can and will do that
21:23:43 <shamail> I think it does slightly, we would no longer represent the needs of the users ourselves but help teams that do get their voices heard
21:24:18 <AndyU_> Hi all. Sorry I'm late
21:24:23 <jamemcc> FYI - possibly one on the LCOO Containerized OpenStack management on Wednesday.
21:24:45 <shamail> Thanks jamemcc
21:25:19 <leong> other than LCOO, that are also work that we can work with Public Cloud and Scientific WG
21:26:04 <jamemcc> #link https://review.openstack.org/#/c/445386/
21:26:05 <leong> and interestingly that some features discussed in various WG can potentially the same with commonatilities
21:26:27 <leong> that can help "project team" to prioritize works that fit mulitple WG
21:26:56 <AndyU_> Ok, I think I'm getting caught up skimming the above.
21:27:27 <AndyU_> I think PWG can play a key role as an enabler of Dev proposals and similar efforts in general.
21:28:17 <AndyU_> Certainly one is to be actively engaged in the Dev Proposal process as enablers, SME's , etc., like we already have discussed.
21:28:34 * leong looks like shamail was kicked out and rejoin :)
21:28:54 <shamail> :)
21:29:20 <AndyU_> But something that was a PWG muission initially (I heard at Summit) but not happening is very needed. More than 70% of all commits for Ocata were made by the 12 top contributing companies.
21:30:46 <leong> i think the very initial mission for PWG is to get involvement from Vendor Product Managers, but that was not happening over the past year
21:30:46 <shamail> We had that, we lost it because we could not deliver on user stories
21:31:18 <shamail> We should've gotten both product managers and engineering managers so decisions could be made
21:31:25 <AndyU_> All the working groups had a common there woven across about the problem of "unanswered requirements". The PWG can facilitate discussions with the big contributors to align around gap analysis, implementation plans for delivery
21:31:32 <leong> however, i do think that we did deliver one user story which is the baremetal :)
21:31:56 <shamail> Rolling upgrades too
21:32:27 <AndyU_> I don't think that the Product Managers fro Red Hat, Mirantis, etc. need to be PWG Members for the PWG to coordinate periodic meetings with them.
21:32:32 <leong> Rolling upgrade can be debatable because it was exist/already-dicussed prior to PWG user story
21:32:49 <shamail> True
21:33:05 <shamail> AndyU_: +1
21:33:07 <Arkady_Kanevsky> Hello Product WG
21:33:25 <leong> anyway, instead of sticking to initial mission that aim for Product Managers from vendors, i think we need to move forward with "who we have today"
21:33:34 <AndyU_> What's needed is to bring the right people together around the right issues and only perhaps a couple tuimes during each cycle (we'd have to figure that out).
21:34:58 <shamail> Leong: Who we have/who we need
21:35:00 <AndyU_> Askingall those Product Managers to be PWG members is too much. But asking them to join periodic coordination meetings hosted by the PWG is not. And it would be very valuable.
21:35:37 <rockyg> AndyU_, ++
21:35:41 <shamail> Andyu_:agree, great idea 
21:36:19 <leong> Andyu_: +1 coordination meetings
21:36:43 <AndyU_> Basically coordinating that connection between the work being done in working groups/teams (Sigs?) and Key development players like Product Managers for big contribs and Key leaders in impacted dev teams
21:36:51 <shamail> So leong how is that for your forum recap?
21:37:08 <leong> let's wrap up this agenda topic
21:37:20 <leong> #info PWG value: properly documenting ideas, getting a structured workflow, and integration into development workflow
21:37:28 <AndyU_> That would be invaluable because it's needed, no one is doing it and the PWG has all the legitimacy to do it where perhaps no other group does?
21:37:42 <AndyU_> Leong +11  :)
21:37:45 <mrhillsman> sorry so late, i'm here
21:37:56 <leong> #info PWG value: Periodic coordination meeting across WGs/Product Managers
21:38:07 <AndyU_> Yes.
21:38:25 <leong> those are the two key items i can summarized from our discussion
21:38:32 <shamail> It's OK mrhillsman , you just missed the fun part of the meeting
21:38:50 <AndyU_> PWG could also host/coordinate periodic syncs BETWEEN working groups as well. The need for that came out of the Forum session about avoiding wg redundancy
21:39:04 <leong> AndyU_: +1
21:39:26 <leong> #info PWG value: coordinate/collaborate between WGs
21:39:45 <Arkady_Kanevsky> other WG within user WG?
21:40:07 <leong> WG can be within either UC or TC
21:40:30 <AndyU_> We could analize what's being worked on, proposed, etc and help to get the right people connected, help the working parties to be focused (advise on strategy) and in alignment with other stakeholders
21:40:33 <leong> one of the key action is to get those WG aware about PWG workflow and value
21:40:50 <AndyU_> Leong, I agree. Doesn't matter where wg falls in UC vs TC
21:41:09 <AndyU_> +1 to Dev Proposal workflow awareness
21:41:35 <Arkady_Kanevsky> I think we should bring characterization of stories for UC WG to them.
21:41:48 <AndyU_> In the Forum session about the Dev proposal process, it turned oyut no one but Leong and I had ever even heard of it ;)
21:41:59 <leong> ok.. let's think of some action plan for the 3 value mention earlier
21:42:14 <Arkady_Kanevsky> As well as show that reqs we got from forum are perculating to stories
21:42:32 <leong> i will summary and email to ML to get inputs
21:42:53 <leong> let's move on to the next agenda topic
21:43:07 <leong> #topic Post-forum Report
21:43:46 <leong> i have run the hashtag program and generated the result, and submit a patch to upload those result to PWG repo
21:44:03 <leong> #link Hashtag results: https://review.openstack.org/#/c/466401/
21:44:08 <AndyU_> Here's another (maybe you discussed it already). What about the PWG creating Dev proposals ourselves if we know of a key need not being addressed and take on actually CREATING (or trying :) ) a wg to carry it forward?
21:44:15 <shamail> Thanks for doing it leong
21:44:24 <leong> shamail: thanks for the +2
21:45:01 <leong> AndyU_: let's push that discussion to ML
21:45:06 <AndyU_> I still need to read it. Anything jumping out?
21:45:09 <AndyU_> got it
21:45:21 <mrhillsman> i think one of the key things missing is maybe what rockyg was mentioning earlier; getting those who have developers to buy-in to the "process"
21:46:21 <leong> given the hashtag result is ready, what and how do we want to deal with those data
21:46:23 <AndyU_> Does it seem they were pretty well used or not so much?
21:46:55 <rockyg> I looked over some of the results.  Interesting.  It also might be worthwhile to get the PTLs to add hashtags where they think they might be useful when they review their forum sessions to summarize on the mailing list.
21:47:09 <shamail> leong: can you reply to John G's email aboutibg
21:47:22 <rockyg> And maybe put a link to the mailing list thread in the etherpad?
21:47:23 <AndyU_> It almost seems like we'd have to look at Leong's data along side skimming the actual etherpads to get a sense for how well it's working and where we need to tune
21:47:25 <shamail> Plans to email moderators
21:47:39 <leong> shamail: yes i will reply to John G
21:47:57 <leong> #action Leong to reply JohnG email on hashtag result
21:48:16 <mrhillsman> a lot of the summaries are being only sent to openstack-dev
21:48:32 <mrhillsman> i forwarded quite a few to openstack-operators but pretty sure i missed some
21:48:45 <leong> i think it is critically important to have the summaries sent to both dev + uc
21:49:13 <mrhillsman> we should have a tag [bos-forum-summary] or something too no?
21:49:17 <shamail> Thanks... we should analyze hash tags and also ask them what they think was the summary from their sessionand encourage them to email the mailing list
21:49:19 <leong> one thing missing from the ##hashtag is project
21:49:58 <AndyU_> did we miss that? Darn.
21:50:05 <shamail> Couldn't that be derived from the either pad name?
21:50:09 <leong> i only see "nova" and "ironic" called out from the discussion
21:50:45 <leong> mrhillsman: what do you mean tag [bos-forum-summary]?
21:50:51 <rockyg> This is the first use.  So, let's go easy.  We can get better over iterations.
21:50:55 <AndyU_> We should have had ##project with some examples in our template. Will need to add it for next time if we left it out.
21:51:00 <leong> rockgy: +1
21:51:15 <mrhillsman> leong: email summaries to multiple mailing lists
21:51:17 <leong> ##project is included in the examples
21:51:26 <rockyg> Another useful iteration would be to setup all the etherpads for all the sessions ahead of time so that naming is consistent and each has the template
21:51:31 <AndyU_> oh... well :)
21:51:35 <mrhillsman> right now i have a number of summaries that are crowded in with other emails, suggesting a tag
21:51:53 <rockyg> mrhillsman, ++
21:52:34 <shamail> mrhillsman: +1, maybe [Forum Summary]
21:52:42 <mrhillsman> works :)
21:52:43 <AndyU_> Rocky +1 to creating etherpads in advance. I'd also add that we should build the wiki page referencing them too.  but maybe just alphabetize them rather than including day/time since that changed a lot.
21:53:25 <leong> I believe we can continue to propose using ##hashtag in next forum, or maybe PTG prior to forum
21:53:30 <mrhillsman> how about a video on moderating a session at the forum?
21:53:34 <AndyU_> +1 mrhillsmann
21:54:18 <leong> can i suggest everyone in this team to look at the ##hashtag results and provide feedback in the ML or in next PWG meeting?
21:54:23 <rockyg> There is actually a video created a while back.
21:54:24 <mrhillsman> i wonder how useful/beneficial/cumbersome hashtag will be for PTG?
21:54:34 <mrhillsman> rockyg: have link?
21:54:41 <rockyg> I can find it.
21:54:41 <mrhillsman> would love to check it out
21:54:48 <AndyU_> +1 mrhillsmann to both the summaries and video or some method of providing guidance on moderating.
21:55:18 <leong> mrhillsman: can you take the action and follow up on the summaries and video/method?
21:55:24 <mrhillsman> sure
21:55:28 <leong> thanks!
21:55:54 <shamail> I gotta go
21:55:55 <leong> #action mrhillsman to follow up on the summaries and video/method of providing guidance on moderating
21:56:00 <shamail> Take care everyone!
21:56:06 <mrhillsman> l8r
21:56:44 <leong> the hashtag result is merged to the repo now
21:56:47 <leong> #action all to review the ##hashtag result at https://github.com/openstack/development-proposals/tree/master/forum/201705-bos
21:57:13 <AndyU_> to the earlier point. ##hashtag should be promoted for PTG too. The more the concept can be institutionalized the more effective it will become
21:57:36 <AndyU_> Meaning... I agree with mrhillsman
21:57:45 <leong> agree
21:58:36 <mrhillsman> does it make sense to comment in github leong?
21:58:37 <leong> mrhillsman: i think it would be great to try out ##hashtag at PTG and also get feedback from Project Team
21:59:21 <mrhillsman> agreed
21:59:24 <leong> mrhillsman: that's the one "hosted" place that i can think of to share the result in ".md" with hyperlink
21:59:26 <leong> :)
22:00:02 <mrhillsman> i'm ok with leaving github comments :)
22:00:11 <leong> mrhillsman: it is 'tentatively' and we can move it somewhere if needed... :-)
22:00:25 <mrhillsman> cool
22:00:28 <leong> and yes.. can commet :-)
22:00:36 <leong> alright, i think we hit the hour
22:00:37 <Arkady_Kanevsky> +1
22:00:50 <leong> thanks all for joining the meeting
22:00:55 <leong> we shall meet again next week
22:01:04 <leong> #endmeeting