21:00:15 <leong> #startmeeting product_working_group
21:00:16 <openstack> Meeting started Mon Jun  5 21:00:15 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:19 <openstack> The meeting name has been set to 'product_working_group'
21:00:23 <leong> #chair shamail
21:00:24 <openstack> Current chairs: leong shamail
21:00:28 <leong> hi all
21:00:33 <MeganR> Hi
21:00:35 <leong> #topic rollcall
21:00:48 <AndyU> o/
21:00:50 <Arkady_Kanevsky> hello all
21:00:50 <shamail> hi
21:00:51 <leong> this is PWG meeting :)
21:00:58 <AndyU> hi all
21:00:59 <annabelleB> hello!
21:01:09 <leong> today agenda can be found here:
21:01:15 <MeganR> o/
21:01:15 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:01:43 <leong> if you have anything else not in the agenda, please feel free to shout out :-)
21:02:08 <leong> #topic Review of action items from previous meeting
21:02:38 <leong> #link Previous minutes: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-05-22-21.00.html
21:02:59 <leong> is mrhillsman here?
21:03:33 <leong> I have replied to JohnG email on the hashtag
21:03:51 <leong> didn't see any further diccussion on the thread
21:04:21 <Arkady_Kanevsky> What is the action for review the ##hashtag result?
21:04:21 <leong> have anyone look at the ##hashtag result?
21:04:56 <shamail> I have not yet
21:05:04 <leong> Arkady: that would be on today Agenda item
21:05:17 <Arkady_Kanevsky> me neither. But want to understand what are we looking for?
21:05:33 <Arkady_Kanevsky> Do we want to propose some new stories?
21:05:34 <leong> i have submitted a patch to fix some ##hashtag, can core please review?
21:05:49 <Arkady_Kanevsky> I will take taht AI, Leong.
21:05:55 <MeganR> I have not looked, either
21:06:01 <leong> #link hashtag patch: https://review.openstack.org/#/c/469267/
21:06:08 <jamemcc> Jamey here: I have - I find the ones we put #LCOO to be a really ueseful and quick cross reference to things taht got discussed and we want to carry forward
21:06:09 <AndyU> I haven't read through them either. There's a lot there.
21:06:16 <leong> the patch also included the "python-program"
21:06:29 <leong> anyone can contribute to improve that python-program if needed :)
21:06:31 <mrhillsman> o/
21:06:41 <leong> hi mrhillsman
21:07:05 <leong> mrhillsman: previous meeting action item -> mrhillsman to follow up on the summaries and video/method of providing guidance on moderating
21:07:11 <leong> any updates?
21:07:54 <mrhillsman> I got the video from rockyg that was done
21:08:30 <mrhillsman> I think it with supplemental will suffice, as shooting another video is probably overkill
21:08:55 <leong> ok
21:09:05 <mrhillsman> Wiki page consolidating all the things maybe?
21:09:36 <leong> mrhillsman: Wiki page consolidating all the things? can you elaborate more?
21:10:09 <mrhillsman> Well, we have the video, moderator template, ops meetups moderator guide, FAQs, eyc
21:10:18 <mrhillsman> etc
21:10:47 <leong> are you thiking putting at "PWG" wiki page or "UC" wiki page?
21:11:03 <Arkady_Kanevsky> we do need to update out wiki. https://wiki.openstack.org/wiki/ProductTeam. It is still stuck on Ocata not Pike.
21:11:21 <mrhillsman> Probably standalone anyone cam link to may be best
21:11:30 <leong> not only update, but also "simplifying" :)
21:11:57 <shamail> standalone makes sense
21:12:06 <AndyU> agree w /mrhillsman about standalone
21:12:10 <shamail> and linked to from the Forum and Ops Meetup pages
21:12:15 <leong> anyone interested to contribute to updating/simplifying the PWG wiki? including the video, moderator template, ops meetups moderator guide, FAQs?
21:12:33 <AndyU> I am o/
21:12:41 <shamail> Why are the moderator templates, ops meetups moderator, etc in PWG?
21:12:51 <mrhillsman> leong I dont...^
21:12:55 <shamail> (sorry if this has been covered already)
21:12:57 <leong> shamail: that's my original question :)
21:13:16 <shamail> Ah ok
21:13:25 <leong> [14:10] <leong> are you thiking putting at "PWG" wiki page or "UC" wiki page?
21:13:59 <shamail> I think the content related to moderating sessions should be on its own page (not PWG or UC) as mrhillsman suggested. The content can be linked as needed to event pages in that case and anyone could edit it as well.
21:14:00 <leong> i think it makes sense to put in a wiki "outside" PWG, maybe within UC? or a standalone wiki?
21:14:07 <mrhillsman> Right, neither, standalone and others can link to it.
21:14:12 <leong> shamail: +!
21:14:18 <leong> +1
21:14:27 <Arkady_Kanevsky> +1
21:14:28 <AndyU> standalone
21:14:33 <leong> so we have two action item on wiki
21:14:43 <leong> 1. update and simplify PWG wiki
21:14:52 <Arkady_Kanevsky> but how would people find standalone wiki? Do we have master index?
21:14:57 <leong> 2. create a standalone wiki for video, moderator template, ops meetups moderator guide, FAQs
21:15:18 <leong> arkady, with standalone wiki, any other group can reference it
21:15:32 <leong> anyone interest to take on (1) or (2) ?
21:15:36 <AndyU> right. It would be linked to from other pages
21:16:29 * leong the room seems quite....
21:16:32 <leong> anyone interest to take on (1) or (2) ?
21:16:34 <leong> :)
21:16:35 <mrhillsman> we have this - https://wiki.openstack.org/wiki/Operations/Meetups#Moderators_Guide
21:16:39 <Arkady_Kanevsky> I will take 1.
21:16:45 <mrhillsman> i can #2
21:16:52 <Arkady_Kanevsky> Will send proposal to email reflector
21:16:54 <mrhillsman> will start with that
21:16:55 <AndyU> I'm willing to help with 1 or 2
21:17:11 <mrhillsman> add other stuff, email folks to modify/update as necessary
21:17:41 <leong> #action Arkady_Kanevsky and AndyU to work on updating/simplifying PWG wiki
21:18:03 <leong> #action mrhillsman and AndyU to work on standalone wiki page for video, moderator template, ops meetups moderator guide, FAQs
21:18:29 <leong> mrhillsman: +1 on starting from the existing guide
21:18:37 <AndyU> I see that "or" became an "and"  ;)  That's ok.
21:18:44 <leong> haha.. ops
21:18:47 <mrhillsman> hehe
21:19:02 <leong> andyu: up to you to pick one :)
21:19:05 <Arkady_Kanevsky> Thanks for help AndyU
21:19:12 <leong> ok.. let's move on to next topic
21:19:20 <AndyU> I'm happy to help with both.
21:19:24 <leong> #topic Action Plan
21:19:38 <leong> in last meeting, we talked about two PWG value
21:19:43 <leong> #info Value 1: Properly documenting ideas, getting a structured workflow, and integration into development workflow
21:19:50 <leong> #info Value 2: Periodic coordination/collaboration across WGs/Product Managers
21:20:06 <leong> i would like to turn that into some deliverables and action plan
21:20:24 <leong> is there anything that we can do in order to "deliver" both the value?
21:21:16 <Arkady_Kanevsky> Leong are you thinking of some automated process?
21:21:20 * shamail is in two meetings atm, sorry.
21:21:22 <leong> for example: would "updating/simplifying" wiki be an action items to achieve value 1?
21:21:37 <AndyU> For #1, I think that we need to do some marketing of the Dev Proposal flow, purpose, etc to wg's, project teams, etc.
21:21:39 <leong> Arkady_Kanevsky: anything that allow us to achieve the value
21:22:19 <leong> Arkady_Kanevsky: is more about what sort of tactics we should do in order to deliver both value
21:22:24 <Arkady_Kanevsky> do not think so Leong. Do not see how it will simplify the process. We will have a pointer to templated proposals.
21:22:31 <AndyU> I the dev proposal forum session we found that no one there had even heard of it before
21:22:56 <leong> Arkady_Kanevsky: yeah.. u are thinking along the line :)
21:23:15 <leong> so my question would be: what should we do in order to realize the value
21:23:22 <Arkady_Kanevsky> we did change our nomenclature in Milan meeting.
21:23:52 <Arkady_Kanevsky> We can update wiki and send email blast with details on proposal idea flow.
21:24:35 <leong> Arkady_Kanevsky: so we do need to update the wiki first....
21:24:53 <Arkady_Kanevsky> I think so.
21:24:54 <MeganR> are we thinking of meeting with PTLs or with the TC to discuss our "value"
21:24:54 <AndyU> Need to increase awareness of the dev proposal flow and encourage quality participation
21:25:34 <Arkady_Kanevsky> +1 AndyU.
21:25:50 <leong> MeganR: i am thinking how can we get PTLs/core involved as part of the PWG workflow
21:26:00 <AndyU> To MeganR's point, PTL's and TC need to understand and support the dev prop flow
21:26:09 <MeganR> have we asked them directly?
21:26:53 <leong> MeganR: that brought up a good question
21:27:06 <leong> so far PTL/core seems not involved in the process
21:27:32 <leong> apart that from the Baremetal use case, i do reach out to ex PTL and core of Ironic
21:27:34 <AndyU> I only spoke with a few PTL and TC but none knew about the process
21:27:53 <AndyU> at the summit that is
21:28:13 <Arkady_Kanevsky> It is too early whne we get proposal isea submitted till we decompose it and do gap analysis
21:28:32 <rocky_g> hey again.
21:28:39 <MeganR> AndyU: can we follow-up with those you spoke with - I'm thinking that we pick a few to "review" the process, and get their feeback and buy-in
21:28:52 <Arkady_Kanevsky> We can add PTL for specific project to proposal review list.
21:28:54 <leong> Arkady_Kanevsky: +1.. i think PTL/core would only be interested after (or at) the Gap Analysis phase
21:29:00 <shamail> In order for them to support it they have to be aware of it but also it has to have value for them. We have to think about how to show value in “subscribing” to this process.
21:29:11 <shamail> Arkady_Kanevsky: +1
21:29:40 <leong> for baremetal, we completed the gap-analysis
21:29:45 <AndyU> MeganR - we can try
21:29:51 <leong> but not for the rest of development proposals
21:30:08 <Arkady_Kanevsky> Should we add optionally to proposal template expected projects impacted.
21:30:21 <AndyU> +1 Arkady
21:30:32 <Arkady_Kanevsky> With that we will be able to add a core or PTL for these projects for review.
21:30:42 <leong> Arkady_Kanevsky: that was includd in the Gap Analysis (for Baremetal case)
21:31:01 <AndyU> In our forum session, project leads/cores expressed a desire to be aware and plugged in early.
21:31:20 <leong> #link baremetal gap analysis: https://github.com/openstack/development-proposals/blob/master/gap-analysis/proposed/baremetal-service.rst
21:31:21 <Arkady_Kanevsky> We definitely do that for gap analysis. But does it make sense to involve them at proposal review also?
21:31:25 <MeganR> is that too late, adding them for the "review" if they don't know about the process now.  Should we be communicating with the PTL when we first receive a project, and let them know that we are working on it?
21:32:05 <AndyU> I think waiting for Gap Analysis may be too late.
21:32:06 <shamail> MeganR: +1
21:32:19 <shamail> That would allow them to decide how involved they want to be and when
21:32:25 <leong> agree: we should get PTL/core aware as early as possible
21:32:43 <Arkady_Kanevsky> My obejctive is to get PTL input if idea was circulatd before in the team and got feedback that we are not aware of.
21:33:09 <AndyU> But for it to be sooner we need to raise the bar on what qualifies a proposal to move forward. It's too easy to just write up the first part with no real will or ability to drive any farther. Don't wantg to waste peoples time.
21:33:24 <leong> AndyU: +1
21:33:28 <Arkady_Kanevsky> +1 AndyU
21:33:57 <leong> so who shall make the call that a proposal is "qualified/good-enough" to move forward? PWG?
21:34:24 <Arkady_Kanevsky> great quetsoin.
21:34:25 <AndyU> Maybe we meet with proposal owners and ask them questions about how they plan to move it forward, assess if it seems viable
21:34:32 <Arkady_Kanevsky> I think it is PWG now/
21:34:37 <MeganR> Why don't we get it to an approved point with the PWG and then reach out to the PTL for their input
21:34:58 <Arkady_Kanevsky> We do that as part of gap analsyis stage
21:35:12 <MeganR> I was thinking earlier
21:35:34 <leong> so PWG need to take an "active" role to review all proposals
21:35:39 <MeganR> decide what is the "bare minimum" to move it forward and then engage the PTL
21:35:51 <Arkady_Kanevsky> Leong +1
21:36:21 <AndyU> The current Approved/Accepted step perhaps should vbe thought of as approved DRAFT which then moves into a 2nd phase of revision with project stakeholders?
21:36:48 <leong> another question is: would PWG has enough skillset to review the proposal?
21:37:41 <Arkady_Kanevsky> if we do not know if we can pull people from our companies for help
21:38:15 <Arkady_Kanevsky> if we do not have enouhg skills we can pull people fomr our respective companies for help
21:38:48 <leong> ok. so can we take on existing Development Proposals and move forward from there?
21:38:48 <AndyU> I think PWG definitely can determine when it is sufficiently clear and focused. When it is agreed to be addressing a significant need and so forth.
21:39:37 <leong> can we review this list and see which one is ready to move forward?
21:39:46 <leong> #link Existing Proposal: https://github.com/openstack/development-proposals/tree/master/development-proposals/proposed
21:40:11 <leong> #link Proposal working-in-progress: https://review.openstack.org/#/q/project:openstack/development-proposals+status:open
21:41:10 <leong> i mean: can we review this list over the week (not now) and see which one is ready to move forward?
21:41:13 <leong> :)
21:41:31 <Arkady_Kanevsky> we need to review a few of them.
21:41:59 <leong> #action all to review existing+wip proposals and decide which one is ready to move forward with wider participation from PTL/core
21:42:00 <Arkady_Kanevsky> Can use help for reveiw of https://review.openstack.org/444664
21:42:49 <leong> for Value 2: Periodic coordination/collaboration across WGs/Product Managers
21:42:54 <AndyU> We're organizing some support behind the logging proposal and will be breathing new life into that
21:43:00 <Arkady_Kanevsky> Leong do you want everybody to send email on result of review?
21:43:15 <rocky_g> AndyU, ++
21:43:32 <leong> Arkady_Kanevsky: i am fine with it
21:43:45 <Arkady_Kanevsky> OK
21:43:49 <leong> Arkady_Kanevsky: for WIP proposal, we can review on gerrit
21:44:06 <AndyU> rocky_g - I didn't forget. We're mobilizing a lot of support now. Will reach out soon.
21:44:08 <leong> for those "merged" proposals, let's discuss over ML
21:44:18 <leong> for Value 2: Periodic coordination/collaboration across WGs/Product Managers
21:44:30 <leong> i think we need to work closely with UC and participate in cross-wg discussion
21:45:35 <leong> i will keep that as an ongoing discussion item
21:45:41 <Arkady_Kanevsky> OK.
21:45:48 <leong> i want to spend some time on next agenda
21:45:51 <jamemcc> Per previous desire for PWG to help the WG with their development proposal - we have this session on Wednesday: #link https://openstack-lcoo.atlassian.net/wiki/display/LCOO/2017.06.7-8+Specialty+-+Containerized+Control+Plane+User+Stories+-+kickoff
21:45:55 <leong> #topic Post-forum report
21:46:03 <Arkady_Kanevsky> what do we need to do for cross-wg discussion?
21:46:10 <leong> Next step on ##hashtag - https://github.com/openstack/development-proposals/tree/master/forum/201705-bos
21:46:35 <leong> what do we want to get out from the ##hashtag result?
21:46:58 <leong> are we going to create a post-forum report based on the ##hashtag result?
21:47:17 <leong> or is the existing ##hashtag result sufficient enough?
21:48:01 <leong> are we able to derive any new development proposals from the ##hashtag result?
21:48:06 <Arkady_Kanevsky> we chaired a few UC sesson and collected data on it. Several of us sent email on it
21:48:07 <mrhillsman> did you say the scripts used to generate those are online?
21:48:08 <shamail> I think we need to mine the data and search insights
21:48:08 <shamail> versus just the raw results
21:48:08 <AndyU> We spoke of (1) making the various stakeholders aware of things in pads relevant to them
21:48:22 <mrhillsman> +1 shamail
21:48:49 <AndyU> yes, and what Shamail said
21:49:09 <leong> what are we trying to "mining"?
21:49:24 <AndyU> Also spoke of looking for the bigger themes
21:49:33 <mrhillsman> it seems from there one could "get out" of it something
21:49:51 <shamail> interesting data, correlations, items with high discussion, recurrence, etc
21:50:05 <mrhillsman> maybe which tags...^
21:50:10 <mrhillsman> always faster than me hehe
21:50:17 <shamail> :P
21:50:48 <leong> so that would probably need "manual mining" i presume...
21:51:11 <shamail> yea
21:51:20 <shamail> at least the first time
21:51:29 <leong> anyone interested to sign up for the data mining?
21:51:35 <shamail> until we identify things to mine for
21:51:47 <Arkady_Kanevsky> how many pages do we have to mine?
21:51:48 <leong> i can't do it alone :)
21:51:53 <AndyU> how do you propose to do it?
21:51:57 <mrhillsman> hehe, agreed leong
21:52:14 <MeganR> I can help - just need a clear understanding of what I'm looking for
21:52:22 <leong> actually the files are not too large for this first-time round
21:52:40 <AndyU> almost seems like we'd need to just skim the etherpads directly. We don't yet know if the hashtag's were even used effectively
21:52:47 <Arkady_Kanevsky> I thiunk each of us can review several. Just need to devide across us
21:52:49 <mrhillsman> i am going to focus on the wiki page for moderators and can help once it takes a little bit of shapre
21:52:51 <mrhillsman> shape
21:52:54 <shamail> yeah
21:53:01 <shamail> lets divide etherpads
21:53:08 <shamail> total # / volunteers
21:53:11 <leong> MeganR: i think we are trying to mine/figure out "what are things we are looking for" :)
21:53:20 <shamail> i’ll help
21:53:35 <Arkady_Kanevsky> I think we are looking for "new" requirements.
21:53:57 <AndyU> like mrhillsman, I'd like to focus on the wiki pages
21:53:58 <mrhillsman> unfulfilled/stale "old" requirements?
21:54:08 <Arkady_Kanevsky> or refinement of existign ones - gaps
21:54:10 <MeganR> @leong - thanks for the clarification, I think  :)
21:54:22 <mrhillsman> better said Arkady_Kanevsky
21:55:26 <leong> ok.. can we use this etherpad to focus on this effort?
21:55:26 <leong> https://etherpad.openstack.org/p/PWG-forum-analysis
21:55:36 <leong> #link PWG Forum Data Mining: https://etherpad.openstack.org/p/PWG-forum-analysis
21:56:07 <leong> put up the list of etherpads/wiki pages and sign up for mining
21:56:17 <rocky_g> Also, as an FYI, dovetail, or some such, did you guys see https://docs.google.com/spreadsheets/d/1Mf8OAyTzZxCKzYHMgBl-QK_2-XSycSkOjqCyMTIedkA/edit#gid=0
21:56:37 <rocky_g> The Public Cloud WG gaps list
21:58:02 <AndyU> rocky_g - thanks for sharing
21:58:36 <Arkady_Kanevsky> this is for public cloud. DO we have one for each use case?
21:58:51 <leong> alright, are we good with the plan for data mining?
21:58:56 * leong 2 mins
21:58:56 <Arkady_Kanevsky> 2 min left.
21:59:36 <leong> rocky_g: i would suggest if the public wg can define that in the PWG development proposals, we shall collaobrat with them
21:59:40 <rocky_g> Arkady_Kanevsky, the gaps can be organized and would turn into a story or three... but they aren't as yet.
21:59:57 <Arkady_Kanevsky> OK
22:00:02 <leong> i guess we can wrap up here
22:00:12 <leong> thanks everyone for joining the call
22:00:27 <mrhillsman> l8r
22:00:32 <mrhillsman> thx leong
22:00:35 <AndyU> Have a good week all
22:00:39 <leong> #endmeeting