21:00:33 <leong> #startmeeting product_working_group
21:00:34 <openstack> Meeting started Mon Jun 19 21:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:38 <openstack> The meeting name has been set to 'product_working_group'
21:00:55 <rocky_g> o/
21:01:04 <shamail> Hi
21:01:31 <leong_> #chair shamail
21:02:06 <AndyU> Hi all  o/
21:02:06 <leong_> having problem.. was kicked out now rejoining as a different user
21:02:28 <shamail> :(
21:02:48 <rocky_g> ouch.  been there. done that
21:03:02 <Arkady_Kanevsky> hello PWG
21:03:05 <leong_> hi all
21:03:16 <leong_> #topic rollcall
21:03:30 <shamail> Here
21:03:34 <Arkady_Kanevsky> Arkady present
21:03:37 <leong_> oh man.. seems like i lost the chair control
21:03:47 <shamail> Yeah
21:04:17 <rocky_g> up to shamail  then
21:04:39 <rocky_g> or to guve the new leong_ chair, also
21:04:42 <shamail> I don't have it either I think
21:04:51 <rocky_g> You should.
21:04:56 <shamail> #chair leong
21:04:56 <AndyU> or we give each other the day off :)
21:05:04 <leong_> i was "just" kicked out prior to adding shamail as chair
21:05:11 <shamail> Yeah
21:05:22 <rocky_g> oh.  Dang!
21:05:47 <shamail> Anyways, let's proceed :)
21:05:55 <rocky_g> Infra could fix it., but is it worth it?  Let's just go on and have them end the session at the close.
21:06:13 <shamail> rocky_g: +1
21:06:45 <leong> yeah.. i am back :)
21:06:51 <rocky_g> yay!
21:06:53 <leong> #chair shamail
21:06:54 <openstack> Current chairs: leong shamail
21:07:00 <leong> yeah!
21:07:02 <leong> fix that
21:07:03 <leong> haha
21:07:08 <shamail> Sweet
21:07:11 <leong> #Rollcall
21:07:36 <shamail> Here
21:07:39 <leong> sorry for the hiccup, i believe we have quorum...
21:08:00 <leong> by the way, i have to jump at half hour... so need shamail to chair
21:08:15 <leong> today agenda can be found here
21:08:22 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:08:37 <leong> #topic Review of action items
21:08:38 <shamail> I can chair after 5:30P ET
21:08:58 <Arkady_Kanevsky> Andy and I had a meeting and are working on wiki change proposal.
21:09:08 <Arkady_Kanevsky> We do want to bring a few things for discussion.
21:09:17 <Arkady_Kanevsky> Can do a couple of them today.
21:09:44 <leong> go ahead!
21:10:04 <mrhillsman> o/
21:10:17 <Arkady_Kanevsky> 1. We do not explicitly state in our objective to coordinate overlaps of requirements between multupel user groups.
21:10:53 <Arkady_Kanevsky> suggest we add that in objective as part of •	Gather data/requirements from other working groups;
21:11:17 <rocky_g> +1
21:11:19 <Arkady_Kanevsky> all working groups
21:11:58 <shamail> +1
21:12:01 <leong> +1
21:12:08 <Arkady_Kanevsky> 2. We do not state in objective that •	Work with the UC, TC and Board to prioritize platform-wide objectives based on User priorities
21:12:36 <Arkady_Kanevsky> If we have agreemnt we will add #1 in objective change as part of proposal.
21:12:42 <AndyU> If it makes this any easier I have some slides I've been working on here which convey some of the thoughts Arkady is sharing: https://docs.google.com/presentation/d/1FWuIModYuIxNOYFne7y-yfF70UDKOMQ2JEUeEwTtt20/edit?usp=sharing
21:12:42 <Arkady_Kanevsky> Ready for comments on #2
21:12:47 <leong> #agreed: explicitly state in our objective to coordinate overlaps of requirements between multiple user groups as as part of "Gather data/requirements from other working groups"
21:13:38 <Arkady_Kanevsky> any feedback on #2?
21:14:03 <leong> for #2, i believe we need to bring that up for discussion at UC?
21:14:26 <rocky_g> I think it provides the biggest bang for the work.
21:14:42 <Arkady_Kanevsky> Like that. Should we add it to UWG agenda for mid cycle
21:14:51 <leong> Tom talked about the feature triage before..
21:14:51 <Arkady_Kanevsky> https://etherpad.openstack.org/p/MEX-ops-meetup
21:15:30 <Arkady_Kanevsky> Feature triage falls into gap analysis part of workflow.
21:15:48 <leong> Arkady_Kanevsky: would you be attending the MEX OPS, if yes, can you bring that up?
21:16:07 <Arkady_Kanevsky> That is 1M$ question.
21:16:15 * shamail will not be there
21:16:23 * leong will not be there either...
21:16:30 <Arkady_Kanevsky> I had sent email to see who will be coming to ops summit and who to PTG.
21:16:55 <leong> thanks Arkady_Kanevsky for the email...:) so far i haven't seen much replied yet
21:16:56 <Arkady_Kanevsky> It does not look like we will have quorum for PWG on either of them.
21:16:57 <rocky_g> Also, if you look at the Public Cloud Providers WG, they have the requirements (missing functionality) identified without the stories.  So, they have the gaps.  I think most of the WGs could do that
21:17:10 <AndyU> My status for both is still unknown
21:17:22 <shamail> Feature triage is requirement gathering centric
21:17:24 <rocky_g> mine is very iffy.
21:17:33 <Arkady_Kanevsky> I will attend one of them. Still deciding which one is the right one.
21:17:33 <leong> shamail: +1
21:17:59 <leong> Arkady_Kanevsky: can we push #2 to next week discussion?
21:18:12 <Arkady_Kanevsky> Tom is the only one responded that he is going to Mexico
21:18:14 <shamail> leong: +1
21:18:20 <Arkady_Kanevsky> Agree to psotpone till next week.
21:18:30 <Arkady_Kanevsky> But I will miss next week as I will be on a plane
21:18:46 <Arkady_Kanevsky> Andy can drive #2 next week
21:19:08 <shamail> Ok
21:19:12 <rocky_g> Also, a point of information:  The PCPWG spreadsheet:  #link https://docs.google.com/spreadsheets/d/1Mf8OAyTzZxCKzYHMgBl-QK_2-XSycSkOjqCyMTIedkA/edit?usp=sharing)
21:19:15 <leong> cool
21:19:16 <leong> #info to follow up the discussion in next week Agenda on objective that Work with the UC, TC and Board to prioritize platform-wide objectives based on User priorities
21:19:24 <Arkady_Kanevsky> I suggest we add #3 into the same agenda: #3•	Periodic coordination/collaboration across WGs/Product Managers
21:19:32 <rocky_g> ++
21:19:48 <leong> Arkady_Kanevsky: that's on weekly agenda :)
21:20:19 <leong> let's move on.. any one got a chance to review the Moderator Guide?
21:20:20 <Arkady_Kanevsky> It is not listed in obejctives on wiki.
21:20:37 <Arkady_Kanevsky> not me.
21:21:09 <rocky_g> I just did a quick pass.  Will need to go deeper.
21:21:37 <leong> ok.. please spend some time to review and provide feedback to mrhillsman and AndyU
21:21:48 <leong> #action all to review Moderator Guide and provide feedback to mrhillsman and AndyU
21:21:48 <Arkady_Kanevsky> +1
21:21:54 <mrhillsman> sorry had to step away for a quick moment
21:21:55 <mrhillsman> back
21:22:23 <leong> so for the PTG and Mex-Ops meetup, i believe we might not have enough quorum to host that meeting
21:23:03 <Arkady_Kanevsky> agree, unless we hear otherwise
21:23:07 <leong> my suggestion is NOT having F2F meetup this time (both PTG and Mex-OPS)
21:23:26 <leong> let's wait for another week and see if there is any more reply to the email
21:23:30 <Arkady_Kanevsky> Board meeting will be colocated with PTG. with several important topics on agenda.
21:23:39 <Arkady_Kanevsky> leong +1
21:23:46 <rocky_g> ++, Arkady_Kanevsky
21:24:04 <leong> #agreed wait for another week from email feedback, next week to finalize if we need to host f2f meetup at PTG or Mex-Ops
21:24:11 <shamail> leong: +1
21:24:30 <leong> shamail: can you take on the chair from here? I got to leave in 5 mins...
21:24:40 <shamail> Sure
21:24:41 <AndyU> If we don't have a f2f this time, will the next opportunity be outside of North America?
21:24:43 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:25:01 <leong> AndyU: i am not sure...maybe
21:25:30 <leong> shamail: pls go ahead :)
21:25:33 <Arkady_Kanevsky> Next one can be is Sidney as part of forum
21:25:37 <shamail> Sounds good
21:25:43 <AndyU> Might be even harder to get quorum then.
21:25:48 <shamail> Arkady_Kanevsky: +1
21:26:01 <mrhillsman> F2F via Zoom?
21:26:11 <shamail> That could be possible
21:26:11 <mrhillsman> :)
21:26:15 <AndyU> mrhillsmann +111
21:26:32 <Arkady_Kanevsky> If we cannot get quorum then we should propose merging several of UWGs into one.
21:26:43 <AndyU> I believe we would benefit from beginning to use web meetings at least occasionally
21:26:47 <Arkady_Kanevsky> Skype works also
21:26:49 <mrhillsman> agreed
21:27:02 <shamail> #action We could possibly conduct midcycle via Teleconference solution... need to mail ML to determine interest.
21:27:19 <Arkady_Kanevsky> Andy and I used skype for business and it worked well.
21:27:23 <mrhillsman> skype does work...if wanting to do zoom, i have a pro account i do not plan on getting rid of for the foreseeable future
21:27:42 <mrhillsman> i think zoom free limits time or something
21:27:47 <shamail> We can discuss further after we can determine whether people would attend.
21:27:52 <mrhillsman> but whatever works
21:28:01 <leong> if only voice needed, we can provide the dialing bridge with global dial-in number, not a problem :)
21:28:02 <Arkady_Kanevsky> email discussion it it
21:28:03 <AndyU> FWIW, Atlassian will provide a free "Hipchat" account which include individual and group video chat.
21:28:03 <shamail> It's a good suggestion in my opinion
21:28:19 <mrhillsman> +1
21:28:28 <shamail> Next topic?
21:28:38 <shamail> #topic Development Proposals review
21:28:39 <Arkady_Kanevsky> yes
21:28:53 <shamail> #link https://review.openstack.org/#/q/project:openstack/development-proposals+status:open
21:29:26 <Arkady_Kanevsky> I need more time to review existing+wip proposals
21:29:34 <shamail> Have people had a chance to review the open proposals yet? We had an action item to discuss which ones (if any) might be ready to discuss with project teams
21:29:44 <shamail> Same here Arkady_Kanevsky
21:30:03 <rocky_g> I'm in the same boat...
21:30:12 <leong> baremetal is ongoing...
21:30:24 <shamail> Alright, if people are okay then I'll defer this until a future meeting?
21:30:25 <Arkady_Kanevsky> https://github.com/openstack/development-proposals/tree/master/development-proposals/proposed - proposal page
21:30:32 <leong> already started discussion with project teams on baremetal
21:30:40 <leong> shamail +1
21:30:41 <rocky_g> Any way we can prioritize and mayb do a couple or three per week?
21:30:45 <shamail> Thanks leong
21:31:01 <shamail> rocky_g: +1
21:31:04 <rocky_g> Identify them first week, discuss second.
21:31:18 <Arkady_Kanevsky> I will review https://review.openstack.org/#/c/411140/. Glad to see it was updated
21:31:20 * leong sneaking out the meeting room.. will check the irc logs later
21:31:24 <rocky_g> So, defined homework instead of vague, large, and fuzzy
21:31:24 <shamail> #action Build a plan to breakdown proposal readiness assessment process
21:32:12 <shamail> #info Discussion on which proposals are ready to be discussed with project teams has been deferred for a future session
21:32:32 <shamail> #topic hashtag analysis
21:32:47 <shamail> Has anyone looked at the hashtags data yet for insights?
21:33:03 <Arkady_Kanevsky> still on my todo list.
21:33:10 <shamail> This one might require a similar approach (break down the work and make weekly progress)
21:33:27 <Arkady_Kanevsky> Maybe we should hijack this meeting in the future to do that work as the group
21:33:38 <shamail> Arkady_Kanevsky: +1
21:33:38 <mrhillsman> same, still on todo list
21:33:41 <mrhillsman> +1
21:34:09 <shamail> #info Hashtag analysis has not started, need to break down the work and use WG meetings for making progress
21:34:21 <rocky_g> Arkady_Kanevsky, exactly.  So the aganda for next meeting is what we put on for us to review and consider during the week.  Then the discussion of those at that next meeting
21:34:25 <AndyU> <sigh> not me either
21:34:45 <shamail> rocky_g: +1
21:34:54 <shamail> #topic PWG Review
21:35:39 <shamail> Disclaimer: This topic isn't meant to be resolved today but just framing a conversation that we need to have in the near future
21:36:32 <shamail> We had numerous discussions last week (Rocky and I, Leong and I, etc) about how to handle our scope given the limited active members in the team
21:37:12 <Arkady_Kanevsky> Shamail, you think we can do lighter proposal creation process? or ost of driving proposal thru execution?
21:37:15 <shamail> We should take time as a WG to determine if we are still effective in our role and, if not, how can we become more effective
21:37:31 <shamail> (This is the homework assignment, to think about your answer to this question)
21:38:03 <Arkady_Kanevsky> This is releated to one itme we pickedc form wiki review
21:38:17 <rocky_g> Yup.  Item 2
21:38:23 <Arkady_Kanevsky> to fill any necessary resource gaps for proposals.
21:38:37 <rocky_g> It seems to me that user groups are building up, but we are not
21:38:39 <Arkady_Kanevsky> I do not beleive we no longer can deliver it
21:38:56 <rocky_g> We can use the user groups to provide their view of the gaps.
21:38:59 <Arkady_Kanevsky> rocky_g - agree
21:38:59 <shamail> Maybe Arkady_Kanevsky but i would broaden the scope even further and ask whether we should create a proposal framework and help other teams create and manage their own proposals with PWG helping them or should we still be the team that drafts and prioritizes?
21:39:20 <rocky_g> That will give us multiple verticals.  We would be liaisons to the User groups.
21:39:43 <Arkady_Kanevsky> so what will be out mission and deliverables?
21:39:44 <rocky_g> Then, we do analysis of what is in multiple gaps docs.
21:39:57 <rocky_g> And that is what we drive through devs
21:40:09 <shamail> For this week, let's not discuss solutions yet but think about whether we agree that there is an issue here for us to resolve and B) what are some ways we can adapt to address any issues
21:40:11 <AndyU> Shamail - IMO we should be the team that helps other teams create and manage their own proposals
21:40:25 <mrhillsman> +1 shamail
21:40:28 <shamail> AndyU: +1 imo
21:40:45 <Arkady_Kanevsky> we will loose roadmaps and critical value we provide to openstack users
21:41:22 <shamail> #action Everyone think about the scope, processes, and team resources of the PWG and we can discuss what's awesome, what's okay, and what's broken in a future meeting (along with brainstorming solutions)
21:41:35 <Arkady_Kanevsky> +1
21:41:50 <shamail> Arkady_Kanevsky: the roadmap team could become stand-alone like the User Survey team potentially :P
21:42:05 <shamail> Anyways, look forward to your insights and suggestions!
21:42:23 <shamail> #topic Opens
21:42:31 <shamail> The floor is now open :)
21:42:39 <shamail> Anyone have additional topics?
21:43:00 <Arkady_Kanevsky> none from me. will use 20 min to review proposals.
21:43:08 <shamail> Great idea :)
21:43:13 <shamail> Going once...
21:43:22 <shamail> twice...
21:43:29 <shamail> Take care everyone!
21:43:30 <AndyU> That last action item would be a good subject for trying out having web meetings (zoom, skype, whatever)
21:43:37 <AndyU> ;)
21:43:39 <Arkady_Kanevsky> thanks everybody
21:43:40 <shamail> AndyU: +1
21:43:41 <mrhillsman> agreed
21:43:45 <rocky_g> Cool.  Thanks.  Lotsnof different approaches.
21:43:47 <mrhillsman> just a reminder
21:44:03 <mrhillsman> wrong window :)
21:44:10 <rocky_g> mrhillsman, i'd like to see how a switch to SIGs would affect our decision
21:44:12 <shamail> #agree We can discuss PWG retrospective in video conference midcycle (if we have one)
21:44:12 <AndyU> heh...
21:44:21 <mrhillsman> well
21:44:23 <mrhillsman> since you asked
21:44:26 <mrhillsman> right window
21:44:30 <mrhillsman> #link https://docs.google.com/document/d/1gTeN5ZB2AnPPXejXOm08sQ75Fc-cMs-x-dOGwfsyM8w/edit#heading=h.kx0vp5ot98rv
21:44:55 <mrhillsman> that is the SIG proposal
21:45:03 <mrhillsman> I added some thoughts again today
21:45:08 <shamail> #action Please review https://docs.google.com/document/d/1gTeN5ZB2AnPPXejXOm08sQ75Fc-cMs-x-dOGwfsyM8w/edit#heading=h.kx0vp5ot98rv
21:45:16 <mrhillsman> any of you are welcome to pitch in
21:45:29 <mrhillsman> there is a comment around your concern rocky_g as well
21:45:32 <rocky_g> Funny.  I'm anonymous moose, but I am SQIRREL!
21:45:42 <rocky_g> cool.
21:45:48 <shamail> lol
21:45:53 <shamail> Alright, take care all.
21:45:58 <mrhillsman> ttyl
21:46:00 <rocky_g> Thanks!
21:46:02 <shamail> #endmeeting