21:01:23 <leong> #startmeeting product_working_group
21:01:24 <openstack> Meeting started Mon Jun 26 21:01:23 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:27 <openstack> The meeting name has been set to 'product_working_group'
21:01:41 <leong> #topic Rollcall
21:01:50 <leong> anyone here for PWG meeting?
21:01:54 <annabelleB> here!
21:02:03 <leong> hi annabelleB
21:02:20 <leong> i forgot to send out meeting reminder... wondering if folks will be joining today..
21:02:52 <leong> let's wait for a couple minutes and see if we have quorum
21:03:17 <annabelleB> sounds good!
21:05:36 <leong> anyone here for PWG meeting?
21:05:51 <rockyg> o/
21:05:57 <leong> hi rockyg
21:06:30 <leong> still waiting for folks to join in....
21:06:37 <rockyg> Hey!
21:08:16 <rockyg> seems the week is getting off to a slow start
21:08:21 <leong> i guess so...
21:08:59 <leong> shamail and arkady won't join today
21:09:26 <AndyU> Will we be having a meeting?
21:09:31 <leong> 9 min past the hour... so far i believe we have leong, rockyg AndyU and annabelleB
21:09:35 <rockyg> what about mrhillsman ?
21:09:36 <AndyU> I just joined
21:09:48 <mrhillsman> o/
21:10:02 <rockyg> We've got 5!
21:10:10 <leong> hi mrhillsman
21:10:19 <leong> i suppose we can get started :-)
21:10:24 <mrhillsman> hey, overly busy week unfortunately hehe
21:10:39 <rockyg> Yeah, life happens when you're having work
21:10:47 <leong> haha
21:10:56 <leong> #link Agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:11:11 <leong> #topic Review of action items
21:11:59 <leong> anyone got a chance to look at the moderator guide?
21:12:04 <leong> i think arkady did. :-)
21:12:28 <rockyg> oops.  Nope.  Running slow.  Got a sinus infection.
21:12:39 <mrhillsman> yep, will make some changes today
21:13:11 <leong> cool...
21:13:50 <leong> i haven't send the email for teleconf option for midcycle yet...
21:14:12 <leong> i presume that we will not have F2F this time...
21:14:30 <leong> if we want to host a telecon, we also need to decide a date and time
21:15:25 <leong> and also need to  figure out how to run the teleconf across timezone
21:15:35 <leong> any comments?
21:16:19 <rockyg> We might consider something like two hours at US beginning of day and 2 hours at the end.  Do it for a couple of days?
21:16:33 <leong> that can be an option
21:17:09 <leong> #info Midcycle Teleconf Option 1: 2 hours at US beginning of day and 2 hours at the end, run for couple of days
21:17:43 <AndyU> Maybe we could start by trying out the webmeeting format now to close up some of these action items that have been dragging on?  Such as take an hour together to do a live review/edit of wiki pages?
21:18:12 <rockyg> ++
21:18:20 <leong> AndyU: +1 i think that will be part of Agenda
21:18:47 <leong> we need to decide the format/time first, then can work on agenda
21:19:04 <leong> i will send the email on this
21:19:14 <AndyU> Oh... and I just remembered I said I'd add the etherpad template to mrhillsmans's moderator guide...
21:19:53 <leong> #action leong to email about teleconf midcycle and format
21:20:18 <leong> #topic Development Proposals
21:20:48 <leong> as per last meeting, we need to build a plan to breakdown the proposal readiness assessment
21:21:25 <leong> do we want to take some time today to brainstorm a bit?
21:21:49 <AndyU> I'm game
21:23:00 <leong> so in general, i suppose the goal is to derive a "readiness assessment checklist"
21:23:39 <rockyg> Yes.
21:24:09 <rockyg> But what should be on it?  Will the gaps analysis need to have been done?
21:24:23 <rockyg> Certainly use cases should be there.
21:24:25 <AndyU> We have 4 phases to a 'Development Proposal'.  The first phase produces an artifact (what do we call it?) according to the dev proposal template. What are the steps that the artifact goes through?
21:25:02 <leong> rockyg: i think we are refering to the "proposal".. gap-analysis is the phase after a proposal been accepted
21:25:02 <AndyU> for example, there is a WIP stage, then what to we call the stage after that and what are the criteria for moving to it?
21:25:34 <rockyg> Ah, thanks.
21:26:33 <leong> rockyg: so the "readiness" is to make sure that such proposal is (1) the impact of it (2) valid to move forward, (3) enough resource? (4) sufficient info to move into gap-analysis phase
21:26:34 <AndyU> Right. I look at the Phases as (1) Requirements Definition  (2) Gap Analysis  (3) Implementation Planning  (4) Development/Delivery
21:27:52 <mrhillsman> why not call it a blueprint
21:28:26 <mrhillsman> or is proposal == blueprint
21:29:06 <mrhillsman> or is that zooming in too far at this point
21:29:22 <leong> mrhillsman: if you refer the standard openstack blueprint. then a proposal != blueprint
21:29:35 <leong> mrhillsman: a proposal potentially can generate multiple blueprint
21:29:37 <rockyg> Yeah.  At this point, it's use cases and/or requirements
21:29:44 <AndyU> Each 'phase' has an Artifact that needs to be produced such as the 'Dev proposal' thing doc, the Gap Anaysis doc, the implementation plan and 4th is the actual delivered code
21:29:50 <rockyg> So BP to detailed
21:30:18 <leong> mrhillsman: however, it can be a blueprint with respect to PWG
21:30:22 <rockyg> too detailed.
21:30:22 <AndyU> And the community is moving away from BP's to Storyboard 'Stories' right?
21:30:29 <mrhillsman> i guess it makes sense to you different terminology; i'm not thinking of overlap with standard openstack def
21:30:34 <rockyg> At least in OpenStack parlance as was pointed out.
21:30:39 <mrhillsman> s/you/use
21:31:04 <leong> the key thing is not about calling it blueprint or proposal... the key thing is need to determine "is such proposal ready to move forward"
21:31:14 <mrhillsman> yeah, going to that
21:31:31 <AndyU> the phase one doc will contain multiple use cases which would likelely become multiople blueprints later on
21:31:50 <mrhillsman> so back to the readiness assessment
21:31:50 <rockyg> Implementation plan could be:  Spec (referring to multiple BPs and/or RFEs) or BP (smaller, single task) or RFE (like BP but filed in the bug tracker)
21:32:08 <mrhillsman> i think thinking backwards will help
21:32:32 <mrhillsman> if it is moving to gap analysis, what does it require to be there
21:32:56 <rockyg> So, review of Use cases.  Do they cover the workflow/tasks encompassed by the description?
21:34:39 <AndyU> right. And I think there are steps to get there. Like going from (1) WIP to (2) PWG Analysis? to (3) Stakeholdering with impacted people/projects in the community?  What says it's been sufficiently stakeholdered and all key players agree?
21:35:07 <leong> mrhillsman: +1
21:35:27 <leong> so we need to define a checklist for that
21:35:49 <rockyg> AndyU, +1
21:35:55 <mrhillsman> i am looking at #link https://wiki.openstack.org/wiki/ProductTeam/Development_Proposals
21:35:55 <AndyU> yes, I think so, high level at least
21:36:08 <mrhillsman> and i see #link https://github.com/openstack/development-proposals/blob/master/development-proposal-template.rst
21:37:01 <mrhillsman> unless i am wrong, something in the template is the first step, and there are mandatory sections, all looks good functionally
21:37:17 <mrhillsman> what qualifies the information i put in that template?
21:37:55 <mrhillsman> if that is a review by the pwg, what is the criteria for the sections?
21:37:57 <AndyU> Can we agree that before phase 1 can go to phase 2 (gap analysis) there should be stakeholdering and concensus among key impacted players over that phase 1 proposal/requirements?
21:38:11 <leong> the question is: how details the "content itself" must be include before we call it "ready"
21:38:24 <mrhillsman> exactly
21:38:24 <leong> AndyU: +1
21:38:42 <leong> hey.. i created this etherpad... can we collect these points there?
21:38:57 <leong> #link Proposal Readiness Checklist: https://etherpad.openstack.org/p/PWG-development-proposal-readiness
21:39:00 <mrhillsman> was just thinking the same
21:39:10 <AndyU> Does the PWG seek to get it in good order (initial triaging) before pulling in stakeholders for a boader review?
21:40:40 <rockyg> Yes.  We do first vetting.  Or should.
21:40:43 <leong> AndyU: i think that can be part of the role of PWG ..
21:40:59 <mrhillsman> i want to +1 but battling the scaling with code vs people in the back of my mind
21:42:44 <leong> to me, all proposal must have "sufficient level" of details so that such proposal can be derived into specific bp/spec for each openstack projects
21:43:24 <leong> a proposal cannot be too "broad" , having a 10000 footview is good as an abstract but is not sufficient to dive down into feature implementation
21:44:07 <rockyg> Agreed.  So, consider each as if they were requesting a whole new set of functionality.  Have all the requirements been covered?  Then, the gap analysis will identify what already exists that meet the new funtionality needs.
21:44:56 <rockyg> So, a development proposal should not assume any of the funtionality already exists.  This is the requirements phase.  What we need, not how.
21:45:11 <AndyU> Leong +1
21:45:25 <leong> rockyg: +1
21:45:40 <AndyU> Right. Keep solutioning out of the requirements phase
21:45:58 <leong> rockyg: gap analysis will identify what already existing and what is not
21:46:28 <rockyg> Right.  What I said.
21:46:33 <leong> rockyg: +1 Proposal is to determine "what"
21:46:39 <rockyg> I just didn't add the negative.
21:46:47 <rockyg> ;-)
21:46:55 <leong> lol
21:47:02 <AndyU> Phase 1 would seek to define the problem and what is desired in order to alleviate it (Problem/Requirments). Then get buy-in from all key stakeholders (and or revise until you do).
21:48:59 <rockyg> ++
21:49:05 <leong> also, it will be good if these "readiness checklist" can be quantifiable...
21:49:37 <rockyg> So, key items here:  Complete problem description but not to include extraneous issues.
21:49:40 <AndyU> I think you would not want to move on to Gap Analyisis until after all the key stakeholders agree on the phase 1 proposal. Need to have that concensus/buy-in
21:50:12 <rockyg> Comprehensive requirements.  Does it have to be in the form of use cases only, or can they take other forms, too?
21:50:26 <mrhillsman> is there another word that can be used besides requirement(s)? i know it is semantics, but at this phase requirements are not known, though there is/are/could be desired outcome(s)
21:51:10 <rockyg> In some proposals, the requirments may not be known.  In others, they are.
21:51:41 <rockyg> There are also a whole slew of implied requirements that emerge out of the general requirements or use cases.
21:52:04 <AndyU> I think in phase 1, we need to understand that the "requirements" are more like "business requirements". They're not specifying any technical solution yet (how), jus the What
21:52:24 <rockyg> AndyU, ++  Good point.  Biz req's
21:53:27 <leong> i tried to put the above discussion point in the etherpad https://etherpad.openstack.org/p/PWG-development-proposal-readiness
21:53:41 <leong> we can later summarized them and hopefully generate a checklist :)
21:54:12 <AndyU> Leong - good idea to start the etherpad
21:54:21 <rockyg> ++
21:54:50 <mrhillsman> ++
21:55:01 <leong> that gives other folks to express their points offline after this meeting as well :)
21:55:27 <leong> we have 5 mins to the hour
21:55:46 <leong> that's a good brainstorming session
21:56:20 <rockyg> agreed
21:56:20 <leong> please keep contributing to that etherpad and we can summarize that next week or so
21:56:21 <AndyU> Does this link work for you all?  https://docs.google.com/presentation/d/1FWuIModYuIxNOYFne7y-yfF70UDKOMQ2JEUeEwTtt20/edit#slide=id.p14
21:56:36 <leong> AndyU: works for me
21:57:00 <rockyg> It does when I'm not on the corp net ;-)
21:57:09 <leong> AndyU: but you might want to double check if you "share with specific person" or "share with EVERYONE"
21:57:27 <AndyU> ok, good.  I offer that as a way to help conceptualize the different phases and how they connect to community cycles
21:57:32 <leong> rockyg: that seems like your corp firewall/proxy issue :)
21:57:43 <mrhillsman> works for me
21:57:51 <AndyU> I selected shared with anyone who has the link
21:58:02 <leong> #action all to continue brainstorming proposal readiness on the etherpad https://etherpad.openstack.org/p/PWG-development-proposal-readiness
21:58:12 <AndyU> I'll make it group editable
21:58:30 <AndyU> #link https://docs.google.com/presentation/d/1FWuIModYuIxNOYFne7y-yfF70UDKOMQ2JEUeEwTtt20/edit#slide=id.p14
21:58:41 <annabelleB> works for me
21:58:49 <leong> we shall continue the proposal conversation next week
21:58:54 <leong> #topic open
21:59:01 <leong> does anyone has any open?
21:59:26 <mrhillsman> nothing here
22:00:07 <leong> alright.. good conversation!
22:00:18 <leong> #endmeeting