21:00:23 <leong> #startmeeting product_working_group
21:00:24 <openstack> Meeting started Mon Jul 10 21:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:27 <openstack> The meeting name has been set to 'product_working_group'
21:00:56 <leong> #chair shamail
21:00:57 <openstack> Warning: Nick not in channel: shamail
21:00:58 <openstack> Current chairs: leong shamail
21:01:15 <Arkady_Kanevsky> hello PWG
21:01:24 <pchadwick> Hello all
21:01:29 <leong> hi Arkady_Kanevsky pchadwick
21:01:44 <rockyg> Hey all!
21:01:53 * leong waiting for folks to join in....
21:01:55 <leong> hi rockyg
21:02:06 <MeganR> Hello!
21:02:17 * leong joined the meeting an hour ago and realize nobody is there LOL
21:02:26 <leong> hi MeganR
21:02:39 <leong> #topic Rollcall
21:03:02 <leong> let's wait for another 2 minutes for other folks to join in
21:03:22 <leong> i have Leong Arkady_Kanevsky pchadwick rockyg MeganR
21:03:25 <leong> am i missing anyone?
21:04:01 <rockyg> don't see mrhillsman or AndyU
21:04:10 <shamail> o/
21:04:11 <leong> #chair shamail
21:04:12 <openstack> Current chairs: leong shamail
21:04:21 <annabelleB> hello!
21:04:23 <leong> i think we have quorum to start now.. :)
21:04:32 <Arkady_Kanevsky> lets go
21:04:40 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:04:53 <leong> please find the above link for today Agenda
21:05:06 <leong> #topic Review of action items
21:05:29 <leong> #link Previous Meeting Notes: http://eavesdrop.openstack.org/meetings/product_working_group/2017/product_working_group.2017-06-26-21.01.html
21:05:33 <Arkady_Kanevsky> I had se nt email on wiki change.
21:05:38 <Arkady_Kanevsky> Waiting for feedback
21:06:03 <leong> thanks Arkady_Kanevsky, i saw that email and generally looks good to me
21:06:31 <Arkady_Kanevsky> let's setup feedback deadline date and I will start making chnages after it
21:06:31 <shamail> +1
21:06:32 <rockyg> LGTM
21:06:36 <leong> i also sent email regarding the PWG teleconf midcycle, so far feedback is "ok", no objection..
21:07:01 <leong> Arkady_Kanevsky: what about end of this week or next?
21:07:05 <mrhillsman> o/
21:07:11 <Arkady_Kanevsky> for midcycle did we agreed on full day(s) or a few hputs over multiple days?
21:07:11 <leong> welcome mrhillsman
21:07:25 <Arkady_Kanevsky> Leong +1 on deadline on feedback
21:07:32 <leong> Arkady_Kanevsky: i think we first need to agree to be "teleconf" ?
21:07:42 <rockyg> ++
21:07:44 <leong> Arkady_Kanevsky: end of this Fri?
21:07:57 <Arkady_Kanevsky> agree. But think we have that alerady.
21:08:08 <Arkady_Kanevsky> Yes on end of friday.
21:08:30 <leong> #action all PWG please review the Wiki changes proposal from Arkady_Kanevsky by end of this Friday EOD
21:08:57 <leong> #topic Midcycle video conferencing
21:09:11 <leong> let's discuss about the midcycle plan
21:09:26 <leong> i believe the general consensus is to organise Teleconf, can we agreed on this?
21:09:38 <Arkady_Kanevsky> +1 on teleconf
21:09:44 <pchadwick> +1
21:09:58 <MeganR> +1
21:10:01 <rockyg> +1
21:10:18 * leong looks like shamail just kicked out while we are making a decision.. lol :)
21:10:52 <shamail> I'd be interested in a virtual midcycle (sry connection issues)
21:11:02 <leong> #agreed PWG agreed to organize a midcycle Teleconf
21:11:30 <leong> now let's talk about the date, time, full/half-day/multiple days
21:11:35 <leong> what's your thoughts?
21:11:48 <shamail> Should we send a doodle poll?
21:12:01 <pchadwick> Doodle makes sense
21:12:09 <leong> any preferences on dates, give me a few, at least say in Aug or Sep?
21:12:21 <shamail> Sept is better for me personally
21:12:38 <pchadwick> Sept +1
21:12:41 <Arkady_Kanevsky> August 29 Tu second half of the day
21:13:27 <leong> My preferences also Sep
21:13:38 <Arkady_Kanevsky> Do we want to block the week of PTL? Spet 10-15?
21:13:45 <leong> what about the rest? MeganR rockyg ?
21:13:46 <leong> mrhillsman:
21:13:47 <leong> ?
21:14:05 <leong> Arkady_Kanevsky: +1
21:14:15 <mrhillsman> i will be at ptg
21:14:20 <rockyg> Half days are good.  I think AndyU suggested that.
21:14:23 <MeganR> I have a tough time knowing exact dates at the moment, will need to travel Aug/Sep, but do not have specific dates yet.
21:14:36 <MeganR> I would prefer half days.
21:14:42 <leong> are we going to have multiple "half day"?
21:15:18 <pchadwick> Doesn't that depend on how much we put on the agenda?
21:15:31 <shamail> pchadwick: +1
21:15:32 <Arkady_Kanevsky> Tuesday and Friday afternoons are better for me.
21:15:37 <leong> 3 half-days? US friendly, EU friendly + APAC friendly?
21:15:42 <shamail> Let's start building an agenda and then determine how many days
21:15:51 <Arkady_Kanevsky> 2 topics per 1/2 day on agenda sound good.
21:16:15 <leong> shamail / pchadwick : +1
21:16:22 <rockyg> I would suggest not doubling up over the PTG or Ops Midcycle, but otherwise.... before 9/21
21:16:40 <Arkady_Kanevsky> I think majority is US. but let's see who will respond to doodle
21:16:43 <pchadwick> OK
21:17:06 <rockyg> A few may be in EU, but most in US.
21:17:41 <leong> ok folks, i just created an etherpad here for midycle agenda: https://etherpad.openstack.org/p/VIR-pwg-meetup
21:17:49 <shamail> Thanks!
21:17:52 <leong> #link Virtual Midcycle Planning: https://etherpad.openstack.org/p/VIR-pwg-meetup
21:19:36 <leong> #action All please propose agenda on the midcycle etherpad link https://etherpad.openstack.org/p/VIR-pwg-meetup
21:19:58 <mrhillsman> what would the link be if there was another?
21:20:35 <shamail> VIR2 :) or VIR-(cycle)
21:20:46 <Arkady_Kanevsky> Let's send etherpad pointer on email and request agedna items.
21:20:47 <mrhillsman> maybe VIR-pwg-meetup-sept-2017 or yeah ^
21:21:03 <rockyg> Arkady_Kanevsky, ++
21:21:19 <mrhillsman> minor thing really but just thinking
21:21:49 <leong> mrhillsman: just append to the top :)
21:22:20 <Arkady_Kanevsky> can we change etherpad page name? do not think etherpad support aliases
21:22:35 <leong> ok.. let's do it now ...
21:22:36 <shamail> No, it would have to be a new etherpad.
21:22:42 <leong> hand on
21:24:02 <leong> #link New PWG virtual midcycle etherpad link: https://etherpad.openstack.org/p/VIR-pwg-meetup-2017q3
21:24:26 <shamail> Hey, my Q3 may not be the same your Q3!
21:24:36 * shamail sees himself out of the room
21:24:40 <shamail> :)
21:24:41 <mrhillsman> hehe
21:24:52 <Arkady_Kanevsky> Leong, are you goint to transfer content between etherpads?
21:24:59 <leong> Arkady_Kanevsky: just done
21:25:12 <shamail> Thanks leong
21:25:29 <MeganR> Shamail: you laugh, but that is actually true for me :)
21:25:31 <leong> #action All please propose agenda on the midcycle etherpad link https://etherpad.openstack.org/p/VIR-pwg-meetup-2017q3
21:26:04 <leong> shamail: lol..
21:26:11 <shamail> MeganR: I know a lot of companies like that so it jumped out at me.
21:26:19 <shamail> Anyway, this name is fine. We get it. :)
21:26:25 <MeganR> we have to be different!
21:26:36 <leong> sorry MeganR and shamail ...:p
21:26:48 <shamail> I'm calendar aligned!
21:27:09 <shamail> I'll add items throughout the week, thanks for creating it.
21:27:12 <MeganR> I'll adjust!
21:27:18 <leong> thanks :)
21:27:19 <AndyU> Sorry to have joined late, but should we be voting for preferred date(s)?
21:27:48 <leong> AndyU: the team suggested to define the Agenda first before we decide how many days are required
21:28:06 <AndyU> ok. makes good sense
21:28:41 <leong> ok.. let's move on next topic
21:28:41 <leong> #topic Sydney Summit/Forum preparation
21:29:14 <Arkady_Kanevsky> usual roamdap update submission?
21:29:16 <leong> #info Summit proposal submission CFP deadline - July 14 at 11:59 pm PT
21:29:31 <annabelleB> I’ve submitted a CFP for the roadmap on behalf of the group
21:29:43 <annabelleB> Happy to add in additional presenters as people confirm their Sydney travel plans
21:29:50 <shamail> Thanks for that annabelleB
21:30:06 <annabelleB> np!
21:30:07 <leong> thanks annabelleB , are you going to co-present with shamail / or maybe pchadwick ?
21:30:10 <pchadwick> Thanks annabelleB - I am pretty sure I will be there.
21:30:24 <Arkady_Kanevsky> I plan to be there also
21:30:27 <annabelleB> pchadwick: perfect! was going to drop you an email today :)
21:30:43 <leong> i also plan to be there but subject to travel approval :)
21:30:48 <Arkady_Kanevsky> any other submission from the group?
21:30:50 <shamail> leong: I will most likely not be in Sydney so pchadwick, annabelleB, +1
21:31:11 <leong> shamail: sure!
21:31:15 <shamail> I just would like to ensure that the presenters actively participate in the roadmap creation
21:31:26 <pchadwick> shamail +1
21:31:29 <Arkady_Kanevsky> +1
21:31:34 <leong> pchadwick: i assume you are comfortable with that? :)
21:31:40 <pchadwick> Yes
21:31:42 <AndyU> Sydney is still up in the air for me
21:31:59 <shamail> Anyone think we should propose a PWG overview session?
21:31:59 <leong> I assume we should also submit a BoF and Working Session?
21:32:18 <AndyU> BoF +1
21:32:22 <Arkady_Kanevsky> do we want to submit status of proposal we are driving?
21:32:23 <shamail> leong: +1
21:32:25 <pchadwick> Do we have any idea if there is an expectation that we will get a lot of new attendees due to the location?
21:32:28 <leong> shamail: is "overview session" = BoF?
21:32:48 <shamail> annabelleB: do you know if we need to submit BoF and Working session through CFP or Forum process?
21:33:00 <annabelleB> pchadwick: I have a hunch so. But also think it will be newcomers to OpenStack and on some level cloud entirely
21:33:01 <shamail> leong: yes, overview = BoF
21:33:17 <annabelleB> shamail: I believe so, but I’ll double check right now
21:33:27 <shamail> pchadwick: every Summit has been ~50% first time attendees for several years now
21:33:37 <AndyU> BoF was via Conference process
21:33:39 <leong> shamail: i believe BoF and WG fall under the same CFP process (as per previous experience)
21:33:40 <shamail> Thanks annabelleB
21:33:41 <pchadwick> OK - so overview/BOF makes sense.
21:34:14 <Arkady_Kanevsky> + for BOF
21:34:21 <rockyg> Nope.  I looked at the website for submissions.  Says the Bofs are different.
21:34:54 <rockyg> But Forum is through the CFP.  Last time, BoFs used same process, but after the summit submissions were through
21:35:12 <leong> i think the "submission" is through CFP, but "selection" is different from CFP process
21:35:24 <shamail> Forum is separate from CFP, we will open Forum registration in Fall
21:35:34 <annabelleB> ::pinged team for clarification, awaiting response::
21:35:37 <Arkady_Kanevsky> what about sessions on upgrade, HA, others?
21:35:46 <rockyg> I think we should propose a Forum session for how to empower sigs, wgs to work with devs to get to specs and/or bps
21:36:01 <shamail> +1 for the Forum session
21:36:07 <leong> annabelleB: thanks! please ask and let us know :-)
21:36:09 <AndyU> Dev proposals should submit for Forum session
21:36:35 <leong> #action annabelleB to verify if we should submit BoF and WG session through the same CFP process
21:36:47 <rockyg> Ah.  Then Forum should also get a * next to it on the CFP page?
21:36:55 <Arkady_Kanevsky> melvin, do we have an etherpad for forum ideas?
21:36:59 <mrhillsman> not yet
21:37:00 <leong> other than BoF, WG working session and Roadmap, anything else?
21:37:28 <AndyU> Might bneed a forum session to INTRODUCE sigs
21:37:31 <mrhillsman> we have a timeline and will send general announcement when ready
21:37:35 <shamail> Arkady_Kanevsky: stay tuned. We decided to launch Forum scheduling in Sept.
21:37:38 <mrhillsman> ++
21:37:48 <Arkady_Kanevsky> OK
21:38:04 <leong> do we plan to run the "hashtag" program again at Sydney forum?
21:38:10 <shamail> Any other CFP submissions?
21:38:12 <rockyg> ++
21:38:15 <rockyg> We should
21:38:22 <mrhillsman> if i can drop a line here, please add sessions for the ops midcycle
21:38:27 <rockyg> Maybe we can get the devs to, also at the PTG
21:38:39 <mrhillsman> https://etherpad.openstack.org/p/MEX-ops-meetup
21:38:53 <shamail> leong: I am hesitant since we never delivered any outputs from the previous summit. It seems like we don't have the resources to own that process for now.
21:38:59 <mrhillsman> since we are talking about sessions and most times they carry-over
21:39:09 <AndyU> what about trying to meet with product managers for major contributors to discuss priorities/objecvtives / seek alignmnet around dev proposals?
21:39:11 <shamail> Thanks mrhillsman
21:39:27 <leong> shamail: from previous summit, the output we delivered is the individual hashtag data generated from each etherpad
21:39:37 <leong> but we didn't get a chance to "summarize" it
21:39:45 <rockyg> AndyU, that should be added to Forum etherpad
21:39:46 <shamail> #link https://etherpad.openstack.org/p/MEX-ops-meetup
21:40:07 <leong> shamail: i agree with you that we might have limited resources to own that hashtag process now
21:40:16 <shamail> leong: sorry, that is what I meant. I know we have the output but we didn't share anything beyond the raw data.
21:40:49 <pchadwick> AndyU - is your proposal re PMs for Sydney or Mexico City?
21:41:01 <shamail> A more efficient path might be for us to just help reach out to moderators after the event so they can send a summary.
21:41:09 <mrhillsman> ^ was just typing that
21:41:21 <mrhillsman> would have been great to have a summary from mods
21:41:25 <AndyU> @Rocky - I added the topic to the mid-cycle agenda
21:41:32 <shamail> Yeah, plus they have all the context
21:41:43 <mrhillsman> ++
21:41:47 <leong> mrhillsman / shamail : agreed :-)
21:41:59 <rockyg> AndyU, yeah.  We need to talk about it before we schedule a forum session for it ;)
21:42:18 <shamail> pchadwick: I think he was referring to Forum (not Ops)
21:42:20 <leong> so my conclusion is that we ran the ##hashtag program and didn't find it effective to summarize the context ?
21:42:38 <pchadwick> shamail - makes sense
21:42:51 <shamail> We ran the program, it gave us raw data but we didn't have resources to generate summaries. The value for the community is in the summary.
21:42:58 <AndyU> +1 to asking moderatoprs to provide Summary, but need to communicate the expectation up front (as a responsibility of a moderator)
21:42:59 <mrhillsman> i don't think it was onboarded well enough, easier to control during ops midcycle vs forum
21:43:02 <Arkady_Kanevsky> I think we have raw data and no resources to convert it to action
21:43:12 <mrhillsman> ^
21:43:36 <leong> mrhillsman: so do you plan to run that ##hashtag again in upcoming midcycle?
21:44:01 <mrhillsman> yes
21:44:15 <AndyU> Also about Forum Summaries - would be nice to have them in a wiki page linked to the page with the etherpads. Have them in one place vs fragmented across various mailing lists?
21:44:23 <shamail> Awesome mrhillsman
21:44:31 <leong> awesome mrhillsman
21:44:34 <mrhillsman> i think most folks found the idea not too obtrusive and we can use midcycle to continue to move it to being useful
21:44:47 <shamail> Good idea AndyU
21:45:02 <leong> also a great path/way to start from small group of folks before turning into forum?
21:45:16 <leong> plus soliciting feedback/improvement
21:45:20 <shamail> They can post summaries to a centralized wiki page but still share it out via ML so there can be discussion if needed.
21:46:00 <shamail> leong: +1
21:46:03 <leong> mrhillsman: let me know if there is any way that i can help with the hashtag program in the upcoming Ops midcycle...
21:46:16 <AndyU> true - and emails could link to the wiki and be less verbose ;
21:46:25 <shamail> AndyU: +1
21:46:26 <mrhillsman> definitely
21:46:37 <leong> #agreed Continue to adopt the ##hashtag program at Ops midcycle
21:47:06 <AndyU> We'll need to provide a template and some guidance I think. I added Forum planning to the mid-cycle agenda
21:47:14 * shamail sneaks out (have to be somewhere in 10 min)
21:47:23 <leong> #agreed Will drop ##hashtag program for forum, we pilot at Boston summit, generate some raw data but didn't have resources to generate summaries.
21:47:42 <rockyg> So, for Forum summaries, you'll get push back from some Devs.  Some would like to kill Wikis
21:47:55 <leong> that's true rockyg
21:48:08 <AndyU> The hashtag output could also be linked from the Forum session/etherpad wiki page
21:48:10 <rockyg> They don't like that old info sits out there that becomes false info.
21:48:49 <rockyg> So, many PTLs will just send to ML.  We could link to the archive of the email on the Wiki page, though.
21:49:45 <leong> anything else to discuss for Sydney?
21:50:00 <rockyg> I think a Wiki is a lot more useful for nondevs and noncommunity members.  Much easier to find stuff.
21:50:15 <AndyU> +1 Rocky
21:50:16 <Arkady_Kanevsky> + rocky
21:50:30 <leong> as long as the wiki provide "accurate/up-to-date" info :-)
21:50:53 <AndyU> MANY operators who will be at the Summit are not in the mailing lists. Also the volume of mail can be overwhelming to sift through.
21:51:09 <pchadwick> AndyU +1
21:51:12 <AndyU> So I like the cross linking idea
21:52:21 <AndyU> Maybe we could also propose using an email tag like [Forum Update] or some such in mail lists?
21:52:22 <rockyg> Yeah.  It gives non-dev folks a way to see what happened.  And as long as we make the top level Forum page identified with *which* forum, and a date, the info never *gets* outdated
21:52:29 <mrhillsman> got to jet so i will catch the rest of the notes this evening
21:52:49 <leong> #topic Community Roadmap
21:52:51 <rockyg> thanks mrhillsman !
21:53:09 <leong> annabelleB / pchadwick : do you have any update for community roadmap?
21:53:20 <leong> ttyl mrhillsman
21:53:21 <pchadwick> I do not
21:53:25 <annabelleB> me either
21:53:43 <pchadwick> But would propose that we start with the Boston version
21:53:52 <pchadwick> that format seemed to work well.
21:54:12 <leong> annabelleB / pchadwick : so do we have enough info to generate the upcoming community roadmap?
21:54:16 <mrhillsman> side note, we have an official if it channel, #openstack-uc so feel free to drop anything there
21:54:21 <mrhillsman> ttyl
21:54:41 <mrhillsman> official irc channel
21:55:04 <annabelleB> timeline wise, i imagine we’ll get most of our info for the queens roadmap post-Denver, but I’m new to the process :)
21:55:37 <pchadwick> leong I have not started looking closely yet, but assume we can follow a similar process to get data from PTLs
21:56:10 <rockyg> annabelleB, Yeah.  You're right there.  I think a key will be to make sure the PTLs know how to pass on their Queens decisions to the PWG Roadmap folks
21:56:10 <Arkady_Kanevsky> do we do interviews or questionare for PTL this time?
21:56:28 <Arkady_Kanevsky> we need to pair down projects list and only deal with "offocial" projetcs
21:56:38 <leong> annabelleB: you might want to check with Heidi on the timeline
21:56:45 <annabelleB> It sounded like the questionare worked well
21:56:47 <rockyg> Arkady_Kanevsky, I think mostly the questionnaires
21:57:10 <leong> btw, the link to the community roadmap is broken: https://www.openstack.org/software/roadmap/
21:57:16 <pchadwick> Questionnaire worked well.
21:57:39 <pchadwick> leong works for me
21:57:45 <leong> if you go to the above link ,and scroll down to "Read the community-generated roadmap", <-- this link is broken
21:57:47 <annabelleB> leong: to that landing page or to a specific asset there? i have no problem with the page
21:58:06 <annabelleB> ah, i’ll sort that out
21:58:12 <leong> thanks annabelleB
21:58:37 <leong> #action annabelleB to check the asset link "Read the community-generated roadmap" at https://www.openstack.org/software/roadmap/
21:58:44 <pchadwick> leong - it gets me to here: https://www.openstack.org/assets/software/roadmap/Community-Generated-Roadmap-PQR-cycles.pdf
21:58:58 <leong> pchadwick: yup. that link is missing
21:59:04 <leong> i mean: that pdf
21:59:15 <leong> i hit 404
21:59:18 <pchadwick> I'm looking at it now ;)
21:59:40 <rockyg> Before you all leave, just wanted to relay some humorous info... it seems there are some in the community spreading the false info that the PWG is dead.
21:59:41 <Arkady_Kanevsky> i have access to https://www.openstack.org/assets/software/roadmap/Community-Generated-Roadmap-PQR-cycles.pdf
21:59:58 <rockyg> I get the 404
22:00:03 <leong> #topic open
22:00:29 <leong> all please continue to review readiness accessment: https://etherpad.openstack.org/p/PWG-development-proposal-readiness
22:00:41 <leong> we just hit the hour.. thanks everyone for your time!
22:00:48 <Arkady_Kanevsky> thanks all
22:00:50 <leong> talk to you next time!
22:00:55 <pchadwick> thanks - ttyl
22:00:57 <rockyg> CYa!
22:01:04 <leong> #endmeeting