21:02:13 <leong> #startmeeting product_working_group
21:02:14 <openstack> Meeting started Mon Dec  4 21:02:13 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:17 <openstack> The meeting name has been set to 'product_working_group'
21:02:39 <shamail> Hi everyone
21:02:44 <rockyg> Hey!
21:02:48 <leong> #topic rollcall
21:03:01 <leong> hi all..
21:03:03 <shamail> Here :)
21:03:10 <leong> thanks for joining Product Team meeting.. :-)
21:03:35 <rockyg> o/
21:03:38 <leong> #link today agenda https://wiki.openstack.org/wiki/Meetings/product-team
21:04:11 <leong> i see shamail, rockyg , anyone else?
21:05:23 <rockyg> arkady was gonna join, but doesn't seem to be on...
21:05:34 <leong> shall we wait for a few more mins?
21:05:52 <shamail> I’m fine with that
21:06:12 <rockyg> yup
21:07:53 <leong> hi Arkady_Kanevsky
21:07:58 <leong> let's get started
21:08:00 <Arkady_Kanevsky> hello Leong
21:08:10 <rockyg> Kewl!
21:08:15 <leong> #topic Sydney Summit recap
21:09:08 <Arkady_Kanevsky> we really screwed up working session in Sydney due to reschedueling
21:09:24 <leong> the WG session was "cancelled" as there are conflicting session at the same hour
21:09:34 <shamail> Sounds like it :(
21:09:39 <Arkady_Kanevsky> indeed.
21:09:40 <leong> i also can't attend the BoF because i am presenting another session
21:09:56 <leong> too many overlapping sessions at this Sydney forums
21:10:07 <Arkady_Kanevsky> 3 of use had a chat at BOF.
21:10:29 <rockyg> I think we need some ML scheduler for next time...
21:10:43 <Arkady_Kanevsky> so nothing really happened for the group at sydney
21:11:25 <leong> #topic Future Plan
21:11:33 <leong> let's discuss what should we do next?
21:11:42 <Arkady_Kanevsky> yes
21:11:50 <shamail> Sounds good
21:12:05 <leong> i drop an email to few of you few days ago..
21:12:27 <Arkady_Kanevsky> we got 2 responses to it.
21:12:36 <Arkady_Kanevsky> SHamail oyu have any suggestions?
21:12:40 <rockyg> I will respond soon.
21:13:00 <shamail> So given that our working session didn’t have a good turn out, we didn’t present the development proposal to SIGs, and general low attendance. I wanted to ask whether we should A) identify a single task to pursue or B) send an email to the community to see if they still value what our charter states.
21:13:56 <rockyg> I feel like we are a startup ahead of our time.  Just when we start gaining traction, we run out of funding.  Devs on the ML are asking about future roadmap now.  And it's not there.
21:14:15 <leong> +1 rockyg
21:14:26 <Arkady_Kanevsky> I think we need to pursue A. If we are not successful the n go route B. But we need to talk to foundation befpore going route B.
21:14:26 <shamail> +1 rockyg... well said
21:14:27 <rockyg> Projects are finally mature enough to start planning beyond the next release.
21:14:59 <shamail> +1 Arkady_Kanevsky
21:15:05 <rockyg> +1
21:15:26 <Arkady_Kanevsky> The one area were we had most success was roadmaps.
21:15:35 <shamail> What are your thoughts Leong?
21:15:52 <shamail> Arkady_Kanevsky: agreed but that always felt more like a marketing than PM function
21:16:00 <Arkady_Kanevsky> With foundation taking it over do we become part of that activity under foundation umbrella?
21:16:46 <Arkady_Kanevsky> Shamail - true. But this is where we were successful - people valued it more.
21:17:07 <Arkady_Kanevsky> And with small team now this is where we can still impact.
21:17:08 <shamail> It’s not a foundation activity, we are simply starting a roadmap team to decouple that work from PWG. Everyone is still welcome to participate... we are hoping to get more participation from the community
21:17:19 <rockyg> So, with devs finally waking up, what about a PTL meeting or two that we facilitate about longer term planning/roadmap?  We'd have to do our usual research for futures, but then we could drive them to get on the same page.
21:17:23 <shamail> We can definitely still participate Arkady_Kanevsky
21:18:14 <leong> shamail: i believe there is still value for Dev Proposal, however, "how to get adoption" is a big question
21:18:36 <Arkady_Kanevsky> we can drive themes but not individual features.
21:18:51 <leong> shamail: i think we can try (A), see what's the response, then (B)
21:19:08 <leong> Arkady_Kanevsky: we are not driving individual features
21:19:09 <shamail> If we decide on option A then maybe we pursue a meeting with some PTLs as rockyg suggested and specifically ask whether development proposal is valuable
21:19:10 <Arkady_Kanevsky> So what are options for A?
21:19:39 <Arkady_Kanevsky> proposals are individual features that span projects and releases.
21:19:47 <leong> for A, maybe SIG is a better place to start, which engage both dev and user
21:19:50 <rockyg> dev proposals are good.  Maybe we meet with PTLs for planning and discuss dev proposals after we gain more creds.
21:20:08 <shamail> I think another option would be to discuss whether just planning is valuable in itself with them... (e.g. is process or planning is key deliverable for our team?)
21:20:11 <leong> Dev Proposal is more for users to define/request feature for Dev
21:20:40 <rockyg> Theirry used to run a weekly PTL meeting for release.  We could do something like monthly or every other week with them if we can get them interested.
21:21:04 <shamail> “Open Office Hours” type sessions rockyg?
21:21:32 <Arkady_Kanevsky_> I am back
21:21:33 <rockyg> Might have been, but getting close to each release, it was a status meeting on all projects
21:22:05 <shamail> Gotcha
21:23:08 <rockyg> Even just getting the PTLs to meet and discuss what each needs from the others would help.  And toss in the dev proposals and we have something.
21:23:10 <shamail> Leong: agreed on Dev proposal value but we first have to see if PTLs value planning feedback from this team before we ask users to work on Dev proposals
21:23:31 <Arkady_Kanevsky_> I think we did a good job on creating dev proposal and reconsile across various user communities
21:23:43 <leong> +1 shamail
21:23:50 <rockyg> I can find the email thread about planning and we can respond to it...
21:24:03 <Arkady_Kanevsky_> but even when we wewre full team we only managed to drive 3 proposals per release...
21:24:33 <shamail> Yeah
21:24:56 <Arkady_Kanevsky_> do we want to ask PTLs for feedback on proposals or SIGs?
21:26:36 <Arkady_Kanevsky_> I like pour proposal development process and hope SIG teams find it useful.
21:26:53 <shamail> I think we want to engage PTLs to learn whether we can help with any of their planning needs around future releases. We can then use that feedback to determine which artifacts or activities we have currently could apply or whether a new approach is needed.
21:27:13 <shamail> We could do the same thing with SIGs too
21:27:39 <rockyg> ++
21:27:45 <Arkady_Kanevsky_> +1.
21:28:12 <shamail> Are you good with this Leong?
21:28:25 <Arkady_Kanevsky_> I wonder if we should concentrate on new things like new alignment board is driving toward and drive these new requirements and processes into planning
21:29:08 <leong> shamail: i am fine with the arrangement, however, i need someone to drive forward..
21:29:22 <leong> given changes to my job scope, i now have limited time on Product Team
21:29:22 <shamail> The million dollar question :)
21:29:39 <shamail> leong: same here
21:29:55 <leong> i think i also need to step down as a chair due to my other commitment.
21:30:19 <leong> i can still participate but don't think i can contribute efficiently
21:30:23 <shamail> :-O
21:30:42 <Arkady_Kanevsky_> SO what are the concrete steps we should do? and people/group to talk/present to ?
21:31:21 <rockyg> So, first going to a TC office hours and discussing some of this would be good.
21:31:28 <shamail> Do we even have enough cycles amongst those of here to move forward?
21:31:39 <shamail> I can help with the conversations but won’t be able to schedule them
21:31:41 <Arkady_Kanevsky_> should I talk to Mike Perez first on how we can help PTLs?
21:31:49 <shamail> rockyg: +1
21:31:57 <rockyg> Arkady_Kanevsky_, +1
21:32:13 <Arkady_Kanevsky_> what are TC office hours?
21:32:25 <rockyg> So, I can put up a doodle poll of TC office hours and we can agree on one to attend as a group.
21:32:40 <Arkady_Kanevsky_> +1 Rocky
21:32:53 <shamail> leong: please send an email if you plan to step down so we can discuss sucession :)
21:32:58 <rockyg> Three different times across the week where the TC hangout in their chat room and have open discussions
21:33:00 <Arkady_Kanevsky_> Meanwhile I will ping Mike.
21:33:09 <leong> shamail: will do
21:33:19 <shamail> Arkady_Kanevsky_: +1
21:33:24 <shamail> Thanks leong
21:33:38 <leong> shamail: i assume i will send to UC mailing list?
21:34:07 <shamail> Leong: +1
21:34:21 <rockyg> #link http://lists.openstack.org/pipermail/openstack-dev/2017-November/124964.html
21:34:45 <rockyg> That's the link to the first email of the thread where the Roadmap and what it contains came up.
21:34:56 <shamail> Thanks rockyg
21:35:24 <shamail> I have to drop off soon... so rockyg will you reply you add something to a TC office hours session in US time zone and let us know?
21:35:31 <shamail> Arkady_Kanevsky_: you’ll contact Mike?
21:35:36 <Arkady_Kanevsky_> Yes
21:35:43 <shamail> Thanks
21:35:48 <rockyg> Yup.  #action would be good.
21:36:14 <shamail> ping leong
21:37:07 <leong> #action rockyg to work on TC office hours session
21:37:26 <leong> #action leong to email uc for stepping down Product chair
21:38:08 <leong> #action Arkady_Kanevsky_ to ping mike on how to help PTLs
21:38:28 <leong> anything else on the table?
21:38:28 <shamail> Thanks leong
21:38:36 <Arkady_Kanevsky_> none from me
21:38:36 <shamail> Nope, I gotta run myself
21:38:46 <Arkady_Kanevsky_> thanks all.
21:38:50 <shamail> Take care everyone!
21:39:02 <rockyg> Thanks!
21:39:06 <leong> thanks!
21:39:13 <leong> #endmeeting