21:01:39 <ttx> #startmeeting project
21:01:39 <openstack> Meeting started Tue Oct  2 21:01:39 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:41 <openstack> The meeting name has been set to 'project'
21:01:45 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:46 <vishy> hi
21:01:56 <ttx> woo, 100% hit
21:01:59 <ttx> We'll spend most of the meeting looking into Design Summit organization status.
21:02:10 <ttx> but first lets start with...
21:02:13 <ttx> #topic Folsom release post-mortem
21:02:22 <ttx> Do we know of anything grossly wrong that we let through ?
21:02:40 <ttx> Nothing embarassing was brought to my attention...
21:03:01 <ttx> all good ?
21:03:07 <heckj> ttx: we found a bootstrapping issue with PKI tokens in Keystone - working it now
21:03:31 <ttx> heckj: is it in http://wiki.openstack.org/ReleaseNotes/Folsom ?
21:03:35 <heckj> it wasn't default - working to get it working as an option in devstack to resolve
21:03:45 <heckj> ttx: not yet
21:03:56 <ttx> heckj: ok, link when available
21:04:01 <heckj> yep
21:04:05 <ttx> anything else ?
21:04:06 <gabrielhurley> ttx: the "edit flavor" feature in horizon is also slightly unstable, but I need to coordinate with nova on how to make it better. it may or may not be backport-able once it's resolved. Tracked in https://bugs.launchpad.net/horizon/+bug/1057799
21:04:08 <uvirtbot> Launchpad bug 1057799 in horizon "Edit flavor unstable" [High,Confirmed]
21:04:46 <ttx> gabrielhurley: same, maybe mention it in release notes
21:04:49 <gabrielhurley> yep
21:04:50 <ttx> While it's fresh, any comment on the process that we should address next time ?
21:05:37 <ttx> ok, we'll have a design summit session on release cycle anyway
21:05:45 <gabrielhurley> overall it seemed way smoother than the essex release. +1
21:05:50 <annegentle> agreed
21:06:04 <ttx> yeah, went quite well, I think
21:06:07 <ttx> #topic Design Summit organization
21:06:20 <ttx> #info The Design Summit is a track with a series a open discussions about Grizzly development, organized around topics
21:06:30 <ttx> series of*
21:06:35 <ttx> #info Each topic lead is responsible for selecting content to fill allocated slots
21:06:46 <ttx> #info You can redirect session suggestions to other (more appropriate) topics
21:06:58 <ttx> #info You can refuse some of them (and redirect their proposer to the "Unconference" room)
21:07:11 <ttx> This is especially true of stuff that looks too much like a classic speaker presentation
21:07:22 <ttx> #info You can merge multiple preapproved sessions into a single schedule slot
21:07:34 <ttx> #info Finally, you can keep a few empty slots, that should facilitate scheduling
21:07:44 <ttx> I'm available all week to help you with session selection and scheduling
21:08:00 <ttx> Ideally, we should have the set of approved sessions at the end of the week, so that we can work on scheduling early next week.
21:08:07 <ttx> Would that work for everyone ?
21:08:11 <danwent> ack
21:08:14 <markmc> sounds good
21:08:20 <davidkranz> Sure
21:08:25 <notmyname> ok
21:08:30 <gabrielhurley> works for me
21:08:30 <jgriffith> sounds alright
21:08:39 <bcwaldon> yep
21:08:45 <ttx> Should we communicate a common deadline for session proposal ? Or do it per-topic ?
21:08:46 <heckj> word
21:08:56 <gabrielhurley> +1 to common deadline
21:08:57 <heckj> I'm fine with a general one
21:09:01 <jgriffith> I'd vote mass email/deadline
21:09:07 <bcwaldon> easier that way for sure
21:09:09 <ttx> EOD Thursday ?
21:09:14 <ttx> or tomorrow ?
21:09:19 <bcwaldon> not tomorrow
21:09:24 <gabrielhurley> Thursday to give people time to read the email and propose a topic
21:09:25 <jgriffith> +1 for EOD thurs
21:09:27 <heckj> pref for thursday
21:09:30 <ttx> ok
21:09:44 <ttx> #action ttx to send deadline for proposals Thursday EOD
21:09:55 <ttx> OK... let's look into the status of each topic now...
21:10:00 <ttx> You can see the graph for each topic at:
21:10:05 <ttx> #link http://summit.openstack.org/cfp/topicstatus
21:10:18 <ttx> And you can sort proposals by topic by clicking on the "Topic" column header on the main page
21:10:26 <ttx> #topic Openstack-Common topic
21:10:36 <ttx> markmc: right at +10 as promised
21:10:47 <markmc> ttx, I thought it was 9 ?
21:11:00 <markmc> ttx, I think I've got ~15 proposed ?
21:11:16 <ttx> markmc: no, I mean your intervention time in the meeting, 10 minutes after start
21:11:23 <markmc> ttx, ah :)
21:11:23 <ttx> You have 14 proposals for 9 available slots
21:11:27 <markmc> for context ...
21:11:32 * markmc is sitting in a pub :)
21:11:37 <markmc> right
21:11:41 <markmc> ttx, figuring the dependency management might make sense to moving to the process track
21:11:49 <markmc> which leaves 4 to cut
21:11:51 <ttx> yes, I think that would help
21:11:55 <markmc> I think 3 I can just reject
21:11:58 <ttx> All of the rest look interesting
21:12:05 <ttx> There are a few RPC talks that could be merged...
21:12:08 <heckj> I can free up a slot or two from Keystone if that helps - under by 3 right now
21:12:09 <markmc> and 1 or 2 might make more sense on the nova track
21:12:20 <ttx> heckj: that doesn't really help unfortunately
21:12:25 <heckj> :-(
21:12:35 * Vek can't make heads or tails of that graphs page
21:12:37 <ttx> Same around monitoring...
21:12:42 <markmc> the 1 or 2 are new ideas that should really be proved in a specific project before common
21:12:50 <ttx> Also some discussions are likely to not require a full session (httplib one, for example)
21:12:57 <gabrielhurley> Vek: the graph page is broken on wide screens. make your window smaller
21:12:58 <markmc> right
21:13:13 <annegentle> ttx: I don't think the http://summit.openstack.org/cfp/topicstatus is updated for Documentation track?
21:13:15 <ttx> gabrielhurley: yes, I realized that recently. Bad css
21:13:25 <markmc> I don't think the httplib one is really a proposal that we can discuss, so that's one of the ones to pass on
21:13:31 <Vek> gabrielhurley: boy, that is broken.  Thanks for the tip.
21:13:33 <ttx> annegentle: I think it is, but wait for your turn :P
21:13:34 <annegentle> ttx: oh wide screen issue :)
21:14:00 <ttx> #action ttx to fix wide screen on topicstatus screen
21:14:12 <markmc> ttx, basically, I think I can squeeze it into the 9 slots but a slot extra would help
21:14:12 * gabrielhurley is a frontend developer. lol.
21:14:15 <ttx> markmc: I'm available to help you cut
21:14:23 <markmc> ttx, cool
21:14:24 <ttx> Questions ?
21:14:42 <ttx> #topic Process topic
21:14:55 <ttx> I have 14 proposals for 14 available slots.. but markmc will add one
21:15:00 <markmc> what do I do to move deps management to process ?
21:15:21 <ttx> markmc: on your review screen, click on the topic of the session you want to switch
21:15:25 <ttx> I think we have all the important subjects covered
21:15:36 <ttx> I already pre-approved 10, I was waiting on potential topic switches to select the last set
21:15:46 <ttx> Questions on the Process topic ?
21:16:13 <ttx> #topic QA topic
21:16:20 <ttx> davidkranz: o/
21:16:27 <ttx> 8 proposals for 7 available slots
21:16:32 <davidkranz> I have 8 for 7 slots now.
21:16:34 <ttx> Looks like all the important stuff is covered...
21:16:40 <ttx> Upgrade testing, configuration testing, performance testing, gating
21:16:59 <ttx> Suggestions: there are a lot of sessions around integration testing, you can probably regroup them and spare one...
21:17:13 <ttx> Like make only 2 sessions out of "OpenStack configuration Testing", "Gating with integration testing" and "Use of testtools and testrepository"
21:17:29 <ttx> If all else fails, the CirrOS session can certainly move to Unconference room.
21:17:36 <davidkranz> ttx: Yeah. I'm also not sure a whole session is neededd for CirrOS
21:17:52 <davidkranz> ttx: I'll figure something out.
21:18:01 <ttx> davidkranz: ok, let me know if you need help
21:18:08 <ttx> Questions on QA ?
21:18:36 <ttx> #topic Keystone topic
21:18:40 <ttx> heckj: o/
21:18:45 * heckj waves
21:18:50 <ttx> 6 proposals for 9 available slots, all preapproved
21:18:59 <ttx> heckj: Are you expecting/looking for more session proposals ?
21:19:28 <heckj> last summit there were a number of last minute sessions, not sure what to expect this year - I think we have more open than we may fill
21:19:29 <ttx> note that you're placed on the Thursday, where ending early is not that much of an issue
21:20:19 <ttx> heckj: do you have your important subjects already covered by the current proposals ?
21:20:47 <heckj> yep, although I'm sure the federation one will be the trickiest and most prone to bleed widely into other topics
21:21:04 <ttx> yeah
21:21:11 <ttx> Questions on Keystone ?
21:21:36 <ttx> #topic Swift topic
21:21:41 <ttx> notmyname: hey
21:21:43 <notmyname> hi
21:21:49 <ttx> 8 proposals for 8 available slots so far
21:21:57 <notmyname> ya, I hope a few others come in
21:21:58 <ttx> it's been filling up fast today
21:22:01 <notmyname> ya
21:22:48 <ttx> in case of emergency you can probably fold one small session into the feature list walkthrough
21:23:16 <ttx> Questions on the Swift topic ?
21:23:46 <ttx> #topic Glance topic
21:23:50 <ttx> bcwaldon: o/
21:23:54 <bcwaldon> ttx: hey
21:23:59 * ttx refreshes
21:24:11 <ttx> still 2 proposals for 5 available slots
21:24:21 <bcwaldon> ttx: yep, I havent had time to scheuld any yet
21:24:25 <ttx> That's the most undersubscribed topic :)
21:24:32 <bcwaldon> ttx: aw :(
21:24:44 <ttx> I suspect you'll add stuff from you ?
21:24:55 <bcwaldon> yes sir
21:25:02 <bcwaldon> but I do like proxying everything through markwash
21:25:03 <ttx> ok, that should fix it :)
21:25:20 <ttx> yes, markwash-proxying is the new fun, I heard
21:25:36 <ttx> Questions on Glance ?
21:25:52 <ttx> onto the large topics now...
21:26:00 <ttx> #topic Quantum topic
21:26:05 <ttx> danwent: hola
21:26:06 <danwent> o/
21:26:14 <termie> GLANCE
21:26:15 <ttx> 26 proposals for 22 available slots !
21:26:20 <danwent> yup
21:26:31 <danwent> we'll put the now famous "quantum squeeze" on
21:26:33 <bcwaldon> termie: thanks for sticking up for me
21:26:56 <danwent> a fair number can hopefully we be squeezed to half-sessions
21:27:01 <ttx> I'd wear a T-shirt that only shows "Glance"
21:27:06 <danwent> and we'll merge a few more.
21:27:16 <ttx> danwent: so you think it looks good ?
21:27:20 <danwent> i'm actually still expecting a few more to come in
21:27:24 <danwent> yes
21:27:32 <ttx> ahah. You'll love the new merge feature
21:27:40 <ttx> Let me explain it a bit
21:27:40 <danwent> can't wait...
21:27:50 <danwent> i hope its a free upgrade from the "standard" version
21:28:02 <ttx> On the schdeuling screen you can basically drag multiple sessions onto a single time slot
21:28:07 <ttx> scheduling*
21:28:32 <danwent> great… I was just wondering if I was going to have to recreate a bunch of new sessions when merging.
21:28:35 <ttx> The default title is the first one you dragged, and the description is a concatenation of the merged descriptions
21:28:44 <danwent> very nice
21:28:49 <ttx> *you can edit title and add a preface to the concatenation
21:29:17 <ttx> in the end the scheduled session all appear to take only one slot on the graph (if everything works as planned)
21:29:29 <danwent> i'll be your biggest beta tester
21:29:32 <ttx> so you can actually preapprove more than you have
21:29:55 <ttx> as long as you plan to merge them at scheduling time
21:30:09 <ttx> Questions on Quantum ? or on Merging ?
21:30:50 <ttx> #topic Cinder topic
21:30:55 <ttx> jgriffith: bonjour
21:31:04 <jgriffith> ola
21:31:07 <ttx> 7 proposals for 7 available slots
21:31:17 <ttx> Looks good to me :) Do you have all the subjects you want covered ?
21:31:34 <jgriffith> Nope, but I plan to do some juggling tomorrow/Thursday
21:31:41 <jgriffith> Will work out well in the end
21:32:16 <jgriffith> I'll look at unconference sessions as a staple again :)
21:32:23 <ttx> well, in the end you have control, you can just pick sessions your proposed and drop everything else. So it should work out well.
21:32:32 <jgriffith> For me at least :)
21:32:41 <ttx> Questions on Cinder ?
21:33:06 <ttx> #topic Nova topic
21:33:10 <ttx> vishy: o/
21:33:28 <ttx> Looks like 22 proposals for 31 available slots
21:33:36 <vishy> hi
21:33:50 <ttx> Do you have all the subjects you want covered already ? Or is nova-core expected to file more ?
21:34:13 <vishy> i expect there will be more
21:34:31 <ttx> In case of need, there seem to be some merging potential, for example between:
21:34:37 <ttx> "Improving Nova's database consistency" and "Nova database archiving strategy"
21:35:00 <ttx> could fit in a single 40-min slot about database improvements
21:35:15 <ttx> but if you're below the number allocated anyway...
21:35:34 <ttx> note that it makes sense to leave a few empty slots on the Nova topic
21:35:58 <ttx> otherwise it will be hard for you to attend some openstack-common / QA / Process topic, with your track running on all 4 days
21:36:15 <vishy> makes sense
21:36:33 <vishy> lets give it a few more days for proposals to see how it fills up
21:36:37 <vishy> then I will consolidate
21:36:39 <ttx> vishy: will you need help reviewing stuff ?
21:36:59 <ttx> or spend the next Nova meeting on it ?
21:37:40 <vishy> yes i will
21:37:47 <ttx> Questions on Nova ?
21:37:49 <vishy> I'm going to mention it in the meeting on thurs
21:37:56 <ttx> ok
21:38:13 <ttx> #topic Horizon topic
21:38:18 <ttx> gabrielhurley: hello
21:38:26 <ttx> 4 proposals for 9 available slots
21:38:38 <ttx> Does that represent everything you had in mind for Grizzly?
21:38:42 <ttx> or is there more to come ?
21:38:44 <gabrielhurley> yep. I expect to get maybe on more proposed regarding quantum, but that's about it
21:39:02 <gabrielhurley> most of what I want to talk about is cross-project ;-)
21:39:17 <heckj> cant imagine...
21:39:19 <ttx> let me look if we can easily give the slots to someone else
21:39:33 <gabrielhurley> if it helps, feel free to give 3 or maybe even 4 away
21:40:10 <ttx> Hmm, we could give a few more to Cinder or QA
21:40:44 <jgriffith> gabrielhurley: Wanna touch base tomororw EOD and see where Cinder is at?
21:40:53 <gabrielhurley> sounds good to me
21:40:53 <jgriffith> gabrielhurley: and if you have new stuff added
21:41:03 <jgriffith> gabrielhurley: cool!
21:41:45 <ttx> we can make minimal changes to the topic layout
21:41:59 <ttx> since some people made travel plans around where that stuff was supposed to happen
21:42:10 <gabrielhurley> well, I'm happy to be acommodating where possible
21:42:23 <ttx> Looking at https://docs.google.com/spreadsheet/ccc?key=0AmUn0hzC1InKdEtNWVpRckt4R0Z0Q0Z3SUc1cUtDQXc#gid=1
21:43:08 <ttx> it's easy to increase QA or Cinder and reduce Horizon, but not so easy to give sessions from Horizon to openstack-common
21:43:43 <ttx> ok, I'll look into options to recover a few sessions from Horizon
21:44:03 <ttx> #action ttx to see how we can make best use of unused Horizon slots (at least 2)
21:44:15 <ttx> Questions on horizon ?
21:44:45 <ttx> #topic Documentation topic
21:44:51 <ttx> annegentle: o/
21:44:54 <annegentle> ayop
21:45:00 <ttx> 3 proposals left for 3 available slots
21:45:16 <annegentle> yep all full up
21:45:36 <ttx> annegentle: would you have needed more room ? Or will you just overflow to the unconference room if need be ?
21:46:03 <annegentle> ttx: I don't think docs needed another slot
21:46:07 <ttx> trying to see if our preallocation was way off-target
21:46:09 <ttx> annegentle: ok
21:46:14 <annegentle> ttx: and absolutely can overflow to unconf
21:46:34 <annegentle> well we beat glance. Just kidding bcwaldon !
21:46:50 * annegentle cracks herself up
21:46:52 <ttx> fwiw unconference will start on Tuesday, the room in Monday is used by incubation wannabees, Heat and Ceilometer
21:47:04 <ttx> room was always empty on day one anyway
21:47:27 <ttx> Questions on doc ?
21:47:48 <ttx> #topic Open discussion
21:47:54 <ttx> Anything else, anyone ?
21:47:56 <annegentle> o/
21:48:02 <ttx> annegentle: go for it
21:48:10 <annegentle> how would you all define "done" for documentation and the Folsom release?
21:48:16 <annegentle> PTLs especially
21:49:30 <ttx> hmm, would define "done" when all critical/high bugs are covered. which turns the question into what makes a release-critical doc issue...
21:49:34 <danwent> annegentle:  from quantum, i think we're done from a "planned content" perspective.  bug fixes and other minor enhancements will filter in, or course.
21:50:02 <annegentle> we are far from having all High covered, and never have had all High covered…. hm.
21:51:14 <annegentle> and I do feel that the ones marked High are topics asked for from document consumers.
21:52:08 <annegentle> possibly, though, the openstack-manuals project is so wide in scope that we can't target well. One step coming up is to separate out the api docs into another bug tracking Launchpad project. Even so, that doesn't get all High done.
21:52:57 <annegentle> any other input?
21:53:35 <annegentle> vish, bcwaldon, heckj thoughts?
21:53:59 <annegentle> jgriffith: your doc topic is the least updated right now, do you have a sense of when you'd be comfortable with a "release" doc?
21:54:48 <jgriffith> annegentle: End of week I'm hoping
21:55:09 <ttx> annegentle: do you think we can have an objective metric to measure "release quality" when it comes to doc ?
21:55:44 <heckj> annegentle: tricky question - I don't have a good answer on what's "done"
21:55:51 <jgriffith> ttx: annegentle any thoughts to requiring docs for new feature submits going forward?
21:56:01 <annegentle> ttx: doc bugs to recognize gaps help. But, it's hard to say "don't release until all doc bugs are closed"
21:56:02 <jgriffith> Actually, controversial question for everyone I guess
21:56:25 <annegentle> jgriffith: mostly the people submitting patches don't have enough of a production system to write operator-level docs.
21:56:48 <annegentle> jgriffith: it comes up all the time, but I'd rather have devs write for devs and operators write for operators
21:56:53 <ttx> annegentle: well, docs are never "finished" or "complete"... per themselves. But you can come up with objectives and track their completion
21:57:00 <annegentle> ttx: absolutely.
21:57:04 <ttx> annegentle: a bit like we do for feature blueprint
21:57:37 <ttx> annegentle: even if that means reducing importance of some (so that they are no longer release-blocking) when we approach deadliens and see that our velocity is not high enough
21:58:21 <ttx> annegentle: the trick is, the timeframe is slightly different from core projects release
21:58:48 <annegentle> ttx: docs are in much better shape than ever before
21:58:53 <ttx> no point in working on documenting options at grizzly-1
21:59:02 <annegentle> ttx: right
21:59:41 <ttx> annegentle: i'd say it's an ongoing discussion. I'll try to think about it and share my thoughts with you in San Diego
21:59:44 <annegentle> ttx: I think that I've been mentally "reducing importance of some (so that they are no longer release-blocking)" but perhaps need to mark them as so in launchpad
22:00:04 <annegentle> ttx: would like some assistance in the actual triaging if you're willing
22:00:10 <ttx> annegentle: for the core projects I've been using "essential" in blueprints to mean "release blocking"
22:00:20 <annegentle> ttx: ok, noted
22:00:32 <annegentle> thanks for the discussion
22:01:02 <ttx> that said, I'm usually so much of a pain with essential blueprints (in order to be 99.99% sure they hit) that PTLs now hesitate to put them as high
22:01:19 <ttx> except bcwaldon, who puts all blueprints to "essential"
22:01:26 <annegentle> heh.
22:01:31 <ttx> ok, anything else anyone ?
22:02:01 <ttx> #endmeeting