21:02:31 <ttx> #startmeeting project
21:02:31 <openstack> Meeting started Tue Oct 23 21:02:31 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:33 <openstack> The meeting name has been set to 'project'
21:02:35 <vishy> o/
21:02:38 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:54 <ttx> #topic Design Summit feedback
21:03:07 <ttx> While it's hot, any comment on the OpenStack Summit in general, and the Design Summit track in particular ?
21:03:29 <notmyname> the content/audience match was off for me
21:03:36 <ttx> Did the format work OK ? (4 days with 4 parallel topics + 1 unconference, running parallel to rest of Summit)
21:03:45 <MarkAtwood> i enjoyed being there, but i was notincg a scaling issue with the design meetings
21:04:09 <jgriffith> I think paralell introduced some challenges in the design sessions
21:04:14 <ttx> MarkAtwood: as in too many people in design summit sessions ?
21:04:14 <russellb> by day 4 of design summit sessions i was fried.
21:04:15 <gabrielhurley> I missed being able to attend more of the "use case"-type talks, but otherwise didn't mind the format.
21:04:25 <ttx> My voice was fried on day 1
21:04:31 <danwent> yeah, i felt like there were a lot of "conference" people in the "summit" session.  Also, after 3 days of sessions, I was fried.
21:04:32 <heckj> more user feedback during sessions == goodness, but less brainstorming/design that didn't go off the rails with lots of relatively uninformed voices
21:04:33 <russellb> yeah, i didn't get to any of the non-design sessions, which would have been nice
21:04:56 <vishy> 4 days was pretty brutal for nova
21:05:00 <jgriffith> But having people asking how object store in cinder works in design sessions was wasteful
21:05:10 <ttx> vishy: could you have done with less ?
21:05:33 <russellb> some of the nova sessions could have been vetted more and then not done at all
21:05:33 * vishy didn't notice the issue that danwent and notmyname are mentioning
21:05:39 <gabrielhurley> though I agree on the occasional audience mismatch, I also found I ended up talking to people who otherwise wouldn't have been in design sessions and that's (occasionally) good for growing the base.
21:05:42 <vishy> maybe they flocked to quantum and swift :)
21:05:47 <notmyname> :-)
21:05:51 <russellb> so we probably could have done 3 days of good sessions
21:05:56 <jeblair> quantum had a huge number of quiet people in the room...
21:06:04 <russellb> zomg networkz
21:06:07 <ttx> the trick is that there is no good way of refining attendance, short of making the design summit invite-only..; which sends the wrong message
21:06:13 <heckj> quantum was attrociously packed
21:06:18 <danwent> yeah
21:06:27 <jgriffith> ttx: I think splitting helped with some of that
21:06:29 <lloydde> the user sessions were over cap too
21:06:48 <ttx> so plan B (try to attract business types in other rooms) kinda worked
21:06:48 <MarkAtwood> it may be worth social engeineering, put in the conference schedule, the guids, and in signs on the doors to the sessions
21:06:54 <danwent> well, i think its really that there's the overlap between the conference and the summit, and conference people decided to hang out in sessions, even though there was no intent to contribute code, and no experience using openstack.
21:07:04 <jgriffith> danwent: ++++1
21:07:16 <MarkAtwood> "this is an advanced session, not a training session, please contribute if you are up to speed"
21:07:27 <MarkAtwood> rewritten for grace and diplomacy, of course
21:07:29 <danwent> if this happened for jgriffith but not vishy, perhaps its more for the newer projects where people are more curious
21:07:34 <ttx> MarkAtwood: there were pretty obvious signs that they were entering development zone
21:07:37 <jeblair> since "ci" topics were on a separate track, it meant that we often didn't get people we would have liked.  having more PTLs to talk about testr and distribution support would have been esuful.
21:07:42 <ttx> but maybe we can separate the events more
21:07:50 <danwent> ttx: that is my thinking
21:07:55 <ttx> Next time, 4th floor !
21:08:01 <jgriffith> LOL
21:08:04 <ttx> Or solve a riddle to get there
21:08:05 <russellb> basement!
21:08:09 <jgriffith> No escalator!
21:08:09 <russellb> with a scary entrance
21:08:19 <danwent> haha… time separation > space separation
21:08:26 <gabrielhurley> Even just marking how "advanced" a particular session is might be helpful
21:08:31 <ttx> time separation won't work. They will come
21:08:56 <danwent> it was better before we combined days
21:08:56 <MarkAtwood> require foundation membership and/or signed contributoir agreement?
21:09:00 <jgriffith> Regardless, it was workable but I was done by Thursday for sure
21:09:02 <danwent> (at least from my perspective)
21:09:06 <vishy> how about a terminal where you have to do a series of git commands to unlock the door
21:09:11 <danwent> vishy: ++
21:09:14 <jgriffith> vishy: Nice!!!
21:09:14 <vishy> :)
21:09:16 <koolhead17> vishy, :P
21:09:22 <jeblair> vishy: a lot of devs would fail that.  :(
21:09:24 <jgriffith> I say we vote!
21:09:51 <ttx> ok, well if you've a good suggestion, please send it my way
21:09:52 <jgriffith> can you clone the nova repo?  You're in
21:10:11 <russellb> or a simple python task ...
21:10:11 <ttx> since format on the next one should be decided pretty quickly
21:10:22 <ttx> by default, the same format will be done again
21:10:32 <ttx> though we can discuss separation / special badges
21:10:39 * jgriffith will start training for it
21:10:47 <ttx> and/or reducing days / parallel tracks
21:10:54 <ttx> #topic Grizzly release schedule
21:11:04 <ttx> We looked into the proposed schedule at the Design Summit
21:11:09 <ttx> Here is the final proposal:
21:11:14 <ttx> #link http://wiki.openstack.org/GrizzlyReleaseSchedule
21:11:18 <ttx> (no change since Friday)
21:11:23 * gabrielhurley likes special badges
21:11:24 <ttx> err Thursday
21:11:41 <ttx> Business summary: It is the same as the Folsom schedule, with one additional week in the second milestone to account for the Christmas holidays.
21:11:53 <ttx> Any comment before we officialize it ?
21:12:55 <ttx> I guess not.
21:13:07 <ttx> #agreed http://wiki.openstack.org/GrizzlyReleaseSchedule
21:13:17 <ttx> #topic Oslo status
21:13:24 <ttx> russellb: hey
21:13:30 <russellb> hey
21:13:35 <ttx> So I added Oslo (openstack-common library name) as a regular status report in this meeting
21:13:41 <russellb> sounds good.
21:13:53 <ttx> russellb: does markmc want to track the blueprint work at launchpad.net/openstack-common or launchpad.net/oslo ?
21:13:53 <russellb> so out of the summit, moving forward with libraryification is the #1 priority
21:14:11 <ttx> need to create a grizzly series wherever you prefer
21:14:12 <russellb> good question.  we already have a lot of history in openstack-common ... can be it be moved?
21:14:37 <ttx> it.. can. Might be shorter to rename project though
21:14:55 <ttx> #action ttx to see with markmc to move openstack-common to oslo
21:15:12 <ttx> #action ttx to create grizzly series wherever needed
21:15:22 <ttx> (and milestones)
21:15:24 <russellb> looks like oslo-cfg is the targeted first library release
21:15:33 <ttx> The idea is to come up, in the next two weeks, with a good roadmap for Grizzly objectives
21:15:54 <ttx> Get people to file blueprints, set series goal to "grizzly" where appropriate... prioritize them and target to a given milestone
21:16:02 <russellb> k, markmc will be back next week, i don't think it will be a problem to work through the roadmap before 2 weeks from now based on summit output
21:16:05 <ttx> we might need to clarify the versioning question first
21:16:23 <ttx> #action ttx to discuss oslo versioning with mordred and markmc
21:16:49 <russellb> cool, don't think I have anything else to report
21:16:52 <ttx> russellb: Anything else you wanted to mention ?
21:16:58 <ttx> Questions on Oslo ?
21:17:23 <bcwaldon> yes
21:17:34 <ttx> bcwaldon: go for it
21:17:35 <bcwaldon> I'd like to hear an explanation of the scope of Oslo
21:17:44 <bcwaldon> and what code should live there
21:18:04 <russellb> code useful for multiple openstack projects, but not necessarily generally useful outside of openstack
21:18:14 <bcwaldon> russellb: thats still rather generic, no?
21:18:19 <russellb> it is, indeed.
21:18:25 <russellb> but Oslo will not be one library
21:18:31 <bcwaldon> russellb: ok, if thats then intention, then ok
21:18:35 <russellb> the plan is to have multiple libraries released under the oslo namespace
21:18:38 <ttx> http://wiki.openstack.org/CommonLibrary has a good set of rules of thumb
21:18:47 <bcwaldon> russellb: and I'd love to hear when we can consume Oslo as an importable library rather than carrying it everywhere
21:19:00 <bcwaldon> i might just be out of ze loop
21:19:03 <russellb> asap basically, but it's one API at a time
21:19:09 <heckj> bcwaldon: +1 - I know it's the top priority
21:19:11 <russellb> so oslo-cfg will be the first library
21:19:22 <bcwaldon> ok, carry on then
21:19:51 <ttx> Any other question ?
21:19:56 <russellb> understand the managed copy-paste thing is a pain, but hopefully it's better overall than unmanaged copying around
21:20:12 <bcwaldon> russellb: yes, but only slightly
21:20:16 <ttx> markmc had a good list of library candidates at the summit session, he should be able to publicize it more clearly
21:20:17 <russellb> :)
21:20:23 <ttx> #topic Keystone status
21:20:24 <russellb> yup
21:20:28 <ttx> heckj: o/
21:20:35 <ttx> #link https://blueprints.launchpad.net/keystone/grizzly
21:20:43 <ttx> #action ttx to create milestones according to Release Schedule
21:20:48 <heckj> collating blueprints from the summit and starting to work out who's going to do what
21:20:54 <ttx> heckj: you should already be able to target the ones that will land in grizzly-1
21:21:05 <ttx> heckj: same as oslo, the idea is to come up with a good roadmap in the next two weeks
21:21:13 <heckj> ttx: agreed
21:21:38 <ttx> Set the series goal for all the relevant ones to "grizzly"
21:21:47 <ttx> You can also clean up https://blueprints.launchpad.net/keystone by setting some of them obsolete/superseded
21:22:07 <ttx> Note that there is one that was "proposed" for Grizzly, that you may want to review @ https://blueprints.launchpad.net/keystone/grizzly/+setgoals
21:22:08 <heckj> started, but not complete in both spaces, as well as generally prioritizing them all
21:22:19 <ttx> heckj: Cool. Anything else ?
21:22:44 <ttx> Did your sessions go well ?
21:22:49 <heckj> great feedback at the summit, looking to take the general interest into solid implementation over the next couple of months
21:22:57 <ttx> Questions about Keystone ?
21:23:21 <ttx> #topic Swift status
21:23:24 <notmyname> o/
21:23:25 <ttx> notmyname: hi!
21:23:32 <ttx> Any idea what your next version should be called ? 1.8.0 ? 1.7.6 ?
21:23:43 <ttx> I'd like to create the first Grizzly milestone for you so that stuff can be targeted to it -- maybe we can pick a name and rename it later if you change your mind ?
21:23:51 <notmyname> we're still tracking for 1.7.5 on trunk
21:24:11 <ttx> maybe I should just call it 1.7.5 and rename it if needed later ?
21:24:15 <notmyname> ya
21:24:23 <notmyname> so far, I expect this one to be 1.7.4
21:24:25 <notmyname> err
21:24:27 <notmyname> 1.7.5
21:24:32 <ttx> #action ttx to create 1.7.5 milestone in swift/grizzly
21:24:35 <ttx> Also you have one "proposed for Grizzly" blueprint in https://blueprints.launchpad.net/swift/grizzly/+setgoals that you may want to review
21:24:58 <ttx> notmyname: anything else ? How were the Swift sessions at the Design Summit ?
21:25:28 <notmyname> the sessions were ok. lot's on interested but uninformed people at the design sessions. but we had some good discussions at times
21:26:09 <notmyname> overall I'm excited about what things will be added in grizzly
21:26:17 <ttx> Re: uninformed people: be sure to mention that in the official survey that should come out soon -- will give us more leverage to negociate more separation
21:26:28 <ttx> Questions on Swift ?
21:27:06 <ttx> #topic Glance status
21:27:11 <ttx> bcwaldon: o/
21:27:13 <bcwaldon> hey hey
21:27:14 <ttx> #link https://blueprints.launchpad.net/glance/grizzly
21:27:18 <ttx> Looks well advanced already...
21:27:25 <bcwaldon> why thank you
21:27:28 <ttx> You might want to parse https://blueprints.launchpad.net/glance and mark obsolete/superseded accordingly
21:27:35 <bcwaldon> yep
21:27:49 <bcwaldon> havent been able to do the first pass of tactical planning after the summit yet
21:28:09 <ttx> and try to come up with a reasonable grizzly plan two weeks from now
21:28:22 <ttx> does that sound doable ?
21:28:31 <bcwaldon> set the bar low
21:28:33 <bcwaldon> fantastic
21:28:47 <ttx> Well, I'll skip next week's meeting, so ... ;)
21:28:49 <ttx> bcwaldon: Anything else ?
21:29:01 <bcwaldon> I did want to thank all those that attended the Glance summit sessions
21:29:08 <bcwaldon> they were very targeted
21:29:14 <bcwaldon> we had all the discussions we needed to
21:29:17 <ttx> I missed them all, hope you wren't alone in those
21:29:23 <bcwaldon> not at all
21:29:44 <ttx> not too much noise / people without a clue ?
21:29:54 <bcwaldon> nope, Glance is rather small and unintersting
21:30:04 <ttx> Looks like it's only Swift/Quantum that were invaded
21:30:14 <ttx> openstack-common and Process were alright
21:30:29 <ttx> Questions on Glance ?
21:30:33 <bcwaldon> Glance only had 3 sessions, so we didnt give the masses much of a chance
21:30:45 <ttx> Pick boring titles, that's the key
21:30:52 <bcwaldon> you've figured me out!
21:30:57 <ttx> "Stable branch maintenance"
21:30:59 <bcwaldon> Image Workers
21:31:05 <ttx> bcwaldon: lol
21:31:09 <bcwaldon> that was for you, markwash
21:31:17 <bcwaldon> ...moving on
21:31:24 <ttx> #topic Quantum status
21:31:29 <ttx> danwent: hey
21:31:35 <ttx> #link https://blueprints.launchpad.net/quantum/grizzly
21:31:50 <danwent> hey
21:31:59 <ttx> Don't forget to set priorities when you add a blueprint to the "grizzly" series goal
21:32:06 <danwent> at team meeting yesterday we went over all key blueprints that need to be filed for g-1
21:32:18 <ttx> Same as others, now is a good time to go through https://blueprints.launchpad.net/quantum and mark obsolete/superseded accordingly
21:32:20 <danwent> but i'd say about 2/3 have not yet been filed
21:32:33 <ttx> A number of blueprints have been "proposed" for grizzly, so you might want to review them at: https://blueprints.launchpad.net/quantum/grizzly/+setgoals
21:32:38 <danwent> yup, makes sense
21:32:46 <ttx> 8 in there
21:33:14 <ttx> So yeah, start with G1 objectives, and try to come up with a longer grizzly roadmap in two weeks time
21:33:23 <ttx> danwent: Anything else ?
21:33:25 <danwent> nope
21:33:35 <ttx> Questions on Quantum ?
21:34:29 <ttx> Even if we don't have a meeting next week, expect me to push for blueprints by IRC pings... just no need to have another meeting to say "one more week!"
21:34:38 <ttx> #topic Cinder status
21:34:41 <ttx> jgriffith: o/
21:34:50 <ttx> #link https://blueprints.launchpad.net/cinder/grizzly
21:34:50 <jgriffith> hey there
21:34:57 <ttx> Nothing in there yet :)
21:35:00 <jgriffith> I have 2 weeks to clean this up :)
21:35:03 <ttx> There are two proposed @ https://blueprints.launchpad.net/cinder/grizzly/+setgoals
21:35:14 <ttx> Looks like you can also parse https://blueprints.launchpad.net/cinder for good grizzly candidates
21:35:25 <ttx> and obsolete/supersede the others
21:35:36 <ttx> How dod the Cinder sessions go ?
21:35:43 <ttx> did*
21:35:44 <jgriffith> Yep, we're in the process of creating session outcomes to bp's
21:35:56 <jgriffith> Really well for the first Cinder summit (IMO)
21:36:19 <jgriffith> some sessions had the looky-lou problem
21:36:21 <jgriffith> but all in all
21:36:24 <ttx> Got enough time to discuss what you needed ?
21:36:49 <jgriffith> yes, I think any more time would've just caused more trouble
21:36:53 <ttx> jgriffith: Anything else ?
21:36:56 <jgriffith> Nope
21:36:58 <ttx> Questions on Cinder ?
21:37:27 <ttx> #topic Nova status
21:37:31 <ttx> vishy: o/
21:37:31 <creiht> cinder rooms could have been larger :)
21:37:39 <vishy> hi
21:37:41 <ttx> #link https://blueprints.launchpad.net/nova/grizzly
21:38:03 <ttx> Also 7 proposed at https://blueprints.launchpad.net/nova/grizzly/+setgoals
21:38:10 <vishy> there will be a lot more in there
21:38:15 <ttx> and loads of potential cleanup in https://blueprints.launchpad.net/nova as always :)
21:38:31 <vishy> I'm currently going through session notes and trying to crystalize them into decisions and blueprints
21:38:38 <vishy> probably will take me until next week
21:38:38 <ttx> vishy: is two weeks reasonable to come up with a realatively sane grizzly roadmap ?
21:39:47 <vishy> sure
21:39:53 <vishy> two weeks seems reasonable
21:39:55 <ttx> vishy: you mentioned you could have done with less Nova at the summit ?
21:40:04 <vishy> well i just was fried by the end
21:40:04 <ttx> what would have been the good length ? 3 days ?
21:40:11 <vishy> I think 3 days for nova
21:40:18 <vishy> and a day off to peruse other tracks or sleep
21:40:21 <vishy> would be good :)
21:40:34 <ttx> then have other connected topics on the 4th day (process/qa/common etc)
21:40:50 * ttx tries to internalize all feedback
21:41:00 <ttx> vishy: Anything else ?
21:41:14 <vishy> nothing for me
21:41:24 <ttx> vishfacts: Vish can attend all sessions of the Design Summit.
21:41:33 <ttx> Questions on Nova ?
21:41:56 <gabrielhurley> vish doesn't attend the design summit, the design summit attends vish.
21:42:15 <ttx> #topic Horizon status
21:42:32 <ttx> gabrielhurley: I didn't follow, were you Dope or Stack ?
21:42:37 <gabrielhurley> I was Terrence Dope
21:42:57 <gabrielhurley> http://dopenstack.com
21:42:58 <ttx> you'll always be Terrence Dope now
21:43:04 <ttx> #link https://blueprints.launchpad.net/horizon/grizzly
21:43:13 <ttx> Looks pretty good to me already :)
21:43:18 <gabrielhurley> yeah, I've been grooming it
21:43:26 <ttx> You might want to parse https://blueprints.launchpad.net/horizon and mark obsolete/superseded the ones that are polluting the view, if any
21:43:29 <gabrielhurley> I opened a whole slew of new blueprints after the sumit
21:43:31 <ttx> rather than let them pile up
21:44:10 <gabrielhurley> they're actually more-or-less all correct
21:44:17 <gabrielhurley> and should be targeted to either G or H
21:44:26 <ttx> gabrielhurley: did you end up having enough, or too much time on the Horizon topic for the summit ?
21:44:43 <gabrielhurley> just about right. I spend most of my Horizon time talking about cross-project stuff anyhow.
21:44:55 <ttx> yeah
21:45:00 <ttx> gabrielhurley: anything else ?
21:45:01 <gabrielhurley> attendance was good, and the sessions were excellent. thanks for everyone involved!
21:45:27 <gabrielhurley> can't think of anything urgent. I've got some stuff to bring tothe mailing list in the next week or so.
21:45:29 <ttx> I really enjoyed the process ones I attended. For some reason there were not tha many people around and we had good discussions
21:45:46 <ttx> +1 for being boring
21:45:51 <ttx> Questions for Horizon ?
21:46:26 <ttx> #topic Other Team reports
21:46:33 <ttx> QA, CI: anyone ?
21:46:56 <ttx> davidkranz: want to give some feedback from QA topic at the Summit, if around ?
21:47:19 <davidkranz> ttx: Sure.
21:47:31 <ttx> davidkranz: how did that go ?
21:47:43 <davidkranz> Pretty well I think. The trick is the follow through.
21:48:01 <davidkranz> Rackspace is going to upload all their tests soon.
21:48:08 <ttx> davidkranz: did you get the people you needed on those sessions ?
21:48:16 <ttx> and not too many of the people you didn't need ?
21:48:37 <davidkranz> We didn't have many ptls, but we used one of Dan's sessions for the quantum stuff which was the most important.
21:48:51 <mordred> davidkranz: we've already made progress on testtools/testr and I think you're going to like it
21:48:57 <ttx> I think it's easier this way around
21:49:02 <davidkranz> Dan Prince was interested in more use of SmokeStack.
21:49:11 <davidkranz> mordred: That's great.
21:49:26 <ttx> davidkranz: anything else ?
21:49:52 <davidkranz> ttx: We also had some in-person QA meetings with summaries posted to the qa list.
21:50:00 <davidkranz> ttx: That's about it.
21:50:08 <ttx> Any other team lead with a status report ?
21:50:12 <mordred> tons of sessions involved cI
21:50:14 <mordred> https://etherpad.openstack.org/state-of-ci
21:50:20 <mordred> there's what we collected overall
21:50:24 <mordred> for those who are interested
21:50:32 <mordred> also, if you didn't notice, we have a new etherpad server
21:50:38 <ttx> mordred: I think the Process topic went well overall, what do you think ?
21:50:44 <mordred> I agree too
21:50:59 <ttx> mordred: people too fried to disagree with moderator
21:51:09 <mordred> I do not really remember any contentious topics
21:51:34 <ttx> mordred: I just rememberd that we need to discuss oslo versioning once markmc will be back
21:51:40 <mordred> yes
21:51:51 <ttx> i.e. aligned vs. tag vs. forward vs. pip
21:51:52 <russellb> ttx: you set that as an action back in the oslo topic
21:51:58 <ttx> yep
21:52:04 <ttx> #topic Open discussion
21:52:12 <ttx> #info We'll skip the meeting next week
21:52:22 <ttx> As mordred knows, i'll have better things to do
21:52:35 <ttx> and I don't expect the plans to be finalized anyway
21:52:46 <ttx> So not so much to discuss in-meeting
21:52:50 <mordred> see you all at UDS next week...
21:52:52 * mordred cries
21:52:56 <ttx> I'll bug you all in the next two weeks so that we make progress on that though.
21:53:01 * russellb won't be there :-p
21:53:06 <ttx> (that being, grizzly plans)
21:53:24 <ttx> Anything else, anyone ?
21:53:42 <ttx> Next meeting on Nov 6
21:54:04 <ttx> WARNING WARNING we are entering DST confusion zone
21:54:12 <ttx> Europe drops DST this weekend
21:54:33 <ttx> Please triple-check meeting times (they are in UTC!) before going to one
21:54:57 <ttx> #endmeeting