21:01:59 <ttx> #startmeeting project
21:01:59 <openstack> Meeting started Tue Nov 13 21:01:59 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:01 <openstack> The meeting name has been set to 'project'
21:02:07 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:18 <ttx> #topic Actions from previous meeting
21:02:26 <ttx> All done, will detail in each section
21:02:37 <ttx> #topic Horizon status
21:02:44 <ttx> gabrielhurley: still there ?
21:02:48 <gabrielhurley> heh
21:02:48 <gabrielhurley> yes
21:02:50 <gabrielhurley> for now
21:02:52 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-1
21:03:03 <ttx> Looks a bit late to me... still feeling good about all those ?
21:03:05 <gabrielhurley> not a lot of change since last week. I need to do some hacking on my two BPs over the weekend but they'll be fine.
21:03:16 <ttx> Especially wondering about the 2 "not started" ones :)
21:03:17 <gabrielhurley> I reached out to "Ray" for a status on that last BP but no response yet
21:03:28 <gabrielhurley> I'll reassign and retarget if i don't get anything in a day or two
21:03:40 <gabrielhurley> and actually the "needs code review" one is merged
21:03:43 <gabrielhurley> I'll close that
21:03:47 <ttx> yes, sounds good. Everything else on track ?
21:03:57 <ttx> like "Unify Horizon Config" ?
21:04:04 <gabrielhurley> yeah. that one's fine
21:04:10 <gabrielhurley> just need to wrap it up
21:04:12 <ttx> ok
21:04:14 <ttx> #link https://blueprints.launchpad.net/horizon/grizzly
21:04:26 <ttx> Should we tentatively assign file-upload-redux & inline-table-editing to team "Nebula", so that I know you will cover it ?
21:04:33 <ttx> I kinda like to have at least a vague idea of an assignee on High priority stuff.
21:04:39 <gabrielhurley> I could do that, sure
21:04:48 <ttx> great
21:04:51 <gabrielhurley> I'll make sure anything high priority is assigned
21:04:56 <ttx> gabrielhurley: anything else ?
21:05:02 <gabrielhurley> don't believe so
21:05:14 <ttx> Questions for Horizon ?
21:05:37 <ttx> #topic Oslo status
21:05:41 <ttx> markmc: hey
21:05:45 <markmc> hey
21:05:46 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-1
21:05:55 <ttx> About https://blueprints.launchpad.net/oslo/+spec/oslo-release-versioning
21:06:02 <ttx> I started the discussion on the ML, so it could be marked as "started", I guess
21:06:14 <markmc> ttx, yeah, thanks for that - will ponder and reply
21:06:17 <ttx> Is there more to it than just completing that discussion ?
21:06:24 <ttx> Did you plan to release any library before g1 ?
21:06:24 <markmc> nope, just the discussion
21:06:35 <markmc> I'm hoping to do oslo-config, but it's tight
21:06:51 <markmc> the argparse re-write is pretty close, but involves some API changes
21:06:54 <ttx> Should the library initial releases appear as blueprints so that we track their completion ?
21:06:55 <heckj> markmc: I'll follow on ML, but wanted to sort out how we were going to do documentation for these various libraries and how that matched to releases/repos.
21:06:59 <markmc> so on the fence about rushing a release out with it
21:07:05 <markmc> ttx, good point
21:07:21 <ttx> markmc: no point in rushing them if no core project makes use of them in the milestone anyway
21:07:29 <markmc> #action markmc file blueprint for oslo-config release
21:07:36 <bcwaldon> markmc: you should use glance as your guinea pig
21:07:43 <markmc> bcwaldon, sounds good
21:07:48 <ttx> i.e. they can be release early in g2 and then get all projects to use them instead of codecopy
21:07:59 <markmc> good idea
21:08:21 <ttx> no real point in having it out "at g1"
21:08:23 <markmc> it's only going to be oslo-config, nothing else ready I think
21:08:29 <ttx> #link https://blueprints.launchpad.net/oslo/grizzly
21:08:56 <ttx> Looks good now
21:09:10 <ttx> markmc: Anything else ?
21:09:17 <markmc> nope, that's it
21:09:26 <markmc> appreciate everyone's input on oslo plans
21:09:29 <ttx> Oh, had a question about common-binaries. You're doing it ?
21:09:31 <markmc> and renaming the repo, etc.
21:09:38 <markmc> ttx, yep, I'll do that
21:09:45 <heckj> markmc: question for you
21:09:47 <annegentle_> markmc: more details on doc plans would be useful
21:09:55 <ttx> Cool, was planning to do it but you can certainly achieve it faster than I would
21:10:01 <heckj> markmc: what's the general plan around providing docs for these libraries? ANy high level outline?
21:10:18 <heckj> (just submitted a review that expands and builds docstrings -> sphinx)
21:10:19 <markmc> annegentle_, yeah - oslo-config is actually a good test case, because cfg actually has fairly good docs inline
21:10:28 <markmc> annegentle_, just need to figure out how to publish them
21:10:44 <markmc> heckj, then you've done more on this than anyone else :)
21:10:56 <annegentle_> go heckj go
21:10:59 <markmc> heckj, it's important, should figure it out as part of the oslo-config release
21:11:18 <heckj> hence the question - didn't know if they were going to fragment, or be consolidated… would prefer consolidated if at all possible.
21:11:33 <heckj> (from a writing it point of view anyway)
21:11:41 <heckj> I can follow up in email/ML
21:11:45 <ttx> other questions on Oslo ?
21:11:48 <annegentle_> markmc: doc builds being published during dev are useful then release them as well - but would also probably need some overall doc arch
21:11:50 <markmc> each package will have its own docs
21:11:57 <annegentle_> probably what heckj is getting at
21:12:44 <ttx> ok, I guess we are done with oslo, moving on
21:12:46 <annegentle_> markmc: we can talk more on ML
21:12:50 <ttx> #topic Keystone status
21:12:55 <ttx> heckj: o/
21:12:56 <markmc> annegentle_, yep, thanks
21:13:00 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-1
21:13:35 <ttx> Looks good to me. Confident all those are going to hit before next week ?
21:14:01 <heckj> V3 api is going slow getting it in, but we're looking good to have a full tech preview
21:14:35 <heckj> auth_token middleware is in keystoneclient as of this morning, the BP remains open to finish the transition
21:14:43 <ttx> heckj: so there will be a "refine V3 API" targeted at grizzly-2 ?
21:15:04 <heckj> and keystoneclient just had some major updates - we'll be releasing a 0.2 keystoneclient near the end of this week
21:15:13 <bcwaldon> heckj: what does the general path look like for projects to use the middleware from the new location?
21:15:21 <Vek> heckj: hope my patch gets in to that...
21:15:33 <heckj> ttx: I expect so, but a lot of that work is covered under more specific blueprints
21:15:35 <bcwaldon> heckj: and will you import the middleware from keystoneclient into a location in keystone to keep backwards compat?
21:15:44 <ttx> heckj: I think from a features communication standpoint it would be good to complete the blueprint that covers the full tech preview
21:16:01 <ttx> heckj: so that it's clear that it hit at g1
21:16:08 <heckj> bcwaldon: can do - don't think that was explicitly in our plans.
21:16:46 <ttx> #link https://blueprints.launchpad.net/keystone/grizzly
21:16:59 <ttx> Looks all good to me.
21:17:19 <ttx> heckj: Anything else you wanted to mention ?
21:17:50 <heckj> lots of early motion, good progress. That's it!
21:17:53 <ttx> Questions about Keystone ?
21:18:30 <ttx> #topic Swift status
21:18:34 <notmyname> o/
21:18:34 <ttx> notmyname: hi!
21:18:50 <ttx> Just released today: https://launchpad.net/swift/grizzly/1.7.5
21:19:08 <notmyname> it's a great release. I'm working on an announcement email/post today
21:19:08 <ttx> notmyname: did you announce it yet ?
21:19:11 <ttx> ok
21:19:35 <ttx> notmyname: you can post to openstack-announce too, I'll make sure it passes the ML filter
21:19:42 <notmyname> ok
21:20:07 <ttx> notmyname: A bit early I guess to talk about next grizzly version... 1.7.6 ?
21:20:30 <notmyname> ya, a bit early, but there has been some cleanup of the bugs and blueprints
21:21:09 <ttx> notmyname: I can setup a 1.7.6 milestone, without date, so that people can target at the "next" milestone.. we can change name and date later ?
21:21:19 <notmyname> yes. sounds good
21:21:34 <ttx> #action ttx to set up swift 1.7.6 milestone, no eta yet
21:21:37 <ttx> notmyname: anything else ?
21:21:52 <notmyname> just the release. that's all
21:22:06 <ttx> Questions on Swift ?
21:22:34 <ttx> #topic Glance status
21:22:40 <ttx> bcwaldon: hey
21:22:45 <bcwaldon> ttx: oh hey
21:22:45 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-1
21:22:57 <ttx> now that's what I call done
21:23:06 <bcwaldon> ttx: why thank you
21:23:14 <bcwaldon> ttx: we'll probably pull some more on over the next week
21:23:25 <ttx> #link https://blueprints.launchpad.net/glance/grizzly
21:23:27 <bcwaldon> ttx: probably just 'whatever happens to get fixed'
21:24:09 <ttx> admittedly 2 blueprints over a total of 12 is not that great of a % on the overall grizzly plan :)
21:24:25 <bcwaldon> ttx: come on now
21:24:27 <bcwaldon> ttx: be nice
21:24:45 <ttx> I play good cop AND bad cop at the same time.
21:24:55 <ttx> So.. on the grizzly plan
21:25:08 <Vek> boy, talk about split personalities...
21:25:14 <ttx> Would be good to  set a priority to streaming-server
21:25:23 <ttx> and set tentative target milestones, especially on essential/high stuff
21:25:39 <bcwaldon> ttx: yes, that might not line up with our priorities for grizzly
21:25:48 <bcwaldon> ttx: I'm thinking through the rest right meow
21:26:13 <ttx> bcwaldon: great. Anything else ?
21:26:26 <bcwaldon> ttx: No, officer
21:26:31 <ttx> Questions on Glance ?
21:27:13 <ttx> #topic Quantum status
21:27:16 <ttx> danwent: o/
21:27:21 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-1
21:27:23 <danwent> o/
21:27:33 <ttx> good progress overall... but only one week left
21:27:42 <ttx> Anything you would drop of this (long) list to ensure focus on the rest ?
21:27:44 <danwent> yup, everything will be posted for a review by wed, or moved out
21:27:52 <ttx> sounds good.
21:28:37 <ttx> #link https://blueprints.launchpad.net/quantum/grizzly
21:28:52 <danwent> i priortized everything
21:28:59 <danwent> prioritized :)
21:29:06 <ttx> let me refresh
21:29:55 <ttx> looks like everything was covered recently :)
21:30:03 <danwent> yup
21:30:44 <ttx> Would be good to set a milestone for ipv6-feature-parity & make-string-localizable
21:30:49 <ttx> since theyare "high" prio
21:31:01 <ttx> otherwise looks good!
21:31:06 <danwent> ok, will ping the dev on the v6 one.  I think we may still need to find someone for localization
21:31:19 <danwent> ah, looks like someone signed up
21:31:20 <danwent> will do
21:31:26 <ttx> danwent: Anything else ?
21:31:29 <danwent> nope
21:31:35 <ttx> Questions on Quantum ?
21:32:01 <ttx> #topic Cinder status
21:32:05 <ttx> jgriffith: o/
21:32:09 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-1
21:32:12 <jgriffith> ttx: hey there
21:32:40 <ttx> OK, this this looks in slow progress... with only one week left ?
21:33:18 <jgriffith> The ones that aren't started should be quick and I plan to pick them up this week-end if they don't get done
21:33:39 <jgriffith> The first two items just need to make it through reviews
21:34:03 <ttx> hmm, ok. Should I add xenapi-storage-manager-nfs to the grizzly series goal ?
21:34:13 <ttx> i.e. do you bless it ?
21:34:22 <jgriffith> I did
21:34:24 <jgriffith> yes
21:34:43 <ttx> done
21:34:49 <jgriffith> thx
21:35:18 <ttx> jgriffith: so you're still confident everything can hit g1
21:35:25 <jgriffith> ttx: absolutely
21:35:31 <ttx> awesome!
21:35:35 <ttx> Looking at the general plan now...
21:35:39 <ttx> #link https://blueprints.launchpad.net/cinder/grizzly
21:36:11 <ttx> Who is going to work on cinder-api-2.0 ?
21:36:25 <jgriffith> ttx: It's already in progress by thingee...
21:36:29 <jgriffith> ttx: I'll update
21:36:42 <jgriffith> ttx: Oh... you found a dup
21:37:04 <ttx> oh, that explains it
21:37:10 <ttx> just mark one obsolete
21:37:12 <jgriffith> ttx: I'll need to merge Chucks and Mike's
21:37:31 <jgriffith> ttx: doing it now
21:37:41 <ttx> Also retain-glance-metadata-for-billing is "proposed" for grizzly, should I confirm it ?
21:38:06 <jgriffith> ttx: yes please, I just targetted that this morning
21:38:13 <ttx> done
21:38:21 <ttx> jgriffith: Anything else ?
21:38:52 <ttx> Questions on Cinder ?
21:39:40 <ttx> #topic Nova status
21:39:43 <ttx> vishy: o/
21:39:46 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-1
21:39:50 <vishy> hi
21:39:59 <ttx> Generally good progress, but only one week left...
21:40:09 <ttx> Anything that won't make it that we should already defer to g2 ?
21:40:14 <ttx> Could help in prioritizing reviews
21:40:23 <vishy> i went through in defering a couple of things already
21:40:41 <vishy> compute cells seems unliekely to land
21:41:05 <vishy> and entrypoints as well
21:41:15 <vishy> mostly due to review delays
21:41:30 <vishy> comstud / mordred: does that seem accurate?
21:41:33 <ttx> how is "Delete all traces of volume code from nova" going ?
21:41:39 <vishy> that one is close
21:41:43 <ttx> ok, good
21:41:57 <ttx> it's good to have the cleanup full by the time the milestone hits
21:41:59 <comstud> vishy: When is cut-off for g-1 ?  Seems unlikely
21:42:11 <ttx> comstud: EOB next tuesday
21:42:20 <comstud> yeah, we'll need slightly longer I suspect
21:42:36 <ttx> vishy: defer as appropriate
21:42:50 <ttx> #link https://blueprints.launchpad.net/nova/grizzly
21:43:07 <ttx> Still a few issues there...
21:43:17 <ttx> Would be good to have assignees for the "High" priority stuff
21:43:52 <ttx> if nobody goes for it and they are targets of opportunity, maybe we can downprioritize those
21:44:24 <ttx> vishy: how is the hunt for volunteer assignees going so far ?
21:44:36 <vishy> ttx: haven't heard a peep!
21:44:38 <vishy> :(
21:45:07 <ttx> vishy: call was a bit lost in your last email, iirc
21:45:27 <vishy> ttx: think i should send out another one for specific ones?
21:45:44 <vishy> ttx: a few of those I think we can assign to their drafters
21:45:58 <vishy> ttx: i will go through and do that and send out an email for volunteers for the rest
21:46:08 <ttx> vishy: for the ones that are really "High" prio, a specific email asking for volunteers can't hurt
21:46:15 <ttx> +1
21:46:23 <ttx> Also we need more tentative milestone targets set
21:46:33 <ttx> but one is linked to the other
21:46:39 <ttx> no assignee, no milestone
21:46:52 <ttx> A few prio mismatches, detected by ttx.py:
21:46:54 <ttx> db-cleanup (High) depends on blueprint with lower priority (db-api-cleanup, Medium)
21:47:01 <ttx> Same for nova-v3-api (High), depending on apis-for-nova-manage (Medium)
21:47:36 <ttx> #action vishy to adjust priorities for db-cleanup db-api-cleanup nova-v3-api apis-for-nova-manage to avoid depending on lower prio bps
21:47:42 <ttx> vishy: Anything else ?
21:47:46 <vishy> hmm, tha second one doesn't really seem like a dependency exactly
21:47:49 <vishy> nope
21:47:52 <vishy> ok i will clean
21:48:03 <ttx> vishy: removing the dependency link will ALSO fix it :)
21:48:10 <ttx> Questions on Nova ?
21:48:45 <ttx> #topic Incubated projects
21:48:49 <ttx> Anyone to talk Ceilometer ?
21:49:00 <ttx> Anyone from Heat ?
21:49:03 <eglynn_> o/
21:49:05 <stevebake> o/
21:49:08 <eglynn_> (from ceilo)
21:49:11 <ttx> ok, ceilometer first
21:49:15 <ttx> Looking at https://launchpad.net/ceilometer/grizzly
21:49:21 <ttx> Want me to create milestones at the common dates ?
21:49:43 <eglynn_> nothing much to report other than reaching out to the Synaps folks with a view to closer collaboration
21:50:04 <eglynn_> ttx re. milestones I'd say G-2 will be our first
21:50:10 <zaneb> o/
21:50:21 <ttx> #action ttx to create milestones for ceilometer grizzly starting at g2
21:50:32 <ttx> eglynn_: Also I looked into jobs necessary for integrated release... Now that you have common-bump-milestone support, I think you only need a proper ceilometer-tarball job
21:50:34 <eglynn_> (a fair bit of churn ongoing on WRT to removing nova DB access)
21:50:53 <ttx> eglynn_: so you can add that to your list of requests to CI :)
21:50:54 <eglynn_> ttx: cool
21:51:02 <ttx> Finally it would be good to work on your Grizzly plans a bit
21:51:06 <ttx> #link https://blueprints.launchpad.net/ceilometer/grizzly
21:51:14 <ttx> Looks a bit bare atm
21:51:20 <eglynn_> yep, understood, we'll get ours hand around that this week
21:51:29 <ttx> #action ceilometer crew to ask for a ceilometer-tarball job and pimp up their grizzly roadmap
21:51:31 <eglynn_> s/ours hand/our hands/
21:51:44 <ttx> stevebake: hello, and welcome to the crazy fast meeting
21:51:48 <stevebake> https://launchpad.net/heat/+milestone/grizzly-1
21:52:04 <ttx> nice!
21:52:07 <ttx> The first step towards total assimilation would be to align Launchpad teams
21:52:13 <ttx> You seem to have a single ~heat team (Heat Drivers), and no ~heat-core
21:52:29 <ttx> Those teams represent different things. heat-core are the code reviewers, while heat-drivers are in charge of the roadmap.
21:52:32 <stevebake> We're still migrating content from the github wiki, so light on blueprints
21:52:37 <ttx> They can be the same people, but generally the drivers group is much smaller
21:52:47 <ttx> So my suggestion would be to create a heat-core group, set review permissions to those
21:52:52 <stevebake> ok
21:52:56 <ttx> then rename ~heat to ~heat-drivers and clean it up (should be PTL + a limited few helpers)
21:53:06 <ttx> #action heat crew to align Launchpad teams with openstack model
21:53:16 <zaneb> I thought there was a heat-core, but I could be wrong
21:53:39 <ttx> stevebake: when do you think you want me to start doing your milestone releases ? g2 ? g3 ?
21:53:46 <stevebake> we're still discussing whether to do a g-1 release, since we're only just incubated
21:54:06 <stevebake> but I think we can commit to g-2 onwards
21:54:12 <zaneb> +1
21:54:17 <ttx> stevebake: that would be next week. Maybe skip it if it doesn't make sense feature-wise
21:54:33 <stevebake> we might do a slightly delayed g-1
21:54:39 <ttx> stevebake: OK, I'll investigate how far you are from a Jenkins job standpoint and keep you posted
21:54:55 <ttx> stevebake: sure, delayed g1 is an option
21:55:22 <stevebake> that is all. Progress is being made
21:55:34 <ttx> stevebake: did you already switch to openstack common versioning ? Or still using the original heat versions ?
21:55:50 <ttx> i.e. v8 or 2013.1?
21:55:53 <zaneb> we haven't switched that over yet
21:56:10 <zaneb> but I think next release it would make sense to do that
21:56:28 <ttx> might not be worth calling something g-1 until you do that
21:56:47 <zaneb> yes, that makes sense
21:56:53 <stevebake> Also need to choose a versioning for first release of python-heatclient
21:56:55 <ttx> so two options, doing a v..8? or switch versioning and do a 2013.1~g1
21:57:20 <ttx> stevebake: that's a lot more open. Client libraries just can pick whatever they want ;)
21:57:30 <stevebake> ok
21:57:31 <ttx> ok, need to move on
21:57:41 <ttx> stevebake: thanks!
21:57:46 <ttx> #topic Other Team reports
21:57:50 <ttx> QA, Docs, CI: anyone ?
21:58:30 <ttx> #topic Open discussion
21:58:40 <ttx> I'm looking into changing the format of the meeting, covering the stuff that matters to everyone first
21:58:46 <ttx> since most people just drop from the meeting when they are done
21:58:55 <ttx> and nobody listens to me at this point
21:59:06 <ttx> That means we would drop the "Other Team reports" and "Open discussion" topics at the end and replace them with a "General announcements" topic at the start
21:59:23 <ttx> Additionally we'll remove the "Actions from last week" topic and talk about those in each corresponding topic.
21:59:32 <ttx> Unless someone complains I'll switch to that format for next meeting.
21:59:42 <ttx> #action ttx to revamp meeting format for next time
21:59:56 <ttx> annegentle_: that affects you ^
22:00:14 <ttx> annegentle_: should make it easier to announce stuff while everyone is still listening
22:00:20 <annegentle_> ttx: nice
22:00:34 <annegentle_> cuz I wanted to announce our participation in the GNOME Outreach Program for Women!
22:00:41 <annegentle_> #link http://wiki.openstack.org/GnomeOutreachWomen
22:01:13 <ttx> annegentle_: cool!
22:01:36 <ttx> Anything else, anyone ?
22:01:38 <annegentle_> very exciting.
22:02:01 <ttx> annegentle_: unfortunately nobody listens anymore. I'd suggest a post on the ML :)
22:02:11 <annegentle_> ttx: yup, will do :)
22:02:15 <heckj> heh
22:02:19 <ttx> and that closes our meeting. Thanks everyone
22:02:21 <ttx> #endmeeting