21:01:46 <ttx> #startmeeting project
21:01:47 <openstack> Meeting started Tue Nov 27 21:01:46 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:50 <openstack> The meeting name has been set to 'project'
21:01:56 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:04 <ttx> #topic General announcements
21:02:14 <annegentle_> o/
21:02:15 <ttx> #info grizzly-1 released last week, the world is still standing
21:02:32 <ttx> Today we'll be mostly going through the grizzly-2 plans and check them for sanity, should be a quick one
21:02:39 <ttx> markmc: how is 2012.2.1 looking ?
21:02:59 <markmc> ttx, pretty good, huge amount of activity in the last week - roughly 50 new backports
21:03:03 <markmc> latest tallies:
21:03:09 <markmc> 77 nova
21:03:09 <markmc> 32 quantum
21:03:09 <markmc> 9 glance
21:03:09 <markmc> 7 keystone
21:03:09 <markmc> 3 cinder
21:03:10 <markmc> 1 horizon
21:03:11 <markmc> 129 total
21:03:13 <markmc> vishy backported a tonne
21:03:17 <ttx> markmc: one security bug will be released tomorrow
21:03:24 <markmc> adam_g caught one nasty regression which we fixed
21:03:27 <markmc> ttx, ah, yes
21:03:27 <ttx> shoudl be added to the mix
21:03:40 <markmc> there's another 10 or so reviews still pending across the projects
21:03:50 <ttx> markmc: could we have caught that regression using our fearless testing/gate ?
21:04:09 <markmc> ttx, good question, I don't recall why we didn't
21:04:26 <markmc> #action markmc check why testing didn't catch the stable/folsom regression
21:04:26 <ttx> adam_g: i think it was usage of old config format with new
21:04:41 <ttx> so maybe grenade could have caught it, but not static version testing
21:04:59 <ttx> markmc: so, on track for Thursday release ?
21:05:02 <markmc> wasn't so much new/old format, just config refactoring confused things
21:05:19 <markmc> ttx, I think so - a little nervous at the rate of change, but we should go ahead I think
21:05:34 <markmc> ttx, it's 11 weeks of stuff at this point
21:06:03 <markmc> 9 weeks
21:06:16 <ttx> markmc: if you prefer it to slow down, we could do next Tuesday
21:07:00 <markmc> ttx, doubt it would help much, think we should plough on
21:07:10 <markmc> ttx, I'll do a few more reviews tonight and then lock down
21:07:20 <ttx> ok, then we can call for last minute regression testing
21:07:32 <markmc> cool, will do
21:07:32 <ttx> mordred, annegentle, davidkranz: Anything interesting happening in CI, QA or Docs ?
21:07:38 <annegentle_> #info We have applicants for Outreach Program for Women submitting small patches in the next 2 weeks, thanks for welcoming our newcomers (we're doing well being a good community).
21:08:19 <ttx> #info 2012.2.1 lock down on Wednesday for release Thursday
21:08:31 <annegentle_> #info Google Doc Summit proposal was declined (bummer) but working on a new proposal for a similar sprint.
21:09:11 <annegentle_> #help Please encourage students in the southern hemisphere to apply for OpenStack slots for OPW.
21:09:12 <ttx> Any other general-interest topic before we start to cover project-specific stuff ?
21:09:14 <annegentle_> #link http://wiki.openstack.org/OutreachProgramForWomen
21:09:18 <annegentle_> that's all I have
21:09:42 <ttx> #topic Oslo status
21:09:46 <ttx> markmc: hello again
21:09:52 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-2
21:09:53 <markmc> me again? sheesh
21:10:04 <ttx> Looks good, maybe a bit ambitious but difficult to defer anything
21:10:20 <markmc> so I filed https://blueprints.launchpad.net/oslo/+spec/oslo-config-package
21:10:25 <markmc> that's my action item :)
21:10:28 <ttx> Note that we need oslo-release-versioning and common-binaries completed early in the milstone, as they are blocking others in same milestone
21:10:35 <ttx> both yours :)
21:10:49 <markmc> yeah, hopefully we're close on release versioning
21:11:07 <ttx> I wouldn't say that, but the discussion is well under way
21:11:20 <markmc> you don't hope we're close ? :)
21:11:33 <ttx> Hope is for the weak
21:11:50 <ttx> markmc: anything else ?
21:11:52 <markmc> common-binaries - kinda waiting for the rootwrap patch and then the update.py will thing will be trivial
21:12:03 <markmc> yes
21:12:16 <markmc> I'm working on porting all the projects to cfg-argparse
21:12:20 <ttx> common-binaries: you'd like rootwrap to be in first ?
21:12:30 <markmc> WIP reviews for nova, glance and keystone are up
21:12:32 <ttx> I was kinda holding until support for binaries was there
21:12:47 <markmc> jut waiting for some cfg patches to land in oslo-incubator
21:12:52 <ttx> as reflected by the bp interdependency
21:12:54 <adam_g> ttx: re: the config breakage. i'd expect something like that to be an issue around a major release but not a point release / stable update
21:12:55 <markmc> I'll do quantum and cinder too
21:13:14 <markmc> #info projects should keep an eye out for cfg-argparse reviews
21:13:31 <markmc> ttx, other thing - how can I do a "release" of oslo in launchpad for grizzly-1
21:13:35 <markmc> ttx, or should I?
21:13:51 <markmc> ttx, e.g. would like bugs to go from FixCommitted to FixReleased
21:14:10 <ttx> markmc: ah. let's talk offline, i'll give it some thought
21:14:15 <markmc> ttx, thanks
21:14:26 <ttx> #action ttx/markmc to discuss how to do oslo grizzly-1 "release"
21:14:40 <ttx> markmc: so common-binaries comes after rootwrap or before ?
21:14:58 <markmc> ttx, if you proposed rootwrap it would kickstart me into action :)
21:15:06 <markmc> ttx, in theory I'd do it before, but ...
21:15:15 <ttx> ok
21:15:41 <ttx> Anything else you wanted to raise before we switch to next topic ?
21:15:48 <markmc> nope, thanks
21:16:01 <ttx> #topic Keystone status
21:16:06 <ttx> heckj: o/
21:16:09 <heckj> ola
21:16:11 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-2
21:16:21 <ttx> Looks good to me
21:16:37 <ttx> I suspect we can consider pluggable-identity-authentication-handlers "started", since there is https://review.openstack.org/#/c/16755/
21:17:07 <heckj> agreed, updated
21:17:41 <heckj> Also working on a high priority bug - memcache/eventlet unhappiness at high load (found from swift)
21:18:22 <ttx> heckj: affecting all versions of keystone ?
21:18:33 <heckj> Working on primarily coming up with a way to repro and verify against failure in the future, solution looks reasonably well in hand - will track with some of the OSLO incubator stuff (moving memcachering into openstack-common).
21:18:51 <heckj> ttx: yes, anything using auth_token with high concurrency may hit this
21:19:04 <heckj> higher load makes it happen faster - not entirely predictable
21:19:09 <ttx> heckj: if you see the end of it by tomorrow could be good to include it in 2012.2.1
21:19:17 <ttx> markmc ^
21:19:21 <heckj> won't be in that fast
21:19:42 <ttx> ok
21:19:43 <heckj> http://10.128.1.55/page/login.html
21:19:50 <heckj> damnit : https://bugs.launchpad.net/keystone/+bug/1020127
21:19:51 <uvirtbot> Launchpad bug 1020127 in keystone "proxy-server Error: Second simultaneous read or write detected" [High,In progress]
21:20:26 <ttx> Interesting. Old bug
21:20:50 <ttx> heckj, others: Anything more about Keystone ?
21:21:01 <heckj> nothing from me
21:21:24 <ttx> #topic Swift status
21:21:27 <notmyname> hi
21:21:29 <ttx> notmyname: o/
21:21:33 <ttx> #link https://launchpad.net/swift/+milestone/1.7.6
21:21:39 <ttx> Any planned features/ETA so far ?
21:21:55 <notmyname> as far as project plans, no.
21:22:36 <ttx> ok then, anything else about Swift before we move to Glance ?
21:22:36 <notmyname> I've been talking with heckj et al about the keystone bug. other than that, we've got a coupl eof new old core devs re-engaged in swift
21:22:46 <ttx> good news
21:22:59 <notmyname> I don't have anything else to report on swift
21:23:02 <ttx> Zombie core devs ftw
21:23:26 <notmyname> should be no more zombies now, actually :-)
21:23:32 <ttx> markwash, bcwaldon: around ?
21:24:14 <ttx> ok, let's skip to quantum
21:24:19 <ttx> #topic Quantum status
21:24:26 <ttx> danwent: hi!
21:24:47 <danwent> hi
21:25:01 <ttx> still on your famous non-Internet connection ?
21:25:15 <markwash> ttx: here btw (sorry for delay)
21:25:18 <danwent> ttx: that's only the evenings… at work i have decent connectivity :)
21:25:24 <ttx> markmc: ok, you're next
21:25:31 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-2
21:25:40 <ttx> yay, 24 blueprints
21:25:42 <markmc> not me again
21:25:51 <danwent> ttx: we have a LOT Of high blueprints
21:26:00 <ttx> mark*wash*: you're next
21:26:06 <ttx> So on one side that's more than you ever managed to complete in one milestone...
21:26:08 <danwent> but several of them are items already deep through code review, essentially left-over from G-1
21:26:18 <ttx> yes, you already have made good progress on about half of them
21:26:35 <ttx> so it looks actually quite doable
21:26:38 <danwent> ttx: there are several that if no one starts working on them in one week or so, i think we can bump out
21:26:49 <ttx> danwent: good plan
21:26:54 <ttx> There are a few things to fix in that plan:
21:27:05 <ttx> quantum-v2-euca-compat is in the current milestone but has no assignee.
21:27:23 <danwent> ttx: yup, i'm going to try and get someone to sign up, otherwise boot
21:27:30 <ttx> lbaas-agent-and-rpc: this is not part of the series goal, but has a milestone set
21:27:44 <ttx> and lbaas-plugin-api-crud (High, grizzly-2) depends on lbaas-restapi-provider (Medium, no milestone)
21:28:02 <ttx> danwent: maybe clarify those by next week ?
21:28:03 <danwent> ttx: ah, that's a new one… it though I just checked for things missing series and there were none… one sec
21:28:19 <danwent> ttx: definitely, will take care of them.
21:28:30 <ttx> There are also 4 blueprints with "unknown" status. Should I set them to "Not started" instead ?
21:28:43 <danwent> sure
21:28:43 <ttx> Hmm... make-string-localizable and nvp-provider-net look started, actually (have linked changes)
21:28:57 <danwent> nvp-provider net definitely is started, its in code review, i believe
21:28:59 <ttx> Will make those two started and the other not started.
21:29:03 <danwent> let me follow-up with the devs directly
21:29:14 <danwent> v6 is definitely not started
21:29:14 <ttx> ok, I'll let you update those then
21:29:19 <danwent> k
21:29:35 <ttx> danwent: anything on your mind ?
21:29:43 <danwent> stable release
21:29:56 <danwent> we are still tracking a few last items to get merged into stable/folsom
21:30:08 <danwent> i think markmc is aware of this.  garyk is lead on stable/folsom on our end.
21:30:20 <ttx> danwent: ok
21:30:29 <danwent> also, i'm working with annegentle_ to try and get more attention focused on quantum docs by quantum core devs
21:30:44 <danwent> that's about it.
21:30:47 <ttx> Sounds good. Everyone ready to switch back to glance now ?
21:30:59 <markwash> o/
21:31:01 <ttx> #topic Glance status
21:31:12 <ttx> markwash: welcome!
21:31:17 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-2
21:31:19 <markwash> ttx: thanks
21:31:27 <ttx> Plan looks good, quite ambitious though, compared to your usual velocity
21:31:41 <ttx> Feeling confident you can hit all those targets by January 8 ?
21:31:56 <markwash> well, most of them
21:32:03 <markwash> not sure which will need more at this point
21:32:28 <markwash> one is in a similar situation to quantum bps, most of the work done already for g-1
21:32:49 <ttx> markwash: sounds good
21:33:13 <ttx> we'll track progress in the next weeks and see if things are getting completed at a reasonable rate anyway
21:33:25 <ttx> markwash: did you have anything else ?
21:33:39 <markwash> that's all :-) happy to answer any other questions though
21:34:12 <ttx> Do we have jgriffith in the house ?
21:34:19 <jgriffith> ttx: yessir
21:34:28 <ttx> #topic Cinder status
21:34:35 <ttx> jgriffith: hello sir
21:34:40 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-2
21:34:41 <jgriffith> ttx: afternoon
21:34:50 <ttx> So.. 19 blueprints !
21:34:54 <jgriffith> Yup
21:35:06 <jgriffith> They're *small* :)
21:35:08 <ttx> That would... explode your own record
21:35:10 <jgriffith> some of them
21:35:15 <jgriffith> That's the goal :)
21:35:34 <ttx> I repeat that the deadline is Tuesday, January 8 :)
21:35:48 <jgriffith> ttx: Nope, it's the week before for Cinder ;)
21:36:07 <ttx> even better :)
21:36:09 <jgriffith> ttx: I've checked with everyone and made it clear that we're shooting for Christmas presents
21:36:18 <ttx> Should I assume all the "unknown" ones are actually "not started" ?
21:36:32 <ttx> (well, the two unknown ones)
21:36:37 <jgriffith> ttx: Yes.. that's safe
21:37:00 <ttx> ok done
21:37:00 <jgriffith> ttx: I'm fairly certain they're not started but wanted confirmation before stating so
21:37:43 <ttx> jgriffith: if you defer, try to defer early. You don't have that much targeted to g3
21:37:55 <ttx> That's all I had. Anything more in Cinder ?
21:38:17 <jgriffith> Not from me... unless somebody wants to rewrite LVM snapshots :)
21:38:38 <ttx> jgriffith: I think we only do that every Friday
21:38:45 <jgriffith> dang it!
21:38:48 <ttx> #topic Nova status
21:38:54 <ttx> vishy: hi!
21:38:58 <vishy> hi
21:39:02 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-2
21:39:14 <ttx> Same as quantum, lots of work, but you seem on track so far.
21:39:43 <ttx> hyper-v-compute-resize: should I add it to the series goal ? Which priority ?
21:40:08 <vishy> sure its new
21:40:11 <vishy> low
21:40:19 <ttx> will do
21:40:28 <ttx> About the general plan at https://blueprints.launchpad.net/nova/grizzly
21:40:40 <ttx> It still suffers from too many "High" priority stuff being untargeted
21:40:51 <ttx> Could you get assignees to indicate *when* they think their work will land ?
21:41:05 <vishy> sure
21:41:05 <ttx> There are a number of things where work started, where I think the assignees should have a pretty good idea...
21:41:18 <ttx> db-session-cleanup, coverage-extension, vmware-compute-driver, zk-service-heartbeat, trusted-filter-cache, grizzly-hyper-v-nova-compute, hw-feature-to-vm
21:42:02 <ttx> About bug 1079210 that was raised by davidkranz last week... any updated status ? the bug is quite calm
21:42:03 <uvirtbot> Launchpad bug 1079210 in nova "Successful full gate jobs show ERRORs and stacktraces" [Medium,Confirmed] https://launchpad.net/bugs/1079210
21:42:27 <davidkranz> ttx: Sean Dague's team is looking at this.
21:42:45 <ttx> davidkranz: ok
21:42:46 <davidkranz> ttx: mtreinish was going to talk to vishy  this afternoon.
21:42:53 <vishy> yeah he pinged me
21:42:59 <vishy> its going to take some investigation
21:43:43 <davidkranz> vishy: There was a suggestion to put some code in tempest that pulls info from the nova db to help.
21:44:02 <ttx> vishy: anything else on your mind ? Review queue worries ?
21:44:05 <davidkranz> I'm sure you guys will figure it out.
21:45:24 <vishy> davidkranz: that would help, so would leaving broken builds up for investigation
21:45:37 <vishy> ttx: no i think we are good atm
21:45:50 <vishy> ttx: going to discuss blueprints at the meetup on thursday
21:45:59 <vishy> to hopefully get more help on the ones i emailed about
21:46:05 <ttx> you mean meeting ?
21:46:27 <vishy> no i mean at the meetup in southbay
21:46:29 <vishy> :)
21:46:31 <ttx> or really recruiting in local meetup ?ok
21:46:44 <ttx> haha
21:46:46 <ttx> Anything else about Nova ?
21:47:14 <comstud> i RSVP'd for Thursday's meetup
21:47:18 <comstud> ppl can give me crap about cells if they want
21:47:34 <comstud> except Vish.
21:47:35 <ttx> comstud: that reminds me...
21:47:39 <russellb> comstud: I can't go, but can I still give you crap about cells?
21:47:45 <comstud> russellb: NO
21:47:47 <comstud> :)
21:48:03 <ttx> comstud: how is the weather looking for cells code those days ? Was lamost in, then farther away...
21:48:09 <ttx> almost*
21:48:22 <comstud> we're close.. i'll have some cleanups up tomorrow
21:48:30 <comstud> the db model re-add went in earlier
21:48:39 <russellb> i'm going to go into heads down review mode on cells once comstud posts updates tomorrow
21:48:50 <ttx> creepy
21:49:05 <ttx> #topic Horizon status
21:49:10 <ttx> gabrielhurley: hey
21:49:14 <gabrielhurley> hi
21:49:16 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-2
21:49:47 <ttx> Only one unassigned blueprint left, I see: orderable-mutiple-choice-field
21:49:49 <gabrielhurley> the one unassigned blueprint is up in the air on who will do it.. a couple people have mentioned thoughts on it but I'm the fallback. it's necessary for quantum work.
21:50:05 <gabrielhurley> I should have an assignee by next week I hope
21:50:30 <ttx> that works
21:50:54 <ttx> Your plan looks nice and reasonable. So I don't have much to say.
21:51:00 <gabrielhurley> cool
21:51:02 <ttx> Anything you wanted to raise ?
21:51:03 <gabrielhurley> i have a question though
21:51:06 <ttx> ah.
21:51:22 <ttx> i didn't order my T-shirt, because you don't ship internationally.
21:51:34 <gabrielhurley> haha, hit me up in private on that one
21:51:34 <ttx> was that this one ?
21:51:53 <gabrielhurley> I'm trying to schedule the weekly project dev meeting for horizon, but I'm having a hard time... what would it take to actually start a second meeting room?
21:52:18 <gabrielhurley> basically I'm on Pacific time and a lot of the folks who want to participate are in Europe, so there's not a lot of middle ground
21:52:38 <ttx> not that much, apart from having the meetbot also hang on that one
21:52:54 <gabrielhurley> yeah, I figured that was the main bit
21:53:01 <ttx> gabrielhurley: raise an openstack-ci bug about an #openstack-meeting2 channel
21:53:08 <gabrielhurley> awesome, will do
21:53:11 <gabrielhurley> that's it for me then
21:53:16 <ttx> There aren't so many good spots for meeting, and we can parallelize a bit
21:53:21 <gabrielhurley> yeha
21:53:49 <ttx> though we should avoid double-booking as much as we can, to let people attend
21:53:55 <gabrielhurley> agreed
21:54:02 <ttx> it's simpler for me to attend two meetings at the same time than one meeting at 4am
21:54:07 <gabrielhurley> I'm probably gonna parallelize with the red dwarf meeting right after this one
21:54:48 <ttx> gabrielhurley: we could also say that reddwarf needs ot move to let priority to the core project, but that would not be nice :)
21:55:00 <gabrielhurley> I considered that. ;-)
21:55:16 <ttx> which nicely brings us to the next topic, incubation
21:55:23 <ttx> #topic Incubated projects
21:55:32 <ttx> Anyone to talk Ceilometer ?
21:56:46 <ttx> Anyone from Heat ?
21:56:48 <shardy> o/
21:56:58 <ttx> shardy: your Launchpad teams look good now.
21:57:08 <ttx> Only one small remark: you should set the "development focus" on https://launchpad.net/heat to be the grizzly series
21:57:29 <shardy> ttx: yep I think we still have some work to align our issues with the grizzly milestones tho
21:57:46 <ttx> Next step is bug 1082820
21:57:46 <uvirtbot> Launchpad bug 1082820 in openstack-ci "Move heat to OpenStack" [High,Triaged] https://launchpad.net/bugs/1082820
21:57:53 <shardy> Plan to discuss at our meeting tomorrow and get that more organized
21:58:15 <ttx> shardy: make sure you get the CI folks in to discuss that
21:58:26 <ttx> Still planning to do a grizzly-1 milestone yourself ? Any ETA for that ?
21:58:51 <shardy> No, I think we're targeting our next release to align with grizzy-2
21:59:06 <shardy> too soon after our last release for things to be ready for g-1
21:59:33 <ttx> ok, then I'd just remove that milstone and make g2 your forst, like we did for ceilo.
21:59:38 <ttx> first*
21:59:39 <shardy> will organize the issues in LP so we have a clear plan of what we'll deliver for g-2
21:59:42 <shardy> Ok
21:59:53 <ttx> Yes, you need to transfer your roadmap to https://blueprints.launchpad.net/heat/grizzly
22:00:04 <shardy> Ok
22:00:05 <ttx> it's a bit empty, I'm pretty sure you have more plans that this :)
22:00:09 <ttx> than*
22:00:22 <shardy> Yep, we're still getting organized after moving everything from github issues
22:00:22 <ttx> ok, we're done.
22:00:31 <shardy> one question -
22:00:35 <ttx> shardy: shoot
22:00:46 <shardy> can we get some help from the CI guys to get better value from our integration tests?
22:01:02 <ttx> shardy: I suspect yes.
22:01:27 <ttx> shardy: talk to them, let me know if there are any issues
22:01:44 * ttx clears the floor for next meeting
22:01:45 <ttx> #endmeeting