21:02:09 <ttx> #startmeeting project
21:02:10 <openstack> Meeting started Tue Dec  4 21:02:09 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:13 <openstack> The meeting name has been set to 'project'
21:02:14 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:25 <ttx> Regular meeting today, we'll look into progress towards the next milestone/release
21:02:33 <ttx> #topic General announcements
21:02:45 <ttx> #info 2012.2.1 released last week, next point release planned for end of January
21:02:57 <markmc> we had one serious regression reported:
21:02:57 <ttx> markmc: did you check why testing didn't catch that stable/folsom regression ?
21:02:58 <markmc> https://bugs.launchpad.net/nova/+bug/1083944
21:03:00 <uvirtbot> Launchpad bug 1083944 in quantum/folsom "RPC exchange name defaults to 'openstack'" [Critical,In progress]
21:03:11 <markmc> ttx, I didn't, good point
21:03:27 <ttx> #action markmc to check why testing didn't catch the various stable/folsom regressions
21:03:45 <ttx> markmc: that's a regression specific to 2012.2.1 ?
21:03:51 <ttx> (bug 1083944)
21:03:52 <uvirtbot> Launchpad bug 1083944 in quantum/folsom "RPC exchange name defaults to 'openstack'" [Critical,In progress] https://launchpad.net/bugs/1083944
21:04:07 <markmc> ttx, yes, mostly a problem for nova - quantum also affected, but it's default config file masks the issue
21:04:39 <bcwaldon> ttx: I'm here!
21:04:47 <ttx> markmc: would you treat that using release notes, or would you consider pushing another (interim) point release to address that ?
21:04:58 <markmc> ttx, I'd be tempted to do a "brown paper bag" release for Nova with just the fix
21:05:03 <markmc> ttx, already added to the release notes
21:05:21 <markmc> ttx, it's the only fix since merged to nova stable/folsom
21:05:22 <ttx> markmc: ok, maybe we can combine it with a few security updates
21:05:35 <markmc> ttx, ah, good idea
21:05:51 <markmc> ttx, I should block other nova fixes being merged until then though
21:05:59 <ttx> #action ttx to look into the vulnerabilities trove for anything that could be in a 2012.2.2
21:06:21 <ttx> For those doing grizzly-2, remember the cut date is January 8
21:06:33 <ttx> The end of year vacation will hit us soon, so take that into account in your predictions :)
21:06:49 <ttx> We were talking about doing a bug day, and annegentle suggested a (separate) doc bug day.
21:06:57 <ttx> annegentle_: want to tell us a bit more about that ?
21:07:23 <annegentle_> sure. So the idea is that the doc team wants to be able to "bother" devs with questions on particularly tough doc bugs (and reviews)
21:07:43 <annegentle_> so we didn't want to distract on bug day
21:08:23 <annegentle_> Tom Fifieldt knocked a good handful of doc bugs over the weekend, but the backlog is still over 100
21:08:27 <ttx> hmm, so we could do a bug day one Thursday, and the doc bug day on the next Thursday, would that work ?
21:08:37 <ttx> (or the other way around)
21:08:38 <annegentle_> ttx: sure
21:09:00 <ttx> PTLs: anyone with a preference on the bugdays date ?
21:09:42 <ttx> or should we just pick the damn dates and we'll make it happen ?
21:10:02 <danwent> ttx: just pick it
21:10:02 <bcwaldon> +1
21:10:32 <jgriffith> pick-away
21:10:46 <ttx> ok, then I'd suggest bugday this week (Thursday) and docbugday next week
21:10:55 <gabrielhurley> sounds good
21:11:00 <ttx> that leaves tha last week before vacation to push reviews for crazy stuff incoming
21:11:04 <jgriffith> fine by me
21:11:08 <annegentle_> ttx: actually shoot, the other way around would work better for me, I'm in an all day training next Thurs.
21:11:28 <annegentle_> ttx: or Thurs. Fri. back to back this week?
21:11:48 <ttx> hmm, I'd rather spearte them to make sure people can focus on them
21:11:56 <annegentle_> ttx: sure makes sense
21:12:01 <jgriffith> reverse is fine by me still
21:12:05 <ttx> two days in a row is a bit too much of a focus
21:12:06 <ttx> #info Doc Bug day December 6, Regular Bug day December 13
21:12:17 <ttx> annegentle_: I'll let you announce / kick it off
21:12:20 <annegentle_> hee we get the original day :)
21:12:30 <ttx> mordred, annegentle, davidkranz: Anything to report from CI/QA/Docs land ?
21:12:38 <annegentle_> #action annegentle_ to send note to mailing list re: bug days
21:12:40 <ttx> (apart from the Docbugday ?)
21:12:42 <heckj> sorry I'm late
21:12:57 <annegentle_> Nothing new this week
21:13:05 <davidkranz> Ditto.
21:13:15 <ttx> Anything else in general announcements before we switch to project-specific stuff ?
21:13:48 <ttx> #topic Oslo status
21:13:53 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-2
21:14:01 <markmc> refresh btw
21:14:08 <markmc> so
21:14:15 <markmc> release-versioning, I think we have a plan
21:14:20 <ttx> markmc: ok, looks on track now
21:14:21 <markmc> monty's going to summarize it
21:14:37 <ttx> cool
21:14:40 <markmc> I should be able to push forward with oslo-config package in the next week or two
21:14:50 <markmc> it's the rootwrap guy who's slacking the most :-P
21:14:51 * markmc ducks
21:14:59 <ttx> not /that/ guy again
21:15:06 <markmc> eric has kicked off the common-db work
21:15:12 <ttx> if people stopped making reviews that show they don't get the security model around it :P
21:15:16 <markmc> I'll poke russell about message versioning
21:15:30 <markmc> so, feeling like we're on track
21:15:35 <ttx> yes, sounds good
21:15:37 <ttx> Anything else on the oslo topic ?
21:15:41 <Vek> sorry
21:15:51 <markmc> action from last week was to close out grizzly-1
21:15:54 <markmc> did that
21:16:14 <markmc> oh, also - we need CI integration for marking bugs as inprogress etc. when reviews are submitted
21:16:18 <markmc> also blueprints it seems
21:16:28 <markmc> have some notes from eglynn on that, will poke this week
21:16:28 <ttx> yes, I fixed that
21:16:34 <ttx> review in progress for the fix
21:16:38 <markmc> really?
21:16:39 <markmc> excellent!
21:16:54 <ttx> bug 1085864
21:16:55 <uvirtbot> Launchpad bug 1085864 in openstack-ci "update_bug doesn't update bug status for oslo" [Undecided,In progress] https://launchpad.net/bugs/1085864
21:17:13 <ttx> ok, ready to switch to keystone status �?
21:17:13 <markmc> #link https://review.openstack.org/3104
21:17:33 <markmc> oh, that's different
21:17:38 <markmc> yep, carry on
21:17:41 <markmc> thanks again for that ttx
21:17:45 <ttx> #topic Keystone status
21:17:51 <heckj> (ttx: refresh keystone link please)
21:17:55 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-2
21:18:14 <ttx> heckj: Looks on track to me
21:18:35 <ttx> heckj: Nothing from me, anythign you wanted to mention ?
21:19:15 <heckj> active discussion on token trusts (also known as delegation) - very relevant to all projects, so other PTL's asked to read, comment, and provide feedback on plans there
21:19:24 <heckj> @link https://blueprints.launchpad.net/keystone/+spec/trusts
21:19:26 <heckj> #link https://blueprints.launchpad.net/keystone/+spec/trusts
21:19:47 <ttx> heckj: I'll admit I didn't read all those threads... Are you converging towards a solution ? Or still discussing ?
21:20:21 <heckj> ttx: converging - lots of theoretically wrapped in there, but some very concrete pieces are coming out in trusts
21:20:40 <ttx> #info other PTL's asked to read, comment, and provide feedback on token trusts plans
21:21:20 <ttx> heckj: sounds great. Better discuss and do it right, rather than half-bake. Anything more about Keystone ?
21:21:26 <Vek> \o
21:21:34 <ttx> Vek: go for it
21:22:04 <Vek> discovered a bug in auth_token.py, but it only applies if someone wants to use memcache-based caching of tokens; guess no one's doing that.
21:22:14 <Vek> lp 1086125
21:22:15 <uvirtbot> Launchpad bug 1086125 in python-keystoneclient "memcache_servers configuration option" [Undecided,In progress] https://launchpad.net/bugs/1086125
21:22:34 <Vek> just wanted to raise it here because python-keystoneclient appears to have the same lack of regular review that python-novaclient does :)
21:22:53 <bcwaldon> Vek: I'll review right now
21:23:18 <ttx> Vek: is that all you had ?
21:23:25 <notmyname> FWIW, https://review.openstack.org/#/q/status:open+<project>,n,z gives all reviews for both the project and for the client project
21:23:26 <heckj> Vek: also work bringing up in keystone meetings if we're missing a review, please
21:23:28 <Vek> yep.
21:23:40 <ttx> #topic Swift status
21:23:44 <ttx> notmyname: o/
21:23:47 <notmyname> hi
21:23:48 <ttx> #link https://launchpad.net/swift/+milestone/1.7.6
21:23:55 <ttx> Still no date for this one ?
21:24:13 <notmyname> swift 1.7.6 will be released after the first of the year
21:24:23 <notmyname> probably around mid january, but no date yet
21:24:31 <ttx> notmyname: thanks, good to know
21:24:41 <ttx> I noticed that new untriaged bugs have started to pile up, would be good to triage them:
21:24:44 <notmyname> this should be a mostly-bugfix release
21:24:46 <ttx> https://bugs.launchpad.net/swift/+bugs?field.status=NEW&field.importance=UNDECIDED
21:25:11 <notmyname> the next release will probably be 1.8 and will (hopefully) include global cluster support
21:25:31 <notmyname> (next == after 1.7.6)
21:25:33 <ttx> interesting
21:25:42 <ttx> notmyname: Anything else in the Swift department, before we switch to Glance ?
21:25:52 <notmyname> I don't have anything else
21:26:13 <ttx> #info Swift 1.7.6 will be released after the first of the year, probably around mid-January
21:26:29 <ttx> #info release after that will probably be 1.8 and will (hopefully) include global cluster support
21:26:35 <ttx> #topic Glance status
21:26:40 <ttx> bcwaldon: o/
21:26:44 <bcwaldon> ttx: hey
21:26:45 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-2
21:27:04 <ttx> Looks mostly on track so far
21:27:06 <bcwaldon> indeed
21:27:30 <bcwaldon> I think we stalled a little bit over the past couple of weeks, but markwash and I had an encouraging discussion about the goals for g2
21:27:45 <bcwaldon> everything appears on track
21:27:49 <ttx> bcwaldon: yes, hopefully will see more work started by next week
21:28:01 <bcwaldon> you can bet on that
21:28:04 <bcwaldon> but don't
21:28:20 <ttx> I only bet when I'm 100% sure to win. Anything more on Glance topic ?
21:28:24 <bcwaldon> no, sir
21:28:53 <ttx> #topic Quantum status
21:28:57 <ttx> danwent: hi!
21:28:58 <danwent> o/
21:29:01 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-2
21:29:15 <ttx> Nice progress overall.. anything not started that you think makes sense to already defer to g3 ?
21:29:30 <danwent> i've already bumped a few things out
21:29:51 <danwent> i'm guessing some of the 'medium' priority stuff that is 'not started' won't make it, but all of the high stuff stands a good to very good chance
21:30:06 <ttx> danwent: sounds good. I found a small logic issue in your plan: lbaas-plugin-api-crud (High, g2) depends on lbaas-restapi-provider (Medium, no milestone)
21:30:34 <danwent> hehe, was just looking at the lbaas-restapi-provider bp
21:30:40 <danwent> i think that should be removed for now
21:30:51 <danwent> there is no dependency
21:30:52 <ttx> the relationship ? OK, will do
21:31:14 <danwent> actually, i think the whole BP should be removed, but I need to check.  certainly the dependency can be removed.
21:31:20 <ttx> l3-router-port-relationship was started, do you know which milestone we can expect it to land ?
21:31:33 <danwent> ah, that just slipped in.  should be G-2.
21:31:48 <danwent> how did you notice that one so I can find them in the future?
21:31:56 <danwent> does ttx.py find it?
21:32:00 <ttx> Saw it on http://wiki.openstack.org/releasestatus/
21:32:19 <danwent> ok, will try and check that out in the future
21:32:36 * ttx sets g2
21:33:04 <ttx> danwent: so you can remove the series goal from https://blueprints.launchpad.net/quantum/+spec/lbaas-restapi-provider if it doesn't make sense
21:33:09 <ttx> That's all I had. Anything else on Quantum, anyone ?
21:33:18 <danwent> will do
21:33:45 <ttx> #topic Cinder status
21:33:49 <jgriffith> :)
21:33:49 <ttx> jgriffith: hi!
21:33:53 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-2
21:33:53 <jgriffith> hey there
21:34:03 <ttx> You look on track so far!
21:34:07 <jgriffith> Yep!
21:34:18 * jgriffith is optimistic still
21:34:22 <ttx> About local-storage-volume (the island project): what's the status of that ? still not started ?
21:34:30 <jgriffith> I'm only worried about the FC nad local-storage
21:34:35 <jgriffith> haha
21:34:44 <ttx> I read your mind
21:34:48 <jgriffith> I'm hoping to get input in tomorrows meeting
21:34:54 <jgriffith> will address bp's from there if needed
21:35:09 <jgriffith> folks have been MIA as of late
21:35:12 <ttx> jgriffith: frankly I don't see why that's "essential", pretty sure cinder grizzly could survive without it
21:35:25 <ttx> nice to have certainly. Essential ?
21:35:31 <jgriffith> ttx: true
21:35:45 <jgriffith> ttx: but if multiple people ask me for something I try to be a bit dramatic :)
21:35:53 <jgriffith> ttx: I'll adjust
21:35:55 <ttx> You can downgrade to High to prepare for the future :)
21:36:02 <jgriffith> ttx: yep, good idea
21:36:07 <ttx> well, saying it's essential is also about committing that it will land
21:36:14 <ttx> so it's a two edged sword
21:36:20 <jgriffith> ttx: Yeah, understood
21:36:24 <ttx> Otherwise, same remark as for Swift, untriaged bugs have started to pile up and could use some attention @
21:36:28 <ttx> https://bugs.launchpad.net/cinder/+bugs?field.status=NEW&field.importance=UNDECIDED
21:36:32 <jgriffith> ttx: Planned to take it myself if needed but that's happening in other areas
21:36:59 <ttx> Anything more in Cinder ?
21:37:08 <jgriffith> Not from me
21:37:34 <ttx> #topic Nova status
21:37:39 <ttx> vishy: o/
21:37:43 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-2
21:37:46 <vishy> hi
21:37:52 <ttx> Nice progress so far.
21:38:31 <ttx> A small inconsistency on your plans: db-cleanup (High) depends on db-unique-keys (Medium)
21:38:37 <ttx> Should I bump db-unique-keys to High, or downgrade db-cleanup to Medium ?
21:39:37 <ttx> vishy ^
21:39:44 <markmc> just spotted that better-libvirt-network-volume-support review has been abandoned
21:39:51 <vishy> medium
21:39:59 <ttx> vishy: a lot of your assignees still need to add milestone targets to their blueprints.
21:40:06 <ttx> If you don't have time to chase them down, want me to send them an email myself ?
21:40:13 <vishy> ttx: sure
21:40:24 <ttx> In particular a lot of non-targeted blueprints are obviously started:
21:40:29 <ttx> db-session-cleanup, coverage-extension, show-availability-zone, vmware-compute-driver, zk-service-heartbeat, trusted-filter-cache, grizzly-hyper-v-nova-compute, powervm-compute-enhancements...
21:40:33 <vishy> markmc: not surprising, someone will probably have to take it
21:40:53 <ttx> #action ttx to help trying to get milestone targets out of Nova assignees
21:41:13 <ttx> vishy: that's all I had. Anything you wanted to add ?
21:41:44 <vishy> ttx: nope
21:42:22 <ttx> #topic Horizon status
21:42:31 <gabrielhurley> hi
21:42:32 <ttx> gabrielhurley: yo
21:42:36 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-2
21:42:46 <ttx> Looks like slow progress to me, still think you're on track ?
21:43:02 <gabrielhurley> slow start on the BPs... I've been sick, etc. I think we'll be alright, though.
21:43:17 <ttx> gabrielhurley: hope you're doing better now :)
21:43:18 <gabrielhurley> it's a similar scope to the G1 timeframe, so I think it's reasonable
21:43:24 <ttx> How much work does resource-introspection represent ?
21:43:40 <gabrielhurley> a couple days of my time. If that one slips to G3 it'll be okay though
21:43:46 <gabrielhurley> I downgraded it from essential to high
21:44:07 <ttx> cool. Anything else you wanted to mention ?
21:44:20 <gabrielhurley> first horizon team meeting is in about 15 minutes in this IRC channel
21:44:27 <gabrielhurley> that's all
21:44:28 <heckj> woot!
21:44:36 <ttx> which means I only have 15min with the baby projects
21:44:45 <gabrielhurley> incentive to keep on schedule ;-)
21:44:46 <stevebake> https://launchpad.net/heat/+milestone/grizzly-2
21:44:48 <ttx> #topic Incubated projects
21:45:01 <ttx> stevebake: How complete is that ?
21:45:26 <stevebake> well, there is feature work which should probably have blueprints, but we're getting better
21:45:37 <ttx> stevebake: So your repo is moved now. Next steps are:
21:45:42 <ttx> * Ask CI to set up the tarball-building Jenkins jobs
21:45:47 <ttx> * Finalize your grizzly blueprints plan
21:46:02 <stevebake> we'll probably start to wind down dev soon and work on more bugs and docs
21:46:03 <ttx> On that last point... I have a few generic advice that is also valid for Ceilometer
21:46:08 <stevebake> shoot
21:46:13 <ttx> * Only use "Unknown" as implementation status if you have no idea what the status is. Most times what you actually want is "Not started" instead
21:46:19 <ttx> * Get everything prioritized
21:46:25 <ttx> * Try to have assignees and milestones for all the High priority stuff
21:46:33 <ttx> * Make sure all milestone-targeted blueprints have series goal = grizzly set
21:46:34 <stevebake> yeah, ReST API is actually almost complete
21:46:41 <ttx> (LP doesn't enforce that and it makes the series/milestone views confusing)
21:46:47 <ttx> * You can use https://github.com/ttx/bp-issues to run ttx.py which emulates a number of sanity checks I make with blueprints
21:46:48 <stevebake> ok
21:46:50 <jd__> (Ceilometer is listening)
21:47:10 <ttx> In case you haven't read it yet, your bible lives at http://wiki.openstack.org/PTLguide
21:47:23 <stevebake> speaking of PTL...
21:47:53 <stevebake> Ours would be Steve Dake, who has been ill since before summit and will hopefully be back mid-jan
21:48:30 <ttx> ok
21:48:32 <stevebake> we're quite happy to carry on without one until then, unless we need to semi-officially appoint an interim
21:49:03 <ttx> stevebake: that's fine (carrying on without one until then)
21:49:13 <ttx> Also note that if you add "openstack-release" to the heat-drivers team I can help you fix minor things in your Launchpad pages
21:49:19 <ttx> Like dates on your milestones etc.
21:49:36 <ttx> jd__: representing Ceilometer ?
21:49:39 <stevebake> ok.
21:49:42 <jd__> ttx: yes, nijaba's away
21:49:46 <ttx> Looking at https://blueprints.launchpad.net/ceilometer/grizzly
21:49:59 <ttx> Starts looking good... hints from above also apply to you
21:50:11 <jd__> yes, I'll transmit those to nijaba :)
21:50:15 <ttx> I was looking at https://launchpad.net/ceilometer/+milestone/grizzly-2 ...
21:50:22 <ttx> Is that a complete plan ? Or you still working on it ?
21:50:29 <jd__> that's the complete plan
21:50:43 <jd__> we reviewed it with nijaba today
21:50:46 <ttx> ok, then you look pretty much on track
21:51:02 <jd__> trying :-)
21:51:05 <ttx> on another note, the thread on the nova/ceilometer integration died without a clear way forward afaict...
21:51:20 <ttx> looks like we depressed you to death
21:51:34 <jd__> no, we've a review about this I think
21:51:46 <ttx> jd__: pointer ?
21:51:47 <jd__> https://review.openstack.org/#/c/17463/
21:51:59 <jd__> didn't checked it yet, I might be wrong though
21:52:29 <markmc> #link https://blueprints.launchpad.net/ceilometer/+spec/nova-independent-virt
21:52:33 <markmc> looks like it alright
21:53:05 <ttx> ok, will look into it. Was wondering about that
21:53:16 <jd__> cool
21:53:31 <ttx> OK, that's all the advice I had in my bag for today... maybe you have questions ?
21:53:43 <ttx> for the first time in a long time we actually have extra time :)
21:53:51 <jd__> I'm good :)
21:54:40 <ttx> stevebake: any question ?
21:54:52 <stevebake> all good here
21:55:07 <ttx> well, back to work then :)
21:55:13 <jd__> :-)
21:55:13 <ttx> (or back to sleep)
21:55:19 <ttx> #endmeeting