21:02:24 <ttx> #startmeeting project
21:02:25 <openstack> Meeting started Tue Dec 11 21:02:24 2012 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:28 <openstack> The meeting name has been set to 'project'
21:02:33 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:46 <ttx> We are 10 days away from the end of the world, and 4 weeks away from grizzly-2
21:02:57 <annegentle_> *snort*
21:02:57 <ttx> #topic Swift status
21:03:04 <ttx> notmyname: o/
21:03:06 <notmyname> ttx: thanks
21:03:08 <ttx> #link https://launchpad.net/swift/+milestone/1.7.6
21:03:22 <notmyname> heh. that's rather empty :-)
21:03:22 <Vek> one of these two things is substantially more likely than the other...
21:03:24 <ttx> List is still a bit empty, anything you want to communicate should land / be fixed in that version ?
21:03:45 <notmyname> I'll work on updating it this week. 1.7.6 is going to be mostly bug fixes
21:03:45 <ttx> or that's still a bit early for that
21:03:54 <notmyname> but we do have some interesting patches (at least proposed)
21:03:55 <vishy> o/
21:04:08 * vishy requests going early since I have to leave soon
21:04:10 <ttx> #action notmyname to update https://launchpad.net/swift/+milestone/1.7.6 with 1.7.6 objectives
21:04:28 <notmyname> in talking with some contributors, I know there are some interesting features being worked on.
21:04:28 <ttx> vishy: going on the same plane as John ?
21:04:47 <notmyname> nope :-)
21:04:47 <ttx> notmyname: Still shooting for mid-January ?
21:05:05 <notmyname> yes. 1.7.6 should be mid-january. no date yet
21:05:10 <ttx> Sounds good.
21:05:13 <ttx> Anything more on Swift ?
21:05:18 <notmyname> I hope to have one or 2 more releases before grizzly
21:05:21 <notmyname> after 1.7.6
21:05:33 <notmyname> but if that happens or not depends on the state of the code
21:05:33 <ttx> ack
21:05:44 <notmyname> goal is 2
21:05:49 <notmyname> 1.8 and 1.8.1
21:06:03 <ttx> notmyname: I'll talk to you another day on the possibility to use RCs for the "final" grizzly one
21:06:04 <notmyname> but that's not official at all. just goals
21:06:11 <notmyname> ack
21:06:14 <notmyname> that's all I have
21:06:34 <ttx> vishy: wanna go now or after general announcements ?
21:07:24 <ttx> let's do general announcements first, Nova next
21:07:27 <ttx> #topic General announcements
21:07:36 <ttx> #info Bug squash day coming this Thursday
21:07:41 <ttx> #link http://wiki.openstack.org/BugDays/20121213BugSquashing
21:07:41 <vishy> k
21:07:50 <annegentle_> o/
21:07:53 <ttx> If you're available, join the crowd on #openstack-bugsquash to help with advice/review
21:08:02 <markmc> #info Nova 2012.2.2 scheduled for Thursday December 13
21:08:04 <markmc> #link https://launchpad.net/nova/+milestone/2012.2.2
21:08:15 <ttx> annegentle_: was the doc bug squash day any successful ?
21:08:23 <ttx> markmc: Will also include the recent security fix that just landed on stable/folsom
21:08:26 <annegentle_> yes, nearly 20 doc bugs squashed in a day
21:08:30 <markmc> ttx, yep
21:08:33 <annegentle_> now we are back porting to folsom as needed
21:08:35 <annegentle_> #info Outreach Program for Women accepted candidates announced today
21:08:42 <annegentle_> #link https://live.gnome.org/OutreachProgramForWomen#OpenStack
21:08:53 <zykes-> thanks to the stable team for backporting the nova floating ip with quantum stuff!
21:08:58 <annegentle_> Welcome to Laura, Anita, Victora.
21:09:11 <markmc> annegentle_, nice on both counts :)
21:09:12 <ttx> Welcome!
21:09:20 <ttx> markmc: did you analyze why automated testing didn't catch the stable/folsom regressions ?
21:09:24 <markmc> annegentle_, irc nicks for them?
21:09:35 <markmc> ttx, yes
21:09:39 <markmc> so, 2 bugs
21:09:43 <ttx> markmc: any corrective actions ?
21:09:48 <markmc> https://bugs.launchpad.net/nova/folsom/+bug/1083944
21:09:56 <markmc> that one came after the release
21:09:56 <annegentle_> Anita is anteaya_i, not sure about Laura and Victoria off the top of my head.
21:09:58 <uvirtbot> Launchpad bug 1083944 in quantum/folsom "RPC exchange name defaults to 'openstack'" [Critical,In progress]
21:10:05 <annegentle_> blog entry forthcoming, I'll include that info
21:10:16 <markmc> basically, unless we were testing notification consumption in the gate, it's unlikely the gate would have caught it
21:10:25 <markmc> and https://bugs.launchpad.net/ubuntu/+source/nova/+bug/1081836
21:10:27 <uvirtbot> Launchpad bug 1081836 in nova "nova-compute (folsom) fails to start, compute_driver is None" [Undecided,Confirmed]
21:10:38 <markmc> that wasn't caught because it was an issue with the default value of a config option
21:10:46 <markmc> but devstack explicitly sets the value of it
21:10:59 <markmc> so, no - don't really have suggestions for either
21:11:11 <ttx> food for thoughts for QA folks
21:11:19 <ttx> mordred, annegentle, davidkranz: Anything to report from CI/QA/Docs land ?
21:11:40 <zykes-> (clear
21:11:57 * annegentle_ is in training all week, off IRC mostly
21:12:10 <ttx> Everyone ready to go project-specific ?
21:12:32 <comstud> yes sir
21:12:33 <ttx> #topic Nova status
21:12:37 <ttx> vishy: o/
21:12:42 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-2
21:12:46 <vishy> hi
21:13:05 <ttx> not that much visible progress since last week
21:13:09 <ttx> Mostly due to a growing review queue, apparently ?
21:13:29 * Vek is intending to do a pile of reviews tomorrow, fyi
21:13:51 <vishy> i have been too busy to do my normal 70 reviews /wk
21:13:56 <russellb> i've been down on my review amounts lately, too
21:14:03 <vishy> hope to have some time to get to some over the next couple weeks
21:14:13 <ttx> #info Focus on review for nova-core
21:14:22 <ttx> nova-compute-cells: how are we doing there ?
21:14:34 <comstud> i've been sick for a week, i'm back at it today
21:14:50 <comstud> reworked a lot.. mostly have tests left
21:14:53 <comstud> and whatever typos i made
21:15:01 <comstud> then the reviews will be updated
21:15:26 <ttx> vishy/nova-core: it's your feeling that it's relatively close now ?
21:15:54 <comstud> there's not been a lot of new input/comments, holding off for my latest
21:16:10 <ttx> russellb: how is version-rpc-messages doing ?
21:16:20 <russellb> patch is up in oslo-incubator
21:16:39 <russellb> I think it's pretty close ... i need to get it running though all the nova tests too
21:16:49 <ttx> ok
21:16:49 <markmc> yeah, it's very close
21:16:56 <ttx> In other news, I've been chasing down a number of assignees to get milestone targets from them
21:17:11 <ttx> Got answers from mostof them
21:17:24 <ttx> devananda mentioned that some of the DB blueprints might just not hit grizzly
21:17:35 <ttx> since he is focusing on baremetal stuff now
21:17:43 <markmc> boo :(
21:18:09 <ttx> vishy: he is supposed to communicate that to you while bumping some off Grizzly series goal
21:18:21 <russellb> sad
21:18:23 <ttx> I did not get answers (or updates) at all from Phil Day and TianTian Gao
21:18:27 <vishy> ok that makes sense
21:18:51 <ttx> all in all fishing for updartes was successful
21:18:57 <ttx> updates*
21:19:34 <ttx> That's all I had on the Nova front. We need to make good progress over the next week
21:19:47 <vishy> cool
21:19:59 <ttx> because I expect a slowdown at the end of December, somehow
21:20:07 <ttx> Any question on Nova before we move on ?
21:20:30 <ttx> #action devananda to defer Db blueprints he won't have time to cover
21:20:59 <ttx> #topic Oslo status
21:21:03 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-2
21:21:14 <ttx> markmc: Almost on track...
21:21:26 <ttx> markmc: About oslo-versioning, unfortunately mordred was nowhere to be seen today
21:21:27 <markmc> yep, we're looking pretty good
21:21:33 <markmc> yeah
21:21:34 <ttx> I'll set up a meeting with him asap
21:21:40 <markmc> I'm not really letting it block me
21:21:44 <ttx> #action ttx to set up a meeting with mordred and markmc to make quick progress on oslo-versioning
21:21:53 <markmc> AFAICT, we have a plan and it should just work
21:22:05 <markmc> so it's really down to me to push ahead with oslo-config
21:22:23 <markmc> but confirming with mordred would be good
21:22:28 <ttx> markmc: yeah, I just want that plan outlined so that I can tell if I'm fine with it :)
21:22:37 <markmc> ttx, cool
21:22:40 <mordred> markmc: aroo?
21:22:42 <mordred> reading
21:22:47 <ttx> here he is
21:22:51 <ttx> markmc: In other news, I'm waiting on https://review.openstack.org/#/c/17672/ to start common-rootwrap
21:22:56 <ttx> Would appreciate your review on that
21:23:10 <markmc> ttx, yep, nova-core are slackers
21:23:10 <markmc> oh wait, that's me too :(
21:23:26 <mordred> markmc: yes, I believe we're in good shape in our plans - I would like to sync up with you to verify that my impl thoughts for it will work for you
21:23:31 <russellb> nova-core is overwhelmed, that's what
21:23:39 <ttx> mordred: maybe we can push that discussion offmeeting, just after this one ?
21:23:49 <ttx> if markmc is still around
21:24:03 <markmc> nah, I've got to disparu
21:24:20 <markmc> mordred, quick summary ?
21:24:21 <ttx> that doesn't sound right in any language
21:24:36 <markmc> disparoo?
21:25:33 * ttx parallelizes -- do we have someone from keystone crew to represent ?
21:26:41 <ttx> mordred: if you push your thoughts to ML right now, markmc might be able to confirm and me to read it today
21:26:59 <ttx> mordred: or if it's short and quick you can do it now
21:27:42 <ttx> ... ok, let's do Glance in the interlude
21:27:49 <ttx> #topic Glance status
21:27:55 <ttx> bcwaldon: o/
21:28:00 <bcwaldon> ttx: hey
21:28:05 <ttx> This is a chaotic agenda
21:28:09 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-2
21:28:21 * ttx refreshes
21:28:28 <ttx> Not a lot of visible progress recently
21:28:33 <bcwaldon> unfortunately little progress lately
21:28:41 <ttx> api-v2-property-protection and glance-api-v2-image-sharing are still not started ?
21:29:04 <bcwaldon> we've had a few design discussions
21:29:14 <bcwaldon> but have been blocked on external things to actually work on them
21:29:26 <bcwaldon> I'm still not worried about finishing them for g-2
21:29:36 <ttx> ok
21:29:41 <ttx> glance-domain-logic-layer: will it be complete once that last review lands ?
21:29:49 <ttx> review @ https://review.openstack.org/#/c/17512/
21:29:50 <bcwaldon> that's a question for markwash
21:30:13 <bcwaldon> just poked him
21:30:20 <markwash> ttx: not entirely
21:30:30 <ttx> bcwaldon: will you have time to make good progress by next week ? Or intend to work during the holidays ?
21:30:42 <ttx> markwash: ack
21:30:47 <bcwaldon> ttx: holi-day?
21:30:58 <bcwaldon> yes I will be working ;)
21:31:01 <markwash> ttx: but it is very close, only two easier patches left
21:31:16 <ttx> apparently some sort of evening, lasting a bit longer
21:31:48 <ttx> ok then, I don't sense panic in you yet, so probably fine
21:31:51 <ttx> Anything more on Glance ?
21:32:26 <bcwaldon> not from me
21:32:40 <ttx> Still no keystone folk ? dolphm, ayoung ?
21:32:46 <ttx> #topic Quantum status
21:32:53 <ayoung> ttx I can fill in
21:32:53 <ttx> danwent: hi!
21:32:55 <danwent> ttx: guess you're going to have to talk to me :)
21:32:59 <ttx> ayoung, cool, you're next
21:33:06 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-2
21:33:23 <ttx> Looks on track to me... just needs some serious review work
21:33:28 <danwent> as a general update, things are moving a bit slowly, as it seems like a lot of folks have pre-holiday internal deadlines that they are trying to hit
21:33:45 <ayoung> yeah, we are cranking.
21:33:48 <danwent> yes, key focus need to be on clearly several big reviews a week from here on out
21:34:06 <ttx> quantum-db-upgrades: how is that going ?
21:34:07 <danwent> overally, seems managable, as long as we don't fall off a holiday cliff :)
21:34:42 <danwent> ttx: its been "about to be posted for review" for over a week now. this is one of the items stalled due to other internal projects. I'm confident mark will have it up soon.
21:34:57 <ttx> ok
21:34:58 <danwent> and his stuff is always super high quality when it hits the review
21:35:07 <ttx> danwent: There was also this question for vishy and you about nova-network deprecation
21:35:10 <danwent> so it tends to get reviewed and merged quickly.
21:35:14 <ttx> on the ML @ http://lists.openstack.org/pipermail/openstack-dev/2012-December/003860.html
21:35:22 <ttx> Is the idea still *not* to mark nova-net deprecated in Grizzly ?
21:35:46 <danwent> ttx: yes, nova-network will be fully supported in grizzly
21:36:03 <danwent> sorry, if it doesn't have quantum in the subject-line, i tend to miss things on the ML
21:36:07 <ttx> danwent: ok, maybe drop a quick note on that thread
21:36:14 <danwent> sure
21:36:23 <ttx> danwent: yes, that's why I mention it
21:36:48 <ttx> That's all I had. Anything else on Quantum, anyone ?
21:36:51 <danwent> maybe i'll update my filter to include "network" :)
21:37:07 <ttx> sounds risky
21:37:13 <danwent> :)
21:37:32 <ttx> #topic Keystone status
21:37:37 <ttx> ayoung: o/
21:37:41 <ttx> Thanks for filling in
21:37:49 <ayoung> No problem.
21:37:52 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-2
21:38:17 <ayoung> We had a pretty long discussion over the groups implementation earlier today.
21:38:26 <ayoung> #link https://blueprints.launchpad.net/keystone/+spec/user-groups
21:38:45 <ayoung> We should have a proof of concept/reference implementation posted shortly
21:38:50 <ttx> Yeah, some progress since last week, but I'd say this is falling a bit behind due to impl discussions
21:39:01 <ttx> around user-groups and trusts
21:39:13 <ttx> about trusts: is that making progress ? It looks like it's still on the drawing table (which is not necessarily a bad thing)
21:39:27 <ttx> but maybe that means it's more likely to land in g3 ?
21:39:35 <ttx> (trying to set expectations right)
21:39:35 <ayoung> I think we are ok. I have an Impl of trusts, but need to rebase it on the code review...
21:39:50 <ayoung> #link https://review.openstack.org/#/c/17782/
21:40:22 <ttx> ayoung: so that lengthy thread converged to a solution that was acceptable for everyone ?
21:40:28 <ttx> ayoung: or that covers something else ?
21:40:57 <ayoung> Trusts are not that hard. They are just another way to generate tokens. Getting them in required working out a circular dependency issue. I still need to get dolph's blessing. That is on the short list for this week
21:41:06 <ayoung> long thread? You mean about groups?
21:41:34 <ttx> ayoung: the one on preauthed tokens
21:41:45 <ayoung> ttx, yes, we are OK with the approach
21:42:00 <ayoung> some quibbling over naming, but I think we are going to keep the name trusts
21:42:09 <ttx> eh, ok
21:42:13 <ttx> Anything more about Keystone ?
21:42:43 <ayoung> we still need to finish the V3 api..
21:43:01 <ttx> ayoung: is that covered by a blueprint somewhere ?
21:43:06 <ayoung> Oh, and the Keyring support. We are going to document clearly what the intention is with that
21:43:11 <ayoung> ttx, V3? Yes.
21:43:49 <ttx> ayoung: not sure it appears as clearly though
21:44:09 <ttx> ayoung: if you have a pointer to it, I could use that
21:44:19 <ttx> ok, got to move on
21:44:24 <ttx> #topic Cinder status
21:44:27 <ttx> jgriffith: hi!
21:44:29 <jgriffith> howdy
21:44:32 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-2
21:44:54 <jgriffith> getting there, expect a few more to close in the next couple of days
21:44:57 <ttx> Not too bad, but not much progress since last week
21:45:03 <ttx> ok, great
21:45:17 <jgriffith> ttx: yeah, it became earily quiet after Friday :)
21:45:18 <ttx> About local-storage: still no news ?
21:45:47 <jgriffith> No... I've got that and volume_backups targetted for removal tomorrow
21:45:50 <jgriffith> pending the cinder meeting
21:45:58 <ttx> ok, sounds good
21:46:06 <ttx> That's all I had for you
21:46:13 <ttx> Anything more in Cinder ?
21:46:55 <ttx> #topic Horizon status
21:47:00 <ttx> gabrielhurley: hey
21:47:04 <gabrielhurley> hi
21:47:06 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-2
21:47:21 <ttx> Same as others, slow progress overall
21:47:31 <gabrielhurley> some progress on blueprints from me, and one bumped out (the implementor doesn't think it'll be done by the close of G2)
21:47:45 <gabrielhurley> lots of good bugfixes in review, though, and only one or two new bugs
21:48:25 <gabrielhurley> I'm gonna coordinate with the quantum team more closely to figure out what's happening with Quantum + Horizon in G2/G3
21:48:42 <ttx> sounds good
21:48:57 <gabrielhurley> If nthing else G2 may be a les feature rich but more bugfix-y milestone
21:49:07 <gabrielhurley> I still have hopes that I'll be able to hack a bunch later this month
21:49:13 <ttx> yes, that's a decent buglist
21:49:24 <gabrielhurley> eh, I just roll the bugs I think are important from release to release
21:49:24 <ttx> Anything more on Horizon ?
21:49:47 <ttx> gabrielhurley: suggestion: work on them this Thursday !
21:49:53 <gabrielhurley> indeed
21:49:54 <ttx> yay for bug squashing day !
21:50:19 <ttx> #topic Incubated projects
21:50:23 <ttx> Anyone from Ceilometer team ?
21:50:47 <ttx> stevebake: still around ?
21:50:51 <stevebake> yop
21:50:56 <ttx> #link https://launchpad.net/heat/+milestone/grizzly-2
21:51:06 <stevebake> ttx.py ran cleanly
21:51:16 <ttx> If I read this correctly you're feature-complete for g2 already ?
21:51:35 <stevebake> yes, focusing on testing, bugs, docs, packaging
21:51:35 <ttx> or that's incomplete :)
21:51:41 <ttx> ok, great
21:51:51 <ttx> You still don't have a heat-tarball Jenkins job set up so I can't integrate you to common release management yet
21:51:58 <stevebake> resourcing will be messy until g-2 thanks to holidays
21:51:59 <ttx> Did you push that request to the CI team ?
21:52:16 <stevebake> ttx: just yesterday, waiting for a review
21:52:32 <ttx> stevebake: link ?
21:52:59 <stevebake> hmm, actually that was only for python-heatclient https://review.openstack.org/#/c/17811/
21:53:36 <stevebake> I'll look into heat-tarball stuff
21:53:55 <ttx> ok, don't hesitate to ping CI folk on #openstack-infra for help/guidance
21:54:07 <ttx> I might have to set a milestoen code to g2 at some point to support that
21:54:17 <ttx> https://blueprints.launchpad.net/heat/grizzly looks good to me
21:54:31 <annegentle_> stevebake: your team is one of the ones with docs on the wiki, is that right? Wanted to be sure you saw the email about the wiki migration.
21:54:43 <stevebake> Does anyone have suggestion for first steps in getting heat into ppa:openstack-ubuntu-testing/grizzly-trunk-testing ?
21:55:05 <annegentle_> stevebake: we can work on a "doc plan" more to get out of the wiki as you keep moving forward
21:55:14 <stevebake> annegentle_: yes, mostly reachable from http://wiki.openstack.org/Heat
21:55:33 <stevebake> that would be very much appreciated
21:55:42 <ttx> stevebake: contacting jamespage would be a start. Not sure they would cover non-core stuff just yet. Do they have ceilometer in ?
21:55:54 <stevebake> ceilometer is in
21:56:14 * nijaba confirms
21:56:14 <ttx> stevebake: ok, then I guess they could consider heat as well. Ask jamespage
21:56:25 <stevebake> annegentle_: I saw ceilo has some docs action happening too
21:56:38 <ttx> nijaba: rady to talk Ceilometer ?
21:56:41 <ttx> ready*
21:56:41 <annegentle_> #action annegentle_ to reach out to Heat (stevebake) via email re: doc plan
21:56:43 <nijaba> ttx: I just got heat packaged in debian, could help
21:56:52 <nijaba> ttx: sure
21:56:55 <ttx> #link https://launchpad.net/ceilometer/+milestone/grizzly-2
21:57:02 * jamespage hears his nick
21:57:08 <ttx> Looks on track to me. Who is planning to work on provide-meter-units ?
21:57:20 <nijaba> guillaume pernot is on it
21:57:20 <ttx> jamespage: see stevebake request above
21:57:26 <jamespage> ttx: ack
21:57:36 <ttx> nijaba: maybe add him as assignee then
21:57:45 <ttx> nijaba: Your CI jobs are now up to par afaict, ready for me to handle your g2 milestone if you wish
21:57:54 <nijaba> will do as soon as the bp is finished and approved
21:57:56 <ttx> To do that I'll need some of your time on that milestone week, as described in:
21:58:04 <ttx> #link http://wiki.openstack.org/PTLguide#Special_actions_on_Milestone_delivery_week
21:58:12 <ttx> (should be no issue given that we share a timezone)
21:58:17 <nijaba> ack
21:58:22 <ttx> I would push it after the core projects release, and ping you so that you can make the announcement yourself
21:58:34 <nijaba> great, thanks a lot
21:58:39 <ttx> Looking at Ceilometer general grizzly plan now:
21:58:43 <ttx> #link https://blueprints.launchpad.net/ceilometer/grizzly
21:59:05 <ttx> Still a few "unknown" status and missing priorities
21:59:19 <nijaba> yes, we have been concrentrating on g2
21:59:22 <ttx> Also don't forget to set the series goal to "grizzly" for stuff that is targeted (for example, multi-publisher)
21:59:38 <ttx> otherwise the per-series and per-milestone views are not coherent
21:59:49 <nijaba> k
21:59:57 <ttx> nijaba, stevebake: any quick question before we wrap up ?
22:00:03 <stevebake> all good
22:00:07 <nijaba> all good here
22:00:12 <ttx> cool
22:00:15 <ttx> #endmeeting