21:01:14 <ttx> #startmeeting project
21:01:15 <openstack> Meeting started Tue Jan 15 21:01:14 2013 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:18 <openstack> The meeting name has been set to 'project'
21:01:20 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:33 <ttx> We'll spend most of our time looking at grizzly-3 plans and adjusting them so that they are reasonable
21:01:46 <ttx> discussing swift first before notmyname disappears
21:01:49 <ttx> #topic Swift status
21:01:52 <notmyname> thanks
21:01:54 <ttx> #link https://launchpad.net/swift/+milestone/1.7.6
21:02:01 <notmyname> we're preparing for 1.7.6
21:02:06 <ttx> I saw you set a tentative date during your meeting last week, which I reflected on that milestone page
21:02:15 <notmyname> things are looking good, and I think we're on track for next week
21:02:33 <notmyname> I think we can cut a milestone-proposed branch later this week
21:02:45 <ttx> sure, just keep me posted on when I can cut a milestone-proposed branch (when you have things frozen for QA)
21:02:53 <notmyname> I'v also added a 1.8 milestone to target things against
21:03:00 <notmyname> ttx: will do
21:03:04 <ttx> sounds good
21:03:23 <notmyname> swift meeting next week (not tomorrow)
21:03:31 <notmyname> I think that's all I have
21:03:33 <notmyname> questions?
21:03:37 <ttx> no, that's all I had
21:03:47 <notmyname> thanks for letting me go first
21:03:51 <ttx> no pb
21:03:59 <ttx> #topic General announcements
21:04:07 <ttx> #info OpenStack Summit registration is open
21:04:11 <jaypipes> o/
21:04:20 <ttx> If you had a contribution merged in Folsom or Grizzly, you should have received a free registration code
21:04:37 <ttx> We'll issue new codes for late grizzly contributors around grizzly-3 milestone
21:04:59 <ttx> so it's not too late, hint hint
21:05:08 <ttx> markmc, mordred, annegentle, davidkranz: Anything from Stable/CI/QA/Docs teams ?
21:05:15 <markmc> #info 2012.2.3 scheduled for January 31st, aiming for RC and slushy freeze on January 24th
21:05:24 <markmc> we're behind on stable/folsom reviews
21:05:37 <markmc> and there's probably a bunch of backports queued up waiting to be done
21:05:47 * markmc will poke people for help
21:05:49 <ttx> markmc: I'll see if I can devote a few cycles to that
21:05:55 <markmc> ttx, thanks
21:06:17 <davidkranz> ttx: We've got a lot of new contributors but nothing specific to report.
21:06:26 <ttx> mordred, jeblair: anything from infra team ?
21:07:02 <annegentle_itsme> o/
21:07:09 <ttx> annegentle_itsme: go ahead
21:07:13 <annegentle_itsme> I'll send an email to the mailing list about progress on the wiki migration
21:07:32 <annegentle_itsme> basically hoping to synch up after a few more tasks are done and the CLA is solid
21:07:47 <ttx> cool, cut off before the end of month I think ?
21:08:09 <annegentle_itsme> ttx: sounds right
21:08:21 <ttx> annegentle_itsme: anything else ?
21:08:25 <annegentle_itsme> that's it
21:08:32 <ttx> OK, let's move to project-specific topics then...
21:08:38 <ttx> #topic Oslo status
21:08:43 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-3
21:08:53 <markmc> pretty light on bps this time around
21:08:55 <ttx> markmc: that plan looks very reasonable
21:09:01 <markmc> wouldn't be surprised if more come in
21:09:09 <markmc> I need to get on the oslo-config release asap
21:09:13 <ttx> Should amqp-rpc-fast-reply-queue be added to the grizzly series goals ?
21:09:25 <ttx> (it's only "proposed" at this point)
21:09:29 <markmc> mostly about figuring out what the CI tasks are
21:09:39 <markmc> ttx, hmm, most likely I screwed up - please fix
21:09:48 <ttx> willdo
21:10:09 <markmc> ah, I see .. proposed
21:10:17 <markmc> common DB needs review help
21:10:19 <ttx> You have four grizzly series blueprints without a milestone set: oslo-build, wsgi-common and no-kombu-default
21:10:31 <ttx> and rpc-api-review
21:10:37 <markmc> ah, good point
21:10:38 <ttx> If you leave them there, they look like targets of opportunity rather than stated objectives
21:10:39 <jeblair> o/
21:10:42 <markmc> I'll knock all them off grizzly
21:10:42 <ttx> which is fine by me
21:10:55 <ttx> yes, if you already know some of them won't make it, or some of them are definitely targeting grizzly-3, you should adjust accordingly.
21:11:02 <markmc> none of them really look like they'll happen in grizzly
21:11:14 <markmc> good catch, thanks
21:11:31 <ttx> Looking at your stuff marked essential... What's the ETA for oslo-config-package ?
21:11:34 <ttx> next few weeks ?
21:11:51 <markmc> yes, I'd hope so
21:12:10 <ttx> ok then. Anything else on the oslo topic ?
21:12:22 <markmc> #action markmc chase what needs doing by CI for oslo-config
21:12:25 <markmc> nope, thanks
21:12:28 <markmc> oh, wait
21:12:37 * ttx waits
21:12:40 <markmc> wanted to mention monty's requirements thread
21:12:43 <markmc> #link http://lists.openstack.org/pipermail/openstack-dev/2013-January/thread.html#4445
21:12:49 <markmc> not strictly oslo related
21:13:00 <markmc> but it's important, cross-project, needs help :)
21:13:20 <markmc> that's it
21:13:21 <ttx> #info Please see http://lists.openstack.org/pipermail/openstack-dev/2013-January/thread.html#4445 about common requirements
21:13:28 <jeblair> the CI part of that should be very easy...
21:13:39 <markmc> jeblair, awesome
21:13:43 <jeblair> the biggest thing is getting a good starting point in the repo
21:13:48 <ttx> jeblair: CI part of oslo-config-package ?
21:14:06 <ttx> OK, good, would like all Essential stuf cleared as early as possible
21:14:13 <jeblair> ttx: the requirements repo. but that too, probably. :)
21:14:17 <ttx> ha
21:14:22 <ttx> #topic Keystone status
21:14:43 <ttx> anyone from keystone ? Looks like we don't have heckj yet
21:14:50 <dolphm> o/ sorta
21:15:13 * dolphm apologizes for not being heckj
21:15:21 <ttx> Hmm, let's wait a bit to give him more time, and you can sub for him if he doesn't show up in a few
21:15:27 <ttx> #topic Glance status
21:15:27 <dolphm> ttx: cool
21:15:35 <ttx> bcwaldon: around ?
21:15:47 <bcwaldon> ttx: yes
21:15:49 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-3
21:16:06 <ttx> bcwaldon: Any idea who is going to work on glance-notifications-deux ?
21:16:11 <bcwaldon> ttx: back-loaded several blueprints :(
21:16:19 <bcwaldon> ttx: just had a conversation about that
21:16:38 <bcwaldon> ttx: seems like we may have someone
21:16:44 <bcwaldon> will lock that down this week
21:17:01 <ttx> bcwaldon: ok. My main concern actually are the 3 "essential" blueprints
21:17:09 <bcwaldon> mine as well
21:17:11 <ttx> I think most of those are highly-desirable, but we /could/ release grizzly without them -- in which case "High" reflects the priority better ?
21:17:32 <bcwaldon> technically, yes
21:17:33 <ttx> could we move some of them to High to reflect that ? I would sleep better at nights
21:17:39 <bcwaldon> I would keep image-sharing as essential
21:17:43 <ttx> agreed
21:17:49 <bcwaldon> the other two, I am still confident about, to be clear
21:17:50 <ttx> since it's finalizing the apiv2
21:17:54 <bcwaldon> yes
21:18:22 <ttx> I think the other two wouldn't delay the release if not complete, to be clear
21:18:35 <bcwaldon> agree
21:18:47 <ttx> so "High" is good, really top priority, but not blocking
21:18:51 <bcwaldon> fine by me
21:18:56 <ttx> will adjust
21:19:01 <ttx> My second concern is the number of blueprints targeted compared to the weight that was pulled in previous grizzly milestones
21:19:10 <ttx> bcwaldon: will you and markwash have more time to throw at Glance in the coming month ? Or should we further cut down the number of objectives ?
21:19:20 <bcwaldon> completely understandable concerns
21:19:29 <bcwaldon> we will have much more time during this milestone, for sure
21:20:32 <ttx> the load is pretty spread between assignees.. I think it's more the review / pushing assignees part that's lacking
21:20:36 <ttx> than pure development time
21:20:47 <bcwaldon> ttx: so you're blaming me, I see how it is
21:20:52 <bcwaldon> which is totally fair :)
21:21:10 <ttx> no, my point is that it's the part that requires regular attention that causes the most problems as to be expected
21:21:20 <bcwaldon> ttx: if you don't see commitment pick up over the next week, you can personally punch markwash
21:21:45 <gabrielhurley> way to man up, bcwaldon
21:21:54 <ttx> OK, let's go with 6 blueprints and see how it goes
21:22:04 <bcwaldon> okie dokie
21:22:16 <ttx> but we'll cut down the objectives at mid-milestone if we see it's going in the same direction as g2 ;)
21:22:25 <ttx> Last remark, there is atmos-storage-adapter planned for grizzly but without a milestone set, do you know when that's supposed to land ?
21:22:42 <bcwaldon> ttx: doubt it will land - the code showed up too late for folsom so it couldn't land
21:22:49 <bcwaldon> got pushed to grizzly, yet I haven't heard back from the original author
21:22:57 <bcwaldon> I can reach out
21:23:04 <ttx> ok, of it lands by miracle we can always add it back
21:23:08 <bcwaldon> sure
21:23:24 <ttx> I'll just un-series-set it, might trigger a response from assignee :)
21:23:28 <ttx> Anything more on Glance ?
21:23:32 <bcwaldon> not from me!
21:23:50 <ttx> bcwaldon: thanks!
21:23:54 <ttx> #topic Quantum status
21:23:55 <bcwaldon> ttx: no, thank you
21:24:02 <ttx> danwent: hi!
21:24:19 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-3
21:24:28 <danwent> hi
21:24:34 <danwent> lots of BPs :)
21:24:38 <ttx> You have a large number of blueprints that are targeted to grizzly-3 but not confirmed in the grizzly series goal (11)
21:24:40 <danwent> but only a few are high, non are essential
21:24:52 <danwent> ttx: i cleaned several up this morning
21:24:56 <ttx> unless you accepted them recently...
21:24:58 <danwent> i thought your script was running clean.
21:25:02 <ttx> arh.
21:25:07 <ttx> you got me
21:25:14 <ttx> Anyway, some of them look like they could be merged in a single blueprint
21:25:15 <danwent> sorry, yeah, did that late
21:25:18 <jeblair> ttx: [quantum devstack gating if you have a sec]
21:25:30 <ttx> but you did that as well
21:25:53 <danwent> ttx: i eliminated a couple, and asked to combine two into one
21:25:55 <ttx> Anyway, yes, that's a pretty large set of blueprints
21:26:01 <ttx> I think you can succeed if you get all the code under review merged ASAP and start to focus on the rest early ?
21:26:45 <danwent> the way i see it is that we'll get our 4 'high' blueprints, as i'll focus the team on those. of the medium priority blueprints, those already in code review stand a good chance of making it, those that are not started will only make it if someone is really driving them.
21:27:03 <danwent> interestingly, no one is super overloaded this milestone, its just a lot of new people signing up for BPs.
21:27:12 <danwent> so its hard to tell which of the medium blueprints will make it ahead of time.
21:27:24 <ttx> ok, that works
21:27:29 <ttx> Would also be good to review the set of grizzly blueprints that don't have a milestone set at https://blueprints.launchpad.net/quantum/grizzly
21:27:43 <ttx> (same remark as the other projects)
21:27:50 <ttx> There are 15 of them, and I'm pretty sure you know some of them that won't make it and should be removed from the series goal
21:27:52 <danwent> ttx: good point, will do
21:27:58 <ttx> Others can be kept as "targets of opportunity", time permitting.
21:28:06 <danwent> agreed.
21:28:08 <ttx> but somehow I doubt there will be that many :)
21:28:23 <danwent> yeah, seems to work our that way, huh? :)
21:28:25 <ttx> jeblair: quantum devstack gating ?
21:28:31 <jeblair> https://review.openstack.org/#/c/19724/
21:28:46 <danwent> jeblair: yup, i gave my +1 to that earlier
21:28:53 <jeblair> Nachi did some analysis of failures of quantum and non-quantum devstack-gate runs
21:29:10 <jeblair> that review addresses the largent difference in failures between them
21:29:20 <jeblair> i think after that's in, we should be able to enable quantum gating
21:29:32 <jeblair> which will affect all the projects gated on devstack-gate, of course
21:29:39 <ttx> yay, more tests
21:29:48 <danwent> jeblair: that's great. we've been wanting this for a LONG time :)
21:29:54 <jeblair> yes, indeed!
21:29:55 <danwent> jeblair: thanks for all you help on this
21:30:14 <danwent> and thanks to nachi (who doesn't seem to be online right now)
21:30:18 <ttx> Anything else on Quantum ?
21:30:30 <danwent> not today
21:30:37 <ttx> #topic Cinder status
21:30:43 <ttx> jgriffith: hi!
21:30:47 <jgriffith> Hey there
21:30:54 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-3
21:31:07 <ttx> jgriffith: Who is going to work on quotas-limits-by-voltype ?
21:31:19 <jgriffith> ttx: will likely be me
21:31:35 <jgriffith> updated
21:31:39 <ttx> thx
21:31:45 <ttx> You have 4 blueprints that were targeted to g3 but not approved in the series goal (or prioritized) yet
21:31:56 <jgriffith> ttx: Yeah... you caught me
21:32:04 <jgriffith> ttx: I'm working through things as we speak
21:32:05 <ttx> You should review them and set series goal / priority for those you accept (remove target milestone for those you don't)
21:32:36 <ttx> Last remark about https://blueprints.launchpad.net/cinder/+spec/del-vols-with-snaps
21:32:42 <ttx> It's accepted in grizzly series goal... is that still an objective ?
21:33:03 <jgriffith> I would like to remove it TBH but I wanted to catch vishy before doing so
21:33:15 <ttx> good thing he is around :)
21:33:26 <jgriffith> I'll update after talking through tha tlater
21:33:26 <vishy> looking
21:34:23 <jgriffith> I'll yield, I'm just pretty indifferent on the whole thing
21:35:10 <jgriffith> vishy: the reason I mentioned checkign with you...
21:35:21 <jgriffith> vishy: There's a bug of the same topic that you logged a while back
21:35:50 <jgriffith> https://bugs.launchpad.net/cinder/+bug/970409
21:35:52 <uvirtbot> Launchpad bug 970409 in nova "Deleting volumes with snapshots should be allowed for some backends" [Low,Triaged]
21:36:24 <vishy> jgriffith: I think I was filing that on behalf of others
21:36:31 <vishy> so it isn't really that important to me
21:36:37 <jgriffith> vishy: K
21:36:51 <jgriffith> vishy: I'll give it some more thought and decide later today
21:36:58 <jgriffith> thanks
21:36:59 <ttx> OK, anything more in Cinder ?
21:37:10 <jgriffith> Not from me
21:37:18 <ttx> #topic Nova status
21:37:23 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-3
21:37:28 <vishy> oh hai!
21:37:28 <ttx> vishy: yay, 46 blueprints
21:37:39 <vishy> should be cake!
21:37:41 <ttx> My main concern here is that the review effort to merge all the targeted low-prio stuff distracts us from getting the important stuff done and merged
21:38:11 <ttx> so i wonder if we can afford looking in 46 directions at the same time
21:38:29 <ttx> vishy: what do you think ? Worth a try ?
21:38:37 <comstud> 2 eyes per person.. only need 23 people
21:38:40 <vishy> ttx: well I think some of those need to be cleaned out
21:38:47 <russellb> progress is so bleak on a bunch of those
21:38:48 <vishy> because they stalled
21:38:55 <russellb> yeah, i think some initial cleaning will remove a bunch
21:38:56 <vishy> and just got moved through the milestones
21:39:21 <ttx> ok, could you clean up the objectives at the next Nova meeting ?
21:39:54 <ttx> you can keep the "maybe" stuff in the grizzly series without a milestone set, I guess
21:40:22 <ttx> vishy: What's the ETA of backportable-db-migrations ? You know essential stuff in last milestones keep me awake at nights
21:40:53 <vishy> ttx: that is just something that goes in right at the end
21:41:06 <vishy> ttx: we discussed last summit making 10 blank db migrations
21:41:09 <russellb> the big range of extra migration numbers?
21:41:12 <vishy> so that we can backport stuff if necessary
21:41:29 <vishy> so there isn't any real work to be done there
21:41:31 <ttx> oh. ok
21:41:53 <ttx> a few random remarks then...
21:42:04 <ttx> https://blueprints.launchpad.net/nova/+spec/cpu-entitlement is targeted to g3 but not in grizzly series
21:42:09 <ttx> Same for recently-added https://blueprints.launchpad.net/nova/+spec/multi-tenancy-aggregates
21:42:31 <ttx> worth reviewing in the same grizzly-3 check meeting
21:42:44 <ttx> If you keep them, set series goal and a priority
21:42:52 <ttx> You also have 21 blueprints in https://blueprints.launchpad.net/nova/grizzly that have no milestone set
21:43:13 <ttx> Would be good to look into them and remove grizzly goal (or set milestone) for those you know won't make it
21:43:25 <ttx> (or will)
21:43:35 <ttx> For example xenapi-config-drive and nova-direct-image-upload look like they are being worked on
21:43:52 <vishy> ttx: ok will look through those
21:44:44 <ttx> at some point in milestone we might uise priority to prioritize the review effort, so also check that priorities reflect that
21:45:12 <ttx> Any question on Nova ?
21:45:45 <ttx> russellb: you add that G3 objectives review topic to the Nova meeting agenda ?
21:45:57 <russellb> yes i'll add it to the agenda
21:46:06 <ttx> russellb: awesome, thx
21:46:08 <ttx> #topic Horizon status
21:46:12 <ttx> gabrielhurley: hey
21:46:14 <gabrielhurley> yo
21:46:15 <russellb> but i may miss the meeting, have a flight that lands 15 minutes before the meeting ... will try to join from airport
21:46:23 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-3
21:46:30 <ttx> vishy: you will be there, right ?
21:46:49 <vishy> ttx: yes
21:47:03 <ttx> gabrielhurley: 12 blueprints, OI see you removed a few :)
21:47:08 <ttx> vishy: thx
21:47:14 <gabrielhurley> the Horizon team meeting last week was really good. I got clarity on all the blueprints that were in G3, and everything that's still there has an assignee who has actively committed to it. It's more than the last milestone, but if a couple slip that'll be okay.
21:47:29 <gabrielhurley> and yeah, anything that was blocked or hesitant I just bumped out
21:47:53 <ttx> quantum-floating-ip depends on query-service-capabilities, which is not targeted or assigned... does that mean it's unlikely to make it ?
21:48:02 <gabrielhurley> does it now...
21:48:28 <gabrielhurley> that link should probably be severed
21:48:28 <ttx> https://blueprints.launchpad.net/horizon/+spec/query-service-capabilities
21:48:50 <ttx> that would fix it
21:49:00 <gabrielhurley> I think that was more of a "it would be better to implement this way" more than an "it must be implemented this way"
21:49:29 <gabrielhurley> and the feature being in Grizzly to support Quantum is more important than the larger sense of right-ness
21:49:33 <ttx> ok, then remove link and just mention it in whiteboard
21:49:36 <ttx> quantum-vnic-ordering (Medium) depends on orderable-mutiple-choice-field (Low prio) -- should I raise prio for the latter ?
21:49:48 <gabrielhurley> yeah
21:49:53 <ttx> willdo
21:50:13 <gabrielhurley> thanks
21:50:15 <ttx> Finally... inline-table-editing is accepted for grizzly but with no milestone set. Should it be kept that way, as a target of opportunity ?
21:50:19 <gabrielhurley> I fixed the dependency on the other one
21:50:26 <gabrielhurley> ah, no that's bumped out
21:50:34 <gabrielhurley> just didn't get fully unset
21:50:39 <ttx> ok will unset series goal as well
21:50:44 <gabrielhurley> again, thanks
21:50:47 <ttx> so that it doesn't clog views
21:50:49 <gabrielhurley> yeah
21:50:51 <ttx> Anything more on Horizon ?
21:50:57 <gabrielhurley> not this week
21:51:26 <ttx> ok then, no heckj still
21:51:28 <ttx> #topic Keystone status
21:51:32 <ttx> dolphm: around ?
21:51:39 <dolphm> ttx: o/
21:51:45 <ttx> you just got promoted
21:51:48 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-3
21:52:09 <ttx> Looks reasonable too, although it assumes a faster velocity than what you achieved in the first two milestones...
21:52:45 <dolphm> guang-yee has a pretty heavily load
21:52:58 <dolphm> as his bp assignments encompass v3 authentication entirely
21:53:08 <dolphm> so myself and henrynash will be providing him quite a bit of support
21:53:13 <ttx> sounds good
21:53:14 <ttx> dolphm: you have two blueprints in the grizzly series taht are not targeted to any milestone
21:53:22 <ttx> domain-role-assignment
21:53:29 <ttx> default-domain
21:53:36 <ttx> Do you know when that's supposed to land ?
21:53:41 <dolphm> ttx: i just created one today, default-domain... i think that's essential to v3 utility in grizzly
21:53:53 <dolphm> ttx: default-domain is my top priority at the moment
21:54:03 <ttx> ok, so it should get added to grizzly-3 milestone target ?
21:54:09 <dolphm> it's been under discussion for quite a bit amongst core contribs
21:54:13 <dolphm> ttx: yes
21:54:41 <ttx> ok willdo
21:54:41 <dolphm> ttx: domain role assignment is also essentially done, it was mostly a spec change that has already landed
21:54:54 <ttx> so both should be in g3 ?
21:54:59 <dolphm> ttx: yes
21:55:14 <ttx> ok, will push them, adjust status for them to match
21:55:20 <ttx> Anything more about Keystone ?
21:55:34 <dolphm> ttx: that sounds like it to me
21:56:06 <ttx> what status should domain-role-assignment have ?
21:56:30 <ttx> beta available, needs code review or implemented ?
21:56:50 <dolphm> ttx: i'm checking on that now, i'll let you know after the meeting
21:56:55 <ttx> sure
21:57:02 <ttx> #topic Incubated projects
21:57:07 <ttx> Anyone from Ceilometer team ?
21:57:24 <ttx> #action dolphm to update status for domain-role-assignment
21:57:29 <ttx> Anyone from Heat team ?
21:57:32 <stevebaker> y
21:57:32 <sdake> #link https://launchpad.net/heat/+milestone/grizzly-3
21:57:50 <sdake> our main focus for g3 is fixing bugs
21:57:54 <ttx> Two issues reported by ttx.py:
21:57:58 <ttx> aws-cloudformation-init has unknown status
21:58:01 <ttx> resource-properties-schema has unknown status and no priority
21:58:10 <ttx> otherwise looks pretty conservative
21:58:11 <sdake> i'll correct those on our wednesday meeting
21:58:20 <ttx> fixing bugs is good
21:58:31 <ttx> So that plan reflects all your grizzly-3 objectives ?
21:58:44 <stevebaker> is it common to maintain a grizzly branch to build packages from?
21:58:59 <sdake> a few people have asked for more blueprints for specific items, but i've asked they wait until h to implement
21:59:07 <sdake> would like our g to work properly first, features second ;)
21:59:34 <sdake> going to open gates on h-1 for blueprints
22:00:05 <ttx> ok
22:00:10 <sdake> so yes, all objectives unless new bugs open
22:00:17 <ttx> no more time left, anyone from Ceilometer team ?
22:00:34 <ttx> For the record, https://launchpad.net/ceilometer/+milestone/grizzly-3 looks good
22:00:44 <ttx> ceilometer crew should probably review the 28 blueprints you have with series goal = grizzly
22:00:49 <ttx> And remove the series goal for those which won't make it
22:00:56 <ttx> #endmeeting