21:02:12 <ttx> #startmeeting project
21:02:13 <openstack> Meeting started Tue Mar  5 21:02:12 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:16 <openstack> The meeting name has been set to 'project'
21:02:18 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:23 <ttx> #topic General announcements
21:02:37 <ttx> PTL self-nominations are under way, they end this Thursday at 23:59 PST.
21:02:45 <ttx> We still have no candidate for Swift, Horizon and Cinder !
21:02:52 <ttx> #link https://wiki.openstack.org/wiki/PTL_Elections_Spring_2013
21:03:05 <ttx> markmc, mordred, annegentle, sdague/davidkranz/jaypipes: Updates from Stable/CI/QA/Docs teams ?
21:03:10 <annegentle> sure
21:03:18 <ttx> annegentle: I heard you wrote a book.
21:03:24 <markmc> heh
21:03:29 <annegentle> Presenting the OpenStack Operations Guide: https://review.openstack.org/#/c/21791/
21:03:31 <annegentle> ha
21:03:39 <markmc> awesome
21:03:42 <annegentle> #link http://docs.openstack.org/ops/
21:03:54 <mordred> ttx: CI has made improvements in the PyPI mirror
21:03:58 <ttx> yes, that review looks unrelated
21:04:19 <ttx> mordred: you confirm we should not pin anything as part of the release process ?
21:04:24 <mordred> and we're getting closer to closing things down so that we only use that
21:04:27 <annegentle> yeah I'm going through the review backlog that was created with a week focus elsewhere :)
21:04:31 <markmc> nothing to report on stable front - 2012.2.4 still scheduled for 2013-04-11
21:04:45 <jgriffith> ttx: gimmie an hour :)
21:04:46 <mordred> ttx: I cannot confirm that ... there is ongoing debate from people on whether they want that or not
21:04:56 <rmk> annegentle: I was reading the book and its a great start.  Noticed a few points which weren't necessary anymore, such as the need to manually reconnect volumes after a hypervisor reboot
21:05:04 <markmc> mordred, ttx, I've got some conclusions I want to post tonight
21:05:05 <rmk> annegentle: Standard doc bug process?
21:05:11 <ttx> markmc: cool
21:05:12 <markmc> mordred, ttx, summary: we should cap, not pin
21:05:14 <annegentle> rmk: yup
21:05:32 <ttx> #action markmc to post conclusions on version pinning vs. release process
21:05:48 <mordred> markmc: I probably agree with you - but I also think there is some additional testing we need to do to support capping
21:05:52 <annegentle> rmk: you can also edit it yourself with a login
21:05:57 <mordred> also - openstack/requirements
21:05:58 <rmk> annegentle: Even better
21:06:05 <markmc> mordred, oh, absolutely
21:06:15 <annegentle> rmk: but bugs are nice to get a sense of what was changed
21:06:20 <ttx> ok, unless anyone has anything more, we should switch to per-project updates
21:06:37 <mordred> markmc: the oslo-config version and name change _is_ going through, right?
21:06:49 <markmc> that would be the next topic
21:06:50 <ttx> #topic Oslo status
21:06:53 <markmc> heh
21:07:00 <ttx> markmc: be my guest
21:07:02 <Vek> heh
21:07:08 <markmc> yeah, I'm thinking we should pull the trigger on it
21:07:20 <markmc> the versioning change definitely makes sense
21:07:28 <ttx> version change +1, name change +0
21:07:32 <markmc> even if ttx gets to say "I told you so"
21:07:42 <Vek> heh
21:07:47 * ttx always gets to say "I told you so"
21:08:01 <markmc> I'm +0 on the name change too, but there was definitely better arguments for olso.config vs oslo-config
21:08:16 <mordred> version change +, name change +0
21:08:22 <mordred> +1
21:08:24 <markmc> I could see period-separated becoming the convention as more namespace packages start appearing
21:08:25 <mordred> version change
21:08:26 <mordred> dammit
21:08:50 <Vek> version change +1, name change 0
21:08:52 <ttx> markmc: what's the motivation behind renaming ?
21:08:54 <heckj> markmc: yeah, and I think there'll be more coming as we move forward
21:09:14 <mordred> ttx: to rename now to get in front of the ball while we're still in pre-release
21:09:16 <markmc> ttx, that upstream python folks are saying it's more conventional for namespace packages
21:09:16 <heckj> I don't care super-much, but it makes it a bit more self-consistent down the road
21:09:31 <markmc> and we're going to have a family of libraries
21:09:39 <markmc> so if we stick with hyphen-separated now
21:09:42 <mordred> yah. /me is working on two right now
21:09:42 <markmc> they'll all be that way
21:09:56 <ttx> so more alignment, at the cost of forcing distros to rename
21:09:59 <mordred> yes
21:10:04 <markmc> forcing debian to rename
21:10:10 <markmc> ubuntu already did, which was dumb
21:10:13 <mordred> it doesn't force the distros to rename
21:10:18 <markmc> but they get to win :)
21:10:26 <mordred> the distros can choose to rename
21:10:38 <markmc> Fedora ignores the thing and just always uses hyphen-separated
21:10:39 <mordred> if they want to. nothing is tying them to their package name matching the upstream package name
21:10:40 <markmc> mordred, indeed
21:10:46 <ttx> mordred: that's an interesting point
21:11:15 <Vek> markmc: sometimes Fedora doesn't even use a python- prefix; there are lots of "pyfoo" packages, too.
21:11:21 <mordred> yup
21:11:22 <ttx> markmc: you should write up something summarizing what you're about to do(if you haven't already)
21:11:27 <soren> Right, policy recommends, but doesn't require that you follow upstream.
21:11:31 <markmc> Vek, not new packages anymore, better guidelines these days
21:11:33 <soren> In Debian/Ubuntu.
21:11:40 <markmc> ttx, it's on the list
21:11:46 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-rc1
21:11:53 <ttx> markmc: Looks like your exception was implemented (advanced-matchmaking), so we are left with bugfixes ?
21:11:55 <Vek> markmc: Sure, but I'm just pointing out that the historical packages are still there.
21:12:21 <markmc> ttx, yep, just bugs ... and I don't know of anything super-urgent
21:12:28 <markmc> ttx, will compile a list of nice-to-haves though
21:12:37 <ttx> In the Oslo case, I think RC1 should be declared early, so that we can trigger the last updates for consuming projects before /their/ RC1
21:12:49 <markmc> ok, makes sense
21:12:52 <ttx> Looking at the bugfix list, you only have one targeted...
21:12:58 <ttx> Does it accurately reflect the current state of RC1 blockers ?
21:13:18 <markmc> I don't know of any blockers
21:13:25 <markmc> there's a bunch targeted, but all fixed
21:13:42 <ttx> I see bug 1129587 is rated critical but not targeted?
21:13:43 <uvirtbot> Launchpad bug 1129587 in oslo "oslo.config doesn't install oslo package's __init__.py" [Critical,Fix committed] https://launchpad.net/bugs/1129587
21:13:48 <ttx> oh, fixed now
21:14:07 <markmc> yeah, tidied that up just before
21:14:07 <ttx> 9 untargeted "high" bugs and 11 untriaged, yeah, doing another pass could help
21:14:12 <ttx> Anything else on the oslo topic ?
21:14:23 <markmc> nope, sorry for taking up so much time on the renaming
21:14:35 <ttx> sounds like an important topic to me :)
21:14:43 <ttx> #topic Keystone status
21:14:49 <ttx> heckj: o/
21:15:03 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-rc1
21:15:06 * ayoung lurks, too
21:15:09 <heckj> ola
21:15:15 <ttx> The 2 FFEs are still in progress afaict
21:15:30 <ttx> trusts: looks like this is close -- any chance you can get it merged today ?
21:15:38 <heckj> yep- extended back and forth in code reviews.
21:15:46 <ayoung> ttx, just zuul issues now
21:15:49 <dolphm> heckj: update-- it's pending gating now
21:15:54 <ttx> ayoung: cool
21:16:02 <ttx> pluggable-identity-authentication-handlers: what's the status ?
21:16:29 <ttx> The only linked review (https://review.openstack.org/22307) sounds rather peripheral
21:17:19 <heckj> ttx: don't have it off the top and didn't check in earlier today, I"ll have to find out and get back to you
21:17:35 <ttx> gyee: if you have an update, please interrupt us :)
21:17:43 <heckj> :-)
21:17:48 <ttx> You've 15 bugs in the RC1 buglist. Is it a complete set of blockers ?
21:18:00 <heckj> Our focus has been entirely on trusts for reviews, but the pluggable authn wasn't that far downt he list
21:18:09 <ayoung> dolphm, is pluggable-identity-authentication-handlers any different from the auth methods?
21:18:31 <heckj> ttx: based on what we know now - yes, although I expect more to pop up as we go through the testing and verification processes
21:18:33 <dolphm> ayoung: a bit -- it involves the plugin interface that people will be implementing
21:18:36 <ttx> You've 11 other "high" bugs to consider, as well as 49 untriaged bugs
21:19:00 <heckj> ttx: we'll get on triaging those bugs
21:19:03 <ttx> #action ttx/heckj/gyee to get status on pluggable-identity-authentication-handlers to see if the FFe should be extended
21:19:08 <gyee> pluggable auth is mostly there
21:19:19 <heckj> ttx: I expect we'll have it wrapped one way or the other tomorrow.
21:19:29 <heckj> ttx: but will explicitly let you know
21:19:39 <ttx> gyee: already merged but the doc thing at https://review.openstack.org/22307 ?
21:20:13 <ttx> gyee: would be great if you could formally complete it today
21:20:18 <gyee> ttx, that's external auth
21:20:33 <gyee> pluggable auth is different
21:20:46 <ttx> confusing linking due to topic branches
21:21:05 <ttx> gyee: what's missing in pluggable-identity-authentication-handlers ?
21:21:24 <gyee> nothing, dolphm want some enhancements
21:21:33 <gyee> but I think it should be considered done
21:21:39 <gyee> enhancements can be done in H
21:21:52 <ttx> dolphm: would that fly for you ?
21:21:54 <ayoung> ttx, to be explicit
21:22:04 <ayoung> there is a set of auth methods that are implemented by code in
21:22:09 <ayoung> keystone/auth/methods
21:22:10 <dolphm> ttx: i'd like to have tomorrow to discuss and make a decision on that
21:22:16 <ayoung> side note, termie hates the name
21:22:18 <ttx> dolphm: ok
21:23:06 <ttx> #action dolphm/heckj/ayoung to make a final decision on pluggable-identity-authentication-handlers completion by tomorrow
21:23:09 <ttx> Anything more about Keystone ?
21:23:23 <heckj> looking forward to the elections!
21:23:27 <ttx> hehe
21:23:38 <ttx> #topic Swift status
21:23:40 <notmyname> hi
21:23:42 <ttx> notmyname: o/
21:23:45 <ttx> #link https://launchpad.net/swift/+milestone/1.8.0
21:24:09 <notmyname> we're finishing up the last pieces for 1.8 this week and next week
21:24:29 <notmyname> if possible, we'll start on QA, but that may have to extend into the RC time before 4/4
21:24:33 <ttx> Is "Multi region replication" still on your map ?
21:24:51 <ttx> It's marked not started and I didn't see any review mentioned recently
21:25:05 <notmyname> yes. check the dependency graph. actually, everything has been done for it except for the region tier (which is in progress)
21:25:13 <notmyname> that's actually the headline feature of 1.8 :-)
21:25:23 <ttx> notmyname: hehe, great
21:25:31 <ttx> notmyname: don't forget to self-nominate for the PTL election, or encourage a successor :)
21:25:39 <ttx> Anything more on Swift ?
21:26:05 <notmyname> not from me
21:26:07 <notmyname> questions?
21:26:29 <ttx> #topic Glance status
21:26:33 <ttx> bcwaldon: o/
21:26:35 <bcwaldon> good afternoon
21:26:36 <ttx> notmyname: thanks!
21:26:40 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-rc1
21:27:06 <bcwaldon> big change this week is that I bumped multiple-image-locations
21:27:14 <bcwaldon> I don't want to slam it in this late in the cycle
21:27:17 <ttx> yeah, that's what I was trying to figure out
21:27:22 <ttx> recent removal ;)
21:27:29 <bcwaldon> 90% of the feature is done, but the important change left is in the v2 API
21:27:39 <ttx> bcwaldon: agreed
21:27:57 <bcwaldon> since we designed the api to depend on JSON schema, we can actually release the feature immediately in Havana without api changes
21:27:57 <ttx> bcwaldon: that leaves glance-api-v2-image-sharing still under work
21:28:10 <bcwaldon> yep - there are two reviews left to land
21:28:15 <bcwaldon> those will close the featuer out
21:28:25 <bcwaldon> we need to write the docs for the API spec as well
21:28:33 <ttx> bcwaldon: ETA for landing ?
21:28:40 <bcwaldon> today/tomorrow
21:28:45 <ttx> ok
21:28:58 <ttx> 15 bugs on the RC1 buglist at this point
21:29:00 <bcwaldon> making 'good' progress on the bugs
21:29:05 <ttx> All critical and most high bugs targeted, only 2 untriaged -- looks very good
21:29:14 <ttx> Is it a complete list of your RC1 blockers ?
21:29:16 <bcwaldon> markwash and I have kept everything well-triaged over the past week or two
21:29:20 <bcwaldon> as far as I know, yes
21:29:26 <ttx> Looks like you just need some assignees to take them
21:29:37 <ttx> Anything more on Glance ?
21:29:39 <bcwaldon> yep
21:30:06 <bcwaldon> I'm good
21:30:07 <ttx> jgriffith: around now ?
21:30:10 <bcwaldon> 'yep' to needing assignees
21:30:23 <jgriffith> that's me
21:30:24 <jgriffith> :)
21:30:29 <jgriffith> sorry about that
21:30:29 <ttx> #topic Cinder status
21:30:33 <ttx> jgriffith: hi!
21:30:36 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-rc1
21:30:38 <jgriffith> afternoon
21:30:51 <ttx> No FFEs, 6 bugs on the RC1 list
21:30:55 <ttx> Are those the only release blockers, or do you still need to triage the open bugs ?
21:31:14 <jgriffith> I took a quick look a fewminutes ago and I think this is about it
21:31:20 <ttx> OK, looks like you're in good shape.
21:31:23 <jgriffith> I'd like til next week
21:31:30 <jgriffith> ie Monday
21:31:41 <ttx> sure. I'd expect the first RC1 to start appearing next week
21:31:43 <jgriffith> Yeah, depending on what shows up the next few days
21:31:47 <jgriffith> cool... thanks
21:31:56 <ttx> with some late ones in two/three weeks max
21:32:02 <ttx> jgriffith: if you want to stay Cinder PTL, you should probably self-nominate very soon
21:32:05 <ttx> Anything more in Cinder ?
21:32:19 <ttx> vishy: around now ?
21:32:38 <Vek> ttx: Have you skipped quantum?
21:32:39 <danwent> ttx: anything to not have to talk to me, huh? :P
21:32:44 <ttx> oops
21:32:50 <ttx> #topic Quantum status
21:32:52 <danwent> haha
21:32:56 <ttx> danwent: hi!
21:32:58 <danwent> hi
21:32:59 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-rc1
21:33:09 <danwent> summary, we're in pretty good shape
21:33:12 <danwent> both FFEs are in
21:33:14 <ttx> All FFEs are now implemented, I see
21:33:23 <danwent> comfortable with target date of march 12th for RC1
21:33:31 <ttx> Though https://review.openstack.org/23570 is still up
21:33:34 <danwent> bugs that are in 'high' state are those that we consider potential blockers
21:33:49 <danwent> that was a review mistakenly tied to the blueprint.
21:33:55 <ttx> ack, will clean
21:34:08 <danwent> that change has its own bug, and will be delayed untili havana-1
21:34:34 <danwent> bugs that are "medium" are deemed important enough to merge in next week if done, but otherwise will wait for next stable release of grizzly.
21:34:39 <ttx> No critical, most "high" are already on the list, only 2 untriaged -- good job
21:35:00 <danwent> markmcclain has being doing a great job triaging
21:35:18 <danwent> been
21:35:27 * ttx isn't sure he wants multiple markmcs as ptls
21:35:33 <danwent> haha
21:35:40 <danwent> yeah, pretty confusing
21:35:41 <ttx> sounds like a tab completion nightmare
21:35:51 <ttx> Anything else on Quantum ?
21:35:56 <danwent> nothing from me
21:36:09 <ttx> vishy: still not around ?
21:36:18 <vishy> i'm here
21:36:18 <ttx> gabrielhurley: around ?
21:36:19 <danwent> btw, i like the idea of making sure there is overlapp time when nova + quantum can sync at summit
21:36:21 * russellb can sub
21:36:25 <vishy> sorry was afk
21:36:31 <gabrielhurley> ttx hi
21:36:32 <ttx> russellb: not yet :P
21:36:37 <ttx> #topic Nova status
21:36:41 <ttx> vishy: o/
21:36:43 <vishy> hi
21:36:45 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-rc1
21:37:17 <ttx> only backportable-db-migrations left
21:37:23 <ttx> Could we have a blocked review up for backportable-db-migrations ?
21:37:28 <ttx> So that it's just a matter of approving it when we're confident we won't need another one ?
21:37:52 <vishy> a blocked review?
21:37:59 <vishy> sdague: ^^
21:38:03 <ttx> a review with a -2 to "not merge it yet"
21:38:07 <vishy> I"m not sure how many more there are
21:38:25 <sdague> vishy: how many migrations in the queue?
21:38:59 <vishy> oh i'm srorry
21:39:01 <sdague> ttx, vishy: this was just to create a dozen blank migrations right?
21:39:06 <vishy> i got it confused with the other review
21:39:09 <ttx> could we push a set and just use some of them if they happen to be needed ? I suppose we don't expect any more at this point ?
21:39:11 <vishy> yeah I can make a blocked review for that
21:39:14 <vishy> :)
21:39:22 <vishy> i will do that today
21:39:43 <ttx> On the exceptions list, there was mathrock's suggestion of "fixing" fixed_range
21:39:51 <ttx> I've mixed feelings about that. Would have been perfectly fine a few weeks ago...
21:39:59 <ttx> vishy: thoughts ?
21:40:31 <vishy> the fix is pretty darn small but I haven't decided whether it is better in g or h
21:40:38 <ttx> It's reasonably contained but touches config options meaning... I think we have lived with it until now and the timing is a bit bad
21:40:49 <vishy> I'm thinking that putting it in G without changing the default config option might be ok
21:41:02 <ttx> vishy: your call
21:41:07 <vishy> so users would have to turn it on manually
21:41:11 <ttx> but soon:)
21:41:36 <ttx> If it's not in this week, it's out.
21:42:03 <ttx> vishy: 28 bugs on the RC1 blockers buglist. How complete is that ?
21:42:27 <ttx> I see one untargeted critical (bug 1101147), 29 high
21:42:29 <uvirtbot> Launchpad bug 1101147 in nova ""Instance didn't become active" in Devstack Gate Exercises" [Critical,Confirmed] https://launchpad.net/bugs/1101147
21:42:39 <ttx> Only 3 untriaged -- pretty nice achievement for Nova
21:42:41 <vishy> Those are all the bugs i targetted going through new bugs
21:42:51 <vishy> there may be others in previously triaged
21:42:58 <vishy> that haven't gotten targetted
21:43:12 <vishy> I'm not sure that should be marked critical
21:43:29 <ttx> vishy: feel free to downgrade. I don't like critical bugs :)
21:43:45 <sdague> vishy: after all the gate resets I thought there was a push to turn common gate reset bugs critical
21:43:50 <sdague> so they actually got looked at
21:43:57 <ttx> vishy: so you plan to do another pass on older bugs to add them to the RC1 blockers list ?
21:44:08 <vishy> sdague: well there isn't really a clear way to figure out what is going wrong there
21:44:13 <vishy> since it is intermittent
21:44:33 <vishy> i targetted and put it down to High
21:45:18 <ttx> vishy: so you plan to do another pass on older bugs to add them to the RC1 blockers list ?
21:46:03 <vishy> yes that is the plan
21:46:06 <ttx> cool
21:46:08 <ttx> Any question on Nova ?
21:46:32 <ttx> (getting a good base list and staying on top of new bugs is the way to a successful RC !)
21:46:55 <ttx> #topic Horizon status
21:47:00 <ttx> gabrielhurley: hey
21:47:10 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-rc1
21:48:00 <gabrielhurley> hi again
21:48:07 <ttx> One FFe still open: quantum-lbaas
21:48:10 <ttx> How far is it ?
21:48:36 <gabrielhurley> was waiting to see what Dan said during the quantum meeting. Sounds like things are good so this is ready to merge, I do believe.
21:48:42 <gabrielhurley> I'll give it one final review and then merge it up.
21:48:48 <ttx> gabrielhurley: awesome
21:49:02 <ttx> Looks like we have a good handle on our FFEs at this point
21:49:07 <gabrielhurley> always a good thing
21:49:09 <ttx> On the bug list, only 8 blockers left. Is that a full list of your blockers, or do you still need to triage a bit ?
21:49:17 <gabrielhurley> nope, triage is basically all set
21:49:29 <ttx> great, we seem to be in good shape
21:49:31 <ttx> gabrielhurley: ready for another PTL run ? If yes, you should nominate yourself :)
21:49:39 <gabrielhurley> I did during the meeting ;-)
21:49:43 <ttx> hah!
21:49:48 * gabrielhurley loves making ttx refresh pages
21:49:54 <ttx> I can't read ML and do meeting at the same time.
21:49:59 <ttx> Anything more on Horizon ?
21:50:19 <gabrielhurley> not offhand
21:50:34 <ttx> #topic Incubated-in-Grizzly/Integarted-in-Havana projects
21:50:50 <ttx> Anyone from Heat or Ceilometer ?
21:50:53 <sdake_> hi
21:50:59 <ttx> #link https://launchpad.net/heat/+milestone/grizzly-rc1
21:51:07 <sdake_> in good shape
21:51:17 <ttx> 15 bugs on your buglist -- is that the complete set of release blockers from your perspective ?
21:51:24 <sdake_> that we know about ;)
21:51:58 <sdake_> but team working hard to test manually on top of our other test suites
21:52:01 <ttx> yeah, releasing is an act of chicken and egg anyway
21:52:50 <ttx> Anyone from the Ceilo crowd ? nijaba, eoghan, jd__ ?
21:52:54 <sdake_> just to clarify, we will release rc1 on 14th?
21:53:11 <ttx> sdake: no, you release RC1 when your buglist is empty
21:53:17 <sdake_> sounds good
21:53:23 <sdake_> should be before 14th
21:53:30 <ttx> sometimes between now and ~March 20
21:53:38 <sdake_> thanks
21:53:59 <ttx> #link https://wiki.openstack.org/wiki/ReleaseCycle
21:54:53 <ttx> Any other question before we close the meeting ?
21:55:35 <ttx> Alright, all back to bugfixing and making Grizzly an awesome release!
21:55:38 <ttx> #endmeeting