21:02:38 <ttx> #startmeeting project
21:02:39 <openstack> Meeting started Tue Mar 12 21:02:38 2013 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:42 <openstack> The meeting name has been set to 'project'
21:02:53 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:05 <ttx> danwent asked to go last.
21:03:17 <gabrielhurley> I'm not last???
21:03:19 <gabrielhurley> OMG
21:03:26 <ttx> Today we'll look into progress towards RC1 production, which is summarized in a graph at:
21:03:30 <ttx> #link http://status.openstack.org/release/rc/
21:03:47 <ttx> hint: those should be going /down/.
21:03:58 <ttx> #topic General announcements
21:04:19 <ttx> PTL elections for Ceilometer/Keystone/Nova in progress, don't forget to vote
21:04:29 <markmc> we should have a papal conclave instead of boring elections
21:04:52 <ttx> markmc: habemus PTLus
21:04:54 <Vek> markmc: see schneier's write-up of that; makes for interesting reating.
21:04:59 <Vek> s/reating/reading/
21:05:03 <jgriffith> markmc: popeless idea
21:05:10 <ttx> markmc, mordred, annegentle, sdague/davidkranz/jaypipes: Updates from Stable/CI/QA/Docs teams ?
21:05:30 <annegentle> doc team meeting today, transcript at… sec.
21:05:38 <markmc> Vek, thanks for the tip ... bedtime reading :)
21:05:42 <davidkranz> Just moving along.
21:05:52 <markmc> no stable news
21:06:03 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/MeetingLogs/DocTeam03122013
21:06:11 <sdague> ttx: yeh just scraping through stack traces to try to reduce them in components prior to release
21:06:29 <sdague> we still get quite a number on a successful tempest run
21:07:13 <ttx> sdague: ack
21:07:19 * ttx moves on
21:07:22 <ttx> #topic Oslo status
21:07:27 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-rc1
21:07:33 <ttx> markmc: o/
21:07:36 <markmc> went through and triaged bugs etc.
21:07:42 <markmc> I think we're in good shape
21:07:45 <ttx> 1 blocker left: bug 1122763
21:07:47 <uvirtbot`> Launchpad bug 1122763 in oslo "ZMQ ipc socket file is created using un-sanitized network input" [Medium,In progress] https://launchpad.net/bugs/1122763
21:07:54 <ttx> Can we cut the incubator stable/grizzly branch once that bug gets fixed ?
21:07:57 <markmc> yeah, there's a patch with a +2
21:08:02 <ttx> Or do you want to let it bake for a few days ?
21:08:14 <markmc> happy to just go ahead and branch
21:08:22 <ttx> OK, we might get to that tomorrow then
21:08:30 <ttx> oslo-config is published now ?
21:08:30 <markmc> I'll take a look at other projects to see how out of sync they are
21:08:37 <markmc> but everyone is welcome to help out with that
21:08:45 <markmc> yeah, oslo.config 1.1.0 is on pypi
21:08:56 <markmc> we're going through some shenanigans to update all pip-requires to use it
21:08:57 <ttx> #info ETA for oslo grizzly branch: March 13
21:09:06 <markmc> waiting for our pypi mirror to rebuild
21:09:13 <markmc> hopefully should get those changes in tonight
21:09:31 <ttx> Looks like we are in good shape here
21:09:33 <ttx> Anything else on the oslo topic ?
21:09:41 <markmc> nope, that's it
21:09:42 <markmc> thanks
21:09:46 <ttx> thanks!
21:10:16 <ttx> dolphm, ayoung, henrynash: around to represent keystone ?
21:10:44 <ttx> hmm, let's do swift then
21:10:51 <notmyname> let's do swift :-)
21:10:53 <ttx> #topic Swift status
21:10:58 <ttx> notmyname: o/
21:11:02 <ttx> #link https://launchpad.net/swift/+milestone/1.8.0
21:11:06 <ttx> notmyname: How is it going ?
21:11:30 <notmyname> we've got one more patch to merge, and then the plan is to cut the rc tomorrow afternoon
21:11:43 <ttx> notmyname: cool!
21:11:53 <ttx> #info ETA for Swift 1.8.0-rc1: March 13
21:12:03 <notmyname> ttx: what's the plan between you and me to cut the rc?
21:12:10 <ttx> You should change _version in __init__.py from 1.7.7 to 1.8.0 at this point
21:12:28 <notmyname> I'll do that with my AUTHORS/CHANGELOG update
21:12:29 <ttx> push the changelog...
21:12:44 <ttx> then I think I can take it and produce 1.8.0-rc1 from there
21:12:50 <ttx> FWIW I'll rename the Launchpad milestone to 1.8.0-rc1 -- I'll just move the bugs and blueprints over to "final" 1.8.0 when it's done.
21:12:57 <notmyname> ok
21:13:25 <ttx> I updated https://wiki.openstack.org/wiki/ReleaseTeam/HowToRelease for the curious
21:13:58 <ttx> notmyname: anything else ?
21:14:11 <notmyname> not from me. questions?
21:14:26 * vishy is here
21:14:37 <ttx> yay
21:14:54 <ttx> #topic Glance status
21:15:00 <ttx> bcwaldon: o/
21:15:04 <bcwaldon> ttx: markwash is going to give the update today
21:15:08 <markwash> ttx: o/
21:15:09 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-rc1
21:15:14 <ttx> I see. training.
21:15:40 <ttx> markwash: 10 bugs on the list
21:15:47 <ttx> Are those all RC1 blockers now ?
21:16:17 <markwash> ttx: most, yes. . all the ones that aren't in progress are definitely
21:16:42 <markwash> I have very high confidence of the ones in progress being done quickly, reviews are up
21:16:46 <ttx> markmc: who will work on bug 1154317 ?
21:16:48 <uvirtbot`> Launchpad bug 1154317 in glance "Publish new API version '2.1'" [Critical,Triaged] https://launchpad.net/bugs/1154317
21:16:52 <bcwaldon> I will
21:16:57 * ttx assigns
21:17:11 <bcwaldon> mark conflict
21:17:41 <markmc> (get a new name, losers)
21:17:47 <ttx> arrrh
21:17:49 <markwash> ttx: yeah that just came up
21:17:53 <ttx> this can only get worse
21:18:18 <ttx> at least in Ubuntu there was only one Mark
21:18:19 * Vek feels like he's at a convention of Marks
21:18:45 <ttx> markwash: what would be your ETA for getting to the bottom of this list of bugs ?
21:18:57 <ttx> end of week ? start of next week ?
21:19:04 <markwash> lets say start of next
21:19:23 <markwash> only because of that last one 1131705
21:19:37 <ttx> #info ETA for Glance grizzly-rc1: March 19
21:20:04 <ttx> markwash: will track progress based on that
21:20:06 <ttx> Anything more on Glance ?
21:20:18 <markwash> not from me
21:20:50 <ttx> #topic Cinder status
21:20:55 <ttx> jgriffith: hi!
21:20:59 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-rc1
21:21:10 <jgriffith> howdy
21:21:15 <ttx> 5 bugs on the RC list
21:21:26 <ttx> All RC1 blockers ?
21:21:40 <jgriffith> all but one
21:21:47 <jgriffith> we can remove 1134768
21:21:52 <ttx> ok, will do
21:22:03 <jgriffith> it's better to have that NOT be called actually :)
21:22:17 <ttx> you can still fix it in RC1 :)
21:22:22 <jgriffith> :)
21:22:30 <jgriffith> Two fo those are in review
21:22:41 <jgriffith> I think we're in good shape if I can get folks to stop trying to sneak stuff in
21:22:56 <jgriffith> Most of what's coming up now is borderline
21:23:02 <ttx> jgriffith: that leaves only 1131322 not in progress
21:23:14 <jgriffith> ttx: yeah and that's critical IMO
21:23:23 <jgriffith> ttx: winston said he's got it handled
21:23:26 <ttx> jgriffith: cutting RC1 early so that we can redirect them to a havana master may solve that
21:23:30 <jgriffith> I'll double check with him when he's online tonight
21:23:38 <jgriffith> ttx: agreed
21:23:49 <ttx> How about we try to do RC1 at the end of the week ?
21:23:51 <jgriffith> I've told folks I want to be done RC1 tomorrow
21:23:56 <ttx> oh.
21:24:05 <ttx> That works for me :)
21:24:05 <jgriffith> let's compromise and go Thursd
21:24:09 <jgriffith> :)
21:24:18 <ttx> #info ETA for cinder grizzly-rc1: Mar 14
21:24:19 <jgriffith> Thursday morning MT
21:24:25 <jgriffith> excellent
21:24:38 <ttx> excellent.
21:24:42 <ttx> jgriffith: are you using the cinder-core ML on Launchpad for anything ? Or can I delete it ?
21:24:49 <jgriffith> nuke it
21:24:54 <ttx> will do.
21:25:00 <jgriffith> I saw the discussion earlier :)
21:25:00 <ttx> Anything more in Cinder ?
21:25:04 <jgriffith> Nope
21:25:05 <jgriffith> thanks
21:25:34 <ttx> #topic Nova status
21:25:45 <vishy> hi
21:25:49 <ttx> vishy: o/
21:25:51 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-rc1
21:26:03 <ttx> 18 bugs on the list
21:26:04 <ayoung> I'm here.
21:26:15 <ttx> Is this the blockers list, or do you still need to punt some of those to grizzly-rc-potential ?
21:26:52 <ttx> ayoung: ok, can you represent keystone and do the keystone section after Nova ?
21:27:01 <vishy> no we removed all of the relevant ones
21:27:02 <Vek> bug 1147746 may be fixed in novaclient...
21:27:04 <uvirtbot`> Launchpad bug 1147746 in nova "nova services API is incompatible w/ novaclient" [High,In progress] https://launchpad.net/bugs/1147746
21:27:05 <vishy> most of them are in progress
21:27:07 <ayoung> ttx will do
21:27:20 <vishy> there might be a couple more we pull off if they don't go well
21:27:28 <Vek> not 100% certain of that, mind...
21:27:32 <ttx> vishy: ok
21:27:53 <ttx> 2 critical bugs are missing from the blockers list: bug 1148614 and bug 1152401
21:27:56 <uvirtbot`> Launchpad bug 1148614 in nova "Reboot with bad volume fails ungracefully" [Critical,In progress] https://launchpad.net/bugs/1148614
21:27:57 <uvirtbot`> Launchpad bug 1152401 in nova "xenapi: Detecting bad-volumes relies on 120 sec timeout" [Critical,Confirmed] https://launchpad.net/bugs/1152401
21:28:13 <ttx> should we put them on, or downgrade their severity ?
21:28:21 <Vek> 1148614 in gate, I believe
21:28:27 <Vek> 1152401 I don't know.
21:28:48 <vishy> hmm i didn't see those
21:28:49 <vishy> looking
21:29:02 <russellb> looks like we should downgrade the 2nd one
21:29:06 <russellb> "This bug is to remind us to fix this in Nova when/if a patch from Citrix becomes available to allow us to 'fail-fast' here."
21:29:17 <ttx> yeah, "High"
21:29:26 <russellb> done
21:29:35 <ttx> I'll add the first one to the RC1 list
21:29:54 <ttx> oh it is
21:29:56 <vishy> doesn't look like the second is targettable
21:29:59 <vishy> ttx: beat you :)
21:30:47 <ttx> vishy: That's stil a large set of bugs, so I think we should try to do RC1 mid next week
21:31:01 <ttx> does tat sound reasonable as an objective ?
21:31:03 <ttx> that*
21:32:30 <vishy> yes
21:32:34 <vishy> i think they will go quickly
21:32:40 <ttx> #info nova grizzly-rc1 ETA: March 20
21:33:07 <ttx> vishy: yes, I think they will, but generally some get added as we get closer :)
21:33:38 <ttx> i.e. when there is just 1-3 left it tends to take a long time to get rid of the last ones
21:33:46 <ttx> Any question on Nova ?
21:34:23 <ttx> #topic Keystone status
21:34:30 <ttx> ayoung: hey!
21:34:40 <Kharec> hi all
21:34:44 <ayoung> ttx, OK, so looking at the G Bug list...
21:34:57 <ayoung> #link https://launchpad.net/keystone/+milestone/grizzly-rc1
21:34:58 <ttx> Thanks for representing keystone :)
21:35:15 <ttx> 15 bugs on the list... I'd like to reduce this so that we complete one day
21:35:21 <ttx> Are all of those blockers, or are some of them just targets of opportunity ?
21:35:36 <ttx> ayoung: My advice is to remove the rc1 target and tag those "grizzly-rc-potential" to keep them on your radar without blocking the release on them
21:35:37 <ayoung> ttx, well, most are underway.
21:35:44 <ayoung> OK...let me see
21:35:57 <ttx> ayoung: I'm more concerned with the ones that are unassigned and unstarted
21:36:08 <ayoung> ttx, ok. looking at them...
21:36:23 <ttx> ayoung: you don't need to reduce the list while in the meeting
21:36:34 <ttx> would be great to do it today though
21:36:39 <ayoung> a couple of them just came in recently, and we are still trying to reproduce.
21:36:56 <ayoung> Confirmed by a community member is not the same as confirmed by core....
21:37:02 <ttx> ayoung: use 'incomplete' liberally to track those
21:37:14 <ayoung> will do
21:37:29 <ttx> ayoung: ideally when you get to a clean list of blockers, you should also try to get people assigned to fix them
21:37:40 <ttx> (can be reassigned afterwards)
21:37:48 <ttx> unassigned bugs tend to not get fixed for some reason
21:37:56 <ayoung> ttx, right.
21:38:12 <ayoung> We'll triage here shortly.
21:38:15 <ttx> #action ayoung/heckj to reduce the RC1 list to pure RC1 blockers and make sure theyr are assigned
21:38:30 <ayoung> ttx, hey, how about the two people actually running for PTL?
21:38:49 <ttx> #action dolphm/henrynash to reduce the RC1 list to pure RC1 blockers and make sure theyr are assigned
21:38:58 <ayoung> +1
21:39:08 <ttx> ayoung: Someone was complaining on list about lack of recent python-keystoneclient on PyPI. What's the status for that ?
21:39:37 <ayoung> ttx, no idea. I have not been paying attention to PyPI.
21:39:51 <ttx> ayoung: ok
21:39:55 <ayoung> We can also take that as an action item
21:40:04 <ttx> ayoung: when do you think you can get to the bottom of that RC1 buglist ? End of week, early next week ?
21:40:11 <ttx> mid next week ?
21:40:24 <ayoung> There are only 5 un asssigned, we should be able to knock that out shortly.
21:40:47 <ayoung> 7 in triaged or assigned that are not
21:40:56 <ttx> let's target early next week
21:40:57 <ayoung> underway...
21:41:01 <ayoung> Sounds good.
21:41:12 <ttx> #info keystone grizzly-rc1 ETA: March 19
21:41:24 <ttx> Anything more about Keystone ?
21:42:03 <ttx> ayoung: thanks for your help!
21:42:11 <ayoung> ttx, one issue worth noting
21:42:29 <ayoung> we are trying to get clarity, but it seems like some of the auth_token middleware pieces (smokestack)
21:42:38 <ayoung> have had a bit of an issue moving from V2 to V3
21:42:39 <ttx> #action ttx to follow up with heckj/dolphm/henrynash about new python-keystoneclient release
21:43:00 <ayoung> we need people to provide decent bug reports on things that break in Keystone around this.
21:43:28 <ttx> ayoung: noted. Maybe raising the issue on the ML would help gettig more eyes on this
21:43:30 <ayoung> For the most part, we try to keep Keystone changes seamless, but if people hit a snag, the more data we get the better.
21:43:43 <ayoung> ttx, if necessary.
21:43:55 <ttx> ok, moving on
21:43:59 <ttx> #topic Horizon status
21:44:04 <gabrielhurley> yo
21:44:08 <ttx> gabrielhurley: hey
21:44:12 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-rc1
21:44:12 <gabrielhurley> new bug reports, but generally not serious ones. lots of small fixes for the quantum features that got merged right at the end.
21:44:27 <gabrielhurley> lots in progress, many pending merge
21:44:31 <ttx> 13 bugs on list -- are those all blockers ?
21:44:46 <gabrielhurley> ehhhh... debatable when you get to the "medium" and "low" ones
21:44:57 <ttx> gabrielhurley: let me rephrase
21:45:18 <ttx> gabrielhurley: are all of those, at this point, things you wouldn't consider releasing without ?
21:45:20 <gabrielhurley> they're all things I'd like to see fixed, especially given that most of them have patches up
21:45:31 <ttx> right
21:45:42 <gabrielhurley> if they prove problematic I'll bump 'em
21:45:47 <ttx> if you knock them down fast enough, no problem
21:45:53 <gabrielhurley> but I'd like to target early next week like the other projects.
21:46:19 <ttx> ok
21:46:36 <ttx> #info horizon grizzly-rc1 ETA: March 19
21:46:48 <gabrielhurley> sounds perfect
21:46:58 <gabrielhurley> I'll start kicking things later this week
21:47:02 <ttx> https://review.openstack.org/#/c/23901/ should probably be -2ed until we open havana
21:47:14 <ttx> I saw it trying to sneak into rc1 :)
21:47:16 <gabrielhurley> true. I marked the BP as Havana
21:47:26 <gabrielhurley> but didn't mark the review yet
21:47:33 <ttx> Anything more on Horizon ?
21:47:36 <gabrielhurley> nope, that's all
21:47:50 <ttx> danwent: around ?
21:47:55 <danwent> ttx: yup
21:48:00 <ttx> #topic Quantum status
21:48:01 <danwent> thanks for switching order
21:48:08 <ttx> np
21:48:10 <ttx> First there was a question on the list about https://review.openstack.org/#/c/18216/
21:48:16 <ttx> Should quantum-scheduler be considered implemented without that ?
21:48:56 <danwent> ttx: yes, this commit was abandoned b/c we had yong split this into three reviews that were easier for reviewers to digest
21:49:02 <danwent> all of those new reviews merged
21:49:05 <ttx> ok, great
21:49:22 <ttx> danwent: maybe chime in on that thread, it's hidden in the Nova PTL thread
21:49:27 <danwent> We have been targeting an RC1 today and are on track. Key issue though is openstack-common items.
21:49:30 <danwent> ttx: ok
21:49:32 <ttx> Nice progress overall on http://status.openstack.org/release/rc/
21:49:41 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-rc1
21:49:52 <ttx> 6 bugs on the list -- I assume those are all blockers ?
21:50:00 <danwent> no, only items that are high.
21:50:12 <danwent> one of the medium issues may not make it
21:50:45 <ttx> danwent: so your ETA is still the end of today ?
21:51:06 <danwent> ttx: well, i'm not sure if that makes sense if oslo stuff is targeting tomorrow
21:51:11 <danwent> that's something i wanted to bring up here
21:51:14 <ttx> danwent: agreed
21:51:31 <danwent> i'm OOO rest of week
21:51:47 <danwent> but we can have markmcclain pitch in do a release tomorrow
21:51:55 <danwent> if we need to wait for oslo
21:52:10 <danwent> or we could branch today, cherry-pick oslo changes, but open master for havana
21:52:28 <ttx> danwent: so here is how we'll do the RC1 cut... at some point you'll bump the release in setup.py to 2013.2. And I'll cut milestone-proposed from the previous commit
21:52:32 <ttx> tag that rc1.
21:52:57 <danwent> ok
21:53:09 <ttx> I'd rather not cherrypick after rc1, because that would mean do an rc2 :)
21:53:22 <ttx> I'd rather have the rc2 triggered by a critical bug, not by rushing the process
21:53:22 <danwent> ok, wasn't sure if we could branch, but not declare an RC1
21:53:31 <ttx> danwent: we actually can.
21:53:54 <danwent> ok, that would be my preference.
21:54:02 <ttx> danwent: your wish is my command
21:54:11 <danwent> then when oslo comes in, we'll pull that over, and declare RC1?
21:54:17 <ttx> danwent: yes.
21:54:19 <danwent> great
21:54:42 <ttx> danwent: just push the new version and ping me. I'll cut milestone-proposed from the previous commit in master
21:54:54 <danwent> ok, great
21:55:07 <ttx> Let's discuss that in 5 min if you're still around
21:55:11 <danwent> k
21:55:13 <ttx> will do a pre-flight check
21:55:43 <ttx> #info quantum grizzly-rc1 ETA March 13
21:55:48 <ttx> danwent: are you using the quantum-core ML on Launchpad for anything ? Or can I delete it ?
21:56:01 <danwent> ttx: we use it a fair amount actually
21:56:14 <danwent> asking for core devs to review things, etc.
21:56:23 <ttx> danwent: Ah. Interesting. let's discuss that in 4 minutes too
21:56:34 <ttx> Anything else on Quantum ?
21:56:49 <danwent> nope
21:56:51 <ttx> #topic Incubated-in-Grizzly/Integrated-in-Havana projects
21:57:00 <ttx> anyone from ceilometer and/or Heat ?
21:57:04 <sdake> yar
21:57:11 <ttx> #link https://launchpad.net/heat/+milestone/grizzly-rc1
21:57:21 <sdake> everything looks good except for one possible problem
21:57:21 <ttx> 8 bugs targeted -- are those all release blockers ?
21:57:35 <sdake> not all blockers, but are like 1 hr of work each except for 1 bug
21:57:41 <sdake> https://bugs.launchpad.net/heat/+bug/1096017
21:57:43 <uvirtbot`> Launchpad bug 1096017 in heat/grizzly "AutoScalingGroup missing VPCZoneIdentifier property" [Medium,Triaged]
21:57:49 <sdake> dev is out, and didn't send me copy of his work
21:57:56 <sdake> so i'll have to sort that out today
21:58:05 <ttx> ok
21:58:18 <ttx> when do you want to cut an RC1 ?
21:58:21 <sdake> i'll let you know when i understand the bug better
21:58:37 <ttx> later this week ?
21:58:47 <sdake> would like to shoot for early next week if possible to provide time to sort out this bug
21:58:51 <sdake> he spent few weeks on it
21:58:56 <ttx> sure
21:58:56 <sdake> so it must be a bit challenging
21:59:16 <sdake> lets try 19th then?
21:59:17 <ttx> anyone from ceilometer ?
21:59:24 <ttx> sdake: works for me
21:59:27 <sdake> thanks
21:59:58 <ttx> OK, then. that's all folks
22:00:02 <ttx> #endmeeting