21:02:51 <ttx> #startmeeting project
21:02:51 <openstack> Meeting started Tue Apr  2 21:02:51 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:54 <openstack> The meeting name has been set to 'project'
21:03:05 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:15 <gabrielhurley> here now
21:03:15 <ttx> #topic General announcements
21:03:25 <ttx> #info Summit scheduling in progress
21:03:33 <ttx> Would you like me to hide the "suggest session" button now, to avoid random new suggestions ?
21:03:40 <ttx> (It would still be possible to add sessions using http://summit.openstack.org/cfp/create)
21:04:02 <ttx> I kinda announced that sessions should be suggested before the end of march...
21:04:34 <notmyname> ya, but wasn't that a soft deadline to get a feel for scheduling?
21:04:35 <markmc> ttx, that's probably reasonable
21:04:55 <ttx> I'm fine with leaving it atm if you need/want more input
21:05:05 <ttx> but we are all more than full already
21:05:09 <ttx> and can add manually if needed
21:05:12 <notmyname> seems that most (all?) tracks are now full, so there's not too much benefit for keeping it open
21:05:12 <markmc> maybe if there was still a hidden shortcut for exceptions PTL want
21:05:18 <notmyname> markmc: +1
21:05:24 <ttx> markmc: see above
21:05:30 <ttx> http://summit.openstack.org/cfp/create
21:05:40 <ttx> not so hidden
21:05:52 <ttx> :)
21:06:00 <markmc> cool
21:07:05 <ttx> #action ttx to hide "suggest session" button to limit new submissions
21:07:05 <ttx> annegentle: How is Grizzly doc coming along ?
21:07:05 <ttx> apevec/markmc, jeblair/mordred, sdague/davidkranz: Anything from Stable/CI/QA teams ?
21:07:11 <markmc> #info 2012.2.4 RC due this week: http://lists.openstack.org/pipermail/openstack-stable-maint/2013-March/000353.html
21:07:37 <markmc> there's more reviews outstanding for stable/folsom than I'd like at this point
21:07:43 <markmc> so help with reviews is very welcome
21:07:46 <jeblair> ttx: nothing earthshattering on the ci front
21:07:53 <ttx> jeblair: by design :)
21:07:56 <jeblair> indeed
21:08:30 <ttx> ok, moving on to projects
21:08:36 <ttx> annegentle: feel free to jump in anytime
21:08:49 <ttx> #topic Oslo status
21:08:51 <annegentle> ttx: really same as last week
21:09:12 <annegentle> I'll send a more detailed status update tomorrow to openstack-doc ML
21:09:16 <ttx> ok
21:09:20 <ttx> markmc: Anything affecting the release that you would like to mention ?
21:09:40 <markmc> no, all quiet
21:09:43 <markmc> well
21:09:52 <markmc> there is a fix for Co-authored
21:10:04 <markmc> but I think we agreed we wouldn't do a respin of nova for that
21:10:10 <markmc> and do it in stable/grizzly
21:10:10 <ttx> markmc: did it got merged to oslo-incubator master yet ?
21:10:15 <markmc> yes, it did
21:10:25 <ttx> ok, so we can include it if we ever respin Nova
21:10:41 <markmc> don't think there's a bug tracking it
21:11:06 * markmc will file one
21:11:15 <ttx> markmc: thx
21:11:18 <markmc> it for grizzly/oslo
21:11:25 <markmc> will do summit scheduling early next week
21:11:41 <ttx> markmc: ok
21:11:50 * mordred facepalms over the co-authored fix
21:11:50 <ttx> Anything else on the oslo topic ?
21:11:55 <markmc> nope
21:12:32 <ttx> mordred: beware of the crowd of co-authors hunting you down for vengeance
21:12:43 <ttx> #topic Keystone status
21:12:51 <ttx> heckj/dolphm: o/
21:13:04 <ttx> Earlier today we published grizzly-rc3...
21:13:08 <heckj> yeah!!!
21:13:12 <ttx> The idea now is that we shouldn't respin now except for a last-minute catastrophic regression/upgrade issue
21:13:18 * heckj nods
21:13:23 <ttx> And document anything else in the Known Bugs section in the Release notes.
21:13:37 <ttx> heckj: anything of that sort spotted so far ?
21:13:43 <heckj> not as yet
21:13:48 * heckj crosses fingers
21:13:51 <ttx> #link https://bugs.launchpad.net/keystone/+bugs?field.tag=grizzly-rc-potential
21:13:58 <heckj> we're getting good validation feedback on the performance fixes now
21:14:02 <ttx> heckj: I don't think any of those bugs will be included in a respin, so I'll all move them to grizzly-backport-potential for post-release consideration
21:14:10 <heckj> sounds good
21:14:19 <ttx> Your release notes look good (https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Identity_.28Keystone.29)
21:14:28 <ttx> Hmm... Weren't PKI tokens actually introduced in Folsom rather than Grizzly ?
21:15:01 <heckj> They were there, but not default
21:15:14 <heckj> with grizzly, they're default
21:15:35 <ttx> hmm ok, maybe that line in the release notes should be a bit more explicit
21:15:41 <heckj> will do
21:15:59 <ttx> though I guess that can be one of the meanings of "replace"
21:16:06 <ttx> How is your summit scheduling looking so far ?
21:16:19 <ttx> well, not yours, but meh :)
21:16:52 <heckj> I don't know - that was taken away from me :-)
21:17:05 <ttx> Ack. Anything more about Keystone ?
21:17:06 <heckj> last I heard, coming along well - some concern over
21:17:25 <heckj> over wanting lots of cross polination from different projects in the key topics for Keystone
21:17:42 <heckj> lots of cross-project concerns that I expect to be discussed/etc at the summit
21:17:55 <heckj> that's it
21:17:55 <ttx> the design summit should last two weeks so that everyone can attend everything
21:18:22 <ttx> #topic Swift status
21:18:27 <ttx> notmyname: o/
21:18:28 <notmyname> hello
21:18:34 <ttx> 1.8.0 RC2 was tagged Friday
21:18:41 <ttx> notmyname: Does it still look like a winner ?
21:18:52 <notmyname> so far. I haven't heard of any showstoppers yet
21:19:06 <ttx> When can we push the final versioning on it ?
21:19:18 <ttx> (https://review.openstack.org/#/c/24765/)
21:19:47 <notmyname> the release is thursday?
21:20:15 <ttx> yes, unless for some catastrophic reason we need to stretch the definition of "Thursday"
21:20:40 <ttx> I can push it when I do the release (which should happen early on Thursday)
21:20:45 <ttx> or before if you prefer
21:21:04 <notmyname> I'm not worried about that yet. ya, what I was about to suggest. shoot for thurs am, and we'll do it earlier if possible
21:21:23 <notmyname> I want to get a final update from people doing QA first
21:21:30 <ttx> notmyname: ok, we'll confirm tomorrow afternoon for you / night for me
21:21:36 <notmyname> ok
21:21:53 <ttx> Swift section in the release notes is still empty: https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Object_Storage_.28Swift.29
21:21:58 <ttx> Planning to work on it ? Need some help ?
21:22:09 <notmyname> yes. QA, then summit scheduling, then release notes :-)
21:22:19 <notmyname> I'll be doing those this afternoon, I think
21:22:25 <ttx> well, summit scheduling can happen AFTER the release notes :)
21:22:42 <ttx> notmyname: sounds good
21:22:51 <ttx> Anything more on Swift ?
21:23:13 <notmyname> looks like we'll be having a bunch of write-in sessions at the summit for overflow :-)
21:23:38 <notmyname> not that anyone could have predicted it. we've had a much larger submission pool this time (of surprisingly good topics)
21:23:38 <ttx> notmyname: I'll try to secure early access to those whiteboards :)
21:23:44 <notmyname> heh :-)
21:24:16 <ttx> #topic Glance status
21:24:17 <notmyname> swift meeting tomorrow,
21:24:22 <ttx> oops
21:24:24 <markmcwash> ttx: hi hi
21:24:24 <notmyname> fin
21:24:32 <ttx> markmcwash: o/
21:24:41 <ttx> Glance RC2 was published Saturday
21:24:44 <markmcwash> w00t
21:24:59 <ttx> Nothing stands out on grizzly-rc-potential list @ https://bugs.launchpad.net/glance/+bugs?field.tag=grizzly-rc-potential
21:25:09 <ttx> May I move all those to grizzly-backport-potential so that they get post-release attention ?
21:25:15 <markmcwash> affirmative
21:25:33 <ttx> anything critical flying under the radar ?
21:25:44 <ttx> (that you know about ?)
21:25:46 <markmcwash> well, its under my radar as well, if it is
21:26:02 <markmcwash> (no) :-)
21:26:06 <ttx> OK. Then you now need to work on the Release notes at https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Image_Service_.28Glance.29
21:26:12 <ttx> When do you think you can update that ? Need some help ?
21:26:26 <bcwaldon> ttx: I should probably put some effort into that
21:26:40 <markmcwash> we can collaborate sometime this week
21:26:42 <bcwaldon> markwash and I can carve out some time this week to do it
21:26:43 <ttx> bcwaldon: you certainly can.
21:26:55 <ttx> ideally that should happen between now and tomorrow EOD
21:27:05 <markmcwash> oh
21:27:07 <bcwaldon> good point
21:27:26 <ttx> since some people like complete release notes by release time, for some reason
21:27:46 <markmcwash> makes sense
21:28:18 <ttx> bcwaldon, markmcwash: let me know if that's an issue for you, I could throw a few cycles to help
21:28:55 <ttx> markmcwash: Making progress on the Design Summit schedule for Glance ?
21:29:30 <markmcwash> I've been stealth reviewing, I think I am almost ready to pull the approve trigger on everything there presently
21:29:51 <markmcwash> (and providing feedback with the proposers)
21:29:55 <ttx> markmcwash: sounds good. Let me know if you want me to hold your hand during the scheduling part
21:30:07 <ttx> Anything more on Glance ?
21:30:18 <markmcwash> I added a meeting for glance to the meetings wiki
21:30:30 <markmcwash> 1st and 3rd thursdays of the month at 2000 UTC
21:30:38 <markmcwash> (same time as Nova Orchestration, different channel)
21:30:46 <ttx> markmcwash: recently ? Looks like the "subscribe to page" on the wiki is not really triggering email alerts
21:30:54 <markmcwash> yes, just today
21:31:03 <ttx> #action ttx to add glance meeting to the meetings gcal
21:31:14 <markmcwash> I'll post an agenda as well soon
21:31:26 <ttx> sounds good
21:31:32 <ttx> #topic Quantum status
21:31:38 <ttx> danwent/markmcclain: hi!
21:31:46 <markmcclain> hi
21:31:49 <ttx> We have a RC3 window open that we need to close ASAP
21:31:54 <ttx> #info https://launchpad.net/quantum/+milestone/grizzly-rc3
21:32:01 <markmcclain> everything is now in
21:32:04 <ttx> Anything else you'd like to pull in before I cut it ?
21:32:10 <markmcclain> no
21:32:21 <ttx> OK, then I'll do it just after the meeting
21:32:32 <markmcclain> sounds good
21:32:35 <ttx> the more light it sees the better it will be
21:33:06 <markmcclain> agreed
21:33:07 <ttx> How is design summit scheduling going so far ? I've seen you had quite a lot of sessions lined up too
21:33:49 <markmcclain> yeah.. I've been reading through them
21:34:00 <markmcclain> and we're going to merge several
21:34:20 <ttx> Sounds good. Anything else on Quantum ?
21:34:28 <markmcclain> no
21:34:47 <ttx> #topic Cinder status
21:34:49 <ttx> jgriffith: hi!
21:34:56 <ttx> Cinder RC3 was published last Wednesday
21:34:57 <jgriffith> ttx: hey hey
21:35:02 <ttx> jgriffith: still looking good ?
21:35:08 <jgriffith> yeah, for the most part
21:35:16 <jgriffith> couple minor things have come up but nothing serious
21:35:23 <ttx> I'll move the bug @ https://bugs.launchpad.net/cinder/+bugs?field.tag=grizzly-rc-potential to grizzly-backport-potential.
21:35:37 <jgriffith> yay
21:35:37 <ttx> Your release notes @ https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Block_Storage_.28Cinder.29 could be improved a bit...
21:35:46 <ttx> Need some help on that, or are you covering it ?
21:35:52 <jgriffith> I'll cover it
21:36:12 <ttx> Cool. Any progress on the Design Summit scheduling ?
21:36:16 <jgriffith> but is there something specifically you see as lacking?
21:36:30 <jgriffith> Yeah, I've about got the summit scheduling wrapped up
21:36:49 <ttx> jgriffith: I think it would be good to list new storage drivers, not just v1/v2 API features
21:36:50 <jgriffith> I have a few sessions that I want to bring up with the core team at tomorrows meeting
21:36:56 <jgriffith> ttx: fair
21:37:16 <jgriffith> ttx: Yeah, now that I think about it there's a number of things I need to add
21:37:19 <jgriffith> ttx: thanks
21:37:40 <ttx> Anything more in Cinder ?
21:37:46 <jgriffith> Nope
21:37:57 <ttx> #topic Nova status
21:38:10 <ttx> vishy: around ?
21:38:55 <vishy> yup
21:39:01 <ttx> Nova RC2 was published Saturday
21:39:05 <ttx> Anything worrying on your radar ?
21:39:34 <vishy> well there is one thing worrying
21:39:38 <vishy> we have 31 untriaged bugs
21:39:51 <vishy> we should probably look through and make sure there isn't anything pressing
21:40:09 <ttx> indeed
21:40:11 <vishy> i have 2 or 3 bugs that are somewhat annoying but i think they are ok going through backports
21:40:26 <ttx> I tried to look them up as they were filed but I may have overlooked something
21:40:42 <vishy> https://bugs.launchpad.net/nova/+bugs?field.tag=grizzly-backport-potential
21:41:06 <ttx> vishy: could you try to get Nova dudes to look into the list today to make sure we didn't overlook anything ?
21:41:34 <vishy> yeah i will
21:41:37 <ttx> If you agree, I'll push all in the grizzly-rc-potential list to grizzly-backport-potential, since they don't really fit the "regression/upgrade/install" criteria for last-minute RC bugs
21:42:01 <ttx> so that we have a clean slate just in case
21:42:08 <ttx> Your release notes look reasonably good at this point.
21:42:18 <ttx> Won't ask you about summit scheduling because I know that's Russell's playground now
21:42:32 <vishy> makes sense
21:42:35 <ttx> vishy: anything else on your mind ?
21:42:38 <vishy> nope
21:42:56 <ttx> awesome!
21:42:58 <ttx> #topic Horizon status
21:43:06 <ttx> gabrielhurley: hey
21:44:43 <ttx> sdake, jd__: around ?
21:45:11 <gabrielhurley> hi
21:45:18 <ttx> hola
21:45:24 <ttx> So... Horizon RC2 was published Thursday
21:45:27 <ttx> Still looking good ?
21:45:31 <gabrielhurley> yep, still lookin' good :-)
21:45:41 <ttx> That's how I like it
21:45:45 <gabrielhurley> me too
21:45:52 <ttx> The release notes at https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Dashboard_.28Horizon.29 still need some urgent love
21:45:56 <gabrielhurley> I'll copy the release notes into the wiki today
21:46:03 <ttx> sounds good
21:46:06 <gabrielhurley> it's a pain to reformat reST into wiki markup
21:46:17 <jd__> ttx: p/
21:46:35 <ttx> How is your Design Summit scheduling going on so far ?
21:46:54 <gabrielhurley> Got the same number of sessions as slots, and I like all the proposals
21:47:02 <gabrielhurley> so, I think that's as well as can be hoped?
21:47:20 <ttx> well, let's say you're more lucky that others ;)
21:47:24 <gabrielhurley> very much so
21:47:42 <ttx> gabrielhurley: Anything you wanted to add ?
21:47:54 <gabrielhurley> nope. it's been a quiet week (thankfully)
21:48:18 <ttx> ok then :)
21:48:20 <ttx> #topic Incubated-in-Grizzly/Integrated-in-Havana projects
21:48:31 <ttx> jd__: o/
21:48:35 <ttx> Is ceilometer RC1 good to be promoted to final 2013.1 release ?
21:48:59 <jd__> probably, we have a bug that poped today that we may want to fix for final, but it can also be fixed in a backport I think
21:49:03 <jd__> didn't dig too far for now
21:49:20 <ttx> ok, you can ping me tomorrow morning in case you need a respin
21:49:25 <ttx> jd__: May I remove bug 1146655 from the grizzly-rc-potential list ?
21:49:27 <uvirtbot> Launchpad bug 1146655 in ceilometer "no metaquery implementation in HBase backend" [Undecided,New] https://launchpad.net/bugs/1146655
21:49:28 <jd__> I will, thanks
21:49:35 <ttx> that's not the one you mentioned, right
21:49:36 <jd__> totally
21:49:41 <ttx> OK
21:49:55 <ttx> If everything is alright, should I push the final based on RC1 on Thursday ?
21:50:02 <ttx> or do you want it another day ?
21:50:11 <jd__> Thursday's fine
21:50:22 <ttx> ok!
21:50:28 <ttx> sdake: around ?
21:50:35 <sdake> yup
21:50:43 <ttx> jd__: any question about the release ?
21:50:47 <ttx> sdake: heat RC2 still ready for release ?
21:50:52 <sdake> yup
21:50:52 <jd__> ttx: nop
21:51:03 <ttx> sdake: Want me to push it on Thursday ?
21:51:12 <sdake> ttx: please
21:51:35 <ttx> ok. Just wave a big red flag if for some reason I shouldn't
21:51:49 <sdake> will do
21:51:52 <ttx> jd__, sdake: Progress on your Design Summit schedules ?
21:52:09 <ttx> jd__: I see yours is mostly scheduled at this point
21:52:24 <jd__> ttx: yep, I need to do a recheck but it should be good as it is otherwise
21:52:44 <jd__> we had to merged a lot of stuff
21:53:04 <ttx> jd__: yeah, tat's the recipe for success
21:53:18 <jd__> :-)
21:53:35 <ttx> anythign else to add before I close the meeting ?
21:54:33 <ttx> well then
21:54:34 <ttx> #endmeeting