21:02:05 <ttx> #startmeeting project
21:02:05 <openstack> Meeting started Tue Apr 23 21:02:05 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:08 <openstack> The meeting name has been set to 'project'
21:02:22 <ttx> We'll skip per-project status this week, in favor of generic advice and open discussion
21:02:28 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:34 <ttx> should take us less than the hour
21:02:41 <ttx> #topic Grizzly documentation release status
21:02:47 <ttx> annegentle: still targeting April 30 ?
21:02:48 <annegentle> I only accept generic advice anyway
21:03:01 <annegentle> Yep, planning to release/publish 4/30
21:03:15 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Release
21:03:16 <ttx> What's included in the docs release exactly ?
21:03:17 <annegentle> that's the process
21:03:39 <annegentle> it has to do with URLs, comment threads, builds, um. all the things
21:03:46 <ttx> everything under docs.o.o ?
21:03:46 <annegentle> #info Doc released planned for 4/30/13
21:04:14 <annegentle> make sure Google indexes correctly, etc. Yep, everything under docs.openstack.org/grizzly anyway
21:04:18 <jgriffith> o/
21:04:24 <ttx> annegentle: Any specific issue that needs urgent help/attention from others ?
21:04:25 <annegentle> Also I'm working on "who wrote Grizzly docs?" data analysis.
21:04:52 <annegentle> yes. Specifically install docs.
21:05:00 <annegentle> There are two doc patches in review for the Basic Install document:
21:05:10 <annegentle> #link ubuntu https://review.openstack.org/#/c/26954/
21:05:25 <annegentle> #link fedora https://review.openstack.org/#/c/26919/
21:05:31 <ttx> #help Ubuntu folk please help on https://review.openstack.org/#/c/26954/
21:05:43 <ttx> #help Fedora folk please help on https://review.openstack.org/#/c/26919/
21:06:00 <annegentle> Networking team seems to have docs on their radar, thank you to them.
21:06:07 <annegentle> jgriffith: you have a docs Q or one for ttx?
21:06:23 <jgriffith> annegentle: no, sorry, just showing up late :)
21:06:25 <ttx> annegentle: no, I think he was just indicating his presence
21:06:33 <annegentle> jgriffith: good to see you!
21:06:37 <jgriffith> :)
21:06:40 <annegentle> ttx: that's it for docs.
21:06:53 <ttx> annegentle: ok
21:07:07 <ttx> Questions on doc release ?
21:07:35 <ttx> #topic Havana Release schedule
21:07:46 <ttx> During the Design Summit we had, like always, a session on release schedule
21:07:53 <ttx> The proposed one looks like this: http://ubuntuone.com/p/mhD/
21:08:07 <ttx> Release on October 17, Feature freeze on Tuesday, September 3
21:08:20 <ttx> The main issue raised about that timing was that Monday, September 2 was US Labor day
21:08:36 <ttx> To reduce the issue I propose we have Feature freeze on the Wednesday (September 4th) and havana-3 tagging on the Friday (September 6)
21:08:44 <ttx> Does that sound good ?
21:08:49 <jgriffith> ttx: +1 on Wed
21:09:00 <markmcclain> +1 on Wed
21:09:14 <markwash> +1 on wednesday
21:09:18 <dolphm> +1
21:09:34 <ttx> Unless there are objections I'll publish it tomorrow and adjust milestones for projects that are using them
21:09:35 <annegentle> I thought Thurs. was your "magic" release day?
21:09:53 <ttx> annegentle: It's the "thank god there is friday to catch up in case of problems" day
21:10:19 <ttx> annegentle: I can publish on Saturday morning if shit happens
21:10:25 <dolphm> s/in case of/due to/
21:11:06 <ttx> #action ttx to publish havana schedule with Feature freeze on the Wednesday (September 4th) and havana-3 tagging on the Friday (September 6)
21:11:17 <ttx> Questions about the release schedule ?
21:12:10 <ttx> #topic Havana cycle plans
21:12:26 <ttx> For the next week(s) the main goal will be to turn the summit sessions into a reasonable set of actionable blueprints
21:12:37 <ttx> The rationale behind tracking work being done as blueprints is to communicate plans to the wider community -- not everyone has time to follow each project closely
21:12:50 <ttx> With blueprints we know what should be worked on, who should be working on it and when it's planned to land
21:12:56 <ttx> So the plan is:
21:13:10 <ttx> 1- File blueprints for stuff that people volunteered to work on. A blueprint needs to cover a clear feature that can be "completed" in the Havana timeframe. "Improve database performance" is not really a good one.
21:13:19 <ttx> (For complex stuff, file multiple blueprints and create dependencies between them)
21:13:31 <ttx> (People should set the Assignee, the "Milestone target" to when they think it should be landed, and propose the "Series goal" to havana)
21:13:54 <ttx> 2- You PTLs review the proposed blueprints, accept the "Series goal" (you can use the page at https://blueprints.launchpad.net/YOURPROJECT/havana/+setgoals to do that) and set a priority
21:14:09 <ttx> Priority reflects how important a given blueprint is to your objectives for this cycle. "Essential" means "cannot ship without" and should be used carefully
21:14:22 <ttx> Blueprints that are accepted in series show up on https://blueprints.launchpad.net/YOURPROJECT/havana -- that's what we'll refine over the next weeks
21:14:48 <ttx> Questions on this process ?
21:15:24 <gabrielhurley> \o
21:15:33 <ttx> jd__: you'll have to read the meeting logs :) ^
21:15:46 <ttx> gabrielhurley: shoot
21:15:55 <gabrielhurley> ttx: you usually only open the next milestone shortly before the current one closes, but that makes it a little trickier to "lay out" plans for when blueprints will happen
21:16:07 <gabrielhurley> e.g. I can target things to H1, or generally to Havana
21:16:14 <gabrielhurley> but can't say what should be H2 or H3
21:16:17 <ttx> gabrielhurley: no no, you cvan target stuff to h2/h3
21:16:29 <gabrielhurley> oh, did you open those?
21:16:35 <gabrielhurley> they weren't there when I looked the other day
21:16:38 <ttx> gabrielhurley: yes, I created them today
21:16:48 <gabrielhurley> heh. you pulled my favorite trick!
21:16:54 <jgriffith> ttx: flying under the radar
21:16:54 <gabrielhurley> I should've refreshed ;-)
21:17:03 <gabrielhurley> thanks
21:17:12 <ttx> Using my whole new https://github.com/ttx/openstack-releasing/blob/master/create_milestones.py script!
21:18:06 <ttx> gabrielhurley: ideally the whole plan (h1/h2/h3) should be laid out -- but I know that h3 is generally a moving target
21:18:25 <ttx> Other questions ?
21:19:08 <ttx> Next week we'll start reviewing those havana plans. let me know if you need help with this step.
21:19:12 <ttx> #topic Havana Design Summit feedback
21:19:19 <jd__> ttx: sure thanks, sorry my IRC bouncer got killed at some point
21:19:26 <ttx> While it's still hot in your memory, any suggestion for improvement on the Design Summit part ?
21:19:53 <jgriffith> The seperate section of the conf hall helped a lot IMO
21:20:13 <jgriffith> Overlap of sessions was an issue, but I think that's going to be the way it goes
21:20:27 <markwash> I found it a difficult to know what was going on in unconference sessions on the fly
21:20:29 <ttx> yeah, I was a bit skeptical about it when Lauren mentioned it... but it was the only thing that kept us sane
21:20:46 <annegentle> better wifi in the rooms needing Etherpads
21:20:47 <dolphm> markwash: +1
21:21:02 <markmc> we talked a bit about reducing the overlap with the conference part
21:21:04 <dolphm> annegentle: ethernet was available to presenters, afaik
21:21:06 <dhellmann> we could have used whiteboards in the rooms, too, for drawing diagrams
21:21:15 <ttx> markwash: I think we'll have to put the unconference stuff online to improve visibility
21:21:18 <annegentle> wifi improved after day 1
21:21:18 <jgriffith> dhellmann: +1
21:21:21 <markmc> i.e. giving us a couple of days where we can do design summit sessions without the conference in parallel
21:21:23 <ttx> dhellmann: some rooms had some
21:21:28 <markmc> to reduce distraction, let us focus
21:21:36 <dhellmann> ttx: ok, maybe I just wasn't in those rooms. did we have to ask for them?
21:21:37 * markmc thinks that's worth trying to figure out
21:21:39 <ttx> I definitely asked for one in every room during the sroom steup thing
21:21:42 <dolphm> unconferences seemed to be generally more productive than regular sessions, IMO
21:21:43 <annegentle> dhellmann: I wanted a white board and took one from another room
21:21:52 <jgriffith> markmc: +1
21:21:57 <ttx> dhellmann: theoretically there should have been one in each
21:22:01 * dhellmann shakes fist at annegentle
21:22:12 * annegentle slinks away with markers
21:22:18 <dolphm> the two big rooms in the back of the dev lounge with round tables were AWESOME for impromptu unconferencing
21:22:22 * jgriffith now knows why not whiteboard in 110
21:22:45 * markmc spotted a whiteboard in the wild
21:22:49 <markmc> someone even wrote on it
21:23:00 <ttx> markmc: we can track who stole it then :)
21:23:10 <jgriffith> ha!
21:23:16 <annegentle> dolphm: wow I never found those! I needed that.
21:23:25 <dhellmann> it would be nice if the dev area wasn't locked down during the keynotes. I know they want us all to attend, but with limited time for hallway track / openspace meetings...
21:23:31 <jd__> there was even a white board in the unconference room at some point :)
21:23:33 <annegentle> I thought the summit 101 session was helpful
21:23:44 <ttx> About session overlap - heckj wants to try some more dynamic scheduling
21:23:57 <dolphm> define "dynamic"
21:23:59 <jd__> dhellmann: +1
21:24:03 <ttx> he agrees to be the point man to arrange sessions around. I know that's a nightmare to handle
21:24:13 <markmc> oh, scheduling
21:24:17 <markmc> sched.org ROCKS
21:24:24 <ttx> dolphm: no more pre-defined topic layout
21:24:30 <dolphm> oh interesting
21:24:35 <ttx> dolphm: have keystone sessions scattered all 4 days$
21:24:37 * markmc literally couldn't have coped without sched synced into his calendar
21:24:41 <dhellmann> markmc: have you seen guidebook? even better. actually downloads to your mobile device.
21:24:47 <dolphm> ttx: i would definitely like that
21:24:55 <dhellmann> but +1 on the calendar sync
21:24:56 <jgriffith> ttx: could you elaborate a bit?
21:25:04 <dolphm> give us time to talk about things in between sessions
21:25:16 <annegentle> ttx: heckj: oo I'd like to hear more too
21:25:17 <markmc> dhellmann, yeah, all I used was the ical feed
21:25:34 <ttx> jgriffith: Stuff is scheduled based on everyone's constraints, rather then in one pre-allocated block for that topic
21:25:48 <jgriffith> ttx: yeah, got it... big +1 here
21:25:51 <ttx> jgriffith: generally involves someone not sleeping for the last 7 days before the summit starts
21:26:01 <ttx> I know that. I did it for the first ones
21:26:02 <jgriffith> ttx: who sleeps the week before the summit?
21:26:24 <jgriffith> that's what the plane is for
21:26:46 <ttx> i.e. someone receives all the angry emails about doublebooking and tries to resolve all the constraints... then pisses off more people
21:27:08 <ttx> not my definition of fun, and the main reason why we switched to preallocated slots
21:27:13 <jgriffith> ahhh... I guess I didn't envision that extreme of dynamic
21:27:18 <ttx> but preallocated slots have their drawbacks
21:27:32 <ttx> like keystone folks not attending security track at conference etc
21:27:35 <jgriffith> I interpretted it as just spaced out, still scheduled but not in blocks
21:27:40 <jgriffith> block/tracks
21:27:45 * russellb is around now, sorry.
21:28:03 <ttx> russellb: read scrollback and let me know if you have any question on the process
21:28:27 <markmcclain> I just wish there was a way that common/process could get a half day head start
21:28:33 <russellb> ack
21:28:45 <markmcclain> that would allow more PTL and core involvement in those tracks
21:28:49 <annegentle> blocks/tracks means being in the same room for hours/days, not sure if that's okay for most people? (Efficient)
21:28:58 <notmyname> as a voice in favor of preallocated tracks, I found "clustered" sessions to be very helpful. also it helps when figuring out other schedules for the week when planning for the summit
21:29:06 <dolphm> markmcclain: +1
21:29:24 <jgriffith> Maybe we can try to see if broader project topics fall out next time around?
21:29:30 <jgriffith> ie: bare-metal
21:29:31 <annegentle> notmyname: I liked being in one room for my track, it was easier if intense
21:29:33 <ttx> notmyname: it certainly simplifies the scheduling constraints, by solving a lot of them ahead of time :)
21:29:49 <jgriffith> rather than having one in Nova, Glance, Cinder etc... combined versions
21:30:31 <ttx> we'll see what can be done and what can be implemented in the already-negociated time and space
21:30:57 <ttx> Any more feedback on Design Summit ? On the general event ?
21:31:23 <annegentle> I was really impressed with the crowd handling considering the growth. And I had a darn good time to boot.
21:31:29 <annegentle> To me, best yet.
21:31:35 <markmc> definitely
21:31:51 <dhellmann> annegentle: +1
21:31:51 <dolphm> the ratio of people attending design summit sessions and not participating is starting to get quite high
21:31:58 <ttx> dhellmann: about general session blocking devs: I think Lauren mentioned that we would not do that anymore
21:32:16 <markmc> dolphm, you thought so? I actually thought it was often less than previous times
21:32:20 <ttx> dhellmann: They may actually have stuff running in the main big room all the time
21:32:27 <patelna_> + growing participants from women - Anne thxs for hosting social
21:32:46 <ttx> dhellmann: with some tickets only allowing entracnce to that "keynote" space
21:32:50 <dhellmann> ttx: good
21:32:52 <annegentle> patelna_: happy to play host!
21:32:53 <dhellmann> ah, I like that, too
21:33:03 <ttx> dhellmann: less people potentially wandering in our direction
21:33:05 <dolphm> markmcclain: other than the unconference sessions I attended, it seems like the majority of design session attendees were just there to lurk
21:33:25 <markwash> patelna_: +1
21:33:34 <patelna_> TTX +1
21:33:37 <gabrielhurley> I didn't mind the lurkers
21:33:49 <ttx> we'll also mark the design summit session more clearly on the schedule, so that they can't be mistaken for a regular presentation
21:33:52 <gabrielhurley> I was just glad the lurkers didn't participate if they were OT or distracting
21:34:02 <ttx> something like "Design session: FOO" all over
21:34:02 <jd__> dolphm: definitely
21:34:14 <dolphm> ttx: awesome, i was really confused when i was told the dev lounge was closed
21:34:18 <dhellmann> ttx: could we mark them as separate tracks in sched.org to make it easier to follow the themes with different colors?
21:34:32 <patelna_> too many people in the design summit ...we need to split the days liek what we had before
21:34:42 <ttx> Sometimes too many lurkers prevent you from having the discussion, that's the limit number we don't want to cross (hence relatively small rooms)
21:34:59 <dolphm> ttx: they can be smaller!
21:35:05 <dolphm> with bouncers
21:35:10 <ttx> dhellmann: design summit sessions have their own color already
21:35:22 <dolphm> ttx: but they're not color coded by project anymore
21:35:24 <dhellmann> ttx: I want separate colors for each project
21:35:36 <patelna_> we had that
21:35:44 <dhellmann> or track or whatever (incl. docs, qa, process, etc.)
21:35:51 <patelna_> the problem was it was overcrowded
21:36:03 <ttx> dhellmann: i'll see what sched lets you do. Having them grouped under a single "design summit" headline is convenient too
21:36:25 <ttx> maybe we'll go back to separate sched websites :)
21:36:37 <dolphm> ttx: create two seperate schedules again, maybe?
21:36:40 * dhellmann didn't mean to open a can of worms
21:37:05 <ttx> no no, that's good feedback, keep it coming
21:37:48 <ttx> #topic Open discussion
21:37:56 <ttx> Any preference on the order you guys should have on the regular meetings ?
21:38:13 <ttx> I tend to place "provider" projects (Oslo, Keystone), before "consumer" projects (Horizon, Heat), but if anyone is based in Europe they can go earlier
21:38:22 <dolphm> i like being early in the meeting
21:38:22 <ttx> I was thinking something like:
21:38:29 <ttx> Oslo, Keystone, Ceilometer, Swift, Glance, Quantum, Cinder, Nova, Heat, Horizon
21:38:36 <gabrielhurley> oh sure. put me last. ;-)
21:38:41 <gabrielhurley> (that's fine)
21:38:46 <ttx> gabrielhurley: you have a meeting next :P
21:38:58 <ttx> I thought I was doing you a FAVOR
21:39:01 <dolphm> lol
21:39:03 <ttx> Still waiting for my beer
21:39:07 <gabrielhurley> haha
21:39:16 <gabrielhurley> next time you're in california
21:39:51 <jd__> ttx: fine with me!
21:40:11 <jgriffith> ttx: no objections here
21:40:19 <ttx> It's in the predator order
21:40:30 <russellb> ha, yeah, it's fine with me
21:40:40 <gabrielhurley> openstack food chain? lol
21:40:41 <markwash> ttx: you should hold out for the germain-robin
21:40:46 <ttx> Well it's not set in stone, we can always adjust
21:41:23 <ttx> Anything else ? Questions about the release cycle, process, blueprints, anything ?
21:41:45 <russellb> so the proposer should be able to set the milestone target?
21:41:45 <markmc> are we nearly there yet?
21:41:59 <ttx> russellb: yes, if he sets himself as assignee, certainly
21:42:06 <russellb> ok, cool.
21:42:17 <markmc> can we make "baby steps" the theme for this release?
21:42:22 <markmc> maybe have a logo and stuff?
21:42:27 * russellb stares at his pile of 175 blueprints
21:42:34 <ttx> markmc: how is "baby steps" related to "Havana" ?
21:42:43 <ttx> Some kind of dance thing ?
21:42:46 <markmc> baby steps + havana == baby with cigar
21:42:47 <markmc> hmm
21:43:03 <markmc> baby swaggering with cigar
21:43:05 <markmc> anyway, I digress
21:43:17 <ttx> I shall raise a thread about the I naming soon, we have a complex issue coming up
21:43:28 <markmc> oooh, you tease
21:43:32 <russellb> heh, still can't find an 'I' near next summit?  :)
21:43:33 <jgriffith> haha.. that's an understatement
21:43:33 <ttx> as Chinese don't seem to start any word with I
21:43:41 <markmc> hehe
21:44:01 <ttx> there are a few places in the general vicinity, but not in China :)
21:44:22 * ttx doesn't want to create a diplocamtic incident, at least not until he is back home
21:44:29 <ttx> diplomatic*
21:44:32 <russellb> there's a manmade lake that starts with 'I', but a man-made tourist area is kinda lame
21:44:58 <ttx> there are a few towns in Taiwan and Indonesia that start with I
21:45:00 <dolphm> someone write a google maps query to find the absolute closest anything to the summit that starts with the letter I, and we'll skip the vote
21:45:13 <ttx> dolphm: you're the man
21:45:24 <markmc> ttx, that sounds like a sure fire diplomatic incident
21:45:30 <markmc> ttx, throw some flags into the mix too
21:45:44 <russellb> Inspiration Lake: http://goo.gl/maps/8l79a
21:45:59 <markmc> the Inspiration release
21:46:04 <markmc> cheesy, but not bad
21:46:24 <russellb> not the worst name ever.
21:46:26 <ttx> especially cheesy once you see that the lake is artificial and the thing hosts a theme park
21:46:39 <russellb> yeah that's the disappointing part :(
21:46:56 <ttx> anyway, watch out for the thread, sometimes next week probably. You can do your research in the mean time
21:46:56 <markwash> we should just call it "Island"
21:47:07 <dolphm> markmc: +1
21:47:10 <ttx> markwash: that kinda reinforces the "non-interoperable" meme
21:47:18 <markwash> lol
21:47:19 <russellb> markwash: yeah, i thought about that ... but that's terrible messaging for a project that wants to promote federation and interop :)
21:47:21 <dolphm> lol
21:47:24 <bcwaldon> ttx: perfect
21:48:09 <russellb> Name: "I...don't know what to call this", short "idunno"
21:48:24 <dolphm> ttx: are there any specifics on where the summit will be yet, other than 'hong kong'?
21:48:35 <ttx> Can that thing be described with a thing that starts with a I : http://www.flags.net/images/smallflags/CHIN0100.GIF
21:48:47 <ttx> dolphm: still under contract negociation
21:49:08 <ttx> anything else before we end the meeting ?
21:49:11 <markmc> oh, since this is an open session
21:49:27 <markmc> I'm working up some improvements on documenting Oslo processes etc.
21:49:38 <dolphm> Isquare, Hong Kong (a 31 story mall)
21:49:41 <markmc> one idea we talked about at the summit was incubating APIs having explicit maintainers
21:49:45 <markwash> we should just skip to K and call it Kowloon (http://en.wikipedia.org/wiki/Kowloon_Walled_City)
21:49:48 * markmc just proposed this: https://review.openstack.org/#/c/27379/1/MAINTAINERS
21:49:51 <markmc> feedback welcome
21:49:56 <markmc> ttx, you're in there :)
21:49:57 <dolphm> there's also an Ikea
21:50:06 <markwash> lol
21:50:29 <russellb> will they offer corporate sponsorship of the next release?
21:50:52 <markwash> that could fit the openstack theme of "some assembly required" :-)
21:51:05 <ttx> markwash: I like it, but that would confuse the hell out of the watchers
21:51:15 <ttx> (Kowloon)
21:51:52 <markwash> nod
21:51:54 <ttx> markmc: looks good
21:52:16 <markmc> ttx, cool, thanks
21:53:09 <dolphm> ttx: we can compensate for the Kowloon confusion by naming the subsequent release starting with the letter I
21:53:44 <dolphm> then we won't have skipped anything and the OCD in all of us will be satisfied (?)
21:54:07 <ttx> dolphm: or find some alphabet that skips "I"
21:54:22 <dolphm> ttx: the OpenStack(tm) Alphabet
21:54:32 <ttx> Isquare sounds like some Apple store
21:54:47 <dolphm> ttx: i guarantee there's a knockoff apple store there
21:54:56 <notmyname> markmc: are we skipping j?
21:55:17 <gabrielhurley> letters with dots over them are clearly unacceptable
21:55:20 <dolphm> i win? http://en.wikipedia.org/wiki/Ice_House_Street
21:56:02 <russellb> oh, and we like naming things after beer, right?
21:56:09 <dolphm> IPA?
21:56:15 <ttx> dolphm: not too bad. Still two words where single words are preferred, but probably the best one suggested so far
21:56:21 <dolphm> OpenStack Ice
21:56:22 <dolphm> done
21:56:36 <russellb> can pretend it's one word 'icehouse'
21:56:57 <dolphm> russellb: +1
21:57:06 <markwash> we need ice
21:57:07 <russellb> i like it more than the fake lake
21:57:14 <gabrielhurley> OpenStack I Ching?
21:57:22 <russellb> Ice may have a trademark conflict ...
21:57:24 <ttx> russellb: yeah, as I say, probably the less intrusive abuse
21:57:48 <russellb> http://www.zeroc.com/ice.html
21:57:49 <dolphm> russellb: it's safer than Ikea
21:58:04 <dolphm> maybe not
21:58:11 <ttx> anyway, time running out, let's close this
21:58:28 <ttx> #endmeeting