21:00:46 <ttx> #startmeeting project
21:00:47 <openstack> Meeting started Tue May 14 21:00:46 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:50 <openstack> The meeting name has been set to 'project'
21:00:58 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:09 <ttx> Usual stuff. Two weeks left in havana-1, will look into the havana-1 plans with an eye on postponing stuff
21:01:21 <ttx> #topic General stuff
21:01:32 <ttx> 2013.1.1 was released last week
21:01:47 <ttx> annegentle, jeblair/mordred, sdague/davidkranz: Anything from Docs/Infra/QA teams ?
21:01:55 <jgriffith> o/
21:02:17 <ttx> Anything anyone wants to raise that affects all projects ?
21:02:22 <jeblair> o/
21:02:41 <ttx> jeblair: is that a yes ?
21:02:51 <ttx> or just a hello ?
21:02:53 <jeblair> we're talking about remote summit participation in the infra team meetings, so stop by next week if you want to contribute
21:03:06 <ttx> that was a yes.
21:03:17 <jeblair> [eol]
21:03:32 <ttx> anything else ?
21:04:07 <ttx> there is a discussion about copyright headers on legal-discuss that you may want to intervene in.
21:04:17 <ttx> ok, let's go per-project now
21:04:25 <ttx> #topic Oslo status
21:04:30 <ttx> markmc: hi!
21:04:34 <markmc> howdy
21:04:35 <ttx> #link https://launchpad.net/oslo/+milestone/havana-1
21:04:54 <ttx> significant progress since... this morning.
21:05:08 <markmc> I'd say correlation-id and object-serialization are very likely to make it
21:05:14 <markmc> the others, it's hard to say
21:05:18 <ttx> trusted-messaging is marked as depending on keystone/key-distribution-server, which is a bit... not in havana plans yet
21:05:25 <markmc> good chance, but couldn't guarantee any of them
21:05:30 <markmc> well
21:05:35 <ttx> how much is that actually blocked by it ?
21:05:36 <markmc> yeah, I should talk to simo about that
21:05:43 <markmc> we could land the code in oslo without that
21:05:53 <markmc> but whether that would achieve anything useful ...
21:06:07 <markmc> so, good point
21:06:26 <ttx> you can remove the dep if it's not a hard dep, and replace it by a mention in the blueprint description
21:06:38 <ttx> Questions about Oslo ?
21:06:39 <markmc> yeah
21:06:46 <markmc> oh, wiki page
21:06:55 <ttx> wiki page ?
21:06:59 <markmc> I basically re-wrote it
21:06:59 <markmc> https://wiki.openstack.org/wiki/Oslo
21:07:13 <markmc> hopefully that answers most of the questions I was hearing at the summit
21:07:37 <markmc> there are some details about making hacking and pbr part of oslo that monty and I will work out
21:07:46 <ttx> cool, will review it
21:07:51 <markmc> oh, another thought
21:08:03 <markmc> nothing in havana is yet using oslo.config from havana
21:08:12 <markmc> they're all till using 2013.1 or whatever
21:08:18 <markmc> another thing I should fix
21:08:33 <markmc> that's me
21:08:59 <ttx> ok
21:09:02 <ttx> #topic Keystone status
21:09:04 <dolphm> o/
21:09:06 <ttx> dolphm: o/
21:09:09 <ttx> #link https://launchpad.net/keystone/+milestone/havana-1
21:09:29 <ttx> dolphm: keystone-ldap-anonymous-binding isn't started yet, do you still think it will make it ?
21:09:41 <dolphm> yes, it should be a very simple implementation
21:10:08 <ttx> Looking at the more general havana plan... any idea who plans to work on store-quota-data and pluggable-remote-user ?
21:10:43 <dolphm> store-quota-data, i'd have to go back and look at the summit etherpad
21:10:51 <dolphm> pluggable-remote-user, either myself or possibly gyee
21:10:59 <dolphm> gyee is on a pluggable spree
21:11:03 <ttx> dolphm: ok, fill  them out if you already know
21:11:09 <dolphm> i'll talk to him
21:11:26 <ttx> keeping you busy with security fixes during this milestone
21:11:34 <ttx> Anything more about Keystone ?
21:11:36 <dolphm> otherwise, i think it's fairly realistic to see an m2-targetted blueprint or two completed in time for m1
21:11:49 <ttx> that would be great.
21:12:13 <dolphm> i did want to mention that the bug in our release notes concerns read-only LDAP uses cases in havana has slipped to 2013.1.2
21:12:24 <dolphm> s/concerns/concerning/
21:12:39 <dolphm> that's it from me
21:12:47 <ttx> dolphm: could you quickfix the release notes ?
21:13:05 <dolphm> ttx: they're up to date: "Read-only LDAP deployments using the bundled identity driver still requires a default domain to be created in LDAP (fix in progress for 2013.1.2)."
21:13:21 <ttx> oh, ok. Known bug.
21:13:24 <ttx> thx!
21:13:27 <ttx> #topic Ceilometer status
21:13:33 <ttx> jd__: o/
21:13:38 <ttx> #link https://launchpad.net/ceilometer/+milestone/havana-1
21:13:39 <jd__> o/
21:13:57 <ttx> Good progress...
21:14:05 <jd__> thank you! :)
21:14:11 <ttx> All on track ?
21:14:25 <jd__> so far so good, I've pinged Toni about his blueprint because I'm worried
21:14:45 <jd__> I've the feeling his patchset is going to be big and will have some rework
21:14:50 <jd__> we didn't see anything for weeks
21:15:01 <jd__> so I might postpone it for havana-2 if no progress, anyway that's no blocker
21:15:01 <ttx> I won't say "not a big deal if it slips" because you have so many in the pipe...
21:15:16 <ttx> Looking into the general plan at https://blueprints.launchpad.net/ceilometer/havana now
21:15:21 <jd__> ttx: well, at least it doesn't block anything else :)
21:15:32 <ttx> There is still a bit of milestone targeting needing to be done
21:15:39 <ttx> jd__: right :)
21:15:53 <ttx> A few of those untargeted blueprints are actually started: hbase-metadata-query, alarm-api, add-event-table...
21:15:53 <jd__> yeah, I'm having a hard time pushing people to assign bp and milestone
21:16:41 <ttx> once it's assigned, it's just a matter of asking the assignee when he thinks, roughly, it will land
21:17:10 <jd__> yup, I'll do that :)
21:17:51 <ttx> Your plan is pretty ambitious already at 45 blueprints.
21:17:59 <ttx> Note that it's better to postpone stuff early rather than communicate false hopes to people :)
21:18:07 <ttx> Questions on Ceilometer ?
21:18:15 <jd__> ttx: fair enough :)
21:18:54 <ttx> #topic Swift status
21:18:57 <ttx> notmyname: o/
21:18:58 <notmyname> hi
21:19:01 <ttx> #link https://launchpad.net/swift/+milestone/1.8.1
21:19:18 <ttx> notmyname: About https://blueprints.launchpad.net/swift/+spec/proxy-affinity-writes, should it be considered "Started" ?
21:19:22 <ttx> Saw code in WIP at https://review.openstack.org/#/c/27431/
21:19:51 <notmyname> ya, I saw that too
21:19:59 <notmyname> but I hadn't had a chance to review it yet
21:20:15 <notmyname> basically 1.8.1 will be the completion of the global cluster features
21:20:16 <ttx> notmyname: if work is started we can update status
21:20:23 <notmyname> and I was just looking at the separate replication patches
21:20:56 <ttx> proxy-affinity-writes is not directly linked to global cluster ?
21:21:16 <notmyname> yes, if work has started, we can update the status. the author didn't reference the blueprint, and I hadn't had a chance to see if it actually matches, so I hadn't updated anything yet
21:21:21 <notmyname> yes, it's related
21:21:39 <ttx> notmyname: Will update status for you. anything you wanted to raise ?
21:21:59 <notmyname> can I update the status after I have a change to look at the code?
21:22:09 <notmyname> the other thing to mention is swift api work
21:22:27 <ttx> notmyname: sure, I'll revert my status change then
21:22:43 <notmyname> work is continuing on https://wiki.openstack.org/Swift/API to define the functionality that wil be defined as swift api v1.0
21:23:32 <ttx> Anything more on Swift ?
21:23:38 <notmyname> work will be continuing to define this and then move on to next versions of the api
21:24:15 <notmyname> that's all from me
21:24:22 <ttx> thanks!
21:24:38 <ttx> #topic Glance status
21:24:43 <ttx> markwash: o/
21:24:47 <ttx> #link https://launchpad.net/glance/+milestone/havana-1
21:24:49 <markwash> ahoy
21:24:56 <markwash> a very few recent changes there
21:25:06 <ttx> Good progress... api-v2-property-protection isn't started yet ?
21:25:28 <markwash> folks are now getting together to plan out the nitty gritty details
21:25:31 <markwash> I'm sure that one will slip
21:25:50 <markwash> I'll get another opinion about h2 vs h3 from them next monday
21:26:04 <ttx> markwash: let's move it to h2 already
21:26:08 <markwash> +1
21:26:12 <ttx> will do
21:26:18 <ttx> Looking into the general havana plan now @ https://blueprints.launchpad.net/glance/havana
21:26:34 <markwash> multiple image locations seems stalled out as well
21:26:40 <ttx> Still a lot of stuff without a milestone target set... should we consider those all targeted to havana-3 ?
21:27:15 <markwash> not for all of them, unfortunately
21:27:23 <markwash> I'll make sure that page looks pretty by thursday during the glance meeting
21:27:29 <ttx> great!
21:27:36 <markwash> #action markwash target all the blueprints
21:27:48 <ttx> re: not all of them -- yes, support-for-multipart-form-data-contenttype and hypervisor-templates-as-glance-images are already started...
21:28:00 <ttx> so probably not that far from completion
21:28:04 <ttx> Anything more on Glance ?
21:28:12 <markwash> those are sort of dark horses, though
21:28:17 <markwash> so I don't know about their velocity yet
21:28:24 <markwash> nothing more from me
21:28:27 <ttx> dark horses. I like that.
21:28:39 <ttx> markwash: thx!
21:28:48 <ttx> #topic Quantum status
21:28:52 <ttx> markmcclain: hi!
21:28:55 <markmcclain> hi
21:28:57 <ttx> #link https://launchpad.net/quantum/+milestone/havana-1
21:29:54 <ttx> catching up with recent changes :)
21:30:10 <markmcclain> yeah.. had a few folks try to sneak two bps into h1
21:30:31 <ttx> portbinding-ex-db looks implemented to me ?
21:31:06 <ttx> or is there more to it ?
21:31:29 <ttx> Same question for https://blueprints.launchpad.net/quantum/+spec/api-core-for-services (targeted to havana-2)
21:31:37 <markmcclain> there's another review associated with it that is not linked
21:31:53 <ttx> good then
21:31:59 <markmcclain> api-core will have 2 reviews
21:32:04 <markmcclain> only 1 has been submitted
21:32:04 <ttx> Good progress overall... except remove-use-of-quantum which is still pending the choice of the new name :)
21:32:15 <russellb> TPFKAQ
21:32:23 <ttx> Looking into the general havana plan now: https://blueprints.launchpad.net/quantum/havana
21:32:37 <markmcclain> russellb: do you have a pronunciation :)
21:32:58 <russellb> markmcclain: it's like the-artist-formerly-known-as-prince, you couldn't pronounce that symbol either
21:33:09 <markmcclain> haha
21:33:13 <ttx> markmcclain: You might want to add https://blueprints.launchpad.net/quantum/+spec/quantum-vpnaas-ipsec-ssl, since it's a dependency of vpnaas-python-apis
21:33:31 <ttx> Looks like you're almost done with https://blueprints.launchpad.net/quantum/havana/+setgoals
21:33:31 <markmcclain> I will.. they just agreed yesterday exactly what was in it
21:33:37 <ttx> Anything else on Quantum ?
21:33:50 <markmcclain> not from me
21:34:03 <ttx> do we have jgriffith ?
21:34:41 <jgriffith> hello!
21:34:44 <ttx> we do have jgriffith
21:34:47 <jgriffith> :)
21:34:52 <ttx> #topic Cinder status
21:34:55 <ttx> #link https://launchpad.net/cinder/+milestone/havana-1
21:35:26 <jgriffith> I'll be moving state machine to H2
21:35:26 <ttx> looks like this is all a bit late, anything you'd like to defer now ?
21:35:34 <ttx> ok
21:35:48 <jgriffith> that one and I need to contact xing Yang regarding her FC support
21:35:56 <ttx> Feeling confident for the "started" ones ?
21:36:04 <jgriffith> so far yes
21:36:10 <jgriffith> Most are coming along nicely
21:36:17 <jgriffith> a few should land before the end of the week
21:36:27 <ttx> ok, beware of the review queue toward the end of the milestone
21:36:33 <ttx> Looking into the general havana plan @ https://blueprints.launchpad.net/cinder/havana
21:37:01 <ttx> https://blueprints.launchpad.net/cinder/+spec/volume-migration should have a priority set
21:37:13 <jgriffith> on it
21:37:34 <jgriffith> I actually would like to work with Avishay and break that one up a bit
21:37:37 <ttx> otherwise looking pretty good
21:37:47 <jgriffith> It's a bit too general as it is right now for my liking
21:37:57 <jgriffith> I'll try and catch him tonight and sort that
21:37:59 <ttx> yes, those kind tend to never be completed
21:38:04 <jgriffith> :)
21:38:09 <ttx> Anything more about Cinder ?
21:38:14 <jgriffith> or they're not what anybody wants :)
21:38:18 <jgriffith> Nope, that's it for me
21:38:31 <ttx> #topic Nova status
21:38:35 <ttx> russellb: o/
21:38:39 <ttx> #link https://launchpad.net/nova/+milestone/havana-1
21:38:41 <russellb> hi!
21:38:51 <ttx> Getting a bit late, still feeling optimistic ?
21:38:59 <russellb> for all of this?  no :-)
21:39:06 <russellb> i've starting pushing some things back today
21:39:16 <russellb> will continue to do so over the next week as i'm able to catch up with people
21:39:25 <ttx> use-db-time and remove-instance-fault-table are targeted but not started yet
21:39:34 <russellb> use-db-time is quick and easy
21:39:54 <russellb> the other probably won't make it, but figured i'd give it a few days in case code magically appears
21:40:46 <ttx> otherwise you got them all triaged, as of 5 minutes ago
21:40:54 <ttx> https://blueprints.launchpad.net/nova/havana/+setgoals has a new one :)
21:40:55 <russellb> haha, yeah.
21:41:02 <russellb> as of about 1 minute ago
21:41:16 * russellb fixes it up
21:41:37 <russellb> good now
21:41:54 <ttx> live-migration-to-conductor (High) depends on query-scheduler (Medium) -- which one should be adjusted ?
21:42:20 <russellb> query-scheduler should go to high, then
21:42:26 <ttx> ok will do
21:42:28 <ttx> Any question on Nova ?
21:42:41 <russellb> question from me
21:42:48 <russellb> do we have a page i can point people on blueprint process?
21:43:13 <russellb> i spend a lot of time telling people which fields to set, etc., to get it on my radar
21:43:20 <ttx> I'd say https://wiki.openstack.org/wiki/Release_Cycle, and https://wiki.openstack.org/wiki/Blueprints
21:43:33 <russellb> ok will check those out, thanks
21:43:56 <ttx> They may need some updates, but that's the reference doc
21:44:06 <russellb> k, will review / propose updates as needed
21:44:06 <ttx> #topic Heat status
21:44:13 <ttx> shardy: hi!
21:44:15 <shardy> hi
21:44:17 <ttx> #link https://launchpad.net/heat/+milestone/havana-1
21:44:54 <ttx> russellb: there is also https://wiki.openstack.org/wiki/PTLguide but that's more for PTL and drivers.
21:45:16 <ttx> shardy: havana-1 looks in good progress
21:45:28 <shardy> ttx: I think we're in good shape for h1, apart from a few of the networking bugs may slip
21:45:34 <ttx> Looking into the general havana plan @ https://blueprints.launchpad.net/heat/havana now
21:45:37 <shardy> need to speak to stevebaker and jpeeler to confirm
21:46:16 <ttx> Could still use a bit more target milestones... but I see progress :)
21:46:47 <shardy> ttx: Yes, I've started putting things I think will get done, or which I'd like to see done for h2
21:46:48 <ttx> a number of those untargeted blueprints are already started, like watch-ceilometer or function-plugins
21:47:07 <ttx> so their assignee should have an idea of when he will complete them
21:47:19 <shardy> but a lot of promised contributions are being slow to materialize, so I'm still playing wait-and-see on some of the bigger stuff expected later in the cycle
21:47:46 <ttx> shardy: it's not a big deal to keep low prio stuff untargeted
21:47:59 <ttx> A bit more embarassing for High prio stuff
21:48:10 <shardy> ttx: I'll speak to asalkeld and zaneb to get updates on when those will land
21:48:16 <ttx> since High means, you really want it in the release
21:48:41 <ttx> shardy: That's all I had for you. anything you wanted to mention ?
21:48:50 <shardy> one question
21:49:02 <shardy> you asked for havana roadmap emails to the list last week
21:49:15 <ttx> yep, those would be nice
21:49:30 <shardy> which list - do you want user-focussed ones to the openstack list?
21:49:35 <shardy> or xpost to both?
21:49:57 <reed> xpost is evil
21:49:59 <ttx> xpost is evil. Post to openstack-dev only. I saw russellb pushed one to his blog, that's fine too
21:50:01 <shardy> wasn't sure how to pitch it so wanted to clarify
21:50:18 <shardy> Ok, thanks
21:50:24 <ttx> I'm pretty sure reed will pick those up and mention them in the newsletter
21:50:30 <reed> i should stop xposting myself :)
21:50:39 <ttx> so they will get attention, without the drawbacks of cross-posting
21:50:48 <ttx> Questions about Heat ?
21:50:49 <russellb> ttx: yeah, was hoping newsletter would get it
21:51:11 <reed> if it's on planet there are highest chances it will make it to the newsletter
21:51:25 <ttx> #topic Horizon status
21:51:29 <ttx> gabrielhurley: hey
21:51:31 <gabrielhurley> hi
21:51:33 <ttx> #link https://launchpad.net/horizon/+milestone/havana-1
21:51:44 <ttx> Progress is a bit slow...
21:51:52 <gabrielhurley> it's kinda borderline
21:51:56 <gabrielhurley> things are moving along
21:52:11 <gabrielhurley> the keystone stuff has been significantly slowed by getting some reviews through on keystoneclient
21:52:18 <gabrielhurley> but I still have confidence in those
21:53:06 <gabrielhurley> I'm not ready to bump any *quite* yet
21:53:12 <ttx> admin-group-crud is not started... is it simple enough to be completed in the two remaining weeks ?
21:53:14 <gabrielhurley> but I am gonna be tightening in on people this week
21:53:18 <gabrielhurley> yeah, it is
21:53:23 <ttx> ok
21:53:35 <ttx> Questions on Horizon ?
21:53:43 <gabrielhurley> by-and-large none of these will be showstoppers if they *do* slip, though
21:54:03 <ttx> gabrielhurley: right, you got the essential under control
21:54:27 <ttx> gabrielhurley: anything else you wanted to mention ?
21:54:32 <gabrielhurley> nope
21:54:36 <ttx> ok then
21:54:37 <ttx> #topic Incubated projects
21:54:46 <ttx> hub_cap, devananda: welcome!
21:54:53 <russellb> \o/
21:54:58 <ttx> Any question ?
21:56:02 <devananda> o/
21:56:10 <devananda> nope. just following along and learning :)
21:56:38 <ttx> devananda: first step is getting that repo set up :)
21:56:57 <devananda> yep... not a lot of real activity yet as a result
21:57:04 <ttx> devananda: do you have seed code ready to fill it ?
21:57:08 <devananda> i'v e got a review up for that, just waiting on jeblair
21:57:09 <devananda> and yes
21:57:17 <devananda> https://github.com/devananda/ironic
21:57:35 <devananda> working on some skeleton docs and will be posting BPs soon
21:57:47 <devananda> so that once there is a repo, folks can begin claiming parts of it and working in parallel
21:57:54 <ttx> reddwarf still needs to move, but i guess it can wait for the name vet first
21:58:16 <ttx> devananda: hopefully should be all set today
21:58:25 <devananda> :)
21:58:31 <ttx> ok, if you have no question, I guess I can close the meeting
21:58:40 <ttx> anything else, anyone ?
22:00:08 <ttx> ok then
22:00:10 <ttx> #endmeeting