21:02:20 <ttx> #startmeeting project
21:02:21 <openstack> Meeting started Tue Jun  4 21:02:20 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:24 <openstack> The meeting name has been set to 'project'
21:02:28 <jgriffit1> :)
21:02:33 * russellb does his usual clean up of nova blueprints out from under ttx
21:02:37 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:48 <ttx> #topic General stuff
21:03:00 <ttx> Last week we published the havana-1 milestone... went mostly OK, except a regression was missed in Heat
21:03:15 <ttx> which streeses again the need for more integration tests there
21:03:30 <zaneb> we have folks working on tempest integration
21:03:35 <ttx> #info The "I" release will be named "Icehouse"
21:03:41 <ttx> (not my choice)
21:03:42 <zaneb> which will hopefully resolve a lot of those issues
21:03:48 <jgriffit1> Ick
21:03:50 <jgriffit1> haha
21:03:58 <ttx> We'll probably skip next week's meeting, unless swift is ready to release...
21:04:06 <notmyname> not by next week
21:04:14 <ttx> notmyname: awesome :)
21:04:19 <ttx> adam_g: status for 2013.1.2 stable release ?
21:04:20 <adam_g_> FYI! stable/grizzly branches are frozen for 2013.1.2 release this Thursday.  Don't be offended if you have a -2 on your merge until branches are open.  Any testing on the current stable/grizzly branches is welcome prior to release.
21:04:34 <markmc> adam_g_, nice :)
21:04:38 <adam_g_> If there's anything critical that needs in 2013.1.2 please get in touch quick!
21:05:07 <annegentle> o/
21:05:11 <russellb> adam_g_: there was a critical nova patch
21:05:17 <ttx> #info If there's anything critical that needs in 2013.1.2 please get in touch with adam_g quick!
21:05:18 <russellb> adam_g_: that i had proposed but you -2'd :-)
21:05:24 <adam_g_> russellb, which?
21:05:39 <russellb> adam_g_: https://review.openstack.org/#/c/31244/
21:05:47 <russellb> adam_g_: regression that has billing implications
21:05:51 <dolphm> adam_g_: i probably have one from keystone
21:05:52 <adam_g_> russellb, i dont think we have a formal way of requesting an exception for the stable freezes, so apologies for the -2
21:06:23 <dolphm> adam_g_: https://bugs.launchpad.net/keystone/+bug/1170649
21:06:26 <uvirtbot> Launchpad bug 1170649 in keystone "Removing a user from a project would result to all members of that project to be removed" [Critical,In progress]
21:06:43 <ttx> dolphm: sounds embarassing
21:06:48 <adam_g_> dolphm, ack, i'll take a look
21:06:52 <dolphm> ttx: criticals always are!
21:06:53 <russellb> people get very unhappy if they underbill customers is all, heh
21:07:41 <ttx> annegentle: something about docs ?
21:07:52 <annegentle> #info Docs are now automatically generating nova.conf config options and inserting into the Compute Admin Manual manually, will get the rest of it automated.
21:08:03 <adam_g_> russellb, dolphm i'll get an email to the stable list today with possible exceptions. keep an eye out
21:08:08 <annegentle> and a new intern welcome: We have Terri Yu working on Ceiliometer with Julian Danjou (jd__) through the GNOME Outreach Program for Women, welcome terriyu!
21:08:13 <russellb> adam_g_: cool thanks!
21:08:43 <annegentle> ttx: that's all I've got
21:08:45 <ttx> welcome terriyu!
21:09:04 <ttx> jeblair/mordred, sdague/davidkranz: news from Infra/QA teams^Wprograms ?
21:09:58 <jeblair> ttx: nack
21:10:15 <ttx> ok then let's go project-specific
21:10:20 <ttx> #topic Oslo status
21:10:22 <ttx> markmc: hi!
21:10:25 <markmc> hey
21:10:35 <ttx> #link https://launchpad.net/oslo/+milestone/havana-2
21:10:40 * markmc knows he's behind on things
21:10:53 * ttx refreshes
21:10:58 <ttx> You've got a number of blueprints there that are missing the "havana" series goal
21:11:08 <ttx> oslo-scheduler, oslo-sqlalchemy-utils, service-restart, common-heartbeat-driver, oslo-base-manager
21:11:16 <ttx> The last two are also missing priority set
21:11:17 <markmc> yeah, I only noticed them earlier
21:11:24 <markmc> will look properly tomorrow
21:11:28 <ttx> 14 blueprints is a bit ambitious compared to the 5 delivered in H1...
21:11:38 <markmc> I always miss these because I never get notifications of new blueprints
21:11:40 <ttx> There is room in H3 for deferring, fwiw. You've got 3 blueprints assigned to you, for example
21:11:58 <markmc> ok, cool
21:12:03 <ttx> Did you make progress unblocking trusted-messaging ?
21:12:08 <markmc> none jump out at me as being totally unrealistic at this point
21:12:17 <ttx> is it still a likely H2 target ?
21:12:23 <markmc> no, I haven't heard an update on the key distribution server work
21:12:25 <ttx> I'd rather not announce it and get people excited if we see no way of delivering it in the current state of affairs...
21:12:57 <markmc> yeah, I'll catch up with simo again
21:13:06 <markmc> the oslo side of things are in pretty good shape for it
21:13:06 <ttx> markmc: anything you wanted to raise ?
21:13:12 <dolphm> markmc: i'm told that it's still in progress, but not ready for review
21:13:12 <markmc> not really
21:13:20 <markmc> bit exhausted after writing this today: http://blogs.gnome.org/markmc/2013/06/04/async-io-and-python/
21:13:32 <markmc> it's some investigation work for the oslo messaging work
21:13:39 <markmc> others should find it useful too, I hope
21:13:49 <markmc> dolphm, cool
21:13:49 <russellb> you had a quantum thing last week, with oslo.config, can't remember details
21:13:58 <russellb> but it affected a nova patch series, too
21:14:19 <russellb> that get cleared up?
21:14:41 <markmc> nearly
21:14:43 <markmc> very nearly
21:14:47 <russellb> ok cool
21:14:49 <markmc> we need this pbr fix https://review.openstack.org/#/c/30938/
21:14:57 <markmc> mordred is pushing a new release asap
21:14:57 <ttx> Other questions about Oslo ?
21:15:23 <mordred> there's another thing I need to fix before releasing a new pbr
21:15:26 <mordred> but yeah
21:15:30 <markmc> ok, cool
21:15:37 <mordred> and I tihnk that it might be a bug in a new releaes of distributer
21:15:42 <mordred> which is making me cry
21:15:56 <ttx> #topic Keystone status
21:16:02 <ttx> dolphm: o/
21:16:03 <dolphm> o/
21:16:07 <ttx> #link https://launchpad.net/keystone/+milestone/havana-2
21:16:46 <ttx> dolphm: you deferred store-quota-data ?
21:17:13 <dolphm> i dropped https://blueprints.launchpad.net/keystone/+spec/store-quota-data from havana altogether, as it's api-impacting and i'd like to have an api-level feature freeze at the end of m2... it doesn't look like there's much momentum behind that bp at this point
21:17:30 <ttx> api-level feature freeze at the end of m2++
21:18:05 <ttx> I think that ll looks good
21:18:09 <dolphm> cool
21:18:17 <ttx> dolphm: Anything more about Keystone ?
21:18:44 <dolphm> not unless you want to hear about bugs
21:19:03 <ttx> if you tell me about bugs I'll tell you about vulnerabilities
21:19:08 <ttx> Questions anyone ?
21:19:44 <ttx> #topic Ceilometer status
21:19:49 <ttx> jd__: hey
21:19:57 <jd__> o/
21:19:58 <ttx> #link https://launchpad.net/ceilometer/+milestone/havana-2
21:20:34 <ttx> I see you've got 8 blueprints assigned to you (and Eoghan's got 3) -- feeling confident ?
21:20:53 <jd__> for mine, pretty
21:21:01 <jd__> I can't tell for others unfortunately
21:21:40 <ttx> we'll see progress in two weeks
21:21:54 <ttx> Plan is looking good now
21:21:59 <ttx> jd__: anything you wanted to mention ?
21:22:17 <jd__> nop
21:22:22 <jd__> we're good :)
21:22:23 <ttx> Questions on Ceilometer ?
21:22:59 <ttx> #topic Swift status
21:23:03 <ttx> notmyname: o/
21:23:06 <notmyname> hi
21:23:13 <ttx> notmyname: no new release in sight yet ?
21:23:18 <notmyname> I don't think I have anything new to report this week
21:23:29 <notmyname> still waiting for reviews on the final patches for this release
21:23:48 <notmyname> but they aren't trivial (and we're all busy), so it takes a while
21:23:52 <ttx> notmyname: you won't want to push it especially on the week I intended to skip this meeting on :)
21:24:29 <notmyname> heh, no. if it's not done by now, it won't be ready for release next week
21:24:46 <ttx> ack
21:25:07 <ttx> will you keep the 1.8.1 numbering, or switch to 1.9.0 ?
21:25:17 <notmyname> probably 1.9
21:25:23 <ttx> yeah, given the feature set
21:25:28 <ttx> notmyname: anything else you wanted to raise ?
21:25:37 <notmyname> no, I'm good
21:25:43 <ttx> Questions about Swift ?
21:26:02 <ttx> #topic Glance status
21:26:08 <ttx> markwash: o/
21:26:13 <ttx> #link https://launchpad.net/glance/+milestone/havana-2
21:26:15 <markwash> ttx: hi hi!
21:26:41 <ttx> use-oslo-common-db-code was proposed to h2 @ https://blueprints.launchpad.net/glance/havana/+setgoals
21:26:54 <markwash> thanks again for that link
21:26:59 <markwash> I've been in discussion with boris
21:27:30 <ttx> ok, just confirm or deny it sometimes in the next 2 weeks
21:27:38 <ttx> 11 blueprints sounds a bit ambitious compared to the 2 completed in H1...
21:27:47 <ttx> but then, those are almost all assigned to different people (except two for Iccha Sethi)
21:27:56 <ttx> and there is a bit of room in H3 in case of spillover
21:28:10 <markwash> I expect spillover, but can't pick which will spill yet
21:28:38 <ttx> https://blueprints.launchpad.net/glance/+spec/membership-policy has code proposed now... should we target it to H2 too ?
21:29:07 <markwash> sorry, thought I had already done that. . yes (and done)
21:29:14 <ttx> markwash: anything you wanted to mention ?
21:29:29 <markwash> not as such
21:29:31 <markwash> thanks!
21:29:33 <ttx> Questions on Glance ?
21:29:37 <markwash> oh
21:29:38 <markwash> one thing
21:29:48 <markwash> thanks to the swift folks for looking into ACLs updates
21:30:05 <ttx> yeah, cross-project love
21:30:11 <markwash> struggling to find the link right now
21:30:24 <markwash> but it will fix one of our bugs with the multi-tenant swift store
21:30:49 <ttx> #topic Quantum status
21:30:55 <markmcclain> hi
21:30:56 <ttx> markmcclain: hi!
21:30:59 <ttx> #link https://launchpad.net/quantum/+milestone/havana-2
21:31:11 <ttx> Yay, 49 blueprints!
21:31:14 <markmcclain> way too many BPs for H2
21:31:22 <ttx> Indeed, that's a decent increase compared to the 17 which were delivered during H1 :)
21:31:36 <ttx> There is also a bit of oversubscription with a lot of assignees having 4 to 7 blueprints assigned...
21:31:54 <markmcclain> yeah.. h2 seemed to be a popular place to cram things in
21:32:04 <ttx> 2 of those don't have an assignee set yet
21:32:21 <markmcclain> oops.. I missed those 2
21:32:42 <markmcclain> our subteams are using this week to revise the plan to a realistic number of BPs for h2
21:33:08 <ttx> https://blueprints.launchpad.net/quantum/+spec/provider-router is actually not even proposed to havana
21:33:27 * ttx curses the series goal / milestone target LP impedence mismatch
21:33:57 <ttx> markmcclain: some of them don't have the priority set too :)
21:34:06 <markmcclain> yeah we're stilling reviewing that blueprint
21:34:39 <markmcclain> I'll clean up the priorities
21:35:01 <ttx> About remove-use-of-quantum: did you send in new names ? I'd like this one to be closed as early in H2 as possible
21:35:28 <ttx> so that we don't affect the end of milestone
21:35:46 <ttx> and merge when the waters are calm
21:35:54 <markmcclain> yeah.. I was waiting feedback on some of the new candidates
21:36:04 <markmcclain> I've got a new short list to send over
21:36:40 <ttx> markmcclain: anything you wanted to raise ?
21:36:55 <markmcclain> not at this time
21:37:24 <ttx> Questions on Quantum ?
21:37:36 <ttx> #topic Cinder status
21:37:39 <ttx> jgriffith: hola!
21:37:41 <jgriffith> o/
21:37:42 <ttx> #link https://launchpad.net/cinder/+milestone/havana-2
21:37:59 <jgriffith> hmm...
21:38:07 <ttx> OK, you win. This is the most significant increase in velocity: 2 blueprints completed in H1, 29 targeted to H2
21:38:11 <jgriffith> optimistic I think
21:38:22 <ttx> Do you expect a lot of losses along the way ?
21:38:37 <ttx> jgriffith: For those you have no idea whether they will be completed, I think it's fine to set them to "Low" and not target them to the milestone until they are done...
21:38:50 <jgriffith> ttx: ahh.. excellent!
21:38:53 <jgriffith> ttx: I have a list ;)
21:38:55 <ttx> like stuff from random teams you never heard of before
21:39:01 <jgriffith> indeed
21:39:23 <ttx> I /think/ that's more accurate than letting them in the milestone and praying
21:39:30 <jgriffith> agree
21:39:37 <jgriffith> considering many are slips from H1 anyway :)
21:39:48 <ttx> when it's people you know it's good to have it "in", but in your case...
21:39:50 <jgriffith> I'm not overly optimistic in their ability to deliver at this point :)
21:39:52 <ttx> volume-host-attching, db-archiving, huawei-hvs-volume-driver need to be confirmed in the havana series goal @ https://blueprints.launchpad.net/cinder/havana/+setgoals
21:40:15 <jgriffith> I think I tricked ya and updated that while you were on quantum :)
21:40:16 <ttx> oh, you cleared that
21:40:23 <jgriffith> sneaky
21:41:04 <ttx> Some still need an assignee :P
21:41:15 <jgriffith> yep
21:41:22 <jgriffith> I'll pull those for sure
21:41:38 <ttx> Did you make progress with avishay on splitting volume-migration ?
21:42:00 <jgriffith> ttx: I've spoken to him about it, but he doesn't know how he'd split it
21:42:08 <jgriffith> ttx: we should be discussing it again tomorrow
21:42:13 <ttx> OK. Was also wondering if db-session-cleanup and hds-hus-iscsi-cinder-driver were not completed ? You can look them up off-meeting
21:42:16 <jgriffith> I'll see if I can help him figure out a way to clean it
21:42:21 <jgriffith> They are
21:42:22 <ttx> jgriffith: anything on your mind ?
21:42:26 <jgriffith> I'm fixing that up now
21:42:33 <jgriffith> Just having a ball :)
21:42:35 <ttx> Questions on Cinder ?
21:42:53 <ttx> #topic Nova status
21:42:57 <ttx> russellb: hey
21:43:01 <ttx> #link https://launchpad.net/nova/+milestone/havana-2
21:43:07 <russellb> hey
21:43:15 <russellb> 73 blueprints ...
21:43:17 <ttx> New world record, 73 blueprints (compared to 16 delivered in H1)
21:43:17 <russellb> a bit insane.
21:43:30 <ttx> That said, 10 of them are Christopher Yeoh's
21:43:38 <russellb> yeah, v3-api work was broken up well
21:43:39 <ttx> I suspect (hope) those are small bits
21:43:41 <russellb> yep
21:44:00 <ttx> And 6 of them were not in the series goal when I checked earlier:
21:44:09 <ttx> user-locale-api, async-network-alloc, improve-vmware-disk-usage, revert-resize-force-option, encrypt-cinder-volumes, list-saving-images-through-admin-api
21:44:16 <russellb> yeah, fixed those up at beginning of meeting
21:44:33 <russellb> this meeting is my reminder to do housekeeping :-/
21:44:44 <russellb> try to do it during the week too, but it's a lot
21:45:16 <ttx> russellb: is it all known parties placing features in H2 ? Or more the Cinder "unknown people" case ?
21:45:17 <russellb> so a ton of blueprints, but all with someone who has theoretically committed to doing the work
21:45:30 <ttx> so, the former
21:45:38 <russellb> mostly known
21:45:46 <ttx> well, review early
21:45:49 * russellb nods
21:45:55 <ttx> russellb: anything else you wanted to mention ?
21:45:57 <russellb> will be pushing on it every week
21:45:58 <russellb> nope ...
21:46:03 <ttx> Any question on Nova ?
21:46:39 <ttx> #topic Heat status
21:46:41 <zaneb> yo
21:46:43 <ttx> zaneb: o/
21:46:46 <ttx> #link https://launchpad.net/heat/+milestone/havana-2
21:47:01 <ttx> Do you have assignees for stack-metadata & discover-catalog-resources ?
21:47:28 <zaneb> I think Randall was going to assign someone for those
21:47:46 <zaneb> but he doesn't have rights to set it in launchpad
21:47:57 <zaneb> so we'll have to check back with him whose names he wants on it
21:48:20 <ttx> zaneb: ok... fix it in the next week, no urgency
21:48:23 <zaneb> sorry - that's just for the stack metadata
21:48:31 <ttx> ah
21:48:34 <zaneb> misread the other one
21:48:42 <zaneb> I don't think we have anyone assigned for that
21:49:08 <ttx> if nobody signed up to do it, maybe deferring to H3 would be more realistic
21:49:23 <zaneb> SpamapS raised it but it wasn't clear to me if he was going to work on it
21:49:26 <ttx> maybe talk about it at next Heat meeting
21:49:32 <ttx> Looking into heat-trusts... do we have progress on keystoneclient side yet ?
21:49:34 <zaneb> ok, will do
21:49:38 <ttx> dolphm: ?
21:49:52 <ttx> "Blocked on keystoneclient support for trusts"
21:49:54 <dolphm> ayoung: ^?
21:50:02 <dolphm> i'm not aware of anything in review
21:50:39 <dolphm> i imagine ayoung would be working on trust support in keystoneclient, but haven't heard anything either way
21:51:02 <SpamapS> I want to work on those..
21:51:06 <SpamapS> but they are secondary targets
21:51:18 <ttx> dolphm: could you check and report back to zaneb or shardy ? Maybe add a comment on that blueprint whiteboard
21:51:24 <ttx> https://blueprints.launchpad.net/heat/+spec/heat-trusts
21:51:24 <dolphm> SpamapS: yours if you want it- https://blueprints.launchpad.net/python-keystoneclient/+spec/delegation-impersonation-support
21:51:36 <ttx> dolphm: I think he is answering another question
21:51:39 <dolphm> ah
21:51:46 <zaneb> dolphm: bad luck ;)
21:51:56 <dolphm> zaneb: +1
21:52:18 <ttx> #action dolphm to clarify progress on keystoneclient support for trusts and report on heat-trusts bp whiteboard
21:52:21 <zaneb> SpamapS: I assigned you to discover-catalog-resources for now
21:52:25 <ttx> zaneb: anything else you want to raise ?
21:52:27 <dolphm> will do
21:52:30 <zaneb> SpamapS: we can bump to H-3 if you want
21:52:36 <zaneb> ttx: nothing to report
21:52:39 <ttx> Questions about Heat ?
21:53:07 <ttx> #topic Horizon status
21:53:11 <ttx> gabrielhurley: o/
21:53:16 <ttx> #link https://launchpad.net/horizon/+milestone/havana-2
21:53:22 <gabrielhurley> \o
21:53:50 <ttx> Looks good... almost realistic compared to some others ;)
21:54:01 <gabrielhurley> it's a bit of a jump from H1, but I polled everyone last week and nobody wanted to give up any of the ones that are left there for this cycle
21:54:21 <ttx> there are a good number under review already
21:54:21 <gabrielhurley> only david-lyle has more than 2 blueprints assigned
21:54:24 <gabrielhurley> yeah
21:54:28 <gabrielhurley> making progress
21:54:34 <gabrielhurley> we'll see if it keeps up
21:54:54 <ttx> ok, then we'll skip next week meeting to let you make progress uninterrupted
21:54:56 <ttx> gabrielhurley: anything you wanted to mention ?
21:54:59 <gabrielhurley> sounds good to me
21:55:01 <gabrielhurley> nope
21:55:05 <ttx> Questions on Horizon ?
21:55:32 <ttx> #topic Incubated projects
21:55:59 <ttx> hub_cap(grapex?), devananda: around?
21:56:18 <ttx> If not i have canned updates I can post
21:56:36 <ttx> #info not much news for Ironic, besides that docs.openstack.org/developer/ironic is up now, and we're still workin on everything else
21:57:21 <hub_cap> ttx: around
21:57:24 <ttx> #info reddwarf chugging along w/ the h2 blueprints, still waiting for name vetting from Foundation crew
21:57:32 <hub_cap> still no name update
21:57:36 <hub_cap> and what u said ttx
21:57:39 <ttx> hub_cap: any additional info or question ?
21:57:55 <hub_cap> ya can u prod mark to get the naming done? ;)
21:58:27 <ttx> hub_cap: not sure my stick goes all the way to his vacation spot
21:58:30 <hub_cap> thats my only question for now heh
21:58:50 <hub_cap> ummmmm...... :P
21:59:01 <hub_cap> ya we shall wait till the 10th and beyond
21:59:16 <ttx> hub_cap: someone else should be able to pick up the results
21:59:19 <ttx> I'll prod
21:59:25 <hub_cap> thx muchos
21:59:41 <hub_cap> im liking what im seeing w/ heat fwiw
21:59:50 <ttx> #action ttx to prod foundation staff for new name vetting for reddwarf
21:59:51 <zaneb> \o/
21:59:55 <hub_cap> itll simplify installs
22:00:13 <ttx> #topic Open discussion
22:00:31 <ttx> #info No meeting next week, let's make progress and see how far we've got in two weeks
22:00:39 <ttx> anything else anyone ?
22:01:18 <ttx> #endmeeting