21:02:12 <ttx> #startmeeting project
21:02:13 <openstack> Meeting started Tue Aug 13 21:02:12 2013 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:16 <openstack> The meeting name has been set to 'project'
21:02:22 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:33 <ttx> Usual agenda, Cinder may go first since John has a conflict
21:02:38 <ttx> (if he arrives)
21:02:44 <jgriffith> 0/
21:02:46 <ttx> #topic General stuff
21:02:54 <ttx> Upcoming deadlines are FeatureProposalFreeze for some projects:
21:03:03 <ttx> Nova and Cinder on Aug 21, Neutron on Aug 23
21:03:09 <ttx> dolphm: did you settle on August 28 for Keystone ?
21:03:17 <dolphm> ttx: yes, haven't heard any complaints
21:03:31 <ttx> dolphm: ok, will add it to the release schedule for info
21:03:35 <dolphm> ttx: thank you!
21:03:41 <ttx> For the projects which enforce it, all feature code shall be *proposed* by FPF
21:03:42 <shardy> ttx: we decided on August 23rd for Heat
21:03:55 <ttx> shardy: ah. good news
21:04:29 <ttx> #action ttx to update release schedule to include Heat (Aug 23) and keystone (Aug 28)
21:04:36 <ttx> This should let you have an easy hard rule about rejecting random stuff that would suddenly appear one week before FeatureFreeze
21:04:49 <ttx> sdague, annegentle, jeblair/mordred: news from QA/Docs/Infra programs ?
21:04:53 <annegentle> o/
21:05:00 <ttx> annegentle: shoot
21:05:22 <annegentle> We had our monthly meeting this morning, are looking at going to weekly or every other week
21:05:25 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/MeetingLogs#2013-08-13
21:06:18 <annegentle> Want to be sure the PTLs are good with continuous publishing for some docs, I think I should ask individuals though.
21:06:21 <jeblair> ttx: nak
21:06:35 <ttx> annegentle: that may be more successful
21:06:49 <annegentle> ttx: yep. That's all I've got
21:06:57 <ttx> I usually go after people and point them to the thread. You can't rely on everyone reading everything
21:07:30 <lifeless> annegentle: we're good with continuous publishing
21:07:37 <ttx> ok, let's go project-specific
21:07:48 <ttx> #topic Cinder status
21:07:54 <jgriffith> ttx: hey there
21:08:00 <ttx> #link https://launchpad.net/cinder/+milestone/havana-3
21:08:17 * ttx refreshes
21:08:31 <jgriffith> one undefined still
21:08:46 <jgriffith> I need an update if it's still moving forward "optional iscsi support"
21:08:57 <jgriffith> should have it set or deferred tomorrow
21:09:06 <ttx> I wonder if refactor-lvm-and-iscsi-driver and vmware-vmdk-cinder-driver should not be considered "Needs code review" now
21:09:17 <ttx> 26% done, 13% under review, 46% in progress, 13% not started
21:09:18 <jgriffith> yes to all of the above
21:09:39 <ttx> OK, please update as soon as you get a chance
21:09:51 <ttx> so you're probably not really behind
21:09:52 <jgriffith> ttx: doing it now
21:10:17 <ttx> You've got 2 "not started" still: add-export-import-volumes and db-migration-tests... Is it reasonable to keep them in the roadmap ?
21:10:21 <jgriffith> we'll see, think there are some things that are going to get added the next few days
21:10:28 <ttx> i.e. are they easy and fast ?
21:10:39 <ttx> Move to Low or 'next' ?
21:10:40 <jgriffith> I need to get ahold of the Mirantis guys, they're tough to communicate with at times
21:10:47 <jgriffith> I'm leaning towards next
21:11:04 <jgriffith> but I was scolded for not targetting those in the first place
21:11:16 <jgriffith> so I'm being overly generous in giving them chances
21:11:41 <ttx> you can send a mail with a deadline and move them if you don't get evidence it may make it
21:11:52 <jgriffith> will do
21:11:57 <ttx> or you can keep them "Low" priority and not care if it makes it or not
21:12:09 <ttx> jgriffith: anything else on your mind ?
21:12:09 <jgriffith> ttx: personally I really don't :)
21:12:31 <jgriffith> just the brick effort, but I should link up with russellb outside of meeting on that
21:12:45 <ttx> ok
21:12:48 <ttx> Questions on Cinder ?
21:12:59 <jgriffith> thanks everyone for letting me jump ahead this week
21:13:08 <ttx> #topic Oslo status
21:13:11 <markmc> hey
21:13:13 <ttx> markmc: hi!
21:13:16 <ttx> #link https://launchpad.net/oslo/+milestone/havana-3
21:13:22 <ttx> 83% done, 16% under review, 0% in progress, 0% not started
21:13:27 <markmc> big one is obviously https://blueprints.launchpad.net/oslo/+spec/trusted-messaging
21:13:41 <markmc> the main part of the oslo work for that has actually merged
21:13:50 <markmc> but we're still waiting on the kds side
21:14:08 <markmc> there's an API spec for the kds stuff under review here: https://review.openstack.org/40692
21:14:13 <ttx> so we may end wit hthe feature in oslo but unusable for the lack of a KDS, right ?
21:14:19 <markmc> I take it keystone folks still think it has a chance to make it
21:14:28 <markmc> well, yeah
21:14:43 <ttx> but then who is lined up to make use of it ? Ceilometer maybe ?
21:14:52 <markmc> the code in oslo is currently just infrastructure which isn't integrated with the main rpc code
21:15:09 <markmc> so, it doesn't risk anything by being there either
21:15:16 <markmc> e.g. it doesn't have to be copied into projects
21:15:19 <ttx> Personally I'm a bit worried to ship late code with such security implications as a KDS
21:15:28 <ttx> (with my VMT hat on)
21:15:30 <jd__> (Ceilometer would like to use it indeed)
21:15:52 <markmc> I'd expect nova would use it if it landed in oslo-incubator and keystone
21:16:12 <markmc> yeah, it's definitely very late at this stage
21:16:25 <markmc> can't speak to what keystone folks feel about it at this stage
21:16:31 <ttx> dolphm: ?
21:16:40 <dolphm> ttx: assuming the implementation lands in time, it would be disabled out of the box in keystone
21:17:02 <ttx> dolphm: that doesn't prevent us from having to security-support it
21:17:03 <dolphm> ttx: now that the api review is up, there's a bunch of eyes suddenly on it
21:17:12 <dolphm> ttx: agree
21:17:34 <ttx> That's the sort of thing I'd definitely prefer to postpone...
21:17:42 <ttx> jd__: how badly do you need it ?
21:18:05 <jd__> ttx: we already have our own signing mechanism, so we don't need it for say
21:18:27 <jd__> we'd just prefer to drop our own mechanism to use the common one.
21:18:37 <ttx> we've been bitten in the past with late security-sensitive stuff
21:19:04 <dolphm> and there's https://github.com/stackforge/barbican
21:19:31 <ttx> dolphm: could you reach the various stakeholders and see how much they would like to be postponed to icehouse on this ? I'd welcome more baking time and discussion around this
21:19:47 <dolphm> ttx: sure
21:19:50 <ttx> markmc: anything you wanted to raise about oslo?
21:19:56 <markmc> dolphm, ttx, let's have a discussion on the mailing list about it
21:20:05 <ttx> markmc: +1
21:20:07 <markmc> dolphm, ttx, there hasn't been a discussion about it there for some months
21:20:08 <dolphm> ++
21:20:13 <ttx> I'll let you guys start it and chime in
21:20:23 <markmc> apart from that, I'm mostly heads-down on https://blueprints.launchpad.net/nova/+spec/oslo-messaging
21:20:28 <ttx> ack
21:20:29 <markmc> i.e. porting nova to oslo.messaging
21:20:38 <ttx> right
21:20:42 <markmc> released oslo.messaging-1.2.0a3 today, consider it pretty much feature complete
21:21:01 <ttx> Questions about Oslo ?
21:21:01 <markmc> I figure if the nova port isn't looking in reasonable shape by next week, punt to icehouse
21:21:25 <markmc> #info oslo meeting this friday https://wiki.openstack.org/wiki/Meetings/Oslo
21:21:38 <ttx> markmc: yes, that's another thing that's risky to touch at the end of a cycle
21:21:48 <markmc> ttx, what is?
21:21:51 <markmc> nova? :)
21:21:59 <ttx> messaging in nova :)
21:22:04 <ttx> #topic Keystone status
21:22:15 <ttx> #link https://launchpad.net/keystone/+milestone/havana-3
21:22:20 <ttx> 0% done, 44% under review, 55% in progress, 0% not started
21:23:12 <ttx> More code needs to be proposed now!
21:23:33 <dolphm> agree!
21:23:40 <ttx> dolphm: should unified-logging-in-keystone could be considered 'Implemented' now that https://review.openstack.org/#/c/39934/ is merged
21:23:40 <dolphm> several of those are pending a second +2
21:24:08 <dolphm> ttx: no, that's just a sync; there's another patch in review to consume logging from oslo
21:24:18 <ttx> dolphm: ok
21:24:32 <ttx> then yes. Propose and land :)
21:24:45 <ttx> dolphm: anything you wanted to raise ?
21:24:58 <dolphm> ttx: yes... i did defer a bp today
21:25:20 <dolphm> there were two different quota storage efforts started during havana
21:25:27 <dolphm> this one has gained the most traction https://blueprints.launchpad.net/keystone/+spec/store-quota-data
21:25:44 <dolphm> at this point, the second is simply a new use case on top of the above bp: https://blueprints.launchpad.net/keystone/+spec/domain-quota-management-and-enforcement
21:26:04 <ttx> ok
21:26:07 <ttx> the other key question is around the maturity of the KDS security-wise and the potential benefit of more baking / discussoin, see previous topic
21:26:18 <ttx> we'll discuss that on the ml
21:26:32 <dolphm> ++
21:26:34 <ttx> dolphm: anything else ?
21:26:38 <dolphm> that is all
21:26:51 <dolphm> hopefully next week we'll have > 0% done :)
21:26:52 <ttx> Questions anyone ?
21:27:15 <ttx> #topic Ceilometer status
21:27:20 <ttx> jd__: hey
21:27:21 <jd__> o/
21:27:23 <ttx> #link https://launchpad.net/ceilometer/+milestone/havana-3
21:27:49 * ttx refreshes
21:27:57 <jd__> :-)
21:28:04 <ttx> 15% done, 7% under review, 69% in progress, 7% not started
21:28:08 <ttx> OK.. unless you have an ace up your sleeve...
21:28:14 <ttx> ...I think it's time to make some dramatic changes because this is going into the wall by chasing too many things at the same time
21:28:37 <ttx> I'd suggest moving more things to Low priority (or to the 'next' milestone)
21:28:50 <ttx> In particular stuff not started yet like nova-cell-support
21:29:07 <ttx> jd__: or maybe you have better suggestions ? or a surprise for us :)
21:29:10 <jd__> agreed
21:29:18 <ttx> Tip: you should never bet on the gate being extremely fluid around FeatureFreeze.
21:29:26 <ttx> Land early what you can :)
21:29:28 <jd__> same thing for the RPC signing, I think we know it'll be for 'next'
21:29:56 <ttx> #action jd__ to use the chainsaw on the h3 roadmap and cut it
21:30:03 <jd__> :-)
21:30:28 <ttx> jd__: when is the ceilometer meeting ?
21:30:43 <jd__> ttx: tomorrow 2100 UTC
21:30:55 <ttx> will see if I can make it to push
21:31:00 <ttx> jd__: anything you wanted to mention ?
21:31:04 <jd__> nop
21:31:10 <ttx> Questions on Ceilometer ?
21:31:37 <ttx> #topic Swift status
21:31:44 <ttx> notmyname: around ?
21:32:03 <ttx> I have a canned update
21:32:08 <ttx> <notmyname> ttx: although I'll try, if I'm not in the meeting tomorrow, that's the status update: 1.9.1 release
21:32:21 <ttx> So 1.9.1 was released earlier today
21:32:32 <ttx> mostly a security update
21:32:41 <ttx> Next release is likely to be synced with the coordinated havana release
21:32:52 <ttx> Questions about Swift that I may not be able to answer ?
21:33:39 <ttx> #topic Glance status
21:33:46 <markwash> me me me!
21:33:48 <ttx> markwash: o/
21:33:51 <ttx> #link https://launchpad.net/glance/+milestone/havana-3
21:33:58 <ttx> 40% done, 20% under review, 40% in progress, 0% not started
21:34:03 <ttx> recent progress I see
21:34:11 <markwash> some, and some bumping
21:34:30 <markwash> one is about to go from review to done
21:34:56 <ttx> Still no code proposed for api-v2-property-protection ?
21:35:12 <markwash> not on gerrit, but I have seen some on github
21:35:15 <markwash> progress is being made
21:35:42 <ttx> and you don't have a FPF s oyou might jus tmake it
21:36:08 <ttx> markwash: anything you wanted to mention ?
21:36:14 <markwash> well. . not having an advertised feature freeze doesn't mean new proposals for h3 won't be outright rejected
21:36:22 <markwash> and a new glance client went out!
21:36:32 <markwash> but probably another will come soon, now with PBR
21:36:37 <ttx> sure, but you can have late code proposed on that feature without appearing to play favorites :)
21:36:50 <ttx> Questions on Glance ?
21:36:50 <markwash> right
21:37:54 <ttx> #topic Neutron status
21:37:58 <ttx> markmcclain: hi!
21:38:05 <markmcclain> hi
21:38:06 <ttx> #link https://launchpad.net/neutron/+milestone/havana-3
21:38:37 <ttx> A few questions while I update the status...
21:38:41 <ttx> What's the status of configurable-ip-allocation ?
21:39:01 <ttx> 39% done, 46% under review, 14% in progress, 0% not started
21:39:05 <ttx> The train is still on the rails!
21:39:13 <markmcclain> the code be in gerrit tomorrow
21:39:20 <ttx> What about hyper-v-wmi-v2 ?
21:39:53 <markmcclain> I spoken with alessandro and expected by now, I'll ping him again
21:40:06 <ttx> and.. how is ipv6-feature-parity doing ?
21:40:19 <markmcclain> it's the one I'm worried the most about
21:40:29 <markmcclain> we've got 10 days right :)
21:41:01 <ttx> 10 days to propose code, by your own terms
21:41:16 <ttx> then another 10 days to merge it
21:41:47 <markmcclain> it's the 2nd 10 day period I expect to be tougher part
21:42:10 <ttx> well, if that's the only FAIL in that list I'll call it a miracle nevertheless
21:42:18 <ttx> markmcclain: anything you wanted to raise ?
21:42:28 <markmcclain> nothing new from me
21:42:34 <ttx> Questions on Neutron ?
21:42:48 <ttx> #topic Nova status
21:42:51 <russellb> o/
21:42:52 <ttx> russellb: hey
21:42:55 <ttx> #link https://launchpad.net/nova/+milestone/havana-3
21:43:00 <ttx> 21% done, 47% under review, 31% in progress, 0% not started
21:43:01 <russellb> been updating, so refresh
21:43:06 <ttx> Not too bad!
21:43:13 <ttx> refreshed 20 seconds ago
21:43:17 <russellb> l
21:43:19 <russellb> err, k
21:43:35 <russellb> yeah, been trying to aggressively update things (move to next, or change priority to Low)
21:43:45 <russellb> will keep pushing on it
21:43:57 <russellb> need to start landing more of this stuff under review ...
21:44:25 <ttx> you pushed some of cyeoh gazillion blueprints to low/next ?
21:44:31 <russellb> yes, mostly to next
21:44:39 <ttx> ok
21:44:40 <russellb> thing is ... we decided we're not going to finish the v3 API in havana
21:44:57 <russellb> and all of those covered aspects of that, so doesn't matter if they finish in havana or not at this point
21:44:58 <russellb> IMO
21:45:06 <ttx> Wondering if glusterfs-native-support is actually not 'Implemented' yet (with merging of https://review.openstack.org/#/c/39498/)
21:45:29 <russellb> oh  nice, that went in today
21:45:30 <russellb> yep implemented
21:45:39 * russellb updates
21:45:50 <ttx> russellb: anything else you wanted to mention ?
21:46:17 <russellb> don't think so ... i' think i got 7-10 new blueprints trying to be added to havana-3 in the last week
21:46:18 <russellb> sheesh
21:46:32 <russellb> having to start swinging the hammer around :)
21:46:38 <russellb> anyway, that's it, thanks!
21:46:38 <ttx> you can't wait until you have that FPF sign on the door :)
21:46:40 * hub_cap ducks
21:46:48 <ttx> Any question on Nova ?
21:46:50 <russellb> ttx: yes
21:47:00 * markwash quacks
21:47:07 * russellb gooses
21:47:11 * hub_cap mallards
21:47:19 <russellb> i think you can safely move on now, heh.
21:47:21 <ttx> #topic Heat status
21:47:27 <shardy> o/
21:47:27 <ttx> shardy: o/
21:47:37 <ttx> #link https://launchpad.net/heat/+milestone/havana-3
21:47:42 <ttx> 48% done, 14% under review, 37% in progress, 0% not started
21:47:48 <ttx> Looks on track to me
21:48:10 <shardy> Yep, quite a lot of stuff landing, bumped anything not started
21:48:21 <ttx> Is hot-parameters completed with the merging of https://review.openstack.org/#/c/38921/ ?
21:48:59 <ttx> oh https://review.openstack.org/#/c/41691/
21:49:07 <ttx> igore me
21:49:11 <ttx> or ignore
21:49:18 <shardy> Yeah, there were several parts to that one up for review IIRC
21:49:44 <ttx> Anything more needed to be done with exception-formatting ?
21:50:55 <shardy> It looks complete, but I'll check at our meeting tomorrow to be certain
21:51:14 <ttx> How is heat-trusts doing this week ?
21:51:32 <shardy> I'm working on it now, slow progress but I'm still hoping it will land in time
21:51:38 <ttx> ok
21:51:45 <ttx> What about native-nova-instance ?
21:52:12 <shardy> Again, I know sdake is making progress on that so should land, but I'll ask for confirmation on that at tomorrows meeting
21:52:17 <ttx> shardy: anything else you want to raise ?
21:52:25 <shardy> Not atm, no, thanks
21:52:29 <ttx> Questions about Heat ?
21:52:40 <ttx> shardy: thx!
21:52:46 <ttx> #topic Horizon status
21:52:52 <ttx> gabrielhurley: around ?
21:53:00 <gabrielhurley> yep yep
21:53:05 <ttx> #link https://launchpad.net/horizon/+milestone/havana-3
21:53:11 <ttx> 33% done, 33% under review, 25% in progress, 8% not started
21:53:18 <ttx> Not too bad
21:53:30 <gabrielhurley> darn, if that 8% were in progress it would've been even thirds
21:53:41 <ttx> network-quotas is marked 'not started' -- I think it would make a good target for a 'Low' priority at this point (or just deferred to 'next')
21:54:03 <gabrielhurley> I reached out to the assignee for that one today, I will probably bump it to "next" as soon as I hear back.
21:54:09 <ttx> ack
21:54:14 <gabrielhurley> the other which may slip is https://blueprints.launchpad.net/horizon/+spec/improved-boot-from-volume
21:54:30 <gabrielhurley> there are a couple people working on competing implementations and I'm not sure they're gonna come together in time
21:54:47 <ttx> You moved realtime-spec out ?
21:54:51 <gabrielhurley> The notable thing I bumped out today was the realtime stuff
21:54:52 <gabrielhurley> lol
21:54:53 <gabrielhurley> yes
21:54:58 <ttx> haha
21:55:00 <gabrielhurley> I would rather land it in I1 than H3
21:55:08 <gabrielhurley> it's gonna be one of those "lots of kinks to work out" features
21:55:12 <ttx> soon we'll operate like a hive
21:55:16 <gabrielhurley> haha
21:55:27 <ttx> gabrielhurley: anything you wanted to mention ?
21:55:31 * gabrielhurley envisions ttx as the queen of the OpenStack hive
21:55:41 <gabrielhurley> uh, no
21:55:43 <gabrielhurley> nothing else
21:55:44 <gabrielhurley> lol
21:55:45 <ttx> fat and lying at the bottom
21:55:56 <ttx> Questions on Horizon ?
21:56:06 <vasiliy> hi gabrielhurley. I have update about https://blueprints.launchpad.net/horizon/+spec/improved-boot-from-volume
21:56:19 <ttx> vasiliy: tell us
21:56:29 <gabrielhurley> vasiliy: awesome, the horizon meeting is in 5 minutes, tell me then
21:56:34 <vasiliy> today was publishe first patch https://review.openstack.org/#/c/41728/
21:56:36 <gabrielhurley> or now, if ttx has time
21:56:43 <vasiliy> It's in-progress now, but we've already started working on testing the patch and preparation of unit-tests.
21:56:44 <ttx> I have one minute
21:56:46 <vasiliy> The main goal of patch is to reflect new functionality "clone image" in Nova.
21:56:48 <gabrielhurley> awesome
21:56:53 <gabrielhurley> yep
21:57:05 <ttx> vasiliy: thx
21:57:09 <ttx> #topic Incubated projects
21:57:14 <ttx> devananda, hub_cap: howdy
21:57:18 <vasiliy> ttx - you are welcome
21:57:22 <ttx> Any question ?
21:57:23 <hub_cap> howdy howdy
21:57:36 <ttx> Any update ?
21:57:49 <hub_cap> chugging away at heat integration starting um, yesterday :)
21:57:58 <hub_cap> ptl is short for code at night i think
21:58:09 <vasiliy> gabrielhurley - the blueprint was assigned to Sam, but he hasn't spare time now - therefore we desided to help him - because worked on related blueprints on Nova
21:58:23 <hub_cap> should be in by end of month tho
21:58:49 <hub_cap> and then we talk incubation status :)
21:58:54 <hub_cap> other than that things r goin well.
21:59:08 <ttx> hub_cap: code at night, yes
21:59:27 <ttx> Anything else to mention in the last minute, anyone ?
21:59:34 <hub_cap> <3
22:00:04 <ttx> #endmeeting