21:01:25 <ttx> #startmeeting project
21:01:26 <openstack> Meeting started Tue Sep 24 21:01:25 2013 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:30 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:31 <openstack> The meeting name has been set to 'project'
21:01:37 <russellb> o/
21:01:41 <ttx> #topic General stuff
21:01:54 <ttx> No project has published an RC1 yet (excet Trove but that doesn't count)
21:01:58 <ttx> except*
21:02:01 <russellb> poor trove
21:02:12 <ttx> Remember that all projects can come up with their RC1 at different times, whenever they empty their release-critical bug lists
21:02:21 <ttx> (and they want to open the Icehouse gates)
21:02:46 <ttx> Ideally all projects would publish before the end of the month (in one week), giving ample time for additional testing and potential RC respins
21:03:04 <adam_g> Heya! The stable-maint team have 2013.1.4 releasing Oct 10th and will be freezing stable/grizzly branches next week in preparation. Please tag any bugs for backport and help us test! We had some regressions slip through for 2013.1.3 and would be great to catch those with testing pre-release if possible
21:03:39 <ttx> adam_g: heh, you'll have competition on the testing front :)
21:03:42 <lifeless> I have a question for TripleO; we're merging the Tuskar effort into TripleO; have the process docs for incubation and integration been updated to handle new services from existing Programs?
21:04:11 <ttx> lifeless: they shouldn't be... resistant to any change
21:04:29 <ttx> lifeless: though I wouldn't bet there isn't some hidden wiki page still using old cosmology
21:05:00 <lifeless> ttx: We'll report bugs as we find them then? Would like to have tuskar-api as a stable integrated thing in I
21:05:08 <ttx> lifeless: updating the list of projects on your program landing page should do the trick
21:05:19 <ttx> sdague, annegentle, mordred: news from the fantastic QA/Docs/Infra programs ?
21:05:38 <mordred> ttx: well, we had a gate break this morning, but it's fixed now
21:05:40 <sdague> well, after morning firedrill we have a working gate again
21:06:19 <ttx> mordred, sdague: any way we can prevent this from happening again ? From what I saw it could just happen any time
21:06:37 <sdague> I think the other notable thing to keep an eye on is the elasticrecheck work that jog0 and mtreinish have been doing, which should make finding recheck bugs a lot easier
21:06:38 <ttx> with random libs bumping their requirements
21:06:54 <mordred> ttx: there is a corner case that got triggered, normally that should be handled
21:07:04 <mordred> ttx: but we are looking at ways to make it more robust
21:07:04 <ttx> mordred: ok
21:07:10 <sdague> ttx: so... we've got this theory of chasing some of our dep libs in the infrastructure to give us early warnings on that
21:07:12 <mordred> also....
21:07:28 <sdague> I expect we'll talk about it in HK, and get pieces going in icehouse
21:07:36 <mordred> we may need to address stable branches and requirements in more depth
21:07:39 <mordred> but yeah, hk
21:07:50 <jeblair> ttx: in general, anyone should be able to fix cases where external deps break us
21:08:17 <jeblair> cases where infra intervention is required to fix that are bugs (and i believe mordred is fixing or has proposed fixes for those)
21:08:30 <ttx> jeblair: +1
21:08:49 <ttx> anything else on the "general stuff" ?
21:09:03 <ttx> OK, let's go into project-specific details now
21:09:16 <ttx> #topic Oslo status
21:09:23 <ttx> markmc: bonsoir
21:09:27 <ttx> #link https://launchpad.net/oslo/+milestone/havana-rc1
21:09:28 <markmc> howdy
21:09:30 <annegentle> nothing from me
21:09:35 <markmc> I'm behind on triaging
21:09:39 * markmc holds his hands up :)
21:09:40 <ttx> annegentle: cool ;)
21:09:52 <lifeless> ttx: 'program specific details' :P
21:10:21 * lifeless may be wrong
21:10:22 <ttx> lifeless: program/project.
21:10:53 <markmc> I had a quick look through untriaged bugs
21:10:55 <ttx> markmc: so you expect more than those 2 targeted bugs between you and stable/havana for oslo-incubator ?
21:11:06 <markmc> specifically looking for oslo.config issues before tagging 1.2.0 earlier
21:11:18 <markmc> this one is about the only one that looked like a potential release blocker:
21:11:19 <markmc> https://bugs.launchpad.net/oslo/+bug/1229475
21:11:21 <uvirtbot> Launchpad bug 1229475 in python-neutronclient "From oslo rpc: RuntimeError: Second simultaneous read on fileno 16 detected" [Undecided,New]
21:11:25 <markmc> but I haven't looked too carefully
21:11:34 <markmc> jog0, any thoughts on that ? ^
21:11:42 <markmc> will triage it and the rest properly tomorrow
21:11:55 * markmc sticks #1229475 on the rc1 milestone so he doesn't forget it
21:12:00 <ttx> markmc: you should be all set by the end of the week ? (to branch oslo-incubator, at least)
21:12:21 <markmc> ttx, unless something else crops up
21:12:37 <ttx> markmc: ok, I'll be in touch
21:12:39 <ttx> Questions about Oslo ?
21:12:42 <markmc> I'm ready to branch oslo.config now
21:13:42 <ttx> markmc: do you actually have stable branches for oslo.* ?
21:14:00 * ttx is suddenly uncertain
21:14:02 <markmc> ttx, I had a stable/grizzly for oslo.config 1.1.x
21:14:05 <markmc> ttx, and needed it
21:14:12 <ttx> markmc: ok then :)
21:14:24 <markmc> ttx, :)
21:14:29 <ttx> markmc: just ping me if/when you need me
21:14:38 <ttx> #topic Keystone status
21:14:41 <dolphm> o/
21:14:46 <ttx> dolphm: hi!
21:14:51 <ttx> #link https://launchpad.net/keystone/+milestone/havana-rc1
21:15:09 <ttx> 3 targeted bugs... does that represent all your known RC issues ?
21:15:14 <dolphm> yes sir!
21:15:20 <ttx> Looks like we should be able to cut a RC1 for you later this week ?
21:15:32 <dolphm> that is my goal
21:15:48 <ttx> that would be great
21:16:20 <dolphm> bug 1221889 has proven to be a fairly complex process to fix
21:16:20 <ttx> keep an eye on incoming reports to make sure nothing critical creeped in
21:16:21 <uvirtbot> Launchpad bug 1221889 in keystone "Invalid X-Subject-Token results in HTTP 401 rather than 404" [High,In progress] https://launchpad.net/bugs/1221889
21:16:33 <dolphm> it's the only one i'm concerned about at this point, and it *could* be dropped from RC list if necessary
21:16:37 <dolphm> it's just a very strong nice to have
21:16:43 <dolphm> otherwise, will do!
21:16:50 <ttx> Other news / questions about Keystone ?
21:16:56 <dolphm> that is all
21:17:15 <ttx> #topic Ceilometer status
21:17:20 <ttx> jd__: hey
21:17:27 <ttx> #link https://launchpad.net/ceilometer/+milestone/havana-rc1
21:17:40 <jd__> bonsoir
21:17:56 <ttx> 8 targeted bugs
21:18:01 <ttx> At your current speed you should have them fixed before the end of the week. RC1 then ?
21:18:10 <jd__> fine with me
21:18:22 <jd__> finger crossed nothing new's coming in
21:18:38 <ttx> jd__: trust me, something will come in :)
21:18:56 <jd__> na problem, we're ready.
21:18:59 <ttx> I'll keep an eye on your last bugs and ping you when RC1 looks ready
21:19:01 <ttx> Other news / questions about Ceilometer ?
21:19:23 <jd__> all good :)
21:19:31 <ttx> #topic Swift status
21:19:36 <ttx> notmyname: o/
21:19:36 <notmyname> hello
21:19:43 <ttx> #link https://launchpad.net/swift/+milestone/1.9.3-rc1
21:19:51 <ttx> (I renamed it to -rc1 because that's the version we actually want to tag at this point)
21:20:03 <ttx> I see two features open on the roadmap: multiple-domains-in-domain-remap and diskfile-databasebroker-as-apis
21:20:11 <ttx> Are those the two ones you'd like to see completed before we issue the -rc1 ?
21:20:15 <notmyname> we'll probably 1.10.0, but that's easy whenever it needs to happen
21:20:29 <ttx> sure
21:20:35 <notmyname> the bug on there is a big deal. working on it now
21:20:48 <ttx> bug 1174660
21:20:50 <uvirtbot> Launchpad bug 1174660 in swift/havana "when client disconnected, garbage collecting is too heavy" [Critical,In progress] https://launchpad.net/bugs/1174660
21:20:52 <notmyname> https://wiki.openstack.org/wiki/Swift/PriorityReviews is the set of patches we are looking at
21:21:15 <ttx> notmyname: ok
21:21:30 <ttx> What's your educated guess for a RC1 ETA with all this ?
21:21:58 <notmyname> Early next week, but we'll reevaluate at the end of this week
21:22:05 <ttx> notmyname: Note, since we're doing a RC dance on this release, we can tag the RC1 before internal QA runs, and just open a RC2 window if those QA runs find critical issues.
21:22:11 <notmyname> right
21:22:27 <ttx> notmyname: in unrelated news, if you want to run for Swift PTL you should probably post your candidacy soon.
21:22:43 <notmyname> as soon as all the IRC meetings are done, I will ;-)
21:22:46 <ttx> Other news / questions about Swift ?
21:23:08 <notmyname> swift hackathon/sprint coming up in a few weeks
21:23:28 <notmyname> oracle announces some swift support with their new stuff today ;-)
21:23:29 <ttx> with texan bbq built in, I heard ?
21:23:34 <notmyname> yup :-)
21:23:43 <ttx> (the hackaton, not oracle)
21:23:45 <notmyname> heh
21:23:54 <notmyname> lot's of fat, either way, I'm sure
21:24:15 <notmyname> /done
21:24:18 <ttx> #topic Glance status
21:24:19 <markwash> yay, me!
21:24:24 <ttx> markwash: yay you
21:24:28 <ttx> #link https://launchpad.net/glance/+milestone/havana-rc1
21:24:32 <markwash> lol
21:24:40 <ttx> 5 targeted bugs at this point...
21:25:01 <markwash> 1 critical
21:25:08 <markwash> 2 highs
21:25:12 <ttx> With your current veolcity you should hit the bottom of that list early next week too
21:25:23 <ttx> if you don't add too many new ones
21:25:29 <markwash> I'd like to aim for end of this week for rc1
21:25:41 <ttx> markwash: I encourage you to!
21:25:48 <markwash> I think we can do it
21:26:02 <ttx> and you like challenges
21:26:23 <ttx> Other news / questions about Glance ?
21:26:41 <markwash> None from me
21:27:22 <ttx> now for more.. interesting projects
21:27:24 <ttx> #topic Neutron status
21:27:25 <markwash> :-(
21:27:42 <markmcclain> hi
21:27:45 <ttx> markwash: you don't really want to be that kind of "interesting", trust me
21:27:52 <markwash> ah, fair point
21:27:53 <ttx> markmcclain: hi!
21:27:57 <ttx> #link https://launchpad.net/neutron/+milestone/havana-rc1
21:28:29 <ttx> markmcclain: did you just bump a bp out ?
21:28:41 <ttx> ipv6-feature-parity ?
21:28:42 <markmcclain> yes
21:29:00 <markmcclain> concerned about stability this late
21:29:07 <ttx> So configurable-ip-allocation is the last standing FFe we have
21:29:09 <markmcclain> would rather let it bake longer
21:29:27 <ttx> markmcclain: I'm all for getting rid of it if it's not 99.9% safe now
21:29:53 <ttx> configurable-ip-allocation has been around forever... any reason why it might suddenly land ?
21:30:25 <markmcclain> it's likely to suffer the same fate
21:30:32 <ttx> (can't find code under review yet :/)
21:30:50 <ttx> when is your cut date for a decision on this ?
21:31:04 <markmcclain> eod
21:31:23 <ttx> markmcclain: ok, keep me posted on your decision
21:31:46 <markmcclain> will do
21:31:52 <ttx> In the mean time, on the bugs side, 34 targeted bugs
21:32:02 <ttx> which is a lot, but then your bugfix velocity is not too bad
21:32:25 <ttx> I'm just concerned that the curves still go up at http://old-wiki.openstack.org/rc/
21:32:29 <ttx> which means you add more than you fix
21:32:37 <ttx> with all that I still fear you might miss the end-of-month target though...
21:32:43 <markmcclain> I share the same concern
21:32:55 <ttx> How about separating between must-have bugfixes (targeted to rc1) and nice-to-have bugfixes (tagged havana-rc-potential) ?
21:33:24 <markmcclain> that's the plan
21:33:28 <ttx> ok
21:33:49 <ttx> Other news / questions about Neutron ?
21:33:56 <markmcclain> nothing else from me
21:34:21 <ttx> will keep on nagging you this week :)
21:34:25 <ttx> #topic Cinder status
21:34:32 <ttx> jgriffith: hola!
21:34:36 <ttx> #link https://launchpad.net/cinder/+milestone/havana-rc1
21:34:45 <jgriffith> hey
21:34:47 <ttx> 4 targeted bugs... does that represent all your known RC issues ?
21:35:00 <jgriffith> yes, all the ones I'm willing to tackle/risk for RC
21:35:11 <ttx> ok... looks like you should be all set in a couple of days. RC1 then ?
21:35:23 <jgriffith> Shooting for tmorrow afternoon, thurs morning
21:35:31 <ttx> jgriffith: sounds good
21:35:34 <jgriffith> unless something unexpected appears
21:35:45 <ttx> always a possibility/certainty
21:35:48 <ttx> Other news / questions about Cinder ?
21:35:50 <jgriffith> backups will have to be broken for multi-backend
21:36:07 <ttx> jgriffith: could you elaborate on that ?
21:36:08 <jgriffith> nope, not rom me
21:36:24 <jgriffith> it turns out that backup service is already suffering from neglect a bit
21:36:36 <jgriffith> it was never tested/checked with multiple volume backends configured
21:36:46 <jgriffith> and it relies on a single one to one relationship
21:36:54 <ttx> jgriffith: sounds like something the release notes should mention
21:36:59 <jgriffith> for sure
21:37:04 <ttx> which makes me think I should probably bootstrap those
21:37:06 <jgriffith> unless my hack I'm trying out right now works
21:37:12 <jgriffith> :)
21:37:26 <ttx> #action ttx to bootstrap release notes doc
21:37:32 <jgriffith> but it reveals bigger issues in the backup code
21:37:41 <jgriffith> which may mean I
21:37:44 <jgriffith> anyway
21:37:53 <jgriffith> either way, I'll make the appropriate adjustment
21:38:03 <ttx> ok, thanks for raising the flag
21:38:10 <jgriffith> yup
21:38:32 <ttx> #topic Nova status
21:38:36 <ttx> russellb: hi!
21:38:40 <ttx> #link https://launchpad.net/nova/+milestone/havana-rc1
21:38:43 <russellb> hi!
21:38:55 <ttx> 23 targeted bugs, should be ok if you don't add too many new ones
21:39:03 <russellb> yeah, aggressively taking things off
21:39:06 <ttx> there are a few unassigned ones like bug 1227027
21:39:07 <uvirtbot> Launchpad bug 1227027 in ossa "Insecure directory permissions with snapshot code" [Undecided,Incomplete] https://launchpad.net/bugs/1227027
21:39:35 <russellb> good point
21:39:49 <ttx> We should target an RC1 early next week ?
21:40:02 <russellb> I think so
21:40:18 <russellb> just a couple High ones unassigned that are the biggest risk
21:40:27 <ttx> we'll do a new checkpoint analysis in a few days and see how it evolved
21:40:51 <ttx> Other news / questions about Nova ?
21:41:28 <ttx> #topic Heat status
21:41:33 <ttx> shardy: o/
21:41:34 <shardy> o/
21:41:37 <ttx> #link https://launchpad.net/heat/+milestone/havana-rc1
21:42:00 <ttx> 20 targeted bugs... confident you can hit RC1 before the end of month with so many blockers ?
21:42:01 <shardy> So many of the in progress bugs have patches up, some of which are just stuck behind the gate
21:42:17 <ttx> ok
21:42:35 <shardy> ttx: Yes, I think so, we're getting through the reviews, there's only two or three which I'm concerned about
21:42:47 <shardy> one worth mentioning is bug #1222830
21:42:49 <uvirtbot> Launchpad bug 1222830 in heat "Creation of OS::Ceilometer::Alarm fails" [Medium,In progress] https://launchpad.net/bugs/1222830
21:42:58 <shardy> That needs a requirements bump to ceilometerclient
21:43:05 <shardy> is it too late for that to happen?
21:43:28 <shardy> (in the global requirements, ref https://review.openstack.org/#/c/47994/)
21:43:48 <ttx> shardy: no, that would be fine in my book
21:44:07 <ttx> it's not as if you introduced a new, non-openstack-produced dep
21:44:19 <shardy> ttx: Ok, thanks
21:44:47 <ttx> shardy: just make sure you communicate that (why and what) to the ML to make sure everyone is aware of it
21:45:03 <ttx> that's making sure of making sure.
21:45:07 <ttx> It's late here.
21:45:15 <shardy> ttx: Ok will do
21:45:33 <ttx> Other news / questions about Heat ?
21:45:47 <shardy> not from me, thanks!
21:46:03 <ttx> #topic Horizon status
21:46:08 <ttx> gabrielhurley: o/
21:46:10 <gabrielhurley> \o
21:46:13 <ttx> #link https://launchpad.net/horizon/+milestone/havana-rc1
21:46:35 * ttx refreshes
21:46:46 <ttx> 27 targeted bugs
21:46:46 <gabrielhurley> RC1 had a long bug list (lots related to the two FFEs, and to translation fixes)
21:46:49 <gabrielhurley> our pace is good though
21:47:02 <gabrielhurley> I think about a week and we should be done
21:47:27 <ttx> velocity in last two weeks: 53 fixes
21:47:35 <gabrielhurley> so just about right
21:47:49 <ttx> so with your current velocity and not adding new bugs you should hit the target
21:47:56 <gabrielhurley> that's the idea
21:48:05 <gabrielhurley> there's only a couple of "high" priority bugs as it is
21:48:14 <ttx> Otherwise just split between true blockers (targeted to havana-rc1) and targets of opportunity (tagged "havana-rc-potential")
21:48:19 <gabrielhurley> if we're down to the wire and some lows don't get fixed... well, we can discuss that if it comes to that
21:48:29 <ttx> right
21:48:48 <ttx> we can revisit that towards the end of the week and see if we need to correct the course
21:48:49 <gabrielhurley> but if the goal is to cut the RC next week I think we'll get everything in
21:48:53 <gabrielhurley> indeed
21:49:14 <ttx> will all depend on the quantity of additions to the list
21:49:21 <gabrielhurley> true
21:49:53 <ttx> gabrielhurley: It's also better if targeted bugs have assignees :) Gives more confidence they might actually get completed in the next days.
21:50:08 <gabrielhurley> yep. will take care of divvying up the remainder in the Horizon meeting next
21:50:19 <ttx> they can always be reassigned if need be
21:50:23 <gabrielhurley> of course
21:50:24 <ttx> ok
21:50:31 <ttx> Other news / questions about Horizon ?
21:50:49 <gabrielhurley> translation efforts are going well. more translators, reviewers there are always helpful
21:51:04 <gabrielhurley> that's about it
21:51:21 <ttx> #topic Incubated projects
21:51:34 <hub_cap> woah almost 10 whole minutes this time!
21:51:38 <ttx> (that's for havana-cincubated projects)
21:51:40 <ttx> devananda, hub_cap: hello!
21:51:52 <devananda> ttx: hi!
21:52:01 <hub_cap> rc1 is cut for trove, havent yet sent out to ML, waiting on seeing someone else do it first so i can copy-pasta the email
21:52:08 <ttx> hub_cap: that's a good sign :)
21:52:23 <ttx> hub_cap: Any sign of a need for a RC2 ?
21:52:29 <ttx> no critical bug ?
21:52:30 <hub_cap> nope i dont think so
21:52:38 <hub_cap> we are focused on icehouse features right now
21:52:42 <hub_cap> no critical buggies
21:52:42 <devananda> ttx: i've moved BPs to icehouse. as before, no RC for ironic this time around.
21:52:54 <ttx> hub_cap: that's fine... just keep an eye on reported bugs
21:52:59 <hub_cap> aye
21:53:02 <ttx> devananda: as planned, wfm
21:53:15 <ttx> Any question ?
21:53:25 <hub_cap> nope, not here
21:54:10 <ttx> well then, let's close early
21:54:14 <hub_cap> woo!!
21:54:17 <hub_cap> hugs
21:54:27 <ttx> I somehow feel like the next release meetings will be more busy
21:54:38 <devananda> no ? here either :)
21:55:02 <ttx> awesome
21:55:05 <ttx> #endmeeting