21:04:13 <ttx> #startmeeting project
21:04:14 <openstack> Meeting started Tue Sep  9 21:04:13 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:04:18 <openstack> The meeting name has been set to 'project'
21:04:19 * devananda lurks
21:04:22 <ttx> crazy tuesdays
21:04:25 <jeblair> for once it's not infra's fault.  well, not directly.  ;)
21:04:31 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:04:51 <ttx> #topic News from the 1:1 sync points
21:04:54 <ttx> Here is the log:
21:04:59 <ttx> #link http://eavesdrop.openstack.org/meetings/ptl_sync/2014/ptl_sync.2014-09-09-11.46.html
21:05:19 <ttx> We missed Nova due to being in the air, we'll do it after this meeting, or tomorrow
21:05:27 <ttx> Syncs today were mostly about reviewing the existing FFEs
21:05:32 <ttx> I think we have final lists now, and almost all should be completed this week.
21:05:43 <ttx> dhellmann: you wanted to mention something iirc
21:05:48 <dhellmann> ah, yes, thanks
21:06:01 <ttx> "we're trying to have final library releases on 18 sept to give time for testing before the rest of the release candidates"
21:06:03 <dhellmann> oslo will be shooting for our final release candidates on 18 sept to give everyone time to run unit tests with them
21:06:09 <mikal> Back
21:06:19 <mestery> dhellmann: nice!
21:06:36 <dolphm> is that about the time we should be aiming for coinciding client releases then?
21:06:53 <ttx> it would be good to stop updating the clients soon, yes
21:07:14 <ttx> so that we don't create fun regressions at the last minutes
21:07:17 <eglynn> dolphm: good point, I was planning to cut a new ceilometerclient release roughly co-inciding with the juno final tag
21:07:37 <ttx> eglynn: how about doing it around the juno-rc1 tag ?
21:07:43 <sdague> so, I'm kind of concerned about dependent libraries getting reved at the end
21:07:46 <eglynn> ttx: that would work
21:07:49 <ttx> it's supposed to be finished then
21:08:01 <eglynn> ttx: fair point, will do
21:08:01 <ttx> sdague: rc1 would work, though ?
21:08:08 <sdague> the process theory is we're in dep freeze when we go into feature freeze
21:08:17 <mestery> Neutron will need a new client release once the L3 HA BP lands, so likely this weekend
21:08:24 <ttx> there is a standing exception for client and oslo until rc1
21:08:37 <ttx> sdague: https://wiki.openstack.org/wiki/DepFreeze
21:08:44 <sdague> ttx: I do realize that's how it's been
21:09:00 <ttx> I mean, the sooner the better, but definitely not after RC1
21:09:04 <sdague> but do realize that means we are now exempting ~30 deps from freeze
21:09:10 <dhellmann> sdague: all of the integration tests are running against master already, so the only issues we might have are in the unit testse
21:09:29 <sdague> dhellmann: or anything we don't hit in integration
21:09:51 <dhellmann> there's nothing I can do about untested code
21:09:54 <ttx> sdague: for oslo that would be frozen on Sep 18
21:10:05 <ttx> sdague: would you suggest we do the same date for clients ?
21:10:15 <sdague> ttx: honestly, the sooner the better
21:10:17 <dhellmann> we've locked down for feature freeze in oslo already, so we're just working on bugs at this point
21:10:41 <ttx> sdague: I agree -- not sure the projects can align though.
21:10:47 <ttx> everyone else: what do you think ?
21:10:49 <sdague> I think we need to rethink the dep exception for kilo, it adds a lot of variability into the process
21:11:01 <dolphm> clients don't get a lot of love until the server goes into feature freeze anyway
21:11:10 <ttx> could final client releases be tagged by Sep 18?
21:11:27 <eglynn> ttx: yes, that's reasonable
21:11:30 <ttx> (unless shit happens that warrants a rev, of course)
21:11:33 <dolphm> that's realistic for keystone
21:11:57 <ttx> sdague: would you mind posting a thread to the -ML proposig that we do all final revs of clients by Sep 18 ?
21:12:05 <sdague> ttx: sure
21:12:08 <ttx> (to align with Oslo)
21:12:41 <ttx> sdague: cool thx
21:13:07 <ttx> #action sdague to post to ML to propose that we do all final revs of clients by Sep 18 (same as olso)
21:13:16 <ttx> #topic Other program news
21:13:20 <ttx> Any other program with a quick announcement ?
21:14:06 <ttx> #topic Open discussion
21:14:12 <ttx> Anything else, anyone ?
21:14:32 <dhellmann> it would be useful to have some other PTLs chime in on the "priorities" thread for kilo
21:14:51 * dhellmann looks for the correct subject line
21:15:00 <ttx> I visited the Design Summit space in Paris and will start working with the event organizer on layouts, which will result in pods/meetup space availability, and then to slot layout
21:15:08 <dhellmann> http://lists.openstack.org/pipermail/openstack-dev/2014-September/044766.html
21:15:12 <ttx> dhellmann: on my TODO list for tomorrow
21:15:24 <mestery> dhellmann: Same here, it's on the list
21:15:42 <SlickNik> dhellman_: Yes, same here - planning to send out an update before tomorrow.
21:16:03 <ttx> I'll also post about officially skipping the "suggestions website" and encouraging people to join the planning etherpads and team meetings
21:16:20 <ttx> #action ttx to propose skipping the "suggestions" and go directly to discussion
21:16:37 <dhellmann> ttx, mestery, SlickNik: good, thanks
21:16:38 <eglynn> is that ML thread the official decision-making process for kilo priorities?
21:16:38 <ttx> #info context added: design summit session
21:16:51 <dhellmann> eglynn: no, but it's the official start of the discussion
21:17:01 <ttx> #action PTLs to participate to the Kilo priorities thread
21:17:07 <dhellmann> eglynn: the tc asked jogo to start the thread on the -dev list
21:17:16 <dolphm> ttx: ++
21:17:27 <ttx> eglynn: it will help decide for cross-project sessions content
21:18:01 <jeblair> ttx: ooh, can we have someplace dry for our pod? :)
21:18:03 <notmyname> /here
21:18:15 <dhellmann> jeblair: don't get greedy
21:18:37 * jeblair buys a wetsuit
21:19:09 <ttx> jeblair: you won't aget a pod
21:19:32 <dhellmann> oh, snap
21:19:50 <ttx> jeblair: there will be a set of pods and a set of signs. len(signs)>len(pods)
21:20:32 <ttx> so wehn you're a group and need a pod, grab your sign and make a pod yours
21:20:48 <ttx> if someone else is already there, fight them in the tar pit
21:20:53 * jeblair throws the oslo sign into the fountain
21:21:08 <ttx> jeblair: ah, you already found the loophole I see
21:21:44 <mikal> The nova sign has to be bigger than everyone else's
21:21:48 <mikal> For reasons
21:21:49 <ttx> ok, anything else to discuss today ?
21:22:04 <ttx> mikal: actually nova doesn't need a pod, so doesn't have a sign.
21:22:11 <ttx> mikal: you have sessions running all the time.
21:22:31 <mikal> ttx: I'm not sure that's a great plan, but we can discuss
21:22:33 <ttx> your pod is just a 280-seat room.
21:22:34 * dhellmann glares at jeblair
21:22:41 <mikal> OMG, biggest pod ever
21:22:51 * jeblair hands dhellman a wetsuit
21:22:59 <dhellmann> heh
21:23:01 <ttx> although that may be the neutron pod.
21:23:25 <mestery> ha!
21:23:26 <ttx> more brainstorming coming this week once I have the maps
21:23:42 <ttx> anything else before we close ?
21:24:09 <ttx> guess not
21:24:12 <ttx> #endmeeting