11:48:21 <ttx> #startmeeting ptl_sync
11:48:22 <openstack> Meeting started Tue Jul 29 11:48:21 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:48:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
11:48:25 <openstack> The meeting name has been set to 'ptl_sync'
11:48:27 <ttx> #topic Ceilometer
11:48:38 <ttx> eglynn: how did j2 go ?
11:48:45 <eglynn> cool, d'ya wanna a do a quick juno-2 retrospective first?
11:48:56 <eglynn> well, gating for juno-2 was severly restricted by a couple of oslo-messaging bugs causing timeouts in the ceilo units
11:49:05 <eglynn> we didn't get the o-m 1.3.1 release until Friday
11:49:13 <eglynn> (and the test timeouts haven't occurred since)
11:49:19 <eglynn> \o/ :)
11:49:29 <eglynn> but in the end, only two j2 BPs needed last minute bumps to juno-3
11:49:41 <eglynn> dedicated-alarm-database was pretty much approved by Monday of last week
11:49:46 <ttx> OK, you managed to get 7 bps in
11:50:17 <eglynn> ... but the gating Gods decided not to smile upon the many rechecks of dedicated-alarm-database
11:50:25 <ttx> Looking at j3 now
11:50:29 <ttx> https://launchpad.net/ceilometer/+milestone/juno-3
11:50:51 <eglynn> yeah so that, that's been fleshed out a bit
11:50:52 <ttx> You have 8 blueprints targeted, which sounds pretty realistic, especially with one already completed
11:51:02 <ttx> do you expect a lot more to show up ?
11:51:15 <eglynn> yeah, the whole SAD freeze turned out to be unenforcable
11:51:26 <eglynn> (with vacations, relocations, job changes etc.)
11:51:28 <ttx> Remember you can now use "Blocked" if you want to show that a blueprint should be there but didn't have specs approved yet
11:51:38 <eglynn> a-ha, yeah
11:51:40 <eglynn> good call
11:51:50 <eglynn> so I've 3 more that I expect to land
11:51:52 <ttx> that should allow us to present a more precise roadmap
11:52:02 <eglynn> I'll add blocked entries in LP for those
11:52:03 <ttx> eglynn: ok, you can add them to the mix as Blocked
11:52:06 <ttx> cool
11:52:10 <eglynn> will do
11:52:43 <ttx> otherwise what can I say... merge as early as possible, I expect a busy end of August
11:53:01 <eglynn> yeap, I'm really banging the drum on feature proposal freeze
11:53:20 <ttx> you plan to enforce FPF at the common date ?
11:53:21 <eglynn> ... despite being the worst offender myself in previous cycles for last minute patches ;)
11:53:33 <ttx> august 21 iirc
11:53:33 <eglynn> that's the message I've been putting out, yes
11:53:48 <ttx> ok great
11:53:56 <ttx> eglynn: anything to add to meeting agenda for today?
11:54:26 <eglynn> I was gonna to raise the per-project functional test suite move
11:54:42 <eglynn> however after discussing with matt, turnout he'll be travelling
11:54:53 <eglynn> so I think it best to punt that to next week's agenda
11:54:53 <ttx> yeah, and sdague is at the Nova sprint
11:55:02 <ttx> ok
11:55:04 <eglynn> cool, that settles it so, next week it is
11:55:21 <eglynn> that's it from me
11:55:22 <ttx> eglynn: ok, that's all I had
11:55:24 <ttx> thx!
11:55:29 <eglynn> cool, thanks for your time!
11:55:30 * ttx finishes rant
11:55:38 <eglynn> LOL :)
12:04:08 <SergeyLukjanov> ttx, hey!
12:04:30 <SergeyLukjanov> ttx, are you ok to talk re sahara?
12:04:48 <ttx> SergeyLukjanov: yep, rant finished
12:04:58 <ttx> #topic Sahara
12:05:08 <SergeyLukjanov> #link https://launchpad.net/sahara/+milestone/juno-3
12:05:09 <ttx> SergeyLukjanov: how did j2 go for you?
12:05:27 <SergeyLukjanov> j2 was fully completed
12:05:46 <SergeyLukjanov> and we have good news - sahara-dashboard was merged to horizon
12:05:59 <SergeyLukjanov> only some small fixes/features backports on review
12:06:23 <SergeyLukjanov> so, we're going to close sahara-dashboard repo soon
12:06:58 <ttx> SergeyLukjanov: this was completed by j2 ?
12:07:01 <ttx> cool
12:07:09 <SergeyLukjanov> ttx, several days after jw
12:07:13 <SergeyLukjanov> j2*
12:07:22 <ttx> ok
12:07:40 <ttx> so... j3
12:07:49 <ttx> https://blueprints.launchpad.net/sahara/+spec/edp-move-examples needs an assignee
12:08:34 <ttx> You have 11 blueprints targeted, compared to 8 implemented in j3, sounds reasonable
12:08:34 <SergeyLukjanov> ttx, yup, I'm looking for volunteers for it now
12:08:44 <ttx> do you expect a lot more to creep in ?
12:09:16 <ttx> #info looking for a volunteer to implement edp-move-examples
12:09:24 <SergeyLukjanov> ttx, I think one bp re adding Apache Storm plugin will be added to j3
12:09:29 <ttx> #info  sahara-dashboard was merged to horizon
12:09:47 <ttx> SergeyLukjanov: is it blocked waiting for spec final approval ?
12:10:00 <SergeyLukjanov> ttx, oh, I'm wrong, it's already in j3 :)
12:10:31 <ttx> ok, so the landscape here should be pretty complete ?
12:10:38 <SergeyLukjanov> ttx, I forget that I've approved spec and targeted it to the j3 a week ago
12:10:43 <SergeyLukjanov> ttx, I hope so
12:11:01 <SergeyLukjanov> ttx, I'm not expecting any more huge stuff for j3
12:11:02 <ttx> #info J3 plan supposed to be complete
12:11:28 <ttx> SergeyLukjanov: do you plan to enforce Feature Proposal Freeze ?
12:11:40 <ttx> Aug 21, feature code needs to be proposed by then
12:12:05 <SergeyLukjanov> ttx, I think it
12:12:24 <SergeyLukjanov> ttx, I think it's not very important for sahara atm
12:12:29 <ttx> SergeyLukjanov: OK cool. Anything to add to agenda for meeting today?
12:12:46 <SergeyLukjanov> ttx, nope, nothing from my side for meeting this time
12:12:58 <ttx> SergeyLukjanov: ok thx
12:13:09 <SergeyLukjanov> ttx, thank you!
12:13:56 <ttx> dhellmann: ready when you are
12:14:34 <SergeyLukjanov> ttx, just added one more bp to the j3 that was approved in specs
12:14:48 <dhellmann> ttx: the toaster just went off, give me a sec to collect breakfast, brb
12:14:52 <ttx> ok that makes 12
12:15:05 <ttx> dhellmann: ping me when ready, no hurry
12:18:50 <dhellmann> ttx: ready
12:19:31 <ttx> argh phone call
12:19:40 * dhellmann finishes his breakfast
12:20:57 <ttx> phone call ended
12:21:00 <ttx> #topic Oslo
12:21:07 <ttx> dhellmann: let me know when you're back
12:21:10 <dhellmann> here
12:21:31 <russellb> ttx: thanks for fixing the bugs :)
12:21:32 <ttx> dhellmann: so.. juno-2 was a bit bumpy with new libs
12:21:58 <ttx> dhellmann: we'll have to adjust the tools so that they workaround more of LP weirdness
12:22:12 <ttx> dhellmann: unless you think we should go for one tracker per lib
12:22:26 <dhellmann> yeah, I wasn't too worried about it because I think it only affected oslo.db and I expected a release shortly after
12:22:36 <ttx> which will make this 1:1 a bit uinfun
12:22:37 <dhellmann> although I've asked them to wait until the API change for exceptions is ironed out
12:22:43 <dhellmann> yeah, I do *not* want that
12:23:13 <ttx> dhellmann: is your lib tagging sufficiently consistent that we could rely on that in our scripts ?
12:23:15 <dhellmann> I would almost rather manage the bps by hand
12:23:27 <dhellmann> I suspect not
12:23:30 <dhellmann> (the tagging)
12:23:49 <dhellmann> I could work more on that, though
12:24:04 <ttx> Not sure it would solve all issues tbh
12:24:08 <dhellmann> yeah
12:24:18 <ttx> oslo.messaging gets FixReleased at coimmon milestones as well
12:24:25 <dhellmann> I'd actually like to be able to use the tool to mark bugs as released when we do cut a library release between milestones
12:24:56 <ttx> dhellmann: you probably already can -- just need to have milestones there corresponding to versions rather than integrated openstack release milestones
12:25:04 <dhellmann> ah, ok
12:25:22 <ttx> The big problem here is that oslo.messaging for example still has juno-X milestones in
12:25:39 <ttx> so you don't "release" in LP when you release in pip
12:25:42 <dhellmann> yeah, and we don't know the alpha milestones for libraries in advance, since we just increment the value by one
12:26:19 <dhellmann> I would have to create a milestone, move all the tickets into it, then use the tool to mark them as released
12:26:19 <ttx> dhellmann: you can have a "next" milestone and rename it when you release, that's what we do with swift
12:26:23 <dhellmann> ah, ok
12:26:35 <ttx> next-juno
12:26:59 <ttx> but that would not solve the other libs
12:27:06 <dhellmann> we would need next-juno-db, next-juno-config, etc.
12:27:21 <ttx> well... it would be pretty ugly in the timeline
12:27:23 <dhellmann> yeah
12:27:35 <dhellmann> how's storyboard coming along? :-)
12:27:35 <ttx> also not make sense in milestone bug dropdown
12:27:48 <ttx> It's awesome, you should try it
12:27:56 <dhellmann> can't wait!
12:28:01 <ttx> although projectgroup is not ready yet
12:28:06 <ttx> which is what you want here
12:28:19 <ttx> dhellmann: what we COULD do though
12:28:20 <dhellmann> seriously, I'm OK with things being a little manual if it means energy goes into that instead of the "legacy" tool
12:28:47 <ttx> is to create oslo libs projects in LP AND move them all under an oslo parent project
12:29:01 <ttx> we don't use the openstack parent group that much anymore
12:29:04 <dhellmann> I didn't know we could have nested projects
12:29:11 <ttx> You can, it's just one level
12:29:23 <ttx> and the project group can't contain bugs/BPs
12:29:34 <ttx> and you need to beg LP admins to get one
12:29:51 <dhellmann> how much longer do you realistically think we'll be using lp?
12:30:01 <ttx> then you can still see bugs and blueprints at "projectgroup" level
12:30:08 <dhellmann> is it worth moving all of the bugs and blueprints around?
12:30:21 <ttx> So I think infra will migrate to SB for Kilo
12:30:36 <ttx> then we'll iron out a number of issues
12:30:45 <ttx> and during Kilo some adventurous projects will join
12:31:00 * dhellmann tries to decide if he's feeling adventurous
12:31:02 <ttx> ideally so that we can have a strong proposal to move all by L
12:31:43 <dhellmann> I think I might like to have oslo move early, rather than kludge something together for lp
12:31:50 <ttx> dhellmann: with more libs being created, it might be worth to implement the oslo projectgroup
12:31:57 <ttx> in LP
12:32:24 <dhellmann> can we convert the existing project, or would we make a new one and leave that one for the incubator?
12:33:09 <ttx> we would rename oslo oslo-incubator and ask for an oslo projectgroup
12:33:25 <dhellmann> ok, that makes sense
12:33:45 <ttx> dhellmann: yeah, I think it's realatively easy, and less weird thean trying to use tag to automate stuff
12:33:55 <dhellmann> yeah
12:34:15 <ttx> that said, we still need to convince that juno-X doesn't make sense for libs.. you would just have the same series (juno) not the same milestones as the integrated release
12:34:18 <dhellmann> will spec2bp still work if the blueprints aren't in the oslo project?
12:34:32 <ttx> I know markmc was pretty attached to having juno-x milestones in oslo.messaging
12:34:49 <ttx> to share the common rhythm I think
12:35:01 <dhellmann> yeah, he wants us to act like an integrated project
12:35:19 <dhellmann> I'm torn on that. I want us to, but I also see some benefits to not.
12:35:47 <ttx> spec2bp... hmm... trick is all specs fall into solo-specs, so that was working with oslo-the-LP-project quite well
12:35:55 <dhellmann> yeah
12:36:07 <ttx> ok, let's think about it a bit more
12:36:12 <ttx> off-sync
12:36:14 <dhellmann> we might need an oslospec2bp that lets me specify the project name
12:36:19 <ttx> and look at j3 now
12:36:45 <ttx> yes, some option to force project name
12:36:52 <ttx> we'll need it for edge cases anyway
12:37:04 <dhellmann> we've had to find some new drivers for a couple of the graduations for j-3, but did have some people volunteer at the last meeting so I think we'll get those back on track
12:37:10 <dhellmann> true
12:37:10 <ttx> https://launchpad.net/oslo/+milestone/juno-3
12:37:41 <ttx> are the "unknown" there "not started", or really "unknown" ?
12:37:58 <dhellmann> I think those are mostly not started; I'll fix that
12:38:18 <dhellmann> we seem to be having more trouble than usual with bp statuses being updated (I thought that happened automatically?)
12:38:25 <ttx> So that makes 14 BPs, compared to 6 in j2
12:38:45 <ttx> I think that's doable if most of the ones under review are completed soon
12:38:53 <dhellmann> yeah
12:39:08 <ttx> Also I suspect the graduation ones are not that complex to complete
12:39:16 <dhellmann> I'm not sure the cross-project testing one is going to make it. I've had some people object to the idea, so I need to talk to jeblair again
12:39:30 <dhellmann> no, they're not hard, but time consuming because of all of the steps
12:39:46 <ttx> sometimes keeping two on the list prevents to complete any, while keeping one you can complete it
12:39:51 <dhellmann> I'm also not counting on anyone adopting those libraries this cycle, so we're going to push right through the rc period with that work
12:40:00 <ttx> oh, ok
12:40:15 <ttx> so you may graduate during the RC period, that sounds good
12:40:16 <dhellmann> I'd like to have the projects thinking about them for k-1
12:40:33 <ttx> https://launchpad.net/oslo.messaging/+milestone/juno-3
12:40:52 <dhellmann> the amqp driver is blocked on having the dependencies packaged for the distros
12:41:12 <dhellmann> gordon is working on that
12:41:14 <ttx> but otherwise it's reasy?
12:41:16 <ttx> +d
12:41:34 <dhellmann> well, I'm not sure "easy" but there is some code up for review
12:41:48 <ttx> no I meant ready
12:41:58 <ttx> ok
12:42:00 <dhellmann> ah
12:42:28 <ttx> so both roadmaps are complete, or you expect new specs to make it in j3 ?
12:43:07 <ttx> If yes, you can use "Blocked" to add them to the milestone plan until they are accepted
12:43:22 <dhellmann> ok
12:43:23 * ttx converts the existing Blocked onto a "Needs Infrastructure" for clarity
12:43:27 <dhellmann> I do have 2 new specs that were just proposed
12:43:30 <dhellmann> ah, cool, thanks
12:44:10 <dhellmann> there's also the one on switching mysql connection libraries, but that's a bigger cross-project concern still
12:44:12 <ttx> dhellmann: that page is always a best shot at approximating what we think will be in juno... so if you think it will make it, you can add it as Blocked
12:44:39 <dhellmann> ok, I'll go through and make sure it is up to date today
12:45:05 <ttx> ok that's all I had -- anything to add to meeting agenda for today?
12:45:29 <ttx> #action ttx to think a bit more how to solve the oslo/libraries/fixrelease/milestones conendrum
12:46:02 <dhellmann> I don't know if it's meeting worthy, but today is my last day at Dreamhost. I start with HP on Monday, and am taking the rest of the week off.
12:46:48 <ttx> Cool. But then the rumour already reached me
12:46:58 <dhellmann> I've already started using a new email address on the ML, so it's out there if people need to reach me directly.
12:46:59 <dhellmann> heh
12:47:16 <ttx> dhellmann: congrats, i suppose :)
12:47:22 <dhellmann> thanks :-)
12:47:30 <ttx> ttyl
12:47:37 <dhellmann> k
14:04:01 <ttx> dolphm: jgriffith doesn't seem to be around, you can go now if you're around
14:04:16 <dolphm> ttx: o/
14:04:18 <ttx> #topic Keystone
14:04:31 <ttx> dolphm: how did j2 go for you?
14:05:06 <dolphm> specs are still a slow process... which resulted in fewer blueprints and more bumped blueprints than i would have preferred
14:05:19 <ttx> https://launchpad.net/keystone/+milestone/juno-3
14:05:30 <ttx> 7 blueprints there, compared to 3 landed in j2
14:05:34 <dolphm> on the upside, we seem to have a broader understanding and agreement on the things we landed much earlier
14:06:05 <ttx> https://blueprints.launchpad.net/keystone/+spec/keystone-to-keystone-federation is marked "unknown" status -- does that mean not started, or really "unknown" ?
14:06:37 <dolphm> it should be just-barely-started
14:06:45 <ttx> ok will mark it started
14:06:55 <ttx> dolphm: do you expect more specs to appear on the j3 board ?
14:07:27 <dolphm> one in particular... i expect hierarchical-multitenancy to land, but it should end up in a feature branch, and not be merged with master until K
14:08:31 <ttx> dolphm: ok, that should be tracked in "next" milestone then
14:08:36 <ttx> future/next
14:08:41 <dolphm> okay
14:09:08 <ttx> dolphm: otherwise the plan is thought to be complete ?
14:09:18 <dolphm> openid-connect will be j3 soon
14:10:20 <dolphm> ttx: IIRC, spec2bp was going to have an option to target unmerged specs?
14:10:45 <dolphm> is that still in review, or am i crazy?
14:10:59 <ttx> still in review
14:11:09 <ttx> I'm a bit behind
14:11:14 <ttx> feedback welcome though
14:11:42 <ttx> https://review.openstack.org/#/c/108041/
14:12:06 <ttx> you can already use the "Blocked" status to show up specs that WILL get approved and make j3
14:12:09 <dolphm> let me try it now...
14:12:19 <ttx> that will make a more comprehensive view
14:12:32 <ttx> dolphm: do you plan to do a feature proposal freeze?
14:12:35 <ttx> Aug 21?
14:12:56 <dolphm> yes
14:13:44 <ttx> ok
14:13:54 <ttx> #info Keystone planning to enforce FPF
14:14:22 <ttx> dolphm: alrighty then, anything to add to meeting agenda for today?
14:14:32 <dolphm> looks like the script worked: https://blueprints.launchpad.net/keystone/+spec/openid-connect
14:14:42 <dolphm> not from me
14:16:05 <ttx> ok
14:16:21 <ttx> awesomesauce
14:16:25 <ttx> dolphm: thx!
14:16:29 <ttx> griff: around?
14:16:39 <griff> ttx: hi ya
14:16:40 <ttx> #topic Cinder
14:16:53 <ttx> Sorry for not having noticed your new nick around before
14:17:01 <griff> nahh... my fault
14:17:05 <griff> I should've said something
14:17:11 <ttx> how was j2 for you?
14:17:22 <griff> great, I left it up to Duncan and Russell :)
14:17:26 <griff> just kidding
14:17:39 <griff> Missed more BP's than I would've liked again
14:17:47 <griff> but got the ones I was most interested in landed
14:19:14 <ttx> 7 landed
14:19:19 <ttx> 13 in j3 plan
14:19:26 <ttx> Lots under review though
14:19:29 <griff> Yeah
14:19:34 <griff> most of those are carried over
14:19:35 <ttx> so if you get them merged fast that MAY work
14:19:43 <griff> I'm being pretty picky about new things at this point
14:19:56 <griff> yeah, my bigger concern is new things coming in
14:20:03 <ttx> https://blueprints.launchpad.net/cinder/+spec/cinder-storwize-driver-qos is "unknown" status -- is that really unknown, or just not started?
14:20:20 <griff> it's really unknown from my view
14:20:36 <griff> they submitted the bp but I've had no comittment or updates
14:20:37 <ttx> ok, great!
14:20:45 <ttx> just doublechecking:)
14:20:49 <griff> :)
14:21:14 <griff> I'll get updates on "unknowns" at tomorrows Cinder meeting
14:21:31 <ttx> griff: do you expect a lot more specs to creep in j3?
14:21:48 <griff> ttx: history says they'll try
14:21:59 <griff> ttx: but I made it clear that this time around I was going to be picky
14:22:06 <ttx> griff: but nothing expected from your side ?
14:22:34 <ttx> once you agree to consider one (and the spec is not approved yet) you can just add it to j3 as "blocked"
14:23:06 <ttx> so that it apperas on the plan
14:23:10 <griff> cool
14:23:12 <ttx> rather than flies below radar
14:23:23 <ttx> ok, that's all I had for you
14:23:32 <ttx> anything you'd like to discuss at meeting today?
14:24:00 <ttx> mikal_: want to quickly steal 10min now?
14:24:29 <griff> nothing for me thanks :)
14:24:36 <ttx> griff: ok then ttyl
14:31:47 <ttx> david-lyle: o/
14:33:14 <david-ly_> ttx: o/
14:33:28 <ttx> #topic Horizon
14:33:35 <ttx> david-lyle: how did j2 go?
14:34:08 <david-lyle_> got most of Sahara in, the rest went in right after j2 tag
14:34:22 <ttx> yep, heard the good news
14:34:23 <david-lyle_> I think 12 bps total merged
14:34:34 <ttx> https://launchpad.net/horizon/+milestone/juno-3
14:34:41 <ttx> So you have 72 blueprints there
14:34:42 <david-lyle_> with several more trickling in now
14:34:59 <david-lyle_> ttx: going to have a fire sale later today, everything must go
14:35:12 <ttx> including 27 that are already up for review
14:35:21 <david-lyle_> honestly haven't taken an attempt at cleaning that up yet
14:35:25 <ttx> if you only merged those that would already be quite a success
14:35:35 <david-lyle_> agreed
14:35:51 <ttx> ok, so maybe review it and try to come down to 30-40
14:36:10 <ttx> anythign above that would just create noise
14:36:14 <david-lyle_> any that have a status other than started or greater will get cut first
14:36:23 <ttx> ack
14:36:25 <david-lyle_> yes, too much review load
14:36:43 <ttx> you can also adopt an early feature proposal freeze
14:36:54 <ttx> so that you can easily reject stuff that's not under review yet
14:37:00 <ttx> the common one is on Aug 21
14:37:06 <david-lyle_> that's a good idea
14:37:23 <ttx> even with that I don't expect magic though :)
14:37:38 <david-lyle_> I think a couple of the need review are stale and may go
14:38:05 <ttx> 70 BPs in 5 weeks means 14/week
14:38:20 <david-lyle_> is that unreasonable?? ;)
14:38:40 <ttx> well, we'll see if we have 14 more implemented next week :)
14:39:03 <ttx> that's about half of those that are already "needs code review"
14:39:24 <ttx> :)
14:39:48 <ttx> david-lyle_: note that we'll have a gap analysis progress review at the TC today, you might consider joining us
14:39:53 <david-lyle_> more likely I expect 14 more random ones to show up
14:39:56 <ttx> since we'll look at Horizon gap plan
14:40:07 <ttx> if you can't come, don't hesitate to update the plan
14:40:18 <ttx> to reflect recent (j2) progress
14:41:01 <david-lyle_> ttx: ok, not much progress, there are 4 items
14:41:24 <david-lyle_> I'll likely attend
14:41:30 <ttx> david-lyle_: anything you wanted to add to the meeting agenda?
14:42:00 <david-lyle_> no, I may have to miss part of that meeting due to a conflict
14:42:13 <ttx> ack -- so far nothing is on the agenda anyway
14:42:17 <ttx> david-lyle_: ttyl
14:42:17 <david-lyle_> ok
14:42:22 <ttx> mestery: around?
14:42:25 <mestery> ttx: o/
14:42:27 <ttx> #topic Neutron
14:42:29 <david-lyle_> ttx: thanks
14:42:33 <ttx> mestery: how did j2 go?
14:42:48 <mestery> ttx: It went well, thanks to russellb's help.
14:42:58 <ttx> cool!
14:43:00 <mestery> ttx: We merged 11 BPs I think, not bad overall
14:43:20 <ttx> pales in comparison to your 84 BPs in j3 though
14:43:27 <mestery> It's a mountain for sure
14:43:48 <ttx> so that's about 17 to merge every week
14:43:57 <mestery> That's pretty high
14:44:16 <mestery> Realistically, if we land 25-30 I'll be happy.
14:44:20 <ttx> with only 23 being ready to review right now
14:44:37 <ttx> right, the trick is, how to predict which ones won't make it and only contribute noise
14:44:58 <mestery> I was going to start pulling things which are in Unknown soon
14:45:22 <ttx> mestery: you started to make use of the "Blocked" status, does that mean those have specs almost approved?
14:45:42 <mestery> ttx: Actually, that means that there is a -2 on the patches in most cases.
14:45:52 <ttx> ok
14:46:12 <ttx> you can use "slow progress" fo that case if you want to distinguish between the two
14:46:22 <mestery> ttx: Good idea! I think I'll move to using that.
14:46:36 <ttx> it's like, you want it in but it's not going in the right direction right now
14:46:52 <mestery> ack
14:46:59 <ttx> also lots of BPs have "unknown" status... is that just not started, or really "unknown" ?
14:47:13 <mestery> Those are really no started
14:47:16 <mestery> I'll move them to that state
14:47:22 <mestery> And those will be ones to prune in the coming weeks
14:47:23 <ttx> ok, cool
14:48:00 <ttx> mestery: we'll have post-j2 gap coverage plan progress review at the TC today
14:48:13 <ttx> you mighrt want to be present, or at least update your page
14:48:28 <mestery> Perfect!
14:48:34 <mestery> I think markmcclain and I will be ready for this
14:49:08 <ttx> mestery: also, just to confirm, you're planning to enforce Feature Proposal Freeze on Aug 21?
14:49:18 <mestery> ttx: Correct
14:49:19 <ttx> #info Neutron will have FPF on Aug 21
14:49:44 <ttx> OK, that's all I had -- anything you want to add to meeting agenda for later today?
14:49:55 <mestery> Nothing from me at this point, thanks ttx!
14:49:58 <ttx> mestery: cool. ttyl!
14:50:02 <mestery> ttx: later!
15:29:48 <notmyname> ttx: ready when you are
15:33:20 <ttx> notmyname: o/
15:33:24 <ttx> #topic Swift
15:33:31 <ttx> notmyname: what news?
15:33:40 <notmyname> ttx: last week we release a new swiftlcient
15:33:48 <notmyname> python-swiftclient 2.2.0
15:33:55 <notmyname> it has support for storage policies
15:33:59 <ttx> #info python-swiftclient 2.2.0 was released last week
15:34:00 <notmyname> and some other nice things
15:34:33 <notmyname> other than that, we're working on the EC stuff
15:35:24 <ttx> ok, still planning to try a release around the end of the month?
15:35:43 <notmyname> ttx: as in 2 days? or end of august?
15:35:48 <ttx> arh
15:35:55 * ttx is already in August for some reason
15:35:57 <notmyname> :-)
15:36:07 <notmyname> ok, end of august seems reasonable :-)
15:36:12 <ttx> heh, ok
15:36:41 <notmyname> when is the swift gap analysis TC meeting?
15:36:48 <ttx> planned next week
15:36:53 <ttx> as discussed
15:37:03 <notmyname> ok
15:37:15 <notmyname> just needed to make sure it was on my calendar :-)
15:37:25 <ttx> anything you want to discuss at cross-project meeting today?
15:38:00 <notmyname> nothing specifically. I'm interested-ly following the defcore and in-tree gate testing threads
15:38:38 <ttx> yes, looks like we are converging towards something more swifty
15:38:54 <ttx> (on the in-tree gate testing)
15:39:16 <ttx> defcore is another beast, but I think you got the discussion going on that
15:39:29 <notmyname> yes, it seems that way. but actually, I'm just really excited to see some changes that may result in a gate pass rate average above 80%
15:40:01 <ttx> notmyname: ack
15:40:11 <ttx> notmyname: that's all I had -- talk to you later?
15:40:21 <notmyname> ttx: have a good rest of your day :-)
16:04:18 <ttx> markwash: o/
16:04:35 <markwash> ttx: good morning / evening
16:05:00 <ttx> #topic Glance
16:05:07 <ttx> how was j2 for you?
16:05:28 <markwash> it rolled by pleasantly enough
16:05:32 <ttx> a bit un-featureful I see
16:05:33 <markwash> and then we had our mini summit
16:05:42 <ttx> https://launchpad.net/glance/+milestone/juno-3
16:05:54 <markwash> I think a few things will land in our specs that will increase the amount of j3 work
16:06:18 <ttx> markwash: feel free to submit them as blueprints with "Blocked" status on the j3 page
16:06:25 <ttx> that will allow us to track more precisely
16:06:46 <markwash> okay, I think the specs will be approved this week in any case
16:07:06 <ttx> I have a script to push the right statuses in LP
16:07:20 <ttx> under review @ https://review.openstack.org/#/c/108041/
16:07:30 <ttx> in case you want to play with it
16:07:42 <markwash> okay, cool
16:08:22 <ttx> Note that we'll do review gap coverage plan progress in the TC meeting today
16:08:43 <markwash> ah, thanks for the reminder
16:08:44 <ttx> if you can't be around, make sure the page is updated
16:09:15 <markwash> I'll be around
16:09:19 <markwash> but probably update the page anyway :-)
16:09:28 <ttx> markwash: that's all I had I guess
16:11:13 <markwash> cool, thanks!
16:11:43 <ttx> anytfhing you'd like to talk about at meeting today?
16:11:57 <markwash> not at this time
16:13:58 <ttx> ok, ttyl
16:14:06 <ttx> SlickNik: ready?
16:14:14 <SlickNik> ttx o/
16:14:17 <ttx> #topic Trove
16:14:25 <ttx> SlickNik: I take it j2 went well?
16:15:02 <SlickNik> Yes, it did. We got neutron support done and fully merged!
16:15:19 <SlickNik> That's one beast down. :)
16:15:32 <ttx> You have 3 times as many blueprint targeted to j3 though
16:15:39 <ttx> feeling lucky?
16:15:54 <SlickNik> Nope, I just need to clean it up. I was using it as a sort of catch all.
16:16:10 <ttx> ok, the sooner the better, otherwise the noise will create a distraction
16:16:32 <ttx> SlickNik: note that we'll be doing the post-j2 review of progress on your gap coverage plan today at the TC
16:16:33 <SlickNik> I was hoping that someone will pick up some of the lower pri ones, but since they're not started yet - I will need to move them out.
16:16:45 <ttx> you migth want to update that page, and/or join us
16:17:29 <SlickNik> ttx: I'm out on the road today, so I might not be able to join. I'll make sure that the wiki is up-to-date with the info. (I'll try my best to join as well).
16:17:38 <ttx> ok
16:17:53 <ttx> That's all I had. i suppose you won't be at the cross-project meeting then?
16:18:50 <ttx> SlickNik: ^
16:19:17 <SlickNik> ttx: Yes, I probably won't make that either. Have family visiting and will likely be driving from Portland to Seattle.
16:19:24 <ttx> ok
16:19:34 <ttx> well, talk to you later, then
16:19:59 <SlickNik> Thanks ttx! Talk to you later!
16:20:03 <ttx> mikal_: I suspect we are skipping our 1:1 for this week? Ping now before I close the day
18:41:13 <russellb> ttx: any juno-2 issues come up during your 1-1s today that i can help follow up on?
19:13:51 <ttx> russellb: nope, I think we are ok now
19:13:56 <russellb> k
21:06:14 <ttx> #endmeeting