08:03:06 <ttx> #startmeeting ptl_sync
08:03:07 <openstack> Meeting started Tue Aug 12 08:03:06 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:03:10 <openstack> The meeting name has been set to 'ptl_sync'
08:04:07 <mikal> Hi
08:04:10 <ttx> #topic Nova
08:04:25 <ttx> #link https://launchpad.net/nova/+milestone/juno-3
08:04:53 <ttx> Status looks coherent, there are 5 "unknown" states that could use clarification
08:05:03 <mikal> Yep
08:05:11 <mikal> And the usual "we could do more code review" comment applies
08:05:15 <ttx> As far as progress goes, last week we had 1 implemented, 29 in review
08:05:20 <ttx> This week:
08:05:24 <mikal> We're trying to identify things to review in the meetings, but its early days
08:05:38 <ttx> #info 2 Implemented, 33 under review, 27 in progress and 11 Not started/Unknown
08:06:27 <ttx> So I'd say you need to convert to "Implemented" faster, and yes, singling out "blueprints of the week" could allow faster iterations and more conversion
08:06:38 <mikal> Agreed
08:06:46 <mikal> So yeah, we're trying it but we could be more active
08:06:53 <mikal> I haven't had a lot of code review time in the last week
08:07:07 <mikal> As I find things which are important and under review I can ping cores and ask them to take a look
08:07:42 <ttx> We are 9 days away from FPF, so I expect a lot of those 38 in progress/notstarted to not make it
08:07:59 <mikal> Agreed
08:08:02 <mikal> We can bump them then though
08:08:07 <ttx> Maybe starting to aggressively defer stuff where assignees are fine to drop it to Kilo
08:08:25 <mikal> Ahhh, as in ping people and ask them if they're going to make it or not?
08:08:39 <ttx> Like Dan Berrange has 5, and only one in review
08:08:39 <mikal> Do you plan on sending a general FPF reminder to the mailing list?
08:08:44 <mikal> Or does each project do that?
08:09:06 <ttx> It's more project-specific, since some projects do not follow the FPF
08:09:13 <mikal> Ok, fair enough
08:09:15 <ttx> I'll send reminders for the feature freeze itself
08:09:22 <ttx> which is cross-project
08:09:35 <ttx> but FPF I think is only followed by 3 projects
08:09:54 <mikal> Ok, I will send an email
08:09:56 <ttx> jaypipes has 3 blueprints to, none under review yet
08:09:59 <ttx> too*
08:10:14 <ttx> In those cases they could already pick one to drop
08:10:22 <mikal> Agreed
08:11:16 <ttx> so my advice would be to review the top, which ones are 99% there and just need a bit more attention to pass
08:11:31 <ttx> and the bottom, which ones are very unlikely to make it and should be proactively dropped
08:11:35 <mikal> As in those in "needs code review"
08:11:37 <ttx> that way you reduce the slate
08:12:13 <ttx> otherwise the sheer number of targets make it very difficult to make any kind of significant progress
08:12:46 <ttx> Quick look at the High/Essential prio stuff
08:12:56 <ttx> There are 6 High
08:13:07 <ttx> 4 already under code review
08:13:22 <mikal> The top two are ongoing efforts
08:13:30 <mikal> They're unlikely to be complete in Juno
08:13:46 <mikal> Which you could argue means they're mistargetted
08:13:48 <ttx> ok, it's like never actually "complete", just merge as much as you can ?
08:13:53 <mikal> But we also really want to land the code
08:13:57 <mikal> Yep
08:14:01 <ttx> ok, that's fine
08:14:02 <mikal> Well, they'll be compelte one day
08:14:06 <mikal> Just not instantly
08:14:15 <mikal> So high actually looks ok to me on that basis
08:14:25 <ttx> I would prioritize up the stuff that affects other projects
08:14:36 <ttx> i.e. ironic and cinder clientv2
08:14:38 <mikal> Like the ironic thing?
08:14:55 <mikal> Yep, ironic is already getting pretty good attention -- its currenlty waiting for review comments to be addressed
08:15:01 <ttx> ok
08:15:09 <mikal> Cinder I'd have to check
08:15:12 <ttx> I think that's all I had
08:15:21 <ttx> not sure how dependent Cinder is on that feature though
08:15:30 <ttx> i suspect you could keep using v1
08:15:42 <mikal> Yeah, I think they want to remove v1 IIRC
08:15:47 <ttx> Anything you'd like to discuss at cross-project meeting today?
08:15:53 <mikal> Just looking at it, the code might have been abandoned?
08:16:12 <mikal> So, we're starting to get requests for kilo specs to open
08:16:18 <mikal> I'd be interested in how other projects are handling that
08:16:30 <mikal> I personally feel its a distraction from Juno, but I think I am going to lose that argument
08:16:39 <ttx> hmm, ok. mestery had a thread about that on the ML a few weeks ago
08:16:49 <mikal> The counter argument being that the people wanting to write those specs aren't interested in fixing Juno bugs anyways
08:17:00 <mikal> Hmmm, I shall go looking for that. I missed it.
08:17:00 <ttx> People should know they can ignore nova-specs in review for now
08:17:10 <mikal> Oh, I think the reviewers do
08:17:12 <ttx> so posting changes there doesn't hurt THAT much
08:17:19 <mikal> Its more we haven't given any way for someone to propose a kilo spec
08:17:28 <ttx> but yeah, just the fact that people ask is a bit worrying
08:17:42 <mikal> Its people who have a feature to add and then want to run away
08:17:54 <mikal> You know the type
08:18:40 <ttx> I can add a topic for the meeting today about "When to open Kilo specs"
08:18:54 <mikal> That would be good
08:18:54 <mikal> Thanks
08:19:06 <ttx> ok done
08:19:17 <ttx> mikal: all set?
08:19:24 <mikal> Yep, done
11:44:41 <eglynn> ttx: knock, knock, ready when you are ...
11:45:15 <ttx> eglynn: o/
11:45:19 <ttx> #topic Ceilometer
11:45:56 <eglynn> #link https://launchpad.net/ceilometer/+milestone/juno-3
11:46:16 <eglynn> so I think that's our full slate of BPs for juno-3
11:46:30 <ttx> #info 2 implemented, 4 under review, 6 in progress
11:46:43 <eglynn> good progress on most things with priority > Low
11:47:01 <eglynn> with the exception of the gnocchi dispatcher, but that slightly decoupled in any case
11:47:12 <eglynn> i.e. forward-looking to kilo
11:47:47 <eglynn> so I'm not overly-concerned but will keep a close eye on it
11:47:52 <ttx> still a long way to go
11:48:34 <eglynn> yeap, so I've an additional resource (cdent) to help out with two of the higher priority BPs
11:48:41 <ttx> ok, cool
11:48:42 <eglynn> (in addition to the main authors)
11:48:49 <eglynn> so that should expedite progress
11:49:13 <ttx> You don't plan to enfore a feature proposal freeze anyway, so for all of those you have 3 weeks left
11:49:34 <eglynn> (that's cdetn helping out on central-agent-partitioning & bigger-data-sql specifically)
11:50:04 <eglynn> yes, I'm planning to push the feature proposal freeze idea as hard as possible
11:50:15 <ttx> OK, if there is little progress by next week we may want to cut down a number of things that will obviously not make it
11:50:28 <ttx> but let's give them all a chance for the time being
11:50:43 <ttx> Anything you want to discuss at meeting today?
11:50:51 <eglynn> yeap, I'll pass that mess onto to gordc, and will do another pass on Friday before I finish up
11:50:59 <eglynn> yeap couple of things
11:51:06 <eglynn> major snafu in Fedora-land has killed the ceilo py26 gate for the last day
11:51:17 <eglynn> mongodb packages were retired from EPEL6 by mistake
11:51:21 <eglynn> (couchdb was the intended victim)
11:51:22 <ttx> heh
11:51:32 <eglynn> see https://www.redhat.com/archives/pulp-list/2014-August/msg00002.html & https://www.redhat.com/archives/pulp-list/2014-August/msg00016.html
11:51:36 <ttx> ?o??db
11:51:48 <eglynn> yeap :)
11:51:56 <eglynn> the bad commit has been reverted and the version re-tagged, pbrady is actively chasing +1s on restoring
11:52:07 <eglynn> but may take a while for the restore to propogate thru'
11:52:16 <eglynn> in the meantime, ceilo gating is blocked :(
11:52:22 <ttx> ok
11:52:22 <eglynn> also possibly marconi & trove?
11:52:42 <ttx> #info Ceilo py26 fgate blocked on Fedora snfu removing mongodb packages
11:52:46 <eglynn> as a stop-gap, we may need to install the RPM direct from the Fedora package build system on the centos-6 jenkins slaves
11:52:55 * eglynn will talk to the infra folks about this
11:53:15 <ttx> Did you discuss the best time for 1:1 syncs with Gordon starting next week?
11:53:46 <eglynn> I mailed him with those alternate times as he was offline, no response yet
11:53:53 <ttx> ok
11:53:54 <eglynn> I'll chase on IRC this afternoon
11:54:12 <ttx> #action ttx to see best time for Gordon for upcoming 1:1 sync with Ceilometer
11:54:22 <eglynn> not that we're going to solve this now, but ...
11:54:25 <ttx> otherwise will discuss it with him directly
11:54:43 <eglynn> the other thing I'm concerned about is the demotivational/distraction effect of that future of integration release discussion
11:54:53 <eglynn> from a timing perspective re. the push for juno-3
11:55:07 <eglynn> but as I said, we're not going to solve that now
11:55:20 <ttx> trick is we need to review several incubation/graduation requests during August
11:55:43 <ttx> all I can say is that this discussion doesn't affect Juno
11:55:52 <ttx> it's all about Kilo
11:56:02 <ttx> BUT some kilo-affecting decisions need to be taken asap
11:56:13 <ttx> especialy which projects to graduate or not
11:56:14 <eglynn> yeah, I was assuming that re the Kilo orientation
11:56:39 <ttx> eglynn: btw we should have time to discuss gnocchi today
11:57:07 <eglynn> yeah, cool, there's been some activity on that ML thread
11:57:16 * ttx is a bit late with email
11:57:21 <ttx> ETOOMANYFIRES
11:57:39 <eglynn> I'll be around during the TC meeting when you need to call on me
11:57:51 <ttx> anything specific you want to discuss at the cross-project meeting?
11:58:22 <eglynn> it might be worth clarifying the documentation contribution workflow
11:58:41 <eglynn> specifically the heavyweight XML docbook markup that we've been struggling with
11:59:04 <eglynn> versus a new lightweight RST-based workflow that the doc team are piloting with heat
11:59:14 <ttx> eglynn: sounds good. Could you edit https://wiki.openstack.org/wiki/Meetings/ProjectMeeting#Agenda_for_next_meeting ?
11:59:19 <eglynn> will do
11:59:22 <ttx> thx!
11:59:35 <ttx> talk to you later, then
11:59:41 <ttx> SergeyLukjanov: around?
11:59:46 <eglynn> OK
12:11:13 <SergeyLukjanov> ttx, I'm here
12:11:44 <SergeyLukjanov> ttx, sorry, just returned from the lunch
12:13:20 <ttx> #topic Sahara
12:13:24 <ttx> SergeyLukjanov: o/
12:13:43 <ttx> #link https://launchpad.net/sahara/+milestone/juno-3
12:14:17 <SergeyLukjanov> ttx, hey
12:14:21 <ttx> #info 2 implemented, 4 udner review, 8 in progress, 1 not started
12:14:44 <ttx> That's 4 more blueprints since last time we looked at it
12:15:01 <ttx> this is also progressing slowly
12:15:17 <ttx> Do you plan to use a feature proposal freeze next week?
12:15:28 <ttx> i.e. drop everything that is not under code review yet?
12:15:40 <SergeyLukjanov> ttx, I think so
12:17:10 <ttx> #info Sahara might use FPF
12:17:12 <SergeyLukjanov> ttx, I'll talk with folks on the meeting this week about slow progress blueprints and probably move some of them to the next
12:17:35 <ttx> Looking at the high-prio items...
12:17:47 <ttx> https://blueprints.launchpad.net/sahara/+spec/edp-swift-trust-authentication is marked "slow progress"
12:18:12 <ttx> although 3 merged out of 4... is it blocked on something ?
12:18:24 <SergeyLukjanov> ttx, it's extremely complicated
12:18:36 <SergeyLukjanov> ttx, and it looks like we'll move it to next
12:19:01 <ttx> ok, do it early rather than kate, will free up reviewers time
12:19:08 <SergeyLukjanov> ttx, it's about changing auth and credentials distribution strategies for data sources
12:20:12 <SergeyLukjanov> ttx, all current CRs are backward compat and adds support for moving to the new strategy, and useful by itself
12:20:22 <SergeyLukjanov> I'm just not sure that it'll be fully completed in J
12:21:33 <ttx> I prefer that you get the others merged rater than try this one and fail the others as a result
12:21:51 <ttx> so maybe move it to next at the next meeting
12:22:10 <ttx> OK, anything you wanted to discuss at cross-project meeting today?
12:22:22 <SergeyLukjanov> ttx, I think everything is going ok
12:22:31 <SergeyLukjanov> dashboard stuff going ok too
12:22:35 <ttx> SergeyLukjanov: ok cool, talk to you later then
12:22:39 <ttx> dhellmann: around?
12:22:44 <dhellmann> hi, ttx
12:22:47 <ttx> #topic Oslo
12:22:49 <SergeyLukjanov> ttx, thx
12:23:08 <ttx> #topic https://launchpad.net/oslo/+milestone/juno-3
12:23:18 <ttx> #topic https://launchpad.net/oslo.messaging/+milestone/juno-3
12:23:25 <ttx> #topic https://launchpad.net/oslo.vmware/+milestone/juno-3
12:23:26 <ttx> ...
12:23:43 <ttx> dhellmann: I've been giving some thoughts on that mess ^
12:24:30 <ttx> I think we should be using an oslo project group in LP, and use library versions as milestones
12:24:32 <dhellmann> hmm, there aren't milestones set up. I thought the vmware guys were going to use the oslo project so we wouldn't keep making this worse :-/
12:25:14 <dhellmann> ttx: that seems like it would help
12:25:16 <ttx> dhellmann: i'll post something to that effect
12:25:27 <dhellmann> we did talk about that last time, iirc, but I didn't follow up on making it happen
12:25:37 <ttx> Still need to check how blueprints would show up
12:25:48 <ttx> for bugs, it's pretty nice
12:25:59 <dhellmann> yeah, I'm worried if we switch to versions for milestones it will be confusing when we talk about the cycle schedule
12:26:38 <ttx> we'd keep the same "series"
12:27:34 <ttx> but yeah, still on my todo list to explore all the consequences of the proposal :)
12:27:43 <ttx> in the meantime...
12:27:47 <dhellmann> ok
12:28:28 <ttx> Most of the oslo-incubator BPs are about graduation, which is not really a FF thing
12:28:36 <dhellmann> right
12:29:05 <ttx> and the remaining ones are more "good if they go in, not a big deal if they don't"
12:29:31 <ttx> Although I guess I would like us to wrap up the daemon mode thing
12:29:46 <ttx> but no big deal if we warp it up first thing in Juno
12:29:49 <ttx> in Kilo
12:30:13 <ttx> So just drop stuff you know won't make it, to avoid settign wrong expectations
12:30:49 <ttx> dhellmann: anythign you want to discuss at meeting today?
12:31:05 <dhellmann> yeah, I think we're OK now that everyone is back from vacation and we can start doing more reviews
12:31:10 <dhellmann> nothing from me this week
12:31:24 <ttx> OK then, thanks for your time
12:31:29 <dhellmann> ttyl
14:01:06 <ttx> jgriffith: ready when you are
14:02:40 <dolphm> ttx: https://bugs.launchpad.net/oslo/+bug/1321080/comments/34
14:04:23 <ttx> dolphm: commented
14:13:04 <ttx> dolphm: I guess we can talk now, if you're around
14:15:08 <dolphm> ttx: o/
14:15:32 <ttx> #topic Keystone
14:16:13 <ttx> #link https://launchpad.net/keystone/+milestone/juno-3
14:16:52 <ttx> #info 0 Implemented, 4 Under review, 2 in progress, 6 Blocked/Not started
14:17:04 <ttx> That looks a bit late to me
14:17:31 <dolphm> agree
14:17:58 <dolphm> on the upside, openid connect is supposedly complete somewhere outside of gerrit
14:18:15 <dolphm> i don't think we'll have anything to deprecate this cycle, so that bp will just go away
14:18:27 <dolphm> and audit support for federation is a small change
14:18:32 <dolphm> that's our three "Not Started"
14:18:46 <ttx> The blocked ones are those waiting for spec approval?
14:19:00 <dolphm> two of the Blocked ones are mostly blocked on "Do we really need this?" but the work is easy if we agree
14:19:02 <dolphm> yes
14:19:10 <ttx> hmm, ok
14:19:15 <ttx> But still, time is running out
14:19:21 <ttx> so you have to make up your mind now
14:19:50 <ttx> because you need to start finalizing some of those
14:19:53 <dolphm> the scary ones in terms of amount of work and complexity of reviews are keystone-to-keystone federation and non-persistent pki tokens
14:21:04 <ttx> right, I'm a bit concerned with  keystone-to-keystone federation
14:21:09 <ttx> what's the current state ?
14:21:21 <ttx> I think that would be really good if that landed in juno
14:21:38 <ttx> so maybe moving non-persistent pki tokens to next makes sense
14:21:54 <dolphm> there were a lot of radically different options to approach it, and we didn't decide on a solution until our hackathon in early july. it's made good progress since then, but we didn't exactly choose the lightest weight solution. it's going to be close if it makes it
14:23:03 <ttx> do you think moving stuff out of the way would help ?
14:23:15 <ttx> or is it completely separate
14:23:38 <dolphm> openid connect looks like the only one that might directly interfere
14:24:02 <dolphm> i'll follow up with steve on that one
14:24:35 <ttx> dolphm: do you plan to enforce FPF next week?
14:24:44 <dolphm> yes, aug 21?
14:25:52 <ttx> yep
14:26:06 <ttx> OK, anything for the meeting agenda today?
14:26:17 <dolphm> nope
14:26:23 <ttx> #info Keystone plans to enforce FPF
14:26:30 <ttx> ok then ttyl!
14:27:12 <dolphm> o/
14:33:21 <ttx> david-lyle: o/
14:33:32 <david-lyle> ttx: o/
14:33:33 <ttx> #topic Horizon
14:34:21 <ttx> down to 63 blueprints
14:34:23 <ttx> https://launchpad.net/horizon/+milestone/juno-3
14:34:34 <david-lyle> heh
14:34:57 <ttx> #info 7 implemented, 28 under review, 24 in progress, 4 unknown
14:35:13 <david-lyle> yeah still way too much load, working on pruning the list, and trying to keep up with cleaning out those added everyday
14:36:19 <ttx> yep, 3 weeks left
14:36:29 <david-lyle> several are very mature and should merge soon
14:37:03 <ttx> ok, hopefully we'll see a clear progress next week
14:37:11 <ttx> also we have FPF on August 21
14:37:27 <ttx> so you can leverage that to remove stuff that is just not there yet
14:37:29 <david-lyle> I set Horizon's at Aug 12
14:37:37 <david-lyle> or 14
14:37:43 <ttx> that would be Thursday
14:37:47 <ttx> cool
14:38:01 <ttx> Looking at High prio stuff...
14:38:04 <david-lyle> yeah, already too much, can't handle more
14:38:21 <ttx> https://blueprints.launchpad.net/horizon/+spec/remove-javascript-bundling is under review -- in good shape?
14:39:12 <david-lyle> it's close, had a couple of bug fixes that set it back a little, should be ready soon
14:39:12 <ttx> i see two more changes needing review/merge
14:39:17 <ttx> ok
14:39:19 <ttx> https://blueprints.launchpad.net/horizon/+spec/launch-instance-ux-enhancement is in progress -- how far is it?
14:39:39 <ttx> That one still very much WIP
14:39:51 <david-lyle> this is stalled and I may have to move out of Juno
14:40:24 <david-lyle> unfortunately
14:40:39 <ttx> ok, drop it early if you do
14:40:45 <ttx> so that we don't communicate wrong expectations
14:41:08 <david-lyle> sure, I'll bring it up in the Horizon team meeting
14:41:22 <david-lyle> make sure there's not work I'm missing
14:41:26 <ttx> ok
14:41:33 <ttx> anything you want to discuss at meeting today?
14:41:51 <david-lyle> no, I don't think so
14:42:02 <ttx> alrighty then, talk to you later
14:42:08 <ttx> mestery: ready when you are
14:42:09 <david-lyle> ttx: thanks
14:42:11 <mestery> ttx: o/
14:42:14 <ttx> #topic Neutron
14:42:35 <ttx> been following your mailing-list adventures
14:42:41 <ttx> #link https://launchpad.net/neutron/+milestone/juno-3
14:42:45 <mestery> ttx: It's been fun :)
14:43:16 <ttx> #info 3 implemented, 39 under review, 11 in progress, 32 unknown/blocked
14:43:34 <ttx> so those unknown are a bit of a concern I guess
14:43:39 <mestery> Agreed
14:43:44 <mestery> It's likely I'll cull most of those next week.
14:43:51 <mestery> For the most part, they are all low priority, best effort.
14:43:53 <ttx> also feels like you could do with 32 less blueprints in your plate
14:43:58 <mestery> Agreed
14:44:22 <ttx> mestery: if all core reviewers really ignored those and prioritized their reviews properly, I would say we don't mind them
14:44:41 <ttx> but just having such a busy slate is discouraging
14:44:51 <ttx> so the numbers just hurt
14:45:08 <mestery> Yes, in the future, we are going to be better about saying no earlier on.
14:45:17 <mestery> It's something we as a team acknowledge we need to do better at
14:45:20 <ttx> Looking at the essential/high stuff
14:45:32 <ttx> https://blueprints.launchpad.net/neutron/+spec/neutron-dvr-fwaas has unknown status
14:45:44 <ttx> does that mean you lst contact with the people working on it ?
14:45:46 <mestery> Yes, that one concerns me, they owner says "it's coming", but I have my doubts.
14:46:03 <mestery> I plan to follow up again on that one today to see if it has a chance.
14:46:06 <ttx> or that you have no idea so it's as bad as not started as far as you're concerned
14:46:14 <mestery> I think the latter.
14:46:18 <ttx> ok
14:46:27 <mestery> There was a lot of activity on it a few weeks back on an email htread
14:46:30 <mestery> and then it's died on the vine :(
14:46:57 <ttx> How is https://blueprints.launchpad.net/neutron/+spec/neutron-ovs-dvr going ?
14:47:18 <mestery> That one is "done", they have left it open while they fix a few bugs which have fallen out.
14:47:25 <mestery> But the functionality has merged a few weeks back
14:47:30 <mestery> So, that's a HUGE win for us
14:47:45 <ttx> frankly if we ignore the Low/Unknowns it doesn't look that bad
14:47:52 <mestery> Agreed
14:48:09 <ttx> Like almost all the >=Medium are proposed
14:48:10 <mestery> L3 HA is also very important, and it's coming along nicely at this point as well.
14:48:22 <mestery> https://blueprints.launchpad.net/neutron/+spec/l3-high-availability
14:48:42 <ttx> so maybe you can just bluntly leverage FPF to remove all the extra stuff
14:48:51 <mestery> That is my plan :)
14:49:04 * mestery will be in Chicago next week for Linuxcon and plans to spend Friday morning cleaning this up.
14:49:06 <mestery> That's post FPF
14:49:12 <mestery> Which is next Thursday
14:49:13 <ttx> But then you should also finalize as many as you can while it's not too difficult to do so
14:49:21 <mestery> Yes
14:49:52 <ttx> Theer are two things that concern me on the recent threads
14:50:17 <ttx> The first one is the disagreement on the nova-net->neutron migration. It looks like a dev vs. ops thing
14:50:32 <ttx> where devs say, better to have cold migration than nothing
14:50:47 <ttx> and (some) ops say we don't like tat as a solution
14:50:50 <mestery> Yes, that one is concerning, as we thoughyt at the nova mid-cycle we had agreement
14:51:00 <ttx> russellb summarized it well with the pony
14:51:03 <mestery> Consider migration a "WIP" I guess right now, which I know isn't good
14:51:07 <mestery> Yes :)
14:51:33 <ttx> The other is the whole "where goes GBP"
14:51:47 <ttx> Did you make progrss on that at the recent meeting?
14:52:08 <russellb> i want a pony.
14:52:09 <mestery> I think so, the bottom line is there is not enough consensus, and the incubator appears like a good place for things like this.
14:52:19 <mestery> The incubator proposal has some issues, which we're working through.
14:52:25 <ttx> russellb: I heard that two times today from my daughters already
14:52:30 <russellb> nice!
14:52:39 <mestery> russellb: Or a unicorn. Unicorns are nice too. :)
14:52:46 <ttx> russellb: the problem being, I actually have enough room for two ponies or more
14:53:03 <russellb> how about time to take care of them?
14:53:15 <russellb> i want to visit your town :)
14:53:21 <russellb> sounds peaceful.
14:53:22 <ttx> russellb: that's the plan.
14:53:43 <ttx> get me cloned so that I can actually take care of all the ponies. OpenStack and otherwise.
14:54:13 <ttx> mestery: ok, so it's not stalled
14:54:41 <mestery> ttx: The incubator appears to be the way forward here.
14:54:57 <ttx> mestery: ok cool
14:55:07 <ttx> mestery: anything you want to discuss at meeting today?
14:55:20 <ttx> I don't see any obvious next step on the pny migration though
14:55:38 <mestery> ttx: Maybe we can discuss when projects are opening Kilo specs?
14:55:42 <mestery> I'd like to wait as long as possible
14:55:45 <mestery> Given where we are in Juno.
14:55:51 <mestery> I think mikal and I are in agreement there at least.
14:55:56 <ttx> It's actually on the agenda already
14:56:00 <mestery> ttx: Perfect. :)
14:56:06 <ttx> mikal added it this morning
14:56:09 <mestery> cool
14:56:14 <ttx> ok, so let's discuss that today
14:56:21 <mestery> Thanks!
14:56:24 <ttx> mestery: talk to you later then
14:56:30 <mestery> ttx: ack, later!
15:30:21 <notmyname> ttx: hello
15:30:39 <ttx> notmyname: o/
15:30:53 <ttx> #topic Swift
15:31:37 <ttx> Getting close to that "end of august" deadline
15:31:45 <notmyname> hmm...I just sent an email to openstack-dev and it was help for moderation
15:32:02 <ttx> notmyname: yeah, it hits a too many recipioent limit, I moderated it through
15:32:08 <notmyname> ah ok
15:32:14 <ttx> not your fault, the original mail had the same issue
15:32:20 <notmyname> oh ok
15:32:32 <ttx> it's lie he copied 20 people on it
15:32:38 <ttx> like*
15:33:10 <notmyname> so, for an end-of-august release. I'll be looking at that this week
15:34:33 <ttx> ok, so we should know nect week?
15:34:38 <ttx> next*
15:35:17 <notmyname> yes. well, I think it's pretty easy to say we can have one. there's several nice little things. but by next week I can give a better idea of a date and what's in it
15:35:38 <ttx> #info more info next week on potential end-of-august intermediary swift release
15:36:16 <ttx> notmyname: anything you want to discuss at meeting today?
15:36:47 <notmyname> ttx: no. I'm working on the gap stuff still.
15:37:11 <ttx> ack
15:37:37 <ttx> OK, well I guess we'll have more to talk about next week once you know what you want to do for the intermediary release
15:38:03 <ttx> Anything else you wanted to mention here?
15:38:14 <notmyname> ..thinking...
15:38:33 <notmyname> no
15:38:44 <ttx> ok then, talk to you later
15:47:39 <ttx> zaneb: o/
15:47:48 <zaneb> o/
15:47:50 <ttx> #topic Heat
15:47:54 <zaneb> is it Tuesday already?
15:48:08 <ttx> and it's 6pm already
15:48:12 <ttx> :)
15:48:22 <ttx> #link https://launchpad.net/heat/+milestone/juno-3
15:48:47 <ttx> #info 1 implemented, 5 under review, 4 in progress, 1 blocked
15:49:01 <zaneb> happily, I did actually update this during the week :)
15:49:35 <ttx> It looks like you'e a bit behind, but with a reasonable amount of targets
15:50:18 <ttx> so by next week we should see how crazy that was
15:50:30 <zaneb> yeah, there will be a lot of reviews to do
15:50:48 <zaneb> but I think most of these are in reasonable shape
15:50:54 <ttx> zaneb: i don't remember, do you plan to enfore a feature proposal freeze next week?
15:50:59 <ttx> enforce*
15:51:07 <zaneb> yes
15:51:19 <ttx> like deferring to kilo anything that's not code proposed by next Thursday ? ok
15:51:20 <zaneb> I prefer 'observe' ;)
15:51:25 <ttx> That should clarify a lot
15:51:42 <ttx> observe. /me adds to vacabulary
15:52:03 <ttx> Looking at high prio stuff...
15:52:05 <ttx> https://blueprints.launchpad.net/heat/+spec/update-failure-recovery
15:52:26 <ttx> How many more reviews do you expect on that one ?
15:52:35 <ttx> https://review.openstack.org/#/q/topic:bp/update-failure-recovery,n,z is all merged
15:52:55 <zaneb> it's actually pretty close, even though I only posted the last lot of patches on Friday
15:53:13 <ttx> ok, so it's in good shape
15:53:21 <zaneb> in the process of rejiggering the queue now, because it had what turned out to be an urgent bug fix right in the middle :D
15:53:31 <ttx> https://blueprints.launchpad.net/heat/+spec/encrypt-hidden-parameters is missing the spec approval?
15:53:52 <ttx> or is blocked for other reasons?
15:54:16 <ttx> Oh, and who is working on https://blueprints.launchpad.net/heat/+spec/stack-display-fields ?
15:54:41 <ttx> (missing an assignee)
15:55:02 <zaneb> basically it needs to take into account the update-failure-recovery stuff, which adds more things to the DB
15:55:35 <zaneb> so I WIP'd the review and set the bp to blocked until such time as we have a plan for how to do that
15:55:38 <ttx> ok
15:55:50 <zaneb> that may be the wrong state for the bp, actually
15:56:09 <zaneb> it's not a major concern
15:56:38 <zaneb> it may well get bumped; last time I looked it was missing things like key rotation
15:57:00 <ttx> ok, will probably be late by next week
15:57:30 <ttx> zaneb: any topic you want to discuss at the cross-project meetign today?
15:57:47 <zaneb> not that I can recall :)
15:58:10 <ttx> ok then, talk to you later!
15:58:36 <zaneb> thanks o/
16:05:22 <ttx> no Nikhil, no markwash
16:06:07 <ttx> jgriffith: you can go now if you're around
16:06:11 <arnaud> ttx, markwash is out one more week afaik
16:06:27 <ttx> arnaud: are you standing in for him?
16:06:37 <arnaud> yep
16:06:42 <ttx> oh, ok
16:06:45 <ttx> #topic Glance
16:06:48 <ttx> let's do this then
16:07:00 <ttx> #link https://launchpad.net/glance/+milestone/juno-3
16:07:19 <ttx> #info 1 under review, 2 in progress
16:07:38 <ttx> That's little progress, as far as blueprint status is concerned, compared to previous weeks
16:07:57 <ttx> arnaud: Still feeling like you can get all those merged before feature freeze ?
16:08:49 <arnaud> yes. but actually, this page doesn't contain the main item that we would like to see merged: http://specs.openstack.org/openstack/glance-specs/specs/juno/metadata-schema-catalog.html
16:09:47 <ttx> hah! Is there a blueprint forr that that we could add to the list?
16:10:18 <ttx> doesn't look like there is
16:10:19 <arnaud> I thought there was some kind of script that would automatically create the LP bp when the spec is approved..
16:10:22 <arnaud> I might be wrong
16:10:31 <ttx> unfortunately not :)
16:10:43 <ttx> There is as cript you can manually run to set the fields right
16:10:56 <ttx> but you just can't create a blueprint using LP API (don't ask)
16:11:03 <arnaud> ok
16:11:31 <arnaud> will create the bp in LP then
16:11:44 <ttx> ok, ping me when done, I'll adjust the fields for you
16:11:55 <arnaud> ok sure
16:12:02 <ttx> you're not in glance-drivers so you actually can't set the prio that will make it stick
16:12:12 <arnaud> I am in glance-drivers
16:12:13 <ttx> cool
16:12:22 <ttx> hmm...
16:12:25 <ttx> https://launchpad.net/~glance-drivers/+members
16:12:31 <arnaud> oh right
16:12:39 <arnaud> I am in gerrit
16:12:39 <ttx> you're in glance-core, probably
16:12:58 <arnaud> I will ask rosmaita, that's not a problem
16:13:02 <ttx> bah, let me add you
16:13:36 <ttx> you being here makes you qualified :)
16:13:41 <arnaud> :) sweet
16:13:55 <ttx> just let mark know at some point :)
16:14:11 <ttx> so yeah, add anything that's missing to the j3 list
16:14:26 <arnaud> let me check
16:14:26 <ttx> you should be able to set all fields. Just don't forget to set a priority
16:14:32 <arnaud> ok
16:14:45 <ttx> unprioritized blueprints fall off the list automatically
16:14:56 <ttx> (so that people don't add crap to the list)
16:15:16 <arnaud> there might be the artifacts (part 1), but I feel that's not gonna make it
16:15:21 <ttx> arnaud: anythign else you wanted to mention ? Anything you'd like to see discussed at the cross-project meeting later today ?
16:15:35 <arnaud> I will double check with ativelkov for the status later today
16:15:49 <SlickNik> o/
16:16:20 <ttx> arnaud: ok, if nothing else... talk to you later!
16:16:32 <ttx> #topic Trove
16:16:33 <arnaud> sure thanks ttx
16:16:36 <ttx> SlickNik: o/
16:16:48 <ttx> #link https://launchpad.net/trove/+milestone/juno-3
16:17:18 <ttx> #info 7 under review, 6 in progress, 1 not started
16:17:33 <SlickNik> Yup, lots in review.
16:17:38 <ttx> ok, so that was cleaned up alright
16:17:46 <ttx> but yes, a bit behind
16:17:49 <jgriffith> ttx: bahh...
16:18:04 <SlickNik> ttx: Also, I was out of the office end of last week, so I intend to do some more triage / cleanup this week.
16:18:11 <ttx> need to start converting those "under review" into nice green implemented
16:18:34 <SlickNik> Yup — working on it.
16:19:04 <SlickNik> You should see (hopefully) more than a couple turn green by next week's status.
16:19:17 <SlickNik> Plus my focus on moving away from rdjenkins is now in gear.
16:19:21 <ttx> SlickNik: do you plan to observe a feature proposal freeze next week and drop everything that's not proposed yet?
16:19:34 <ttx> or be a bit more flexible?
16:20:15 <SlickNik> ttx: we plan to observe it. But might make an exception in a couple of cases (depending on importance)
16:20:31 <ttx> looking at your "high" item
16:20:35 <ttx> https://blueprints.launchpad.net/trove/+spec/replication-v1
16:20:45 <ttx> "good progress"
16:21:18 <ttx> feeling confident on that one? Looks like a lot of reviews
16:22:38 <SlickNik> I'm very confident on that one. There's a good effort to get that reviewed and merged by multiple stakeholders (RAX, HP, Tesora)
16:22:45 <ttx> ok, great
16:22:58 <ttx> SlickNik: anything to add to meeting agenda for today?
16:23:18 <ttx> #info Will observe a FPF, probably with a couple exceptions
16:24:06 <SlickNik> ttx: not anything else.
16:24:10 <SlickNik> that's all I had.
16:24:13 <SlickNik> Thanks!
16:24:18 <ttx> SlickNik: ok then. talk to you later, and thanks for coming
16:24:47 <ttx> That concludes our syncs... We skipped Cinder today since they are in the middle of their meetup
16:24:54 <ttx> #endmeeting