08:49:03 <ttx> #startmeeting ptl_sync
08:49:04 <openstack> Meeting started Tue Dec 9 08:49:03 2014 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:49:05 <ttx> We can
08:49:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:49:09 <openstack> The meeting name has been set to 'ptl_sync'
08:49:09 <SlickNik> Thanks!
08:49:12 <ttx> #topic Trove
08:49:28 <ttx> So.. next week we have kilo-1
08:49:48 <SlickNik> So I spent some time getting https://bugs.launchpad.net/trove/+milestone/kilo-1 in shape.
08:49:48 <ttx> The goal being to tag sometimes between the 16th and the 18th
08:50:11 <ttx> so on thos days, as soon as you're happy with the sahpe of master we can push the tag
08:50:21 <SlickNik> Yes. Working towards getting all the BPs that are on track reviewed and through.
08:50:29 <SlickNik> Soundsgood
08:50:39 <ttx> just send me a SHA and I'll make it happen
08:50:49 <ttx> https://launchpad.net/trove/+milestone/kilo-1
08:51:10 <ttx> 7 in-progress blueprints to get in
08:51:22 <ttx> and 12 bugfixes still targeted
08:51:32 <ttx> next week we'll refine that list to cover true milestone blockers
08:51:43 <ttx> but the current list sounds reasonable to me
08:52:00 <SlickNik> Most of them are pretty close.
08:52:44 <SlickNik> Will sync with you on them again next week to check what we need to move out (if any).
08:52:50 <ttx> agreed
08:52:59 <ttx> No questions from me, you look in good shape
08:53:25 <SlickNik> Sounds good. That's pretty much all I had.
08:53:50 <SlickNik> Thanks for being flexible with the timing.
08:54:05 <ttx> no pb!
08:54:10 <ttx> talk to you next week
08:54:47 <SlickNik> Thank you — see you later at the x-project meeting.
08:55:46 <asalkeld> o/
09:00:17 <ttx> asalkeld: o/
09:00:21 <asalkeld> hi ttx
09:00:26 <ttx> #topic Heat
09:00:40 <asalkeld> #link https://launchpad.net/heat/+milestone/kilo-1
09:00:53 <ttx> asalkeld: same comment, kilo-1 is next week, so the idea is to tag sometimes between the 16th and the 18th
09:01:00 <asalkeld> ok
09:01:11 <asalkeld> i might need to move one or two bp to k2
09:01:13 <ttx> On those days, as soon as you're happy with the shape of master you send me a SHA and we can push the tag
09:01:26 <asalkeld> ok ttx sounds
09:01:29 <asalkeld> good
09:01:35 <ttx> (and defer the missed Bps to k2)
09:01:51 <asalkeld> sounds easy ;)
09:01:55 <ttx> it is easy
09:02:05 <ttx> especially since the milestone itself is not that important
09:02:20 <asalkeld> ok, yeah just intermediate
09:02:51 <ttx> the goal is just to avoid picking the wrong SHA, like if you wait for the last patch in a series implementing a feature, better wait a few more minutes :)
09:03:07 <asalkeld> sure, makes sense
09:03:10 <mikal> .
09:03:20 <ttx> https://blueprints.launchpad.net/heat/+spec/cinder-custom-constraints has no priority ?
09:03:31 <asalkeld> ttx, checking
09:04:01 <ttx> (is implemented already)
09:04:31 <ttx> and yes, depending how complex they are, decouple-nested lazy-load-outputs and multi-region-support might need to get pushed
09:04:32 <asalkeld> yeah, it was a very small bp
09:04:51 <asalkeld> decouple-nested - is looking big
09:04:59 <asalkeld> needs heaps of test code rework
09:04:59 <ttx> keep them in as long as you sincerely think they are likely to get in
09:05:08 <asalkeld> ok
09:05:10 <ttx> but defer them if you think they won't
09:05:28 <asalkeld> sure, makes sense
09:05:43 <ttx> Next week we'll refine again to only list milestone blockers
09:05:52 <ttx> so that we know what we are waiting on
09:06:05 <asalkeld> ok
09:06:47 <ttx> Do you need to merge anything more on the topic of env-nested-usability ?
09:07:02 <asalkeld> i just marked it done
09:07:21 <ttx> hah!
09:07:25 <ttx> alright then
09:07:37 <ttx> questions on your side ?
09:07:46 <asalkeld> no, all good
09:07:48 <asalkeld> thanks
09:07:56 <ttx> alright, have a good week!
09:08:01 <asalkeld> you too
09:08:20 <ttx> mikal: are you standing in for john, or should we just skip this week ?
09:09:02 <mikal> I am hot spare John
09:09:14 <mikal> Not that we've managed to overlap beforehand to brief
09:09:21 <mikal> But I am here for your release questioning needs
09:09:23 <ttx> let's try :)
09:09:26 <mikal> Also, I have questions about your bot
09:09:26 <ttx> #topic Nova
09:09:47 <ttx> ok let's start with the bot question
09:10:06 <mikal> Ok, so I approved four BPs Friday last week as part of our meeting
09:10:11 <mikal> I assigned a milestone etc
09:10:17 <ttx> did you set a priority ?
09:10:21 <mikal> And then your bot removed the milestone and slapped my wrist
09:10:27 <mikal> Obviously I've missed a step
09:10:30 <mikal> Ahhh, probably not?
09:10:38 <mikal> https://blueprints.launchpad.net/nova/+spec/hyperv-serial-ports is an example
09:10:39 <ttx> So the problem is... anybody can set a milestone.
09:10:50 <ttx> but only drivers can set a priority
09:11:00 <ttx> so we use the milestone+priority comboi to mean "approve"
09:11:16 <mikal> Fair enough
09:11:20 <ttx> and slap the wrists of anyone who dares to set milestone without priority
09:11:22 <mikal> I will retry with priorities set then
09:11:45 <ttx> it's an ugly workaround for Launchpad weird permission model around milestone targets
09:12:40 <ttx> I understand it can be surprising, that's why it's opt in and I explain it to people before they accept or reject it
09:12:41 <mikal> Ok, all fixed
09:12:43 <mikal> So all is well
09:12:53 <ttx> sorry about the "slap"
09:12:53 <mikal> Yeah, I think its because John has always done this for me
09:13:00 <mikal> I was just trying to help out while he was distracted
09:13:05 <mikal> Its all good, fixed now
09:13:12 <mikal> Next topic!
09:13:18 <ttx> https://launchpad.net/nova/+milestone/kilo-1
09:13:31 <ttx> We'll tag kilo-1 between the 16th and 18th next week
09:13:39 <mikal> Yep
09:13:42 <ttx> so the list if probably a bit optimistic at this point
09:13:45 <mikal> A lot of that is going to get bumped I think
09:13:48 <mikal> Which is pretty normal
09:14:11 <ttx> it's good to refine it so that it represents your best guess as to what should make it
09:14:18 <mikal> We've also said that we will impose a spec approval deadline of kilo-1 as well
09:14:21 <ttx> but I expect John will do it
09:14:22 <mikal> So I need to remind people of that
09:14:48 <ttx> There are a few "unknown" status there that are probably not in good shape for next week
09:14:49 <mikal> I think if its not in "needs code review" or "implemented" its probably safe to bump
09:14:53 <mikal> But I will leave that to John
09:15:05 <ttx> yeah, usually at this point, not proposed = not in
09:15:28 <ttx> so I would remove at least 10
09:15:44 <mikal> There's only 5 things in k-2 as well
09:15:55 <mikal> So being a bit more realistic there would be good
09:16:05 <ttx> and in the unlikely case they make it, we can put them back in k1
09:16:13 <mikal> So, are things moved manually?
09:16:16 <mikal> Or is there a script for that?
09:16:24 * mikal wonders if I should do some of it for John
09:16:53 <ttx> I don't have a script for that. I could make one. But to be fair, only Nova has the volume of specs that makes such a "defer" script needed :)
09:17:07 <mikal> Heh, fair enough
09:17:19 * mikal will move all the ones in "unknown" or "not started" as a first pass
09:17:27 <ttx> well, horizon has an habit of targeting hundreds of bugs
09:17:43 <ttx> I may already have that script somewhere let me check
09:18:22 <ttx> hmm, no
09:18:24 <mikal> Its ok, I can just grind through
09:18:26 <mikal> Its only about ten
09:18:48 <ttx> last thing is https://bugs.launchpad.net/nova/+bug/1266262
09:18:52 <ttx> targeted to k1 but no assignee
09:18:58 <ttx> probably unlikely to make it
09:19:12 * mikal looks
09:19:41 <ttx> but may be worth finding someone
09:19:53 <mikal> Sean Dague might have an opinion there
09:19:55 <mikal> I can ping him
09:19:56 <ttx> If you plan to try finding someone, you can keep it in
09:20:09 <ttx> we can clean up next week with "last minute blockers"
09:20:10 <mikal> Let's keep it for now
09:20:15 <mikal> Works for me
09:20:43 <ttx> vmware-vsan-support might be completed with https://review.openstack.org/#/c/74300/
09:21:08 * mikal looks
09:21:10 <ttx> quiesced-image-snapshots-with-qemu-guest-agent might have been completed with https://review.openstack.org/#/c/72038/
09:21:28 <mikal> How are you deciding which ones to call out like this?
09:21:42 <ttx> and hyper-v-smbfs-volume-support might have been completed with https://review.openstack.org/#/c/129235/
09:21:51 <ttx> http://status.openstack.org/release/
09:21:57 <ttx> I'm using this ^
09:22:06 <ttx> shows merged reviews attached to blueprints.
09:22:30 <ttx> When one in-progress BP only shows merged stuff, I check the review to see if it looks like it's multipart of single-review
09:22:41 <ttx> or*
09:23:02 <mikal> Ok, well I shall ask people about those as well then
09:23:21 <ttx> In those cases those are recent merged, so might just be completed
09:24:20 <mikal> Cool
09:24:26 <mikal> What else do we need to cover tonight?
09:24:26 <ttx> Alright, I think we are good..; questions on your side ?
09:24:32 <mikal> Nup, I think I am good
09:24:38 <ttx> thx for stepping in!
09:24:43 <mikal> No problem!
09:24:49 <mikal> Cool, see you at the TC thing then!
12:56:47 <SergeyLukjanov> ttx, hello, /me ready when you are
12:57:25 <ttx> SergeyLukjanov: will do eglynn first
12:57:43 <ttx> fwiw schedule is now at https://wiki.openstack.org/wiki/Release_Cycle_Management/1:1_Syncs
12:57:46 <SergeyLukjanov> ttx, yeah, just defining that I'm online :)
12:58:19 <ttx> eglynn: eady when you are
12:58:21 <ttx> +r
12:58:24 <eglynn> hey
12:58:30 <ttx> #topic Ceilometer
12:58:33 <eglynn> #link https://launchpad.net/ceilometer/+milestone/kilo-1
12:59:02 <eglynn> I bumped the instance-restart BP to k2 due to lack of traction on the code reviews
12:59:07 <ttx> eglynn: we'll tag and publish kilo-1 next week, seomteimes between the 16th and 18th -- just give me a SHA when you're happy with the state of master
12:59:15 <eglynn> cool
12:59:32 <ttx> eglynn: those last 5 are still on track for k1 ?
12:59:39 <eglynn> only slight concern is declarative-http-tests since we've seen no code yet
12:59:55 <ttx> ok, defer it early if you learn more
13:00:01 <eglynn> I'll have a 1:1 with cdent later on today and make a call on whether it's still realistic
13:00:12 <eglynn> otherwise the rest are all on target
13:00:14 <ttx> next week we'll refien the list to only contain milestone blockers
13:00:28 <eglynn> cool
13:00:58 <ttx> OK, looks all good and reasonable
13:01:12 <ttx> questions on your side ?
13:01:27 <eglynn> nope all good ... I'll start populating the kilo-2 roster by EoW
13:01:35 <ttx> ack
13:01:39 <ttx> have a great day then
13:01:52 <ttx> SergeyLukjanov: ready?
13:01:54 <eglynn> you too ... thanks for your time! :)
13:02:11 <ttx> This is becoming too easy
13:11:57 <dhellmann> ttx: ready when you are
13:12:21 <ttx> dhellmann: ok, let's do it now
13:12:26 <ttx> #topic Oslo
13:12:49 <ttx> dhellmann: so next week we'll tag the incubator at some point and park kilo-1 over
13:12:55 <ttx> mark*
13:12:56 <dhellmann> k
13:13:18 <ttx> Just let me know of a time/SHA that seems appropriate, sometimes between the 16th and the 18th
13:13:38 <ttx> https://launchpad.net/oslo/+milestone/kilo-1
13:13:39 <dhellmann> ok
13:14:04 <ttx> Are those two still in progress ? I think tooz is mostly done now, was renmaed
13:14:17 <dhellmann> yeah, we need to update the review team settings in gerrit but that's it
13:14:24 <dhellmann> I'll get jd to do that today
13:14:27 <ttx> ok
13:14:42 <dhellmann> oh, and probably the launchpad settings, too
13:14:45 <ttx> what about the other one, graduate oslo.context ?
13:15:07 <dhellmann> dims is making good progress on that
13:15:17 <dhellmann> the code is ready, there are just a few release management things to do
13:15:34 <dhellmann> I think we can finish both by next week
13:15:38 <ttx> ack
13:16:02 <ttx> In other news, I reworked spec2bp to address your remarks, hopefully
13:16:12 <ttx> it's now oslo-projectgroup-aware
13:16:37 <dhellmann> ok, I'll take a look at the latest version
13:16:53 <ttx> and lets you specify the path to the spec when it's nonstandard and not stored in the UTL bp field
13:16:56 <ttx> URL*
13:17:35 <dhellmann> cool
13:17:36 <ttx> that's all I had I think -- questions on your side ?
13:18:04 <dhellmann> I added some stuff to the oslo-specs repo last week to refuse specs that don't have matching blueprints in launchpad
13:18:20 <dhellmann> so those names should always match now :-)
13:18:48 <ttx> oh, interesting. We could mention it at the specs cross-project meeting today
13:18:53 <dhellmann> sure
13:19:02 <dhellmann> I could put it in oslosphinx, to make it easier to share
13:19:09 <dhellmann> turn it on/off with some options
13:19:30 <ttx> OK, anything else ?
13:19:38 <dhellmann> nothing from me
13:19:53 <ttx> dhellmann: ok then, talk to you later!
13:19:54 <SergeyLukjanov> ttx, sorry, internet issue
13:20:00 <dhellmann> ttx: thanks!
13:20:05 <ttx> SergeyLukjanov: is it better now ?
13:20:12 <SergeyLukjanov> ttx, I hope so
13:20:23 <ttx> #topic Sahara
13:20:39 <ttx> SergeyLukjanov: so, same drill, k1 next week, tag between Tue and Thu
13:20:51 <SergeyLukjanov> ack
13:20:55 <SergeyLukjanov> #link https://launchpad.net/sahara/+milestone/kilo-1
13:21:20 * SergeyLukjanov going to cleanup plans before the 1-1 meeting next week
13:21:30 <ttx> indirect-vm-access still likely to make it ?
13:21:34 <SergeyLukjanov> sounds like we have a few features that should be moved to k2
13:21:47 <SergeyLukjanov> ttx, I think so, the spec was just approved
13:22:19 <SergeyLukjanov> ttx, moving to "needs code review"
13:22:25 <ttx> ok
13:22:46 <ttx> so we'll revisit the list next week to lmimit to last-minute milestone blockers
13:22:55 <SergeyLukjanov> ttx, yeah
13:23:00 <ttx> On the bugs side, would be good to refine the list at this point too
13:23:09 <ttx> Not enough assignees to make it
13:24:36 <SergeyLukjanov> ttx, yup, agree, will cleanup the list
13:25:02 <ttx> any reason why you use publish-to-pypi for sahara proper ?
13:25:24 <SergeyLukjanov> ttx, hm, I'm looking now
13:25:35 <SergeyLukjanov> ttx, actually I don't remember any objectives for it
13:25:51 <SergeyLukjanov> ttx, no py3X support, but it's like in all other projects :)
13:26:16 <ttx> ok, I'll propose a fix for it
13:26:21 <SergeyLukjanov> ttx, thanks
13:26:44 <ttx> hmm, what else...
13:26:56 <SergeyLukjanov> ttx, oh, one moment
13:27:24 <SergeyLukjanov> ttx, what's the issue of using publish-to-pypi?
13:27:37 <ttx> we only publish to pypi the libraries
13:28:01 <ttx> server code is signed/published to LP and tarballs.o.o
13:28:22 <SergeyLukjanov> ttx, okay, so, probably we should remove it from pypi
13:28:29 <ttx> so it's more a consistency thing
13:28:43 <ttx> thso that people don't start complaining about https://pypi.python.org/pypi/nova being stale
13:28:44 <SergeyLukjanov> ttx, we've been publishing sahara to pypi starting from the first release
13:28:57 <ttx> yes, was a convenient way to inherit the tarball jobs :)
13:29:38 <ttx> SergeyLukjanov: ok, that's all I had -- questions ?
13:29:46 <SergeyLukjanov> nope, thank you!
13:30:17 <ttx> cheers
14:14:19 <mestery> ttx: Just FYI, I'm in Utah this week for Neutron, I am planning to be at our 1:1, but if you're around now, I'm available now as well.
14:14:55 <mestery> For 10 minutes at least :)
14:15:07 <mestery> Otherwise, I'll catch you in 50 minutes
14:15:54 <ttx> mestery: o/
14:15:57 <ttx> We can do it now
14:16:01 <mestery> Perfect!
14:16:03 <mestery> Thanks!
14:16:07 <ttx> #topic Neutron
14:16:22 <ttx> So we'll tag k1 next week, sometimes between the &6th and the 18th
14:16:27 <ttx> err 16th
14:16:40 <mestery> :)
14:16:44 <mestery> Excellent!
14:16:44 <ttx> just let me know when you're happy with the state of master
14:16:51 <mestery> YEs, we're at the sprint
14:16:56 <mestery> breaking services out this week
14:17:03 <mestery> I assume we'll tag those repositories too?
14:17:08 <mestery> It will be new for all of us
14:17:13 <ttx> so that's a good question
14:17:23 <mestery> Yes
14:17:31 <ttx> we can tag them alright. The question is more, what release model will apply to them
14:17:44 <ttx> is it more library like ?
14:17:59 <ttx> i.e. semver versioning, publish to pypi
14:18:05 <mestery> Yes, that's about right. They still depend on Neutron itself.
14:18:06 <ttx> or more companion tarballs
14:18:08 <mestery> Yes
14:18:16 <mestery> Let me think about this though
14:18:21 <mestery> I will figure it out today and let you know
14:18:44 <ttx> we need to check which jenkins jobs will apply to those, that's part of the split
14:19:03 <mestery> Yes, it's on our list of things to do today.
14:19:07 <mestery> And we need the co-gating jobs setup too, which will happen today as well
14:19:22 <ttx> From my perspective both options are on the table, we can certainly upload multiple tarballs in the "k1" milestone page on LP
14:19:22 <mestery> We have the new repos up with code, and reviews out to get them passing basic tests
14:19:28 <mestery> OK, cool
14:19:36 <ttx> and share versioning
14:19:52 <mestery> Excellent
14:19:56 <ttx> I think it boils down to how tightly integrated thsoe will be with neutron
14:20:18 <ttx> if they need synced releae, let's just share versioning and release all as components
14:20:38 <ttx> if the link between them is more loose... you could use a semver contract
14:20:41 <mestery> My gut feeling says lets do it that way for Kilo, post-Kilo we can think about separating them even more
14:20:59 <ttx> ok
14:21:18 <ttx> just keep me posted so that I can do a few checks in advance
14:21:37 <mestery> Ack, will do sir
14:21:48 <ttx> mestery: from a launchpad perspective, are those all tracked in same project, or different projects ?
14:22:18 <mestery> Same project, we're sharing both LP and neutron-specs for these
14:22:31 <ttx> ok, then it makes sense to share release
14:22:34 <mestery> Cool
14:22:57 <ttx> it's just a production artifact that they are released in separate tarballs instead of one
14:23:02 <ttx> at least for kilo.
14:23:21 <mestery> Yes, makes sense
14:23:45 <ttx> so yes, we'll tag them all, and should have -tarball jobs lined up to pick them up
14:23:58 <ttx> I'll check that my release scripts can handle that
14:24:03 <mestery> thanks!
14:24:12 <ttx> #action ttx to check that release scripts can handle the multi-tarball neutron split case
14:24:35 <ttx> https://launchpad.net/neutron/+milestone/kilo-1
14:24:59 <ttx> 4 specs still in progress, all likely to make it by next week ?
14:25:07 <mestery> My guess is we land 4 of those, maybe 5, but next week.
14:25:12 <mestery> Sorry
14:25:19 <mestery> 2 of the 4 in progress, maybe 3
14:25:26 <mestery> Total of 4-5
14:25:33 <mestery> Also
14:25:37 <mestery> The split spec will be approved and done in K1 too
14:25:45 <ttx> OK, we'll refine the list next ween so that only last-minute milestone blockers are left
14:25:47 <mestery> It's a formality we need to get done today
14:25:50 <mestery> Cool
14:26:06 <ttx> ok, maybe add it to k1 as "Blocked" ?
14:26:07 <mestery> Yes, the sprint has been super useful this week with regards to getting coding done in person, thanks also to infra and QA over IRC!
14:26:11 <mestery> Will do
14:26:36 <ttx> OK, that's all the urgent stuff I had. Questions on your side ?
14:27:03 <mestery> Nothing else, the split was the main thing on my mind now.
14:27:03 <mestery> Thanks ttx!
14:27:20 <ttx> alright, have a good sprint!
14:27:33 <mestery> thanks!
14:45:10 <dhellmann> ttx: +1 on the new spec2bp, thanks for making it work with oslo
14:46:15 <ttx> Cool, will let it bake for others comment for a few daysthen will merge it
15:20:12 <ttx> nikhil_k: around?
15:20:13 <nikhil_k> ttx: o/
15:20:26 <ttx> #topic Glance
15:20:46 <ttx> nikhil_k: kilo-1 strikes next week
15:21:06 <nikhil_k> yeah!
15:21:15 <ttx> that means we'll push a k1 tag sometimes between the 16th and the 18th, whenevr you're happy enough with the state of master to send me a SHA
15:21:34 <ttx> https://launchpad.net/glance/+milestone/kilo-1
15:21:38 <nikhil_k> ok, sounds good
15:21:52 <ttx> I see two "unknown" statuses there
15:22:01 <nikhil_k> ttx: they'r yet to be picked up
15:22:26 <ttx> nikhil_k: still likely to make it before next week ?
15:22:37 <nikhil_k> ttx: had given them a chance to get in k1. may be we can push them to k2 early next week
15:22:46 <nikhil_k> it's a small chance
15:22:50 <ttx> yes, we'll refine the list next week
15:23:03 <ttx> so that it only includes the last-minute milestone blockers
15:23:56 <nikhil_k> cool, that works!
15:25:14 <nikhil_k> ttx: was that all for me?
15:25:40 <ttx> sorry phone rang
15:25:51 <nikhil_k> ah k
15:26:00 <ttx> but sounds all good
15:26:06 <ttx> questions from you ?
15:26:18 <nikhil_k> had one smal one
15:26:24 <ttx> shall take a bit more time next week as we finally cull the list :)
15:26:52 <nikhil_k> what to do with the stable/icehouse review requests?
15:27:39 <ttx> nikhil_k: we'll set up the glance-stable-maint group tomorrow
15:27:49 <nikhil_k> ok nice
15:27:54 <ttx> so you shall be able to approve those yourself, as long as you follow stable policy
15:28:04 <nikhil_k> ah cool
15:28:14 <ttx> I'll keep you posted. We were waiting to get 2014.2.1 out of the way
15:28:25 <nikhil_k> gotcha
15:28:29 <ttx> I booked tomorrow afternoon with fungi to set that up
15:28:36 <nikhil_k> ttx: how is that group getting formed?
15:28:46 <ttx> starts with stable liaison
15:28:50 <nikhil_k> gotcha
15:28:54 <ttx> let me check the proposed group
15:29:30 <ttx> would be you and Erno
15:29:34 <ttx> to start
15:29:45 <nikhil_k> ttx: ok and we've liberty to add people
15:29:55 <nikhil_k> there are a few who we would like to be in there
15:30:02 <ttx> yes, the stable-maint-core group just needs to make sure they know stable policy before adding them
15:30:15 <ttx> so once we lectured them, we can add them
15:30:43 <nikhil_k> sounds good!
15:31:10 <ttx> reference: http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html
15:31:33 <ttx> nikhil_k: note that there is a glance-oriented topic at meeting today
15:31:49 <ttx> osprofiler options naming
15:31:51 <nikhil_k> ttx: ah yes, I'd recommended that
15:32:00 <nikhil_k> will be there in the meeting
15:32:06 <ttx> alright
15:32:10 <ttx> nikhil_k: thx!
15:32:14 <ttx> thingee: around?
15:32:15 <nikhil_k> thanks too!
15:32:16 <thingee> ttx: o/
15:32:20 <ttx> #topic Cinder
15:32:29 <ttx> So yeah, same warning...
15:32:35 <ttx> kilo-1 strikes next week
15:32:38 <ttx> that means we'll push a k1 tag sometimes between the 16th and the 18th, whenevr you're happy enough with the state of master to send me a SHA
15:33:15 <ttx> questions on that process ?
15:33:15 <thingee> ttx: a few of these are waiting for one more +2. I wasn't able to approve other merges since they were in bad shape for other reasons.
15:33:20 <thingee> ttx: nope
15:33:26 <ttx> https://launchpad.net/cinder/+milestone/kilo-1
15:33:44 <ttx> cinder-drbd-volume-driver still likely to make it ?
15:33:59 <thingee> yes, just spoke with the assignee to have code for me today
15:34:07 <ttx> ok
15:34:40 <ttx> We'll refine the list next week so that only last-minute milestone tag blockers are left
15:35:10 <thingee> ttx: sure
15:35:12 <ttx> on the bugs side, one of them is targeted but not assigned: https://bugs.launchpad.net/cinder/+bug/1383460
15:35:21 <ttx> Still liekly to make it ?
15:35:38 <ttx> I guess that's simple enough :)
15:35:47 <thingee> ttx: That can be closed likely. sample config is gone.
15:35:52 <thingee> ttx: I check it out
15:35:58 <thingee> i'll*
15:36:04 <ttx> ok, mark it invalid if that makes sense
15:36:38 <ttx> OK, looks all good. How is the "all drivers on k1" initiative working out so far ?
15:37:19 <thingee> great, I really do have code reviews for all and cert tests passing... drbd being my only special case :)
15:37:50 <ttx> ok
15:38:03 <ttx> Sounds all good to me. Questions on your side ?
15:38:28 <thingee> nothing. looking forward to core issues being taken care of in the next couple of milestones :)
15:38:46 <ttx> thingee: heh yes.
15:38:52 <ttx> thingee: ok then, have a good day!
15:38:59 <ttx> david-lyle: ready when you are
15:39:05 <thingee> ttx: have a good evening!
15:39:11 <david-lyle> ttx: ready
15:39:15 <ttx> #topic Horizon
15:39:29 <ttx> same warning about k1 striking next week
15:39:47 <ttx> https://launchpad.net/horizon/+milestone/kilo-1
15:39:52 <david-lyle> We're in good shape for K-1
15:40:07 <ttx> I see one "not started", still likely to make it ?
15:40:24 <ttx> https://blueprints.launchpad.net/horizon/+spec/mark-host-down-for-maintenance
15:40:53 <ttx> I guess https://review.openstack.org/#/c/103627/ makes it "started" at least
15:40:54 <david-lyle> It's ready for review actually
15:41:10 <ttx> ok, updating
15:41:46 <david-lyle> oops, stomped on your change I think
15:41:54 <ttx> those last 8 still stand a good chance of getting in before next week ?
15:41:59 <ttx> you win!
15:42:14 <david-lyle> put it as good progress, there's still a little discussion around the how
15:42:22 <david-lyle> I think we're in good shape
15:42:29 <ttx> OK, we'll readjust the list next week anyway so that it only contains the last-minute tag blockers
15:42:41 <ttx> On the bugs side, a couple unassigned targeted issues
15:42:47 <david-lyle> I won't block k-1 on any of them
15:43:24 <ttx> will you have people working on those, or is it better to just defer those to k2 now ?
15:43:34 <david-lyle> looking
15:43:36 <ttx> https://bugs.launchpad.net/python-keystoneclient/+bug/1282089
15:43:42 <ttx> https://bugs.launchpad.net/horizon/+bug/1396194
15:44:09 <david-lyle> let's move to k-2
15:44:19 <david-lyle> I need to find owners
15:44:36 <ttx> ok, I'll let you do that
15:44:40 <david-lyle> sure
15:44:49 <ttx> alright, questions on your side ?
15:45:27 <david-lyle> no, I'm set
15:45:37 <ttx> cool, have a good day then, talk to you later!
15:45:59 <david-lyle> Sounds good, thanks!
16:49:06 <ttx> notmyname: ready when you are
16:49:41 <notmyname> ttx: good morning
16:49:44 <ttx> #topic Swift
16:49:47 <ttx> ohai
16:50:07 <notmyname> we're on track for the dates we discussed last week
16:50:12 <notmyname> tracking some things at
16:50:14 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
16:50:33 <notmyname> that's really all I've got
16:50:34 <ttx> 2.2.1 RC between dec 11 and 15 and final by the end of the week ?
16:50:44 <notmyname> yup
16:51:15 <ttx> nice long url
16:51:36 <notmyname> thank gerrit for that ;-)
16:52:34 <ttx> can I set up a 2.2.1 milestone in LP ?
16:52:37 <notmyname> yes
16:52:46 <notmyname> and I'll put stuff into it as we get closer
16:52:59 <ttx> ok doing it now
16:53:42 <ttx> You can start pushing stuff to it: https://launchpad.net/swift/+milestone/2.2.1
16:54:00 <notmyname> thanks
16:54:01 <ttx> Alright, should be all set for next week
16:54:06 <ttx> notmyname: have a great day
16:54:10 <notmyname> you too
16:54:40 <ttx> Skipping keystone this week
17:03:49 <ttx> devananda: ready when you are
17:04:56 <devananda> ttx: hi! still working on my first cup of coffee
17:05:03 <devananda> ttx: so proceed at your own risk :)
17:05:07 <ttx> that... is fine
17:05:12 * ttx treads carefully
17:05:17 <ttx> #topic Ironic
17:05:44 <ttx> so... kilo-1 strikes next week
17:05:49 <devananda> we reviewed k1 plans last night
17:05:50 <ttx> that means we'll push a k1 tag sometimes between the 16th and the 18th, whenevr you're happy enough with the state of master to send me a SHA
17:06:02 <ttx> https://launchpad.net/ironic/+milestone/kilo-1
17:06:06 <devananda> bumped one proposal, the rest are getting increased attentiona nd folks think they will make it
17:06:17 <ttx> what's up on new-ironic-state-machine ?
17:06:19 <devananda> also, the elephant from last week -- https://review.openstack.org/#/c/133828/
17:06:30 <devananda> should be landing today
17:06:44 <devananda> that spec is representative of our -intention-
17:06:48 <devananda> not a specific piece of code
17:06:57 <ttx> so no real implementation yet ?
17:07:21 <devananda> I am doing the work, for now, of migrating the code to a state machine
17:07:32 <devananda> and then others will divy up the new aspects which that spec outlines
17:07:44 <ttx> OK, maybe you can close it as "informational" when done then, I think that communicates what it is quite well
17:07:52 <devananda> sounds good
17:08:24 <ttx> the other 3 are in good shape ?
17:08:30 <devananda> yup
17:08:35 <devananda> other news, I've been stalled a bit in planning our midcycle
17:08:38 <devananda> and need to get back on that this week
17:08:45 <devananda> i'll update the ML and wiki with details
17:08:51 <ttx> next week we'll refine the list to reduce it to milestone tag last minute blockers
17:09:00 <ttx> so should be slightly busier
17:09:06 <devananda> *nod*
17:09:12 <ttx> for today, nothing else from me. Questions from you ?
17:09:20 <devananda> nope
17:09:23 <devananda> cheers :)
17:10:08 <ttx> alright then, have a good day. Drink coffee
17:10:15 <ttx> that's all for today!
17:10:19 <ttx> #endmeeting