09:00:28 <ttx> #startmeeting ptl_sync
09:00:28 <openstack> Meeting started Tue Dec 16 09:00:28 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:32 <openstack> The meeting name has been set to 'ptl_sync'
09:00:32 <ttx> #topic Heat
09:00:40 <ttx> https://launchpad.net/heat/+milestone/kilo-1
09:01:00 <ttx> so... what's left
09:01:07 <ttx> https://blueprints.launchpad.net/heat/+spec/stack-snapshot
09:01:07 <asalkeld> just some bugs
09:01:20 <ttx> oh you markes that one implemented already
09:01:36 <asalkeld> ttx, refresh
09:01:36 <asalkeld> just chatted to the author and it's done
09:01:37 <ttx> so.. bugs.
09:01:43 <ttx> https://bugs.launchpad.net/bugs/1401929
09:02:02 <ttx> pending on https://review.openstack.org/#/c/141444/ which is marked WIP
09:02:25 <asalkeld> ttx yeah we have 2 days right?
09:02:32 <ttx> max 2 days yes
09:02:47 <asalkeld> so i can give them a day to progress?
09:02:54 <ttx> sure
09:03:05 <asalkeld> then ditch if needed
09:03:10 <asalkeld> there are not many
09:03:21 <ttx> just checking if they are likely to make it
09:03:33 <ttx> https://bugs.launchpad.net/heat/+bug/1295536 for example does not seem to belong in that category
09:03:43 <ttx> no movement on it since July
09:04:09 <ttx> we should at least move to to kilo-2, if not untarget it
09:04:16 <asalkeld> agree, just moved to k2
09:04:34 <ttx> been moved over sionce.. icehouse-rc1
09:04:44 <ttx> https://bugs.launchpad.net/bugs/1301314
09:04:48 <asalkeld> yeah
09:04:56 <ttx> same for that one
09:05:39 <ttx> no recent activity on it either, no reason to block on it
09:05:40 <asalkeld> yeah, i should remoev the in progress
09:05:48 <asalkeld> ttx that gone
09:05:56 <ttx> https://bugs.launchpad.net/heat/+bug/1396917
09:06:20 <ttx> ok, this one has a review up and relatively recent activity, let's keep it
09:06:43 <ttx> although i'd rate it "unlikely" too :)
09:06:46 <asalkeld> cool
09:06:50 <ttx> https://bugs.launchpad.net/heat/+bug/1402472
09:06:55 <ttx> this one is fresh and active
09:07:16 <ttx> OK, let's block on those 3, and we'll adjust as we go
09:07:29 <asalkeld> yip, only 3 in progress now
09:07:30 <asalkeld> ok
09:07:37 <asalkeld> looks good to me
09:08:01 <ttx> since you're ahead of me in earth rotation, we can close it on your Thursday evening
09:08:07 <ttx> which is my Thursday morning
09:08:19 <asalkeld> that would be great, just moved house
09:08:26 <ttx> around same time as now on Thursday
09:08:29 <asalkeld> feeling worn out
09:08:34 <asalkeld> ok
09:08:55 <ttx> alright! Thanks and talk to you later
09:09:04 <asalkeld> later
09:09:38 * ttx needs to send reminder for cross-project meeting, too
09:10:05 <ttx> johnthetubaguy: around?
09:10:11 <johnthetubaguy> ttx: yes
09:10:13 <ttx> #topic Nova
09:10:17 <ttx> johnthetubaguy: hi!
09:10:31 <ttx> https://launchpad.net/nova/+milestone/kilo-1
09:10:35 <ttx> Time for the big cleanup
09:11:05 <ttx> and try to focus review time on those that are just around the corner
09:11:09 <johnthetubaguy> yeah, that time was last week, and mikal said he would do that for me, I will try finish that off
09:11:25 <ttx> johnthetubaguy: would you like to have some time to do it now ? We can talk in a few
09:11:50 <johnthetubaguy> been out last week and yesterday, just got back to my desk this morning
09:12:01 <ttx> We can talk an hour from now if that helps
09:12:06 <johnthetubaguy> probably better for me to churn through these and get back to you
09:12:09 <ttx> since mikal can't make it
09:12:10 <johnthetubaguy> yeah, that should work
09:12:13 <johnthetubaguy> thanks
09:12:21 <ttx> alright, talk to you in ~one hour then
09:12:34 <johnthetubaguy> ack
09:12:36 * ttx can use the extra time too
09:12:39 * johnthetubaguy applies coffee
09:12:46 <ttx> oh, good idea.
09:12:51 * ttx fetches coffee
10:09:00 <ttx> johnthetubaguy: knock knock
10:10:12 <johnthetubaguy> ttx: hey, still churning through
10:10:28 <ttx> johnthetubaguy: I can give you a bit more time, and knock again in 20min
10:10:37 <johnthetubaguy> lots of people on #openstack-nova spotted me
10:10:48 <ttx> you triggered a panic I hope
10:11:08 <johnthetubaguy> ttx: sadly its not related
10:11:45 <ttx> johnthetubaguy: now or in 20min, your call
10:12:05 <johnthetubaguy> ttx: sorry, yeah, 20 mins would be better, sorry
10:12:11 <ttx> np
10:38:12 <ttx> johnthetubaguy: how about now ?
10:38:42 <johnthetubaguy> ttx: looking better now, whats the link to your magic spot implemented blueprints tool?
10:38:51 <ttx> http://status.openstack.org/release/
10:39:12 <ttx> but refreshed every 30min I think
10:39:51 <johnthetubaguy> cool
10:39:58 <ttx> nothing stands out as implemenetd there
10:40:10 <johnthetubaguy> yeah, I am going to do a manual check
10:40:17 <johnthetubaguy> seems the topic might be missing on quite a few of those
10:40:42 <ttx> so those are the ones that are supposedly on review
10:41:06 * ttx checks out the bugs to see if there are stale ones
10:41:15 <johnthetubaguy> seems nova-pagination is probably complete
10:41:43 <johnthetubaguy> oh, those bugs can probably all be kicked out, except pci-passthrough
10:41:56 <johnthetubaguy> but its worth a check
10:42:33 <ttx> https://bugs.launchpad.net/nova/+bug/1266962 not really in progress, moving
10:42:56 <ttx> will only keep those with a review + pci-passthrough
10:42:59 <johnthetubaguy> yeah, I moved it to kilo-2
10:43:01 <johnthetubaguy> yeah
10:43:05 <johnthetubaguy> just not done the bugs yet
10:43:32 <ttx> not sure what to do of https://bugs.launchpad.net/nova/+bug/1368260 -- seems partially fixed and stale
10:44:08 <ttx> https://bugs.launchpad.net/nova/+bug/1316271 stale, moved to k2
10:44:50 <ttx> https://bugs.launchpad.net/nova/+bug/1383465 -- probably worth prioritizing https://review.openstack.org/#/c/131321/ up just in case it can make it
10:45:09 <ttx> https://bugs.launchpad.net/nova/+bug/1385480 stale, moved to k2
10:45:46 <ttx> https://bugs.launchpad.net/nova/+bug/1266262 has seen no activity, so k2 it is too
10:46:35 <ttx> I don't think https://bugs.launchpad.net/nova/+bug/1368260 will make it either
10:46:46 <ttx> it's either already fixed or k2
10:47:34 <johnthetubaguy> yeah, looking at that
10:48:37 <ttx> parsing BP list now
10:49:03 <johnthetubaguy> I think there are loads of these that need to get kicked out too
10:49:10 <johnthetubaguy> only done the first pass there
10:49:28 <johnthetubaguy> but I hope to review some now ish, in the hope they could make it
10:49:48 <ttx> just checking for obvious stale ones
10:50:25 <ttx> https://blueprints.launchpad.net/nova/+spec/image-meta-try-system-meta-before-glance -- a bit unclear what this hinges on
10:51:16 <ttx> https://blueprints.launchpad.net/nova/+spec/anti-affinity-on-migration -- same question
10:52:47 <ttx> https://blueprints.launchpad.net/nova/+spec/libvirt-smbfs-volume-support might be completed
10:53:03 <ttx> see https://review.openstack.org/#/c/131734/
10:53:26 <johnthetubaguy> yeah, they look a bit messed up
10:53:29 <ttx> same for https://blueprints.launchpad.net/nova/+spec/nova-pagination
10:54:17 <ttx> and same https://blueprints.launchpad.net/nova/+spec/vmware-spbm-support
10:54:57 <ttx> and https://blueprints.launchpad.net/nova/+spec/virt-driver-cpu-pinning
10:55:14 <ttx> all the other ones have clear, open and active reviews
10:56:14 <ttx> so maybe prioritize checking on those 6
10:57:07 <ttx> and we can do another status check tomorrow morning ?
10:57:29 <johnthetubaguy> sounds like a plan
10:57:43 <johnthetubaguy> I will review those, in the hope of working out whats happening
10:57:56 <ttx> I bet the last 4 are complete :)
10:58:03 <ttx> and the first 2 won't make it :P
10:58:11 <ttx> ok, have a good day!
10:58:24 <johnthetubaguy> yeah, I think you probably right
10:58:34 <johnthetubaguy> catch you tomorrow
12:01:10 <dhellmann> ttx, I happen to be online early to deal with the sqlalchemy thing so if you want to chat now we can
12:59:35 <ttx> eglynn: o/
12:59:52 <ttx> dhellmann: missed your ping, I guess you'll be on in 20min
13:00:10 <eglynn> ttx: hey
13:00:13 <ttx> #topic Ceilometer
13:00:37 <eglynn> #link https://launchpad.net/ceilometer/+milestone/kilo-1
13:01:03 <ttx> so we have left...
13:01:05 <ttx> https://blueprints.launchpad.net/ceilometer/+spec/notification-coordination
13:01:08 <eglynn> so looking good, once we get notification-coordination landed (a couple spurious failures in the tests)
13:01:27 <eglynn> I've bumped the declarative-http-tests to kilo-2
13:01:44 <ttx> That's the two reviews at: https://review.openstack.org/#/q/topic:bp/notification-coordination,n,z
13:01:46 <ttx> ?
13:01:48 <eglynn> chdent had down an initial spike, but not enough progress to double down on it for k1
13:02:10 <eglynn> yep, that's the ones
13:02:21 <ttx> ok... and https://bugs.launchpad.net/ceilometer/+bug/1393328
13:02:26 <ttx> https://review.openstack.org/#/c/141698/
13:02:41 <ttx> Once those 3 merge I'll ping you and confirm we are good to go
13:02:49 <eglynn> yep, pretty trivial, we'll get that landed today I hope
13:02:54 <eglynn> coolness
13:03:04 <ttx> if not done by tomorrow we'll rediscuss
13:03:36 <eglynn> yep, shouldn't come to that
13:03:46 <ttx> sounds good. Questions ?
13:03:55 <eglynn> none from me
13:04:11 <ttx> ok then, we are all set
13:04:22 <eglynn> cool, thanks for your time :)
13:05:47 <ttx> SergeyLukjanov: around?
13:19:44 <ttx> dhellmann: around now ?
13:22:48 <dhellmann> ttx: here
13:23:01 <ttx> #topic Oslo
13:23:06 <ttx> https://launchpad.net/oslo/+milestone/kilo-1
13:23:16 <ttx> 2 blueprints still open
13:23:22 <ttx> https://blueprints.launchpad.net/oslo-incubator/+spec/graduate-oslo-context
13:23:35 <dhellmann> yeah, we're waiting on some requirements stuff to land for tooz to be finished
13:23:40 <ttx> was that completed ? or should we move it to k2 ?
13:24:01 <dhellmann> and the context thing is waiting on one patch, let me look if that's done
13:24:12 <ttx> dhellmann: do you have the link to the tooz requirements change ? Maybe I can help it
13:24:14 <dhellmann> no, that patch is WIP
13:24:30 <dhellmann> it's in the work items in the blueprint
13:24:37 <dhellmann> both of them
13:24:37 <ttx> ok
13:24:44 <dhellmann> they won't land until we fix the sqlalchemy issue
13:24:59 <dhellmann> but if you approve them, I can force them through after that blockage is fixed
13:25:18 <dhellmann> the 2nd is already approved
13:25:30 <ttx> https://review.openstack.org/#/c/140920/ is +2/aprv so should be ok. Let me review the other one
13:25:50 <ttx> pretty straightforward
13:26:12 <ttx> ok, so how about we keep tooz in scope, and move context to k2 ?
13:27:13 <dhellmann> ok. I thought thursday was the deadline, and assuming we can ever land anything I expect to get that to land this week
13:27:34 <ttx> well, if you think it can make it in the next day, we can wait
13:27:44 <dhellmann> I'll go ahead and move it up
13:28:22 <ttx> quick look at oslo-incubator changes to see if we can tag now or if there are things you'd like to wait on
13:28:28 <ttx> https://review.openstack.org/#/q/project:openstack/oslo-incubator+status:open,n,z
13:28:50 <ttx> Looks like there are a few things that could still make it with extra reviews today
13:28:54 <dhellmann> I'm not aware of anything other than removing the context code that we need to worry about
13:29:12 <dhellmann> I expect to be spending all day dealing with the setuptools/sqlalchemy/oslo.db thing so I don't plan to do any oslo reviews today
13:29:35 <ttx> dhellmann: hm, how about we talk again tomorrow and decide then ?
13:29:46 <ttx> looks like we'll see clearer at that point
13:30:10 <dhellmann> yeah, that sounds like a good plan -- sorry, this sort of surprise always seems to come up around a milestone, doesn't it?
13:30:21 <ttx> well, otherwise it's not fun
13:30:26 <dhellmann> heh
13:31:25 <ttx> about stable branches
13:31:40 <ttx> I pushed https://review.openstack.org/#/c/141769/ so that there is an oslo-stable-maint team
13:31:52 <dhellmann> ok
13:32:02 <ttx> (part of the "let's create project-specific stable review groups" effort)
13:32:13 <dhellmann> I haven't been able to get anyone to volunteer to be part of that, so I may just have to add it to the core responsibilities
13:32:16 <ttx> https://review.openstack.org/#/admin/groups/544,members
13:32:29 <ttx> I added the ones that were previously part of openstack-stable-maint
13:32:40 <dhellmann> ah, cool, that's good enough then
13:32:55 <ttx> let me know if you want someone else. We'll brief them with stable policy and add them
13:33:10 <SergeyLukjanov> ttx, sorry, I've been a bit later today, waiting for empty slot
13:33:13 <ttx> should overall be a lot more scalable
13:33:35 <ttx> dhellmann: that's all, I'll let you handle oslo.db now ;)
13:33:41 <ttx> questions ?
13:33:58 <dhellmann> ttx: no, I hope to have good news by the time we get to the project meeting but we'll see how it goes
13:34:18 <ttx> ack
13:34:25 <ttx> SergeyLukjanov: o/
13:34:34 <SergeyLukjanov> ttx, hi
13:34:39 <ttx> #topic Sahara
13:34:42 <ttx> https://launchpad.net/sahara/+milestone/kilo-1
13:34:54 <SergeyLukjanov> ttx, sorry about being late
13:34:59 <ttx> two bugs still open
13:35:06 <ttx> https://bugs.launchpad.net/sahara/+bug/1378967
13:35:11 <SergeyLukjanov> ttx, the cleanup is done and mostly everything planned merged
13:35:21 <ttx> unfixed for 2 months, any reason to think it will suddenly get better ?
13:35:42 <SergeyLukjanov> ttx, nope, both issues low prio
13:35:48 <SergeyLukjanov> ttx, moving them to k2
13:35:52 <ttx> Should we move them over and tag now ?
13:36:00 <SergeyLukjanov> ttx, hopefully there will be no new issues for k1
13:36:05 <ttx> anything in the pipe you'd like to wait for ?
13:36:24 <SergeyLukjanov> ttx, let me check
13:36:46 <ttx> or we can wait tomorrow morning and catch anything that will land until then
13:37:14 <SergeyLukjanov> ttx, I think everything is ok now but I prefer tomorrow morning
13:37:33 <ttx> ok!
13:37:58 <SergeyLukjanov> ttx, no questions from my side
13:38:17 <SergeyLukjanov> ttx, thank you
13:38:35 <ttx> SergeyLukjanov: ok!
13:38:40 <ttx> thanks
13:40:09 <ttx> SergeyLukjanov: just add to kilo-1 page if you find anything blocking
15:01:47 <mestery> ttx: here and waiting
15:01:55 <ttx> mestery: o/
15:02:02 <ttx> #topic Neutron
15:02:17 <ttx> https://launchpad.net/neutron/+milestone/kilo-1
15:02:45 <ttx> quite a few things still opened
15:02:55 <ttx> https://blueprints.launchpad.net/neutron/+spec/services-split
15:03:05 <ttx> anything left to do there before it's considered done ?
15:03:09 <mestery> Nope, it's done
15:03:13 <mestery> I just marked it complete now :)
15:03:17 <mestery> Was waiting for final word from doug this morning
15:03:20 <mestery> And just got it in neutron meeting
15:03:27 <ttx> https://blueprints.launchpad.net/neutron/+spec/neutron-ovs-dvr-vlan
15:03:49 <mestery> Kilo-2
15:03:50 <mestery> just moved it
15:03:51 <ttx> https://review.openstack.org/#/c/131800/ merged, so may be complete ?
15:04:01 * mestery looks
15:04:10 <mestery> Ah
15:04:12 <mestery> that was the spec
15:04:13 <mestery> ;)
15:04:16 <mestery> The code is delayed a bit
15:04:18 <ttx> oops
15:04:18 <mestery> so kilo-2 it is
15:04:21 <ttx> ok
15:04:34 <ttx> https://blueprints.launchpad.net/neutron/+spec/lbaas-api-and-objmodel-improvement
15:04:43 <mestery> That one *may* be done, I'll figure out this morning yet
15:04:49 <mestery> I need to talk to blogan this morning
15:05:01 <mestery> There are a LOT of reviews listed there :)
15:05:02 <ttx> Lots of stuff still open @ https://review.openstack.org/#/q/topic:bp/lbaas-api-and-objmodel-improvement,n,z
15:05:14 <ttx> https://blueprints.launchpad.net/neutron/+spec/report-ha-router-master
15:05:29 <ttx> same here
15:05:41 <mestery> Yes, I'll defer this one now
15:05:46 <ttx> https://blueprints.launchpad.net/neutron/+spec/ml2-cisco-nexus-mechdriver-providernet
15:06:02 <ttx> probably k2 too
15:06:06 <mestery> yes
15:06:35 <mestery> So, once I get a handle on https://blueprints.launchpad.net/neutron/+spec/lbaas-api-and-objmodel-improvement we'll be good to go
15:06:51 <ttx> there is a long list of bugs too, should be untargeted unless they are really close or you would like ot block on them
15:07:18 <ttx> or maybe wait until tomorrow to clean it up
15:07:18 <mestery> ttx: Yes, it's likely I'll untarget the ones which won't merge
15:07:25 <mestery> I'll take a crack today and finalize tomorrow
15:07:31 <mestery> You'll cut the release tomorrow then?
15:07:33 <ttx> ok
15:07:51 <ttx> we need to discuss a few things about the neutron-*aas
15:08:01 <mestery> Ready and waiting
15:08:16 <ttx> we said we would tag with same versions and attach tarballs to neutron milestone page
15:08:48 <ttx> we'll need to enable a few pre-release pipe jobs to make that happen
15:09:01 <mestery> Ah, ok, cool, that makes sense
15:09:02 <ttx> because currently nothing will happen on tag
15:09:11 <mestery> :)
15:09:17 <ttx> I'll propose a zuul layout change and ping you to +1 it
15:09:31 <mestery> Perfect, please do
15:09:58 <ttx> The other questiojn is about the stable branches. The neutron-*aas repos have stable/juno and stable/icehouse defined, although it doesn't make any sense there
15:10:10 <ttx> are you fine with us clearing them out ?
15:10:34 <mestery> Yes, that makes perfect sense, we brough them over to preserve history, but there will be no releases on those branches for services, so clearing it out makes sense.
15:10:39 <ttx> neutron-*aas stuff for stable/juno is actually in neutron stable/juno
15:10:45 <mestery> yes
15:10:46 <mestery> ;)
15:11:00 <ttx> ok, that will clarify, we don't really want stuff to be proposed there
15:11:22 <ttx> OK, I'll make both happen
15:11:32 <mestery> awesome, thanks!
15:11:51 <ttx> let me know when things are OK to tag. Otherwise I'll talk to you tomorrow
15:12:06 <mestery> Perfect, works for me, thanks ttx!
15:12:09 <ttx> mestery: thx!
15:18:35 <ttx> mestery: https://review.openstack.org/142126
15:19:10 <mestery> ttx: +1
15:19:44 <ttx> thx
15:23:43 <ttx> thingee: ready when you are
15:24:06 <thingee> thingee: hi
15:24:12 <thingee> ttx: rather hi :)
15:24:15 <ttx> #topic Cinder
15:24:30 <ttx> https://launchpad.net/cinder/+milestone/kilo-1
15:24:42 <ttx> Loads of stuff still open in there
15:24:53 <ttx> Let's see if we can separate the chaff from the wheat
15:25:23 <ttx> and keep those that can make it in the next coupld days
15:25:24 <thingee> yeah, so good news, four of those have +2/A...just failed yesterday because of a series of gate issues.
15:25:45 <ttx> let's quickly go through all of them
15:25:49 <thingee> ok
15:25:52 <ttx> https://blueprints.launchpad.net/cinder/+spec/db-migration-tests
15:26:25 <thingee> waiting in gate..failed jenkins
15:26:41 <ttx> Do you need https://review.openstack.org/#/c/141414/ as well ?
15:26:46 <ttx> (nice number)
15:27:05 <thingee> no
15:27:08 <ttx> https://blueprints.launchpad.net/cinder/+spec/filtering-weighing-with-driver-supplied-functions
15:27:18 <thingee> I can push that to k-2
15:27:31 <ttx> ok
15:27:36 <thingee> done
15:27:50 <ttx> https://blueprints.launchpad.net/cinder/+spec/dell-storage-center-block-storage-driver
15:28:05 <ttx> Looks like it could make it
15:28:25 <thingee> yup. had enough iterations on code review
15:28:28 <ttx> https://blueprints.launchpad.net/cinder/+spec/volume-type-description
15:28:48 <thingee> failed in gate..recheck is happening now
15:29:05 <ttx> only needs https://review.openstack.org/#/c/131871/ ?
15:29:25 <thingee> yes
15:29:26 <ttx> https://blueprints.launchpad.net/cinder/+spec/quobyte-usp-driver
15:29:38 <thingee> waiting on a dependency review
15:29:49 <thingee> otherwise approved
15:30:03 <ttx> ok
15:30:11 <ttx> https://blueprints.launchpad.net/cinder/+spec/srb-driver
15:30:48 <ttx> may make it
15:30:50 <ttx> I guess
15:30:50 <thingee> can make it. enough iterations on it already
15:31:00 <ttx> https://blueprints.launchpad.net/cinder/+spec/backup-notification
15:31:09 <ttx> in gate
15:31:23 <ttx> https://blueprints.launchpad.net/cinder/+spec/violinmemory-v6000-storage-drivers
15:31:44 <ttx> unlikely, but may make it
15:32:09 <thingee> agreed
15:32:12 <ttx> same for https://blueprints.launchpad.net/cinder/+spec/huawei-storage-drivers
15:32:52 <ttx> https://blueprints.launchpad.net/cinder/+spec/huawei-sdshypervisor-driver ... may make it I guess
15:33:16 <thingee> sds hypervisor will make it.
15:33:36 <ttx> https://blueprints.launchpad.net/cinder/+spec/open-vstorage-volume-driver is pretty close
15:33:53 <thingee> agreed
15:34:00 <ttx> https://blueprints.launchpad.net/cinder/+spec/cloudbyte-elastistor-cinder-driver
15:34:13 <ttx> hmm, not sure where that one is
15:34:53 <ttx> https://blueprints.launchpad.net/cinder/+spec/oracle-zfssa-nfs-cinder-driver looks a bit unlikely
15:34:54 <thingee> yeah. I don't think that one has a chance for k-1
15:35:04 <thingee> yup. a bit slow on responding back
15:35:25 <ttx> https://blueprints.launchpad.net/cinder/+spec/symantec-nfs-cinder-driver looks doable
15:35:32 <ttx> https://blueprints.launchpad.net/cinder/+spec/storpool-block-driver
15:35:42 <ttx> .. in gate
15:35:56 <ttx> and finally.. https://blueprints.launchpad.net/cinder/+spec/lvm-driver-for-shared-storage
15:36:09 <thingee> heh
15:36:13 <thingee> that's a special one.
15:36:19 <ttx> hmm, yes
15:36:29 <thingee> no one is sure on the use case. not looking good honestly
15:36:40 <thingee> because no one has reviewed it as a result.
15:36:56 <thingee> we just got cert results for it yesterday too
15:36:59 <thingee> might be bumped
15:37:05 <ttx> ok
15:37:27 <ttx> Looks like they still ahve a chance, but by tomorrow we'll bump most of them
15:37:59 <ttx> https://bugs.launchpad.net/cinder/+bug/1401137 -- not sure what to do with this one... is it likely to be closed ?
15:38:12 <ttx> maybe when storpool-block-driver merges ?
15:38:23 <thingee> oh, I'll untarget that
15:38:31 <thingee> I don't know why people do that with cert results
15:38:34 <ttx> alright!
15:38:57 <ttx> what do you plan to do with those who will miss k1 ? Delay them until L ?
15:39:20 <ttx> or grant k2 dribver exceptions case by case ?
15:39:23 <thingee> so there was a point in my mailing list post that drivers close to being merged will be granted into for reviews in k-2
15:39:41 <ttx> ok
15:39:58 <ttx> so not too much tears to be expected tomorrow
15:40:14 <thingee> right, it wouldn't be fair.
15:40:36 <ttx> Also might let us close tomorrow rather than Thursday, less pressure
15:40:51 <ttx> Will ping you tomorrow (in your morning) to see where we stand
15:40:53 <thingee> I'll see that it happens
15:41:04 <thingee> sure
15:41:13 <ttx> ok, questions ?
15:41:17 <thingee> nope!
15:41:27 <ttx> ok then, have a nice day!
15:41:35 <thingee> have a nice evening
15:41:44 <ttx> next we have.. david-lyle
15:41:53 <david-lyle> o/
15:42:06 <ttx> #topic Horizon
15:42:07 <ttx> https://launchpad.net/horizon/+milestone/kilo-1
15:42:17 <ttx> 3 Bps still open
15:42:23 <ttx> https://blueprints.launchpad.net/horizon/+spec/heat-topology-display-improvement
15:42:41 <david-lyle> just need reviews on all 3
15:42:45 <ttx> Looks like it could make it to the finish line
15:42:54 <ttx> https://blueprints.launchpad.net/horizon/+spec/glance-metadata-definitions-base-admin-ui
15:43:19 <david-lyle> that one is larger, and may need another patch, but it would be nice to get in k-1
15:43:32 <ttx> yeah, feels further away, been there forever
15:43:42 <ttx> https://blueprints.launchpad.net/horizon/+spec/make-batchaction-help-text-configurable
15:44:04 <ttx> two reviews, pretty close
15:44:22 <ttx> OK, we'll see what goes in tomorrow and if we can tag then
15:44:27 <ttx> on the bugs side...
15:44:29 <david-lyle> sure
15:44:48 <ttx> anything that needs ot get in k1, or we can defer anything that misses the tag ?
15:44:53 <ttx> to*
15:45:15 <david-lyle> all can defer to k-2
15:46:16 <ttx> ok, sounds good. You can send me a SHA when you're happy, or we can talk again tomorrow and see
15:46:33 <david-lyle> ok, I can send you the SHA
15:46:34 <ttx> questions on your side?
15:47:14 <david-lyle> no
15:47:39 <ttx> ok the, have a good day!
15:47:43 <ttx> then,*
15:48:00 <david-lyle> after the holidays, I'd like to have a dicussion on policy in the cross-project meeting, but I'm not ready for that yet
15:48:31 <ttx> ok, sure.. just add tto the wiki page when ready (at least one day before if you want it on the agenda)
15:49:07 <david-lyle> ok, will do, thanks
15:49:36 <david-lyle> talk to you later
15:49:49 <ttx> same!
16:52:18 <ttx> notmyname: around?
16:56:36 <ttx> morganfainberg: ready when you are
16:56:42 <morganfainberg> ttx o/
16:56:50 <ttx> #topic Keystone
16:57:00 <ttx> https://launchpad.net/keystone/+milestone/kilo-1
16:57:12 <ttx> a few bugs left
16:57:17 <ttx> https://bugs.launchpad.net/keystone/+bug/1398470
16:57:20 <morganfainberg> yep, and those are being actively chased.
16:57:27 <ttx> in gate
16:57:48 <morganfainberg> the other two just were respun to address comments minutes ago
16:58:06 <ttx> https://review.openstack.org/#/c/130474/ depends on outdated one
16:58:10 <ttx> but yes, all those are active
16:58:31 <morganfainberg> oh that was just updated recently, i'll get that one rebased.
16:58:36 <ttx> OK, sounds like we are seeing the light at the end of the tunnel
16:58:43 <morganfainberg> but i expect the three to merge today / in gate today
16:58:55 <ttx> should be all set tomorrow. Ok
16:58:57 <morganfainberg> i punted everything else that was even close to being in jeapordy to k2
16:59:13 <ttx> Send me a SHA when you notice it's ready, or I'll ping you again tomorrow for a new status update
16:59:36 <ttx> sounds like a plan ?
17:00:07 <morganfainberg> yep
17:00:09 <morganfainberg> sounds good
17:00:18 <ttx> alright then, have a good day!
17:00:23 <morganfainberg> same to you!
17:00:37 <ttx> still no notmyname ?
17:01:04 * ttx quickly writes an unrelated email then
17:02:21 * SlickNik is here
17:03:22 <notmyname> ttx: here now
17:03:24 <notmyname> sorry. slow commute
17:05:29 <ttx> notmyname: no pb
17:05:33 <ttx> #topic Swift
17:05:54 <ttx> How is your 2.2.1.r^H^Hc1 doing ?
17:06:08 <notmyname> good. granted, it's only been live for less than 24 hours :-)
17:06:48 <ttx> Don't hesitate to populate https://launchpad.net/swift/+milestone/2.2.1 with key feature(s) for promotion purposes
17:07:06 <notmyname> I will. that's on my list for today/tomorrow
17:07:23 <notmyname> again, we're expecting another release mid to end of january
17:07:33 <ttx> Those bugs you mentioned in your email... that would be for that end-of-january release ?
17:07:38 <notmyname> yes
17:07:46 <ttx> #info Swift expecting another release mid to end of january
17:07:51 <ttx> notmyname: ok
17:07:52 <notmyname> basically, we're still working on them, and they're tricky :-)
17:08:03 <ttx> well, you better get the fix right in that area :)
17:08:16 <notmyname> something something data placement across thousands of drives and multiple region migration paths etc
17:08:38 <notmyname> oh, also make it work for 2 servers ;-)
17:08:39 <ttx> yeah, I quicklooked into the descriptions, definitely tricky
17:09:01 <notmyname> anyway, good progress is being made, but still working on it
17:09:19 <ttx> ok then, just ping me if there are issues with the c1. Wez plan to tag the final on.. Friday, right?
17:09:40 <notmyname> yes. that's the current plan
17:09:45 <ttx> alright then
17:09:51 <ttx> have a great day!
17:10:01 <notmyname> thanks. you too
17:10:10 <ttx> devananda: around?
17:10:42 <ttx> SlickNik: you can jump the queue
17:10:51 <ttx> First reply wins
17:10:54 <SlickNik> ttx: thanks
17:11:01 <ttx> #topic Trove
17:11:04 <ttx> and Trove wins
17:11:05 <SlickNik> if devananda isn't around
17:11:20 <ttx> https://launchpad.net/trove/+milestone/kilo-1
17:11:28 <ttx> Looks pretty much complete to me
17:11:35 <ttx> Antthing you're waiting on ?
17:11:39 <ttx> -t+y
17:11:46 <SlickNik> ttx, nope. We should be set.
17:12:04 <ttx> SlickNik: would you like to wait until tomorroiw to tag ? Or should we just tag now and call it done ?
17:12:30 <ttx> Or I can tag it in my tomorrow morning if it's still all-green. How is that?
17:12:53 <SlickNik> There were a couple of things that were not blocking, but between reviews and gate issues, it was easier to move it to kilo-2.
17:13:00 <SlickNik> Either way.
17:13:07 * ttx tags now then
17:13:07 <devananda> ttx: here
17:13:17 <SlickNik> Now is good if you have the time.
17:13:36 <SlickNik> devananda: I took your spot, but shouldn't take long. :)
17:13:45 <ttx> famous last words
17:13:47 <devananda> np :)
17:14:29 <ttx> tag in progress
17:14:40 <SlickNik> ttx; lol
17:14:42 <ttx> hmmmm
17:14:57 * ttx may have to tweak that script in the new setuptools world
17:15:21 <SlickNik> uh-oh — better to wait till tomorrow then.
17:16:08 <ttx> asked in infra
17:16:57 <SlickNik> yeah — just saw that.
17:19:10 <ttx> ok, let's talk to deva in parallel
17:19:20 <ttx> #action ttx to tag Trove
17:19:26 <ttx> #topic Ironic
17:19:42 <SlickNik> Okay — thanks ttx
17:19:49 <ttx> devananda: o/
17:19:58 <devananda> ttx: two BP's still targeted to k1
17:20:04 <devananda> both have code up and under review
17:20:14 <ttx> https://launchpad.net/ironic/+milestone/kilo-1
17:20:26 <ttx> should i set "logical names" to needs code review" then ?
17:20:39 <devananda> I'll keep managing the status on there, as soon as it's all green, tagging is good
17:20:48 <devananda> ah - sure
17:21:17 <ttx> is there a review up for https://bugs.launchpad.net/ironic/+bug/1271317 ?
17:21:46 <ttx> feels a bit far away
17:22:16 <devananda> indeed. /me removes
17:22:53 <devananda> we are going to have a bug status review day after the milestone is tagged
17:23:00 <ttx> OK, send me email when I can tag, if I don't get any I'll sync up again tomorrow
17:23:09 <devananda> ack
17:23:18 <ttx> I can also trigger tag automatically on all-green on that page if you're fine with it
17:23:30 <ttx> one less email in this world
17:23:31 <devananda> yup, that's fine
17:23:51 <ttx> sounds like a plan
17:24:00 <ttx> any question, last words ?
17:24:39 <ttx> SlickNik: ok, will tag as soon as I know what format tags should have those days
17:24:45 <devananda> nope :)
17:25:05 <ttx> #endmeeting