09:22:35 <ttx> #startmeeting ptl_sync
09:22:36 <openstack> Meeting started Tue Feb 10 09:22:35 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:22:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:22:38 <Johnthetubaguy-w> :)
09:22:40 <openstack> The meeting name has been set to 'ptl_sync'
09:22:43 <ttx> #topic Nova
09:22:56 <ttx> #link https://launchpad.net/nova/+milestone/kilo-3
09:23:17 <ttx> That list, I assume, represents the "priorities" + the accepted FFEs ?
09:23:36 <Johnthetubaguy-w> Yeah, bit messy right now, I should start pinging folks for code
09:23:59 <Johnthetubaguy-w> Yeah, that's the plan, no ffe yet though
09:24:29 <ttx> Looking at deadlines again... for Nova you're in non-priority feature freeze already
09:24:56 <ttx> And you'll have the general FF at kilo-3
09:25:04 <Johnthetubaguy-w> Yes, we set a deadline for ffe requests of Thursday
09:25:05 <ttx> Feature proposal freeze on March 5 ?
09:25:32 <ttx> (i.e. code for all those k3 things must be proposed by then)
09:25:32 <Johnthetubaguy-w> Yes, I think we should just match the general dates there
09:25:58 <ttx> OK, how is the FFE process doing ? Lots of them as I expected.. 2 months freeze is just too long for most people
09:26:30 <Johnthetubaguy-w> Cells will be close to the wire on that, others should be close, but I should advertise that date more
09:27:06 <ttx> Ar eth "medium" in the k34 list priority stuff, or FFEd stuff ?
09:27:12 <Johnthetubaguy-w> So the plan is we will have a drivers meeting to decide if any should get in, we hope not
09:27:21 <ttx> err, I mean the "mediums" in the k3 list
09:28:10 <Johnthetubaguy-w> Mediums are all priority items, I should check the priorities again
09:28:17 <ttx> ok
09:28:30 <ttx> No hurry, just refine the list as you go
09:28:58 <ttx> I won't get involved in FFEs until we reach the general Feature Freeze and they start affecting the stability of the end release
09:29:10 <ttx> so I'll let you run through them
09:29:51 <ttx> That's about all I had. I propose we skip 1:1s next week
09:29:51 <Johnthetubaguy-w> OK cool, that sounds the efficient way, we will get you to bless any final ffe this time, sorry about last time!
09:30:02 <Johnthetubaguy-w> Makes sense
09:30:14 <ttx> anything else on your mind?
09:30:26 <Johnthetubaguy-w> Thanks for keeping us on track though, it really helps!
09:30:40 <Johnthetubaguy-w> Nothing more from me really
09:30:44 <ttx> Oh, we'll discuss novanet2neutron status at the cross-project meeting today. You might want to ensure some nova people are present
09:31:13 <Johnthetubaguy-w> Ah, we have jogo and anyeta that cover that
09:31:23 <ttx> cool
09:31:30 <Johnthetubaguy-w> I will try ping them later
09:31:39 <ttx> OK, have a good train ride
09:31:46 <ttx> I pinged anteaya already
09:31:47 <Johnthetubaguy-w> Thanks:)
09:31:52 <Johnthetubaguy-w> Cool
09:32:05 * ttx grabs coffee
09:32:05 <Johnthetubaguy-w> Tunnel soon, so just in time!
09:32:06 * anteaya has been pinged
13:00:12 <ttx> eglynn: ohai
13:00:19 <eglynn> ttx: hola!
13:00:21 <ttx> #topic Ceilometer
13:00:37 <ttx> #link https://launchpad.net/ceilometer/+milestone/kilo-3
13:00:55 <ttx> That "unknown in the list is actually "not started" I suppose ?
13:01:08 <eglynn> yes, I'll update that
13:01:24 <ttx> ok, otherwise looks good
13:01:56 <ttx> As far as deadlines go, I just have Feature Freeze for ceilometer on March 19 like veryone else
13:02:17 <ttx> Do you plan to enforce FeatureProposalFreeze (feature code must be proposed) on March 5 ?
13:02:27 <eglynn> we spoke about a FPF two week prior to that
13:02:32 <eglynn> yep, exactly
13:02:35 <ttx> ok, that corresponds
13:03:02 <ttx> Any other deadlien I missed ?
13:03:09 <eglynn> nope that's it
13:03:24 <eglynn> BTW I put in provisional numbers for summit sessions in https://docs.google.com/spreadsheets/d/14pryalH3rVVQGHdyE3QeeZ3eDrs_1KfqfykxSTvrfyI/edit#gid=610965958
13:03:33 <ttx> cool thx
13:03:37 <eglynn> I'll discuss at team meeting on Thurs before finalizing
13:03:50 <ttx> I don't really need a final number
13:04:04 <eglynn> a-ha, k, just a general indication?
13:04:09 <ttx> it's more to work on the room layout to fuzzy-match the requests
13:04:23 <ttx> since I have to decide on room layout very soon
13:04:35 <eglynn> k
13:04:45 <ttx> Final allocations we can't really do until we know which project teams we'll have
13:04:56 <ttx> I propose we skip 1:1s next week
13:05:05 <ttx> since this is early in k3 period
13:05:06 <eglynn> cool with me
13:05:19 <ttx> alright then, that's all I had
13:05:25 <eglynn> one very general question for you ...
13:05:29 <eglynn> more TC-level in fact
13:05:37 <ttx> sure, ask
13:06:02 <eglynn> when do you expect to start accepting "applications" for stackforge projects to be big-tented?
13:06:16 <ttx> That's actually something we'll discuss today
13:06:27 <ttx> The criteria is up so we could accepot them now
13:06:38 <eglynn> a-ha, cool
13:06:41 <ttx> just want to check if that is ok with other members
13:06:52 <ttx> The goal being to process them before the L design summit
13:06:58 <ttx> so that we can give those teams room
13:07:14 <eglynn> (reason I ask is that jd is thinking of taking gnocchi down that route)
13:07:42 <ttx> I almready have the security group (OSSG) wanting its own offciial team recognized
13:07:49 <ttx> so they asked too
13:07:56 <eglynn> coolness
13:08:12 <ttx> alright, have a good week!
13:08:22 <eglynn> you too, thanks for your time!
13:08:25 <ttx> SergeyLukjanov: ready when you are
13:11:02 <dhellmann> ttx: I'm around, if SergeyLukjanov isn't ready
13:11:08 <ttx> #topic Oslo
13:11:12 <ttx> dhellmann: ok, let's do that
13:11:16 <SergeyLukjanov> oops, soory, I'm here
13:11:23 <SergeyLukjanov> will wait
13:11:29 <ttx> SergeyLukjanov: too late :)
13:11:35 <ttx> #link https://launchpad.net/oslo/+milestone/kilo-3
13:11:37 <dhellmann> sorry to steal your spot SergeyLukjanov
13:12:23 <SergeyLukjanov> dhellmann, that's ok :)
13:12:31 <ttx> So that would be 4 graduations still planned before end of kilo ?
13:12:47 <ttx> + some extra features in oslo.cache but worked in the incubator
13:12:50 <dhellmann> versionedobject and policy are definite
13:13:03 <dhellmann> debtcollector, too
13:13:21 <dhellmann> I haven't seen any progress at all on the reports one, so I'll have to check with solly about that
13:13:41 <ttx> #link https://launchpad.net/oslo/+milestone/next-kilo
13:14:06 <ttx> I don't see major features there, which is probably a good thing
13:14:45 <dhellmann> yeah, most of the work in the libs at this point is around bugs
13:14:45 <ttx> dhellmann: looking at the release schedule, I don't see anything specific for Oslo
13:14:57 <dhellmann> do you mean like freeze dates?
13:15:01 <ttx> that means FF on kilo-3 (March 19)
13:15:03 <ttx> yes
13:15:21 <ttx> Do you plan somethign like FeatureProposalFreeze two weeks before ?
13:15:21 <dhellmann> ok, I talked to the team about using 12 Mar instead, to give us a week
13:15:27 <dhellmann> just 1 week, but yeah
13:15:44 <ttx> So.... feature freeze on Mar 12 ?
13:15:55 <dhellmann> I think it's safe to assume that we'll do that each cycle -- freeze 1 week before everyone else
13:15:56 <dhellmann> yes
13:16:03 <ttx> ok adding
13:16:40 <ttx> done
13:16:45 <ttx> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
13:17:11 <ttx> Do you plan to enforce a feature proposal freeze one or two weks before that ?
13:17:40 <ttx> (deadline for feature code to be proposed for review)
13:17:41 <dhellmann> probably, although we didn't discuss that specifically
13:17:52 <ttx> ok, the general one is on March 5
13:17:55 <ttx> just so you know
13:18:02 <dhellmann> let's keep the same date for now
13:18:26 <ttx> In other news I propose we skip 1:1s next week
13:18:30 <dhellmann> if the feature is small, it might make it, otherwise it wouldn't make it in time anyway so it would freeze naturally
13:18:41 <dhellmann> ok
13:18:46 <ttx> anything on your mind ?
13:19:10 <dhellmann> this thing with stable requirements management is pretty far out of hand
13:19:37 <ttx> dhellmann: yeah, I wanted to circle back with you on that
13:19:48 <dhellmann> I think jogo and mtreinish worked out most of what to do, and oslo is no longer running the stable tests so we're not blocked any more, but we need to find an owner for requirements management
13:19:55 <dhellmann> all of the people doing it are part time
13:20:16 <ttx> dhellmann: yeah
13:20:28 <dhellmann> and by "not blocked" for Oslo, I mean we can land patches but not release anything -- we had 4+ releases planned for this week
13:20:35 <dhellmann> and we do have projects waiting for them
13:20:35 <ttx> dhellmann: We could also do a virtual sprint to align all the stars
13:20:54 <dhellmann> it would be a good idea to at least hold a meeting of some sort
13:21:05 <ttx> because sometimes it feels like it's just we are not focused on the same plan at the same time
13:21:18 <dhellmann> oh, you meant that figuratively, yeah a sprint is a good idea, too
13:21:45 <ttx> We all seem to have one piece of the puzzle
13:22:32 <ttx> when you say "an owner for requirements management" what would that person do ?
13:22:41 <dhellmann> every time we think we have it figured out, another aspect comes up
13:22:53 <dhellmann> maybe I just mean an owner for solving the current problem we have
13:23:21 <dhellmann> but I know I've been reluctant to approve new requirements because they are triggering so many issues, so keeping an eye on reviews would be good, too
13:23:46 <ttx> It feels like we need to solve the issue once and for all, and then we can live happily ever after
13:23:59 <ttx> I expect stable branch chamions to spend more time on requireemnts and less tiem unwedging the gate
13:24:01 <dhellmann> at least until the next big issue :-)
13:24:14 <ttx> once we cap things
13:24:53 <ttx> I'm pretty sure they would prefer watching stable requirements caps than working out which event broke the stable gate
13:25:07 <dhellmann> yeah, I know one or two have been involved in this, but I'm surprised there hasn't been more of a concerted effort from the primary stable team on this. I'm worried we think we have more support there than we do.
13:25:40 <dhellmann> maybe it's a matter of understanding the problem -- I don't have a lot of insight into the stable maint stuff this cycle, aside from these requirements-related issues
13:25:56 <ttx> A champion is supposed to drum the beat to get more support, rather than do all the work themselves. One issue is that recently they have been stumped in fixing things
13:26:30 <ttx> So it feels like they thought they would be able to handle it.. but then it broke faster than they could solve it
13:26:45 <dhellmann> that sounds about right
13:26:47 <ttx> especially since those are not experts in QA/gate/tempest
13:27:09 <ttx> anyway, topic for discussion tonight at the cross-project meeting
13:27:22 <dhellmann> ++
13:28:04 <ttx> SergeyLukjanov: still around ?
13:28:09 <SergeyLukjanov> yup
13:28:24 <dhellmann> thanks, ttx
13:29:01 <ttx> #topic Sahara
13:29:02 <ttx> #topic Sahara
13:29:10 <SergeyLukjanov> #topic https://launchpad.net/sahara/+milestone/kilo-3
13:29:20 <ttx> #undo
13:29:21 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x978a350>
13:29:23 <ttx> #link https://launchpad.net/sahara/+milestone/kilo-3
13:29:30 <SergeyLukjanov> oops, sorry
13:29:36 <SergeyLukjanov> it's not a topic, heh
13:29:40 <ttx> k3 page looks good
13:29:50 <ttx> add-lib-subset-cm-api locked on spec approval...
13:30:58 <ttx> Looking at deadlines... any specific thing for you ?
13:31:08 <ttx> FF on Mar 19, FPF on Mar 5 like everyone else ?
13:31:20 <SergeyLukjanov> hm
13:31:29 <SergeyLukjanov> yup, I think it's ok for us too
13:31:45 <SergeyLukjanov> (was counting number of weeks before it)
13:32:22 <ttx> alright. All sounds good and aligned.
13:32:24 <SergeyLukjanov> the deadlines are ok for us
13:32:28 <ttx> We'll skip 1:&s next week
13:32:32 <ttx> 1:1s
13:32:36 <SergeyLukjanov> okay, ack
13:32:45 <ttx> SergeyLukjanov: anything on your mind ?
13:32:54 <SergeyLukjanov> nope, i'm all set
13:34:28 <ttx> SergeyLukjanov: alright, have a good day!
13:34:45 <SergeyLukjanov> ttx, thx, you too
14:39:18 <nikhil_k> ttx: I'm here early if you've time for sync. Have a quite a few items today
14:44:22 <ttx> nikhil_k: sure, let me do a biobreak and i'll be there for you in 2min
14:44:31 <nikhil_k> sure :)
14:44:32 <nikhil_k> thanks
14:47:00 <ttx> #topic Glance
14:47:04 <ttx> nikhil_k: o/
14:47:08 <nikhil_k> o/
14:47:11 <ttx> #link https://launchpad.net/glance/+milestone/kilo-3
14:47:29 <ttx> https://blueprints.launchpad.net/glance/+spec/catalog-index-service is unprioritized
14:47:45 <ttx> Otherwise looks good
14:47:52 <nikhil_k> done
14:48:16 <ttx> Taskflow integration landed just after k2 right
14:48:21 <nikhil_k> yes
14:48:46 <ttx> Any specific deadline in k3 apart from feature freeze on March 19 ?
14:49:02 <ttx> Planning to enforce a Feature Proposal Freeze on March 5 as well ?
14:49:28 <nikhil_k> ttx: not yet, I will have to confirm that to you next week. Sorry
14:49:44 <ttx> ok
14:50:09 <ttx> Although next week I planned to skip 1:1s. So just send me an email instead and i'll update https://wiki.openstack.org/wiki/Kilo_Release_Schedule
14:50:25 <nikhil_k> Thanks, that sounds good
14:50:34 <ttx> All good to me; anything else you wanted to discuss ?
14:51:04 <nikhil_k> yes :)
14:51:18 <nikhil_k> I wanted to propose zhiyan for stable core maint
14:51:52 <nikhil_k> He has been a long standing consistent reviewer for glance and is interested in becoming the stable-core-maint for the same
14:52:18 <ttx> ok, could you send an email to list with [stable] prefix suggesting him ? I'll reach out to check that he is aware of policy and then add him
14:52:31 <nikhil_k> ttx: Thanks, will do.
14:52:39 <ttx> anything else ?
14:52:59 <nikhil_k> ttx: What can we do for situations like these https://review.openstack.org/#/c/154229/ ?
14:53:18 <nikhil_k> We would like to change the API (without bumping up the versions)
14:53:37 <nikhil_k> And, I _think_ no one is using it and it's fairly recent
14:53:57 <ttx> If it's not "released" yet I think it's fair game to fix it
14:54:14 <nikhil_k> (though) It's a blunder really
14:54:22 <ttx> maybe raise a small thread so that people are aware just in case
14:54:33 <nikhil_k> ttx: oh, like you mean as in kilo?
14:54:34 <ttx> how long has this code been around?
14:54:36 <nikhil_k> ttx: surely
14:54:44 <nikhil_k> https://review.openstack.org/#/c/133874/
14:54:47 <nikhil_k> Dec 18
14:55:03 <ttx> yes, I thinkn it's fair game
14:55:16 <nikhil_k> ttx: There is no client support for this and they realized it after trying to add support there
14:56:34 <nikhil_k> ttx: also, Horizon would be a primary consumer and they are very likely not using it as glanceclient does not support it yet
14:56:53 <nikhil_k> I will start email thread but just wanted it to be out there
14:57:01 <nikhil_k> pretty disappointing
14:57:16 <ttx> well, shit happens
14:57:24 <nikhil_k> heh
14:57:35 <ttx> anything else ?
14:58:03 <nikhil_k> I think we may have a bit heavy handed k3
14:58:19 <nikhil_k> I've not added a few spec to the list
14:58:40 <ttx> Generally asking if things can wait until l1 is a good way to push back things preventively
14:58:46 <ttx> and switch focus to reviews
14:59:07 <nikhil_k> makes sense
14:59:15 <nikhil_k> I think people would not want to wait
14:59:30 <nikhil_k> but, I would like to plan it with you better this time and keep this communicated with community
14:59:41 <nikhil_k> may be we will need FFE for 2-3 specs
14:59:52 <nikhil_k> (I mean that's a possibility)
15:00:08 <ttx> ok
15:00:22 <nikhil_k> That was it from my end
15:00:37 <ttx> alright, have a good day!
15:00:47 <nikhil_k> Have a good one, yourself!
15:00:57 <nikhil_k> Appreciate the time adjustment :)
15:01:14 <ttx> np
15:30:25 <ttx> thingee: o/
15:30:31 <thingee> ttx: hey!
15:30:37 <ttx> #topic Cinder
15:30:52 <ttx> #link https://launchpad.net/cinder/+milestone/kilo-3
15:30:55 <ttx> Busy milestone
15:31:05 <thingee> ttx: ok so I know this looks bad. I got some explaining to do.
15:31:19 <ttx> The 3 'implemented' ones... were they fixed post-k2 ?
15:31:37 <ttx> or was one of them actually completed in k2 and we missed it
15:31:39 <thingee> nope. I checked last minute stuff before you tagged things
15:31:44 <ttx> ok
15:31:53 <thingee> that's why it took me a bit of time to give the ok
15:32:28 <thingee> so I realized a lot of people just put up a patch that do driver updates of some new feature. We never really strictly tracked those before
15:32:44 <thingee> I really wanted to start tracking those to understand how over subscribed we were.
15:33:03 <ttx> the way it looks now it's doable if you only do reviews from now to FF :)
15:33:16 <thingee> luckily I can say three were pretty close in k-2 and are done now.
15:33:26 <thingee> and there are two more just about done as of last night.
15:33:35 <thingee> So I like to be optimistic and think 26 here :)
15:33:59 <ttx> ok
15:34:17 <ttx> I have a few deadlines for you in k3
15:34:17 <thingee> left to do anyways. I have removed some I wasn't sure were going to happen because I haven't seen code or contact from the assignee
15:34:19 <ttx> Cinder spec approval deadline (Feb 15)
15:34:24 <ttx> Cinder feature freeze (Mar 10)
15:34:36 <thingee> those are correct
15:34:50 <ttx> Do you plan any Feature Proposal Freeze ? The general one is March 5 so a bit close to your proposed ff
15:35:01 <ttx> (FPF = code must be up for review)
15:35:42 <thingee> Might need a bit more time with the code freeze
15:36:16 <ttx> well, if you have a date I can add it to the schedule
15:36:19 <ttx> so just let me know
15:36:28 <thingee> march 2nd? I'll have to talk to the team
15:36:53 <ttx> There was also some confusion about whether Cinder was frozen, on one ml thread
15:36:54 <thingee> I always get the dates in agreement from people in our meeting.
15:37:11 <ttx> my understading is that it's under non-priority feature freeze
15:37:17 <thingee> ok, if it was sent yesterday, I was mostly on a plane all day so I'll reply.
15:37:26 <thingee> thank goodness for gertty
15:37:33 <ttx> heh
15:37:56 <ttx> I plan to skip 1:1s next week
15:38:06 <thingee> ok, I'll update my calendar accordingly
15:38:10 <ttx> That's all I had -- anything on your side ?
15:38:28 <thingee> Nope, I'm good!
15:38:55 <ttx> thingee: cool, have a great day
15:39:02 <ttx> david-lyle: ready when you are
15:39:04 <thingee> you too
15:39:11 <david-lyle> ttx: ready
15:39:11 <thingee> even that is
15:39:14 <thingee> evening*
15:39:16 <ttx> #topic Horizon
15:39:27 <ttx> #link https://launchpad.net/horizon/+milestone/kilo-3
15:39:46 <ttx> A bit of cleanup might be necessary there
15:39:56 <david-lyle> ttx: indeed
15:40:08 <david-lyle> will start on that
15:40:08 <ttx> In particular unassigned blueprints, "unknown" delivery and "undefined" priorities
15:40:24 <ttx> no hurry for today, but would be good to fix it in the next 2 weeks
15:40:36 <ttx> It also looks a bit long
15:40:40 <david-lyle> ttx: it is
15:41:01 <david-lyle> I have in mind some that aren't going to make it
15:41:05 <david-lyle> will start dropping
15:41:16 <ttx> as a comparison point, you got 9 implemented in k1 and k2
15:41:29 <david-lyle> that was lower than normal
15:41:36 <ttx> so even taking into account abusier milestone, I don't think you can get above 25 :)
15:41:49 <david-lyle> we have some big ticket items have taken longer
15:42:11 <david-lyle> really I have 4-5 highs that I want to land, the rest are opportunistic
15:42:33 <ttx> ok, makes sense
15:42:53 <ttx> I don't have any specific deadline noted for Horizon in k3
15:42:54 <david-lyle> we don't really have a great system for that
15:43:01 <ttx> so that means aligning with FF on March 19
15:43:13 <ttx> Do you plan to enforce FPF on March 5 as well ?
15:43:24 <david-lyle> yes
15:43:27 <ttx> FPF = All feature code up for review
15:43:30 <ttx> alright
15:43:45 <david-lyle> I'll start publicizing that in Horizon
15:43:52 <ttx> Last thing, I propose we skip 1:1s next week, not much to report early in milestones
15:44:01 <david-lyle> sure, not a problem
15:44:15 <ttx> alright, anything on your side ?
15:44:36 <david-lyle> for L, horizon would like to formally move to specs, what do I need to do to start that process?
15:44:55 <ttx> david-lyle: ask infra to create a repo
15:45:09 <david-lyle> ok, will do
15:45:10 <ttx> or propose it yourself, following the infra manual
15:45:22 <david-lyle> ok, I can look at that too
15:45:32 <ttx> then add the repo name to projects.yaml in governance and you shall be set
15:45:54 <david-lyle> also I proposed an ATC exception https://review.openstack.org/#/c/154271/
15:46:10 <david-lyle> main UX contributor to Horizon for Kilo
15:46:23 <david-lyle> would like to see him acknowledged
15:46:38 <david-lyle> hopefully that can make it on the TC agenda
15:46:38 <ttx> sure, will be on docket for next week meeting
15:46:43 <david-lyle> perfect
15:46:44 <david-lyle> thanks
15:46:58 <ttx> neds to be up for a couple days before we can actually vote on it
15:47:02 <ttx> needs*
15:47:10 <david-lyle> no problem
15:47:21 <ttx> anything else ?
15:47:27 <david-lyle> I'm set
15:47:37 <ttx> alright then. Have a good day !
15:47:48 <david-lyle> you too
15:47:50 <david-lyle> thanks
16:43:50 <ttx> notmyname: I suspect you're knee deep in your hackathon, we can skip this week 1:1s if that's more convenient for you
16:44:06 <notmyname> ttx: I'm here
16:44:09 <notmyname> I've got time
16:44:17 <notmyname> there's one thing to let you know of
16:44:22 <ttx> ok, want to talk now ?
16:44:25 <notmyname> yup
16:44:26 <ttx> #topic Swift
16:44:40 <notmyname> #info there is now a feature/crypto branch in Swift
16:44:50 <notmyname> did you see the scrollback from -infra yesterday?
16:45:12 <notmyname> if not I can sumarize
16:45:15 <ttx> notmyname: hmm, not really, only the review that proposed a clarification in infra manual
16:45:33 <notmyname> right
16:45:41 <notmyname> that's basically it. https://review.openstack.org/#/c/154286/
16:45:53 <notmyname> to coordinate things through the release manager
16:46:07 <ttx> right converge names when appropriate
16:46:15 <notmyname> right
16:46:32 <ttx> sounds good
16:46:36 <notmyname> but yesterday, since we're at the start of our hackathon/midcycle, we got the branch created so it wouldn't be a blocker
16:46:49 <ttx> what type of work will land on the crypto branch exactly ?
16:46:52 <notmyname> that being said, do you know of exisitng feature/crypto branches in other projects?
16:46:57 <ttx> no
16:47:12 <notmyname> this is for our on-disk encryption. specifically, http://specs.openstack.org/openstack/swift-specs/specs/in_progress/at_rest_encryption.html
16:47:20 <ttx> ok, noted
16:47:28 <notmyname> thanks
16:47:39 <ttx> #info crypto feature branch is to support Swift on-disk encryption
16:47:54 <notmyname> to confirm, I see that we've got about 2 months left until the RC for kilo. right?
16:48:03 <notmyname> early/mid april
16:48:57 <ttx> yes
16:49:10 <notmyname> ok, thanks
16:49:26 <notmyname> that's all I've got for this week
16:49:30 <ttx> Ideally you would have the finak Kilo swift RC sometimes between April 5 and April 20
16:49:45 <notmyname> ack
16:50:03 <ttx> ok, only thing I had was the suggestion to skip 1:1s next week
16:50:16 <notmyname> ok
16:50:48 <ttx> notmyname: have a good hack day!
16:50:52 <notmyname> thanks!
17:02:14 <ttx> morganfainberg: around?
17:02:24 <morganfainberg> o/
17:02:27 <ttx> #topic Keystone
17:02:39 <ttx> #link https://launchpad.net/keystone/+milestone/kilo-3
17:02:57 <ttx> domain-config-ext is marked unknown, shall I set to "not started" ?
17:03:24 <morganfainberg> i haven't swept through k3 targets
17:03:28 <morganfainberg> you can or i can today
17:03:37 <ttx> done
17:03:54 <ttx> Looking at k3 deadlines
17:04:03 <ttx> You're past spec proposal deadline
17:04:16 <ttx> and you'll have the common FF on March 19
17:04:30 <ttx> planning to enforce the feature proposal freeze on March 5 as well ?
17:04:56 <ttx> (i.e. all feature code up for review)
17:05:42 <morganfainberg> yep.
17:06:03 <ttx> alright. We'll skip 1:1 next week since that will be the soft belly of the milestone
17:06:14 <morganfainberg> so i'll need to change this time.
17:06:14 <ttx> Nothing else from me
17:06:16 <morganfainberg> with you
17:06:28 <morganfainberg> i just got hit with a meeting w/ VP @ hp weekly at this time slot
17:06:37 <ttx> sounds pretty awesome
17:06:46 <morganfainberg> yeah. my days have become...
17:06:49 <morganfainberg> meetings
17:06:58 <ttx> would 10 mins earlier work for you ?
17:07:01 <morganfainberg> yeah
17:07:07 <ttx> we could switch with notmyname
17:07:09 <ttx> maybe
17:07:13 <morganfainberg> i'll have a hard stop at 9am pacific
17:07:24 <morganfainberg> i could move as early as 8:30 my time
17:07:29 <morganfainberg> so 30mins earlier
17:07:29 <ttx> sure, most of our 1:1s only last for 4 min anyway
17:07:43 <ttx> I'm in the middle of a call at that time unfortunately
17:07:58 <ttx> :50 is as early I can be sure not to be in the call anymore and giving you full attention
17:08:00 <morganfainberg> let me know when, we have till week after next
17:08:05 <ttx> sure
17:08:15 <ttx> #action ttx to figure out new time for Morgan 1:1
17:08:19 <morganfainberg> thanks
17:08:39 <morganfainberg> we could move it much later in the day if needed [post Keystone meeting]
17:08:51 <ttx> morganfainberg: have a good err... VP meeting
17:08:53 <morganfainberg> keystone meeting 1 h after this one.
17:09:28 <ttx> I'd rather avoid that if possible, but yes that is the backup option
17:09:46 <ttx> between teh keystone meeting and  the TC meeting
17:09:56 <ttx> devananda: around?
17:09:57 <morganfainberg> yeah if needed.
17:10:03 <morganfainberg> earlier is better imo
17:10:37 <ttx> devananda: ignore me, just read your email. Get well soon
17:12:01 <ttx> SlickNik: around?
17:13:09 <notmyname> morganfainberg: ttx: I'd be happy to swap with a 10 minute later time slot
17:13:27 <ttx> notmyname: awesome, I think we have a winner
17:13:37 <ttx> consider yourselves switched
17:14:55 <notmyname> ttx: starting the week after next
17:16:06 <ttx> yes
17:16:47 <notmyname> ack. calendar updated
17:18:09 <ttx> updated https://wiki.openstack.org/wiki/Release_Cycle_Management/1:1_Syncs
17:18:12 <ttx> morganfainberg: ^
17:26:51 <SlickNik> ttx: here now
17:29:35 <ttx> SlickNik: hey
17:29:39 <ttx> #topic Trove
17:29:52 <ttx> #link https://launchpad.net/trove/+milestone/kilo-3
17:30:03 <ttx> Page looks good
17:30:42 <ttx> Re: k3 deadlines, I suspect you follow the common Feature Freeze on Mar 19 and the common Feature Proposal Freeze two weeks before (Mar 5) ?
17:30:53 <SlickNik> Yes — that's the plan for Trove.
17:32:16 <ttx> Alright then
17:32:24 <ttx> We'll skip 1:1s next week
17:33:02 <ttx> anythign else on your side ?
17:33:03 <SlickNik> Just working on making progress towards those BPs for kilo-3.
17:33:03 <ttx> sounds good!
17:33:05 <ttx> have a good day then
17:33:18 <ttx> That concludes our scheduled broadcast
17:33:20 <SlickNik> You too. See you in a little bit.
17:33:22 <ttx> #endmeeting